Mailinglist Archive: opensuse-gnome (10 mails)

< Previous Next >
[opensuse-gnome] Unable to install several patches after upgrading to Gnome 3.6
  • From: Robert Munteanu <robert.munteanu@xxxxxxxxx>
  • Date: Tue, 6 Nov 2012 14:38:39 +0200
  • Message-id: <CAC8ULPbkVt3Z7=rmQf6TYfpWBr+fZy2gQsZhdb+C2c0mQ-MkHg@mail.gmail.com>
Hi,

I've upgraded to Gnome 3.6 about a month ago and I noticed that I have
some patches which can't be installed due to conflicts:

zypper> lu -t patch
The following software management updates will be installed first:

Repository | Name | Version | Category |
Status | Summary
---------------------+-------------------+---------+-------------+--------+---------------------------------------------------------
openSUSE-12.2-Update | openSUSE-2012-658 | 1 | recommended |
needed | PackageKit: update zypp backend to fix error when fetc->

The following updates are also available:

Repository | Name | Version | Category |
Status | Summary
---------------------+-------------------+---------+-------------+--------+---------------------------------------
openSUSE-12.2-Update | openSUSE-2012-587 | 1 | recommended |
needed | glib2: update to 2.32.4 stable version
openSUSE-12.2-Update | openSUSE-2012-621 | 1 | recommended |
needed | libwacom: Update to version 0.6

zypper> in -t patch openSUSE-2012-658
Resolving package dependencies...

Problem: patch:openSUSE-2012-658-1.noarch conflicts with
libpackagekit-qt2-2.x86_64 < 0.7.4-2.12.1 provided by
libpackagekit-qt2-2-0.7.4-2.11.x86_64
Solution 1: Following actions will be done:
replacement of libpackagekit-qt2-2-0.7.4-2.11.x86_64 with
libpackagekit-qt2-2-0.7.4-2.12.1.x86_64
replacement of libpackagekit-glib2-14-0.7.4-2.11.x86_64 with
libpackagekit-glib2-14-0.7.4-2.12.1.x86_64
replacement of PackageKit-gtk3-module-0.7.4-2.11.x86_64 with
PackageKit-gtk3-module-0.7.4-2.12.1.x86_64
replacement of PackageKit-gstreamer-plugin-0.7.4-2.11.x86_64 with
PackageKit-gstreamer-plugin-0.7.4-2.12.1.x86_64
replacement of PackageKit-browser-plugin-0.7.4-2.11.x86_64 with
PackageKit-browser-plugin-0.7.4-2.12.1.x86_64
replacement of PackageKit-backend-zypp-0.7.4-2.11.x86_64 with
PackageKit-backend-zypp-0.7.4-2.12.1.x86_64
replacement of PackageKit-0.7.4-2.11.x86_64 with
PackageKit-0.7.4-2.12.1.x86_64
Solution 2: do not install patch:openSUSE-2012-658-1.noarch

I noticed that libpackagekit-qt2-2-0.7.4-2.11.x86_64 is provided by
obs://build.opensuse.org/GNOME and the other two patches have similar
problems.

What is the recommended way to apply these patches?

Thanks,

Robert

--
Sent from my (old) computer
--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-gnome+owner@xxxxxxxxxxxx

< Previous Next >