Mailinglist Archive: opensuse-gnome (98 mails)

< Previous Next >
[opensuse-gnome] Finding latest upstream versions
  • From: Vincent Untz <vuntz@xxxxxxxxxx>
  • Date: Tue, 9 Sep 2008 06:02:39 +0200
  • Message-id: <20080909040239.GS14804@xxxxxxxxx>
Hi,

I've added a script that is able to check out the latest upstream
version for most modules maintained by the GNOME team (even if it's not
living on ftp.gnome.org).

Now, the missing part is that we need data on where to grab a latest
upstream version. This is easy to do, except that it takes quite some
time since we have many modules.

Everybody can help here. First, check out what we currently have:

git clone http://www.vuntz.net/git/osc-plugins.git/
cd osc-plugings/obs-dissector

Then open upstream-tarballs.txt and read the comments at the top -- they
should be pretty clear (especially once you started looking at the list
that's already there). If not, tell me what's unclear.

Now, go to http://tmp.vuntz.net/opensuse-packages/obs.py. If there's a
yellow cell, then it means that we don't have data for this. Start
looking where the tarballs for this module live and add the relevant
data to upstream-tarballs.txt and gnome-opensuse-match.txt.

If you find a location for which we don't have a method (like google
code or launchpad), you should still add the module to the files, but
the entry in upstream-tarballs.txt should be commented out.

Then, either tell me where your git branch lives, or send me a patch!

(you might want to send a mail or tell on IRC that you're working on
this, to avoid duplicated work)

Thanks,

Vincent

--
Les gens heureux ne sont pas press├ęs.
--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages