Mailinglist Archive: opensuse-gnome (174 mails)

< Previous Next >
[opensuse-gnome] Gnome build system problems
  • From: Will Stephenson <wstephenson@xxxxxxx>
  • Date: Sat, 1 Mar 2008 23:34:06 +0100
  • Message-id: <200803012334.07651.wstephenson@xxxxxxx>
Hi all

I'm trying to build NetworkManager from SVN on factory. I can't get
autogen.sh to complete. I've installed gnome-common, automake, autoconf,
libtool, intltool, pkg-config, gettext-runtime and gettext-tools, and still
get the following error:

(http://www.pastebin.ca/924656)

wstephenson@gorse:/home/wstephenson/code/kde/networkmgr/NetworkManager-svn/NetworkManager-0.7.0>
./autogen.sh
/usr/bin/gnome-autogen.sh
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.61
checking for automake >= 1.7...
testing automake-1.10... found 1.10.1
checking for libtool >= 1.4.3...
testing libtoolize... found 1.5.26
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... found 2.15.5
checking for intltool >= 0.25...
testing intltoolize... found 0.35.5
checking for pkg-config >= 0.14.0...
testing pkg-config... found 0.23
Checking for required M4 macros...
Checking for forbidden M4 macros...
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.

Processing ./configure.in
Running libtoolize...
You should add the contents of `/usr/share/aclocal/libtool.m4' to
`aclocal.m4'.
Putting files in AC_CONFIG_AUX_DIR, `..'.
Running glib-gettextize... Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po/Makefile.in.in

Please add the files
codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
progtest.m4
from the /usr/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

Running intltoolize...
intltoolize: 'po/Makefile.in.in' is out of date: use '--force' to overwrite

I understand that most of the requests and suggestions in the output above are
normally ignored - I get similar output when building on 10.3 successfully.

I get the same result if autogen.sh is run with the args to configure.
captain_magnus tried the same, with the gnome-devel pattern installed, and
got the same result.

Who knows the gnome buildsystem well enough to say what's missing here?

TIA

Will
--
Will Stephenson
Desktop Engineer
KDE Team
--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups