Mailinglist Archive: opensuse-gnome (124 mails)

< Previous Next >
Re: [opensuse-gnome] libgnomecanvas 2.14
  • From: Federico Mena Quintero <federico@xxxxxxxxxx>
  • Date: Tue, 18 Sep 2007 12:27:33 -0500
  • Message-id: <1190136453.22387.103.camel@xxxxxxxxxxxxxxxxxxxxxx>
On Mon, 2007-09-17 at 20:03 -0400, Chris Arnold wrote:
> I use sled sp1 and gnome. I am trying to upgrade my install of
> libgnomecanvas 2.12 to 2.14 using the opensuse gnome:stable repo.
> Everytime i install 2.14 version, it messes-up gmd so i can not login.
> Has anyone gone to 2.14 from 2.12 successfully? If so, please share
> exactly what you had to do.

One other thing I remembered...

You should double-check that the installation path of the 2.14 package
is the same as the 2.12 one.  SLED10 SP1 uses /opt/gnome; make sure that
the new package doesn't use /usr, or GDM will not be able to load the
libgnomecanvas library.

Also, from your mail to opensuse-factory it seems that you only need
libgnomecanvas-2.14 to install gtkpod.  I can't think of a reason why
gtkpod would require a newer libgnomecanvas, as the API hasn't changed
in ages.  Can you perhaps recompile the gtkpod SRPM while removing the
dependency on libgnomecanvas-2.14?

  Federico

-- 
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
References