Mailinglist Archive: opensuse-fr (14 mails)

< Previous Next >
[opensuse-fr] Pas de wifi ni resolution DNS
  • From: Patrick Serru <patrik@xxxxxxxxx>
  • Date: Tue, 3 Oct 2017 09:29:37 -0500
  • Message-id: <201710030929.37404@----Apocryphe---->
Bonjour tous,

C’est étrange, mais sur les 5 installations de Leap 42.3 sur un labtop
Compaq Presario C700, les deux dernières m’ont fait l’honneur de me demander
de configurer le réseau, et pas les 3 premières. Quelqu’un peut-il me dire,
s’il lui plaît, ce qui fait que l’installation demande parfois cette
configuration, tout de suite après le choix de la langue et de la disposition
du clavier ? Le choix d’une installation minimale, peut-être.

Après cette installation minimale pour un fonctionnement en mode texte,
mise à jour en ligne et avoir banni les paquetages yast2-firewall et network
manager, le système boot correctement, avec les interfaces Wifi (192.168.0.0)
et Ethernet (192.168.1.0) fonctionnelles dans la configuration souhaitée.
Mais quand j’essaye d’installer d’autres paquetages, cela casse / déconfigure
quelque chose qui fait que le Wifi ne semble plus fonctionner (il n’apparaît
plus dans ifconfig"), plus d’Internet ni de résiltion DNS.

Après l’ajout au système minimum de XOrg-X11 et tigervnc et reboot, le
sytème fonctionne toujours comme espéré. Je suis surpris, parceque dans
l’exemple proposé par Frédéric dans un post récent :
"avahi dhcp-server ntp samba-client samba-server sshd", je ne vois pas de
référence à la résolution dns (tcp & udp, port 53, sauf erreur)… Quelqu’un
sait quelque chose à ce sujet ?

Voici un chéma de linstallation :
____ eth0
| |<--------
|desk| |
|top | eth1 |
|____|<--. | 192.168.0.0
| | ______
eth1 | | _____ _/ \_
198.168.1.0 | --->| | ( )
| |modem|---->( INTERNET )
eth0 | |câble| (_ _)
____ | |_____| \______/
| |<--’ eth0 ^
|lab | |
| top| wlan0 . 192.168.0.0
|____|<--.... ....

Quelqu’un pourrait-il m’aider à configurer le parfeu du labtop, grâce au
fichier /etc/sysconfig/ ? Voici le contenu de ce fichier pour ma dernière
tentative:
FW_DEV_EXT="wlan0"
FW_DEV_INT="eth0"
FW_DEV_DMZ=""
FW_ROUTE="no"
FW_MASQUERADE="no"
FW_MASQ_DEV=""
FW_MASQ_NETS=""
FW_NOMASQ_NETS=""
FW_PROTECT_FROM_INT=""
FW_SERVICES_EXT_TCP="http https 587 imap"
FW_SERVICES_EXT_UDP="53"
Tous les autres paramètres contiennent leur valeur par défaut (soit vides,
soit des chaînes vides).

Mon objectif est de permettre tout le trafique sur le réseau 192.168.1.0
(eth0) et limiter celui de l’extérieur (wlan0) à http, https, 587 et imap.
Mais le labtop doit bien-sûr pouvoir être en mesure de résoudre les noms de
domaines (DNS).

Cordialement,

Patrick Serru
--
To unsubscribe, e-mail: opensuse-fr+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-fr+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups