Mailinglist Archive: opensuse-features (411 mails)

< Previous Next >
[openFATE 305623] Remove gnomesu dependancies from YaST
Feature changed by: Dinar Valeev (k0da)
Feature #305623, revision 22
Title: Remove gnomesu dependancies from YaST

openSUSE-11.2: Duplicate of #305640
+ Master status: Rejected by JP Rosevear <jpr@xxxxxxxxxx>
+ reject date: 2009-08-21 08:44:09
+ reject reason: Past feature freeze
Priority
Requester: Mandatory
Projectmanager: Mandatory

Info Provider: (Novell)
Info Provider: (Novell)
Requested by: Federico Lucifredi (flucifredi)
Product Manager: (Novell)
Project Manager: (Novell)
Engineering Manager: (Novell)
Developer: (Novell)
Partner organization: openSUSE.org

Description:
The Gnome team informs me gnomesu is obsoleted. We need to stop
depending on gnomesu on YaST, ideally moving towards PolicyKit as much
as possible but at a minimum matching the current mainline Gnome
behavior.

Discussion:
#5: Jiri Srain (jsrain) (2009-06-02 11:43:54)
The only dependency I found is the yast2-control-center-gnome package;
Jared, can you handle it?

#6: Jared Allen (jpallen) (2009-07-01 17:09:54) (reply to #5)
Yes, we'll need to look into an alternative. I'm not sure that
PolicyKit itself is enough to replace the functionality of gnomesu.
I'll ask Gabriel to look into this.

#7: Gabriel Burt (gabrielburt) (2009-07-06 22:11:34) (reply to #6)
$ sudo zypper remove libgnomesu The following packages are going to be
REMOVED:   deskbar-applet gedit gedit-lang gnome-applets gnome-applets-
lang gnome-python-desktop libgnomeprintui libgnomeprintui-lang
libgnomesu libgnomesu0 libgnomesu-lang planner planner-lang tomboy
tomboy-lang yast2-control-center-gnome
So those are the packages on a default GNOME install that depend on
libgnomesu.
To replace this with something powered by PolicyKit, it looks like gksu
is the best option (though Rodrigo wsa working on AdminKit, but it
never got traction or a lot of work, from what I can tell).  Vincent
has a related FATE feature opened, FATE #305640 - but it's more
general, deals with getting rid of gnomesu entirely.  Should we keep
these boht open/separate?
The actual usage of gnomesu is coming from a SUSE patch to libgnome-
desktop.

#8: Stephan Kulow (coolo) (2009-09-14 14:48:10)
too late for 11.2



--
openSUSE Feature:
https://features.opensuse.org/305623

< Previous Next >
This Thread
  • No further messages