Mailinglist Archive: opensuse-features (542 mails)

< Previous Next >
[openFATE 310780] Provide python 3 bindings when supported
  • From: fate_noreply@xxxxxxx
  • Date: Mon, 20 Dec 2010 13:55:26 +0100 (CET)
  • Message-id: <feature-310780-4@xxxxxxxxxxxxxx>
Feature changed by: Thomas Schmidt (digitaltomm)
Feature #310780, revision 4
Title: Provide python 3 bindings when supported

- openSUSE-11.4: Unconfirmed
+ openSUSE Distribution: New
Priority
- Requester: Important
+ Requester: Desirable

Requested by: Todd R (theblackcat)
Partner organization: openSUSE.org

Description:
The new version of python, python 3, has been out for several years
now.  A lot of python bindings now support python 3.  However, although
openSUSE has provided python 3 for a while, it provides few, if any,
python 3 versions of packages.
My suggestion is that python 2 be kept the default, but for python
packages and bindings that support it, python 3 versions should be made
available as well.  I think the python in the name would be replaced by
python3, so in additiona to python-numpy there would be python3-numpy,
for example.


--
openSUSE Feature:
https://features.opensuse.org/310780

< Previous Next >
This Thread
  • No further messages