Mailinglist Archive: opensuse-features (542 mails)

< Previous Next >
[openFATE 306188] Request for RAID metadata version specification option in Partitioner's install interface
  • From: fate_noreply@xxxxxxx
  • Date: Sat, 18 Dec 2010 20:56:41 +0100 (CET)
  • Message-id: <feature-306188-14@xxxxxxxxxxxxxx>
Feature changed by: Per Jessen (pjessen)
Feature #306188, revision 14
Title: Request for RAID metadata version specification option in
Partitioner's install interface

openSUSE-11.2: Rejected by Andreas Jaeger (a_jaeger)
reject date: 2009-08-12 10:15:21
reject reason: No answer in time.
Priority
Requester: Desirable

openSUSE-11.4: Unconfirmed
Priority
Requester: Desirable

Requested by: Unknown Nil (unknown)
Product Manager: (Novell)
Project Manager: (Novell)
Developer: (Novell)
Partner organization: openSUSE.org

Description:
Allow setting of software raid superblock version in YaST.

Relations:
- use new RAID SBs (novell/bugzilla/id: 282807)
https://bugzilla.novell.com/show_bug.cgi?id=282807
- lilo reports inconsistent raid version when trying to install on
raid1 (novell/bugzilla/id: 357897)
https://bugzilla.novell.com/show_bug.cgi?id=357897
- request for RAID metadata version specification option in
Partitioner's install interface (novell/bugzilla/id: 483973)
https://bugzilla.novell.com/show_bug.cgi?id=483973

Discussion:
#1: Andreas Jaeger (a_jaeger) (2009-06-09 15:00:44)
Why is it beneficial to change the version at all? Or should the
default get changed?

#2: Andreas Jaeger (a_jaeger) (2009-08-12 10:16:32) (reply to #1)
Or why shouldn't we use a later metadata version number by default
instead?

#3: Arvin Schnell (aschnell) (2009-08-14 12:06:05) (reply to #2)
AFAIR not all bootloaders can handle the latest raid superblock
versions.

#4: Per Jessen (pjessen) (2009-11-06 23:08:11) (reply to #2)
The mdadm utility defaults to 0.90, and I think it would make sense to
follow that rather than use a later version for no particularly
beneficial reason - in particular when an explicity upgrade to >0.90
regresses other functionality. Bug 357897.

#5: Jan Engelhardt (jengelh) (2009-11-07 01:43:42) (reply to #4)
That would just mean that LILO has not been updated in *years*. Super1
support was added to mdadm over 4 years ago. Not even CentOS 5.x is
reaches that age.
The main benficial reason here is to span MDs over many disks, and set
names/hosts/uuids so that arrays do not accidentally get assembled in
another system.

#6: Per Jessen (pjessen) (2009-11-07 11:00:03) (reply to #5)
The most recent LILO version is 22.8 from February 2007.

+ #9: Per Jessen (pjessen) (2010-12-18 20:56:21) (reply to #6)
+ Update: the most recent lilo is 23.1 from 4 November 2010:
+ http://lilo.alioth.debian.org/ftp/upstream/sources/
+ I have not yet looked at it in detail, but it looks like support for
+ raid metadata got upgraded to 1.x.

#8: Jan Engelhardt (jengelh) (2009-12-05 15:03:37) (reply to #4)
mdadm now defaults to 1.1.

#7: Per Jessen (pjessen) (2009-11-07 11:23:13)
It's a case of "works with more than 28 devices" versus "works with
lilo":
1) RAID array created with metadata version 0.90 -> it works with lilo,
but will "only" support 28 devices.
2) RAID array created with metadata version >=1.0 -> it doesn't work
with lilo, but supports more than 28 devices.
Both situations are corner cases, and both are easily worked around by
creating the array outside of YaST.



--
openSUSE Feature:
https://features.opensuse.org/306188

< Previous Next >
This Thread
References