Mailinglist Archive: opensuse-features (243 mails)

< Previous Next >
[openFATE 310975] Video Driver Pre-Install Script for ATI Installation
  • From: fate_noreply@xxxxxxx
  • Date: Thu, 16 Dec 2010 09:38:08 +0100 (CET)
  • Message-id: <feature-310975-3@xxxxxxxxxxxxxx>
Feature changed by: Lee Matheson (oldcpu)
Feature #310975, revision 3
Title: Video Driver Pre-Install Script for ATI Installation

openSUSE-11.4: Unconfirmed
Priority
Requester: Important

Requested by: Helen South (helen-au)
Partner organization: openSUSE.org

Description:
Installing ATI Catalyst is problematic, possibly due to pre-existing
FGLRX drivers which need to be removed before installation of the ATI
drivers. It's remarkably easy for a non technical user to come up with
a botched installation. Doubly so for the 64 bit version which has 32
bit dependencies.
openSUSE needs some sort of easy-install process, which will find and
remove any conflicting FGLRX drivers, and if possible download and
install the right ATI driver for the current kernel.

Business case (Partner benefit):
openSUSE.org: Reducing the confusion created by having to search
through a range of instructions on forums and wikis, many of which are
lengthy and with convoluted command line solutions that have variable
succes.

+ Discussion:
+ #1: Lee Matheson (oldcpu) (2010-12-16 09:36:24)
+ I note user "please_try_again" in openSUSE forums, is working on a
+ script ... here is a thread documenting some of his efforts:
http://forums.opensuse.org/english/development/programming-scripting/449058-upgrading-ati-driver-atiupgrade.html
+ ... Assuming this script like this reaches a level of desired maturity,
+ is it the sort of script that could be included with an openSUSE
+ distribution version ?



--
openSUSE Feature:
https://features.opensuse.org/310975

< Previous Next >
List Navigation