Mailinglist Archive: opensuse-features (518 mails)

< Previous Next >
[openFATE 310263] By default use a functioning version of Java
  • From: fate_noreply@xxxxxxx
  • Date: Sun, 8 Aug 2010 16:03:44 +0200 (CEST)
  • Message-id: <feature-310263-2@xxxxxxxxxxxxxx>
Feature changed by: Vadim Krevs (vkrevs)
Feature #310263, revision 2
Title: By default use a functioning version of Java

openSUSE-11.4: Unconfirmed
Priority
Requester: Important

Requested by: Andrew Joakimsen (joak0)

Description:
The "OpenJDK" version of Java is installed by default in openSUSE. This
version of Java does not enjoy widespread compatibility. I have yet to
find a site that properly works with this Java implemenaton and have
promptly replaced it with a working Jave implemenation -- Sun.
 
The installation of the working Java plugin should be via the same
mechanism that is employed to install Flash plugin upon the first
update to the system (pullin-flash-player package).
 
Until the point in time it can be demonstrated that the OpenJDK
implementation can work with >= 95% of Java applets encountered in "the
real world" it should not be included by default in OpenSUSE. I think
it is a way better out-of-box experiance for users to have to install
Java (just like in Windows) vs. appear to have Java but "Java is broken
in openSUSE" I doubt many non-technical users can understand the
difference.

+ Discussion:
+ #1: Vadim Krevs (vkrevs) (2010-08-08 16:03:25)
+ IMHO, the version of Java installed by default should be the
+ latest  supported by the latest released Eclipse SDK.



--
openSUSE Feature:
https://features.opensuse.org/310263

< Previous Next >
This Thread