Mailinglist Archive: opensuse-features (299 mails)

< Previous Next >
[openFATE 308762] Remove Hal by default on opensuse 11.3
  • From: fate_noreply@xxxxxxx
  • Date: Fri, 28 May 2010 13:51:39 +0200 (CEST)
  • Message-id: <feature-308762-39@xxxxxxxxxxxxxx>
Feature changed by: Kay Sievers (kay_sievers)
Feature #308762, revision 39
Title: Remove Hal by default on opensuse 11.3

openSUSE-11.3: Rejected by (michl19)
reject date: 2010-02-10 18:32:11
reject reason: As upstream project remove hal more and more it will
evolutionary get removed from openSUSE as well.
Requester: Important

Requested by: Luis Medinas (lmedinas)

Hal is deprecated and now most applications now use udev and devicekit-
* (will be udisks). Now it's important to remove HAL because it will
speed boot process and of course because it's not moving upstream.
This pages show packages status from Fedora and Ubuntu.

#1: Andreas Jaeger (a_jaeger) (2010-01-18 09:43:33)
Let's first evaluate which packages need hal and change the openSUSE
packages. I'm aware of "hwinfo".

#18: Will Stephenson (wstephenson) (2010-02-18 11:17:22) (reply to #1)
KDE4 would need a backend for Solid that uses whatever replaces hal:
Devicekit-*, udev, afaik.

#19: Andreas Jaeger (a_jaeger) (2010-02-18 13:22:35) (reply to #18)
Will, could you talk with the Solid developers so that this gets fixed
in KDE, please?

#23: Markus K (kamikazow) (2010-03-01 13:37:40) (reply to #19)
openSUSE will use KDE SC 4.4 which uses HAL, so I'm doubtful it'll
happen before 12.0.

#24: Stephan Kulow (coolo) (2010-03-01 14:19:42) (reply to #23)
KDE's use of HAL is happening so late, that it won't break boot speed
improvement if there is some.

#2: Steffen Winterfeldt (snwint) (2010-01-18 12:02:40)
hwinfo works fine without hal. I think.
But libzypp relies on hal.

#13: Kay Sievers (kay_sievers) (2010-02-17 19:01:47) (reply to #2)
hwinfo has hal code in it, and "Requires:" it at the moment. It should
be dropped, if it works without it. Steffen, care to check?

#3: Luis Medinas (lmedinas) (2010-01-18 14:36:26)
According to the Yast team it still needs hal for automounting[1]. I
think this shouldn't be hard to replace.
Xorg git master doesn't depend of hal anymore i guess it should be an
easy task for the Xorg team to provide X without Hal. Gnome has already
removed Hal on 2.29 but i don't have any idea how KDE goes.
Firefox 3.6 still depends of gnome-vfs (which is deprecated) but i
asked Wolfgang to see if he can patch firefox to now depend of it. I
guess doesn't depend anymore on gnome-vfs.
[1] -

#4: Kay Sievers (kay_sievers) (2010-01-18 14:47:34) (reply to #3)
Yast uses HAL to _prevent_ automounting by the running desktop. If
needed, it should be replaced by a call to:
   devkit-disks --inhibit

#5: Luis Medinas (lmedinas) (2010-02-02 18:46:11) (reply to #4)
YaST bug report is

#6: Andreas Jaeger (a_jaeger) (2010-02-11 11:18:56) (reply to #5)
Add feature 308980 for the Yast/libzypp case

#7: Luis Medinas (lmedinas) (2010-02-11 23:01:49)
If Yast, firefox and Xorg removes HAL i think the GNOME livecd could be
shipped without HAL. This is at least my main goal for this feature and
it shouldn't be hard to accomplish it.

#8: Andreas Jaeger (a_jaeger) (2010-02-12 10:01:08) (reply to #7)
Firefox and Xorg changes have to come from upstream and get

#9: Luis Medinas (lmedinas) (2010-02-14 21:53:49) (reply to #8)
Xorg is done on git master (xorg-server 1.7.x i guess), Firefox 3.7 is
using GIO/gvfs instead of gnome-vfs but i guess it won't make into

#10: Wolfgang Rosenauer (wrosenauer) (2010-02-15 11:22:45) (reply to
I can confirm that Firefox 3.7 (or how it's numbered in the end) already
should support GIO instead of gnome-vfs. Likely it's not finished in
11.3 timeframe though. Backporting the feature to 3.6 should be
possible but it's a pain and I don't want to waste my time if it's not
really necessary.

#11: Luis Medinas (lmedinas) (2010-02-15 16:28:29) (reply to #10)
Wolfgang i did a research in ubuntu and looks like they won't add that
patch to firefox. So i guess they are running firefox with hal at
runtime (hal isn't started on boot but only when firefox is running).

#12: Kay Sievers (kay_sievers) (2010-02-17 18:58:57) (reply to #11)
On Ubuntu, the systemwide hald process is activated by D-Bus only when
it is accessed. This will only slow down applications which request HAL
information at the first start, but not the bootup process.

#14: Vincent Untz (vuntz) (2010-02-17 19:33:43)
I saw that Debian disabled the PolicyKit and ConsoleKit integration in
hal because GNOME doesn't use it anymore, and KDE never used it. Maybe
we want to do it too (to help remove the old PolicyKit :-))

#16: Kay Sievers (kay_sievers) (2010-02-17 20:42:22) (reply to #14)
Here is a version of HAL that disables PolicyKit, and locks-down all
access to the "at_console" user:
  home:kay_sievers:branches:Base:System / hal
I'm able to de-install all of the old PolicyKit now.

#15: Luis Medinas (lmedinas) (2010-02-17 20:04:08)
Can someone confirm if the xorg-server on o:F is still using HAL ? Xorg-
server got rid of HAL on git master but i'm not sure if it's for xorg-
server 1.7 or 1.8

#17: Kay Sievers (kay_sievers) (2010-02-17 20:42:51) (reply to #15)
That version of X is not in Factory right now, it still requires HAL.

#20: Luis Medinas (lmedinas) (2010-02-19 14:06:51) (reply to #17)
You're right xorg-server 1.7 still uses HAL. On 1.8 git master they
moved to this patch, no idea what's the Xorg team plans for 11.3.
[1] -

#21: Rastislav Krupansky (ra100) (2010-03-01 07:36:59)
Just a note regarding to speed boot process. I tried Ubuntu Lucid Lynx
Alpha3, which doesn´t use hal. I don´t know whether it caused by hal
removal, or plymouth also, but Alpha3 has significantly faster boot
than Milestone2. Result is more than 30 sec. I just tried livecd boot
without installation.

#22: Stephan Kulow (coolo) (2010-03-01 13:10:57) (reply to #21)
great unrelated fact :)
It would be news to me if Ubuntu uses plymouth - but feel welcome to
analyze the boot process of the live cds and track them either in bugs
or features.

#25: Luis Medinas (lmedinas) (2010-03-02 03:45:19) (reply to #22)
Yes ubuntu is using plymouth for the next release. Mandriva already
adopt it on 2010.0 afaik.

#26: Malvern Star (solaris444) (2010-03-31 21:07:21)
I'm inclined to leave it in until the move to openSuSE 12.0 as the
potential for breaking things is pretty significant.

#27: Kay Sievers (kay_sievers) (2010-05-03 11:47:06)
Just an update. On my personal box I have left:
$ rpm -e hal is needed by (installed) gimp-2.6.8-3.4.x86_64 is needed by (installed) gnome-vfs2-2.24.3-1.6.
hal is needed by (installed) hal-palm-0.12.5-1.5.x86_64
hal is needed by (installed) gnome-power-manager-2.30.0-1.10.x86_64
hal-palm which is pulled-in by evolution should be fixed bnc#580612.
gimp has a not commonly used input-device module which could move to
a subpackage.
gnome-vfs2 could be built without HALsupport. gvfs2 should no longer
be used anyway.
the gnome-power-manager git version already dropped all HAL support
and relies on X to provide the backlight interface. In our current
version, we could just drop the Requires: hal in the spec file without
any trouble, it is only needed for some badly supported graphics
All would still work for these cards when HAL is installed, but it would
no longer unconditionally pull it in.
Nothing else left. If wanted, it should be possible to provide at
least a GNOME system without HAL.

#28: Andreas Jaeger (a_jaeger) (2010-05-03 12:50:11) (reply to #27)
That's great progress.
Kay, could you file separate bug reports for these, please?

#29: Kay Sievers (kay_sievers) (2010-05-03 14:00:32) (reply to #28)
it's a pleasure :)
#601943: gnome-power-manager: please drop: Requires: hal
#601947: gimp: please get rid of hal and move modules/libcontroller- to a sub-package
#601954: gnome-vfs2: please consider building without HAL support

#30: Kay Sievers (kay_sievers) (2010-05-24 14:53:27)
Update: with gnome-vfs2 from openSUSE:GNOME (waiting to get into
Factory), "rpm -e hal" succeeds on my box, and all seems fine. Thanks

+ #31: Kay Sievers (kay_sievers) (2010-05-28 13:51:30)
+ With today's Factory update, HAL is gone here, and it's not coming back
+ with "zypper dup". Seems all fine. :)

openSUSE Feature:

< Previous Next >
This Thread