Mailinglist Archive: opensuse-factory (262 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200917 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Fri, 18 Sep 2020 16:01:05 +0000
  • Message-id: <160044486553.2926.8875125371396217741@go-agent-stagingbot-7>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200917

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
blueberry (1.3.8 -> 1.3.9)
busybox-links
dar (2.6.10 -> 2.6.12)
libxkbcommon (1.0.0 -> 1.0.1)
perl-Image-ExifTool (12.04 -> 12.06)
polkit-default-privs (1550+20200715.6ddc764 -> 1550+20200909.647e56f)
publicsuffix (20200810 -> 20200909)
snapper
systemd (245.7 -> 246.4)
vim (8.2.1412 -> 8.2.1551)
virt-manager (2.2.1 -> 3.0.0)
xtables-addons (3.9_k5.8.7_1 -> 3.11_k5.8.7_1)
z3 (4.8.8 -> 4.8.9)

=== Details ===

==== blueberry ====
Version update (1.3.8 -> 1.3.9)
Subpackages: blueberry-lang

- Update to 1.3.9
* l10n: Update translations
- Fixes for %_libexecdir changing to /usr/libexec (boo#1174075)
- Use %{_udevrulesdir} for udev rules files

==== busybox-links ====
Subpackages: busybox-coreutils busybox-findutils busybox-gawk busybox-grep
busybox-gzip busybox-patch busybox-psmisc busybox-sed busybox-sendmail
busybox-tar busybox-xz

- busybox-vi: also conflict with gvim, one more vi variant.

==== dar ====
Version update (2.6.10 -> 2.6.12)
Subpackages: dar-doc dar-lang libdar64-6000

- update to 2.6.12:
- fixed regression met in 2.6.11 when generating encrypted
archives
- fixing bug in dar_manager libdar part, met when the two oldest
entries for a file are recorded as unchanged (differential
backup)
- fixed typo in dar_manager man page
- updated lax mode to ignore encryption flag found in header
and trailer
- fixed two opposite bugs in strong encryption code that
annihilated each other, by chance
- fixing bug met when merging an archive an re-compressing
the data with another algorithm that gives a less good result,
this condition lead the merging operation to fail
reporting a CRC mismatch
- improving archive header code to cope with unknown flags

==== libxkbcommon ====
Version update (1.0.0 -> 1.0.1)
Subpackages: libxkbcommon-x11-0 libxkbcommon0

- Update to release 1.0.1
* Make the table output of `xkbcli how-to-type` aligned.

==== perl-Image-ExifTool ====
Version update (12.04 -> 12.06)
Subpackages: exiftool perl-File-RandomAccess

- update to 12.06
- Added read support for Lyrics3 metadata (and fixed problem
where APE metadata may be ignored if Lyrics3 exists)
- Added a new Panasonic VideoBurstMode value
- Added a new Olympus MultipleExposureMode value
- Added a new Nikon LensID
- Added back conversions for XMP-dwc EventTime that were removed
in 12.04 with a patch to allow time-only values
- Decode GIF AspectRatio
- Decode Olympus FocusBracketStepSize
- Extract PNG iDOT chunk in Binary format with the
name AppleDataOffsets
- Process PNG images which do not start with mandatory
IHDR chunk
- Added a new Panasonic SelfTimer value
- Decode a few more DPX tags
- Extract AIFF APPL tag as ApplicationData
- Fixed bug writing QuickTime ItemList 'gnre' Genre values
- Fixed an incorrect value for Panasonic VideoBurstResolution
- Fixed problem when applying a time shift to some invalid
makernote date/time values

==== polkit-default-privs ====
Version update (1550+20200715.6ddc764 -> 1550+20200909.647e56f)

- Update to version 1550+20200909.647e56f:
* whitelist org.freedesktop.network1.forcerenew (bsc#1176215)

==== publicsuffix ====
Version update (20200810 -> 20200909)

- Update to version 20200909:
* Update gTLD list to 2020-09-09
* Add pages.dev
* Add gsj.bz
* Added gitapp.si
* Add small-web.org domain under Small Technology Foundation
* Update to ICANN and private SLDs on CentralNic registry platform
* The list of Jelastic public domains was extended
* Add forte.id
* Add Danger Science Group domains
* Switch cloud.metacentrum.cz from suffix to wildcard notation
* Added mcpe.me
* Add omniwe.site
* Add GOV.UK Pay test environment domain

==== snapper ====
Subpackages: libsnapper5 snapper-zypp-plugin

- package new snapperd.service file on Debian based distributions
(gh#openSUSE/snapper#557)

==== systemd ====
Version update (245.7 -> 246.4)
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1
libudev1-32bit systemd-32bit systemd-container systemd-doc systemd-lang
systemd-logger systemd-sysvinit udev

- Drop 0001-udev-temporarly-restore-the-creation-a-few-symlinks-.patch
linuxrc has already been fixed.
- Add 0001-udev-temporarly-restore-the-creation-a-few-symlinks-.patch
A temporary patch until the installer environment is updated to
create some of the symlinks that udevd used to create during its
startup but now udevd relies on the init system to do so.
- Rework how we prevent journald from both enabling auditd and
recording audit messages
journald.conf gained a new setting Audit= to control whether
journald enables audit during the boot process. So let's use it and
make sure it's disabled by default by shipping a drop-in that
overrides upstream default.
Also we used to patch systemd to prevent journald from reading the
audit messages. There's still no way for downstream to configure
that properly (we would need to mask systemd-journald-audit.socket
meaning shipping a symlink in /etc) but I think dropping
systemd-journald-audit.socket from the package is a nicer way to do
that as some users might choose to reenable this setting (by
reintroducing the socket unit in /etc).
- Enable audit support (bsc#1175883)
Enabling audit support in systemd will only make PID1 (and some of
its services) to generate some audit records for certain events. But
it doesn't affect journald, which has been prevented from recording
audit messages in the journal (SUSE specific behavior).
- Upgrade to v246.4 (commit f1344d5b7f31e98aedb01e606f41d74d3caaf446)
See https://github.com/openSUSE/systemd/blob/SUSE/v246/NEWS for
details.
Now that the number of SUSE specific patches has been shrinked and
is pretty low (12 at the time of this writing), they are no more
tracked by the git repo and are now handled at the package
level. Hence It is easier to maintain and identify them. This
effectively means that SUSE/v246 will contain upstream commits only.
Added 0001-restore-var-run-and-var-lock-bind-mount-if-they-aren.patch
Added 0002-rc-local-fix-ordering-startup-for-etc-init.d-boot.lo.patch
Added 0003-strip-the-domain-part-from-etc-hostname-when-setting.patch
Added 0004-tmpfiles-support-exclude-statements-based-on-file-ow.patch
Added 0005-udev-create-default-symlinks-for-primary-cd_dvd-driv.patch
Added 0006-sysv-generator-add-back-support-for-SysV-scripts-for.patch
Added 0007-networkd-make-network.service-an-alias-of-systemd-ne.patch
Added 0008-sysv-generator-translate-Required-Start-into-a-Wants.patch
Added 0009-pid1-handle-console-specificities-weirdness-for-s390.patch
Added 0010-journald-disable-audit-support-completely-from-the-j.patch
Added 0011-core-disable-session-keyring-per-system-sevice-entir.patch
Added 0012-resolved-create-etc-resolv.conf-symlink-at-runtime.patch

==== vim ====
Version update (8.2.1412 -> 8.2.1551)
Subpackages: gvim vim-data vim-data-common

- Fix postun scriptlet of vim-small: do not unconditionally
deregister vim-small as an alternative on uninstall (which
happens on package upgrades too) (boo#1176549).
- Add vi as slave to update-alternatives so that every package
has a matching "vi" symlink [bsc#1174564].
- Updated to version 8.2.1551, fixes the following problems
* Vim: not operator does not result in boolean.
* Previous tab page not usable from an Ex command.
* Popupwindow missing last couple of lines when cursor is in the first line.
* Closing a popup window with CTRL-C interrupts 'statusline' if it calls
a function.
* Vim9: boolean evaluation does not work as intended.
* Test 49 is old style.
* Vim9: invalid error for missing white space after function.
* Vim9: not operator applied too early.
* Test 49 is old style.
* Vim9: handling "+" and "-" before number differs from Vim script.
* The Mac GUI implementation is outdated and probably doesn't even work.
* Vim9: find global function when looking for script-local.
* Mac build fails.
* Vim9: cannot use call() without :call.
* Vim9: cannot call autoload function in :def function.
* Vim9: cannot use a range with marks in :def function.
* Vim9: :def function does not abort on nested function error.
* Vim9: no error for missing white after : in dict.
* Vim9: error for missing comma instead of extra white space.
* Vim9: no error for white space before comma in dict.
* Various inconsistencies in test files.
* Vim9: cannot mingle comments in multi-line lambda.
* Vim9: crash when lambda uses outer function argument.
* Vim9: always converting to string for ".." leads to mistakes.
* Function implementing :substitute has unexpected name.
* Vim9: 'statusline' is evaluated using Vim9 script syntax.
* Missing tests for interrupting script execution from debugger.
* Tiny and small builds have no test coverage.
* Debugger code insufficiently tested.
* Running tests in tiny version gives error for summarize.vim.
* Outdated references to the Mac Carbon GUI.
* Vim9: crash when interrupting a nested :def function.
* Error messages are spread out and names can be confusing.
* Vim9: function expanded name is cleared when sourcing a script again.
* Vim9: line number in error message is not correct.
* Vim9: return type of keys() is list<any>.
* Test 77a for VMS depends on small.vim which does not exist.
* Some test makefiles delete files that are not generated.
* Vim9: no check that script-local items don't become global.
* Vim9: list type at script level only uses first item.
* Vim9: dead code in to_name_end().
* Vim9: failure to compile lambda not tested.
* Vim9: failure invoking lambda with wrong arguments.
* Vim9: crash when using typecast before constant.
* MS-Windows: test files are not deleted.
* Vim9: the output of :disassemble cannot be interrupted.
* .gawk files not recognized.
* Vim9: declaring ascript variable at the script level does not infer
the type.
* Error messages are spread out.
* Vim9: string indexes are counted in bytes.
* Vim9: string slice not supported yet.
* Vim9: list slice not supported yet.
* Vim9: build warning for unused variable.
* Vim9: subscript not handled properly.
* Vim9: cannot index or slice a variable with type "any".
* Vim9: :echomsg doesn't like a dict argument.
* Vim9: invalid error for missing white space.
* Vim9: cannot assign string to string option.
* Errors in spell file not tested.
* :const only locks the variable, not the value.
* ":argdel" does not work like ":.argdel" as documented. (Alexey Demin)
* Items in a list given to :const can still be modified.
* /usr/lib/udef/rules.d not recognized as udevrules.
* Vim9: can't use v:true for option flags.
* Filetype test fails on MS-Windows.
* Vim9: error when using bufnr('%').
* Vim9: cannot use "true" for some popup options.
* Vim9: error for list index uses wrong line number.
* Vim9: skip expression in search() gives error.
* Vim9: line number reported with error may be wrong.
* Vim9: crash when using a nested lambda.
* Vim9: error for using special as number when returning "false" from a
popup filter.
* Flaky failure in assert_fails().
* Vim9: readdirex() expression doesn't accept bool.
* Vim9: readdir() expression doesn't accept bool.
* Travis: installing snd-dummy is not always useful.
* Text does not scroll when inserting above first line.
* Vim9: error when setting an option with setbufvar().
* Vim9: using /= with float and number doesn't work.
* Vim9: crash when compiling heredoc lines start with comment.
* Build failures.
* Not enough test coverage for the spell file handling.
* Missing change to calling eval_getline().
* "make clean" may delete too many files.
* Vim9: cannot use " #" in a mapping.
* CursorHold test is flaky. (Jakub K?dzio?ka)
* On slow systems tests can be flaky.
* Vim9: error when using "$" with col().
* Vim9: error when using address without a command.
* Vim9: concatenating to constant reverses order.
* Vim9: can use += with a :let command at script level.
* Vim9: error for an autocmd defined in a :def function in legacy Vim script.
* Vim9: white space checks are only done for a :def function.
* Not all file read and writecode is tested.
* Vim9: no error when using a number other than 0 or 1 as bool.
* Using malloc() directly.
* Not all debugger commands covered by tests.
* Vertical separator is cleared when dragging a popup window using a
multi-byte character for the border.
* Using "var" in a :def function may refer to a legacy Vim script variable.
* Putting a string in Visual block mode ignores multi-byte characters.
* Failure after trinary expression fails.
* Cannot interrupt shell used for filename expansion. (Dominique Pellé)
* Multibyte vertical separator is cleared when dragging a popup window
using a multi-byte character for the border.
* Vim9: can create s:var in legacy script but cannot unlet.
* Vim9: error for :exe has wrong line number.
* Cannot easily get the character under the cursor.
* Vim9: cannot assign to local option.
* Vim9: Ex command default range is not set.
* Vim9: CTRL-] used in :def function does not work.
* Reading past end of buffer when reading spellfile. (Yegappan Lakshmanan)
* Not enough test coverage for the spell file handling.
* Still not enough test coverage for the spell file handling.
* No longer get an error for string concatenation with float. (Tsuyoshi Cho)
* Messages from tests were not always displayed.
* Line in testdir Makefile got commented out. (Christian Brabandt)
* Vim9: cannot use a function name as a function reference at script level.
* Vim9: :endif not found after "if false".
* Vim9: :elseif may be compiled when not needed.
* Vim9: test fails on MS-Windows.
* Vim9: test still fails on MS-Windows.
* Compiler warning for conversion of size_t to long.
* Vim9: error when passing getreginfo() result to setreg().
* Vim9: type error for argument type is not at call position.
* It is not possible to specify cell widths of characters.
* Cannot get the class of a character; emoji widths are wrong in some
environments.
* Memory acccess error when using setcellwidths().
* Python: iteration over vim objects fails to keep reference.
* Using invalid script ID causes a crash.
* The user cannot try out emoji character widths.
* Vim9: cannot find function reference for s:Func.
* Vim9: test with invalid SID does not work in the GUI.
* Vim9: test with invalid SID is skipped in the GUI.
* Cannot translate messages in a Vim script.
* ch_logfile() is unclear about closing when forking.
* Build rule for Vim.app is unused.
* Various comment problems.
* Cannot move position of "%%" in message translations. (Emir Sar?)
* The "r" command fails for keys with modifiers if 'esckeys' is off and
modifyOtherKeys is used. (Lauri Tirkkonen)
* Vim9: bufname('%') gives an error.
* Vim9: error for argument type does not mention the number.
- disable-unreliable-tests.patch: refresh
- vim-changelog.sh: work with bash

==== virt-manager ====
Version update (2.2.1 -> 3.0.0)
Subpackages: virt-install virt-manager-common

- Update to virt-manager 3.0.0 (fate#326786)
virt-manager-3.0.0.tar.bz2
* virt-install ?cloud-init support (Athina Plaskasoviti, Cole
Robinson)
* The virt-convert tool has been removed. Please use virt-v2v
instead
* A handful of UI XML configuration options have been removed.
The XML editor can be used instead. For a larger discussion see
this thread: https://www.redhat.com/archives/virt-tools-list/
2019-June/msg00117.html
* The ?New VM? UI now has a ?Manual Install? option which creates
a VM without any required install media
* In the ?New VM? UI, the network/pxe install option has been
removed. If you need network boot, choose ?Manual Install? and
set the boot device after initial VM creation
* ?Clone VM? UI has been reworked and simplified
* ?Migrate VM? UI now has an XML editor for the destination VM
* Global and per-vm option to disable graphical console
autoconnect. This makes it easier to use virt-manager alongside
another client like virt-viewer
* virt-manager: set guest time after VM restore (Michael Weiser)
* virt-manager: option to delete storage when removing disk
device (Lily Nie)
* virt-manager: show warnings if snapshot operation is unsafe
(Michael Weiser)
* Unattended install improvements (Fabiano FidĂȘncio)
* cli: new ?xml XPATH=VAL option for making direct XML changes
* virt-install: new ?reinstall=DOMAIN option
* virt-install: new ?autoconsole text|graphical|none option
* virt-install: new ?os-variant detect=on,require=on suboptions
* cli: ?clock, ?keywrap, ?blkiotune, ?cputune additions (Athina
Plaskasoviti)
* cli: add ?features kvm.hint-dedicated.state= (Menno Lageman)
* cli:?iommu option (Menno Lageman)
* cli: Add ?graphics websocket= support (Petr Benes)
* cli: Add ?disk type=nvme source.* suboptions
* cli: Fill in all ?filesystem suboptions
* Translation string improvements (Pino Toscano)
* Convert from .pod to .rst for man pages
* Switch to pytest as our test runner
* Massively improved unittest and uitest code coverage
* Now using github issues as our bug tracker
- Drop patches contained in new tarball

3c6e8537-guest-fix-warning-message-when-machine-type-is-changed-for-secure-boot.patch
0c223ab2-guest-Dont-set-default-uefi-if-firmware-is-set.patch
414ffa5e-virt-install-Use-minutes-instead-of-seconds-on-get_time_string.patch
53245827-urlfetcher-Force-a-flush-after-writing-to-a-file.patch
3009888a-urlfetcher-Dont-override-fullurl-when-its-explicitly-set.patch
9465da41-urlfetcher-Deal-with-file-in-_LocalURLFetcher.patch
651e5b6d-devices-video-Simplify-model-hvm-check.patch
1547e16d-domcapabilities-Get-video-devices.patch
2e20b128-domcapabilities-Add-supports_video_bochs.patch
d9736db9-addhardware-Add-bochs-display-to-the-video-list.patch
8f4c53ea-video-Prefer-bochs-when-its-supported..patch
ae19d6d6-fix-resizing-of-spice-clients-with-guest-resizing-enabled.patch
51d84c54-connection-Avoid-repeated-default-pool-creation-attempts.patch
d934d6f2-domcaps-Fix-check-for-uncached-security-features.patch
29f9f5f2-virt-xml-fix-defined_xml_is_unchanged.patch

15a9502b-Fix-showing-the-firmware-type-in-case-of-firmware-auto-selection.patch
5573aeb4-createnet-Fix-XML-editor-error-when-dhcp-fields-are-empty.patch
e8bf16b9-details-fix-detection-of-firmware-auto-selection.patch
7e3fb3f2-graphics-Default-to-vga-instead-of-qxl-for-non-spice.patch
- Drop deprecated patches
virtman-fix-env-script-interpreter.patch
virtinst-osdict-get_supported.patch
virtconv-python2-to-python3-conversion.patch
virtinst-python2-to-python3-conversion.patch
virtman-python2-to-python3-conversion.patch
virttests-python2-to-python3-conversion.patch
0002-virtinst-python3-avoid-comparison-of-None-and-int.patch

==== xtables-addons ====
Version update (3.9_k5.8.7_1 -> 3.11_k5.8.7_1)

- Update to release 3.11
* Support for Linux 5.9

==== z3 ====
Version update (4.8.8 -> 4.8.9)

- update to 4.8.9:
significant improvements to regular expression solving expose user theory
plugin. It is a leaner user theory plugin that was once available.
It allows for registering callbacks that react to when bit-vector and Boolean
variables
receive fixed values.
- many
- the new arithmetic theory is turned on by default. It _does_ introduce
regressions on several scenarios, but has its own advantages. Users can
turn on the old solver by setting smt.arith.solver=2.
Depending on feedback, we may turn toggle this default setting again back to
smt.arith.solver=2.
- remove remove-timestamp.patch, 5a42a000e938a295feb1a7070dd74b192796db4e.patch
(upstream)


< Previous Next >
This Thread
  • No further messages