Mailinglist Archive: opensuse-factory (262 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200915 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Wed, 16 Sep 2020 20:01:06 +0000
  • Message-id: <160028646666.7709.13373438087458706166@go-agent-stagingbot-7>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200915

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
autoyast2 (4.3.43 -> 4.3.48)
libpinyin (2.3.0 -> 2.4.91)
libqt5-qttranslations (5.15.0 -> 5.15.1)
libqt5-qtvirtualkeyboard (5.15.0 -> 5.15.1)
mozc
multipath-tools
perl-Mojolicious (8.58 -> 8.59)
yast2 (4.3.24 -> 4.3.25)
yast2-country (4.3.8 -> 4.3.9)
yast2-installation (4.3.16 -> 4.3.17)
yast2-network (4.3.17 -> 4.3.19)
yast2-users (4.3.7 -> 4.3.8)

=== Details ===

==== autoyast2 ====
Version update (4.3.43 -> 4.3.48)
Subpackages: autoyast2-installation

- Fix the returned value form the AutoinstPartPlan's Read method
(boo#1176490).
- 4.3.48
- Formally mark that fixes made for SP2 no longer affect SP3
(no code changes bsc#1173793 and bsc#1172026). For the first one
code is not longer in place and for the second new xml parser
does not need workaround for empty strings.
- 4.3.47
- Fix installation using encrypted profile (bsc#1176336)
- improve usability by entering password just once
- use shared UI::PasswordDialog
- 4.3.46
- Using ":" in the autoyast(...) supplements (bsc#1146494).
- 4.3.45
- When 'NetworkManager' is selected in the profile as the network
backend to be used, the 'NetworkManager' package is added to the
list of packages to be installed in case of missing (bsc#1172817)
- 4.3.44

==== libpinyin ====
Version update (2.3.0 -> 2.4.91)
Subpackages: libpinyin-data libpinyin13 libzhuyin13

- Update version to 2.4.91
* improve full pinyin auto correction
* bug fixes
- Drop libpinyin-1.7.0-no-AX_CXX_COMPILE_STDCXX_11.patch, no longer
support Leap 42
- add libzhuyin%{sover} to libpinyin-devel

==== libqt5-qttranslations ====
Version update (5.15.0 -> 5.15.1)

- Update to 5.15.1:
* New bugfix release
* For more details please see:

http://code.qt.io/cgit/qt/qttranslations.git/plain/dist/changes-5.15.1/?h=5.15.1

==== libqt5-qtvirtualkeyboard ====
Version update (5.15.0 -> 5.15.1)
Subpackages: libQt5HunspellInputMethod5 libQt5VirtualKeyboard5
libqt5-qtvirtualkeyboard-hunspell

- Update to 5.15.1:
* New bugfix release
* For more details please see:

http://code.qt.io/cgit/qt/qtvirtualkeyboard.git/plain/dist/changes-5.15.1/?h=5.15.1

==== mozc ====
Subpackages: fcitx-mozc ibus-mozc ibus-mozc-candidate-window mozc-gui-tools

- Build scripts migration to Python 3
* Add: build-scripts-migration-to-python3.patch
* Add: fix-zip-code-conversion-output.patch
- Update post code dictionary
- Use system libprotobuf because Mozc's build script cannot handle
newer protobuf source code
* Fix build error under RISC V environment
* Add: mozc-2.23.2815.102-protobuf_generated_classes_no_inheritance.patch

==== multipath-tools ====
Subpackages: kpartx libmpath0

- Missing past changelog bug references:
* 0.7.3+10+suse.70ccb55b0439:
Patch series for NVMe discovery and failover (bsc#1038865,
bsc#1057820)
* 0.7.9+109+suse.203c1cf
* setup_map: wait for pending path checkers to finish
(bsc#1118224)

==== perl-Mojolicious ====
Version update (8.58 -> 8.59)

- updated to 8.59
see /usr/share/doc/packages/perl-Mojolicious/Changes
8.59 2020-09-05
- Added l function to ojo. (kiwiroy)
- Added MOJO_PROMISE_DEBUG environment variable to Mojo::Promise.

==== yast2 ====
Version update (4.3.24 -> 4.3.25)
Subpackages: yast2-logs

- Enhance GPG module with symmetric encryption
(related to bsc#1176336)
- add new shared password dialog
- 4.3.25

==== yast2-country ====
Version update (4.3.8 -> 4.3.9)
Subpackages: yast2-country-data

- Using ":" in the autoyast(...) supplements (bsc#1146494).
- 4.3.9

==== yast2-installation ====
Version update (4.3.16 -> 4.3.17)

- Using ":" in the autoyast(...) supplements (bsc#1146494).
- 4.3.17

==== yast2-network ====
Version update (4.3.17 -> 4.3.19)

- When proposing the virtualization network configuration, force a
read of the current configuration in case that it is not present
(bsc#1176313)
- 4.3.19
- Using ":" in the autoyast(...) supplements (bsc#1146494).
- 4.3.18

==== yast2-users ====
Version update (4.3.7 -> 4.3.8)

- Using ":" in the autoyast(...) supplements (bsc#1146494).
- 4.3.8


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages