Mailinglist Archive: opensuse-factory (201 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200905 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 06 Sep 2020 22:01:25 +0000
  • Message-id: <159942968571.20355.1745389472468820505@go-agent-stagingbot-1>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200905

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
Mesa (20.1.6 -> 20.1.7)
Mesa-drivers (20.1.6 -> 20.1.7)
audacity
brotli (1.0.7 -> 1.0.9)
gpg2 (2.2.21 -> 2.2.23)
ndctl
orca (3.36.5 -> 3.36.6)
perl-DBD-SQLite (1.64 -> 1.66)
phodav (2.4 -> 2.5)
pipewire (0.3.9 -> 0.3.10)
read-only-root-fs
rubygem-parser (2.7.1.2 -> 2.7.1.4)
vulkan-loader (1.2.148 -> 1.2.151)
xen
xiterm
yast2-installation (4.3.15 -> 4.3.16)

=== Details ===

==== Mesa ====
Version update (20.1.6 -> 20.1.7)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- update to 20.1.7
* seventh bugfix release for the 20.1 branch
- switched to llvm9 usage for Leap/SLE15 since llvm10 is not (yet)
in Leap/SLE15
- version 20.1.6 needed for jira#SLE/SLE-12880, jira#SLE/SLE-12882
- use again /etc/OpenCL/vendors for openSUSE Leap, i.e. use
/usr/etc/OpenCL/vendors only for Tumbleweed

==== Mesa-drivers ====
Version update (20.1.6 -> 20.1.7)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- update to 20.1.7
* seventh bugfix release for the 20.1 branch
- switched to llvm9 usage for Leap/SLE15 since llvm10 is not (yet)
in Leap/SLE15
- version 20.1.6 needed for jira#SLE/SLE-12880, jira#SLE/SLE-12882
- use again /etc/OpenCL/vendors for openSUSE Leap, i.e. use
/usr/etc/OpenCL/vendors only for Tumbleweed

==== audacity ====
Subpackages: audacity-lang

- Remove libavformat symlink and remove the plugins sub package.
The symlink is obsoleted by linking to ffmpeg rather than
dlopening it. The plugins were caused by the wrong suil version.
- Add _constraints for min 6GB physicalymemory for ppc64/ppc64le
- Link to ffmpeg rather than dlopening it.
- Create symlink for libavformat, audacity looks for the major
version only and this no longer exists in openSUSE after
ffmpeg-4.3.1. See boo#1175205

==== brotli ====
Version update (1.0.7 -> 1.0.9)
Subpackages: libbrotli-devel libbrotlicommon1 libbrotlicommon1-32bit
libbrotlidec1 libbrotlidec1-32bit libbrotlienc1

- Add 0001-Revert-Add-runtime-linker-path-to-pkg-config-files-7.patch
- Update to 1.0.9
* Fix integer overflow when input chunk is longer than
2GiB [boo#1175825]
* `brotli -v` now reports raw / compressed size
* decoder: minor speed / memory usage improvements
* encoder: fix rare access to uninitialized data in ring-buffer
- Drop brotli_Ensure-decompression-consumes-all-input.patch,
brotli_Verbose-CLI+Shared-Brotli.patch (merged)

==== gpg2 ====
Version update (2.2.21 -> 2.2.23)
Subpackages: dirmngr gpg2-lang

- GnuPG 2.2.23:
* gpg: fix AHEAD preference list overflow boo#1176034 / CVE-2020-25125
* gpg: fix possible segv in the key cleaning code
* gpgsm: fix a minor RFC2253 parser gub
* scdaemon: Fix a PIN verify failure on certain OpenPGP card
implementations
- GnuPG 2.2.22:
* gpg: Change the default key algorithm to rsa3072
* gpg: Add regular expression support for Trust Signatures on
all platforms
* gpg: Ignore --personal-digest-prefs for ECDSA keys
* gpgsm: Make rsaPSS a de-vs compliant scheme
* gpgsm: Show also the SHA256 fingerprint in key listings
* gpgsm: Do not require a default keyring for --gpgconf-list
* gpg-agent: Default to extended key format and record the
creation time of keys
Add new option --disable-extended-key-format
* gpg-agent: Support the WAYLAND_DISPLAY envvar
* gpg-agent: Allow using --gpgconf-list even if HOME does not
exist
* gpg-agent: Make the Pinentry work even if the envvar TERM is
set to the empty string
* scdaemon: Add a workaround for Gnuk tokens <= 2.15 which
wrongly incremented the error counter when using the
"verify" command of "gpg --edit-key" with only the signature
key being present
* dirmngr: Better handle systems with disabled IPv6
* gpgpslit: Install tool. It was not installed in the past to
avoid conflicts with the version installed by GnuPG 1.4
* gpgtar: Make --files-from and --null work as documented
- drop gnupg-gpgme-t-encrypt-sym.patch, upstream

==== ndctl ====

- Suppress ENXIO when processing all namespaces (jsc#SLE-13321, bsc#1175851,
ltc#187867).
+ ndctl-namespace-Suppress-ENXIO-when-processing-all-n.patch

==== orca ====
Version update (3.36.5 -> 3.36.6)
Subpackages: orca-lang

- Update to version 3.36.6:
+ General: Add some sanity checks to prevent crashing due to
GStreamer failure.

==== perl-DBD-SQLite ====
Version update (1.64 -> 1.66)

- updated to 1.66
see /usr/share/doc/packages/perl-DBD-SQLite/Changes
1.66 2020-08-30
- Switched to a production version
1.65_03 2020-07-27
- Upgraded SQLite to 3.32.3
1.65_02 2020-02-08
- Upgraded SQLite to 3.31.1
1.65_01 2020-01-18
- Upgraded SQLite to 3.30.1
- Added several SQL_ types as alias (pali++)
- Fixed two initialization issues (ppisar++)
- Allowed create_function to return an array reference
to specify the type of the value

==== phodav ====
Version update (2.4 -> 2.5)

- Update to version 2.5:
+ Add PhodavVirtualDir & related API.
+ Various misc build and code fixes.

==== pipewire ====
Version update (0.3.9 -> 0.3.10)
Subpackages: libpipewire-0_3-0 pipewire-modules pipewire-spa-plugins-0_2
pipewire-spa-tools pipewire-tools

- Update to version 0.3.10:
* Many improvements to the pulse layer.
+ GStreamer pulsesink element now works.
+ Fixes some segfaults.
+ Enable rtkit for client threads.
+ fixes capture of monitor stream by name
+ implement some more extensions, this makes paman
work and removes some warnings.
* Many improvements to the GStreamer elements
+ negotiation rework, avoid calling GStreamer methods from
the PipeWire callbacks because they might block and cause
deadlocks.
+ Add support for non-string property values.
+ improve stability after buffer and format
renegotiation.
+ Rework the device provider.
+ pipewiresink can now provide a stream that can
be consumed by apps like cheese.
* Many improvements to the JACK layer:
+ Rework the buffer_size callbacks. Make sure we call
the callback from a 'safe' thread and that we don't
call the process callback while the application is
handling the callback. This improves stability in
apps like Carla when PipeWire dynamically changes
the buffer size.
+ Improve compatibility with apps that call
get_buffer_frames() with a 0 size (calfjackrack)
+ JACK can now create nodes that can be set as a
sink/source in PulseAudio/ALSA apps (you can make an
effects rack and set that as default sink for
apps).
* Added a group id property for nodes. This makes it
possible to schedule nodes with the same driver even
when they are otherwise not linked together. To make
this work well a new flag needed to be added to nodes
to signal when they are ready for processing.
Together with the GStreamer fixes, this makes things
like:
gst-launch-1.0 -v pipewiresrc path=51
stream-properties="props,node.group=1" !
audio/x-raw ! pipewiresink stream-properties="props,node.group=1"
work as expected with PipeWire managing the resampling
to keep the clocks of the devices in sync.
This can later also be used to force devices to be grouped
together to create a JACK-like scheduling group.
* Streams and filter now use PIPEWIRE_NODE and
PIPEWIRE_LATENCY env variables as fallback.
* ACP add per device port list. This makes UCM devices
expose the right ports.
* Fix some segfaults in ACP and UCM.
* make pw-cat use the metadata to find default devices.
* The media session can now save and load audio device
Profiles and Routes (volumes), stream volumes and
the default sink and sources.

==== read-only-root-fs ====

- Adjust btrfsmaintenance sysconfig to not use the read-only
root filesystem [bsc#1176052]

==== rubygem-parser ====
Version update (2.7.1.2 -> 2.7.1.4)

- New upstream release 2.7.1.4
v2.7.1.4 (2020-06-19)
- --------------------
Features implemented:
* ruby28.y: add find pattern. (#714) (Ilya Bylich)
* lexer.rl: reject `->...` and `->(...)` with the same error. (#713) (Ilya
Bylich)
* ruby28.y: accept leading args before forward arg. (#712) (Ilya Bylich)
* Added `emit_forward_arg` compatibility flag. (#710) (Ilya Bylich)
* ruby28.y: include entire lambda expr in lambda rule. (#708) (Ilya Bylich)
* ruby28.y: extracted excessed_comma rule. (#706) (Ilya Bylich)
* Source::TreeRewriter: Improved merging and representations (#703)
(Marc-André Lafortune)
Bugs fixed:
* ruby*.y: fixed context inside lambda args and module. (#709) (Ilya Bylich)
v2.7.1.3 (2020-05-26)
- --------------------
API modifications:
* fixed all warnings. tests are running in verbose mode now. (#685) (Ilya
Bylich)
Features implemented:
* ruby-[parse, rewrite]: add legacy switches (#699) (Marc-André Lafortune)
* Added Parser::Source::Range#to_range. (#697) (Ilya Bylich)
* ruby28.y: support rescue modifier in endless method definition. (#696)
(Ilya Bylich)
* ruby28.y: unify kwrest and no-kwrest rules. (#694) (Ilya Bylich)
* ruby28.y: add right hand assignment (#682) (Vladimir Dementyev)
Bugs fixed:
* fix Comment.associate for postfix conditions/loops (#688) (Marc-André
Lafortune)

==== vulkan-loader ====
Version update (1.2.148 -> 1.2.151)

- Update to release 1.2.151
* Fixed crash in device enumeration

==== xen ====
Subpackages: xen-libs xen-tools xen-tools-domU

- Fix build on aarch64 with gcc10
- Package xenhypfs for aarch64

==== xiterm ====
Subpackages: fbiterm gtkiterm libiterm1

- added patches
fix do not enable application keypad mode [bsc#1158271]
+ xiterm-no-keypad-application-mode.patch
- big thanks to Stefan Hundhammer

==== yast2-installation ====
Version update (4.3.15 -> 4.3.16)

- Self-update improvement: write the list of updated packages to
the /.packages.self_update file in the inst-sys (bsc#1175614)
- 4.3.16


< Previous Next >
This Thread
  • No further messages