Mailinglist Archive: opensuse-factory (377 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200815 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 16 Aug 2020 23:00:44 +0000
  • Message-id: <159761884494.12667.5513975013099993513@go-agent-stagingbot-7>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200815

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
PackageKit
efivar
gnome-desktop (3.36.4 -> 3.36.5)
gnome-shell (3.36.4+3 -> 3.36.5)
gnome-shell-extensions (3.36.2 -> 3.36.3)
google-roboto-fonts (20161103.2.135 -> 2.138)
graphite2 (1.3.12 -> 1.3.14)
grub2
gtk3 (3.24.21 -> 3.24.22)
kernel-firmware (20200716 -> 20200807)
libinput (1.16.0 -> 1.16.1)
libiscsi (1.19.0+git.20200521 -> 1.19.0+git.20200812)
libjpeg-turbo (2.0.4 -> 2.0.5)
libmatroska (1.6.0 -> 1.6.2)
libqt5-qttools
man-pages (5.07 -> 5.08)
mokutil
mutter (3.36.4+9 -> 3.36.5)
nano (5.0 -> 5.1)
orca (3.36.3 -> 3.36.5)
portaudio
postgresql (12 -> 12.0.1)
postgresql12 (12.3 -> 12.4)
python-ordered-set
python-scipy (1.4.1 -> 1.5.2)
quadrapassel (3.36.04 -> 3.36.05)
remmina (1.4.7 -> 1.4.8)
schily
thai-fonts (0.6.1 -> 0.7.2)
wireshark (3.2.5 -> 3.2.6)

=== Details ===

==== PackageKit ====
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module PackageKit-lang libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- Add PackageKit-zypp-cleanup-tmp-files.patch: zypp: Cleanup
temporary files when PackageKit quits
(gh#/hughsie/PackageKit/commit/807f410, bsc#1169739).

==== efivar ====

- Do not partition LTO as we may reach new GAS error:
Error: invalid attempt to declare external version
name as default in symbol `efi_set_variable@@LIBEFIVAR_0.24'

==== gnome-desktop ====
Version update (3.36.4 -> 3.36.5)
Subpackages: gnome-desktop-lang gnome-version libgnome-desktop-3-19
libgnome-desktop-3_0-common typelib-1_0-GnomeDesktop-3_0

- Update to version 3.36.5:
+ No changes, version bump only.

==== gnome-shell ====
Version update (3.36.4+3 -> 3.36.5)
Subpackages: gnome-shell-calendar gnome-shell-lang

- Update to version 3.36.5:
+ Fix extension updates when many extensions are installed.
+ Fix missing icons in on-screen keyboard.
+ Fix delay when showing calendar events.
+ Fix app picker regressions on small displays.
+ Fix top bar navigation when NumLock is active.
+ Delay login animation until wallpaper has loaded.
+ Revert changes that caused mispositioning in overview in
multi-monitor setups.
+ Reset auth prompt on login screen on VT switch before fade in.
+ Fix stuck grab when destroying open popup menu.
+ Misc. bug fixes and cleanups.
+ Updated translations.
- Update gnome-shell-fate324570-Make-GDM-background-image-configurable.patch:
to be compatible with 3.36 (boo#1172826).

==== gnome-shell-extensions ====
Version update (3.36.2 -> 3.36.3)
Subpackages: gnome-shell-classic gnome-shell-classic-session

- Update to version 3.36.3:
+ Updated translations.

==== google-roboto-fonts ====
Version update (20161103.2.135 -> 2.138)

- Update summary to be more on point.
- Version 2.138
- Use upstream version number
- Use roboto-android.zip for better emoji compatibility
- Update metainfo installation location according to latest standard
- Remove useless docs but keep the license file
- Move google-roboto-slab-fonts into an individual package

==== graphite2 ====
Version update (1.3.12 -> 1.3.14)
Subpackages: libgraphite2-3 libgraphite2-3-32bit

- Update to 1.3.14:
* Bug fixes
* Allow features to be hidden (for aliases)
* Move to python3
* Rename doc files from .txt to .asc
- Run spec-cleaner
* Remove rpm groups
* Use make macros
* Use license macro
- Refresh patches:
* link-gcc-shared.diff
* graphite2-1.2.0-cmakepath.patch
- Update to 1.3.13:
* Resolve minor spacing issue in rtl non-overlap kerning
* python3 for graphite.py
* Better fuzzing
* Better building on windows

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Make grub-calloc inline to avoid symbol not found error as the system may not
use updated grub to boot the system (bsc#1174782) (bsc#1175060) (bsc#1175036)
* 0001-kern-mm.c-Make-grub_calloc-inline.patch

==== gtk3 ====
Version update (3.24.21 -> 3.24.22)
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-tigrigna gtk3-immodule-vietnamese
gtk3-immodule-xim gtk3-lang gtk3-schema gtk3-tools libgtk-3-0
typelib-1_0-Gtk-3_0

- Update to version 3.24.22:
+ GtkTextView:
- Fix some corner cases of pixelcache invalidation.
- Make select-all work on touch.
+ Fix print portal support.
+ Adwaita:
- Tweak title style class.
- Add a public color for text view background.
+ Wayland: Add a way to change the application id:
+ Add --enable-tracker3 option to configure.
+ Updated translations.
- Only recommend instead of Require adwaita-icon-theme: Even though
GTK3 references this icon set as fallback, we only want to
recommend it here to have a chance to make live CD's smaller
(where we have good control of the apps on them).

==== kernel-firmware ====
Version update (20200716 -> 20200807)
Subpackages: kernel-firmware-all kernel-firmware-amdgpu kernel-firmware-ath10k
kernel-firmware-atheros kernel-firmware-bluetooth kernel-firmware-bnx2
kernel-firmware-brcm kernel-firmware-chelsio kernel-firmware-dpaa2
kernel-firmware-i915 kernel-firmware-intel kernel-firmware-iwlwifi
kernel-firmware-liquidio kernel-firmware-marvell kernel-firmware-media
kernel-firmware-mediatek kernel-firmware-mellanox kernel-firmware-mwifiex
kernel-firmware-network kernel-firmware-nfp kernel-firmware-nvidia
kernel-firmware-platform kernel-firmware-qlogic kernel-firmware-radeon
kernel-firmware-realtek kernel-firmware-serial kernel-firmware-sound
kernel-firmware-ti kernel-firmware-ueagle kernel-firmware-usb-network ucode-amd

- Update to version 20200807 (git commit c331aa9c49ce):
* amdgpu: update vega20 firmware for 20.30
* amdgpu: update vega12 firmware for 20.30
* amdgpu: update vega10 firmware for 20.30
* amdgpu: update renoir firmware for 20.30
* amdgpu: update raven2 firmware for 20.30
* amdgpu: update raven firmware for 20.30
* amdgpu: update picasso firmware for 20.30
* amdgpu: update navi14 firmware for 20.30
* amdgpu: update navi10 firmware for 20.30
* linux-firmware: update NXP SDSD-8997 firmware image
* Mellanox: Add new mlxsw_spectrum firmware xx.2008.1036
* linux-firmware: Update AMD SEV firmware
* QCA: Add correct bin file for WCN3991
- Still keep the revert of AMDGPU Picasso firmware due to the
regression (bsc#1174278)
- Move a big prestera firmware file in platform subpackage into the
own subpackage, kernel-firmware-prestera
- Update aliases from 5.8 kernel packages

==== libinput ====
Version update (1.16.0 -> 1.16.1)
Subpackages: libinput-udev libinput10

- Update to release 1.16.1
* Add original MX Master to inverted-horizontal-wheel-having mice

==== libiscsi ====
Version update (1.19.0+git.20200521 -> 1.19.0+git.20200812)

- Update to version 1.19.0+git.20200812:
* .travis.yml: Also build for the ppc64le architecture
* iscsi-ls: Fix iser url scheme parsing
* test-tool: Use block_size instead of hardcoded 512 bytes
* examples/iscsi-dd: use common init function for src and dst endpoints
* examples/iscsi-dd: use common iscsi_endpoint struct
* iscsi-perf: Add explicit casts to avoid two warnings
* socket: Make the pdu timeout handling aware of old iscsi context
* libiscsi: Make the cancellation aware of the pdus in old iscsi context
* pdu: Remove the checking for iscsi->is_loggedin in iscsi_cancel_pdus()
* libiscsi: Avoid discontinuities in cmdsn ordering in some cases
* test-tool: Use block_size instead of hardcoded 512 bytes
* exclude ld_iscsi.so from RPM
* include iser-private.h in make dist tarball

==== libjpeg-turbo ====
Version update (2.0.4 -> 2.0.5)
Subpackages: libjpeg8 libjpeg8-32bit libturbojpeg0

- Update to version 2.0.5
* Worked around issues in the MIPS DSPr2 SIMD extensions that caused failures
in the libjpeg-turbo regression tests. Specifically, the
jsimd_h2v1_downsample_dspr2() and jsimd_h2v2_downsample_dspr2() functions
in the MIPS DSPr2 SIMD extensions are now disabled until/unless they can be
fixed, and other functions that are incompatible with big endian MIPS CPUs
are disabled when building libjpeg-turbo for such CPUs.
* Fixed an oversight in the TJCompressor.compress(int) method in the
TurboJPEG Java API that caused an error ("java.lang.IllegalStateException:
No source image is associated with this instance") when attempting to use
that method to compress a YUV image.
* Fixed an issue (CVE-2020-13790) in the PPM reader that caused a buffer
overrun in cjpeg, TJBench, or the tjLoadImage() function if one of the
values in a binary PPM/PGM input file exceeded the maximum value defined in
the file's header and that maximum value was less than 255. libjpeg-turbo
1.5.0 already included a similar fix for binary PPM/PGM files with maximum
values greater than 255.
* The TurboJPEG API library's global error handler, which is used in
functions such as tjBufSize() and tjLoadImage() that do not require a
TurboJPEG instance handle, is now thread-safe on platforms that support
thread-local storage.
- Fix source verification
- Drop patches fixed upstream:
* ctest-depends.patch
* libjpeg-turbo-CVE-2020-13790.patch
- Run spec-cleaner
* Remove package groups
* Use make macros

==== libmatroska ====
Version update (1.6.0 -> 1.6.2)

- Update to version 1.6.2
* In release 1.6.1 the version number in CMakeLists.txt wasn't
updated, affecting the installed cmake and pkgconfig files.
The version number has been bumped to 1.6.2 in all relevant
files now.
- Update to version 1.6.1
* "KaxBlockAddIDValue" class: this class is no longer marked as
"mandatory" in order to coincide with the latest
specification.

==== libqt5-qttools ====
Subpackages: libQt5Designer5 libQt5Help5 libqt5-qdbus libqt5-qtpaths

- Add _constraints with 4GB min disk space

==== man-pages ====
Version update (5.07 -> 5.08)

- version update to 5.08
Newly documented interfaces in existing pages
- --------------------------------------------
prctl.2
Dave Martin
Add SVE prctls (arm64)
Add documentation for the the PR_SVE_SET_VL and PR_SVE_GET_VL
prctls added in Linux 4.15 for arm64.
Dave Martin [Catalin Marinas]
Add tagged address ABI control prctls (arm64)
Add documentation for the the PR_SET_TAGGED_ADDR_CTRL and
PR_GET_TAGGED_ADDR_CTRL prctls added in Linux 5.4 for arm64.
setns.2
Michael Kerrisk
Document the use of PID file descriptors with setns()
Starting with Linux 5.8, setns() can take a PID file descriptor as
an argument, and move the caller into or more of the namespaces of
the thread referred to by that descriptor.
capabilities.7
Michael Kerrisk
Document CAP_BPF
Michael Kerrisk
Add CAP_PERFMON
symlink.7
Aleksa Sarai
Document magic links more completely
etc. see Changes
- modified patches
% man-pages-openat2.h-location.patch (refreshed)

==== mokutil ====

- Update mokutil-support-revoke-builtin-cert.patch
+ Add "--revoke-cert" to the man page

==== mutter ====
Version update (3.36.4+9 -> 3.36.5)
Subpackages: libmutter-6-0 mutter-data mutter-lang

- Update to version 3.36.5:
+ Screencast fixes and improvements.
+ Fix glitches when subsurfaces extend outside the toplevel.
+ Mipmap background texture rendering.
+ Fix wine copy & paste.
+ Plugged memory leaks.
+ Updated translations.

==== nano ====
Version update (5.0 -> 5.1)
Subpackages: nano-lang

- GNU nano 5.1:
* Make M-Bsp (Alt+Backspace) delete a word backwards
* Make M-[ bindable
* Fix crash on first keystroke in an empty buffer --indicator
and --softwrap
* Fix crash when invoking the formatter while text is marked
* In UTF-8 locales, an anchor is shown as a diamond

==== orca ====
Version update (3.36.3 -> 3.36.5)
Subpackages: orca-lang

- Update to version 3.36.5:
+ Web + Thunderbird: Fix regression breaking access to content
(incomplete cherry-pick).
- Update to version 3.36.4:
+ Web:
- Fix false positive causing us to not present self-referential
labels.
- Fix crash caused by author using aria-labelledby pointing to
itself.
- Always speak the current line when caret moves due to mouse
click so that presentation is consistent regardless of the
element.
- Fix bug causing events from Google Docs to be ignored when a
dialog appears but lacks focus.
+ Thunderbird: Fix bug causing us to incorrectly update our
location within settings.
+ General: Fix bug causing learn mode to not work in (at least)
gnome-shell controls.
+ Updated translations.

==== portaudio ====

- The portaudio C library uses pthread_cleanup* macros, a sane but
compiler/os specific implementation of them requires using
- fexceptions flag. see pthread.h for details.

==== postgresql ====
Version update (12 -> 12.0.1)
Subpackages: postgresql-contrib postgresql-docs postgresql-llvmjit
postgresql-server

- We also transfer PostgreSQL 9.4.26 to the new package layout in
SLE12-SP2 and newer. Reflect this in the conflict with
postgresql94.
- Also conflict with PostgreSQL versions before 9.
- Conflicting with older versions is not limited to SLE.
- Bump version to 12.0.1, so that the binary packages also have
a cut-point to conflict with.

==== postgresql12 ====
Version update (12.3 -> 12.4)
Subpackages: libpq5 postgresql12-contrib postgresql12-docs postgresql12-llvmjit
postgresql12-server

- update to 12.4:
* CVE-2020-14349, bsc#1175193: Set a secure search_path in
logical replication walsenders and apply workers
* CVE-2020-14350, bsc#1175194: Make contrib modules' installation
scripts more secure.
* https://www.postgresql.org/docs/12/release-12-4.html
- Remove postgresql-regress.patch, it does not apply anymore and
it does not seem to be needed anymore.
- Pack the /usr/lib/postgresql symlink only into the main package.
- Let postgresqlXX conflict with postgresql-noarch < 12.0.1 to get
a clean and complete cutover to the new packaging schema.

==== python-ordered-set ====

- Replace Source URL with the standard one

==== python-scipy ====
Version update (1.4.1 -> 1.5.2)

- Update to 1.5.2
* wrappers for more than a dozen new LAPACK routines are now available in
scipy.linalg.lapack
* Improved support for leveraging 64-bit integer size from linear algebra
backends
* addition of the probability distribution for two-sided one-sample
Kolmogorov-Smirnov tests
* see upstream changelog for more detailed info
- Drop breaking patch no_implicit_decl.patch
* the problem is with lapacke

==== quadrapassel ====
Version update (3.36.04 -> 3.36.05)
Subpackages: quadrapassel-lang

- Update to version 3.36.05:
+ Updated translations.

==== remmina ====
Version update (1.4.7 -> 1.4.8)
Subpackages: remmina-lang remmina-plugin-rdp remmina-plugin-secret
remmina-plugin-vnc remmina-plugin-xdmcp

- Update to release 1.4.8
* Adding timout option for RDP connections.
* Avoid quickconnect to empty hostnames. Fixes #2240
* Using full paths instead of variables
* Add support for quick connecting to RDP, VNC and SPICE from the
command line
* Add SSH support to the protocol handler
* Restart SSH session when user has provided new username or password to
allow for changing SSH user
* Use inline with AppStream 0.12 specification.
* Enabled GDK_SCROLL_SMOOTH for RDP/VNC
* Some fixes for the RDP backend
* Trim white from ip addresses input into quick connect bar
* Enhancing the SNAP info dialog box
* Adding FreeRDP log level setting

==== schily ====
Subpackages: cdda2wav cdrecord libcdrdeflt1_0 libdeflt1_0 libedc_ecc1_0
libedc_ecc_dec1_0 libfile1_0 libfind4_0 libparanoia1_0 librmt1_0 librscg1_0
libscg1_0 libscgcmd1_0 libschily2_0 mkisofs readcd spax star

- Update to release 2020.08.12
* star: GNU cpio archives may contain longer path names than
permitted by the AT&T documentation, problems with which
where fixed.
* sccs: sccslog again allows ovelapping delgets and now allows
overlapping delget groups to be correctly detected as commit
bundle.

==== thai-fonts ====
Version update (0.6.1 -> 0.7.2)

- Update to version 0.7.2.
* Garuda has been fine-tuned by hand for balanced cubic splines
and optimal quadratic splines.
* All families now use OS/2 Typo metrics instead of just Win/Hhea
metrics.
* The OS/2 Typo metrics of each family have been normalized for
equal line spacing on all faces, esp. regular and bold.
* Switch to Python 3 on build scripts.
* Fix a TDS zipball naming issue in the generated CTAN zipball.

==== wireshark ====
Version update (3.2.5 -> 3.2.6)
Subpackages: libwireshark13 libwiretap10 libwsutil11 wireshark-ui-qt

- Wireshark 3.2.6:
* CVE-2020-17498: Kafka dissector crash (boo#1175204)
* Further features, bug fixes and updated protocol support as
listed in:
https://www.wireshark.org/docs/relnotes/wireshark-3.2.6.html


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages