Mailinglist Archive: opensuse-factory (377 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200814 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 16 Aug 2020 10:00:48 +0000
  • Message-id: <159757204891.29482.13282046060131301159@go-agent-stagingbot-1>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200814

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.10.21 -> 7.0.10.27)
augeas (1.11.0 -> 1.12.0)
autoyast2 (4.3.32 -> 4.3.35)
brotli
busybox
busybox-links
chromaprint (1.4.3 -> 1.5.0)
ethtool (5.7 -> 5.8)
firewalld (0.7.4 -> 0.7.5)
fribidi (1.0.5 -> 1.0.10)
gd (2.2.5 -> 2.3.0)
gdb (8.3.1 -> 9.2)
hwdata (0.337 -> 0.338)
openblas_pthreads
openldap2 (2.4.50 -> 2.4.51)
pigz
pmdk (1.8 -> 1.9)
qemu (5.0.0 -> 5.1.0)
texlive
yast2-add-on (4.3.3 -> 4.3.4)
yast2-auth-client (4.3.0 -> 4.3.1)
yast2-bootloader (4.3.7 -> 4.3.8)
yast2-configuration-management (4.3.2 -> 4.3.3)
yast2-country (4.3.6 -> 4.3.8)
yast2-dhcp-server (4.3.0 -> 4.3.1)
yast2-dns-server (4.3.0 -> 4.3.1)
yast2-firewall (4.3.2 -> 4.3.4)
yast2-firstboot (4.3.3 -> 4.3.4)
yast2-ftp-server (4.3.1 -> 4.3.2)
yast2-http-server (4.3.0 -> 4.3.1)
yast2-installation (4.3.13 -> 4.3.14)
yast2-iscsi-client (4.3.1 -> 4.3.2)
yast2-kdump (4.3.1 -> 4.3.2)
yast2-mail (4.3.0 -> 4.3.1)
yast2-nfs-client (4.3.1 -> 4.3.2)
yast2-nfs-server (4.3.0 -> 4.3.1)
yast2-nis-client (4.3.3 -> 4.3.4)
yast2-nis-server (4.3.0 -> 4.3.1)
yast2-ntp-client (4.3.0 -> 4.3.1)
yast2-online-update-configuration (4.3.0 -> 4.3.1)
yast2-printer (4.3.1 -> 4.3.2)
yast2-proxy (4.3.1 -> 4.3.2)
yast2-ruby-bindings (4.3.0 -> 4.3.2)
yast2-samba-client (4.3.1 -> 4.3.2)
yast2-samba-server (4.3.2 -> 4.3.3)
yast2-security (4.3.1 -> 4.3.3)
yast2-services-manager (4.3.2 -> 4.3.4)
yast2-sound (4.3.2 -> 4.3.3)
yast2-squid (4.3.1 -> 4.3.2)
yast2-storage-ng (4.3.12 -> 4.3.14)
yast2-sysconfig (4.3.1 -> 4.3.2)
yast2-tftp-server (4.3.0 -> 4.3.1)
yast2-trans (84.87.20200725.1c0c8c4fe3 -> 84.87.20200812.809b1261b7)
yast2-users (4.3.6 -> 4.3.7)
yast2-ycp-ui-bindings (4.3.0 -> 4.3.2)

=== Details ===

==== ImageMagick ====
Version update (7.0.10.21 -> 7.0.10.27)
Subpackages: ImageMagick-config-7-SUSE ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI7 libMagickWand-7_Q16HDRI7

- version update to 7.0.10.27
* fix regression when detecting the libz delegate library.
* Add animated webp blend method support (reference
https://github.com/ImageMagick/ImageMagick/pull/2351).
* Add support for OpenRaster (.ora) image format (reference
https://github.com/ImageMagick/ImageMagick/pull/2342).
* Paths in Photoshop EPS files are no longer corrupted (reference
https://github.com/ImageMagick/ImageMagick/issues/2380).
- version update to 7.0.10.25
* Remove UseCIEColor setting from PDF code as its use is not recommended.
* Update to the latest documentation.
* To preserve compression of input image with the tiff encoder use:
- define tiff:preserve-compression=true.
* Add support for the -white-balance command-line option.
* Discover hidden files when globbing (e.g. *.jpg) (reference
https://github.com/ImageMagick/ImageMagick/discussions/2239).
* New inverse-log evaluate operator.
* Ensure that float is valid in ClampToQuantum() (reference
https://github.com/ImageMagick/ImageMagick/pull/2219).
* New pseudo-image format, ashlar, e.g.
convert *.jpg -resize 320x320 ashlar:canvas.png).
- version update to 7.0.10.22
* fix wrapping of caption (reference
https://github.com/ImageMagick/ImageMagick/issues/2178).
* sanity check of affine matrix when drawing.

==== augeas ====
Version update (1.11.0 -> 1.12.0)
Subpackages: augeas-lenses libaugeas0

- update to 1.12.0
General changes/additions
- update gnulib to 91584ed6
Lens changes/additions
- Anaconda: new lens to process /etc/sysconfig/anaconda instead of Shellvars
(Pino Toscano) (Issue #597)
- DevfsRules: add lens for FreeBSD devfs.rules files
- Dovecot: permit ! in block titles (Nathan Ward) (Issue #599)
- Hostname: Allow creation of hostname when file is missing (David Farrell)
(Issue #606)
- Krb5: add more pkinit_* options (Issue #603)
- Logrotate: fix missing recognition of double quoted filenames (Issue #611)
- Multipath: accept values enclosed in quotes (Issue #583)
- Nginx: support unix sockets as server address (Issue #618)
- Nsswitch: add merge action (Issue #609)
- Pam: accept continuation lines (Issue #590)
- Puppetfile: allow symbols as (optional) values (Issue #619) allow comments
in entries (Issue #620)
- Rsyslog: support dynamic file paths (Issue #622) treat #!/+/- as comment
(arnolda, PR #595)
- Syslog: accept 'include' directive (Issue #486)
- Semanage: new lens to process /etc/selinux/semanage.conf instead of
Simplevars (Pino Toscano) (Issue #594)
- Shellvars: allow and/or in @if conditions (#582) accept functions wrapped
in round brackets, accept variables with a dash in their name, exclude csh/tcsh
profile scripts (Pino Toscano) (Issue #600) accept variable as command (Issue
#601)
- Ssh: accept RekeyLimit (Issue #605)
- Sshd: accept '=' to separate option names from their values (Emil Dragu,
#587)
- Sudoers: support 'always_query_group_plugin' flag (Steve Traylen, #588)
- Strongswan: parse lists. This is a backwards-incompatible change since list
entries that were parsed into a single string are now split into a list of
entries (Kaarle Ritvanen)
- Toml: new lens to parse .toml files (PR #91)
- Xorg: accept empty values for options (arnolda, PR #596)
- refresh patches
- run spec-cleaner

==== autoyast2 ====
Version update (4.3.32 -> 4.3.35)
Subpackages: autoyast2-installation

- bsc#1173624
- Run firewall configuration in first stage
- 4.3.35
- AutoYaST: Added supplements: autoyast(files,general,report,scripts,
partitioning,software) into the spec file in order to install
this packages if the section has been defined in the AY
configuration file (bsc#1146494).
- 4.3.34
- Improve finding the respective package for a section in the XML
installation profile. Find a package with the
"autoyast(<section_name>)" supplements dependency (bsc#1146494).
- 4.3.33

==== brotli ====
Subpackages: libbrotli-devel libbrotlicommon1 libbrotlicommon1-32bit
libbrotlidec1 libbrotlidec1-32bit libbrotlienc1

- Fix W: shared-lib-calls-exit /usr/lib64/libbrotlienc.so.1.0.7
exit@GLIBC_2.2.5.

==== busybox ====
Subpackages: busybox-static

- Enable SELinux for the dynamic version

==== busybox-links ====
Subpackages: busybox-bzip2 busybox-coreutils busybox-findutils busybox-gawk
busybox-grep busybox-patch busybox-psmisc busybox-sed busybox-sendmail
busybox-tar busybox-unzip busybox-xz

- Fix typo in spec file
- Create new sub-packages: selinux-tools and policycoreutils

==== chromaprint ====
Version update (1.4.3 -> 1.5.0)

- Update to 1.5.0:
* Added support for fpcalc -raw -signed, which helps with easier PostgreSQL
integration
* Added support for using libavresample instead of libswresample
* Fixed possible crash in chromaprint_decode_fingerprint
* Fixed unit tests on big endian CPUs
- Run spec-cleaner
* Remove package groups
* Use license macro
- Remove bcond_without and use ffmpeg unconditional

==== ethtool ====
Version update (5.7 -> 5.8)

- update to new upstream release 5.8
* netlink handler for device features
* netlink handler for private flags
* netlink handler for ring sizes
* netlink handler for channels counts
* netlink handler for coalescing parameters
* netlink handler for pause parameters
* netlink handler for EEE settings
* netlink handler for timestamping info
* master/slave configuration support
* LINKSTATE SQI support
* cable test support
* cable test TDR support
* JSON output for cable test commands
* igc driver support
* support for get/set ethtool_tunable
* dsa: mv88e6xxx: add pretty dump for 88E6352 SERDES
* fix some build warnings
- drop patches present in 5.8 release:
* netlink-fix-build-warnings.patch
* netlink-fix-error-message-suppression.patch
* netlink-fix-unwanted-switch-fall-through-in-family_i.patch
- ethtool.keyring:
add new upstream maintainer's key (F4554567B91DE934)

==== firewalld ====
Version update (0.7.4 -> 0.7.5)
Subpackages: firewalld-lang python3-firewall

- Update to version 0.7.5:
* release: v0.7.5
* chore(translation): merge from master
* fix(cli): add ipset type hash:mac is incompatible with the family parameter
Fixes: rhbz1541077
* test(rhbz1483921): better test name
* fix(cli): add --zone is an invalid option with --direct
* fix: core: rich: Catch ValueError on non-numeric priority values
* fix: update dynamic DCE RPC ports in freeipa-trust service
* docs: replace occurrences of the term blacklist with denylist
* docs(README): add libxslt for doc generation
* test(rich): source mac with nftables backend
* fix(firewall-offline-cmd): remove instances of "[P]" in help text
* test(check-container): add support for centos8 stream
* test(functions): use IndividualCalls if host doesn't support nft rule index
* test(functions): add macro IF_HOST_SUPPORTS_NFT_RULE_INDEX
* test(dbus): better way to check IPv6_rpfilter expected value
* fix(ipset): flush the set if IndividiualCalls=yes
* test(ipv6): skip square bracket address tests if ipv6 not available
* test(gh509): only run test for nftables backend
* fix(dbus): service: don't cleanup config for old set APIs
* fix(config): bool values in dict based import/export
* fix(doc): dbus: signatures for zone tuple based APIs
* test(dbus): zone: fix zone runtime functional test title
* test(dbus): zone: fix false failure due to list order
* fix(client): addService needs to reduce tuple size
* test(direct): rule in a zone chain
* fix(direct): rule in a zone chain
* test(dbus): zone: verify runtime config APIs
* test(dbus): zone: verify permanent config APIs
* fix(systemd): Conflict with nftables.service
* fix: test/regression/gh599: use expr to be more portable
* test: dbus: zone: verify runtime config API signatures
* test: dbus: zone: verify permanent config API signatures
* fix: test/regression/gh599: fix if not using debug output
* test: log: verify logging still works after truncate
* test: ipset: verify port ranges for non-default protocol

==== fribidi ====
Version update (1.0.5 -> 1.0.10)
Subpackages: libfribidi0 libfribidi0-32bit

- Update to version 1.0.10:
* Fixed various compilation problems and symbol exports necessary for
proper compilation under windows.
- Changes from version 1.0.9:
* A bug fix in the fribidi unicode algorithm where isolate sequences were
not really isolated.
* Restored mistakenly removed deprecated function
fribidi_log2vis_get_embedding_levels()
* autotools now generates xz archives instead of bzip2 archives
- Changes from version 1.0.8:
* A bug fix in the fribidi unicode algorithm for multiple isolate
sequences.
* Fixed a potential buffer overflow for a long sequence of isolate
overrides characters
- Changes from version 1.0.7:
* This is a minor bugfix that removes symlinks and updates the meson
version.
- Changes from version 1.0.6:
* This is a minor bugfix release that fixes a list of minor issues that
have turned up during the last year.
* Various compilation and cross compilation issues.
* Various minor header cleanups.
* Removed libc's bsearch for performance and portability reasons
- Run spec-cleaner
* Remove package groups
- Drop patches fixed upstream
* Truncate-isolate_level-to-FRIBIDI_BIDI_MAX_EXPLICIT_.diff
* no-config-h.diff

==== gd ====
Version update (2.2.5 -> 2.3.0)
Subpackages: libgd3

- Version update to 2.3.0:
[#]## Security
- Potential double-free in gdImage*Ptr(). (CVE-2019-6978)
- gdImageColorMatch() out of bounds write on heap. (CVE-2019-6977)
- Uninitialized read in gdImageCreateFromXbm(). (CVE-2019-11038)
- Double-free in gdImageBmp. (CVE-2018-1000222)
- Potential NULL pointer dereference in gdImageClone(). (CVE-2018-14553)
- Potential infinite loop in gdImageCreateFromGifCtx(). (CVE-2018-5711)
[#]## Fixed
- Fix #597: add codecov support
- Fix #596: gdTransformAffineCopy run error
- Fix #589: Install dependencies move to .travis.yml
- Fix #586: gdTransformAffineCopy() segfaults on palette images
- Fix #585: gdTransformAffineCopy() changes interpolation method
- Fix #584: gdImageSetInterpolationMethod(im, GD_DEFAULT) inconsistent
- Fix #583: gdTransformAffineCopy() may use unitialized values
- Fix #533: Remove cmake modules
- Fix #539: Add RAQM support for cmake
- Fix #499: gdImageGifAnimAddPtr: heap corruption with 2 identical images
- Fix #486: gdImageCropAuto(?, GD_CROP_SIDES) crops left but not right
- Fix #485: auto cropping has insufficient precision
- Fix #479: Provide a suitable malloc function to liq
- Fix #474: libtiff link returns 404 HTTP code
- Fix #450: Failed to open 1 bit per pixel bitmap
- Fix #440: new_width & new_height exception handling
- Fix #432: gdImageCrop neglecting transparency
- Fix #420: Potential infinite loop in gdImageCreateFromGifCtx
- Fix #411: gd_gd.c format documentation appears to be incorrect
- Fix #369: Fix new_a init error in gdImageConvolution()
- Fix #351: gdImageFilledArc() doesn't properly draw pies
- Fix #338: Fatal and normal libjpeg/libpng errors not distinguishable
- Fix #169: Update var type to hold bigger w&h for ellipse
- Fix #164: update doc files install directory in CMakeLists.txt
- Correct some test depend errors
- Update cmake min version to 3.7
- Delete libimagequant source code download action in CMakeLists.txt
- Improve msys support
- Fix some logic error in CMakeLists.txt
- Remove the following macro: HAVE_STDLIB_H, HAVE_STRING_H, HAVE_STDDEF_H,
HAVE_LIMITS_H, HAVE_ERRNO_H, AC_C_CONST
[#]## Added
- test cases for following API: gdImageCopyResized(), gdImageWebpEx(),
gdImageCreateFromGd2PartPtr(), gdImageCloneMatch(),
gdImageColorClosestHWB(), gdImageColorMatch(), gdImageStringUp(),
gdImageStringUp16(), gdImageString(), gdImageString16(),
gdImageCopyMergeGray(), gdImageCopyMerge()
- Drop CVE patches now fixed upstream:
- gd-CVE-2018-1000222.patch
- gd-CVE-2018-14553.patch
- gd-CVE-2018-5711.patch
- gd-CVE-2019-11038.patch
- gd-CVE-2019-6977.patch
- gd-CVE-2019-6978.patch
- Drop patch: libgd-config.patch since upstream have dropped libgd-config binary
- Run spec-cleaner
+ Remove package groups
+ use license macro
+ use make macros

==== gdb ====
Version update (8.3.1 -> 9.2)

- Restore License/Group.
- Add BuildRequire babeltrace-devel. On Factory this adds bdeps
babeltrace-devel, libuuid-devel, babeltrace, libglib-2_0-0, and
libgmodule-2_0-0.
- Fix internal error on aarch64 [swo#26316].
gdb-aarch64-fix-erroneous-use-of-spu-architecture-bfd.patch
- Change into multibuild package and add flavour gdb-testsuite.
- Fix s390 -> s390x typo.
- Don't BuildRequire binutils-gold for SLE-12/s390.
- BuildRequire binutils-gold for testsuite
- Rebase to 9.2 release.
- Fix SLE-11 build. Gdb 9.1 requires make 3.82, but SLE-11 has
make 3.81:
* gdbserver-fix-build-with-make-3.81.patch
- Fix patch context:
* gdb-fix-the-thread-pool.c-compilation.patch
- Fix build error due to missing DIAGNOSTIC_IGNORE_UNUSED_FUNCTION.
* gdb-fix-the-thread-pool.c-compilation.patch
- Drop ChangeLog part of patch:
* gdb-fix-unused-function-error.patch
- Fix Werror=unused-function with gcc 4.8 (for Leap 42.3).
* gdb-fix-unused-function-error.patch
- Require %{suse_version} >= 1500 for --with-system-readline.
- Rebase to 9.1 release (as in fedora 32 @ 1735910).
* Breakpoints on nested functions and subroutines in Fortran.
* Multithreaded symbol loading, disabled by default. Enable
using 'maint set worker-threads unlimited'.
* Multi-target debugging support.
* New command pipe.
* New command set logging debugredirect [on|off].
* New fortran commands info modules, info module functions,
info module variables.
- Fedora-specific patches dropped:
* gdb-libexec-add-index.patch
* gdb-6.3-rh-testversion-20041202.patch
* gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
- Obsoleted fedora patches dropped:
* gdb-6.5-bz216711-clone-is-outermost.patch
* gdb-6.6-scheduler_locking-step-is-default.patch
* gdb-6.8-bz436037-reg-no-longer-active.patch
* gdb-bz541866-rwatch-before-run.patch
* gdb-bz568248-oom-is-error.patch
* gdb-follow-child-stale-parent.patch
* gdb-readline62-ask-more-rh.patch
* gdb-rhbz1371380-gcore-elf-headers.patch
* gdb-rhbz1553086-binutils-warning-loadable-section-outside-elf.patch
* gdb-rhbz1704406-disable-style-log-output-1of3.patch
* gdb-rhbz1704406-disable-style-log-output-2of3.patch
* gdb-rhbz1704406-disable-style-log-output-3of3.patch
* gdb-rhbz1708192-parse_macro_definition-crash.patch
* gdb-rhbz1723564-gdb-crash-PYTHONMALLOC-debug.patch
* gdb-rhbz795424-bitpos-20of25.patch
* gdb-rhbz795424-bitpos-21of25.patch
* gdb-rhbz795424-bitpos-22of25.patch
* gdb-rhbz795424-bitpos-23of25.patch
* gdb-rhbz795424-bitpos-25of25-test.patch
* gdb-rhbz795424-bitpos-25of25.patch
* gdb-rhbz795424-bitpos-arrayview.patch
* gdb-rhbz795424-bitpos-lazyvalue.patch
* gdb-testsuite-readline63-sigint.patch
- Fedora patches added:
* gdb-rhbz1818011-bfd-gcc10-error.patch
- Obsoleted patched dropped:
* gdb-fix-s390-build.diff
* gdb-fix-riscv-tdep.patch
* gdb-testsuite-add-missing-initial-prompt-read-in-multidictionary.exp.patch
* gdb-testsuite-pie-no-pie.patch
* gdb-testsuite-read1-fixes.patch
* gdb-testsuite-i386-pkru-exp.patch
* gdb-s390-handle-arch13.diff
* gdb-fix-heap-use-after-free-in-typename-concat.patch
* gdb-dwarf-reader-reject-sections-with-invalid-sizes.patch
* gdb-0001-remove-alloca-0-calls.patch
* gdb-arch13-1.diff
* gdb-arch13-2.diff
* gdb-arch13-3.diff
* bfd-change-num_group-to-unsigned-int.patch
*
gdb-fix-incorrect-use-of-is-operator-for-comparison-in-python-lib-gdb-command-prompt.py.patch
* gdb-symtab-prefer-var-def-over-decl.patch
*
gdb-only-force-interp_console-ui_out-for-breakpoint-commands-in-mi-mode.patch
* gdb-testsuite-8.3-kfail-xfail-unsupported.patch
- Backport from master:
* gdb-fix-debug-agent-odr-bool-int.patch
* gdb-fix-python3.9-related-runtime-problems.patch

==== hwdata ====
Version update (0.337 -> 0.338)

- Update to version 0.338:
+ Updated pci, usb and vendor ids.

==== openblas_pthreads ====

- Avoid compile-time CPU-detection (boo#1100677)

==== openldap2 ====
Version update (2.4.50 -> 2.4.51)
Subpackages: libldap-2_4-2 libldap-2_4-2-32bit libldap-data openldap2-client

- updated to 2.4.51
- removed obsolete patch 0014-ITS-8650-fix-debug-usage.patch
OpenLDAP 2.4.51 Release (2020/08/11)
Added slapo-ppolicy implement Netscape password policy controls (ITS#9279)
Fixed libldap retry loop in ldap_int_tls_connect (ITS#8650)
Fixed libldap to use getaddrinfo in ldap_pvt_get_fqdn (ITS#9287)
Fixed slapd to enforce singular existence of some overlays (ITS#9309)
Fixed slapd syncrepl to not delete non-replicated attrs (ITS#9227)
Fixed slapd syncrepl to correctly delete entries on resync (ITS#9282)
Fixed slapd syncrepl to use replace on single valued attrs (ITS#9294,
ITS#9295)
Fixed slapd-perl dynamic config with threaded slapd (ITS#7573)
Fixed slapo-ppolicy to expose the ppolicy control (ITS#9285)
Fixed slapo-ppolicy race condition for pwdFailureTime (ITS#9302)
Fixed slapo-ppolicy so it can only exist once per DB (ITS#9309)
Fixed slapo-chain to check referral (ITS#9262)
Build Environment
Fix test064 so it no longer uses bashisms (ITS#9263)
Contrib
Fix default prefix value for pw-argon2, pw-pbkdf2 modules (ITS#9248)
slapo-allowed - Fix usage of unitialized variable (ITS#9308)
Documentation
ldap_parse_result(3) - Document ldap_parse_intermediate (ITS#9271)

==== pigz ====

- Build with -fexceptions to get compiler/os specific (aka. sane)
implementations of pthread_cleanup* routines.

==== pmdk ====
Version update (1.8 -> 1.9)
Subpackages: libpmem1

- Update to PMDK 1.9
- Switches the default instruction set for memcpy, memmove and memset
implementations on x86 to AVX512, and introduces numerous performance
improvements for those operations on AVX and SSE2 fallback paths.
- Optimizes transactional allocations in libpmemobj by avoiding one
extraneous cache miss and reducing the amount of work required to perform
a reservation.
- Introduces a new API in libpmemobj, pmemobj_tx_set_failure_behavior,
that enables the application to control the behavior of aborting
transactions.
- Stabilizes support for ppc64.
- pmem: mem[cpy|set] optimization when eADR is available
- obj: detect msync failures in non-pmem variants of mem[cpy|move|set]
- Add patches to fix compilation against libfabric:
- examples-rpmem-add-missing-lfabric-flag.patch to fix examples linkage errors
- common-fix-LIBFABRIC-flags.patch to fix daemons/tools linkage errors

==== qemu ====
Version update (5.0.0 -> 5.1.0)
Subpackages: qemu-arm qemu-block-curl qemu-block-dmg qemu-block-gluster
qemu-block-iscsi qemu-block-nfs qemu-block-rbd qemu-block-ssh qemu-extra
qemu-guest-agent qemu-ipxe qemu-ksm qemu-kvm qemu-lang qemu-microvm qemu-ppc
qemu-s390 qemu-seabios qemu-sgabios qemu-tools qemu-ui-curses qemu-ui-gtk
qemu-ui-sdl qemu-ui-spice-app qemu-vgabios qemu-vhost-user-gpu qemu-x86

- Update to v5.1.0: See http://wiki.qemu.org/ChangeLog/5.1
Take note that ongoing feature deprecation is tracked at both
http://wiki.qemu-project.org/Features/LegacyRemoval and in
the deprecated.html file installed with the qemu package
Some noteworthy changes:
* s390: Protected virtualization (secure execute) is fully merged
upstream
* s390: vfio-ccw devices no longer require setting the allow
prefetch bit in the ORB, but is still dependent on host kernel
support
* s390: vfio-ccw now has basic support for relaying path state
changes to the guest
* PowerPC: pseries: NVDIMMs require label-size property
* PowerPC: pseries: POWER10 support
* PowerPC: added interface to inject POWER style NMIs
* ARM: new board: sonorapass-bmc
* ARM: new emulated features: ARMv8.2-TTSUXN, ARMv8.5-MemTag
* ARM: Raspberry Pi boards now support a USB controller
* ARM: virt board now supports hot-remove memory
* RISC-V lots of improvements
* qemu-img resize now requires -shrink to shrinking raw images
* The mem parameter of the -numa option is no longer recognized
starting with 5.1 machine types - instead use the memdev parameter
* The ACPI WAET table is now exposed to guests
* The max blocksize for virtual storage device is now 2 MiB
* NVMe improvements
* Crypto subsystem improvements
* Block backends and tools: Numerous improvements and fixes
* Firmware updates: SeaBIOS (essentially v1.14.0), OpenBIOS, SLOF
(20200717), OpenSBI (v0.7)
* Patches dropped (upstream unless otherwise noted):
ati-vga-check-mm_index-before-recursive-.patch
audio-fix-wavcapture-segfault.patch
es1370-check-total-frame-count-against-c.patch
exec-set-map-length-to-zero-when-returni.patch
gcc10-maybe-uninitialized.patch
hw-vfio-pci-quirks-Fix-broken-legacy-IGD.patch
megasas-use-unsigned-type-for-reply_queu.patch
nbd-server-Avoid-long-error-message-asse.patch
ppc-spapr_caps-Don-t-disable-cap_cfpc-on.patch
s390x-Add-SIDA-memory-ops.patch
s390x-Add-unpack-facility-feature-to-GA1.patch
s390x-Move-diagnose-308-subcodes-and-rcs.patch
s390x-protvirt-Add-migration-blocker.patch
s390x-protvirt-Disable-address-checks-fo.patch
s390x-protvirt-Handle-SIGP-store-status-.patch
s390x-protvirt-Inhibit-balloon-when-swit.patch
s390x-protvirt-KVM-intercept-changes.patch
s390x-protvirt-Move-diag-308-data-over-S.patch
s390x-protvirt-Move-IO-control-structure.patch
s390x-protvirt-Move-STSI-data-over-SIDAD.patch
s390x-protvirt-SCLP-interpretation.patch
s390x-protvirt-Set-guest-IPL-PSW.patch
s390x-protvirt-Support-unpack-facility.patch
s390x-s390-virtio-ccw-Fix-build-on-syste.patch
Sync-pv.patch
tests-Disable-some-block-tests-for-now.patch (no longer needed)
vga-fix-cirrus-bios.patch
virtiofsd-add-rlimit-nofile-NUM-option.patch
virtiofsd-stay-below-fs.file-max-sysctl-.patch
* Patches renamed:
build-Do-not-apply-WORKAROUND_CFLAGS-for.patch
- > Do-not-apply-WORKAROUND_CFLAGS-for-host-.patch
build-Fix-s-directive-argument-is-null-e.patch
- > Fix-s-directive-argument-is-null-error.patch
* Patches added:
hw-hyperv-vmbus-Fix-32bit-compilation.patch
- New subpackages, due to modularization: qemu-chardev-baum,
qemu-hw-display-qxl, qemu-hw-usb-redirect, qemu-hw-usb-smartcard
- Configure to use "system" libslirp and libdaxctl (libnvdimm)
when available
- Don't disable cap_cfpc on POWER8 by default (bsc#1174374)
ppc-spapr_caps-Don-t-disable-cap_cfpc-on.patch

==== texlive ====
Subpackages: libkpathsea6 libsynctex2

- Fix longstanding bug: Make sure that pdfcsplain points to pdftex
as otherwise UTF-8 characters are missed in the output

==== yast2-add-on ====
Version update (4.3.3 -> 4.3.4)

- AutoYaST: Added supplements: autoyast(add-on) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.4

==== yast2-auth-client ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(auth-client) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-bootloader ====
Version update (4.3.7 -> 4.3.8)

- AutoYaST: Added supplements: autoyast(bootloader) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.8

==== yast2-configuration-management ====
Version update (4.3.2 -> 4.3.3)

- AutoYaST: Added supplements: autoyast(configuration-management)
into the spec file in order to install this packages if the
section has been defined in the AY configuration file (bsc#1146494).
- 4.3.3

==== yast2-country ====
Version update (4.3.6 -> 4.3.8)
Subpackages: yast2-country-data

- AutoYaST: Added supplements: autoyast(language,keyboard,timezone)
into the spec file in order to install this packages if the
section has been defined in the AY configuration file
(bsc#1146494).
- 4.3.8
- Fixed failing unit test on S390 (related to bsc#1172749)
- 4.3.7

==== yast2-dhcp-server ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(dhcp-server) into the spec
file in order to install this packages if the section has been
defined in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-dns-server ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(dns-server) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-firewall ====
Version update (4.3.2 -> 4.3.4)

- AutoYaST: moved the configuration into first stage (bsc#1173624)
- 4.3.4
- AutoYaST: Added supplements: autoyast(firewall) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.3

==== yast2-firstboot ====
Version update (4.3.3 -> 4.3.4)

- AutoYaST: Added supplements: autoyast(firstboot) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.4

==== yast2-ftp-server ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(ftp-server) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-http-server ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(http-server) into the spec
file in order to install this packages if the section has been
defined in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-installation ====
Version update (4.3.13 -> 4.3.14)

- AutoYaST: Added supplements: autoyast(deploy_image,ssh_import)
into the spec file in order to install this packages if the
section has been defined in the AY configuration file (bsc#1146494).
- 4.3.14

==== yast2-iscsi-client ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(iscsi-client) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-kdump ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(kdump) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-mail ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(mail) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-nfs-client ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(nfs) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-nfs-server ====
Version update (4.3.0 -> 4.3.1)
Subpackages: yast2-nfs-common

- AutoYaST: Added supplements: autoyast(nfs-server) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-nis-client ====
Version update (4.3.3 -> 4.3.4)

- AutoYaST: Added supplements: autoyast(nis) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.4

==== yast2-nis-server ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(nis_server) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-ntp-client ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(ntp-client) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-online-update-configuration ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(online_update_configuration)
into the spec file in order to install this packages if the
section has been defined in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-printer ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(printer) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-proxy ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(proxy) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-ruby-bindings ====
Version update (4.3.0 -> 4.3.2)

- Fixed yast-ycp-ui-bindings dependency (bsc#1175115)
- 4.3.2
- Added new UI terms: MenuBar(), Menu() (bsc#1175115)
- 4.3.1

==== yast2-samba-client ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(samba-client) into the spec
file in order to install this packages if the section has been
defined in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-samba-server ====
Version update (4.3.2 -> 4.3.3)

- AutoYaST: Added supplements: autoyast(samba-server) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.3

==== yast2-security ====
Version update (4.3.1 -> 4.3.3)

- Fixed randomly failing unit tests, do not query the installed
PAM modules in the testing system (related to bsc#1171318)
- 4.3.3
- AutoYaST: Added supplements: autoyast(security) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-services-manager ====
Version update (4.3.2 -> 4.3.4)

- AutoYaST: Added supplements: autoyast(services_manager) into the
spec file in order to install this packages if the section has
been defined in the AY configuration file (bsc#1146494).
- 4.3.4
- Fix changing other services than the user expects (bsc#1165388,
bsc#1174615)
- 4.3.3

==== yast2-sound ====
Version update (4.3.2 -> 4.3.3)

- AutoYaST: Added supplements: autoyast(sound) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.3

==== yast2-squid ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(squid) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-storage-ng ====
Version update (4.3.12 -> 4.3.14)

- AutoinstProposal now properly reports the proposal as failed when
it fails to find the disks (bsc#1174469)
- 4.3.14
- Proposal: fixed detection of shadowed subvolumes for roles using
separate LVM volume groups for each filesystem (bsc#1174475).
- 4.3.13
- Partitioner: fix stripes size reported for thin LVs.
- Partitioner: do not show stripes size when its value is zero.

==== yast2-sysconfig ====
Version update (4.3.1 -> 4.3.2)

- AutoYaST: Added supplements: autoyast(sysconfig) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.2

==== yast2-tftp-server ====
Version update (4.3.0 -> 4.3.1)

- AutoYaST: Added supplements: autoyast(tftp-server) into the spec file
in order to install this packages if the section has been defined
in the AY configuration file (bsc#1146494).
- 4.3.1

==== yast2-trans ====
Version update (84.87.20200725.1c0c8c4fe3 -> 84.87.20200812.809b1261b7)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en_GB yast2-trans-es yast2-trans-et
yast2-trans-fa yast2-trans-fi yast2-trans-fr yast2-trans-gl yast2-trans-gu
yast2-trans-hi yast2-trans-hr yast2-trans-hu yast2-trans-id yast2-trans-it
yast2-trans-ja yast2-trans-jv yast2-trans-ka yast2-trans-km yast2-trans-ko
yast2-trans-lo yast2-trans-lt yast2-trans-mk yast2-trans-mr yast2-trans-nb
yast2-trans-nl yast2-trans-pa yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR
yast2-trans-ro yast2-trans-ru yast2-trans-si yast2-trans-sk yast2-trans-sl
yast2-trans-sr yast2-trans-sv yast2-trans-ta yast2-trans-th yast2-trans-tr
yast2-trans-uk yast2-trans-vi yast2-trans-wa yast2-trans-xh yast2-trans-zh_CN
yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20200812.809b1261b7:
* Fixed missing new line
* New POT for text domain 'autoinst'.
* New POT for text domain 'autoinst'.
* New POT for text domain 'packager'.
* New POT for text domain 'autoinst'.
* New POT for text domain 'services-manager'.
* New POT for text domain 'security'.
* New POT for text domain 'network'.
* New POT for text domain 'installation'.
* New POT for text domain 'control'.
* New POT for text domain 'autoinst'.
* New POT for text domain 'users'.
* New POT for text domain 'packager'.
* New POT for text domain 'nis'.
* New POT for text domain 'base'.
* Translated using Weblate (Ukrainian)
* Translated using Weblate (Spanish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Persian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Greek)
* Translated using Weblate (Greek)
* Translated using Weblate (Greek)
* Translated using Weblate (Greek)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (French)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Added translation using Weblate (Persian)
* New POT for text domain 'instserver'.
* New POT for text domain 'installation'.
* New POT for text domain 'firstboot'.
* Translated using Weblate (Catalan)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)

==== yast2-users ====
Version update (4.3.6 -> 4.3.7)

- AutoYaST: Added supplements: autoyast(users,groups,user_defaults)
into the spec file in order to install this packages if the
section has been defined in the AY configuration file (bsc#1146494).
- 4.3.7

==== yast2-ycp-ui-bindings ====
Version update (4.3.0 -> 4.3.2)

- Use new syntax (MenuBar(), Menu()) in MenuBar example (bsc#1175115)
- 4.3.2
- Added MenuBar widget (bsc#1175115)
- Require libyui.so.13
- 4.3.1


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages