Mailinglist Archive: opensuse-factory (435 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200713 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Tue, 14 Jul 2020 14:00:24 +0000
  • Message-id: <159473522456.14586.9728727825545020071@go-agent-stagingbot-5>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200713

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
acpica (20200110 -> 20200528)
alsa (1.2.3.1 -> 1.2.3.2)
autoyast2 (4.3.21 -> 4.3.22)
bijiben (3.36.1 -> 3.36.2)
eog (3.36.2 -> 3.36.3)
evince (3.36.6 -> 3.36.7)
evolution (3.36.3 -> 3.36.4)
evolution-data-server (3.36.3 -> 3.36.4)
evolution-ews (3.36.3 -> 3.36.4)
flatpak
gdm
gjs (1.64.3 -> 1.64.4)
glib2 (2.64.3 -> 2.64.4)
gnome-control-center (3.36.3 -> 3.36.4)
gnome-desktop (3.36.3.1 -> 3.36.4)
gnome-maps (3.36.2 -> 3.36.4)
gnome-music (3.36.3 -> 3.36.4.1)
gnome-shell (3.36.3 -> 3.36.4)
libnsl (1.2.0 -> 1.3.0)
libqca-qt5 (2.3.0 -> 2.3.1)
librsvg (2.48.7 -> 2.48.8)
libvirt (6.4.0 -> 6.5.0)
mutter (3.36.3+1 -> 3.36.4)
osinfo-db
php7 (7.4.7 -> 7.4.8)
python-libvirt-python (6.4.0 -> 6.5.0)
xdg-desktop-portal
yast2 (4.3.13 -> 4.3.14)
yast2-sound (4.3.1 -> 4.3.2)

=== Details ===

==== acpica ====
Version update (20200110 -> 20200528)

- Update to version 20200528
ACPICA kernel-resident subsystem:
Removed old/obsolete Visual Studio files which were used to build the
Windows versions of the ACPICA tools. Since we have moved to Visual
Studio 2017, we are no longer supporting Visual Studio 2006 and 2009
project files. The new subdirectory and solution file are located at:
acpica/generate/msvc2017/AcpiComponents.sln
iASL Compiler/Disassembler and ACPICA tools:
* iASL: added support for a new OperationRegion Address Space (subtype):
PlatformRtMechanism. Support for this new keyword is being released for
early prototyping. It will appear in the next release of the ACPI
specification.
* iASL: do not optimize the NameString parameter of the CondRefOf operator.
In the previous iASL compiler release, the NameString parameter of the
CondRefOf was optimized. There is evidence that some implementations of
the AML interpreter do not perform the recursive search-to-parent search
during the execution of the CondRefOf operator. Therefore, the CondRefOf
operator behaves differently when the NameString parameter is a single
name segment (a NameSeg) as opposed to a full NamePath (starting at the
root scope) or a NameString containing parent prefixes.
* iASL: Prevent an inadvertent remark message. This change prevents a
remark if within a control method the following exist:
1) An Operation Region is defined, and
2) A Field operator is defined that refers to the region.
This happens because at the top level, the Field operator does not
actually create a new named object, it simply references the operation
region.
* Removed support for the acpinames utility. The acpinames was a simple
utility used to populate and display the ACPI namespace without executing
any AML code. However, ACPICA now supports executable opcodes outside of
control methods. This means that executable AML opcodes such as If and
Store opcodes need to be executed during table load. Therefore, acpinames
would need to be updated to match the same behavior as the acpiexec
utility and since acpiexec can already dump the entire namespace (via the
'namespace' command), we no longer have the need to maintain acpinames.
* In order to dump the contents of the ACPI namepsace using acpiexec,
execute the following command from the command line:
acpiexec -b "n" [aml files]
- Refresh parches

==== alsa ====
Version update (1.2.3.1 -> 1.2.3.2)
Subpackages: libasound2 libasound2-32bit libatopology2

- Update to alsa-lib 1.2.3.2:
another bug fix release: control namehint fixes, PCM dnsoop fixes,
UCM regression fixes, etc. See the details in
https://www.alsa-project.org/wiki/Changes_v1.2.3.1_v1.2.3.2

==== autoyast2 ====
Version update (4.3.21 -> 4.3.22)
Subpackages: autoyast2-installation

- Move pre-scripts to the autoinit client running them just after
the profile has been processed (bsc#1110413)
- 4.3.22

==== bijiben ====
Version update (3.36.1 -> 3.36.2)
Subpackages: bijiben-lang gnome-shell-search-provider-bijiben

- Update to version 3.36.2:
+ Fixed memory leak in OwnCloud provider.
+ Fixed warnings about signal handler when exiting.
+ Updated translations.

==== eog ====
Version update (3.36.2 -> 3.36.3)
Subpackages: eog-lang

- Update to version 3.36.3:
+ Bug fixes:
- EogThumbView: Fix visible range callback being queued to
often.
- EogJobs: Ensure thumbnail job emits finished signal even if
failed.
+ Updated translations.

==== evince ====
Version update (3.36.6 -> 3.36.7)
Subpackages: evince-lang evince-plugin-comicsdocument
evince-plugin-djvudocument evince-plugin-dvidocument evince-plugin-pdfdocument
evince-plugin-tiffdocument evince-plugin-xpsdocument libevdocument3-4
libevview3-3 nautilus-evince typelib-1_0-EvinceDocument-3_0
typelib-1_0-EvinceView-3_0

- Update to version 3.36.7:
+ pdf: Add back 'de facto' tooltip feature.
+ Updated translations.

==== evolution ====
Version update (3.36.3 -> 3.36.4)
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin
evolution-plugin-text-highlight

- Update to version 3.36.4:
+ Bugs fixed: glgo#GNOME/evolution#963, glgo#GNOME/evolution#969,
glgo#GNOME/evolution#979, glgo#GNOME/evolution#982,
glgo#GNOME/evolution#985.
+ Updated translations.

==== evolution-data-server ====
Version update (3.36.3 -> 3.36.4)
Subpackages: evolution-data-server-lang libcamel-1_2-62 libebackend-1_2-10
libebook-1_2-20 libebook-contacts-1_2-3 libecal-2_0-1 libedata-book-1_2-26
libedata-cal-2_0-1 libedataserver-1_2-24 libedataserverui-1_2-2

- Update to version 3.36.4:
+ camel-folder-search: Fix a memory leak when searching message
body.
+ Rename camel_stream_buffer_truncate() to
camel_stream_buffer_discard_cache().
+ Bugs fixed: glgo#GNOME/evolution-data-server#215,
glgo#GNOME/evolution-data-server#222,
glgo#GNOME/evolution-data-server#226 (CVE-2020-14928),
glgo#GNOME/evolution-data-server#228, glgo#GNOME/evolution#982.
+ Updated translations.

==== evolution-ews ====
Version update (3.36.3 -> 3.36.4)
Subpackages: evolution-ews-lang

- Update to version 3.36.4:
+ camel_ews_folder_new: Remove useless reference on the
CamelSettings.
+ Bugs fixed: glgo#GNOME/evolution#982.
+ Updated translations.

==== flatpak ====
Subpackages: libflatpak0 system-user-flatpak typelib-1_0-Flatpak-1_0

- Fixes for %_libexecdir changing to /usr/libexec

==== gdm ====
Subpackages: gdm-lang gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Fixes for %_libexecdir changing to /usr/libexec

==== gjs ====
Version update (1.64.3 -> 1.64.4)
Subpackages: libgjs0 typelib-1_0-GjsPrivate-1_0

- Update to version 1.64.4:
+ Fix CI failure caused by GTK4 update.

==== glib2 ====
Version update (2.64.3 -> 2.64.4)
Subpackages: glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Update to version 2.64.4:
+ Bugs fixed:glgo#GNOME/GLib#2140, glgo#GNOME/GLib!1507,
glgo#GNOME/GLib!1523, glgo#GNOME/GLib!1547.
+ Updated translations.

==== gnome-control-center ====
Version update (3.36.3 -> 3.36.4)
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Update to version 3.36.4:
+ Sound: Stop non-interactive profile changes from triggering
changed events.
+ Users:
- Don't limit the number of maximum fingerprint enroll stages.
- Don't use sync calls for deleting fingerprints.
- Only load the fingerprint state once.
- Make the fingerprint operations cancellable.
- Don't wait for fprintd on initialization.
+ Updated translations.

==== gnome-desktop ====
Version update (3.36.3.1 -> 3.36.4)
Subpackages: gnome-desktop-lang gnome-version libgnome-desktop-3-19
libgnome-desktop-3_0-common typelib-1_0-GnomeDesktop-3_0

- Update to version 3.36.4:
+ tests: Don't run at build-time.
+ Updated translations.

==== gnome-maps ====
Version update (3.36.2 -> 3.36.4)
Subpackages: gnome-maps-lang

- Update to version 3.36.4:
+ Fix an issue where some search result gets the wrong level of
name.
+ Updated translations.

==== gnome-music ====
Version update (3.36.3 -> 3.36.4.1)
Subpackages: gnome-music-lang

- Update to version 3.36.4.1:
+ Fix a showstopper bug in 3.36.4
- Update to version 3.36.4:
+ Bugs fixed:
- pauseonsuspend: Fix calls to MusicLogger.warning().
- Duplication of menu bar.
+ Updated translations.

==== gnome-shell ====
Version update (3.36.3 -> 3.36.4)
Subpackages: gnome-shell-calendar gnome-shell-lang

- Update to version 3.36.4:
+ Hide switch-user button on lock screen if unsupported.
+ Improve world clocks styling.
+ Improve calendar-server performance.
+ Fix regressions in redesigned modal dialogs.
+ Better support sandboxed apps with multiple .desktop files.
+ Fix on-screen keyboard size in portrait orientation.
+ Support scrolling anywhere in slider menu items.
+ Fixed crash.
+ Plugged leaks.
+ Misc. bug fixes and cleanups.
+ Updated translations.
- Drop patch fixed upstream:
+ gnome-shell-disable-screensaver-user-switch-when-remote.patch

==== libnsl ====
Version update (1.2.0 -> 1.3.0)
Subpackages: libnsl2 libnsl2-32bit

- Update to version 1.3.0
- Cleanup to support new gettext, libtool, automake, ...
- Try to detect recursive NIS calls
- Fix SRPM group and word choice in description.

==== libqca-qt5 ====
Version update (2.3.0 -> 2.3.1)
Subpackages: libqca-qt5-plugins

- Update to 2.3.1
* fixes memleaks and crashes

==== librsvg ====
Version update (2.48.7 -> 2.48.8)
Subpackages: gdk-pixbuf-loader-rsvg librsvg-2-2 librsvg-lang rsvg-thumbnailer
typelib-1_0-Rsvg-2_0

- Update to version 2.48.8:
+ Compute 'bolder' and 'lighter' font-weight correctly.

==== libvirt ====
Version update (6.4.0 -> 6.5.0)
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- Update to libvirt 6.5.0
- The node device driver now supports creating mediated devices
using the mdevctl utility
- Many incremental improvements and bug fixes, see
https://libvirt.org/news.html
- Dropped patches:
ec07aad8-libxl-normalize-mac-addr.patch

==== mutter ====
Version update (3.36.3+1 -> 3.36.4)
Subpackages: libmutter-6-0 mutter-data mutter-lang

- Update to version 3.36.4:
+ Fix crash on area screenshots with fractional scaling.
+ Do not paint textures of fully obscured windows.
+ Turn off CRTCs as well when enabling DPMS.
+ Improve selection support.
+ Use a more appropriate combine function on opaque areas.
+ Fix remote desktop being broken without screencast session.
+ Fix popovers disappearing on wayland and HiDPI.
+ Fixed crashes.
+ Plugged memory leaks.
+ Misc. bug fixes and cleanups.

==== osinfo-db ====

- Add fix-tumbleweed-order.patch: ensure x86_64 is listed before
i686, to have x86_64 selected by default in GNOME Boxes
- Update url with gitlab home for osinfo-db.

==== php7 ====
Version update (7.4.7 -> 7.4.8)
Subpackages: apache2-mod_php7 php7-ctype php7-dom php7-gd php7-gettext
php7-iconv php7-json php7-mbstring php7-mysql php7-pdo php7-sqlite
php7-tokenizer php7-xmlreader php7-xmlwriter

- updated to 7.4.8: This is a security release which also contains
several bug fixes. See https://www.php.net/ChangeLog-7.php#7.4.8
- Use /run/php-fpm instead of /run/php
- modified sources
% php-fpm.tmpfiles.d
- do not install %{_tmpfilesdir}, %{_tmpfilesdir}/php-fpm.conf in
test favour
- added tmpfiles.d for php-fpm to provide a base base for a socket
(boo#1173786)

==== python-libvirt-python ====
Version update (6.4.0 -> 6.5.0)

- Update to 6.5.0
- Add all new APIs and constants in libvirt 6.5.0

==== xdg-desktop-portal ====
Subpackages: xdg-desktop-portal-lang

- Fixes for %_libexecdir changing to /usr/libexec

==== yast2 ====
Version update (4.3.13 -> 4.3.14)
Subpackages: yast2-logs

- Make CFA::MultiFileConfig fully reusable (related to bsc#1155735,
and bsc#1157541).
- add space to SPACE_CHARS (bsc#1173907)
- 4.3.14

==== yast2-sound ====
Version update (4.3.1 -> 4.3.2)

- Only record the first 2 numbers of kernel version (boo#1173918)
- 4.3.2


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages