Mailinglist Archive: opensuse-factory (352 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200603 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Fri, 05 Jun 2020 09:00:34 +0000
  • Message-id: <159134763402.2896.958724555544894807@go-agent-stagingbot-7>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200603

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
cryptsetup (2.3.1 -> 2.3.3)
exim (4.93.0.4 -> 4.94)
ffmpeg-4
gptfdisk (1.0.4 -> 1.0.5)
haveged (1.9.4 -> 1.9.8)
irqbalance (1.6.0+git20190711.f7fdebb -> 1.6.0+git20200317.0348a3b)
judy
kcmutils
kdeconnect-kde
kdevelop5 (5.5.1 -> 5.5.2)
kirigami2
kmod (26 -> 27)
libdlm
libdrm (2.4.101 -> 2.4.102)
libreoffice (6.4.3.2 -> 6.4.4.2)
libsolv (0.7.13 -> 0.7.14)
libzypp (17.23.4 -> 17.23.5)
lvm2
lvm2-device-mapper
mariadb-connector-c (3.1.7 -> 3.1.8)
open-vm-tools
opie
perl-Mojolicious (8.50 -> 8.51)
perl-Net-DNS (1.23 -> 1.24)
perl-TimeDate (2.32 -> 2.33)
rp-pppoe (3.13 -> 3.14)
skopeo (0.2.0 -> 1.0.0)
sonnet
tnftp
xawtv
xf86-input-synaptics

=== Details ===

==== cryptsetup ====
Version update (2.3.1 -> 2.3.3)
Subpackages: cryptsetup-lang libcryptsetup12 libcryptsetup12-32bit
libcryptsetup12-hmac

- Update to 2.3.3:
* Fix BitLocker compatible device access that uses native 4kB
sectors
* Support large IV count (--iv-large-sectors) cryptsetup option
for plain device mapping
* Fix a memory leak in BitLocker compatible handling
* Allow EBOIV (Initialization Vector algorithm) use
* LUKS2: Require both keyslot cipher and key size option, do
not fail silently
- includes changes from 2.3.2:
* Add option to dump content of LUKS2 unbound keyslot
* Add support for discards (TRIM) for standalone dm-integrity
devices (Kernel 5.7) via --allow-discards, not for LUKS2
* Fix cryptsetup-reencrypt to work on devices that do not allow
direct-io device access.
* Fix a crash in the BitLocker-compatible code error path
* Fix Veracrypt compatible support for longer (>64 bytes)
passphrases

==== exim ====
Version update (4.93.0.4 -> 4.94)

- update to exim 4.94
* some transports now refuse to use tainted data in constructing their
delivery
location
this WILL BREAK configurations which are not updated accordingly.
In particular: any Transport use of $local_user which has been relying upon
check_local_user far away in the Router to make it safe, should be updated
to
replace $local_user with $local_part_data.
* Attempting to remove, in router or transport, a header name that ends with
an asterisk (which is a standards-legal name) will now result in all headers
named starting with the string before the asterisk being removed.

==== ffmpeg-4 ====
Subpackages: libavcodec58 libavdevice58 libavfilter7 libavformat58
libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5

- libfdk-aac is now .so.2, not .so.1.

==== gptfdisk ====
Version update (1.0.4 -> 1.0.5)

- Update to 1.0.5
* Changed number of columns in type code output ("sgdisk -L"
and equivalents in gdisk and cgdisk) from 3 to 2, since some
descriptions are long enough that they are ambiguous with
three columns.
* You can now put the 0xEE partition last in a hybrid MBR using
sgdisk. (Previously, this was possible with gdisk but not
with sgdisk.) See the sgdisk man page for details.
* Added numerous type codes for Container Linux, Veracrypt, and
Freedesktop.org's Discoverable Partitions Specification
* Partition type name searches are now case-insensitive.
* It is now possible to quit out of partition type name
searches by typing "q".
* When changing a partition type code, the default is now the
current type code, not a platform-specific type code.

==== haveged ====
Version update (1.9.4 -> 1.9.8)
Subpackages: libhavege1

- Update to version 1.9.8:
* Fix for Unresolved symbol error_exit in libhavege #20 by pld-gitsync [Jirka
Hladky]
* order after systemd-tmpfiles-setup-dev.service (origin/pr/21) [Christian
Hesse]
* use systemd security features [Christian Hesse]
* do not run in container [Christian Hesse]
* do not use carriage return in line break [Christian Hesse]
* Fixed invalid UTF-8 codes in ChangeLog [Jirka Hladky]
- Changes for version 1.9.5:
* Added test for /dev/random symlink [Jirka Hladky]
* Update to automake 1.16 [Jirka Hladky]
* Fix segv at start [Andrew]
* Fixed built issue on Cygwin [jbaker6953]
* Fix segfault on arm machines (origin/pr/7) [Natanael Copa]
* init.d/Makefile.am - add missing dependency [Jackie Huang]
* service.redhat - update PIDFile [Pierre-Jean Texier]
* Fix type mismatch in get_poolsize [Andreas Schwab]
* Fixup upstream changelog [Nicolas Braud-Santoni]
* Remove support for CPUID on ia64 (origin/pr/19) [Jeremy Bobbio]
* Output some progress during CUSUM and RANDOM EXCURSION test [Sven Hartge]
* Diagnostics capture mode now works correctly [Ethan Rahn]
- Drop upstream patches:
* f2193587.patch
* get-poolsize.patch

==== irqbalance ====
Version update (1.6.0+git20190711.f7fdebb -> 1.6.0+git20200317.0348a3b)
Subpackages: irqbalance-ui

- Update to latest git HEAD version 0348a3b.
There has been no version update for quite some time, but some
restructuring and fixes we want to have included.
D install-man-pages.patch

==== judy ====

- run spec-cleaner

==== kcmutils ====
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update Fix-crash-when-loading-external-app.patch to last version
that actually was committed upstream
- Add upstream patches to fix loading normal settings modules that
got broken by the previous fix (kde#421898), and add unit tests:
* Rename-KCModuleInfo-unittest-and-extend-it-with-fake-KCM.patch
* Add-test-for-a-normal-KCM-with-desktop-file.patch
* Repair-kcmshell5-after-previous-commits.patch
* Port-these-two-to-KCModuleInfo_property-as-well.patch
- Add Fix-crash-when-loading-external-app.patch to fix loading the
Yast entry in systemsettings (boo#1171916, kde#421566)

==== kdeconnect-kde ====
Subpackages: kdeconnect-kde-lang kdeconnect-kde-zsh-completion

- Add patch submitted upstream to use
ecm_qt_declare_logging_category so users can easily modify the
debugging configuration and use a default logging level of
Warning instead of sending all debug messages to the log:
* 0001-Use-ecm_qt_declare_logging_category-to-declare-the-l.patch

==== kdevelop5 ====
Version update (5.5.1 -> 5.5.2)
Subpackages: kdevelop5-lang kdevplatform kdevplatform-lang libkdevplatform55

- Update to 5.5.2
* Remove plugin "kde repo provider" due to defunct service
* Fix extra margins around config pages

==== kirigami2 ====
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Add patch to fix PlaceholderMessage with Qt 5.12:
* fix-import-in-PlaceholderMessage.patch

==== kmod ====
Version update (26 -> 27)
Subpackages: kmod-compat libkmod2

- Update to release 27
* Link to libcrypto rather than requiring openssl.
* Use PKCS#7 instead of CMS for parsing module signature to be
compatible with LibreSSL and OpenSSL < 1.1.0.
* Teach modinfo to parse modules.builtin.modinfo. When using
Linux kernel >= v5.2~rc1, it is possible to get module
information from this new file.

==== libdlm ====
Subpackages: libdlm3

- Support uint64_t corosync ringid (bsc#1168771)
* add cluster-ringid-seq.patch

==== libdrm ====
Version update (2.4.101 -> 2.4.102)
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2
libdrm_radeon1

- upgrade to version 2.4.102
* lots of FreeBSD and modetest stuff

==== libreoffice ====
Version update (6.4.3.2 -> 6.4.4.2)
Subpackages: libreoffice-base libreoffice-base-drivers-firebird
libreoffice-calc libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-l10n-es
libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru
libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
libreofficekit

- Fix bsc#1146025 - LO-L3: Colored textboxes in PPTX look very odd (SmartArt)
* bsc1146025.diff
- Fix bsc#1165849 - LO-L3: Shadow size for rectangle is only a fraction of
Office 365
* bsc1165849-1.diff
* bsc1165849-2.diff
* bsc1165849-3.diff
- Update to 6.4.4.2:
* 6.4.4 release
- Remove merged patch bsc1160687-1.diff

==== libsolv ====
Version update (0.7.13 -> 0.7.14)
Subpackages: libsolv-devel libsolv-tools python3-solv ruby-solv

- Support blacklisted packages in solver_findproblemrule()
[bnc#1172135]
- Support rules with multiple negative literals in choice rule
generation
- bump version to 0.7.14

==== libzypp ====
Version update (17.23.4 -> 17.23.5)

- Enable zchunk on SLE-15-SP2.
- Older kernel-devel packages are not properly purged (bsc#1171224)
- doc: enhance service plugin example.
- version 17.23.5 (22)

==== lvm2 ====
Subpackages: liblvm2cmd2_03

- removing LVM cache with cache volume does not remove the cache volume
(bsc#1171907)
+ bug-1171907-lvremove-remove-attached-cachevol-with-removed-LV.patch

==== lvm2-device-mapper ====
Subpackages: device-mapper libdevmapper-event1_03 libdevmapper1_03
libdevmapper1_03-32bit

- removing LVM cache with cache volume does not remove the cache volume
(bsc#1171907)
+ bug-1171907-lvremove-remove-attached-cachevol-with-removed-LV.patch

==== mariadb-connector-c ====
Version update (3.1.7 -> 3.1.8)

- Update to release 3.1.8 [bsc#1171550]
* CONC-304: Rename the static library to libmariadb.a and other
libmariadb files in a consistent manner
* CONC-441: Default user name for C/C is wrong if login user
is different from effective user
* CONC-449: Check $MARIADB_HOME/my.cnf in addition to
$MYSQL_HOME/my.cnf
* CONC-457: mysql_list_processes crashes in unpack_fields
* CONC-458: mysql_get_timeout_value crashes when used improperly
* CONC-464: Fix static build for auth_gssapi_client plugin
* Fixes for the following security vulnerabilities:
CVE-2020-13249
- refresh absolute_path_fix.patch and private_library.patch

==== open-vm-tools ====
Subpackages: libvmtools0 open-vm-tools-desktop

- While updating to 11.1.0 (build 16036546) (boo#1171764) hold off on
producing the open-vm-tools-sdmp (boo#1171765 Service Discover plugin)
until it has gone through the ECO process. Once approved, will resubmit
to include the plugin.

==== opie ====
Subpackages: opie-32bit

- allso apply permissions macros to /etc/opiekeys

==== perl-Mojolicious ====
Version update (8.50 -> 8.51)

updated to 8.51
see /usr/share/doc/packages/perl-Mojolicious/Changes
8.51 2020-05-30
- Improved map efficiency in Mojo::Promise. (mst)
- Improved more tests to use subtests. (veesh)
- Improved .perltidyrc with more modern settings.

==== perl-Net-DNS ====
Version update (1.23 -> 1.24)

updated to 1.24
see /usr/share/doc/packages/perl-Net-DNS/Changes

==== perl-TimeDate ====
Version update (2.32 -> 2.33)

updated to 2.33
see /usr/share/doc/packages/perl-TimeDate/ChangeLog
2.33 -- Wed May 19 11:34:00 MT 2020
* Remove PAX Headers in tarball using GNU tar

==== rp-pppoe ====
Version update (3.13 -> 3.14)

- Refresh spec-file via spec-cleaner and manual optimisations.
* Add make_build and autopatch macros.
* Remove group tag and obsoleted conditions.
- Refresh and rename patches:
* docdir.diff to rp-pppoe-3.14-docdir.patch
* nonrfc-modems.diff to rp-pppoe-3.14-nonrfc-modems.patch
* release-buildsystem.diff to rp-pppoe-3.14-release-buildsystem.patch
* resolve-conf.diff to rp-pppoe-3.14-resolve-conf.patch
* rp-pppoe-3.10-config.patch to rp-pppoe-3.14-config.patch
* rp-pppoe-3.10-init.patch to rp-pppoe-3.14-init.patch
* rp-pppoe-pie.patch to rp-pppoe-3.14-pie.patch
* strip.diff to rp-pppoe-3.14-strip.patch
- Update to 3.14
* Add -H and -M options for sending HURL and MOTM packets respectively.
* Change VERSION macro to RP_VERSION to avoid conflict with pppd macro.

==== skopeo ====
Version update (0.2.0 -> 1.0.0)

- Update to skopeo v1.0.0:
* Add skopeo Login from c/common
* Add skopeo login&logout
* Add Security Policy
* Add tests for using signatures with mirrors
* Update c/image for containers/image#912
* Use cobra in skopeo
* Update containers/image to v5.4.4
* Bump github.com/containers/storage from 1.18.2 to 1.19.0
* v0.11.2 containers/common

==== sonnet ====
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Support spell checking for Finnish using Voikko in the
sonnet-voikko package (boo#1172245)

==== tnftp ====

- tnftp ssl client should validate hostnames and certificates,
so for example tnftp -d https://revoked.badssl.com/example
fails to connect. (tnftp-verify_hostname.patch), There are
at least two reports about this misbehaviour online but it has
never been fixed. Patch targets openSSL 1.1.x and later
so specify requirement in spec file.

==== xawtv ====
Subpackages: pia tv-common v4l-conf

- add gcc-10.patch: fixes multiple definitions of global variables across the
code. These cause errors with new major gcc 10 version.
- v4l-conf: add v4l-conf-fix-CVE-2020-13696.patch: fix security issue in
setuid-root program that allows for arbitrary file existence tests and
open() with O_RDWR (bsc#1171655, CVE-2020-13696)

==== xf86-input-synaptics ====

- devel package: removed requires to main package, since it's not
required at all for development (boo#1172153)


N�����r��y隊Z)z{.���r�+�맲��r��z�^�ˬz��N�(�֜��^� ޭ隊Z)z{.���r�+��0�������Ǩ�
< Previous Next >
This Thread
  • No further messages