Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200319 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 22 Mar 2020 14:00:26 +0000
  • Message-id: <158488562660.7989.17918966544750473411@go-agent-stagingbot-6>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200319

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.9.27 -> 7.0.10.0)
attica-qt5 (5.67.0 -> 5.68.0)
baloo5 (5.67.0 -> 5.68.0)
bluez-qt (5.67.0 -> 5.68.0)
breeze5-icons (5.67.0 -> 5.68.0)
frameworkintegration (5.67.0 -> 5.68.0)
gpsd
hplip
icewm
icewm-theme-branding
kactivities-stats (5.67.0 -> 5.68.0)
kactivities5 (5.67.0 -> 5.68.0)
karchive (5.67.0 -> 5.68.0)
kauth (5.67.0 -> 5.68.0)
kbookmarks (5.67.0 -> 5.68.0)
kcalendarcore (5.67.0 -> 5.68.0)
kcmutils (5.67.0 -> 5.68.0)
kcodecs (5.67.0 -> 5.68.0)
kcompletion (5.67.0 -> 5.68.0)
kconfig (5.67.0 -> 5.68.0)
kconfigwidgets (5.67.0 -> 5.68.0)
kcontacts (5.67.0 -> 5.68.0)
kcoreaddons (5.67.0 -> 5.68.0)
kcrash (5.67.0 -> 5.68.0)
kdbusaddons (5.67.0 -> 5.68.0)
kdeclarative (5.67.0 -> 5.68.0)
kded (5.67.0 -> 5.68.0)
kdelibs4support (5.67.0 -> 5.68.0)
kdesu (5.67.0 -> 5.68.0)
kdnssd-framework (5.67.0 -> 5.68.0)
kdoctools (5.67.0 -> 5.68.0)
kemoticons (5.67.0 -> 5.68.0)
kfilemetadata5 (5.67.0 -> 5.68.0)
kglobalaccel (5.67.0 -> 5.68.0)
kguiaddons (5.67.0 -> 5.68.0)
kholidays (5.67.0 -> 5.68.0)
khtml (5.67.0 -> 5.68.0)
ki18n (5.67.0 -> 5.68.0)
kiconthemes (5.67.0 -> 5.68.0)
kidletime (5.67.0 -> 5.68.0)
kimageformats (5.67.0 -> 5.68.0)
kinit (5.67.0 -> 5.68.0)
kio (5.67.0 -> 5.68.0)
kirigami2 (5.67.0 -> 5.68.0)
kitemmodels (5.67.0 -> 5.68.0)
kitemviews (5.67.0 -> 5.68.0)
kjobwidgets (5.67.0 -> 5.68.0)
kjs (5.67.0 -> 5.68.0)
knewstuff (5.67.0 -> 5.68.0)
knotifications (5.67.0 -> 5.68.0)
knotifyconfig (5.67.0 -> 5.68.0)
kpackage (5.67.0 -> 5.68.0)
kparts (5.67.0 -> 5.68.0)
kpeople5 (5.67.0 -> 5.68.0)
kplotting (5.67.0 -> 5.68.0)
kpty (5.67.0 -> 5.68.0)
kquickcharts (5.67.0 -> 5.68.0)
kross (5.67.0 -> 5.68.0)
krunner (5.67.0 -> 5.68.0)
kservice (5.67.0 -> 5.68.0)
ktexteditor (5.67.0 -> 5.68.0)
ktextwidgets (5.67.0 -> 5.68.0)
kunitconversion (5.67.0 -> 5.68.0)
kwallet (5.67.0 -> 5.68.0)
kwayland (5.67.0 -> 5.68.0)
kwidgetsaddons (5.67.0 -> 5.68.0)
kwindowsystem (5.67.0 -> 5.68.0)
kxmlgui (5.67.0 -> 5.68.0)
libKF5ModemManagerQt (5.67.0 -> 5.68.0)
libKF5NetworkManagerQt (5.67.0 -> 5.68.0)
libgsasl
libkcddb
libmfx
libqmi (1.24.6 -> 1.24.8)
libreoffice (6.4.2.1 -> 6.4.2.2)
makedumpfile
moonjit (2.1.2 -> 2.2.0)
nodejs12
oxygen5-icon-theme (5.67.0 -> 5.68.0)
plasma-framework (5.67.0 -> 5.68.0)
prison-qt5 (5.67.0 -> 5.68.0)
purge-kernels-service
purpose (5.67.0 -> 5.68.0)
python-publicsuffix (1.1.0 -> 1.1.1)
qqc2-desktop-style (5.67.0 -> 5.68.0)
rpm
salt
schily
solid (5.67.0 -> 5.68.0)
sonnet (5.67.0 -> 5.68.0)
sssd
sudo (1.8.31 -> 1.8.31p1)
syndication (5.67.0 -> 5.68.0)
syntax-highlighting (5.67.0 -> 5.68.0)
texlive
threadweaver (5.67.0 -> 5.68.0)
vim
virtualbox
yast2-samba-client (4.2.2 -> 4.2.3)
zimg

=== Details ===

==== ImageMagick ====
Version update (7.0.9.27 -> 7.0.10.0)
Subpackages: ImageMagick-config-7-SUSE ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI7 libMagickWand-7_Q16HDRI7 perl-PerlMagick

- version update to 7.0.10.0
* Label text no longer gets cut-off (reference
https://imagemagick.org/discourse-server/viewtopic.php?f=1&t=37621).
* Prevent heap overflow (reference
https://github.com/ImageMagick/ImageMagick/issues/1857).

==== attica-qt5 ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Attica5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. They reverted change error() to socketError
* Attica: Convert license statements to SPDX markers
* Use ecm_qt_install_logging_categories over manual categories file
* Add a default provider (as per documentation)

==== baloo5 ====
Version update (5.67.0 -> 5.68.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* [FileContentIndexer] Remove duplicate condition check for loop break
* [ModifiedFileIndexer] Correct time checks for new files
* [ModifiedFileIndexer] Omit BasicIndexingJob run when not required
* [tools] Clean up messed up whitespace
* Fix minor EBN issues (http->https)
* Extract messages from header file as well
* Sync IndexerConfig on exit (kde#417127)
* Use ecm_qt_install_logging_categories over manual categories file
* [FileIndexScheduler] Force evaluation of indexerState after suspend/resume
- Drop upstream patches:
* 0001-FileIndexScheduler-Force-evaluation-of-indexerState-.patch
* Sync-IndexerConfig-on-exit.patch

==== bluez-qt ====
Version update (5.67.0 -> 5.68.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Fix errors in the QRegularExpression porting commit
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Use ecm_qt_install_logging_categories over manual categories file
* Convert license statements to SPDX

==== breeze5-icons ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Too many changes since 5.67.0, only listing bugfixes:
* [breeze-icons] Add telegram-desktop tray icons (kde#417583)
* New icon for KTimeTracker (kde#410708)

==== frameworkintegration ====
Version update (5.67.0 -> 5.68.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* [KStyle] Set the color of KMessageWidgets to the correct one from the
current color scheme

==== gpsd ====

- Allow building without python2 available

==== hplip ====
Subpackages: hplip-hpijs hplip-sane

- Use LSB fallback if distro determination fails (bsc#1166623)
* Add patch: Use-lsb_release-fallback-code-if-import-distro-fails.patch
- Removed python3-distro dependency again, not necessary any more.
- Recommend python3-distro (boo#1166623)

==== icewm ====
Subpackages: icewm-config-upstream icewm-default icewm-lang icewm-lite

- Improve build tag consistency between SLE and Leap.
* Recommend polkit-gnome to both Leap and SLE.
* Disable icewm-preferences.patch for Leap. The patch makes sense
to icewm-config-upstream while Leap uses icewm-theme-branding
the provide the theme.

==== icewm-theme-branding ====

- Improve build tag consistency between SLE and Leap.
* Build the branding package separately for openSUSE and SLE,
like most of other branding packages did.

==== kactivities-stats ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kactivities5 ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Fix issue finding the Boost include directories
* Make it compile against qt5.15. (QProcess::startDetached(QString) is
deprecated)
* Use exposed DBus methods to switch activities in CLI
* Use ecm_qt_install_logging_categories over manual categories file

==== karchive ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file
* Convert license statements to SPDX headers

==== kauth ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang libKF5AuthCore5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* [KAuth] Add support for action details in Polkit1 backend.
* Use ecm_qt_install_logging_categories over manual categories file
* [policy-gen] Fix the code to actually use the correct capture group
* Drop Policykit backend
* [polkit-1] Simplify Polkit1Backend action exists lookup
* [polkit-1] Return an error status in actionStatus if there is an error
* Calculate KAuthAction::isValid on demand
* Be more helpfully verbose when we can't start an action

==== kbookmarks ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Rename actions to be consistent
* Use ecm_qt_install_logging_categories over manual categories file

==== kcalendarcore ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Fix mismatching iterator types
* Update visibility cache when notebook visibility is changed
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* KCalendarCore: Convert license statements to SPDX markers
* Use ecm_qt_install_logging_categories over manual categories files
* Port QRegExp to QRegularExpression

==== kcmutils ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Check activeModule before using it (kde#417396)
- Drop Check-activeModule-before-using-it.patch

==== kcodecs ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kcompletion ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kconfig ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Too many changes since 5.67.0, only listing bugfixes:
* [KConfigGui] Clear styleName font property for Regular font styles
(kde#378523)
* Fix code generation for entries with min/max (kde#418146)

==== kconfigwidgets ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file
* Change "Redisplay" to "Refresh"
* Remove old code that is not used anymore

==== kcontacts ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Use ecm_qt_install_logging_categories over manual categories files

==== kcoreaddons ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file
* add hint that QIcon can be used as a program logo

==== kcrash ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Use ecm_qt_install_logging_categories over manual categories file

==== kdbusaddons ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Deprecate KDBusConnectionPool
* KDbusAddons: Convert license statement to SPDX
* Use ecm_qt_install_logging_categories over manual categories file
* Use a less convoluted way to check if it's in flatpak

==== kdeclarative ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Expose capture signal on KeySequenceItem
* Fix size of the header in GridViewKCM (kde#417347)
* Allow ManagedConfigModule derived class to register explicitly
KCoreConfigSkeleton.
* Allow to use KPropertySkeletonItem in ManagedConfigModule
* respect header's visibility

==== kded ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kded-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Add a --replace option to kded5
* Use ecm_qt_install_logging_categories over manual categories file

==== kdelibs4support ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kdesu ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kdnssd-framework ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* KDNSSD: Convert license headers to SPDX statements

==== kdoctools ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.

==== kemoticons ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kfilemetadata5 ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kfilemetadata5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kglobalaccel ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against last qt5.15 without deprecated method.
QProcess::execute(QString) is deprecated
* Use ecm_qt_install_logging_categories over manual categories file

==== kguiaddons ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* [UrlHandler] Handle opening the online docs for KCM modules
* KGuiAddons: Convert license headers to SPDX statements
* [KColorUtils] Change getHcy() hue range to [0.0, 1.0)
* [KColorUtils] Add hue(), chroma(), hcyColor() and update documentation

==== kholidays ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* KHolidays: Convert license statements to SPDX expressions
* Update Japanese holidays
* holiday_jp_ja - fix spelling for National Foundation Day (kde#417498)
* Fix compile: no target named KF5KHolidays

==== khtml ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== ki18n ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Support Qt 5.14 on Android
* Use ecm_qt_install_logging_categories over manual categories files

==== kiconthemes ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kidletime ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kimageformats ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kimageformats-eps

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kinit ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kinit-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Make kwrapper/kshell spawn klauncher5 if needed
* Use ecm_qt_install_logging_categories over manual categories file

==== kio ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kio-core kio-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Too many changes since 5.67.0, only listing bugfixes:
* [KFileFilterCombo] Don't add invalid QMimeType to mimes filter (kde#417355)
* Fix running konsole on Wayland (kde#408497)
* KIO::iconNameForUrl: fix searching for kde protocol icons (kde#417922)
* Change "AutoSkip" to "Skip All" (kde#416964)
* [KOpenWithDialog] Automatically select the result if the model filter has
only one match (kde#400725)

==== kirigami2 ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Too many changes since 5.67.0, only listing bugfixes:
* Icon: fix rendering of image: urls on High DPI (kde#417647)
* Do not crash when icon's width or height is 0 (kde#417844)
* properly sync size hints with state machine (kde#417351)
- Drop 0001-make-headerParent-correctly-alignedwhen-there-is-a-s.patch

==== kitemmodels ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* KRearrangeColumnsProxyModel: temporarily disable assert due to QTreeView bug
* Add missing license header in previous commit
* KRearrangeColumnsProxyModel: reset in setSourceColumns()
* KItemModels: Convert license headers to SPDX markers
* Use ecm_qt_install_logging_categories over manual categories file
* Revert early return on setFilterRole
* Move Plasma's SortFilterProxyModel into KItemModel's QML plugin

==== kitemviews ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kjobwidgets ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kjs ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Expose the evaluation timeout management functions in public API.

==== knewstuff ====
Version update (5.67.0 -> 5.68.0)
Subpackages: knewstuff-imports libKF5NewStuff5 libKF5NewStuff5-lang
libKF5NewStuffCore5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Fix clicking thumb-only delegate (kde#418368)
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::. + they
reverted error() -> networkError()
* Fix scrolling on the EntryDetails page (kde#418191)
* Don't double delete CommentsModel (kde#417802)
* Make it compile against last qt5.15 without deprecated method.
QProcess::execute(QString) is deprecated
* Cover also the qtquick plugin in the installed categories file
* Use ecm_qt_install_logging_categories over manual categories file
* Use the right translation catalog to show translations
* Fix the KNSQuick Dialog's close title and basic layout (kde#415606)

==== knotifications ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Fix config include
* Make kstatusnotifieritem available without dbus
* Adapt action numbering in Android to work like in KNotifications
* Fix minor EBN issues and typos
* Have kai the knotifications maintainer
* Always strip html if server does not support it
* Use ecm_qt_install_logging_categories over manual categories file
* [android] Emit defaultActivated when tapping the notification

==== knotifyconfig ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kpackage ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kpackage-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== kparts ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* templates: Convert license statements to SPDX headers

==== kpeople5 ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kpeople5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file
* fix pri file generation

==== kplotting ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* KPlotting: Convert license statements to SPDX

==== kpty ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kquickcharts ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Too many changes to list here.

==== kross ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kross-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Qt5::UiTools is not optional in this module

==== krunner ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* templates: Convert license statements to SPDX headers
* Use ecm_qt_install_logging_categories over manual categories file

==== kservice ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kservice-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* New query mechanism for applications: KApplicationTrader

==== ktexteditor ====
Version update (5.67.0 -> 5.68.0)
Subpackages: ktexteditor-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* templates: Convert license statements to SPDX headers
* Remove duplicate include
* README.md: fix example code & code markup
* Fix minor EBN issues (http->https)
* Make it compile against last qt5.15 without deprecated method.
QOverload<int>::of(&QComboBox::currentIndexChanged) is deprecated
* Add an option to dynamic-break inside words
* Use ecm_qt_install_logging_categories over manual categories file
* KateModeMenuList: don't overlap the scroll bar

==== ktextwidgets ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- No code change since 5.67.0

==== kunitconversion ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. They reverted change error() to socketError

==== kwallet ====
Version update (5.67.0 -> 5.68.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Use ecm_qt_install_logging_categories over manual categories file

==== kwayland ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Add application menu dbus paths to org_kde_plasma_window interface
* Registry: don't destroy the callback on globalsync
* Use ecm_qt_install_logging_categories over manual categories file
* [surface] Fix buffer offset when attaching buffers to surfaces

==== kwidgetsaddons ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* [KMessageWidget] Allow the style to change our palette
* [KMessageWidget] Draw it with QPainter instead of using stylesheet
* Slightly reduce level 1 heading size

==== kwindowsystem ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Use ecm_qt_install_logging_categories over manual categories file

==== kxmlgui ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against q5.15. They reverted commit about error() vs
networkerror()
* Port QLinkedList which is deprecated in qt5.15
* Port QProcess::start(...) deprecated method (qt5.15)
* Use ecm_qt_install_logging_categories over manual categories file

==== libKF5ModemManagerQt ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* modemmanager-qt: Convert license headers to SPDX expressions
* Drop qmake pri file generation & installation, currently broken
* Use ecm_qt_install_logging_categories over manual categories file

==== libKF5NetworkManagerQt ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Support SAE in securityTypeFromConnectionSetting
* Drop qmake pri file generation & installation, currently broken
* Use ecm_qt_install_logging_categories over manual categories file

==== libgsasl ====
Subpackages: libgsasl-lang libgsasl7

- Re-enable GSSAPI by explicitly choosing mit kerberos.

==== libkcddb ====
Subpackages: libKF5Cddb5 libkcddb-lang

- Add Switch-from-freedb.org-to-gnudb.org.patch to use gnudb.org by
default, freedb.org will be shutdown at the end of March
(kde#418421)

==== libmfx ====
Subpackages: libmfx1

- u_buildfix-for-gcc10.patch
* fixes build against gcc10 (boo#1166609)

==== libqmi ====
Version update (1.24.6 -> 1.24.8)
Subpackages: libqmi-glib5 libqmi-tools

- Update to version 1.24.8:
libqmi-glib:
* Fixed string reading logic to avoid critical memory leak.
* Improved logic to fallback to GSM7 or UCS2, by making sure that
the UTF-8 string validation doesn't consider non-printable
characters.
* Several other minor improvements and fixes.

==== libreoffice ====
Version update (6.4.2.1 -> 6.4.2.2)
Subpackages: libreoffice-base libreoffice-base-drivers-firebird
libreoffice-calc libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-l10n-es
libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru
libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
libreofficekit

- Update to 6.4.2.2:
* 6.4.2 RC2 release

==== makedumpfile ====

- makedumpfile-arm64-VA-range-SUSE.patch: Fix error processing core files on
arm64 (bsc#1142715).

==== moonjit ====
Version update (2.1.2 -> 2.2.0)

- No need to namespace luajit with update-alternatives, we really
want just one version of it to be provided to keep things
simple
- Update to 2.2.0:
* The v2.2 release of moonjit brings many new features that bring the
project closer to its aim of unifying LuaJIT forks and compatibility
with Lua.
- Do not suffix the version anymore as we support all lua variants,
removes the patch:
* luajit-lua-versioned.patch

==== nodejs12 ====
Subpackages: nodejs12-devel npm12

- openssl_rand_regression.patch: Add getrandom syscall definition
for all Linux platforms. This fixes a runtime error in SLE-12
(bnc#1162117)

==== oxygen5-icon-theme ====
Version update (5.67.0 -> 5.68.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Support data-error/warning/information also in 32,46,64,128 sizes
* Add "plugins" action item, to match Breeze icons
* Add status icons: data-error, data-warning, data-information

==== plasma-framework ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Too many changes since 5.67.0, only listing bugfixes:
* Try to apply the colorscheme of the current theme to QIcons (kde#417780)
* Remove hardcoded colors (kde#417511)
* Construct NullEngine with KPluginMetaData() (kde#417548)
* Don't warn for invalid plugin metata (kde#412464)
- Drop Try-to-apply-the-colorscheme-of-the-current-theme-to-QIcons.patch

==== prison-qt5 ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Remove empty/unused private classes on internal types
* Fix pri file to not fail with CamelCase includes
* Fix pri file to have qmake name of QtGui as dependency
* Use ecm_qt_install_logging_categories over manual categories file
* Prison: Convert license statements to SPDX identifiers

==== purge-kernels-service ====

- Set build architecture to noarch.

==== purpose ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Rewrite nextcloud plugin
* kill twitter support
* Port deprecated method
* Fix build with Qt 5.15.0
* Use ecm_qt_install_logging_categories over manual categories file

==== python-publicsuffix ====
Version update (1.1.0 -> 1.1.1)

- update to 1.1.1
* Add deprecation notice to README.
* Fix UnicodeDecodeError in setup.py when building or installing
package with LC_ALL=C (thanks to Evgeni Golov).
* Update the built-in list and fix tests (thanks to Evgeni Golov).
* Fetch the public suffix list using https.
* Add public_suffix_list.dat to MANIFEST.in.

==== qqc2-desktop-style ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* ScrollView: Use scrollbar height as bottom padding, not width
- Drop 0001-ScrollView-Use-scrollbar-height-as-bottom-padding-no.patch

==== rpm ====
Subpackages: librpmbuild9 rpm-build rpm-devel

- Use libgcrypt as crypto library instead of beecrypt
* dropped patch: beecrypt-4.1.2-build.diff
* dropped patch: beecrypt-4.1.2.diff
- Rewrite rpmqpack to use rpm's database interface
modified patch: rpmqpack.diff
- Backport database detection code from upstream
new patch: db_ops_name.diff
- Backport read-only BerkeleyDB code
new patch: bdb_ro.diff
- Enable ndb backend
- Backport bdb disabling fix
new patch: disable_bdb.diff
- Backport ndb improvements
new patch: ndb_backport.diff
- Backport automatic db conversion
new patch: db_conversion.diff
- Disable the BerkeleyDB backend and switch over to 'ndb'

==== salt ====
Subpackages: python3-salt salt-master salt-minion

- virt._get_domain: don't raise an exception if there is no VM
- Added:
* virt._get_domain-don-t-raise-an-exception-if-there-i.patch
- Adds test for zypper abbreviation fix
- Improved storage pool or network handling
- Better import cache handline
- Added:
* loader-invalidate-the-import-cachefor-extra-modules.patch
* open-suse-2019.2.3-virt-defined-states-219.patch
- Modified:
* use-full-option-name-instead-of-undocumented-abbrevi.patch

==== schily ====
Subpackages: cdda2wav cdrecord libcdrdeflt1_0 libdeflt1_0 libedc_ecc1_0
libedc_ecc_dec1_0 libfile1_0 libfind4_0 libparanoia1_0 librmt1_0 librscg1_0
libscg1_0 libscgcmd1_0 libschily2_0 mkisofs readcd spax star

- Update to release 2020.03.11
* Bourne Shell: set -m now works in scripts as well. Before,
bosh did never call startjobs() when the shell startup was
done with a shell script.
* Bourne Shell: The shell now supports the alternate ;& switch
command limiter in addition to ;; where ;& implements a
fallthrough to the next command list regardless on thether
there is a match or not.

==== solid ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. SkipEmptyParts is part of Qt::.
* Fix inverted logic in IOKitStorage::isRemovable
* Use ecm_qt_install_logging_categories over manual categories file

==== sonnet ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Port QRegExp to QRegularExpression
* fix segfault at exit
* Use ecm_qt_install_logging_categories over manual categories file
* Convert license statements to SPDX

==== sssd ====
Subpackages: libsss_certmap0 libsss_idmap0 libsss_nss_idmap0 sssd-32bit
sssd-krb5-common sssd-ldap

- Fix dynamic DNS updates not using FQDN (bsc#1160587); Add
0001-AD-use-getaddrinfo-with-AI_CANONNAME-to-find-the-FQD.patch

==== sudo ====
Version update (1.8.31 -> 1.8.31p1)

- Update to 1.8.31p1
* Sudo once again ignores a failure to restore the RLIMIT_CORE
resource limit, as it did prior to version 1.8.29.
Linux containers don't allow RLIMIT_CORE to be set back to
RLIM_INFINITY if we set the limit to zero, even for root,
which resulted in a warning from sudo.

==== syndication ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Use ecm_qt_install_logging_categories over manual categories file

==== syntax-highlighting ====
Version update (5.67.0 -> 5.68.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Too many changes since 5.67.0, only listing bugfixes:
* Makefile highlight: fix variable names in "else" conditionals (kde#417379)
* Makefile highlight: add substitutions (kde#416685)

==== texlive ====
Subpackages: libkpathsea6 libsynctex2

- Use CVE numbers

==== threadweaver ====
Version update (5.67.0 -> 5.68.0)

- Update to 5.68.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.68.0.php
- Changes since 5.67.0:
* Make it compile against qt5.15. They reverted change error() to socketError

==== vim ====
Subpackages: gvim vim-data vim-data-common

- apparmor.vim: fix typo in setfcap capability (taken from AppArmor 2.13.4)

==== virtualbox ====
Subpackages: virtualbox-guest-tools virtualbox-guest-x11 virtualbox-kmp-default

- A fix for boo #1166782 ("VirtualBox Guest 6.1.4 for OpenSUSE 15.1 constant
segfault in libX11.so.6.3 every 5 seconds") is fixed.
File "VirtualBox-6.1.4-VBoxClient-vmsvga-x11-crash.patch", published in
https://www.virtualbox.org/ticket/19357, fixes the problem.

==== yast2-samba-client ====
Version update (4.2.2 -> 4.2.3)

- Do not stop nmbd while nmbstatus is running, it is not necessary
anymore; (bsc#1158916);
- 4.2.3

==== zimg ====

- Add colorspace-fix-assertion-part2.patch in order to address
gh#sekrit-twc/zimg#123.
- Add colorspace-fix-assertion.patch in order to fix
build with GCC10. See gh#sekrit-twc/zimg#122.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages