Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
[opensuse-factory] PostgreSQL changed build dependency
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Sat, 21 Mar 2020 20:54:46 +0100
  • Message-id: <2246172.G7yQR80KXt@xrated>
Dear Reinhard, Marcus and Stefan,

I've noticed a change to the latest PostgreSQL package, that results in an
important dependency shift.

In order to have pg_config available, which is essential for proper postgresql
binding, packages like python-psycopg2 and asterisk need this:

%if ( 0%{?sle_version} >= 150200 && 0%{?is_opensuse} ) || 0%{?suse_version} >
1500
BuildRequires: postgresql-server-devel
%else
BuildRequires: postgresql-devel
%endif

Is this new behavior to be expected?

Cheers,
Pete


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages