Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200314 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Mon, 16 Mar 2020 20:01:04 +0000
  • Message-id: <158438886483.4784.16218628454397092236@go-agent-stagingbot-3>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200314

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
389-ds
NetworkManager (1.22.8 -> 1.22.10)
SDL2 (2.0.10 -> 2.0.12)
autoyast2 (4.2.29 -> 4.2.31)
corosync
geocode-glib (3.26.1 -> 3.26.2)
gnome-bluetooth (3.34.0 -> 3.34.1)
ibus
libqca-qt5 (2.2.1 -> 2.3.0)
llvm9
mozilla-nspr (4.24 -> 4.25)
mozilla-nss (3.49.2 -> 3.50)
ncurses
netcontrol
openblas_pthreads (0.3.8 -> 0.3.9)
polkit-default-privs (1550+20200213.f716f0a -> 1550+20200310.cdde967)
ppp
tracker (2.3.2 -> 2.3.4)
tracker-miners (2.3.2 -> 2.3.3)
xen (4.13.0_08 -> 4.13.0_10)
xfce4-branding-openSUSE (4.14+20200228 -> 4.14+20200311)
yast2 (4.2.67 -> 4.2.73)
yast2-auth-client (4.2.3 -> 4.2.4)
yast2-installation (4.2.29 -> 4.2.37)
yast2-iscsi-client (4.2.4 -> 4.2.5)
yast2-ntp-client (4.2.8 -> 4.2.9)
yast2-packager (4.2.56 -> 4.2.58)
yast2-python-bindings (4.1.2 -> 4.1.3)
yast2-samba-server (4.2.2 -> 4.2.4)
yast2-storage-ng (4.2.93 -> 4.2.97)
yast2-update (4.2.13 -> 4.2.18)

=== Details ===

==== 389-ds ====
Subpackages: lib389 libsvrcore0

- Change systemd_requires to systemd_ordering based on packaging
advice.
- Change 389-ds to use sysusers.d for user/group addition of dirsrv
instead of manual calls to useradd/groupadd.

==== NetworkManager ====
Version update (1.22.8 -> 1.22.10)
Subpackages: NetworkManager-lang libnm0 typelib-1_0-NM-1_0

- Update to version 1.22.10:
+ core: periodically cleanup stale device state files from /run.
+ dhcp: fix crash in nettools client.
+ bond: fixed the validation of the miimon option.
+ Various minor bug fixes and improvements.
- Modify nfs script (boo#1164642)
* Also mount nfs4 shares
* Ignore nfs or nfs4 shares in case if the noauto option is set

==== SDL2 ====
Version update (2.0.10 -> 2.0.12)

- Update to release 2.0.12
* Support for the Google Stadia controller and other game
controllers
* A new video driver for offscreen rendering
* ARM NEON optimizations
- Drop CVE-2019-13616.patch (merged upstream)

==== autoyast2 ====
Version update (4.2.29 -> 4.2.31)
Subpackages: autoyast2-installation

- Adapted to changes in yast2-storage-ng (related to bsc#1140040).
- 4.2.31
- Security fix: Removed all "--gpg-auto-import-keys" options from
zypper commands (bsc#1140711)
- 4.2.30

==== corosync ====
Subpackages: libcfg6 libcmap4 libcorosync_common4 libcpg4 libquorum5

- Don't package sysconfig file in tmpfiles.d, it's a bug. Instead correctly
add it to /etc/sysconfig, invoking fillup accordingly.

==== geocode-glib ====
Version update (3.26.1 -> 3.26.2)
Subpackages: libgeocode-glib0 typelib-1_0-GeocodeGlib-1_0

- Update to version 3.26.2:
+ Fix build exporting all the symbols.
+ Allow GIR generation when cross-compiling.
+ Allow unknown parameters inside geo: URL.

==== gnome-bluetooth ====
Version update (3.34.0 -> 3.34.1)
Subpackages: gnome-bluetooth-lang libgnome-bluetooth13
typelib-1_0-GnomeBluetooth-1_0

- Update to version 3.34.1:
+ Prefer ?Alias? adapter name to ?Name?.
+ Fix some memory leaks.
+ Updated translations.

==== ibus ====
Subpackages: ibus-dict-emoji ibus-gtk ibus-gtk-32bit ibus-gtk3 ibus-lang
libibus-1_0-5 libibus-1_0-5-32bit typelib-1_0-IBus-1_0

- Enable wayland and emoji features in SLE 15 SP2 (boo#1165844,
SLE-11652)
- Remove the with_kde option in the spec file and add a patch
to remove an unneeded qt5 dependency
* 0001-Replace-the-Qt-check-for-appindicator-engine-icon-wi.patch
- Enable emoji also on ppc

==== libqca-qt5 ====
Version update (2.2.1 -> 2.3.0)
Subpackages: libqca-qt5-plugins

- Remove baselibs.conf
- Update to 2.3.0
* Qt5 is the only supported Qt series now
* OpenSSL <= 1.1.0 is no longer supported
* Various botan bugfixes
* More dynamic test coverage of backend capabilities
* no longer tries to setuid when the effective uid is not root
- Rename qca-2.2.1-fixDSA.patch to qca-2.3.0-fixDSA.patch and
rebase it
- Update minimum required Qt5 and cmake versions

==== llvm9 ====
Subpackages: clang9 clang9-doc libLLVM9 libLTO9 libc++-devel libc++1
libc++abi-devel libc++abi1 libclang9

- Require clang-tools for clangX-devel.
- Move all clang-related scripts (including those originally in
clangX-checker), hmaptool and clang-doc into a common
unversioned subpackage clang-tools, like python3-clang.
The scripts reference the unversioned executables, so allowing
multiple versions via update-alternatives would be misleading.
The clang-doc executable will come with assets in Clang 10, so
we have to take it out of update-alternatives as well.
This should be the proper solution to boo#1161873.
- Include run-find-all-symbols script in clang-tools.
- Remove metadata for clangX-include-fixer subpackage that never
had any files and thus wasn't released as rpm. There are so many
clang binaries that packaging them separately doesn't scale.
- Fix lldb version string, adapt lldb-cmake.patch (boo#1165517).
- Remove unneccesary libtool dependency.
- Don't let clang depend on libc++, we link it with libstdc++.
- Recommend gold plugin if clang and gold are installed.

==== mozilla-nspr ====
Version update (4.24 -> 4.25)

- update to version 4.25
* fixed reading files larger than 4 GB on Win32
* added support for Xtensa architecture

==== mozilla-nss ====
Version update (3.49.2 -> 3.50)
Subpackages: libfreebl3 libfreebl3-hmac libsoftokn3 libsoftokn3-hmac
mozilla-nss-certs mozilla-nss-tools

- update to NSS 3.50
* Verified primitives from HACL* were updated, bringing performance
improvements for several platforms.
Note that Intel processors with SSE4 but without AVX are currently
unable to use the improved ChaCha20/Poly1305 due to a build issue;
such platforms will fall-back to less optimized algorithms.
See bmo#1609569 for details
* Updated DTLS 1.3 implementation to Draft-30.
See bmo#1599514 for details.
* Added NIST SP800-108 KBKDF - PKCS#11 implementation.
See bmo#1599603 for details.
* Several bugfixes and minor changes

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base terminfo-screen

- Add ncurses patch 20200308
+ update copyright notices in test-packages.
+ modify tracemunch to guard against errors in its known_p1 table.
+ add several --with-xxx-libname options, to help with pkgsrc (prompted
by discussion with Thomas Klausner).
- Add ncurses patch 20200301
+ modify wbkgd() and wbkgrnd() to avoid storing a null in the
background character, because it may be used in cases where the
corresponding 0x80 is not treated as a null (report by Marc Rechte,
cf: 20181208).
- Add ncurses patch 20200229
+ modify CF_NCURSES_CONFIG to work around xcode's c99 "-W" option,
which conflicts with conventional use for passing linker options.
> fixes for building with Visual Studio C++ and msys2 (patches by
"Maarten Anonymous"):
+ check for pcre2posix.h instead of pcre2-posix.h
+ add case in CF_SHARED_OPTS for msys2 + msvc
+ add fallback definition for STDIN_FILENO in progs.priv.h
+ modify win_driver.c to use _alloca() rather than gcc's variable
length array feature.
+ add NCURSES_IMPEXP to ncurses wrapped-variable declarations
+ remove NCURSES_IMPEXP from class variables in c++/cursslk.h
+ remove fallback prototype for exit() from c++/etip.h.in
+ use configured check for <sys/time.h> in a couple of places
+ conditionally include winsock.h in ncurses/win32con/gettimeofday.c,
because Visual Studio needs this for the timestruct declaration.
+ adjust syntax in a couple of files using the NCURSES_API symbol.

==== netcontrol ====

- bonding: don't complain about unknown options (bsc#1132794)
[+ 0005-bonding-don-t-complain-about-unknown-options.1132794.patch]
- udev: use correct udev rule (write) lock directory
[+ 0004-udev-use-correct-udev-rule-write-lock-directory.patch]
- sysconfig: fix segfault on missed end-quote (bsc#1027736)
[+ 0003-sysconfig-fix-segfault-on-missed-end-quote-bsc-10277.patch]
- fix segfault on invalid check in route creation (bsc#1148646)
[+ 0002-Fix-invalid-check-in-route-creation-bsc-1148646.patch]
- fix virsh iface-list not working as expected (bsc#1029201)
[+ 0001-virsh-iface-list-not-working-as-expected-bsc-1029201.patch]

==== openblas_pthreads ====
Version update (0.3.8 -> 0.3.9)

- Update to version 0.3.9
common:
* Fixed a miscompilation of the GETRF functions with CMAKE
The size of the memory buffer used for splitting GEMM tasks across
multiple threads can now be configured in the build system.
Imported bugfix 390 from LAPACK (missing NaN propagation in xCOMBSSQ)
POWER:
* fixed several compilation problems related to endianness and
ELF version support on POWER8 and POWER9.
* fixed misuse of the absolute value IAMIN/IAMAX in place of IMIN/IMAX
* fixed a race condition in the level3 blas code
MIPS64:
* fixed misuse of the absolute value IAMIN/IAMAX in place of IMIN/IMAX
ARMV7:
* fixed a race condition in the level3 blas code
* fixed a compilation problem on Android
ARMV8:
* Added support for Ampere EMAG8180
* Added support for Neoverse N1
improved performance of the blas_lock function
fixed a race condition in the level3 blas code
* Fixed a performance regression on TSV110 servers
x86_64:
* Fixed a long-standing error with undeclared register clobbers in
the DSCAL microkernel for Haswell,SkylakeX and Zen exposed by gcc9.2
* Fixed a long-standing bug in the SSE implementation of the IAMAX functions
* Fixed a cmake build failure with DYNAMIC_ARCH on x86_64
* Fixed an oversight in the cpu detection code for Intel Goldmont+,
Cannon Lake and Ice Lake
* Fixed compile failure on OSX when the compiler name contains a dash
(e.g. gcc-9)
* Fixed compilation with MinGW on SkylakeX
* Improved speed of the AVX512 GEMM3M code, added an AVX512 kernel for
* STRMM and improved performance of the AVX2 GEMM kernels
IBM Z:
* fixed compilation of the DYNAMIC_ARCH code

==== polkit-default-privs ====
Version update (1550+20200213.f716f0a -> 1550+20200310.cdde967)

- Update to version 1550+20200310.cdde967:
* profiles: whitelist new timeshift pkexec actions (bsc#1165436)
* polkit profile: remove trailing '###' lines

==== ppp ====

- Add pam_keyinit to /etc/pam.d/ppp (bsc#1144055).

==== tracker ====
Version update (2.3.2 -> 2.3.4)
Subpackages: libtracker-common-2_0 libtracker-control-2_0-0
libtracker-miner-2_0-0 libtracker-sparql-2_0-0 tracker-lang
typelib-1_0-Tracker-2_0 typelib-1_0-TrackerControl-2_0

- Update to version 2.3.4:
+ Brown paper bag release, fix NULL check.
+ Changes in version 2.3.3:
+ Fix race condition during tracker-store shutdown maybe leading
to warnings and missed writeback events.
+ Made fts:offsets stronger against corrupt FTS tables.
+ Updated translations.
- Drop tracker-fix-segfault-in-writeback.patch: fixed upstream.

==== tracker-miners ====
Version update (2.3.2 -> 2.3.3)
Subpackages: tracker-miner-files tracker-miners-lang

- Update to version 2.3.3:
+ The secure sandbox for tracker-extract now permits
clock_nanosleep() calls, fixing crashes on some systems.
+ Miners now set nice/scheduler priorities in a way that placates
glib. The sched_setscheduler syscall is as a side effect also
allowed by the tracker-extract sandbox.
+ Updated translations.
- Drop tracker-miners-set-cpu-io-nice.patch and
tracker-miners-allow-settatr.patch: fixed upstream.
- Add tracker-miners-bsc1165635-crawl-timestamp.patch: properly set
crawl timestamp (bsc#1165635 glgo#GNOME/tracker-miners!159).

==== xen ====
Version update (4.13.0_08 -> 4.13.0_10)
Subpackages: xen-libs xen-tools xen-tools-domU

- bsc#1158414 - GCC 10: xen build fails
gcc10-fixes.patch
- bsc#1165206 - Xen 4.12 DomU hang / freeze / stall / NMI watchdog
bug soft lockup CPU #0 stuck under high load / upstream with
workaround. See also bsc#1134506
default-to-credit1-scheduler.patch

==== xfce4-branding-openSUSE ====
Version update (4.14+20200228 -> 4.14+20200311)
Subpackages: exo-branding-openSUSE libgarcon-branding-openSUSE
libxfce4ui-branding-openSUSE openSUSE-xfce-icon-theme
thunar-volman-branding-openSUSE xfce4-notifyd-branding-openSUSE
xfce4-panel-branding-openSUSE xfce4-power-manager-branding-openSUSE
xfce4-session-branding-openSUSE xfce4-settings-branding-openSUSE
xfdesktop-branding-openSUSE xfwm4-branding-openSUSE

- Update to version 4.14+20200311:
* Use elementary-xfce-darker by default

==== yast2 ====
Version update (4.2.67 -> 4.2.73)
Subpackages: yast2-logs

- CWM::MultiStatusSelector minor improvements (related to
bsc#1157780).
- 4.2.73
- Add the new CWM::MultiStatusSelector custom widget (related to
bsc#1157780, bsc#1161308, bsc#1161200).
- 4.2.72
- Do not remove the installation repositories in the "Previously
Used Repositories" step (bsc#1163081)
- 4.2.71
- Allow to restore the vertical scroll of a CWM::RichText
(related to bsc#1049965)
- 4.2.70
- Read the list of network service properly, no matter where
it is stored (bsc#1162853).
- 4.2.69
- Skip repository reloading at installation to avoid unselecting
products to install (bsc#1165501)
- 4.2.68

==== yast2-auth-client ====
Version update (4.2.3 -> 4.2.4)

- Default bind_policy to 'soft' if not present in the config
(bsc#1162025).
- 4.2.4
- SLEx_15_LOC : YaST: ALL_LANGS:Untranslated text in User Logon
Management/Manage Domain User Login/Active Directory Enrollment dialog
bsc#1083947

==== yast2-installation ====
Version update (4.2.29 -> 4.2.37)

- Add Abort confirmation for inst_welcome client used in firstboot
(bsc#1163347)
- 4.2.37
- Make sure to show release notes for add-on products (bsc#1158287)
- 4.2.36
- Added "yupdate" script to simplify patching the installer
(bsc#1163691)
- 4.2.35
- Rely on the new Y2Network::NtpServer class (jsc#SLE-7188).
- 4.2.34
- Allow to modify the control file at installation time using a
skelcd-* package (bsc#1164468).
- 4.2.33
- don't start getty on hvc0 & ttyAMA0 before Yast2-Firstboot (bsc#1157233)
- 4.2.32
- Fixed user-visible messages (bsc#1084015)
- 4.2.31
- Reimplemented the "Previously Used Repositories" dialog
(inst_upgrade_urls.rb) to properly evaluate the new and the old
system repositories (bsc#1159433)
- 4.2.30

==== yast2-iscsi-client ====
Version update (4.2.4 -> 4.2.5)

- Handle the iscsi service status (restart, start...) change after
the iscsid and the iscsiuio sockets (bsc#1160606)
- 4.2.5

==== yast2-ntp-client ====
Version update (4.2.8 -> 4.2.9)

- Supporting more than one ntp server in the time setting module.
(bsc#1164547)
- 4.2.9

==== yast2-packager ====
Version update (4.2.56 -> 4.2.58)

- Avoid unselecting the base product (related to bsc#1165501)
- 4.2.58
- Avoid to abort the installer when the user decides to not fix a
repository url (bsc#1163015).
- 4.2.57

==== yast2-python-bindings ====
Version update (4.1.2 -> 4.1.3)

- Fix build for python 3.8; (bsc#1166517)/
- 4.1.3

==== yast2-samba-server ====
Version update (4.2.2 -> 4.2.4)

- Fix check of connected users when proposing the default service
action (bsc#1166303)
- 4.2.4
- Propose to restart samba services by default when writing the
configuration with services already running. Reload is still used
if some user is connected to the samba server (bsc#1165638)
- 4.2.3

==== yast2-storage-ng ====
Version update (4.2.93 -> 4.2.97)

- write nocow attribute correctly into YAML
- 4.2.97
- AutoYaST: report the user when conflicting attributes are set
in a partition section (i.e., mount, raid_name, lvm_group,
btrfs_name, bcache_backing_for and bcache_caching_for)
(bsc#1165907).
- 4.2.96
- Usability improvements when asking the user to install packages
during the probing phase (related to bsc#1140040).
- More flexible API for PackageHandler and related classes
- More libstorage-ng "storage features" now recognized and handled
if needed: UF_DASD, UF_BITLOCKER, UF_JFS, UF_F2FS, UF_EXFAT.
- Partitioner: better error reporting when the installation of
needed packages fails.
- 4.2.95
- AutoYaST: show an error when no suitable physical volumes are
found for a given volume group (bsc#1162043).
- 4.2.94

==== yast2-update ====
Version update (4.2.13 -> 4.2.18)

- Do not remove the installation repositories in the "Previously
Used Repositories" step (bsc#1163081)
- 4.2.18
- Fixed repository loading to not remove the initial installation
repository (bsc#1163081)
- 4.2.17
- Switch from Autotools based build to Rake
- Fixed user-visible messages (bsc#1084015)
- 4.2.16
- Also accept Packages.db as valid rpm database (bsc#1162485)
- 4.2.15
- Store the original repository setup early in the upgrade workflow
so YaST can easily differ between the old and new repositories
(bsc#1159433)
- 4.2.14


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages