Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
Re: [opensuse-factory] 15.2 beta update / mariadb problem
On Mon, Mar 16, 2020 at 6:29 AM Stefan Seyfried
<stefan.seyfried@xxxxxxxxxxxxxx> wrote:

Hi all,

I need some guidance on how to create a proper bugreport.
I'm running a server at home with Leap, which hosts among others an owncloud
instance with mariadb as database backend.

Since I was using a newer kernel because of XFS features anyway, yesterday I
thought it would be a good idea to try
updating to Leap 15.2 beta.

I did take a fresh backup before doing this, which proved a good idea.

After the update, the mariadb databases were broken.
mysql root user was not able to access the database.
Re-running "mysql_secure_installation" was not possible because of that.

So I moved away /var/lib/mysql, rerun mysql_secure_installation and tried to
restore the database dump with

mysql -u root < /space3/backup/sda/mysqldump/2020-03-15.sql

which choked on line 2009

2002 --
2003 -- Table structure for table `user`
2004 --
2005
2006 DROP TABLE IF EXISTS `user`;
2007 /*!40101 SET @saved_cs_client = @@character_set_client */;
2008 /*!40101 SET character_set_client = utf8 */;
2009 CREATE TABLE `user` (
2010 `Host` char(60) COLLATE utf8_bin NOT NULL DEFAULT '',
2011 `User` char(80) COLLATE utf8_bin NOT NULL DEFAULT '',

Because I needed the system up, the next try was "restore /var/lib/mysql from
backup" which fortunately worked.

My guess is that even though mariadb shows a post-upgrade message that you
should backup /var/lib/mysql before
restarting the database (which will perform an update), actually the RPM
restarts the database and something went badly
wrong at this step.

As you might guess, I know nothing about mariadb and databases in general, so
I'm type of lost on how to create a useful
bugreport.

I still have the (broken) contents of /var/lib/mysql that do not work.
I also have a fairly complete backup of the system before the update, so if
time permits, I might try to reproduce the
issue in a virtual machine.

So what information would the mariadb maintainer need from me in a good
bugreport?

Ditto, I still have a server with hosed mysql authentication..
happended in tumblweed too.. unfortunately I have not been able to
completely shut it down for a few hours to do a full restore.. so it
is running with skip-grant-tables and no networking whatsoever.
apparently the mysql authentication tables ends with no users in, not
even root..

I have database backups, yeah, but I 'll prefer not to restore them
and fix the authentication issue instead.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References