Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
[opensuse-factory] Changes in gpg-agent / Plasma? SSH-Key no longer available in gpg-agent...
Hi all,

was there a change recently that affects gpg-agent in Plasma?
I have configured my gpg-agent to have ssh support (enable-ssh-support in
~/.gnupg/gpg-agent.conf) and normally I get a plasma pinentry window that asks
for the password to unlock my SSH key in GPG-agent. No nothing like that, just
being asked on the CLI and the key is not available in "ssh-add -l" afterwards.

Fallout of the nsswitch thingy?

I just noticed this today, while I tried out Plasma+Wayland. Now it is no longer
working in Plasma (without Wayland), too.

I am currently on 20200307, but it worked the last couple of days after
installation of that snapshot, so I am puzzled. I cleaned up some rpmnew files
yesterday, but there was only zypper, firewalld, some libvirt things and of
course nsswitch.

Johannes

--
Johannes Kastl
Linux Consultant & Trainer
Tel.: +49 (0) 151 2372 5802
Mail: kastl@xxxxxxxxxxxxx

B1 Systems GmbH
Osterfeldstra├če 7 / 85088 Vohburg
http://www.b1-systems.de
GF: Ralph Dehner
Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537

< Previous Next >
Follow Ups