Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200307 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 08 Mar 2020 20:00:33 +0000
  • Message-id: <158369763342.10334.5980031264885673889@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200307

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
alsa-tools
autoyast2 (4.2.28 -> 4.2.29)
libstorage-ng (4.2.65 -> 4.2.66)
rubygem-bundler (2.0.2 -> 2.1.4)
rubygem-capistrano (3.11.0 -> 3.11.2)
rubygem-commander (4.4.7 -> 4.5.0)
rubygem-cool.io (1.5.4 -> 1.6.0)
rubygem-cri (2.15.9 -> 2.15.10)
rubygem-debase-ruby_core_source (0.10.7 -> 0.10.9)
rubygem-delayed_job (4.1.7 -> 4.1.8)
rubygem-delayed_job_active_record (4.1.3 -> 4.1.4)
rubygem-devise (4.6.2 -> 4.7.1)
rubygem-devise-i18n (1.8.0 -> 1.9.0)
rubygem-excon (0.71.0 -> 0.72.0)
rubygem-faraday (0.15.4 -> 1.0.0)
rubygem-faraday_middleware (0.13.1 -> 0.14.0)
rubygem-ffi (1.12.1 -> 1.12.2)
rubygem-flog (4.6.2 -> 4.6.4)
rubygem-fluentd (1.6.2 -> 1.9.1)
rubygem-get_process_mem (0.2.4 -> 0.2.5)
rubygem-gettext-setup (0.30 -> 0.34)
rubygem-gettext_i18n_rails (1.8.0 -> 1.8.1)
rubygem-gpgme (2.0.18 -> 2.0.19)
rubygem-haml (5.1.1 -> 5.1.2)
rubygem-highline (2.0.2 -> 2.0.3)
rubygem-hitimes (1.3.1 -> 2.0.0)
rubygem-hoe (3.18.0 -> 3.22.0)
rubygem-jaro_winkler (1.5.3 -> 1.5.4)
rubygem-jbuilder (2.9.1 -> 2.10.0)
rubygem-jekyll-sass-converter (1.5.2 -> 2.1.0)
rubygem-js-routes (1.4.7 -> 1.4.9)
rubygem-json-jwt (1.10.2 -> 1.11.0)
rubygem-kgio (2.11.2 -> 2.11.3)
rubygem-listen (3.1.5 -> 3.2.1)
rubygem-mercenary (0.3.6 -> 0.4.0)
rubygem-mime-types (3.2.2 -> 3.3.1)
rubygem-mime-types-data (3.2019.0331 -> 3.2019.1009)
rubygem-mimemagic (0.3.3 -> 0.3.4)
rubygem-mini_magick (4.9.5 -> 4.10.1)
rubygem-mixlib-authentication (3.0.1 -> 3.0.6)
rubygem-mixlib-cli (2.1.1 -> 2.1.5)
rubygem-mixlib-config (3.0.1 -> 3.0.6)
rubygem-mixlib-log (3.0.1 -> 3.0.8)
rubygem-mixlib-shellout (3.0.4 -> 3.0.9)
rubygem-mocha (1.9.0 -> 1.11.2)
rubygem-moneta (1.1.1 -> 1.2.1)
rubygem-msgpack (1.3.1 -> 1.3.3)
rubygem-multi_json (1.13.1 -> 1.14.1)
rubygem-mustermann-grape (1.0.0 -> 1.0.1)
rubygem-net-ldap (0.16.1 -> 0.16.2)
rubygem-oauth2 (1.4.1 -> 1.4.3)
rubygem-omniauth-google-oauth2 (0.7.0 -> 0.8.0)
rubygem-paint (2.1.0 -> 2.1.1)
rubygem-parser (2.7.0.1 -> 2.7.0.2)
rubygem-path_expander (1.0.4 -> 1.1.0)
rubygem-pg (1.1.4 -> 1.2.2)
rubygem-rack-1_6 (1.6.11 -> 1.6.13)
rubygem-rack (2.1.2 -> 2.2.2)
rubygem-rack-oauth2 (1.10.0 -> 1.10.1)
rubygem-rack-protection (2.0.5 -> 2.0.8.1)
rubygem-rails-i18n (5.1.3 -> 6.0.0)
rubygem-raindrops (0.19.0 -> 0.19.1)
rubygem-rake-compiler (1.0.7 -> 1.1.0)
rubygem-reverse_markdown (1.2.0 -> 1.4.0)
rubygem-rouge (3.6.0 -> 3.15.0)
rubygem-ruby-openid (2.7.0 -> 2.9.2)
rubygem-ruby_parser (3.13.1 -> 3.14.2)
rubygem-serverengine (2.1.1 -> 2.2.1)
rubygem-sexp_processor (4.12.1 -> 4.14.1)
rubygem-simplecov (0.17.0 -> 0.18.1)
rubygem-simplecov-html (0.10.2 -> 0.11.0)
rubygem-slop (4.7.0 -> 4.8.0)
rubygem-sqlite3 (1.4.1 -> 1.4.2)
rubygem-sshkit (1.19.1 -> 1.20.0)
rubygem-stomp (1.4.8 -> 1.4.9)
rubygem-temple (0.8.1 -> 0.8.2)
rubygem-tins (1.21.1 -> 1.24.1)
rubygem-tomlrb (1.2.8 -> 1.2.9)
rubygem-trollop (2.9.9 -> 2.9.10)
rubygem-tzinfo-0 (0.3.55 -> 0.3.56)
rubygem-tzinfo (2.0.0 -> 2.0.1)
rubygem-tzinfo-data (1.2019.2 -> 1.2019.3)
rubygem-unicode-display_width (1.6.0 -> 1.6.1)
rubygem-webpacker (4.2.0 -> 4.2.2)
rubygem-winrm-elevated (1.1.1 -> 1.2.0)
xapps
yast2-http-server (4.2.6 -> 4.2.7)
yast2-network (4.2.58 -> 4.2.60)
yast2-packager (4.2.54 -> 4.2.56)
yast2-storage-ng (4.2.90 -> 4.2.93)

=== Details ===

==== alsa-tools ====

- Update to 1.2.2 (do not support Python 2 and PyGtk).
- Remove
0001-hdspmixer-Use-__u32-and-__u64-for-RMS-array-types.patch
which was included upstream.

==== autoyast2 ====
Version update (4.2.28 -> 4.2.29)
Subpackages: autoyast2-installation

- Fixed crash while loading none existing AY file (bsc#1165464).
- 4.2.29

==== libstorage-ng ====
Version update (4.2.65 -> 4.2.66)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#708
- merge gh#openSUSE/libstorage-ng#707
- Translated using Weblate (Finnish) (bsc#1149754)
- Add option for ignoring clustered LVM
- Update lib version
- Ignore clustered LVM
- Revert "Add option for ignoring clustered LVM"
- Revert "Update lib version"
- Revert "Translated using Weblate (Finnish)" (bsc#1149754)
- Sync branches (SLE-15-SP1)
- 4.2.66

==== rubygem-bundler ====
Version update (2.0.2 -> 2.1.4)

- updated to version 2.1.4
see installed CHANGELOG.md

==== rubygem-capistrano ====
Version update (3.11.0 -> 3.11.2)

- updated to version 3.11.2
see installed CHANGELOG.md

==== rubygem-commander ====
Version update (4.4.7 -> 4.5.0)

- updated to version 4.5.0
see installed History.rdoc
=== 4.5.0 / 2020-01-21
* Drop support for Ruby < 2.3.
* Fix bug parsing double dash (#75).

==== rubygem-cool.io ====
Version update (1.5.4 -> 1.6.0)

- updated to version 1.6.0
see installed CHANGES.md
1.6.0
- ----
* Add ruby 2.6/2.7 to windows gem
* Drop ruby 2.1/2.2/2.3 from windows gem

==== rubygem-cri ====
Version update (2.15.9 -> 2.15.10)

- updated to version 2.15.10
see installed NEWS.md
[#]# 2.15.10
Fixes:
- Fixed warnings appearing in Ruby 2.7 (9a3d810)

==== rubygem-debase-ruby_core_source ====
Version update (0.10.7 -> 0.10.9)

- updated to version 0.10.9
see installed CHANGELOG.md
[#]#
[0.10.9](https://github.com/os97673/debase-ruby_core_source/compare/v0.10.8...v0.10.9)
* ruby 2.7.0 added (contributed by [ViugiNick](https://github.com/ViugiNick))
[#]#
[0.10.8](https://github.com/os97673/debase-ruby_core_source/compare/v0.10.7...v0.10.8)
* ruby 2.7.0-preview3 added (contributed by
[ViugiNick](https://github.com/ViugiNick))

==== rubygem-delayed_job ====
Version update (4.1.7 -> 4.1.8)

- updated to version 4.1.8
see installed CHANGELOG.md
4.1.8 - 2019-08-16
=================
* Support for Rails 6.0.0

==== rubygem-delayed_job_active_record ====
Version update (4.1.3 -> 4.1.4)

- updated to version 4.1.4
no changelog found

==== rubygem-devise ====
Version update (4.6.2 -> 4.7.1)

- updated to version 4.7.1
see installed CHANGELOG.md
[#]## 4.7.1 - 2019-09-06
* bug fixes
* Fix an edge case where records with a blank `confirmation_token` could be
confirmed (by @tegon)
* Fix typo inside `update_needs_confirmation` i18n key (by @lslm)
[#]## 4.7.0 - 2019-08-19
* enhancements
* Support Rails 6.0
* Update CI to rails 6.0.0.beta3 (by @tunnes)
* refactor method name to be more consistent (by @saiqulhaq)
* Fix rails 6.0.rc1 email uniqueness validation deprecation warning (by
@Vasfed)
* bug fixes
* Add `autocomplete="new-password"` to `password_confirmation` fields (by
@ferrl)
* Fix rails_51_and_up? method for Rails 6.rc1 (by @igorkasyanchuk)

==== rubygem-devise-i18n ====
Version update (1.8.0 -> 1.9.0)

- updated to version 1.9.0
no changelog found

==== rubygem-excon ====
Version update (0.71.0 -> 0.72.0)

- updated to version 0.72.0
no changelog found

==== rubygem-faraday ====
Version update (0.15.4 -> 1.0.0)

- updated to version 1.0.0
no changelog found

==== rubygem-faraday_middleware ====
Version update (0.13.1 -> 0.14.0)

- updated to version 0.14.0
no changelog found

==== rubygem-ffi ====
Version update (1.12.1 -> 1.12.2)

- updated to version 1.12.2
see installed CHANGELOG.md
1.12.2 / 2020-02-01
- ------------------
* Fix possible segfault at FFI::Struct#[] and []= after GC.compact . #742

==== rubygem-flog ====
Version update (4.6.2 -> 4.6.4)

- updated to version 4.6.4
see installed History.rdoc
=== 4.6.4 / 2019-12-14
* 2 minor enhancements:
* Added basic support for safe_call (nic-potter).
* Added extra complexity penalty to safe_call processing.
=== 4.6.3 / 2019-09-14
* 1 minor enhancement:
* Removed --18 and --19 options to cmdline. No real value anymore.
* 2 bug fixes:
* Fixed some sexp access under STRICT_SEXP=2.
* Fixed option / arg processing bug that caused a hang (reading from stdin).

==== rubygem-fluentd ====
Version update (1.6.2 -> 1.9.1)

- updated to version 1.9.1
see installed CHANGELOG.md
[#] v1.9
[#]# Release v1.9.1 - 2020/01/31
[#]## Enhancement
* http_server helper: Support HTTPS
https://github.com/fluent/fluentd/pull/2787
* in_tail: Add `path_delimiter` to split with any char
https://github.com/fluent/fluentd/pull/2796
* in_tail: Remove an entry from PositionaFile when it is unwatched
https://github.com/fluent/fluentd/pull/2803
* out_http: Add warning for `retryable_response_code`
https://github.com/fluent/fluentd/pull/2809
* parser_syslog: Add multiline RFC5424 support
https://github.com/fluent/fluentd/pull/2767
* Add TLS module to unify TLS related code
https://github.com/fluent/fluentd/pull/2802
[#]## Bug fix
* output: Add `EncodingError` to unrecoverable errors
https://github.com/fluent/fluentd/pull/2808
* tls: Fix TLS version handling in secure mode
https://github.com/fluent/fluentd/pull/2802
[#]# Release v1.9.0 - 2020/01/22
[#]## New feature
* New light-weight config reload mechanizm
https://github.com/fluent/fluentd/pull/2716
* Drop ruby 2.1/2.2/2.3 support
https://github.com/fluent/fluentd/pull/2750
[#]## Enhancement
* output: Show better message for secondary warning
https://github.com/fluent/fluentd/pull/2751
* Use `ext_monitor` gem if it is installed. For ruby 2.6 or earlier
https://github.com/fluent/fluentd/pull/2670
* Support Ruby's Time class in msgpack serde
https://github.com/fluent/fluentd/pull/2775
* Clean up code/test
https://github.com/fluent/fluentd/pull/2753
https://github.com/fluent/fluentd/pull/2763
https://github.com/fluent/fluentd/pull/2764
https://github.com/fluent/fluentd/pull/2780
[#]## Bug fix
* buffer: Disable the optimization of Metadata instance comparison on Windows
https://github.com/fluent/fluentd/pull/2778
* outut/buffer: Fix stage size computation
https://github.com/fluent/fluentd/pull/2734
* server: Ignore Errno::EHOSTUNREACH in TLS accept to avoid fluentd restart
https://github.com/fluent/fluentd/pull/2773
* server: Fix IPv6 dual stack mode issue for udp socket
https://github.com/fluent/fluentd/pull/2781
* config: Support @include/include directive for spaces included path
https://github.com/fluent/fluentd/pull/2780
[#] v1.8
[#]# Release v1.8.1 - 2019/12/26
[#]## Enhancement
* in_tail: Add `path_timezone` parameter to format `path` with the specified
timezone
https://github.com/fluent/fluentd/pull/2719
* out_copy: Add `copy_mode` parameter. `deep_copy` parameter is now
deprecated.
https://github.com/fluent/fluentd/pull/2747
* supervisor: Add deprecated log for `inline_config`
https://github.com/fluent/fluentd/pull/2746
[#]## Bug fixes
* parser_ltsv: Prevent garbage result by checking `label_delimiter`
https://github.com/fluent/fluentd/pull/2748
[#]# Release v1.8.0 - 2019/12/11
[#]## New feature
* Add service discovery plugin and `out_forward` use it
https://github.com/fluent/fluentd/pull/2541
* config: Add strict mode and support `default`/`nil` value in ruby embedded
mode
https://github.com/fluent/fluentd/pull/2685
[#]## Enhancement
* formatter_csv: Support nested fields
https://github.com/fluent/fluentd/pull/2643
* record_accessor helper: Make code simple and bit faster
https://github.com/fluent/fluentd/pull/2660
* Relax tzinfo dependency to accept v1
https://github.com/fluent/fluentd/pull/2673
* log: Deprecate top-level match for capturing fluentd logs
https://github.com/fluent/fluentd/pull/2689
* in_monitor_agent: Expose Fluentd verion in REST API
https://github.com/fluent/fluentd/pull/2706
* time: Accept localtime xor utc
https://github.com/fluent/fluentd/pull/2720
https://github.com/fluent/fluentd/pull/2731
* formatter_stdout: Make time_format configurable in stdout format
https://github.com/fluent/fluentd/pull/2721
* supervisor: create log directory when it doesn't exists
https://github.com/fluent/fluentd/pull/2732
* clean up internal classes / methods / code
https://github.com/fluent/fluentd/pull/2647
https://github.com/fluent/fluentd/pull/2648
https://github.com/fluent/fluentd/pull/2653
https://github.com/fluent/fluentd/pull/2654
https://github.com/fluent/fluentd/pull/2657
https://github.com/fluent/fluentd/pull/2667
https://github.com/fluent/fluentd/pull/2674
https://github.com/fluent/fluentd/pull/2677
https://github.com/fluent/fluentd/pull/2680
https://github.com/fluent/fluentd/pull/2709
https://github.com/fluent/fluentd/pull/2730
[#]## Bug fixes
* output: Fix warning printed when chunk key placeholder not replaced
https://github.com/fluent/fluentd/pull/2523
https://github.com/fluent/fluentd/pull/2733
* Fix dry-run mode
https://github.com/fluent/fluentd/pull/2651
* suppress warning
https://github.com/fluent/fluentd/pull/2652
* suppress keyword argument warning for ruby2.7
https://github.com/fluent/fluentd/pull/2664
* RPC: Fix debug log text
https://github.com/fluent/fluentd/pull/2666
* time: Properly show class names in error message
https://github.com/fluent/fluentd/pull/2671
* Fix a potential bug that ThreadError may occur on SIGUSR1
https://github.com/fluent/fluentd/pull/2678
* server helper: Ignore ECONNREFUSED in TLS accept to avoid fluentd restart
https://github.com/fluent/fluentd/pull/2695
* server helper: Fix IPv6 dual stack mode issue for tcp socket.
https://github.com/fluent/fluentd/pull/2697
* supervisor: Fix inline config handling
https://github.com/fluent/fluentd/pull/2708
* Fix typo
https://github.com/fluent/fluentd/pull/2710
https://github.com/fluent/fluentd/pull/2714
[#] v1.7
[#]# Release v1.7.4 - 2019/10/24
[#]## Enhancement
* in_http: Add `use_204_response` parameter to return proper 204 response
instead of 200.
fluentd v2 will change this parameter to `true`.
https://github.com/fluent/fluentd/pull/2640
[#]## Bug fixes
* child_process helper: fix stderr blocking for discard case
https://github.com/fluent/fluentd/pull/2649
* log: Fix log rotation handling on Windows
https://github.com/fluent/fluentd/pull/2663
[#]# Release v1.7.3 - 2019/10/01
[#]## Enhancement
* in_syslog: Replace priority_key with severity_key
https://github.com/fluent/fluentd/pull/2636
[#]## Bug fixes
* out_forward: Fix nil error after purge obsoleted sockets in socket cache
https://github.com/fluent/fluentd/pull/2635
* fix typo in ChangeLog
https://github.com/fluent/fluentd/pull/2633
[#]# Release v1.7.2 - 2019/09/19
[#]## Enhancement
* in_tcp: Add security/client to restrict access
https://github.com/fluent/fluentd/pull/2622
[#]## Bug fixes
* buf_file/buf_file_single: fix to handle compress data during restart
https://github.com/fluent/fluentd/pull/2620
* plugin: Use `__send__` to avoid conflict with user defined `send`
https://github.com/fluent/fluentd/pull/2614
* buffer: reject invalid timekey at configure phase
https://github.com/fluent/fluentd/pull/2615
[#]# Release v1.7.1 - 2019/09/08
[#]## Enhancement
* socket helper/out_forward: Support Windows certstore to load certificates
https://github.com/fluent/fluentd/pull/2601
* parser_syslog: Add faster parser for rfc3164 message
https://github.com/fluent/fluentd/pull/2599
[#]## Bug fixes
* buf_file/buf_file_single: fix to ignore placeholder based path.
https://github.com/fluent/fluentd/pull/2594
* server helper: Ignore ETIMEDOUT error in SSL_accept
https://github.com/fluent/fluentd/pull/2595
* buf_file: ensure to remove metadata after buffer creation failure
https://github.com/fluent/fluentd/pull/2598
* buf_file_single: fix duplicated path setting check
https://github.com/fluent/fluentd/pull/2600
* fix msgpack-ruby dependency to use recent feature
https://github.com/fluent/fluentd/pull/2606
[#]# Release v1.7.0 - 2019/08/20
[#]## New feature
* buffer: Add file_single buffer plugin
https://github.com/fluent/fluentd/pull/2579
* output: Add http output plugin
https://github.com/fluent/fluentd/pull/2488
[#]## Enhancement
* buffer: Improve the performance of buffer routine
https://github.com/fluent/fluentd/pull/2560
https://github.com/fluent/fluentd/pull/2563
https://github.com/fluent/fluentd/pull/2564
* output: Use Mutex instead of Monitor
https://github.com/fluent/fluentd/pull/2561
* event: Add `OneEventStrea#empty?` method
https://github.com/fluent/fluentd/pull/2565
* thread: Set thread name for ruby 2.3 or later
https://github.com/fluent/fluentd/pull/2574
* core: Cache msgpack packer/unpacker to avoid the object allocation
https://github.com/fluent/fluentd/pull/2559
* time: Use faster way to get sec and nsec
https://github.com/fluent/fluentd/pull/2557
* buf_file: Reduce IO flush by removing `IO#truncate`
https://github.com/fluent/fluentd/pull/2551
* in_tcp: Improve the performance for multiple event case
https://github.com/fluent/fluentd/pull/2567
* in_syslog: support `source_hostname_key` and `source_address_key` for
unmatched event
https://github.com/fluent/fluentd/pull/2553
* formatter_csv: Improve the format performance.
https://github.com/fluent/fluentd/pull/2529
* parser_csv: Add fast parser for typical cases
https://github.com/fluent/fluentd/pull/2535
* out_forward: Refactor code
https://github.com/fluent/fluentd/pull/2516
https://github.com/fluent/fluentd/pull/2532
[#]## Bug fixes
* output: fix data lost on decompression
https://github.com/fluent/fluentd/pull/2547
* out_exec_filter: fix non-ascii encoding issue
https://github.com/fluent/fluentd/pull/2539
* in_tail: Don't call parser's configure twice
https://github.com/fluent/fluentd/pull/2569
* Fix unused message handling for <section> parameters
https://github.com/fluent/fluentd/pull/2578
* Fix comment/message typos
https://github.com/fluent/fluentd/pull/2549
https://github.com/fluent/fluentd/pull/2554
https://github.com/fluent/fluentd/pull/2556
https://github.com/fluent/fluentd/pull/2566
https://github.com/fluent/fluentd/pull/2573
https://github.com/fluent/fluentd/pull/2576
https://github.com/fluent/fluentd/pull/2583

==== rubygem-get_process_mem ====
Version update (0.2.4 -> 0.2.5)

- updated to version 0.2.5
see installed CHANGELOG.md
[#]# Master - unreleased
[#]# 0.2.5
- Use new sys-proctable interface
(https://github.com/schneems/get_process_mem/pull/36)

==== rubygem-gettext-setup ====
Version update (0.30 -> 0.34)

- updated to version 0.34
no changelog found

==== rubygem-gettext_i18n_rails ====
Version update (1.8.0 -> 1.8.1)

- updated to version 1.8.1
no changelog found

==== rubygem-gpgme ====
Version update (2.0.18 -> 2.0.19)

- updated to version 2.0.19
no changelog found

==== rubygem-haml ====
Version update (5.1.1 -> 5.1.2)

- updated to version 5.1.2
see installed CHANGELOG.md
[#]# 5.1.2
Released on August 6, 2019
([diff](https://github.com/haml/haml/compare/v5.1.1...v5.1.2)).
* Fix crash in some environments such as New Relic by unfreezing string
literals for ParseNode#inspect. [#1016](https://github.com/haml/haml/pull/1016)
(thanks [Jalyna](https://github.com/jalyna))

==== rubygem-highline ====
Version update (2.0.2 -> 2.0.3)

- updated to version 2.0.3
see installed Changelog.md
[#]## 2.0.3 / 2019-10-11
* PR #245 - Suppress `Psych.safe_load` arg warn (@koic)

==== rubygem-hitimes ====
Version update (1.3.1 -> 2.0.0)

- updated to version 2.0.0
see installed HISTORY.md

==== rubygem-hoe ====
Version update (3.18.0 -> 3.22.0)

- updated to version 3.22.0
see installed History.rdoc
=== 2.22.0 / 2020-02-09
* 4 minor enhancements:
* Added metadate mapping for 'docs'.
* Added rdoc extension to the history and readme file finder globs.
* Extended readme parsing to more intelligently deal with markup sections.
* Refactored intuit_values to take the file content as an arg.
* 2 bug fixes:
* Fixed ordering of test_prelude vs framework in Minitest::TestTask.
(flavorjones)
* Fixed wiring of test_prelude into Minitest::TestTask.create. (flavorjones)
=== 3.21.0 / 2020-01-11
* 2 minor enhancements:
* Added support for wiki_uri and mailing_list_uri. (JuanitoFatas)
* Load encrypted private key using ENV['GEM_PRIVATE_KEY_PASSPHRASE'] as
passphrase. (larskanis)
* 5 bug fixes:
* Add require_ruby_version for 2.1+. (MSP-Greg)
* Fix a ruby 2.7 keyword arg deprecation. (anatol)
* Fix debug_gem task when you have a signing_key and broken rubygems (<
3.1.0).
* Fixed shadowed variable and json output for minitest's test:isolated task.
* Minor tweak to make hoe load when openssl isn't available.
=== 3.20.0 / 2019-11-09
* 2 minor enhancements:
* Added <test>:isolated task that runs tests in parallel. Replaces <test>:dep
task.
* Bumped rake dependency to be < 15.
=== 3.19.0 / 2019-10-29
* 4 minor enhancements:
* Added deprecation to parse_urls for ancient url array form.
* Added support for gemspec metadata. (viraptor)
* Hoe#parse_urls now returns a hash no matter what
* Removed looong deprecated Hoe#url/url= methods.
* 1 bug fix:
* Fixed sow for ruby 2.6 deprecations in ERB. (felipec)
=== 3.18.1 / 2019-09-14
* 1 minor enhancement:
* Added deprecations to minitest/test_task: TESTOPTS, N (for #threads),
FILTER.
* 3 bug fixes:
* Fixed one use of Array.prepend on ruby 2.3-2.4.
* Removed FILTER/N/X handling from hoe/test.rb in favor of
minitest/test_task.rb.
* Sort globs before shuffling to normalize different file systems.

==== rubygem-jaro_winkler ====
Version update (1.5.3 -> 1.5.4)

- updated to version 1.5.4
no changelog found

==== rubygem-jbuilder ====
Version update (2.9.1 -> 2.10.0)

- updated to version 2.10.0
see installed CHANGELOG.md
2.10.0
- ---------
* Requires Rails 5+ and Ruby 2.2+
* Nested hashes are deep-merged

==== rubygem-jekyll-sass-converter ====
Version update (1.5.2 -> 2.1.0)

- updated to version 2.1.0
no changelog found

==== rubygem-js-routes ====
Version update (1.4.7 -> 1.4.9)

- updated to version 1.4.9
see installed CHANGELOG.md
[#]# v1.4.9
* Allow to specify null namespace and receive routes as an object without
assigning it anywhere #247

==== rubygem-json-jwt ====
Version update (1.10.2 -> 1.11.0)

- updated to version 1.11.0
no changelog found

==== rubygem-kgio ====
Version update (2.11.2 -> 2.11.3)

- updated to version 2.11.3
see installed NEWS
=== kgio 2.11.3 / 2020-01-08 09:25 UTC
Some doc and warning fixes for newer Rubies.
We're no longer on bogomips.org since it's due
for expiry and I can't pay extortionists for a .org, so
s/bogomips.org/yhbt.net/ for now, and be prepared to move again
when extortionists move onto the .net TLD.
pkg.mk: use --local to "gem install"
pkg.mk: use dark216 theme for Earth Day 2019
test: fix warnings with RUBYOPT=-w
tests: fix unused variable warnings from newer Rubies
test_connect_fd_leak: do not close socket if non-existent
test_syssend: avoid warning on cleanup
build: remove olddoc from the gemspec
doc: remove private email and outdated gmane archives
doc: move from bogomips.org/kgio to yhbt.net/kgio

==== rubygem-listen ====
Version update (3.1.5 -> 3.2.1)

- updated to version 3.2.1
see installed CHANGELOG.md

==== rubygem-mercenary ====
Version update (0.3.6 -> 0.4.0)

- updated to version 0.4.0
see installed History.markdown
[#]# 0.4.0 / 2020-01-18
[#]## Major Enhancements
* Drop Ruby 2.3 support
[#]## Minor Enhancements
* Remove parent command&#39;s flags from subcommand usage (#44)
[#]## Development Fixes
* Adopt Jekyll&#39;s rubocop config for consistency
[#]## Documentation
* fixes the readme (#52)

==== rubygem-mime-types ====
Version update (3.2.2 -> 3.3.1)

- updated to version 3.3.1
see installed History.md
[#]# 3.3.1 / 2019-12-26
* 1 minor bugfix:
* Al Snow fixed a warning with MIME::Types::Logger producing a warning
because Ruby 2.7 introduces numbered block parameters. Because of the
way that the MIME::Types::Logger works for deprecation messages, the
initializer parameters had been named `_1`, `_2`, and `_3`. This has
now been resolved. [#146][]
* Administrivia:
* Olle Jonsson removed an outdated Travis configuration option (`sudo:
false`). [#142][]
[#]# 3.3 / 2019-09-04
* 1 minor enhancement
* Jean Boussier reduced memory usage for Ruby versions 2.3 or higher by
interning various string values in each type. This is done with a
backwards-compatible call that _freezes_ the strings on older
versions of Ruby. [#141][]
* Administrivia:
* Nicholas La Roux updated Travis build configurations. [#139][]

==== rubygem-mime-types-data ====
Version update (3.2019.0331 -> 3.2019.1009)

- updated to version 3.2019.1009
see installed History.md
[#]# 3.2019.10.09 / 2019-10-09
* Updated the IANA media registry entries as of release date.
* Reordered the `.ai` extension so that it is not the preferred extension for
`application/pdf` [#24][].
[#]# 3.2019.0904 / 2019-09-04
* Updated the IANA media registry entries as of release date.
* Moved the `.ai` extension from `application/postscript` to
`application/pdf`.
[#23][] fixing [#22][].

==== rubygem-mimemagic ====
Version update (0.3.3 -> 0.3.4)

- updated to version 0.3.4
see installed CHANGELOG.md
[#]# 0.3.4 (2020-01-28)
Added frozen string literal comments

==== rubygem-mini_magick ====
Version update (4.9.5 -> 4.10.1)

- updated to version 4.10.1
no changelog found

==== rubygem-mixlib-authentication ====
Version update (3.0.1 -> 3.0.6)

- updated to version 3.0.6
no changelog found

==== rubygem-mixlib-cli ====
Version update (2.1.1 -> 2.1.5)

- updated to version 2.1.5
no changelog found

==== rubygem-mixlib-config ====
Version update (3.0.1 -> 3.0.6)

- updated to version 3.0.6
no changelog found

==== rubygem-mixlib-log ====
Version update (3.0.1 -> 3.0.8)

- updated to version 3.0.8
no changelog found

==== rubygem-mixlib-shellout ====
Version update (3.0.4 -> 3.0.9)

- updated to version 3.0.9
no changelog found

==== rubygem-mocha ====
Version update (1.9.0 -> 1.11.2)

- updated to version 1.11.2
no changelog found

==== rubygem-moneta ====
Version update (1.1.1 -> 1.2.1)

- updated to version 1.2.1
see installed CHANGES
1.2.1
* Transformer - fix :escape transformer deserialize implementation (#168)
1.2.0
* Adapters::Sequel - fix for compatibility with new version of JDBC SQLite
* Adapters::Couch - refactor of error handling, #clear, #merge!, #slice, rev
caching
* Fallback - add fallback proxy (#162)
* Pool - rewrite to enable limiting of size, gradual shrinking
* Enumerable - add proxy providing Enumerable API (using #each_key)
* Adapters::Couch, Adapters::RestClient - add Faraday :adapter option
* Adapters::Couch - add :full_commit and :batch options to some operations
* Adapters::LRUHash - rewrite to take advantage of ordered hashes
* Adapters::ActiveRecord - recover from deadlock during increment

==== rubygem-msgpack ====
Version update (1.3.1 -> 1.3.3)

- updated to version 1.3.3
see installed ChangeLog
2020-02-05 version 1.3.3:
* Hotfix release for Windows environments: 1.3.2 missed including binaries
2020-02-04 version 1.3.2:
* Add Ruby 2.7.0 binary in gem releases for Windows

==== rubygem-multi_json ====
Version update (1.13.1 -> 1.14.1)

- updated to version 1.14.1
see installed CHANGELOG.md
1.14.1
- -----
* [Fix a warning in Ruby
2.7](https://github.com/intridea/multi_json/commit/26a94ab8c78a394cc237e2ea292c1de4f6ed30d7)
1.14.0
- -----
* [Support Oj 3.x
gem](https://github.com/intridea/multi_json/commit/5d8febdbebc428882811b90d514f3628617a61d5)

==== rubygem-mustermann-grape ====
Version update (1.0.0 -> 1.0.1)

- updated to version 1.0.1
no changelog found

==== rubygem-net-ldap ====
Version update (0.16.1 -> 0.16.2)

- updated to version 0.16.2
see installed History.rdoc
=== Net::LDAP 0.16.2
* Net::LDAP#open does not cache bind result
{#334}[https://github.com/ruby-ldap/ruby-net-ldap/pull/334]
* Fix CI build {#333}[https://github.com/ruby-ldap/ruby-net-ldap/pull/333]
* Fix to "undefined method 'result_code'"
{#308}[https://github.com/ruby-ldap/ruby-net-ldap/pull/308]
* Fixed Exception: incompatible character encodings: ASCII-8BIT and UTF-8 in
filter.rb {#285}[https://github.com/ruby-ldap/ruby-net-ldap/pull/285]

==== rubygem-oauth2 ====
Version update (1.4.1 -> 1.4.3)

- updated to version 1.4.3
see installed CHANGELOG.md
[#]# [1.4.3] - 2020-01-29
- [#483](https://github.com/oauth-xx/oauth2/pull/483) - add project metadata
to gemspec (@orien)
- [#495](https://github.com/oauth-xx/oauth2/pull/495) - support additional
types of access token requests (@SteveyblamFreeagent, @thomcorley, @dgholz)
- Adds support for private_key_jwt and tls_client_auth
[#]# [1.4.2] - 2019-10-01
- [#478](https://github.com/oauth-xx/oauth2/pull/478) - support latest
version of faraday & fix build (@pboling)
- officially support Ruby 2.6 and truffleruby

==== rubygem-omniauth-google-oauth2 ====
Version update (0.7.0 -> 0.8.0)

- updated to version 0.8.0
see installed CHANGELOG.md
[#]# 0.8.0 - 2019-08-21
[#]## Added
- Updated omniauth-oauth2 to v1.6.0 for security fixes.
[#]## Deprecated
- Nothing.
[#]## Removed
- Ruby 2.1 support.
[#]## Fixed
- Nothing.

==== rubygem-paint ====
Version update (2.1.0 -> 2.1.1)

- updated to version 2.1.1
see installed CHANGELOG.md
[#]## 2.1.1
* Blacklist True Color support for urxvt, fixes #25

==== rubygem-parser ====
Version update (2.7.0.1 -> 2.7.0.2)

- updated to version 2.7.0.2
see installed CHANGELOG.md

==== rubygem-path_expander ====
Version update (1.0.4 -> 1.1.0)

- updated to version 1.1.0
see installed History.rdoc
=== 1.1.0 / 2019-09-22
* 1 minor enhancement:
* Added a default path (default: ".") to scan if no files are initially found.
=== 1.0.5 / 2019-09-14
* 1 bug fix:
* Fixed a deprecation warning from File.exists?

==== rubygem-pg ====
Version update (1.1.4 -> 1.2.2)

- updated to version 1.2.2
see installed ChangeLog

==== rubygem-rack-1_6 ====
Version update (1.6.11 -> 1.6.13)

- updated to version 1.6.13
see installed HISTORY.md

==== rubygem-rack ====
Version update (2.1.2 -> 2.2.2)

- updated to version 2.2.2
see installed CHANGELOG.md
[#]# [2.2.2] - 2020-02-11
[#]## Fixed
- Fix incorrect Rack::Request#host value.
([#1591](https://github.com/rack/rack/pull/1591),
[@ioquatix](https://github.com/ioquatix))
- Revert Rack::Handler::Thin implementation.
([#1583](https://github.com/rack/rack/pull/1583),
[@jeremyevans](https://github.com/jeremyevans))
- Double assignment is still needed to prevent an "unused variable" warning.
([#1589](https://github.com/rack/rack/pull/1589),
[@kamipo](https://github.com/kamipo))
- Fix to handle same_site option for session pool.
([#1587](https://github.com/rack/rack/pull/1587),
[@kamipo](https://github.com/kamipo))
- updated to version 2.2.1
see installed CHANGELOG.md
[#] Changelog
All notable changes to this project will be documented in this file. For info
on how to format all future additions to this file please reference [Keep A
Changelog](https://keepachangelog.com/en/1.0.0/).
[#]# [2.2.1] - 2020-02-09
[#]## Fixed
- Rework `Rack::Request#ip` to handle empty `forwarded_for`.
([#1577](https://github.com/rack/rack/pull/1577),
[@ioquatix](https://github.com/ioquatix))
[#]# [2.2.0] - 2020-02-08
[#]## SPEC Changes
- `rack.session` request environment entry must respond to `to_hash` and
return unfrozen Hash. ([@jeremyevans](https://github.com/jeremyevans))
- Request environment cannot be frozen.
([@jeremyevans](https://github.com/jeremyevans))
- CGI values in the request environment with non-ASCII characters must use
ASCII-8BIT encoding. ([@jeremyevans](https://github.com/jeremyevans))
- Improve SPEC/lint relating to SERVER_NAME, SERVER_PORT and HTTP_HOST.
([#1561](https://github.com/rack/rack/pull/1561),
[@ioquatix](https://github.com/ioquatix))
[#]## Added
- `rackup` supports multiple `-r` options and will require all arguments.
([@jeremyevans](https://github.com/jeremyevans))
- `Server` supports an array of paths to require for the `:require` option.
([@khotta](https://github.com/khotta))
- `Files` supports multipart range requests.
([@fatkodima](https://github.com/fatkodima))
- `Multipart::UploadedFile` supports an IO-like object instead of using the
filesystem, using `:filename` and `:io` options.
([@jeremyevans](https://github.com/jeremyevans))
- `Multipart::UploadedFile` supports keyword arguments `:path`,
`:content_type`, and `:binary` in addition to positional arguments.
([@jeremyevans](https://github.com/jeremyevans))
- `Static` supports a `:cascade` option for calling the app if there is no
matching file. ([@jeremyevans](https://github.com/jeremyevans))
- `Session::Abstract::SessionHash#dig`.
([@jeremyevans](https://github.com/jeremyevans))
- `Response.[]` and `MockResponse.[]` for creating instances using status,
headers, and body. ([@ioquatix](https://github.com/ioquatix))
- Convenient cache and content type methods for `Rack::Response`.
([#1555](https://github.com/rack/rack/pull/1555),
[@ioquatix](https://github.com/ioquatix))
[#]## Changed
- `Request#params` no longer rescues EOFError.
([@jeremyevans](https://github.com/jeremyevans))
- `Directory` uses a streaming approach, significantly improving time to
first byte for large directories.
([@jeremyevans](https://github.com/jeremyevans))
- `Directory` no longer includes a Parent directory link in the root
directory index. ([@jeremyevans](https://github.com/jeremyevans))
- `QueryParser#parse_nested_query` uses original backtrace when reraising
exception with new class. ([@jeremyevans](https://github.com/jeremyevans))
- `ConditionalGet` follows RFC 7232 precedence if both If-None-Match and
If-Modified-Since headers are provided.
([@jeremyevans](https://github.com/jeremyevans))
- `.ru` files supports the `frozen-string-literal` magic comment.
([@eregon](https://github.com/eregon))
- Rely on autoload to load constants instead of requiring internal files,
make sure to require 'rack' and not just 'rack/...'.
([@jeremyevans](https://github.com/jeremyevans))
- `Etag` will continue sending ETag even if the response should not be
cached. ([@henm](https://github.com/henm))
- `Request#host_with_port` no longer includes a colon for a missing or empty
port. ([@AlexWayfer](https://github.com/AlexWayfer))
- All handlers uses keywords arguments instead of an options hash argument.
([@ioquatix](https://github.com/ioquatix))
- `Files` handling of range requests no longer return a body that supports
`to_path`, to ensure range requests are handled correctly.
([@jeremyevans](https://github.com/jeremyevans))
- `Multipart::Generator` only includes `Content-Length` for files with paths,
and `Content-Disposition` `filename` if the `UploadedFile` instance has one.
([@jeremyevans](https://github.com/jeremyevans))
- `Request#ssl?` is true for the `wss` scheme (secure websockets).
([@jeremyevans](https://github.com/jeremyevans))
- `Rack::HeaderHash` is memoized by default.
([#1549](https://github.com/rack/rack/pull/1549),
[@ioquatix](https://github.com/ioquatix))
- `Rack::Directory` allow directory traversal inside root directory.
([#1417](https://github.com/rack/rack/pull/1417),
[@ThomasSevestre](https://github.com/ThomasSevestre))
- Sort encodings by server preference.
([#1184](https://github.com/rack/rack/pull/1184),
[@ioquatix](https://github.com/ioquatix),
[@wjordan](https://github.com/wjordan))
- Rework host/hostname/authority implementation in `Rack::Request`. `#host`
and `#host_with_port` have been changed to correctly return IPv6 addresses
formatted with square brackets, as defined by
[RFC3986](https://tools.ietf.org/html/rfc3986#section-3.2.2).
([#1561](https://github.com/rack/rack/pull/1561),
[@ioquatix](https://github.com/ioquatix))
- `Rack::Builder` parsing options on first `#\` line is deprecated.
([#1574](https://github.com/rack/rack/pull/1574),
[@ioquatix](https://github.com/ioquatix))
[#]## Removed
- `Directory#path` as it was not used and always returned nil.
([@jeremyevans](https://github.com/jeremyevans))
- `BodyProxy#each` as it was only needed to work around a bug in Ruby <1.9.3.
([@jeremyevans](https://github.com/jeremyevans))
- `URLMap::INFINITY` and `URLMap::NEGATIVE_INFINITY`, in favor of
`Float::INFINITY`. ([@ch1c0t](https://github.com/ch1c0t))
- Deprecation of `Rack::File`. It will be deprecated again in rack 2.2 or
3.0. ([@rafaelfranca](https://github.com/rafaelfranca))
- Support for Ruby 2.2 as it is well past EOL.
([@ioquatix](https://github.com/ioquatix))
- Remove `Rack::Files#response_body` as the implementation was broken.
([#1153](https://github.com/rack/rack/pull/1153),
[@ioquatix](https://github.com/ioquatix))
- Remove `SERVER_ADDR` which was never part of the original SPEC.
([#1573](https://github.com/rack/rack/pull/1573),
[@ioquatix](https://github.com/ioquatix))
[#]## Fixed
- `Directory` correctly handles root paths containing glob metacharacters.
([@jeremyevans](https://github.com/jeremyevans))
- `Cascade` uses a new response object for each call if initialized with no
apps. ([@jeremyevans](https://github.com/jeremyevans))
- `BodyProxy` correctly delegates keyword arguments to the body object on
Ruby 2.7+. ([@jeremyevans](https://github.com/jeremyevans))
- `BodyProxy#method` correctly handles methods delegated to the body object.
([@jeremyevans](https://github.com/jeremyevans))
- `Request#host` and `Request#host_with_port` handle IPv6 addresses
correctly. ([@AlexWayfer](https://github.com/AlexWayfer))
- `Lint` checks when response hijacking that `rack.hijack` is called with a
valid object. ([@jeremyevans](https://github.com/jeremyevans))
- `Response#write` correctly updates `Content-Length` if initialized with a
body. ([@jeremyevans](https://github.com/jeremyevans))
- `CommonLogger` includes `SCRIPT_NAME` when logging.
([@Erol](https://github.com/Erol))
- `Utils.parse_nested_query` correctly handles empty queries, using an empty
instance of the params class instead of a hash.
([@jeremyevans](https://github.com/jeremyevans))
- `Directory` correctly escapes paths in links.
([@yous](https://github.com/yous))
- `Request#delete_cookie` and related `Utils` methods handle `:domain` and
`:path` options in same call. ([@jeremyevans](https://github.com/jeremyevans))
- `Request#delete_cookie` and related `Utils` methods do an exact match on
`:domain` and `:path` options. ([@jeremyevans](https://github.com/jeremyevans))
- `Static` no longer adds headers when a gzipped file request has a 304
response. ([@chooh](https://github.com/chooh))
- `ContentLength` sets `Content-Length` response header even for bodies not
responding to `to_ary`. ([@jeremyevans](https://github.com/jeremyevans))
- Thin handler supports options passed directly to
`Thin::Controllers::Controller`.
([@jeremyevans](https://github.com/jeremyevans))
- WEBrick handler no longer ignores `:BindAddress` option.
([@jeremyevans](https://github.com/jeremyevans))
- `ShowExceptions` handles invalid POST data.
([@jeremyevans](https://github.com/jeremyevans))
- Basic authentication requires a password, even if the password is empty.
([@jeremyevans](https://github.com/jeremyevans))
- `Lint` checks response is array with 3 elements, per SPEC.
([@jeremyevans](https://github.com/jeremyevans))
- Support for using `:SSLEnable` option when using WEBrick handler. (Gregor
Melhorn)
- Close response body after buffering it when buffering.
([@ioquatix](https://github.com/ioquatix))
- Only accept `;` as delimiter when parsing cookies.
([@mrageh](https://github.com/mrageh))
- `Utils::HeaderHash#clear` clears the name mapping as well.
([@raxoft](https://github.com/raxoft))
- Support for passing `nil` `Rack::Files.new`, which notably fixes Rails'
current `ActiveStorage::FileServer` implementation.
([@ioquatix](https://github.com/ioquatix))
[#]## Documentation
- CHANGELOG updates. ([@aupajo](https://github.com/aupajo))
- Added [CONTRIBUTING](CONTRIBUTING.md).
([@dblock](https://github.com/dblock))

==== rubygem-rack-oauth2 ====
Version update (1.10.0 -> 1.10.1)

- updated to version 1.10.1
no changelog found

==== rubygem-rack-protection ====
Version update (2.0.5 -> 2.0.8.1)

- updated to version 2.0.8.1
no changelog found

==== rubygem-rails-i18n ====
Version update (5.1.3 -> 6.0.0)

- updated to version 6.0.0
see installed CHANGELOG.md
[#]# 6.0.0
- Update rails-i18n.gemspec to use Railties 6.0.0
- Add Malagasy (mg) locale
- Update following locales:
- Afrikaans (af)
- Arabic (ar)
- Azerbaijani (az)
- Belarusian (be)
- Bulgarian (bg)
- Bengali (bn)
- Bosnian (bs)
- Catalan (ca)
- Czech (cs)
- Welsh (cy)
- Danish (da)
- German (de-AT, de-CH, de-DE, de)
- Greek (el-CY, el)
- English (en-AU, en-CA, en-CY, en-GB, en-IE, en-IN, en-NZ, en-US, en-Za, en)
- Esperanto (eo)
- Spanish (es-419, es-AR, es-CL, es-CO, es-CR, es-EC, es-ES, es-MX, es-NI,
es-PA, es-PE, es-US, es-VE, es)
- Estonian (et)
- Basque (eu)
- Farsi/Persian (fa)
- Finnish (fi)
- French (fr-CA, fr-CH, fr-FR, fr)
- Galician (gl)
- Hebrew (he)
- Hindi (hi-IN, hi)
- Croatian (hr)
- Hungarian (hu)
- Indonesian (id)
- Icelandic (is)
- Italian (it, it-CH)
- Japanese (ja)
- Georgian (ka)
- Khmer (km)
- Kannada (kn)
- Korean (ko)
- Luxembourgish (lb)
- Lao (lo)
- Lithuanian (lt)
- Latvian (lv)
- Malagasy (mg)
- Macedonian (mk)
- Malayalam (ml)
- Mongolian (mn)
- Marathi (mr-IN)
- Malay (ms)
- Norwegian Bokmål (nb)
- Nepali (ne)
- Dutch (nl)
- Norwegian (nn)
- Occitan (oc)
- Oriya/Odiya (or)
- Panjabi (pa)
- Polish (pl)
- Portuguese (pt-BR, pt)
- Raeto-Romance (rm)
- Romanian (ro)
- Russian (ru)
- Slovak (sk)
- Slovenian (sl)
- Albanian (sq)
- Cyrillic Serbian (sr)
- Swedish (sv-SE, sv)
- Swahili (sw)
- Tamil (ta)
- Telugu (te)
- Thai (th)
- Tagalog (tl)
- Turkish (tr)
- Tatar (tt)
- Uyghur (ug)
- Ukrainian (uk)
- Urdu (ur)
- Uzbek (uz)
- Vietnamese (vi)
- Wolof (wo)
- Chinese (zh-CN, zh-HK, zh-TW, zh-YUE)
[#]# 6.0.0.beta1 (2019-01-28)
- Update rails-i18n.gemspec to use Railties 6.0.0.beta1
- Update Gemfile
- Update .travis.yml

==== rubygem-raindrops ====
Version update (0.19.0 -> 0.19.1)

- updated to version 0.19.1
see installed NEWS
=== raindrops 0.19.1 / 2020-01-08 09:31 UTC
This release fixes some warnings on newer Rubies.
We're no longer on bogomips.org since it's due
for expiry and I can't pay extortionists for a .org, so
s/bogomips.org/yhbt.net/ for now, and be prepared to move again
when extortionists move onto extorting the .net TLD.
doc: switch homepage to dark216
ext/raindrops/extconf: fix cflags reset on ancient CC
fixes for newer rubies
replace bogomips.org with yhbt.net

==== rubygem-rake-compiler ====
Version update (1.0.7 -> 1.1.0)

- updated to version 1.1.0
see installed History.txt
=== 1.1.0 / 2012-12-25
* Bugfixes:
* Fix a bug that JavaExtenstionTask can't build anything.
[#163] [Reported by Kai Kuchenbecker]
=== 1.0.9 / 2012-12-23
* Changes:
* Use "-Xlint" option for JRuby native extension by default.
[#158] [Patch by Stephen George]
* Enhancements:
* Make customizable compiler Xlint option for JRuby native extension.
[#118] [Patch by Hiroshi Hatake]
* Add support for Ruby 2.7.
[#161] [Reported by Masaki Hara]
=== 1.0.8 / 2019-09-21
* Enhancements:
* Added Rake::JavaExtensionTask#encoding= to pass the -encoding option to
javac.
[#157] [Patch by Tiago Dias]
* Bugfixes:
* Drop EOL'd rubyforge_project directive from .gemspec.
[#155] [Patch by Olle Jonsson]

==== rubygem-reverse_markdown ====
Version update (1.2.0 -> 1.4.0)

- updated to version 1.4.0
see installed CHANGELOG.md
[#]# 1.4.0 ? January 2020
- BREAKING: jump links will no longer be ignored but treated as links, see #82
[#]# 1.3.0 - September 2019
- Add support for `s` HTML tag, thanks @fauno

==== rubygem-rouge ====
Version update (3.6.0 -> 3.15.0)

- updated to version 3.15.0
no changelog found

==== rubygem-ruby-openid ====
Version update (2.7.0 -> 2.9.2)

- updated to version 2.9.2
see installed CHANGELOG.md
[#]# 2.9.2
* Perform all checks before verifying endpoints.
[#126](https://github.com/openid/ruby-openid/pull/126)
[#]# 2.9.1
* Updated CHANGELOG.md
[#]# 2.9.0
* Remove deprecated `autorequire` from gemspec.
[#123](https://github.com/openid/ruby-openid/pull/123)
* Rescue from `Yadis::XRI::XRIHTTPError` on discovery.
[#106](https://github.com/openid/ruby-openid/pull/106)
* Avoid SSRF for claimed_id request.
[#121](https://github.com/openid/ruby-openid/pull/121)
* Updated documentation.
[#115](https://github.com/openid/ruby-openid/pull/115),
[#116](https://github.com/openid/ruby-openid/pull/116),
[#117](https://github.com/openid/ruby-openid/pull/117),
[#118](https://github.com/openid/ruby-openid/pull/118)
* Reduce warnings output in test runs.
[#119](https://github.com/openid/ruby-openid/pull/119)
* Drop deprecated option from gemspec.
[#120](https://github.com/openid/ruby-openid/pull/120)
* Remove circular require.
[#113](https://github.com/openid/ruby-openid/pull/113)
* Updated Travis CI config with Ruby 2.6
[#114](https://github.com/openid/ruby-openid/pull/114)
* Simplify Bundler require; remove need for extra `:require`.
[#112](https://github.com/openid/ruby-openid/pull/112)
[#]# 2.8.0
* Fix `admin/mkassoc` script.
See https://github.com/openid/ruby-openid/pull/103
* Allow specifying timeout for `OpenID::StandardFetcher` in environment
variables.
See https://github.com/openid/ruby-openid/pull/109
* Fixed some documentation.
See https://github.com/openid/ruby-openid/pull/111
* Fixed example server.
See https://github.com/openid/ruby-openid/pull/91
* Fixed tests.
See https://github.com/openid/ruby-openid/pull/86
* Misc. changes to the CI setup.
See
- https://github.com/openid/ruby-openid/pull/110
- https://github.com/openid/ruby-openid/pull/108
- https://github.com/openid/ruby-openid/pull/107

==== rubygem-ruby_parser ====
Version update (3.13.1 -> 3.14.2)

- updated to version 3.14.2
see installed History.rdoc
=== 3.14.2 / 2020-02-06
* 1 minor enhancement:
* Cleaned up call_args and removed arg_blk_pass from ruby_parser_extras.rb!
Yay!
=== 3.14.1 / 2019-10-29
* 1 minor enhancement:
* Declared that ruby_parser supports ruby 2.2 and up.
* 3 bug fixes:
* Fixed a problem with %W with a null-byte terminator. (wtf?) (spohlenz)
* Fixed line numbering for command (eg methods without parentheses)
arguments. (mvz)
* Fixed lineno on new dxstrs. (presidentbeef)
=== 3.14.0 / 2019-09-24
* 8 minor enhancements:
* Added Sexp#line_min & new line number debugging feature.
* Allow bin/ruby_parse to use RP_TIMEOUT to tweak default timeout for large
files & slow debugging modes.
* Did you know that custom inspect can't be > 65 chars? 65! Me neither. Fixed.
* For now, value_expr == remove_begin.
* Improved error messages for unterminated regexps.
* Moved all STR_* consts into State::Values and made them State instances.
* Overhauled RubyLexer::State + Values to allow for completely separate
groups of States.
* RubyParserExtras#remove_begin removes nested begins and patches line
numbers.
* 22 bug fixes:
* Changed EOF signaling to return [false, false] per doco.
* Changed RubyParserStuff#remove_begin to keep inner line number, if any.
(mvz)
* Differentiated between lambda call and stabby proc. Added :lambda sexp.
(whitequark)
* Extended State#== to check equal? first as an optimization.
* Fixed a bug in tab indent width.
* Fixed a line numbering bug for assignables.
* Fixed a line numbering bug for defns w/ nil bodies.
* Fixed another missing line number, driven out by ruby_to_ruby bootstrap.
* Fixed dedenting squiggle heredocs if interpolation is in the mix. (mvz)
* Fixed differentiation of `{ |a| ... }` vs `{ |a,| ... }`. Fixes #236
(whitequark).
* Fixed lex_state for symbols.
* Fixed lex_state for tSTRING_END and tREGEXP_END.
* Fixed line numbers for BEGIN block. (mvz)
* Fixed op_asgn1 w/ command_call having array instead of arglist. (mvz)
* Fixed parsing of () in a command-call (eg p).
* Fixed remaining missing line numbers by forcing extra checks during test
and blowing up. They may still be wrong (esp after heredocs, ugh), but they're
there! Special thank you to mvz for pushing on this and providing tests and PRs.
* Fixed some lex_state versioning issues with closing braces/bracket on
ruby<25.
* Keep carriage return escapes in heredocs. (mvz)
* Massive overhaul of line number code.
* More line number fixes and extra tests from mvz. Thank you!
* Parsing BEGIN block when not at top level should raise an error. (mvz)
* Removed irb task from Rakefile as it has been pushed up to Hoe and doubles
up here.

==== rubygem-serverengine ====
Version update (2.1.1 -> 2.2.1)

- updated to version 2.2.1
see installed Changelog
2020-01-24 version 2.2.1:
* Fix IPv6 dual-stack mode issue for UDP
* experimental: Add SERVERENGINE_USE_SOCKET_REUSEPORT envvar to enable
SO_REUSEPORT
2019-11-16 version 2.2.0:
* Fix IPv6 dual-stack mode issue for TCP

==== rubygem-sexp_processor ====
Version update (4.12.1 -> 4.14.1)

- updated to version 4.14.1
see installed History.rdoc
=== 4.14.1 / 2020-02-09
* 2 bug fixes:
* Declared support for ruby 2.2+ to gemspec.
* Fixed alias for `not?` to `-` for ruby <= 2.4. (nard-tech).
=== 4.14.0 / 2020-02-06
* 4 minor enhancements:
* Added '-' as an alias for the 'not?' pattern matching command.
* Added Klass matcher to match on types.
* Added `k` shortcut for Klass & hooked into Sexp::Matcher.parse.
* Added any matcher to pattern parser.
=== 4.13.0 / 2019-09-24
* 4 minor enhancements:
* Added Sexp.q (query) and deprecated Sexp.s to distinguish better and match
inspect output.
* Extended Sexp::Matcher::Parser to allow `not?` patterns.
* Extended Sexp::Matcher::Parser to cover more method names.
* Split out all pattern-oriented code to sexp_matcher.rb.
* 1 bug fix:
* Fixed bug w/ ruby's Array#eql? and #hash not looking at ivars.

==== rubygem-simplecov ====
Version update (0.17.0 -> 0.18.1)

- updated to version 0.18.1
see installed CHANGELOG.md
0.18.1 (2020-01-31)
===================
Small Bugfix release.
[#]# Bugfixes
* Just putting `# :nocov:` on top of a file or having an uneven number of
them in general works again and acts as if ignoring until the end of the file.
See [#846](https://github.com/colszowka/simplecov/issues/846) and thanks
[@DannyBen](https://github.com/DannyBen) for the report.
0.18.0 (2020-01-28)
===================
Huge release! Highlights are support for branch coverage (Ruby 2.5+) and
dropping support for EOL'ed Ruby versions (< 2.4).
Please also read the other beta patch notes.
You can run with branch coverage by putting `enable_coverage :branch` into
your SimpleCov configuration (like the `SimpleCov.start do .. end` block)
[#]# Enhancements
* You can now define the minimum expected coverage by criterion like
`minimum_coverage line: 90, branch: 80`
* Memoized some internal data structures that didn't change to reduce
SimpleCov overhead
* Both `FileList` and `SourceFile` now have a `coverage` method that returns
a hash that points from a coverage criterion to a `CoverageStatistics` object
for uniform access to overall coverage statistics for both line and branch
coverage
[#]# Bugfixes
* we were losing precision by rounding the covered strength early, that has
been removed. **For Formatters** this also means that you may need to round it
yourself now.
* Removed an inconsistency in how we treat skipped vs. irrelevant lines (see
[#565](https://github.com/colszowka/simplecov/issues/565)) - SimpleCov's
definition of 100% is now "You covered everything that you could" so if
coverage is 0/0 that's counted as a 100% no matter if the lines were irrelevant
or ignored/skipped
[#]# Noteworthy
* `FileList` stopped inheriting from Array, it includes Enumerable so if you
didn't use Array specific methods on it in formatters you should be fine
0.18.0.beta3 (2020-01-20)
========================
[#]# Enhancements
* Instead of ignoring old `.resultset.json`s that are inside the merge
timeout, adapt and respect them
[#]# Bugfixes
* Remove the constant warning printing if you still have a `.resultset.json`
in pre 0.18 layout that is within your merge timeout
0.18.0.beta2 (2020-01-19)
===================
[#]# Enhancements
* only turn on the requested coverage criteria (when activating branch
coverage before SimpleCov would also instruct Ruby to take Method coverage)
* Change how branch coverage is displayed, now it's `branch_type: hit_count`
which should be more self explanatory. See
[#830](https://github.com/colszowka/simplecov/pull/830) for an example and feel
free to give feedback!
* Allow early running exit tasks and avoid the `at_exit` hook through the
`SimpleCov.run_exit_tasks!` method. (thanks
[@macumber](https://github.com/macumber))
* Allow manual collation of result sets through the `SimpleCov.collate`
entrypoint. See the README for more details (thanks
[@ticky](https://github.com/ticky))
* Within `case`, even if there is no `else` branch declared show missing
coverage for it (aka no branch of it). See
[#825](https://github.com/colszowka/simplecov/pull/825)
* Stop symbolizing all keys when loading cache (should lead to be faster and
consume less memory)
* Cache whether we can use/are using branch coverage (should be slightly
faster)
[#]# Bugfixes
* Fix a crash that happened when an old version of our internal cache file
`.resultset.json` was still present
0.18.0.beta1 (2020-01-05)
===================
This is a huge release highlighted by changing our support for ruby versions
to 2.4+ (so things that aren't EOL'ed) and finally adding branch coverage
support!
This release is still beta because we'd love for you to test out branch
coverage and get your feedback before doing a full release.
On a personal note from [@PragTob](https://github.com/PragTob/) thanks to
[ruby together](https://rubytogether.org/) for sponsoring this work on
SimpleCov making it possible to deliver this and subsequent releases.
[#]# Breaking
* Dropped support for all EOL'ed rubies meaning we only support 2.4+.
Simplecov can no longer be installed on older rubies, but older simplecov
releases should still work. (thanks
[@deivid-rodriguez](https://github.com/deivid-rodriguez))
* Dropped the `rake simplecov` task that "magically" integreated with rails.
It was always undocumented, caused some issues and [had some
issues](https://github.com/colszowka/simplecov/issues/689#issuecomment-561572327).
Use the integration as described in the README please :)
[#]# Enhancements
* Branch coverage is here! Please try it out and test it! You can activate it
with `enable_coverage :branch`. See the README for more details. This is thanks
to a bunch of people most notably [@som4ik](https://github.com/som4ik),
[@tycooon](https://github.com/tycooon),
[@stepozer](https://github.com/stepozer),
[@klyonrad](https://github.com/klyonrad) and your humble maintainers also
contributed ;)
* If the minimum coverage is set to be greater than 100, a warning will be
shown. See [#737](https://github.com/colszowka/simplecov/pull/737) (thanks
[@belfazt](https://github.com/belfazt))
* Add a configuration option to disable the printing of non-successful exit
statuses. See [#747](https://github.com/colszowka/simplecov/pull/746) (thanks
[@JacobEvelyn](https://github.com/JacobEvelyn))
* Calculating 100% coverage is now stricter, so 100% means 100%. See
[#680](https://github.com/colszowka/simplecov/pull/680) thanks
[@gleseur](https://github.com/gleseur)
[#]# Bugfixes
* Add new instance of `Minitest` constant. The `MiniTest` constant (with the
capital T) will be removed in the next major release of Minitest. See
[#757](https://github.com/colszowka/simplecov/pull/757) (thanks
[@adam12](https://github.com/adam12))
0.17.1 (2019-09-16)
===================
Bugfix release for problems with ParallelTests.
[#]# Bugfixes
* Avoid hanging with parallel_tests. See
[#746](https://github.com/colszowka/simplecov/pull/746) (thanks
[@annaswims](https://github.com/annaswims))

==== rubygem-simplecov-html ====
Version update (0.10.2 -> 0.11.0)

- updated to version 0.11.0
see installed CHANGELOG.md

==== rubygem-slop ====
Version update (4.7.0 -> 4.8.0)

- updated to version 4.8.0
see installed CHANGELOG.md
v4.8.0 (2020-01-17)
- ------------------
Features:
* Add support for prefixing integer values with `+` character
[#243](https://github.com/leejarvis/slop/pull/243) (Juha Ylitalo)
* Add support for parsing floats with scientific notation
[#250](https://github.com/leejarvis/slop/pull/250) (Hansuk Hong)
Maintenance:
* Add 2.7.0 to CI and fix warnings
[#248](https://github.com/leejarvis/slop/pull/248) (Juha Ylitalo, Andrew
Kane)

==== rubygem-sqlite3 ====
Version update (1.4.1 -> 1.4.2)

- updated to version 1.4.2
see installed CHANGELOG.rdoc
=== 1.4.2
* Travis: Drop unused setting "sudo: false"
* The taint mechanism will be deprecated in Ruby 2.7
* Fix Ruby 2.7 rb_check_safe_obj warnings
* Update travis config
=== 1.4.1
* Don't mandate dl functions for the extention build
* bumping version

==== rubygem-sshkit ====
Version update (1.19.1 -> 1.20.0)

- updated to version 1.20.0
see installed CHANGELOG.md
[#]# [1.20.0][] (2019-08-03)
* [#468](https://github.com/capistrano/sshkit/pull/468): Make `upload!` take
a `:verbosity` option like `exec` does - [@grosser](https://github.com/grosser)

==== rubygem-stomp ====
Version update (1.4.8 -> 1.4.9)

- updated to version 1.4.9
see installed CHANGELOG.md
[#]# 1.4.9 20191116
* More debugging messages in netio.rb.
* Test workaround for Artemis-2289.
* New put and get examples.
* Fix issue #160.
* Address issue #155.
* Suppress SSL stacktrace to stdout.
* Example logger enhancements.
* Optional STOMP frame in examples.

==== rubygem-temple ====
Version update (0.8.1 -> 0.8.2)

- updated to version 0.8.2
see installed CHANGES
0.8.2
* Support TruffleRuby in Temple::Filters::StaticAnalyzer (#127)
* Support TruffleRuby in Temple::Filters::StringSplitter (#127)

==== rubygem-tins ====
Version update (1.21.1 -> 1.24.1)

- updated to version 1.24.1
no changelog found

==== rubygem-tomlrb ====
Version update (1.2.8 -> 1.2.9)

- updated to version 1.2.9
no changelog found

==== rubygem-trollop ====
Version update (2.9.9 -> 2.9.10)

- updated to version 2.9.10
see installed History.txt

==== rubygem-tzinfo-0 ====
Version update (0.3.55 -> 0.3.56)

- updated to version 0.3.56
see installed CHANGES
== Version 0.3.56 (tzdata v2019c) - 1-Nov-2019
* Updated to tzdata version 2019c
(https://mm.icann.org/pipermail/tz-announce/2019-September/000057.html).

==== rubygem-tzinfo ====
Version update (2.0.0 -> 2.0.1)

- updated to version 2.0.1
see installed CHANGES.md
[#]# Version 2.0.1 - 24-Dec-2019
* Fixed "SecurityError: Insecure operation - require" exceptions when loading
data with recent Ruby releases in safe mode. #100.
* Fixed warnings when running on Ruby 2.7. #109.
* Add a `TZInfo::Timezone#=~` method that performs a regex match on the time
zone identifier. #99.
* Add a `TZInfo::Country#=~` method that performs a regex match on the country
code.

==== rubygem-tzinfo-data ====
Version update (1.2019.2 -> 1.2019.3)

- updated to version 1.2019.3
no changelog found

==== rubygem-unicode-display_width ====
Version update (1.6.0 -> 1.6.1)

- updated to version 1.6.1
see installed CHANGELOG.md
[#]# 1.6.1
- Fix that ambiguous and overwrite options where ignored for emoji-measuring

==== rubygem-webpacker ====
Version update (4.2.0 -> 4.2.2)

- updated to version 4.2.2
see installed CHANGELOG.md
[#]# [[4.2.2]](https://github.com/rails/webpacker/compare/v4.2.1...v4.2.2) -
2019-12-09
- Fixed issue with webpack clean task for nested assets
[#2391](https://github.com/rails/webpacker/pull/2391)
[#]# [[4.2.1]](https://github.com/rails/webpacker/compare/v4.2.0...v4.2.1) -
2019-12-09
- Fixed issue with webpack clean task
[#2389](https://github.com/rails/webpacker/pull/2389)

==== rubygem-winrm-elevated ====
Version update (1.1.1 -> 1.2.0)

- updated to version 1.2.0
no changelog found

==== xapps ====
Subpackages: libxapp1 typelib-1_0-XApp-1_0 xapps-common xapps-common-lang

- Add xapps-python3.patch, fix issues to build without python2

==== yast2-http-server ====
Version update (4.2.6 -> 4.2.7)

- Propose to restart the http service as the default action when it
is running (bsc#1165638)
- 4.2.7

==== yast2-network ====
Version update (4.2.58 -> 4.2.60)

- bsc#1164506
- fixed setting hostname in installer
- bsc#1164587
- fixed setting hostname according to AY profile
- 4.2.60
- Do not modify interface name when enslaving it (bsc#1165463)
- 4.2.59

==== yast2-packager ====
Version update (4.2.54 -> 4.2.56)

- fix showing count of packages to install in slide show
(bsc#1161412)
- 4.2.56

==== yast2-storage-ng ====
Version update (4.2.90 -> 4.2.93)

- Fix unit tests for the progress dialog added in version 4.2.82
(related to bsc#1135366).
- 4.2.93
- AutoYaST: export the 'disklabel' attribute for software RAID
devices.
- AutoYaST: include a 'partitions' section when exporting an
unpartitioned software RAID which is not used as a filesystem
(bsc#1159201).
- 4.2.92
- Partitioner: allow to select APQNs when encrypting with pervasive
encryption (jsc#SLE-7376).
- 4.2.91


< Previous Next >
This Thread
  • No further messages