Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200304 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Fri, 06 Mar 2020 12:00:30 +0000
  • Message-id: <158349603044.22515.17464258083196121730@go-agent-stagingbot-4>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200304

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.9.25 -> 7.0.9.27)
PackageKit (1.1.12 -> 1.1.13)
boost-base
boost-extra
gcc10 (9.2.1+git1022 -> 10.0.1+git174776)
gcc9
libqt5-qtwebengine
libzypp (17.23.0 -> 17.23.1)
logrotate (3.15.1 -> 3.16.0)
lvm2
lvm2-device-mapper
perl-Encode (3.02 -> 3.03)
rubygem-bootsnap (1.4.5 -> 1.4.6)
rubygem-concurrent-ruby (1.1.5 -> 1.1.6)
rubygem-lolcat (100.0.0 -> 100.0.1)
rubygem-puma (4.3.1 -> 4.3.3)

=== Details ===

==== ImageMagick ====
Version update (7.0.9.25 -> 7.0.9.27)
Subpackages: ImageMagick-config-7-SUSE ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI7 libMagickWand-7_Q16HDRI7 perl-PerlMagick

- version update to 7.0.9.27
* Make sure we can grok this Fx expression: 1- -2.
* Do not advance when substituting a NULL string.
* Correct alpha for named colors in the Q32 non-HDRI build.
* Write Group4 compressed image as a single strip.
* No percent sign in lab() color.
* Introducing the -color-threshold command-line option.
* Handle out of range HDRI values for -statistic option (reference
https://imagemagick.org/discourse-server/viewtopic.php?f=3&t=37589).
* Fix improper casting when computing image signature (reference
https://imagemagick.org/discourse-server/viewtopic.php?f=1&t=37594).

==== PackageKit ====
Version update (1.1.12 -> 1.1.13)
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module PackageKit-lang libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- No longer recommend -lang: supplements are in use
- Fix autotools modifications in openSUSE vendor patch
+ Patch: PackageKit-dnf-Add-openSUSE-vendor.patch
- Update to version 1.1.13
+ New APIs for pk-client-helper in packagekit-glib2
+ dnf, zypp: Various fixes related to upgrades
+ Added support for user services
+ New plymouth "system-upgrade" and "reboot" modes used now
+ Add mutex lock to protect EULAs array
+ Correct bug tracker links on website
+ Support non-x86 arches in gstreamer helper
+ List installed, removed and obsoleted packages in pkcon get-updates
+ Properly mark obsoleted packages when simulating upgrade
+ Provide information about obsoleted packages
+ Return directly when its state is going backwards
+ Shrink the progress bar to fit when run in small spaces
+ Improve the 'using' documentation with a link to API
- Remove upstreamed patches:
+ PackageKit-add-mutex-lock-to-protect-backend-priv-eulas.patch
+ PackageKit-return-on-transactions-going-backwards.patch
+ PackageKit-zypp-dont-set-upgrade-mode-on-updating-specific-packages.patch
+ PackageKit-zypp-fix-newest-filter.patch
+ PackageKit-zypp-fix-what-provides-newest-filter.patch
+ PackageKit-zypp-get-files-string-array.patch
+ PackageKit-zypp-get-updates-dup-or-up.patch
+ PackageKit-zypp-upgrade-system.patch
+ zypp-perform-actions-disallowed-by-update-in-upgrade-mode.patch
+ 0001-dnf-Don-t-override-DnfContext-s-release_ver-for-the-.patch
+ 0001-dnf-Invalidate-the-sack-cache-after-downloading-new-.patch
+ 0001-offline-update-Use-new-plymouth-system-upgrade-and-r.patch
- Add new openSUSE specific patches for DNF backend:
+ PackageKit-dnf-Add-openSUSE-vendor.patch
+ PackageKit-dnf-Add-support-for-AppStream-repodata-basenames-use.patch
- Remove old openSUSE patches for the DNF backend:
+ 1001-dnf-Add-openSUSE-Tumbleweed-vendor.patch
+ 1002-dnf-Add-support-for-AppStream-repodata-basenames-use.patch
- Refresh patches:
+ PackageKit-drop-gtk2.patch

==== boost-base ====
Subpackages: boost-license1_71_0 boost1_71_0-jam libboost_date_time1_71_0
libboost_filesystem1_71_0 libboost_headers1_71_0-devel libboost_iostreams1_71_0
libboost_locale1_71_0 libboost_program_options1_71_0 libboost_regex1_71_0
libboost_thread1_71_0

- Fix macro which defines the name of the HPC python3 library
directory (bsc#1165277).
- Include headers and serial libs in the HPC MPI packages
(bsc#1165307).

==== boost-extra ====

- Fix macro which defines the name of the HPC python3 library
directory (bsc#1165277).
- Include headers and serial libs in the HPC MPI packages
(bsc#1165307).

==== gcc10 ====
Version update (9.2.1+git1022 -> 10.0.1+git174776)
Subpackages: libatomic1 libgcc_s1 libgcc_s1-32bit libgfortran5 libgomp1 libitm1
liblsan0 libobjc4 libquadmath0 libstdc++6 libstdc++6-32bit libstdc++6-locale
libtsan0 libubsan1

- Add libstdc++6-pp provides and conflicts to avoid file conflicts
with same minor version of libstdc++6-pp from gcc9.
- Disable zstd use for SLES15 and older.
- Bump to rfa1160f6e50500aa38162fefb43bfb10c25e0363.
- Bump to r33351ff9faa21c4c1af377d661a52ac0ce366db3.
- Adjust installed headers for arm and aarch64, enable link-mutex
for riscv64.
- Don't remove go tool buildid, needed for bootstrapping go
- Increase disk constraint
- Bump to rc940105cc17111be98d8d42ba48a413b0e63aebe.
- Bump libtool version of libgo.
- Bump to r269e8130b77065452698ab97e5da77d132d00276.
- Bump to r507de5ee23efdc8a16d6b0b6488e118055c711cd.
- Add lto-dump to cross packages.
- New package, inherits from gcc9
* gcc-add-defaultsspec.diff, add the ability to provide a specs
file that is read by default
* tls-no-direct.diff, avoid direct %fs references on x86 to not
slow down Xen
* gcc43-no-unwind-tables.diff, do not produce unwind tables for
CRT files
* gcc41-ppc32-retaddr.patch, fix expansion of __builtin_return_addr
for ppc, just a testcase
* gcc44-textdomain.patch, make translation files version specific
and adjust textdomain to find them
* gcc44-rename-info-files.patch, fix cross-references in info files
when renaming them to be version specific
* gcc48-libstdc++-api-reference.patch, fix link in the installed
libstdc++ html documentation
* gcc48-remove-mpfr-2.4.0-requirement.patch, make GCC work with
earlier mpfr versions on old products
* gcc5-no-return-gcc43-workaround.patch, make build work with
host gcc 4.3
* gcc7-remove-Wexpansion-to-defined-from-Wextra.patch, removes
new warning from -Wextra
* gcc7-avoid-fixinc-error.diff

==== gcc9 ====
Subpackages: cpp9 gcc9-c++ gcc9-fortran gcc9-info gcc9-locale gcc9-objc
libasan5 libstdc++6-devel-gcc9

- Add libstdc++6-pp provides and conflicts to avoid file conflicts
with same minor version of libstdc++6-pp from gcc10.
- Install go tool buildid for bootstrapping go

==== libqt5-qtwebengine ====

- Fix a deadlock causing audio/video playback to fail (boo#1163744):
* QTBUG-82186.patch
- Fix an issue with selections breaking replying in KMail:
* QTBUG-81574.patch

==== libzypp ====
Version update (17.23.0 -> 17.23.1)

- Fix package status computation regarding unneeded, orphaned, recommended
and suggested packages (broken in 17.23.0) (bsc#1165476)
- version 17.23.1 (22)

==== logrotate ====
Version update (3.15.1 -> 3.16.0)

- Update to 3.16.0 bsc#1160281:
* fix compilation with gcc-10, which defaults to -fno-common (#288)
* reduce number of open() operations on state file (#282)
* validate user/group given to the su directive early (#276)
* add hardening options to systemd unit file in examples (#274, #291)
* fix crash of logrotate on invalid configuration with include (#271)
* fix heap buffer overflow on too long logfile extension (#270)

==== lvm2 ====
Subpackages: liblvm2cmd2_03

- vgreduce --removemissing with cache devices will remove lvs (bsc#1157736)
+ bug-1157736-add-suggestion-message-for-mirror-LVs.patch

==== lvm2-device-mapper ====
Subpackages: device-mapper libdevmapper-event1_03 libdevmapper1_03
libdevmapper1_03-32bit

- vgreduce --removemissing with cache devices will remove lvs (bsc#1157736)
+ bug-1157736-add-suggestion-message-for-mirror-LVs.patch

==== perl-Encode ====
Version update (3.02 -> 3.03)

- updated to 3.03
see /usr/share/doc/packages/perl-Encode/Changes

==== rubygem-bootsnap ====
Version update (1.4.5 -> 1.4.6)

- updated to version 1.4.6
* no changelog found

==== rubygem-concurrent-ruby ====
Version update (1.1.5 -> 1.1.6)

- updated to version 1.1.6
[#]# Release v1.1.6, edge v0.6.0 (10 Feb 2020)
concurrent-ruby:
* (#841) Concurrent.disable_at_exit_handlers! is no longer needed and was
deprecated.
* (#841) AbstractExecutorService#auto_terminate= was deprecated and has no
effect.
Set :auto_terminate option instead when executor is initialized.
[#]# Release v1.1.6.pre1, edge v0.6.0.pre1 (26 Jan 2020)
concurrent-ruby:
* (#828) Allow to name executors, the name is also used to name their threads
* (#838) Implement #dup and #clone for structs
* (#821) Safer finalizers for thread local variables
* Documentation fixes
* (#814) Use Ruby's Etc.nprocessors if available
* (#812) Fix directory structure not to mess with packaging tools
* (#840) Fix termination of pools on JRuby
concurrent-ruby-edge:
* Add WrappingExecutor (#830)

==== rubygem-lolcat ====
Version update (100.0.0 -> 100.0.1)

- update to v100.0.1:
* allow using paint 2.2.0

==== rubygem-puma ====
Version update (4.3.1 -> 4.3.3)

- updated to version 4.3.3
[#] Bugfixes
* Fix: Fixes a problem where we weren't splitting headers correctly on
newlines (#2132)
[#] Security
* Fix: Prevent HTTP Response splitting via CR in early hints.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages