Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
[opensuse-factory] Leap build failure in graphics repo due to local packages
  • From: "Axel Braun" <Axel.Braun@xxxxxx>
  • Date: Mon, 2 Mar 2020 12:44:56 +0100
  • Message-id: <trinity-58e7feef-b2e5-43fa-9988-b066e48cdece-1583149496704@3c-app-gmx-bs11>
Hi,

I have a local package (gdcm) which builds nicely against leap. I have
submitted it to the graphics repo and found that it fails to build there.
Reason is that graphics repo uses a factory branch of the poppler package
(version 0.84) which has an API change compared to version 0.79 in standard
Leap 15. This is actually the reason why gdcm fails to build for TW (this is
already reported to upstrea - unfortunately the developer works on Debian on an
even oder version of poppler...)

Question...should the build for local branches of projects like poppler not be
switched off for Leap, in order to pull in the Leap standard component?
Otherwise - like here - we get a build error which happens not for the standard
Leap repo.

Kind regards
Axel
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups