Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
Re: [opensuse-factory] why upgrading too leap15.2?


Am 29.02.20 um 21:14 schrieb Stefan Seyfried:
Am 29.02.20 um 20:50 schrieb zb4ng:
Am 29.02.20 um 18:23 schrieb Stefan Seyfried:
Am 29.02.20 um 17:49 schrieb zb4ng:
I tried to install the new SAGE math package some weeks ago, which
didn't work since glibc version was too ancient. But for other things
LEAP works just fine, so I don't need to mess around with TW.

More details, please, so that we can reproduce / advise possible
workarounds.


For information, SAGE (https://www.sagemath.org/) is a huge python based
software; they even include their own python interpreter (which is still
python 2.x last time I checked).

I just tried it.

I downloaded the binary package
sage-9.0-Debian_GNU_Linux_10-x86_64.tar.bz2, extracted it, run "./sage"
and it failed for too old glibc. But debian 10 is brand new, so next
try: download sage-9.0-Debian_GNU_Linux_9-x86_64.tar.bz2, extract it,
run "./sage" and it seems to work fine.


It works for me, too (including Jupyter)! Somehow, it never occurred to me before to try the Debian versions.

Thanks!
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation