Mailinglist Archive: opensuse-factory (607 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200214 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 16 Feb 2020 02:01:49 +0000
  • Message-id: <158181850989.5610.12997735352500050283@go-agent-stagingbot-5>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200214

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
Mesa
Mesa-drivers
MozillaFirefox (72.0.2 -> 73.0)
MozillaThunderbird (68.4.2 -> 68.5.0)
NetworkManager
acpica (20190509 -> 20200110)
amarok (2.9.70git.20191004T143525~5ed62f9a08 ->
2.9.70git.20200131T110159~195748144f)
attica-qt5 (5.66.0 -> 5.67.0)
audacity
babl (0.1.72 -> 0.1.74)
baloo5 (5.66.0 -> 5.67.0)
bluez
bluez-qt (5.66.0 -> 5.67.0)
breeze
breeze5-icons (5.66.0 -> 5.67.0)
c-ares (1.15.0+20191108 -> 1.15.0+20200117)
catfish
ccache (3.7.6 -> 3.7.7)
edict
frameworkintegration (5.66.0 -> 5.67.0)
fwupd
gedit-plugins
gegl (0.4.18 -> 0.4.20)
gnome-builder
gnu-unifont-bitmap-fonts (12.1.03 -> 12.1.04)
grub2
ibus
ilmbase
iproute2 (5.4 -> 5.5.0)
kactivities-stats (5.66.0 -> 5.67.0)
kactivities5 (5.66.0 -> 5.67.0)
karchive (5.66.0 -> 5.67.0)
kauth (5.66.0 -> 5.67.0)
kbookmarks (5.66.0 -> 5.67.0)
kcalendarcore (5.65.0 -> 5.67.0)
kcmutils (5.66.0 -> 5.67.0)
kcodecs (5.66.0 -> 5.67.0)
kcompletion (5.66.0 -> 5.67.0)
kconfig (5.66.0 -> 5.67.0)
kconfigwidgets (5.66.0 -> 5.67.0)
kcontacts (5.65.0 -> 5.67.0)
kcoreaddons (5.66.0 -> 5.67.0)
kcrash (5.66.0 -> 5.67.0)
kdbusaddons (5.66.0 -> 5.67.0)
kdeclarative (5.66.0 -> 5.67.0)
kded (5.66.0 -> 5.67.0)
kdelibs4support (5.66.0 -> 5.67.0)
kdesu (5.66.0 -> 5.67.0)
kdnssd-framework (5.66.0 -> 5.67.0)
kdoctools (5.66.0 -> 5.67.0)
kemoticons (5.66.0 -> 5.67.0)
kfilemetadata5 (5.66.0 -> 5.67.0)
kglobalaccel (5.66.0 -> 5.67.0)
kguiaddons (5.66.0 -> 5.67.0)
kholidays (5.66.0 -> 5.67.0)
khtml (5.66.0 -> 5.67.0)
ki18n (5.66.0 -> 5.67.0)
kiconthemes (5.66.0 -> 5.67.0)
kidletime (5.66.0 -> 5.67.0)
kimageformats (5.66.0 -> 5.67.0)
kinit (5.66.0 -> 5.67.0)
kio (5.66.0 -> 5.67.0)
kio-extras5
kirigami2 (5.66.0 -> 5.67.0)
kitemmodels (5.66.0 -> 5.67.0)
kitemviews (5.66.0 -> 5.67.0)
kjobwidgets (5.66.0 -> 5.67.0)
kjs (5.66.0 -> 5.67.0)
knewstuff (5.66.0 -> 5.67.0)
knotifications (5.66.0 -> 5.67.0)
knotifyconfig (5.66.0 -> 5.67.0)
kpackage (5.66.0 -> 5.67.0)
kparts (5.66.0 -> 5.67.0)
kpeople5 (5.66.0 -> 5.67.0)
kplotting (5.66.0 -> 5.67.0)
kpty (5.66.0 -> 5.67.0)
kquickcharts (5.66.0 -> 5.67.0)
kross (5.66.0 -> 5.67.0)
krunner (5.66.0 -> 5.67.0)
kservice (5.66.0 -> 5.67.0)
ktexteditor (5.66.0 -> 5.67.0)
ktextwidgets (5.66.0 -> 5.67.0)
kunitconversion (5.66.0 -> 5.67.0)
kwallet (5.66.0 -> 5.67.0)
kwayland (5.66.0 -> 5.67.0)
kwidgetsaddons (5.66.0 -> 5.67.0)
kwin5
kwindowsystem (5.66.0 -> 5.67.0)
kxmlgui (5.66.0 -> 5.67.0)
libKF5ModemManagerQt (5.66.0 -> 5.67.0)
libKF5NetworkManagerQt (5.66.0 -> 5.67.0)
libdv
libgee (0.20.2 -> 0.20.3)
libmicrohttpd (0.9.69 -> 0.9.70)
libosinfo
libusbmuxd
mercurial (5.2.1 -> 5.3)
mozilla-nss (3.48 -> 3.49.2)
nano (4.7 -> 4.8)
nodejs12 (12.15.0 -> 12.16.0)
openexr
orca
ovmf
oxygen5-icon-theme (5.66.0 -> 5.67.0)
pidgin
plasma-framework (5.66.0 -> 5.67.0)
plasma5-desktop
plasma5-workspace
postgresql12
postgresql12-libs
presage
prison-qt5 (5.66.0 -> 5.67.0)
purpose (5.66.0 -> 5.67.0)
python-decorator (4.4.0 -> 4.4.1)
python-gobject
python-matplotlib (3.1.2 -> 3.1.3)
python-packaging (19.2 -> 20.1)
python-pip (19.3.1 -> 20.0.2)
python-pyasn1-modules (0.2.7 -> 0.2.8)
python-pyparsing (2.4.5 -> 2.4.6)
python-urllib3 (1.25.6 -> 1.25.8)
python3-qt5
qqc2-desktop-style (5.66.0 -> 5.67.0)
redis
rubygem-winrm-fs (1.3.2 -> 1.3.4)
solid (5.66.0 -> 5.67.0)
sonnet (5.66.0 -> 5.67.0)
syndication (5.66.0 -> 5.67.0)
syntax-highlighting (5.66.0 -> 5.67.0)
threadweaver (5.66.0 -> 5.67.0)
vala (0.46.5 -> 0.46.6)
xfce4-whiskermenu-plugin (2.3.5 -> 2.4.1)

=== Details ===

==== Mesa ====
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- u_Revert_gallium_Fix_big-endian_addressing_of_non-bitmask_array_formats.patch
* replaces U_gallium-Fix-big-endian-addressing-of-non-bitmask-arr.patch
by an official merge request (bsc#1162252, gitlab issue#2472)

==== Mesa-drivers ====
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- u_Revert_gallium_Fix_big-endian_addressing_of_non-bitmask_array_formats.patch
* replaces U_gallium-Fix-big-endian-addressing-of-non-bitmask-arr.patch
by an official merge request (bsc#1162252, gitlab issue#2472)

==== MozillaFirefox ====
Version update (72.0.2 -> 73.0)
Subpackages: MozillaFirefox-translations-common

- Mozilla Firefox 73.0
* Added support for setting a default zoom level applicable for all
web content
* High-contrast mode has been updated to allow background images
* Improved audio quality when playing back audio at a faster or
slower speed
* Added NextDNS as alternative option for DNS over HTTPS
MFSA 2020-05 (bsc#1163368)
* CVE-2020-6796 (bmo#1610426)
Missing bounds check on shared memory read in the parent process
* CVE-2020-6797 (bmo#1596668) (MacOS X only)
Extensions granted downloads.open permission could open arbitrary
applications on Mac OSX
* CVE-2020-6798 (bmo#1602944)
Incorrect parsing of template tag could result in JavaScript injection
* CVE-2020-6799 (bmo#1606596) (Windows only)
Arbitrary code execution when opening pdf links from other
applications, when Firefox is configured as default pdf reader
* CVE-2020-6800 (bmo#1595786,bmo#1596706,bmo#1598543,bmo#1604851,
bmo#1608580,bmo#1608785,bmo#1605777)
Memory safety bugs fixed in Firefox 73 and Firefox ESR 68.5
* CVE-2020-6801 (bmo#1601024,bmo#1601712,bmo#1604836,bmo#1606492)
Memory safety bugs fixed in Firefox 73
- updated requirements
* rust >= 1.39
* NSS >= 3.49.2
* rust-cbindgen >= 0.12.0
- rebased patches
- removed obsolete patch
* mozilla-bmo1601707.patch
- switched to cairo-gtk3-wayland build
(to fully enable wayland MOZ_ENABLE_WAYLAND=1 needs to be set)
- disabled elfhack due to failing packager
https://github.com/openSUSE/firefox-maintenance/issues/28
- disabled PGO due to build failure
https://github.com/openSUSE/firefox-maintenance/issues/29

==== MozillaThunderbird ====
Version update (68.4.2 -> 68.5.0)
Subpackages: MozillaThunderbird-translations-common

- Mozilla Thunderbird 68.5.0
New
* Support for Client Identity IMAP/SMTP Service Extension
* Support for OAuth 2.0 authentication for POP3 accounts
Fixes
* Status area goes blank during account setup
* Calendar: Could not remove color for default categories
* Calendar: Prevent calendar component loading multiple times
* Calendar: Today pane did not retain width between sessions
MFSA 2020-07 (bsc#1163368)
* CVE-2020-6793 (bmo#1608539)
Out-of-bounds read when processing certain email messages
* CVE-2020-6794 (bmo#1606619)
Setting a master password post-Thunderbird 52 does not delete
unencrypted previously stored passwords
* CVE-2020-6795 (bmo#1611105)
Crash processing S/MIME messages with multiple signatures
* CVE-2020-6797 (bmo#1596668) (Mac OSX only)
Extensions granted downloads.open permission could open arbitrary
applications on Mac OSX
* CVE-2020-6798 (bmo#1602944)
Incorrect parsing of template tag could result in JavaScript injection
* CVE-2020-6792 (bmo#1609607)
Message ID calculcation was based on uninitialized data
* CVE-2020-6800 (bmo#1595786,bmo#1596706,bmo#1598543,bmo#1604851,
bmo#1608580,bmo#1608785,bmo#1605777)
Memory safety bugs fixed in Thunderbird 68.5

==== NetworkManager ====
Subpackages: NetworkManager-lang libnm0 typelib-1_0-NM-1_0

- Add -fcommon to CFLAGS. This is currently being done upstream
(boo#1160381).

==== acpica ====
Version update (20190509 -> 20200110)

- Add -fcommon as there are a lot re-definitions which lead to errors
and compile failures with gcc10 which enables -fno-common by default
bsc#1160383 - acpica fails with -fno-common
- Update to version 20200110

==== amarok ====
Version update (2.9.70git.20191004T143525~5ed62f9a08 ->
2.9.70git.20200131T110159~195748144f)

- Update to version 2.9.70git.20200131T110159~195748144f:
* Use safe hardcoded value for ProvidersUrl

==== attica-qt5 ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Attica5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Make it compile with qt5.15

==== audacity ====
Subpackages: audacity-lang

- Fix invalid RPM group.

==== babl ====
Version update (0.1.72 -> 0.1.74)

- Update to version 0.1.74:
+ Build fixes, improved host cpu detection, OSX fixes, clang
warning squelches.

==== baloo5 ====
Version update (5.66.0 -> 5.67.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Migrate config from KConfig to KConfigXt in order to allow KCM to use it
* Fix minor typos
* Port endl to \n or std::cout/cerr as in qt5.15 endl is Qt:: namespaced
* Port QRegExp to QRegularExpression

==== bluez ====
Subpackages: libbluetooth3

- Fix path to systemctl in %post script

==== bluez-qt ====
Version update (5.66.0 -> 5.67.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Remove extra flush when we close file it will flush
* endl is Qt:: namespaced in qt5.15. Port to \n and flush
when QTextStream is not on a QFile

==== breeze ====
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers libbreezecommon5-5

- Update tarball, with new preview image

==== breeze5-icons ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* create Breeze style Kate icon based on new design by Tyson Tan
* Change VLC icon to be more like official VLC icons
* add ktrip icon from ktrip repo
* Clean up wayland icon shadow
* Add icon for application/sql
* Cleanup and add 22px media repeat icons
* Add icon for text/vnd.kde.kcrash-report
* Turn application/x-ms-shortcut into an actual shortcut icon

==== c-ares ====
Version update (1.15.0+20191108 -> 1.15.0+20200117)

- Upgrade to latest snapshot from 2020-01-17
- disable-live-tests.patch: refreshed
- regression.patch: fix a regression in DNS results that contain
both A and AAAA answers.
- Add netcfg as the build requirement and runtime requirement.
ares_getaddrinfo function uses the getservbyport_r function which
requires the /etc/services file to function properly. That config
file is provided by the netcfg package. Unit tests rely on it
too, hence it has to be a build dependency as well.
- Switch to cmake-based build.
Some packages need the cmake build files.

==== catfish ====
Subpackages: catfish-lang

- Fixed dependency conditional for Leap 15.2 build

==== ccache ====
Version update (3.7.6 -> 3.7.7)

- Update to version 3.7.7:
* Fixed a bug related to object file location in the dependency file (if
using -MD or -MMD but not -MF and the build directory is not the same as the
source directory then the object file location in the .d file would become
incorrect). This fixes regression in ccache 3.7.5 introduced by the bug fix
related to EDG-based compilers. Note that this removes support for EDG-based
compilers again. (A better fix for this is planned for ccache 4.0.)
* Removed the unify mode since it has bugs and shortcomings that are
non-trivial or impossible to fix: it doesn?t work with the direct mode, it
doesn?t handle C++ raw strings correctly, it can give false cache hits for
.incbin directives, it?s turned off when using -g and it can make line numbers
in warning messages and __LINE__ macros incorrect.
mtime and ctime values are now stored in the manifest files only when
sloppy_file_stat is set. This avoids adding superfluous manifest file entries
on direct mode cache misses.
* A ?Result:? line is now always printed to the log.
* The ?cache miss? statistics counter will now be updated for read-only cache
misses, making it consistent with the cache hit case.

==== edict ====
Subpackages: edict2 jmdict

- Fix invalid RPM group.

==== frameworkintegration ====
Version update (5.66.0 -> 5.67.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Drop unused dependency
* Drop HAVE_X11 remnants

==== fwupd ====
Subpackages: fwupd-lang libfwupd2 libfwupdplugin1 typelib-1_0-Fwupd-2_0

- Drop docbook-utils-minimal build dependency, manpages are generated
with gtk-doc.

==== gedit-plugins ====
Subpackages: gedit-plugin-zeitgeist gedit-plugins-data gedit-plugins-lang

- Drop gedit-plugins-lang Requires: It should have been a
Recommends, and those are not needed anymore as Supplements: are
in place to take care of it.

==== gegl ====
Version update (0.4.18 -> 0.4.20)
Subpackages: gegl-0_4 gegl-0_4-lang libgegl-0_4-0

- Update to version 0.4.20:
+ Build: Improvements and refinements of meson builds and CI.
Fixing major issues for OSX and win32.
+ Buffer:
- Pass O_BINARY where relevant on windows, fixing crashes
occuring when swap is used.
- Avoid 32bit overflows in computations for gegl_buffer_set and
gegl_buffer_get.
+ Core:
- Avoid running more thread jobs than there are pixels to
process.
- Faster teardown of buffer caches when bounding box shrinks.
- Only do in-place processing if ROI fits in input abyss.
+ Operations:
- Improved edge handling for gegl:distance-transform.
- gegl:crop removed workaround for incorrect in-place handling.
- Drop gegl-0.4.18_allow_unknown_arch.patch: Fixed upstream.
- No longer recommend -lang: supplements are in use.

==== gnome-builder ====
Subpackages: gnome-builder-doc gnome-builder-lang gnome-builder-plugin-jedi
gnome-builder-plugin-jhbuild gnome-builder-plugin-vala-pack

- Add explicit python3-gobject BuildRequires: used to pulled in by
pkgconfig(pygobject-3.0), but in order to not drag in py2 and py3
all the time, this dependency was eliminated.

==== gnu-unifont-bitmap-fonts ====
Version update (12.1.03 -> 12.1.04)

- unifont 12.1.04:
* added two missing dots to Arabic Extended-A glyph U+08BA
* added descending lines to coffin (U+26B0) so it looks more 3D
*  removed dotted circles in Adlam and Nyiakeng Puachue Hmong
* changed four Soyombo glyphs
* improved several Duployan glyphs

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- From Stefan Seyfried <seife@xxxxxxxxxxxxxxxxxxxx> : Fix grub2-install fails
with "not a directory" error (boo#1161641, bsc#1162403)
* grub2-install-fix-not-a-directory-error.patch

==== ibus ====
Subpackages: ibus-gtk ibus-gtk-32bit ibus-gtk3 ibus-lang libibus-1_0-5
libibus-1_0-5-32bit typelib-1_0-IBus-1_0

- No longer recommend -lang: supplements are in use.

==== ilmbase ====
Subpackages: libHalf-2_4-24 libIex-2_4-24 libIlmThread-2_4-24

- Fix relative paths in generated pkgconfig files:
0001-Use-absolute-CMAKE_INSTALL_FULL_LIBDIR-for-libdir-in.patch

==== iproute2 ====
Version update (5.4 -> 5.5.0)

- Update to new upstream version 5.5
* bridge: support fdb get
* devlink: command line option to switch netns
* devlink: all changing netns on reload
* devlink: new timestamp format for health report dump
* ip: support for alternative device names
* ip link: support to get SR-IOV VF node GUID and port GUID
* ip neigh: support get
* rdma: relax requirement to have PID for HW objects
* rdma: stat show mr
* ss: allow dumping kTLS info
* tc: support action flags
* tc flower: support masked port destination and source match
* tc pie: add dq_rate_estimator option
* tipc: new commands to set TIPC AEAD key
* more json support
- drop patches obsoleted by version upgrade:
* ss-fix-end-of-line-printing-in-misc-ss.c.patch
* no-double-definitions.patch
* Revert-emp-fix-warning-on-deprecated-bison-directive.patch
* Revert-tc-ematch-fix-deprecated-yacc-warning.patch
- refresh
* split-link-and-compile-steps-for-binaries.patch

==== kactivities-stats ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Fix broken SQL query in allResourcesQuery

==== kactivities5 ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kactivities5-imports libKF5Activities5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Remove files that Windows cannot handle.
* Ensure to store resource uri without a trailing slash

==== karchive ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kauth ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang libKF5AuthCore5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kbookmarks ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* [bookmarksmenu] Improve variable name
* Remove outdated comments

==== kcalendarcore ====
Version update (5.65.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0
- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl. qCritical/qDebug already adds a endl.
* Improve README.md to have an Introduction section
* Make incidence geographic coordinate also accessible as a property
* Fix RRULE generation for timezones
* Update the obsolete projects.kde.org URL

==== kcmutils ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* prefer the new kcm plugins to the old
* KCModuleQml: Ensure defaulted is emitted with the current
configModule->representsDefaults on load
* Show button respecting what is declared by KCModule
* Update KPluginSelector to allow KCM to show good state
for reset, apply and default button

==== kcodecs ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kcompletion ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* [KCompletion] Port QRegExp to QRegularExpression

==== kconfig ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Too many changes to list here.

==== kconfigwidgets ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* KStandardAction: add method for SwitchApplicationLanguage action creation
* Don't assume the manager and menu have the same lifetime
* [KColorSchemeManager] Don't list duplicates
* [KColorschemeManager] Add option to reenable following global theme
* Fix KCMModule::setButtons documentation, if Apply is activated we
also want to show a Reset button
* Port QRegExp to QRegularExpression

==== kcontacts ====
Version update (5.65.0 -> 5.67.0)
Subpackages: kcontacts-lang libKF5Contacts5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0
- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port QRegExp to QRegularExpression
* Align ECM and Qt setup with Frameworks conventions
* Specify ECM dependency version as in any other framework

==== kcoreaddons ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* demote plugin load errors from warning to debug level + reword
* Document how to filter by servicetype the right way
* Add perlSplit() overload taking a QRegularExpression
and deprecate the QRegExp one
* Add mime type for backtraces saved from DrKonqi
* Add utility text function KShell::tildeCollapse
* Port to QMultiHash as QHash::insertMulti is deprecated
* KPluginMetaData: add initialPreference() getter
* desktoptojson: also convert InitialPreference key
* KCoreAddons: fix compilation with qtbase git dev branch

==== kcrash ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kdbusaddons ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kdeclarative ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* typo--
* Correctly compute bottom margin for grid delegates with subtitles
* Port away from deprecated IconSize() method
* [ConfigModule] Say which package is invalid

==== kded ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kded-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kdelibs4support ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kdesu ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kdnssd-framework ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* typo--

==== kdoctools ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kemoticons ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kfilemetadata5 ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kfilemetadata5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Port away from deprecated QList::toSet() method

==== kglobalaccel ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kguiaddons ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kholidays ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Update holidays and add flagdays and namedays for Sweden

==== khtml ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== ki18n ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Remove no longer necessary Qt5Script dependencies
- Replace python(2) dependencies with python3, which it actually
used already anyway
- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* ki18n_wrap_ui: error when file doesn't exist
* [Kuit] Revert changes in parseUiMarker()
* ki18n: export Kuit::setupForDomain, unittest
KUitSetup::setFormatForMarker
* [Kuit] Port QRegExp to QRegularExpression
* [Kuit] Port QRegExp to QRegularExpression, third pass

==== kiconthemes ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kidletime ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Introduce SPDX license headers

==== kimageformats ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kimageformats-eps

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kinit ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kinit-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kio ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kio-core kio-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Too many changes since 5.66.0, only listing bugfixes:
* Allow to handle apps with Terminal=True in their desktop
file, handle their associated mimetype properly (kde#410506)
* Add KIO::DropJobFlag to allow manually showing the menu (kde#415917)
* [KOpenWithDialog] Hide collapsible group box when all
options inside are hidden (kde#415510)
* SlaveBase::dispatchLoop: Fix timeout calculation (kde#392768)
* [KDirOperator] Allow renaming files from the context menu (kde#189482)

==== kio-extras5 ====
Subpackages: kio-extras5-lang libkioarchive5

- Add cmake(KF5ActivitiesStats) for the recentlyused:/ protocol

==== kirigami2 ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Add upstream patch
0001-make-headerParent-correctly-alignedwhen-there-is-a-s.patch
- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Too many changes since 5.66.0, only listing bugfixes:
* Clip the flickable parent item (kde#416877)
* proper size hint for the gridlayout (kde#416860)

==== kitemmodels ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Fix build of python bindings for kcolumnheadersmodel

==== kitemviews ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kjobwidgets ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kjs ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Abort machine run once a timeout signal has been seen.
* Fixed variable name in function documentation.
* Support ** exponentiation operator from ECMAScript 2016.
* Complete port from 0 to nullptr.
* Restore COMPILER macros as they are also used in KHTML.
* Added shouldExcept() function that works based on a function.
* Ported away from COMPILER() convenience macro.
* Prepare 5s timeout in test suite.

==== knewstuff ====
Version update (5.66.0 -> 5.67.0)
Subpackages: knewstuff-imports libKF5NewStuff5 libKF5NewStuff5-lang
libKF5NewStuffCore5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Unbreak the KNSQuick::Engine::changedEntries functionality
* Make it compile against last qt5.15 without deprecated methods
* Add ellipsis at the end, as per HIG
* API dox: add since for KDE_INSTALL_KNSRCDIR, note
backward-compatible variant
* Fix the KNSQuick Dialog's close title and basic layout

==== knotifications ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Add new signal for default action activation
* Drop dependency to KF5Codecs by using the new
stripRichText function
* Strip richtext on Windows
* Reduce dependencies on Windows
* Adapt to Qt 5.14 Android changes
* Don't use KWindowSystem on Android
* Deprecate raiseWidget
* Port KNotification from KWindowSystem

==== knotifyconfig ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Port away from KLineEdit and KComboBox to Q equivalent

==== kpackage ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kpackage-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kparts ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kpeople5 ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kpeople5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Adjust metainfo.yaml to new tier
* Remove legacy plugin loading code

==== kplotting ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kpty ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== kquickcharts ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Fix Qt version check
* Expand Pie Chart autotest with multiple value sources and model
* Register QAbstractItemModel as anonymous type for property assignments
* Hide the line of a line chart if its width is set to 0

==== kross ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kross-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* addHelpOption already adds by kaboutdata

==== krunner ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Port QRegExp to QRegularExpression

==== kservice ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kservice-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* autotests: simplify test to use bin/data/menus
* [autotests] rename test desktop file, so can see the debug output in CI
* Support multiple values in XDG_CURRENT_DESKTOP
* [autotest] mkpath() before copy to fix CI failure
* Deprecated allowAsDefault
* Make "Default Applications" in mimeapps.list the preferred applications
* autotests: use local desktop file to avoid relying on konsole

==== ktexteditor ====
Version update (5.66.0 -> 5.67.0)
Subpackages: ktexteditor-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Too many changes since 5.66.0, only listing bugfixes:
* fix Drag&copy function (by using Ctrl Key) (kde#413848)

==== ktextwidgets ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Fix cppcheck warning
* Drop KWindowSystem dependency

==== kunitconversion ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Make it compiles against qt5.15

==== kwallet ====
Version update (5.66.0 -> 5.67.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Revert readEntryList() to use QRegExp::Wildcard
* Fix QRegularExpression::wildcardToRegularExpression() usage
- Drop patches:
* d4980443755f5df63b6a13f662df169797f2684f.patch
* 02ab54ea6fe8b61a4e474070061d6e41aebc71a0.patch

==== kwayland ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0.

==== kwidgetsaddons ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* QApplication::globalStrut() will be removed in qt6.
* [KMessageWidget] Subtract the correct margin
* [KMessageBox] Only allow selecting text in the dialog box
using the mouse (kde#416204)
* [KMessageWidget] Use devicePixelRatioF for animation pixmap (kde#415528)

==== kwin5 ====
Subpackages: kwin5-lang

- The devel subpackage needs libepoxy-devel (boo#1163286)
- Remove conditions for Leap 42

==== kwindowsystem ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* [KWindowShadows] Check for X connection
* Fix build on FreeBSD
* Introduce shadows API
* Deprecate KWindowEffects::markAsDashboard()

==== kxmlgui ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* autotests: mark known test failure with QEXPECT_FAIL
* Use KStandardAction convenience method for switchApplicationLanguage
* allow programLogo property to be a QIcon, too
* Compile against qt5.15
* remove ability to report bugs against arbitrary stuff from a static list
* remove compiler information from bug report dialog
* KMainWindow: fix autoSaveSettings to catch QDockWidgets being shown again
* Drop unused headers
* i18n: Add more semantic context strings
* i18n: Split translations for strings "Translation"

==== libKF5ModemManagerQt ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== libKF5NetworkManagerQt ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* [networkmanager-qt] Port QRegExp to QRegularExpression

==== libdv ====

- Cleanup spec file, remove obsolete conditionals.
- Build playdv as a separate package, removes X11, SDL1 and gtk2
build dependencies from the library.

==== libgee ====
Version update (0.20.2 -> 0.20.3)

- Update to version 0.20.3:
+ Minor warning fixes for newer valac.
+ Guard GLib.Cond.wait/wait_until calls against spurious or
stolen wakeups.

==== libmicrohttpd ====
Version update (0.9.69 -> 0.9.70)

- Update to 0.9.70:
* Fixed 100-continue handling for PATCH method
* Fixed FTBFS from wrong #endif position for certain builds
* Fixed connection overflow issue when combining
MHD_USE_NO_LISTEN_SOCKET with MHD_USE_THREAD_PER_CONNECTION
* Updated m4 script to fix FTBFS when using
- Werror=unused-but-set-parameter
* Adding fix for urlencoding of keys without values in
post-processor logic.
* Adding patch from Ethan Tuttle with test case for urlencoding
in post-processor for keys without values.

==== libosinfo ====
Subpackages: libosinfo-1_0-0 libosinfo-lang typelib-1_0-Libosinfo-1_0

- No longer recommend -lang: supplements are in use.

==== libusbmuxd ====

- Software using pthread_cleanup_* routines must be built with
with -fexceptions so a safer and cleaner implementation is
used.

==== mercurial ====
Version update (5.2.1 -> 5.3)
Subpackages: mercurial-lang

- Mercurial 5.3
This is a regularly-scheduled quarterly feature release.
See release notes at https://www.mercurial-scm.org/wiki/Release5.3
- drop mercurial-4.8-python2-shebang.patch because of switch to Python 3
- fixed and refreshed mercurial-locale-path-fix.patch

==== mozilla-nss ====
Version update (3.48 -> 3.49.2)
Subpackages: libfreebl3 libfreebl3-hmac libsoftokn3 libsoftokn3-hmac
mozilla-nss-certs mozilla-nss-tools

- update to NSS 3.49.2
Fixed bugs:
* Fix compilation problems with NEON-specific code in freebl
(bmo#1608327)
* Fix a taskcluster issue with Python 2 / Python 3 (bmo#1608895)
- update to NSS 3.49.1
3.49.1

https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.49.1_release_notes
* Cache the most recent PBKDF2 password hash, to speed up repeated
SDR operations, important with the increased KDF iteration counts
(bmo#1606992)
3.49

https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.49_release_notes
* The legacy DBM database, libnssdbm, is no longer built by default
when using gyp builds (bmo#1594933)
* several bugfixes

==== nano ====
Version update (4.7 -> 4.8)
Subpackages: nano-lang

- update to 4.8:
* When something is pasted into nano, suppress auto-indentation
* paste can be undone as a whole with a single M-U
* Improve handling of lock files on start-up
* Shift+Meta+letter key combos can be bound with 'bind Sh-M-letter'
* A custom nanorc file can be specified on the command line, with
- f filename or --rcfile=filename

==== nodejs12 ====
Version update (12.15.0 -> 12.16.0)
Subpackages: nodejs12-devel npm12

- Update to LTS release 12.16.0:
* assert: add experimental assert.match() and assert.doesNotMatch()
methods. These allow matching vs. provided regular expressions.
* child_process, cluster: now support serialization option to
allow for custom serialization mechanism for IPC.
* cli: add --trace-edit and --trance-uncaught flags
* crypto:
+ added support for 'ieee-p1363' signature type for DSA and ECDSA
in addition to DER
+ Added Hash.prototype.copy making it possibly to clone internal
state of Hash object. This allows digest computation between
updates.
* deps:
+ libuv was updated to 1.34.0
+ V8 was updated to 7.8.279.23 - for official changes, see
https://v8.dev/blog/v8-release-78
* events:
+ add EventEmitter.on to async iterate over events
+ allow monitoring error events via EventEmitter.errorMonitor
+ add experimental method to captureRejections for async handlers
* perf_hooks: now considered stable API
* wasi: Add new core module for WebAssebly System Interface as
an experimental feature.
- wasi_compile_flags.patch: fix header inclusions in uvwasi dependency

==== openexr ====

- Fix relative paths in generated pkgconfig files:
0001-Use-absolute-CMAKE_INSTALL_FULL_LIBDIR-for-libdir-in.patch

==== orca ====
Subpackages: orca-lang

- Add python3-gobject BuildRequires: We eliminated an auto-pull-in
of the python stack for consumers of the C-headers. Orca uses
both.

==== ovmf ====
Subpackages: qemu-ovmf-x86_64

- Build the unified firmware with preloaded keys for backward
compatibility (bsc#1159793)

==== oxygen5-icon-theme ====
Version update (5.66.0 -> 5.67.0)
Subpackages: oxygen5-icon-theme-large

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== pidgin ====
Subpackages: libpurple libpurple-lang libpurple-tcl

- No longer recommend -lang: supplements are in use

==== plasma-framework ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Too many changes to list here.

==== plasma5-desktop ====
Subpackages: plasma5-desktop-emojier

- Add %exclude for ibus-emoji-dicts to avoid file conflicts
- Ship ibus emoji dicts as part of the emojier subpackage,
recommend it by default now
- Recommend noto-coloremoji-fonts for emojier
- Drop superfluous -lang recommends
- Add patch to unlock widgets by default as the GUI option got
dropped (kde#417424):
* 0001-unlock-widgets.patch

==== plasma5-workspace ====
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Update tarball, now with updated preview images

==== postgresql12 ====
Subpackages: postgresql12-contrib postgresql12-llvmjit postgresql12-server

- Avoid the dependency from the devel package to the main package.
devel packages are exclusive, thus ecpg does not require
update-alternatives.
- Remove unused build dependencies from the client libs package:
LVM, icu, selinux, systemd.
- Drop conditionals for suse_version 1110/1120.

==== postgresql12-libs ====

- Avoid the dependency from the devel package to the main package.
devel packages are exclusive, thus ecpg does not require
update-alternatives.
- Remove unused build dependencies from the client libs package:
LVM, icu, selinux, systemd.
- Drop conditionals for suse_version 1110/1120.

==== presage ====
Subpackages: libpresage1 presage-data

- Revert change of the source package name for the doc flavor.
Different flavors require distinct package names for _multibuild
to work properly.
- Update presage-0.9.1-python3.patch: Adjust two more env python to
for python3.
- Export the include path to fix the build under python 3.8

==== prison-qt5 ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== purpose ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* QJsonDocument::fromBinaryData is deprecated in qt5.15.
We need to port to QCborValue::fromCbor
* Port some qt5.15 deprecated method
* Fix QRegularExpression::wildcardToRegularExpression() usage
* [Purpose] Port QRegExp to QRegularExpression

==== python-decorator ====
Version update (4.4.0 -> 4.4.1)

- update to 4.4.1:
Changed the description to "Decorators for Humans" are requested by
several users. Fixed a .rst bug in the description as seen in PyPI.

==== python-gobject ====
Subpackages: python2-gobject python3-gobject python3-gobject-Gdk
python3-gobject-cairo

- Remove %{python_module gobject-devel = %{version}} from
common-devel: Assuming that consumers of the .pc and include
headers are not really using the python bindings.

==== python-matplotlib ====
Version update (3.1.2 -> 3.1.3)
Subpackages: python3-matplotlib python3-matplotlib-cairo python3-matplotlib-gtk3

- Update to 3.1.3
* suppress a warning with Pandas 1.0
* support pillow >= 7
* support dateutils >= 2.8.1
* prevent an infinite recursion
* do not clobber non-python registered signal handler
* fix path intersection computation with 0 length segments
* fix performance regression in draw_idle
* several minor bugs

==== python-packaging ====
Version update (19.2 -> 20.1)
Subpackages: python2-packaging python3-packaging

- add issue_254.patch to fix tests under non-x86_64 pplatforms
- Update to 20.1
* Fix a bug caused by reuse of an exhausted iterator.
* Add type hints
* Add proper trove classifiers for PyPy support
* Scale back depending on ctypes for manylinux support detection
* Use sys.implementation.name where appropriate for packaging.tags
* Expand upon the API provded by packaging.tags
* Officially support Python 3.8
* Add major, minor, and micro aliases to packaging.version.Version
* Properly mark packaging has being fully typed by adding a py.typed file

==== python-pip ====
Version update (19.3.1 -> 20.0.2)

- update to 20.0.2
- add setuptools-45.1.0-py3-none-any.whl for testsuite
- drop pytest5.patch
* Fix a regression in generation of compatibility tags
* Rename an internal module, to avoid ImportErrors due to improper
uninstallation
* Switch to a dedicated CLI tool for vendoring dependencies.
* Remove wheel tag calculation from pip and use packaging.tags. This should
provide more tags ordered better than in prior releases.
* Deprecate setup.py-based builds that do not generate an .egg-info directory.
* The pip>=20 wheel cache is not retro-compatible with previous versions.
Until pip 21.0, pip will continue to take advantage of existing legacy cache
entries.
* Deprecate undocumented --skip-requirements-regex option.
* Deprecate passing install-location-related options via --install-option.
* Use literal "abi3" for wheel tag on CPython 3.x, to align with PEP 384
which only defines it for this platform.
* Remove interpreter-specific major version tag e.g. cp3-none-any from
consideration. This behavior was not documented strictly, and this tag in
particular is not useful. Anyone with a use case can create an issue with
pypa/packaging.
* Wheel processing no longer permits wheels containing more than one
top-level .dist-info directory.
* Support for the git+git@ form of VCS requirement is being deprecated and
will be removed in pip 21.0. Switch to git+https:// or git+ssh://. git+git://
also works but its use is discouraged as it is insecure.
* Default to doing a user install (as if --user was passed) when the main
site-packages directory is not writeable and user site-packages are enabled.
* Warn if a path in PATH starts with tilde during pip install.
* Cache wheels built from Git requirements that are considered immutable,
because they point to a commit hash.
* Add option --no-python-version-warning to silence warnings related to
deprecation of Python versions.
* Cache wheels that pip wheel built locally, matching what pip install does.
This particularly helps performance in workflows where pip wheel is used for
building before installing. Users desiring the original behavior can use pip
wheel --no-cache-dir
* Display CA information in pip debug.
* Show only the filename (instead of full URL), when downloading from PyPI.
* Suggest a more robust command to upgrade pip itself to avoid confusion when
the current pip command is not available as pip.
* Define all old pip console script entrypoints to prevent import issues in
stale wrapper scripts.
* The build step of pip wheel now builds all wheels to a cache first, then
copies them to the wheel directory all at once. Before, it built them to a
temporary directory and moved them to the wheel directory one by one.
* Expand ~ prefix to user directory in path options, configs, and environment
variables. Values that may be either URL or path are not currently supported,
to avoid ambiguity:
- -find-links
- -constraint, -c
- -requirement, -r
- -editable, -e
* Correctly handle system site-packages, in virtual environments created with
venv (PEP 405).
* Fix case sensitive comparison of pip freeze when used with -r option.
* Enforce PEP 508 requirement format in pyproject.toml build-system.requires.
* Make ensure_dir() also ignore ENOTEMPTY as seen on Windows.
* Fix building packages which specify backend-path in pyproject.toml.
* Do not attempt to run setup.py clean after a pep517 build error, since a
setup.py may not exist in that case.
* Fix passwords being visible in the index-url in "Downloading <url>" message.
* Change method from shutil.remove to shutil.rmtree in noxfile.py.
* Skip running tests which require subversion, when svn isn't installed
* Fix not sending client certificates when using --trusted-host.
* Make sure pip wheel never outputs pure python wheels with a python
implementation tag. Better fix/workaround for #3025 by using a
per-implementation wheel cache instead of caching pure python wheels with an
implementation tag in their name.
* Include subdirectory URL fragments in cache keys.
* Fix typo in warning message when any of --build-option, --global-option and
--install-option is used in requirements.txt
* Fix the logging of cached HTTP response shown as downloading.
* Effectively disable the wheel cache when it is not writable, as is the case
with the http cache.
* Correctly handle relative cache directory provided via --cache-dir.
*

==== python-pyasn1-modules ====
Version update (0.2.7 -> 0.2.8)

- specfile:
* update copyright year
* be more specific in %files section
- update to version 0.2.8:
* Improve test routines for modules that use certificate extensions
* Improve test for RFC3709 with a real world certificate
* Added RFC7633 providing TLS Features Certificate Extension
* Added RFC7229 providing OIDs for Test Certificate Policies
* Added tests for RFC3280, RFC3281, RFC3852, and RFC4211
* Added RFC6960 providing Online Certificate Status Protocol (OCSP)
* Added RFC6955 providing Diffie-Hellman Proof-of-Possession
Algorithms
* Updated the handling of maps for use with openType for RFC 3279
* Added RFC6486 providing RPKI Manifests
* Added RFC6487 providing Profile for X.509 PKIX Resource
Certificates
* Added RFC6170 providing Certificate Image in the Internet X.509
Public Key Infrastructure, and import the object identifier into
RFC3709.
* Added RFC6187 providing Certificates for Secure Shell
Authentication
* Added RFC6482 providing RPKI Route Origin Authorizations (ROAs)
* Added RFC6664 providing S/MIME Capabilities for Public Keys
* Added RFC6120 providing Extensible Messaging and Presence Protocol
names in certificates
* Added RFC4985 providing Subject Alternative Name for expression of
service names in certificates
* Added RFC5924 providing Extended Key Usage for Session Initiation
Protocol (SIP) in X.509 certificates
* Added RFC5916 providing Device Owner Attribute
* Added RFC7508 providing Securing Header Fields with S/MIME
* Update RFC8226 to use ComponentPresentConstraint() instead of the
previous work around
* Add RFC2631 providing OtherInfo for Diffie-Hellman Key Agreement
* Add RFC3114 providing test values for the S/MIME Security Label
* Add RFC5755 providing Attribute Certificate Profile for
Authorization
* Add RFC5913 providing Clearance Attribute and Authority Clearance
Constraints Certificate Extension
* Add RFC5917 providing Clearance Sponsor Attribute
* Add RFC4043 providing Internet X.509 PKI Permanent Identifier
* Add RFC7585 providing Network Access Identifier (NAI) Realm Name
for Certificates
* Update RFC3770 to support openType for attributes and reported
errata
* Add RFC4334 providing Certificate Extensions and Attributes for
Authentication in PPP and Wireless LAN Networks

==== python-pyparsing ====
Version update (2.4.5 -> 2.4.6)
Subpackages: python2-pyparsing python3-pyparsing

- update to 2.4.6
* Fixed typos in White mapping of whitespace characters, to use
correct "\u" prefix instead of "u".
* fix bug in left-associative ternary operators defined using
infixNotation. First reported on StackOverflow by user Jeronimo.
* Backport of pyparsing_test namespace from 3.0.0, including
TestParseResultsAsserts mixin class defining unittest-helper
methods:
. def assertParseResultsEquals(
self, result, expected_list=None, expected_dict=None, msg=None)
. def assertParseAndCheckList(
self, expr, test_string, expected_list, msg=None, verbose=True)
. def assertParseAndCheckDict(
self, expr, test_string, expected_dict, msg=None, verbose=True)
. def assertRunTestResults(
self, run_tests_report, expected_parse_results=None, msg=None)
. def assertRaisesParseException(self, exc_type=ParseException, msg=None)

==== python-urllib3 ====
Version update (1.25.6 -> 1.25.8)

- update to 1.25.8
* Drop support for EOL Python 3.4
* Optimize _encode_invalid_chars
* Preserve chunked parameter on retries
* Allow unset SERVER_SOFTWARE in App Engine
* Fix issue where URL fragment was sent within the request target.
* Fix issue where an empty query section in a URL would fail to parse.
* Remove TLS 1.3 support in SecureTransport due to Apple removing support.

==== python3-qt5 ====

- Disable debug assertions, e.g. Cura passes None for empty dicts and
crashes when trying to convert to QVariantMap, fixes boo#1157504.
- Split python2 and python3 builds using _multibuild.
- Rename python-qt5-utils package to python-qt5-common-devel to
better reflect its use, and drop the dependencies to it from the
bindings package.
- Make doc and common-devel subpackages noarch.
- Adjust _constraints, build requires 5 GByte disk space regardless
of architecture.
- Fix install location of binary dbus-mainloop integration module.

==== qqc2-desktop-style ====
Version update (5.66.0 -> 5.67.0)

- Add upstream patch
0001-ScrollView-Use-scrollbar-height-as-bottom-padding-no.patch
- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Remove scrollbar related workarounds from list delegates
* [TabBar] Remove frame
* Add active, link, visited, negative, neutral and positive background colors
* fix paddings
* use hasTransientTouchInput
* always round x and y
* support mobile mode scrollbar
* ScrollView: Do not overlay scrollbars over contents

==== redis ====

- print instance name in the from the service files

==== rubygem-winrm-fs ====
Version update (1.3.2 -> 1.3.4)

- New upstream release 1.3.4
[#] 1.3.4
- Bump rubyzip dependency
[#] 1.3.3
- Replace erubis with erubi

==== solid ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Add signals for udev events with actions bind and unbind
* [Solid] Port away from deprecated QList methods
* Clarify referencing of DeviceInterface
* [Solid] Port QRegExp to QRegularExpression

==== sonnet ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- No code change since 5.66.0

==== syndication ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* [Syndication] Port QRegExp to QRegularExpression

==== syntax-highlighting ====
Version update (5.66.0 -> 5.67.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Updates nasm.xml with the latest instructions
* Perl: Add 'say' to keyword list
* Make it compile against last qt5.15 without deprecated methods
* cmake: Fix `CMAKE_POLICY_*_CMP<N>` regex and add
special args to `get_cmake_property`
* Add GraphQL highlighting definition

==== threadweaver ====
Version update (5.66.0 -> 5.67.0)

- Replace %make_jobs with %cmake_build.
- Update to 5.67.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.67.0.php
- Changes since 5.66.0:
* Make it compiles against qt5.15

==== vala ====
Version update (0.46.5 -> 0.46.6)
Subpackages: libvala-0_46-0

- Update to version 0.46.6:
+ Various improvements and bug fixes:
- codegen:
. Fix precondition in creation method of structs
. Don't set implemenation of interface property to its own
. Use result value of assignment rather than its computation
. Cast instance parameter in member-initializer for
base-properties
. Skip StructRegisterFunction for boolean/integer/floating
types
. Handle different type-symbols in visit_base_access()
. Explicitly include header for length-type of arrays
. Explicitly include <glib.h> as needed for null-literal
- vala:
. VoidType is actually compatible with itself
. Keep formal_target_type on transform of
method-call/object-creation
. Add a basic parameter check for [Print] methods
. Don't ignore inner errors in Block and acknowledge them
further
. Don't report further errors if MemberInitializer.check()
failed
. Improve error message for unsupported inner types and
declarations
. Don't allow "va_list" as return-type or type of fields
. Check before accessing "name" of parent_symbol which might
be null
. Allow to override base interface properties explicitly
. Always bail if there are semantic errors
. Fix base-access check for compact classes
. Improve detection of recursive struct declarations
. Inline allocated arrays require length or initializer
. Don't ignore errors in Parameter and acknowledge them
further
- parser: Implicit "main" method of main-block is public and
static
- genie: Fix parser's inner state when a struct is declared
after a class
- girparser: Apply explicitly given ctype metadata attributes
on callables
- testrunner: Invalid tests and therefore expected failures
must return 1
+ Bindings:
- glib-2.0: Add to_string() for GLib.PollFd and GLib.Pid
- gstreamer: Update from 1.17.0+ git master
- gtk+-3.0: Update to 3.24.13+3822ac74
- gtk4: Update to 3.96.0+4ab12ab7
- webkit2gtk-4.0: Update to 2.27.4

==== xfce4-whiskermenu-plugin ====
Version update (2.3.5 -> 2.4.1)
Subpackages: xfce4-whiskermenu-plugin-lang

- Update to 2.4.1
* Fix narrow iconview columns.
* Fix bad hyphenation by increasing iconview column width.
* Translation updates
- Update to 2.4.0
* Add option to show as icons. (bxo#15675)
* Add hiding menu items. (bxo#14816)
* Add searching keywords of menu items. (bxo#15047)
* Add tooltip to profile picture for editing profile. (bxo#15501)
* Adjust wording of switch user command. (bxo#15398)
* Add icons to context menu.
* New default layout.
* Make panel button square only if single row and title hidden.
* Rearrange settings dialog.
* Redesign session confirmation dialogs.
* Refactor code.
* Rewrite menu load to match GarconGtkMenu.
* Switch categories with keyboard focus if hover enabled.
* Use custom icon renderer.
* Use link time optimization if available.
* Increase C++ version.
* Translation updates


N�����r��y隊Z)z{.���r�+�맲��r��z�^�ˬz��N�(�֜��^� ޭ隊Z)z{.���r�+��0�������Ǩ�
< Previous Next >
This Thread
  • No further messages