Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
Re: [opensuse-factory] Minimal processor features for Tumbleweed on i586?
On Thu, 2020-01-30 at 12:11 +0100, Thomas Zimmermann wrote:
Hi

Am 30.01.20 um 11:50 schrieb Jan Engelhardt:
On Thursday 2020-01-30 11:40, Thomas Zimmermann wrote:

I tried to run Tumbleweed on i586 today and when starting Gnome on X11
or got a number of errors caused by invalid opcodes.

[ 630.370899] traps: evolution-sourc[2962] trap invalid opcode
ip:ae285db9 sp:bfd6fa00 error:0 in libjavascriptcoregtk-
4.0.so.18.14.8[ad937000+ca8000]

It's the usual crap that programs make use of sse2
without checking cpuid AT DAMN RUNTIME.

webkit2gtk3 build log:
[ 64s] -- Performing Test C_COMPILER_SUPPORTS_-msse2
[ 65s] -- Performing Test C_COMPILER_SUPPORTS_-msse2 - Success
[ 65s] -- Performing Test C_COMPILER_SUPPORTS_-mfpmath=sse
[ 65s] -- Performing Test C_COMPILER_SUPPORTS_-mfpmath=sse - Success
[ 65s] -- Performing Test CXX_COMPILER_SUPPORTS_-msse2
[ 65s] -- Performing Test CXX_COMPILER_SUPPORTS_-msse2 - Success
[ 65s] -- Performing Test CXX_COMPILER_SUPPORTS_-mfpmath=sse
[ 65s] -- Performing Test CXX_COMPILER_SUPPORTS_-mfpmath=sse - Success


Glad to see that the processor is not yet entirely unsupported. Shall I
open a bug report for this problem?

That will be tough: webkit2gtk claims in the CMake files:

include(DetectSSE2)
if (NOT SSE2_SUPPORT_FOUND)
message(FATAL_ERROR "SSE2 support is required to compile WebKit")
endif ()

Cheers,
Dominique

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >