Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200127 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Wed, 29 Jan 2020 01:04:19 +0000
  • Message-id: <158025985931.24142.4902356273528175062@go-agent-stagingbot-6>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200127

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
accerciser
anjuta
anjuta-extras
dasher
dconf-editor
dtc
eog-plugins
evolution-rss
gdl
gitg
gnome-dvb-daemon
gnome-mahjongg
gnome-weather
gthumb
iagno
inn
kdeconnect-kde (1.3.5 -> 1.4)
kwallet
libgda
libgnome-games-support
libreoffice (6.4.0.2 -> 6.4.0.3)
libsolv (0.7.10 -> 0.7.11)
meld
nemiver
obs-service-recompress (0.3.1+git20170704.59bf231 ->
0.4.0+git20200123.696d003)
pcsc-lite
php7 (7.4.1 -> 7.4.2)
pitivi
python-alembic (1.3.2 -> 1.3.3)
quadrapassel
rubygem-i18n (1.7.0 -> 1.8.2)
rubygem-public_suffix (4.0.1 -> 4.0.3)
rubygem-rb-inotify (0.10.0 -> 0.10.1)
rubygem-tzinfo-1.2 (1.2.5 -> 1.2.6)
rubygem-yard (0.9.20 -> 0.9.24)
rygel
seahorse-sharing
sushi
vlc

=== Details ===

==== accerciser ====
Subpackages: accerciser-lang

- No longer recommend -lang: supplements are in use

==== anjuta ====
Subpackages: anjuta-lang libanjuta-3-0

- No longer recommend -lang: supplements are in use
- Update to version 3.34.0:
+ Replace Bugzilla by Gitlab URL in DOAP file.
+ Add new vala version.
+ anjuta-tags: fix tag for vala language.
+ Convert README to markdown.
+ Add build rule so that README is not flagged as missing.
+ build: Allow building with vala 0.44.
+ Fix error in distcheck.
+ build: Don't require exact match in the bison check.
+ Updated translations.
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
- Replace pkgconfig(libvala-0.38) BuildRequires with libvala-devel.
- Update to version 3.28.0:
+ help: Fix build-tutorial.
+ Fix a random crash when vim modelines are used.
+ Updated translations.
- Drop:
- update-desktop-files BuildRequires and its macro: they are no
longer required anymore.
- shared-mime-info BuildRequires, and glib2_gsettings_schema_*,
desktop_database_*, icon_theme_cache_* and mime_database_*
post/postun scriptlets and glib2_gsettings_schema_requires
macro: their functionality has been moved to RPM file triggers
(RPM 4.13, suse_vesion 1330).
- Modernize spec-file by calling spec-cleaner
- Update to version 3.26.0:
+ Remove some untracked files from git status (bgo#787473).
+ Language-support-vala fails to build with vala 0.38
(bgo#786973).
+ Updated translations.
- Stop passing --disable-vala to configure, bug fixed upstream.
- Trim descriptions in secondary packages, and update summaries.
Do not run fdupes across hardlink boundaries.
- Pass --disable-vala to configure until bgo#786973 is resolved.
- Update to version 3.25.91:
+ bgo#782633: Scintilla editor occupies 100% of a core after
switching tabs.
+ bgo#782452: Using #!/usr/bin/perl in scripts is not portable.
+ Avoid errors with recent version of gcc.
+ gdb: bgo#783380: Unable to debug executable compiled with -pie
option.
+ bgo#770822: "Search for example code" points to discontinued
webpage
+ bgo#763115: Anjuta builds are not reproducible.
+ Fix some compiler warnings.
+ Fix warning misleading-indentation.
+ Remove obsolete CSS properties.
+ Remove deprecated flags.
+ Fix some run time critical warnings.
+ Avoid an endless loop when updating a project.
+ Fix another crash when updating project files.
+ bgo#786309: segfault when shm support is missing.
+ gtksourceview: Ignore changes that happen during a save.
+ symbol-db: add support for libgda-6.0.
+ Support reproducible builds.
+ manuals: Remove extra - symbols before =.
+ Allow building with vala 0.36 and 0.38.
+ bgo#771625: needs support for vala 0.34.
+ Fix callback generation when user_data is set on glade.
+ Fix translator comments.
+ Updated translations.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Drop anjuta-vala-0.34.patch and anjuta-fix-gcc7-build.patch:
Fixed upstream, following this, drop gnome-common BuildRequires:
and autogen.sh call, no longer needed.

==== anjuta-extras ====
Subpackages: anjuta-extras-lang

- No longer recommend -lang: supplements are in use

==== dasher ====
Subpackages: dasher-data-extras dasher-data-recommended dasher-lang

- No longer recommend -lang: supplements are in use

==== dconf-editor ====
Subpackages: dconf-editor-lang

- No longer recommend -lang: supplements are in use

==== dtc ====

- add dtc-no-common-conflict.patch (bsc#1160388)

==== eog-plugins ====
Subpackages: eog-plugins-lang

- No longer recommend -lang: supplements are in use

==== evolution-rss ====
Subpackages: evolution-plugin-rss evolution-plugin-rss-lang

- No longer recommend -lang: supplements are in use

==== gdl ====
Subpackages: gdl-lang libgdl-3-5

- No longer recommend -lang: supplements are in use

==== gitg ====
Subpackages: gitg-lang libgitg-1_0-0 libgitg-ext-1_0-0

- No longer recommend -lang: supplements are in use

==== gnome-dvb-daemon ====
Subpackages: gnome-dvb-daemon-lang python-gnome-dvb-daemon
totem-plugin-gnome-dvb-daemon

- No longer recommend -lang: supplements are in use

==== gnome-mahjongg ====
Subpackages: gnome-mahjongg-lang

- No longer recommend -lang: supplements are in use

==== gnome-weather ====
Subpackages: gnome-shell-search-provider-gnome-weather gnome-weather-lang

- No longer recommend -lang: supplements are in use

==== gthumb ====
Subpackages: gthumb-lang

- No longer recommend -lang: supplements are in use

==== iagno ====
Subpackages: iagno-lang

- No longer recommend -lang: supplements are in use

==== inn ====

- change user to news before touching files in /var/log/news
[bnc#1154302] [CVE-2019-3692]

==== kdeconnect-kde ====
Version update (1.3.5 -> 1.4)
Subpackages: kdeconnect-kde-lang

- Update to 1.4
* New "KDE Connect" desktop app to control the phone from the PC
* SMS app that can read and write SMS texts
* control PC system's global volume from a phone
* flip forward and back through presentation slides
* compatibility with Thunar (Xfce's file manager) and Elementary
applications such as Pantheon Files.
- Run spec-cleaner

==== kwallet ====
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Add upstream patch to fix twice anchored regexp's
* d4980443755f5df63b6a13f662df169797f2684f.patch
- Add upstream patch to revert QRegExp::Wildcard to solve problem with
listing of entries using QRegularExpression::wildcardToRegularExpression
* 02ab54ea6fe8b61a4e474070061d6e41aebc71a0.patch

==== libgda ====
Subpackages: libgda-5_0-4 libgda-5_0-4-lang libgda-5_0-bdb libgda-5_0-sqlite
libgda-ui-5_0-4 libgda-ui-5_0-plugins

- No longer recommend -lang: supplements are in use

==== libgnome-games-support ====
Subpackages: libgnome-games-support-1-3 libgnome-games-support-lang

- No longer recommend -lang: supplements are in use

==== libreoffice ====
Version update (6.4.0.2 -> 6.4.0.3)
Subpackages: libreoffice-base libreoffice-base-drivers-firebird
libreoffice-calc libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-l10n-es
libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru
libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
libreofficekit

- Update to 6.4.0.3:
* RC 3 of 6.4 release
- Require java 1.8 or newer

==== libsolv ====
Version update (0.7.10 -> 0.7.11)
Subpackages: libsolv-devel libsolv-tools python3-solv ruby-solv

- fixed solv_zchunk decoding error if large chunks are used
- treat retracted pathes as irrelevant
- made add_update_target work with multiversion installs
- bump version to 0.7.11

==== meld ====
Subpackages: meld-lang

- No longer recommend -lang: supplements are in use

==== nemiver ====
Subpackages: nemiver-lang

- No longer recommend -lang: supplements are in use

==== obs-service-recompress ====
Version update (0.3.1+git20170704.59bf231 -> 0.4.0+git20200123.696d003)

- Update to version 0.4.0+git20200123.696d003:
* run test suite during build
- Update to version 0.4.0+git20200123.946b23f:
* add zstd compression support

==== pcsc-lite ====
Subpackages: libpcsclite1

- BuildRequire pkgconfig(libudev) instead of libudev-devel: allow
OBS to shortcut through -mini flavors.

==== php7 ====
Version update (7.4.1 -> 7.4.2)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pgsql php7-shmop php7-snmp php7-sockets
php7-sqlite php7-sysvsem php7-sysvshm php7-tidy php7-tokenizer php7-xmlreader
php7-xmlwriter php7-xsl php7-zlib

- updated to 7.4.2: This is a security release which also contains
several bug fixes. See https://www.php.net/ChangeLog-7.php#7.4.2

==== pitivi ====
Subpackages: pitivi-lang

- No longer recommend -lang: supplements are in use

==== python-alembic ====
Version update (1.3.2 -> 1.3.3)

- specfile:
* update copyright year
- update to version 1.3.3:
* bug
+ Fixed issue where COMMENT directives for PostgreSQL failed to
correctly include an explicit schema name, as well as correct
quoting rules for schema, table, and column names. Pull request
courtesy Matthew Sills. References: #637
* usecase
+ Added support for rendering of ?computed? elements on Column
objects, supported in SQLAlchemy via the new Computed element
introduced in version 1.3.11. Pull request courtesy Federico
Caselli.
Note that there is currently no support for ALTER COLUMN to add,
remove, or modify the ?GENERATED ALWAYS AS? element from a
column; at least for PostgreSQL, it does not seem to be
supported by the database. Additionally, SQLAlchemy does not
currently reliably reflect the ?GENERATED ALWAYS AS? phrase from
an existing column, so there is also no autogenerate support for
addition or removal of the Computed element to or from an
existing column, there is only support for adding new columns
that include the Computed element. In the case that the Computed
element is removed from the Column object in the table metadata,
PostgreSQL and Oracle currently reflect the ?GENERATED ALWAYS
AS? expression as the ?server default? which will produce an op
that tries to drop the element as a default. References: #624

==== quadrapassel ====
Subpackages: quadrapassel-lang

- No longer recommend -lang: supplements are in use

==== rubygem-i18n ====
Version update (1.7.0 -> 1.8.2)

- New upstream release 1.8.2
1.7.1:
- I18n is now tested with GitHub Actions, instead of Travis CI.
- Fixed issue introduced in v1.7.0 (04a814b) where count option was not
preserved - #503
- #501 adds a comment that explains that you will need to double-splat
keyword arguments given to I18n.t to avoid warnings in Ruby 2.7.
1.8.0:
- Use Rails' implementation of deep_merge when chaining fallback backends -
#499.
1.8.1:
- Reverted #499 in #508 due to #507 - missing deep_merge method.
1.8.2:
- Restoration of #499 via #509 - deep_merge! & deep_merge methods appear
again in the Hash refinement.
- An issue was introduced in v1.7.0 where some translations were returned as
hashes, see #510. This was fixed in 1b5e345, and is available in this release.

==== rubygem-public_suffix ====
Version update (4.0.1 -> 4.0.3)

- updated to version 4.0.3
[#] Fixed
* Fixed 2.7 deprecations and warnings (GH-167). [Thanks @BrianHawley]

==== rubygem-rb-inotify ====
Version update (0.10.0 -> 0.10.1)

- updated to version 0.10.1
no changelog found

==== rubygem-tzinfo-1.2 ====
Version update (1.2.5 -> 1.2.6)

- updated to version 1.2.6
* Timezone#strftime('%s', time) will now return the correct number of seconds
since the epoch. #91.
* Removed the unused TZInfo::RubyDataSource::REQUIRE_PATH constant.
* Fixed "SecurityError: Insecure operation - require" exceptions when loading
data with recent Ruby releases in safe mode.
* Fixed warnings when running on Ruby 2.7. #106 and #111.

==== rubygem-yard ====
Version update (0.9.20 -> 0.9.24)

- New upstream release 0.9.24
[#] 0.9.24 - January 8th, 2020
- Add {YARD::CodeObjects::NamespaceMapper.on_invalidate} callback when
separator cache is changed.
- Fix issue where Registry fails to resolve first-time lookups on instance
methods.
- New upstream release 0.9.23
[#] 0.9.23 - January 5th, 2020
- Fix issues with double encoded code blocks when highlighted from an extra
file.
[#] 0.9.22 - December 31st, 2019
- Revert jquery update in last release since it requires more changes. (#1298)
[#] 0.9.21 - December 31st, 2019
- Updates to add support for Ruby 2.7.0 (#1290, #1296)
- Fix parsing of multiline method signatures (#1220)
- Remove RubyGems post install message (#1269)
- Improve object deletion from RegistryStore (#1284)
- Improve memory usage performance (#1260)
- Handle include and extend calls with explicit receivers (#1274)
- Fix deep nesting of TOC items (#1288)
- Fix highlighting for Asciidoc markup code blocks (#1276)
- Fix HTML formatting of script tags (#1263)
- Update jquery to 3.4.1 (#1294)
- Test fixes (#1244)

==== rygel ====
Subpackages: librygel-core-2_6-2 librygel-server-2_6-2

- No longer recommend -lang: supplements are in use

==== seahorse-sharing ====
Subpackages: seahorse-sharing-lang

- No longer recommend -lang: supplements are in use

==== sushi ====
Subpackages: sushi-lang

- No longer recommend -lang: supplements are in use

==== vlc ====
Subpackages: libvlc5 libvlccore9 vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt
vlc-vdpau

- BuildRequire pkgconfig(libudev) instead of libudev-devel: Allow
OBS to shortcut through the -mini flavors.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages