Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200125 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 26 Jan 2020 20:01:01 +0000
  • Message-id: <158006886138.6057.1049812609391063425@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200125

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
build (20200107 -> 20200124.1)
dbus-1
gdbm
gettext-runtime (0.19.8.1 -> 0.20.1)
gmp (6.1.2 -> 6.2.0)
sed (4.7 -> 4.8)
shadow (4.7 -> 4.8)
suse-module-tools (15.2.9 -> 15.2.10)

=== Details ===

==== build ====
Version update (20200107 -> 20200124.1)
Subpackages: build-mkbaselibs build-mkdrpms

- fix SLE 15 configurations
- Fix dist autodetection for sle15-sp2
- Fix crash when using preinstall dependency expansion in OBS
- build-vm-kvm: use /boot/kernel.obs.build and /boot/initrd.obs.build
as fallback regardless of the platform to have a global fallback
kernel to use for distros that do not use the "kernel-obs-build"
package to provide the guests kernel and initrd as the system
binaries are not reliable for use in a guest system
- use abuild user if $NOROOTFORBUILD is set.
- fix createrepo existens check for appimager and docker builds
in chroot
- support to use virt-make-fs for ext3 VM builds
- Arch Linux zstd format support
- fix testbuild fail with latest rpm in SP2 and Leap 15.2
- do not retry automatically on disk full error

==== dbus-1 ====
Subpackages: libdbus-1-3 libdbus-1-3-32bit

- Remove left overs from blocking restart on update from May 29th 2019
- Use sysusers.d to create messagebus user

==== gdbm ====
Subpackages: gdbm-devel gdbm-lang libgdbm6 libgdbm_compat4

- added patches
Build with -no-common, [bsc#1160872]
+ gdbm-no-common.patch

==== gettext-runtime ====
Version update (0.19.8.1 -> 0.20.1)
Subpackages: gettext-tools

- Add libtextstyle0 to baselibs.conf: gettext-runtime-32bit has a
dependency on it, so we also need the library built as -32bit.
- Add missing Requires: libtextstyle0 in corresponding devel package,
drop gettext-runtime Requires.
- Skip creation of shared libtextstyle in -mini flavor.
- Statically link to libtextstyle in -mini flavor, fixes
broken bootstrap of gettext.
- Add -lm to LDFLAGS (boo#1138806)
- Added xz to requires (boo#1141380)
- The previous update to 0.20.1 also fixes (boo#1113719)
- Remove autoreconf call (not required), and drop the no longer
required libtool build dependency.
- Heed SLPP by placing libtextstyle.so.0 in the right package.
- Drop documentation from libtextstyle0, no one will read it there.
- Drop static library.
- Remove pointless ldconfig calls for libtextstyle-devel.
- Avoid pointless sh invocation of libtextstyle0 scriptlets.
- Avoid unnecessary |xargs rm.
- Remove redundant %clean section.

==== gmp ====
Version update (6.1.2 -> 6.2.0)
Subpackages: gmp-devel libgmp10 libgmp10-32bit libgmpxx4

- GMP 6.2.0:
* New C++ functions factorial, primorial and fibonacci for mpz_class
* Functions to detect primality now substitute the first 24 Miller-Rabin
iterations with the BPSW test
* Mini-GMP: new functions mpz_2fac_ui and mpz_mfac_uiui.
* Mini-GMP: mpz_sizeinbase, mpz_get_str, and mpz_set_str now support bases up
to 62.
* various bug fixes
* Major speedup on AMD Ryzen and Epyc, IBM POWER9, 64-bit ARM CPUs
from assembly code
* Speedups from reimplementations
- drop patches:
* gmp-6.1.2-conftest.patch, upstream
* gmp-noexec.diff, upstream
* floating-point-format-no-lto.patch, similar change
- Move prominent summary from description to the summary field,
and update the main description.

==== sed ====
Version update (4.7 -> 4.8)
Subpackages: sed-lang

- GNU sed 4.8:
* "sed -i" now creates temporary files with correct umask
(limited to u=rwx), to avoid prolems with fuse-like file systems
* improved DFA performance through gnulib update
- drop disable-null-ptr-argument.patch, upstream

==== shadow ====
Version update (4.7 -> 4.8)

- Set 0755 for chpasswd, groupadd, groupdel, groupmod, newusers,
useradd, userdel, usermod explicitly.
- bsc#1160729: Make valid shell check only a warning
* Add shadow-4.8-shell-check.patch
- Update to 4.8:
* Initial optional bcrypt support.
* Make build/install of 'su' optional.
* Fix for vipw not resuming correctly when suspended
* Sync password field descriptions in manpages
* Check for valid shell argument in useradd
* Allow translation of new strings through POTFILES.in
* Migrate to itstool for translations
* Migrate to new SELinux api
* Support --enable-vendordir
* pwck: Only check homedir if set and not a system user
* Support nonstandard usernames
* sget{pw,gr}ent: check for data at EOL
* Add YYY-MM-DD support in chage
* Fix failing chmod calls for suidubins
* Fix --sbindir and --bindir for binary installations
* Fix LASTLOG_UID_MAX in login.defs
* Fix configure error with dash
- Remove because upstreamed:
* libeconf.patch
* shadow-usermod-variable.patch
- Rebase:
* shadow-login_defs-unused-by-pam.patch
* chkname-regex.patch
* shadow-util-linux.patch
* shadow-login_defs-comments.patch
- Add shadow-4.8-selinux-include.patch
See https://github.com/shadow-maint/shadow/pull/200

==== suse-module-tools ====
Version update (15.2.9 -> 15.2.10)

- Update to version 15.2.10:
* ppc64le: fix dependency of papr_scm
(bsc#1142152, ltc#176292, FATE#327775).


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages