Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200123 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sat, 25 Jan 2020 13:01:52 +0000
  • Message-id: <157995731291.29764.17409272189960552264@go-agent-stagingbot-4>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200123

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.9.16 -> 7.0.9.17)
apache2
audit (2.8.4 -> 2.8.5)
audit-secondary (2.8.4 -> 2.8.5)
autogen
bash-completion
dwz
ethtool (5.3 -> 5.4)
fillup
gdb
hplip
ipset (7.4 -> 7.5)
libqt5-qtdeclarative
libqt5-qtwebengine
libvirt (5.10.0 -> 6.0.0)
libx86emu (2.4 -> 2.6)
messagelib
nghttp2 (1.39.2 -> 1.40.0)
perl-TimeDate (2.30 -> 2.31)
polkit-default-privs (13.2+20200116.0f7fd4b -> 13.2+20200121.bfca858)
python-libvirt-python (5.10.0 -> 6.0.0)
python-reportlab (3.5.32 -> 3.5.34)
python-rpm-macros (20191104.08e6493 -> 20200117.8e39013)
python-six (1.13.0 -> 1.14.0)
python-zope.component (4.5 -> 4.6)
python-zope.hookable (4.2.0 -> 5.0.0)
python-zope.i18nmessageid (4.3.1 -> 5.0.0)
python-zope.proxy (4.3.2 -> 4.3.3)
sqlite3 (3.29.0 -> 3.30.1)
taglib
valgrind
xorg-x11-server

=== Details ===

==== ImageMagick ====
Version update (7.0.9.16 -> 7.0.9.17)
Subpackages: ImageMagick-config-7-SUSE ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI7 libMagickWand-7_Q16HDRI7 perl-PerlMagick

- version update to 7.0.9.17
* Allow larger negative interline spacing (reference
https://imagemagick.org/discourse-server/viewtopic.php?f=1&t=37391).
* Conditional compile for huge xml pages for RSVG delegate library.
* Put "width" property in the PNG namespace (reference
https://github.com/ImageMagick/ImageMagick/issues/1833).
* -combine -colorspace sRGB no longer returns grayscale output (reference
https://github.com/ImageMagick/ImageMagick/issues/1835).
* Support Jzazbz colorspace (contributed by snibgo @
http://im.snibgo.com/jzazbz.htm).

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- apache2-devel now provides httpd-devel [bsc#1160100]

==== audit ====
Version update (2.8.4 -> 2.8.5)
Subpackages: audit-devel libaudit1 libaudit1-32bit libauparse0

- Update to version 2.6.5:
* Fix segfault on shutdown
* Fix hang on startup (#1587995)
* Add sleep to script to dump state so file is ready when needed
* Add auparse_normalizer support for SOFTWARE_UPDATE event
* Mark netlabel events as simple events so that get processed quicker
* When audispd is reconfiguring, only SIGHUP plugins with valid pid (#1614833)
* Add 30-ospp-v42.rules to meet new Common Criteria requirements
* Update lookup tables for the 4.18 kernel
* In aureport, fix segfault in file report
* Add auparse_normalizer support for labeled networking events
* Fix memory leak in audisp-remote plugin when using krb5 transport.
(#1622194)
* Event aging is off by a second
* In ausearch/auparse, correct event ordering to process oldest first
* auparse_reset was not clearing everything it should
* Add support for AUDIT_MAC_CALIPSO_ADD, AUDIT_MAC_CALIPSO_DEL events
* In ausearch/report, lightly parse selinux portion of USER_AVC events
* In ausearch/report, limit record size when malformed
* In auditd, fix extract_type function for network originating events
* In auditd, calculate right size and location for network originating events
* Treat all network originating events as VER2 so dispatcher doesn't format it
* In audisp-remote do an initial connection attempt (#1625156)
* In auditd, allow expression of space left as a percentage (#1650670)
* On PPC64LE systems, only allow 64 bit rules (#1462178)
* Make some parts of auditd state report optional based on config
* Fix ausearch when checkpointing a single file (Burn Alting)
* Fix scripting in 31-privileged.rules wrt filecap (#1662516)
* In ausearch, do not checkpt if stdin is input source
* In libev, remove __cold__ attribute for functions to allow proper hardening
* Add tests to configure.ac for openldap support
* Make systemd support files use /run rather than /var/run (Christian Hesse)
* Fix minor memory leak in auditd kerberos credentials code
* Fix auditd regression where keep_logs is limited by rotate_logs 2 file test
* In ausearch/report fix --end to use midnight time instead of now (#1671338)
- Remote zos building is now a configurable option.
It should be disabled in audit (and left enabled in audit-secondary).

==== audit-secondary ====
Version update (2.8.4 -> 2.8.5)
Subpackages: audit python3-audit

- Update to version 2.6.5:
* Fix segfault on shutdown
* Fix hang on startup (#1587995)
* Add sleep to script to dump state so file is ready when needed
* Add auparse_normalizer support for SOFTWARE_UPDATE event
* Mark netlabel events as simple events so that get processed quicker
* When audispd is reconfiguring, only SIGHUP plugins with valid pid (#1614833)
* Add 30-ospp-v42.rules to meet new Common Criteria requirements
* Update lookup tables for the 4.18 kernel
* In aureport, fix segfault in file report
* Add auparse_normalizer support for labeled networking events
* Fix memory leak in audisp-remote plugin when using krb5 transport.
(#1622194)
* Event aging is off by a second
* In ausearch/auparse, correct event ordering to process oldest first
* auparse_reset was not clearing everything it should
* Add support for AUDIT_MAC_CALIPSO_ADD, AUDIT_MAC_CALIPSO_DEL events
* In ausearch/report, lightly parse selinux portion of USER_AVC events
* In ausearch/report, limit record size when malformed
* In auditd, fix extract_type function for network originating events
* In auditd, calculate right size and location for network originating events
* Treat all network originating events as VER2 so dispatcher doesn't format it
* In audisp-remote do an initial connection attempt (#1625156)
* In auditd, allow expression of space left as a percentage (#1650670)
* On PPC64LE systems, only allow 64 bit rules (#1462178)
* Make some parts of auditd state report optional based on config
* Fix ausearch when checkpointing a single file (Burn Alting)
* Fix scripting in 31-privileged.rules wrt filecap (#1662516)
* In ausearch, do not checkpt if stdin is input source
* In libev, remove __cold__ attribute for functions to allow proper hardening
* Add tests to configure.ac for openldap support
* Make systemd support files use /run rather than /var/run (Christian Hesse)
* Fix minor memory leak in auditd kerberos credentials code
* Fix auditd regression where keep_logs is limited by rotate_logs 2 file test
* In ausearch/report fix --end to use midnight time instead of now (#1671338)
- Fix build errors when using gcc-10 no-common default (bsc#1160384)
New patch: audit-fno-common.patch
- Refresh audit-allow-manual-stop.patch

==== autogen ====
Subpackages: libopts25

- guile-version.patch: Allow building with guile 3.0

==== bash-completion ====

- Remove _adb as it seems to be broken anyway (boo#1161136)

==== dwz ====

- Fix reference from compilation unit to partial unit [swo#25398].
* dwz-fix-reference-from-pu-to-cu.patch

==== ethtool ====
Version update (5.3 -> 5.4)

- Update to new upstream release 5.4
* support Energy Detect Power Down
* Solarflare SFF-8079/8472 eeprom interpretation fixes
* fix compiler warnings with new gcc
- drop "-Wno-unused-parameter" from CFLAGS, these warnings should
be gone now

==== fillup ====

- fillup-fno-common.patch: fix compilation on Tumbleweed
(boo#1160871)

==== gdb ====

- Add support for official name of s390 arch13: z15.
Add descriptions for arch13 instructions. Adds
gdb-arch13-1.diff, gdb-arch13-2.diff and gdb-arch13-3.diff.
[jsc#SLE-7903]

==== hplip ====
Subpackages: hplip-hpijs hplip-sane

- Use /etc/sane.d/dll.d/hpaio to register SANE backend rather
than modifying /etc/sane/dll.conf
- SANE backend must be configured in hplip-sane package (bsc#1160708)
- Revert changes from 3.18.5 that break hp-setup for fax devices
(bsc#1107711, lp#1773320)
* Added patch: Revert-changes-from-3.18.5-that-break-hp-setup-for-f.patch

==== ipset ====
Version update (7.4 -> 7.5)
Subpackages: libipset13

- Update to release 7.5
* netfilter: ipset: avoid null deref when IPSET_ATTR_LINENO
is present.
* netfilter: xt_set: Do not restrict --map-set to the
mangle table.

==== libqt5-qtdeclarative ====

- Only force-enable the QML JIT for 32-bit x86

==== libqt5-qtwebengine ====

- Disable valgrind on %arm due to boo#1130395

==== libvirt ====
Version update (5.10.0 -> 6.0.0)
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- Update to libvirt 6.0.0
- jsc#SLE-6997, jsc#SLE-6998
- Many incremental improvements and bug fixes, see
https://libvirt.org/news.html
- Dropped patches:
0a65cba4-news-fix.patch 07aaced4-Add-TAA-No.patch,
f411b7ef6-Add-TSX-CTRL.patch, 50d7465f-qemu-firmware1.patch,
57f9067c-qemu-firmware2.patch, 7c5264d2-qemu-firmware3.patch,
8e1804f9-qemu-firmware4.patch, 8fcee478-qemu-firmware5.patch

==== libx86emu ====
Version update (2.4 -> 2.6)

- merge gh#wfeldt/libx86emu#17
- Introduce LDFLAGS variable in Makefiles
- test: Link with the development version of the library
- test: Sort tests by name
- Add Travis CI configuration file and a badge in the README
- Travis CI integration
- 2.6
- merge gh#wfeldt/libx86emu#22
- decode: Prepare for SSE support
- ops2: Add SSE instructions
- ops2: Add packed SSE ops
- Minimal SSE support
- merge gh#wfeldt/libx86emu#21
- prim_ops: Fix compiler warning
- merge gh#wfeldt/libx86emu#24
- ops2: Add cpuid support using a new handler
- ops2: Introduce a callback function for MSR access
- Push cpuid msr callback
- merge gh#wfeldt/libx86emu#26
- add '--32' option to demo program to start in 32-bit mode
- 2.5

==== messagelib ====
Subpackages: messagelib-lang

- Add upstream patch to prevent attachments from being lost when
saving a message as a draft (kde#416369):
* 0001-Fix-Bug-416369-attachments-lost-draft-message.patch

==== nghttp2 ====
Version update (1.39.2 -> 1.40.0)

- Update to version 1.40.0
* lib: Add nghttp2_check_authority as public API
* lib: Fix the bug that stream is closed with wrong error code
* lib: Faster huffman encoding and decoding
* build: Avoid filename collision of static and dynamic lib
* build: Add new flag ENABLE_STATIC_CRT for Windows
* build: cmake: Support building nghttpx with systemd
* third-party: Update neverbleed to fix memory leak
* nghttpx: Fix bug that mruby is incorrectly shared between
backends
* nghttpx: Reconnect h1 backend if it lost connection before
sending headers
* nghttpx: Returns 408 if backend timed out before sending
headers
* nghttpx: Fix request stal

==== perl-TimeDate ====
Version update (2.30 -> 2.31)

- Remove patch perl-TimeDate-getdate.patch (source was fixed)
- updated to 2.31
see /usr/share/doc/packages/perl-TimeDate/ChangeLog
2.31 -- Thu Jan 16 14:00:00 MT 2020
* Fix year 2020 bug from t/getdate.t [Prajith]
* Fix warnings from t/date.t
* Fix pod issue in lib/Date/Parse.pm
* Fix for French language using English day suffixes in %o [mitchjacksontech]
* RT#84075: Fix Date::Parse::str2time century issue. [perlpilot]
* Adds Occitan language. [Quenty31]
* Migrate GitHub repo and bugtracker to atoomic/perl-TimeDate

==== polkit-default-privs ====
Version update (13.2+20200116.0f7fd4b -> 13.2+20200121.bfca858)

- Update to version 13.2+20200121.bfca858:
* systemd networkd incremental polkit rules (bsc#1161328)

==== python-libvirt-python ====
Version update (5.10.0 -> 6.0.0)

- Update to 6.0.0
- Add all new APIs and constants in libvirt 6.0.0
- Revert commit b22e4f24 to retain python2 support a bit longer
on SUSE
revert-b22e4f24.patch

==== python-reportlab ====
Version update (3.5.32 -> 3.5.34)
Subpackages: python2-reportlab python3-reportlab

- Update to 3.5.34:
- change of the core repository (it is
https://hg.reportlab.com/hg-public/reportlab, they stuck to
Mercurial even when Bitbucket left it; issue reporting on the
email list
https://pairlist2.pair.net/mailman/listinfo/reportlab-users)
- attempted restriction of the reportlab.lib.color.toColor
function; fix of CVE-2019-17626 (bsc#1154370;
bt#rptlab/reportlab#199)
- fix bug in Pie3d reported by Eldon Ziegler <eldonz@xxxxxxxxxxxxxx>
- fix bug in background splitting in repeatRows cases
- small improvements to CandleSticks
- created NotSet validator (use in CandleStickProperties)
- add documentation
- remove python38_build.patch, because it has been included
upstream

==== python-rpm-macros ====
Version update (20191104.08e6493 -> 20200117.8e39013)

- Add python-rpm-generators to express setuptools dependency for generator
- Update to version 20200117.8e39013:
* Add macros related to the Python dist metadata dependency generator

==== python-six ====
Version update (1.13.0 -> 1.14.0)
Subpackages: python2-six python3-six

- update to 1.14.0
* Add `six.assertNotRegex`
* `six.moves._dummy_thread` now points to the `_thread` module on
Python 3.9+. Python 3.7 and later requires threading and deprecated the
`_dummy_thread` module
* Remove support for Python 2.6 and Python 3.2
* `six.wraps` now ignores missing attributes

==== python-zope.component ====
Version update (4.5 -> 4.6)

- update to version 4.6
* Add support for Python 3.8.
* Drop support for Python 3.4.
* Fix tests on Python 2 following changes in ZODB 5.5.0.

==== python-zope.hookable ====
Version update (4.2.0 -> 5.0.0)

- update to version 5.0.0
* Add support for Python 3.7 and 3.8.
* Drop support for Python 3.4.

==== python-zope.i18nmessageid ====
Version update (4.3.1 -> 5.0.0)

- update to version 5.0.0
* Drop support for Python 3.4.
* Add support for Python 3.8.

==== python-zope.proxy ====
Version update (4.3.2 -> 4.3.3)

- update to 4.3.3
* Add support for Python 3.8.
* Drop support for Python 3.4.

==== sqlite3 ====
Version update (3.29.0 -> 3.30.1)
Subpackages: libsqlite3-0

- Fix regression found when running python-Django/Djano1 testsuite:
+ 7833feecfe-Prevent-SQLite-from-bad-NULL-assumption.patch
+ 548082dfab-Improvements-to-the-LEFT-JOIN.patch
+ 8a39167bd2-Further-improvements-to-LEFT-JOIN.patch
- Fix check for existing dirs, triggers when running the testsuite
on BTRFS or XFS:
+ fix_dir_exists_on_btrfs.patch
- Fix truncation/bad rounding of timestamps in SQLite strftime
function, exposed when running testsuite on i586:
+ sqlite3-avoid-truncation-error.patch
- sqlite 3.30.1:
* fix a segfault for nested queries that use the FILTER clause
ib aggregate functions (introduced in 3.30.0)
- update to 3.30.0:
* Add support for the FILTER clause on aggregate functions
* Add support for the NULLS FIRST and NULLS LAST syntax in ORDER BY clauses
* The index_info and index_xinfo pragmas are enhanced to provide
information about the on-disk representation of WITHOUT ROWID tables
* Add the sqlite3_drop_modules() interface, allowing applications
to disable automatically loaded virtual tables that they do not need
* Improvements to the .recover dot-command in the CLI so that it
recovers more content from corrupt database files
* Enhance the RBU extension to support indexes on expressions
* Change the schema parser so that it will error out if any of
the type, name, and tbl_name columns of the sqlite_master table
have been corrupted and the database connection is not in
writable_schema mode.
* The PRAGMA function_list, PRAGMA module_list, and PRAGMA
pragma_list commands are now enabled in all builds by default
* Add the SQLITE_DBCONFIG_ENABLE_VIEW option for sqlite3_db_config().
* Added the TCL Interface config method in order to be able to
disable SQLITE_DBCONFIG_ENABLE_VIEW as well as control other
sqlite3_db_config() options from TCL.
* Added the SQLITE_DIRECTONLY flag for application-defined SQL
functions to prevent those functions from being used inside
triggers and views
- drop sqlite3-CVE-2019-16168.patch, upstream

==== taglib ====
Subpackages: libtag1 libtag_c0

- Add patch to get the right directories when running taglib-config:
* 0001-Changed-libdir-includedir-variables-to-change-based-.patch

==== valgrind ====

- Add support for PR_CAPBSET_READ/DROP syscalls. Fixes false
error messages with latest libcap 2.30.
* 0001-Add-newer-constants-for-prctl-syscall.patch
* 0002-Add-support-for-PR_CAPBSET_READ-and-_DROP-syscalls.patch

==== xorg-x11-server ====
Subpackages: xorg-x11-server-Xvfb xorg-x11-server-extra xorg-x11-server-sdk
xorg-x11-server-wayland

- u_fno-common.patch
* fix build with gcc's -fno-common option (boo#1160423)


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages