Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200116 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sat, 18 Jan 2020 05:02:07 +0000
  • Message-id: <157932372723.3679.5309604634696107326@go-agent-stagingbot-4>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200116

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
Mesa (19.3.1 -> 19.3.2)
Mesa-drivers (19.3.1 -> 19.3.2)
SDL2
boost-base
boost-extra
gpg2
hwinfo (21.67 -> 21.68)
ibus
icu
lftp (4.9.0 -> 4.9.1)
libpeas
llvm9
mypy (0.750 -> 0.761)
perl-Date-Manip (6.78 -> 6.79)
perl-TimeDate
polkit-default-privs (13.2+20191210.15c9882 -> 13.2+20200116.0f7fd4b)
python-Babel (2.7.0 -> 2.8.0)
python-PyYAML (5.2 -> 5.3)
python-docutils (0.15.2 -> 0.16)
python-gobject
python-hiredis (1.0.0 -> 1.0.1)
python-hpack
python-py (1.8.0 -> 1.8.1)
python-pybind11
python-scipy
python-six (1.12.0 -> 1.13.0)
rdma-core (26.1 -> 27.0)
rubygem-cheetah (0.5.1 -> 0.5.2)
systemd (243 -> 244)
texlive
totem
vlc

=== Details ===

==== Mesa ====
Version update (19.3.1 -> 19.3.2)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- Enable LLVM support on riscv64
- Update to version 19.3.2
* Intel and AMD drivers make up the bulk of the changes, with
a bit of nir and glsl, plus a sprinkling of other stuff in
there.

==== Mesa-drivers ====
Version update (19.3.1 -> 19.3.2)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- Enable LLVM support on riscv64
- Update to version 19.3.2
* Intel and AMD drivers make up the bulk of the changes, with
a bit of nir and glsl, plus a sprinkling of other stuff in
there.

==== SDL2 ====

- Temporarily work around -fno-common build failure [boo#1160382].

==== boost-base ====
Subpackages: boost-license1_71_0 boost1_71_0-jam libboost_date_time1_71_0
libboost_filesystem1_71_0 libboost_headers1_71_0-devel libboost_iostreams1_71_0
libboost_locale1_71_0 libboost_program_options1_71_0 libboost_regex1_71_0
libboost_thread1_71_0

- removed hpc bjam package (boo#1160621)
- added gnu-hpc-openmpi3 and mpich flavor (boo#1160622)

==== boost-extra ====

- removed hpc bjam package (boo#1160621)
- added gnu-hpc-openmpi3 and mpich flavor (boo#1160622)

==== gpg2 ====
Subpackages: gpg2-lang

- Accept key updates even without UIDs [bsc#1143158]
- Add patches:
* gnupg-allow-import-of-previously-known-keys-even-without-UIDs.patch
*
gnupg-accept_subkeys_with_a_good_revocation_but_no_self-sig_during_import.patch
* gnupg-add-test-cases-for-import-without-uid.patch

==== hwinfo ====
Version update (21.67 -> 21.68)

- merge gh#openSUSE/hwinfo#84
- the /sbin/udevadm compat symlink is gone
- 21.68

==== ibus ====
Subpackages: ibus-gtk ibus-gtk-32bit ibus-gtk3 ibus-lang libibus-1_0-5
libibus-1_0-5-32bit typelib-1_0-IBus-1_0

- Drop ibus-delete-weak-pointer-for-vala-0.43.4.patch
* which cannot be applied to 1.5.21
- Add ibus-delete-weak-pointer-for-vala-0.43.4.patch:
Backport this fix from upstream, To make ibus-1.5.19 can success
build with vala-0.43.4 and later editions(bnc#1159079).

==== icu ====
Subpackages: libicu-suse65_1 libicu65_1-ledata

- Remove /usr/lib(64)/icu/current [boo#1158955].

==== lftp ====
Version update (4.9.0 -> 4.9.1)

- Update to version 4.9.1
* get1: fixed creating the target directory.
* get1: fixed renaming the temp file.
* fixed a coredump on startup when IPv6 is not supported or configured.

==== libpeas ====
Subpackages: libpeas-1_0-0 libpeas-gtk-1_0-0 libpeas-lang
libpeas-loader-python3 typelib-1_0-Peas-1_0 typelib-1_0-PeasGtk-1_0

- Change %bcond_without python2 to %bcond_with python2, no longer
build python2 support.
- Add explicit gtk-doc BuildRequires, previously pulled in via
gobject-python-common-devel.

==== llvm9 ====
Subpackages: clang9 clang9-checker clang9-doc libLLVM9 libLTO9 libc++-devel
libc++1 libc++abi-devel libc++abi1 libclang9

- riscv-eh-frame-fixup.patch: Remove changesets that alter the libLLVM ABI
- Add upstream patch to export compiler-rt FuzzedDataProvider header,
required by Envoy 1.12.2:
* compiler-rt-move-fdp.patch
- riscv-eh-frame-fixup.patch: Fix handling of .eh_frame on RISC-V
- polly-pthread.patch: Add missing -lpthread

==== mypy ====
Version update (0.750 -> 0.761)

- update to version 0.761
- update to version 0.760:
- Type Signature Suggestions for Tools
- Type Inference Improvements
- Fixes to Regressions
- Fix regression introduced in 0.750: union (non-)simplification should not
affect type inference (PR 8095)
- Breaking Changes
- Make the error code of a binary operation involving overload operator, for
consistency (PR 8124)
- Other Notable Improvements and Bug Fixes
- Generate error when assigning an Enum or TypedDict type to an attribute
(Xuanda Yang, PR 8107)
- Fix relative path calculation if path is on a different drive on Windows
(Netzeband, PR 8094)
- Don?t infer an abstract type object type from concrete type object values
(Xuanda Yang, PR 8096)
- Fix an inconsistency with type checking lambda expressions (PR 8080)
- Fix crash involving generic callable types (PR 8075)
- Improve error message with long tuple initializer (Xuanda Yang, PR 7995)
- Improve mypy daemon documentation (PR 8041)
- Recommend typing_extensions instead of mypy_extensions for TypedDict (PR
8023)
- Fix an inconsistency with self types (PR 8030, PR 8021)
- Support type alias within Literal[...] (Xuanda Yang, PR 8014)
- Fix --warn-return-any false positive when returning Any from a function
declared to return object (Xuanda Yang, PR 8011)
- Stubgen: Split @abstractproperty into @abstractmethod and @property (Xuanda
Yang, PR 8066)
- Stubgen: Give a better error message when using a .pyd file as target
(Xuanda Yang, PR 8063)
- Update stubgen documentation (PR 8031)
- Typeshed Updates
- Many small improvements were made to typeshed ? too many to list. Browse
the typeshed commit log here.

==== perl-Date-Manip ====
Version update (6.78 -> 6.79)

- updated to 6.79
see /usr/share/doc/packages/perl-Date-Manip/Changes

==== perl-TimeDate ====

- Extend perl-TimeDate-getdate.patch to fix another year-2020 bug
(bsc#1159990)

==== polkit-default-privs ====
Version update (13.2+20191210.15c9882 -> 13.2+20200116.0f7fd4b)

- Update to version 13.2+20200116.0f7fd4b:
* Previous submission didn't contain all necessary files (bsc#1161091)
- Update to version 13.2+20200116.3c654b5:
* flatpak: Add additional entry to whitelist to reflect added
override-parental-controls entry (bsc#1161091)
- Update to version 13.2+20200116.c29a8c3:
* whitelist new sysprof3 polkit rule org.gnome.sysprof3.profile
(bsc#1151418)

==== python-Babel ====
Version update (2.7.0 -> 2.8.0)

- update to 2.8.0
* CLDR: Upgrade to CLDR 36.0
* Messages: Don't even open files with the "ignore" extraction method
* Numbers: Fix formatting very small decimals when quantization is disabled
* Messages: Attempt to sort all messages

==== python-PyYAML ====
Version update (5.2 -> 5.3)

- update to 5.3
* Use `is` instead of equality for comparing with `None`
* fix typos and stylistic nit
* Fix up small typo
* Fix handling of __slots__
* Allow calling add_multi_constructor with None
* Add use of safe_load() function in README
* Fix reader for Unicode code points over 0xFFFF
* Enable certain unicode tests when maxunicode not > 0xffff
* Use full_load in yaml-highlight example
* Document that PyYAML is implemented with Cython
* Fix for Python 3.10
* increase size of index, line, and column fields
* remove some unused imports
* Create timezone-aware datetimes when parsed as such
* Add tests for timezone

==== python-docutils ====
Version update (0.15.2 -> 0.16)

- Update to 0.16:
- Dropped support for Python 2.6, 3.3 and 3.4
- Docutils now supports Python 2.7 and Python 3.5+ natively
(without conversion by ``2to3``).
- Keep `backslash escapes`__ in the document tree. Backslash characters in
text are be represented by NULL characters in the ``text`` attribute of
Doctree nodes and removed in the writing stage by the node's
``astext()`` method.
- Remove merged patch fix_tests_38.patch

==== python-gobject ====
Subpackages: python2-gobject python3-gobject python3-gobject-Gdk
python3-gobject-cairo

- Drop gnome-common Requires from python-gobject-common-devel
sub-package, no longer needed, nor used since 3.29.1, where the
BuildRequires was dropped, but the explicit Requires was not
removed by mistake.

==== python-hiredis ====
Version update (1.0.0 -> 1.0.1)

- Update to 1.0.1:
* Permit all allowed values of codec errors (see #86)
* BUGFIX: READEME.md has UTF-8 characters, setup.py will fail on systems
where the locale is not UTF-8. (see #89)
- Drop merged patch 0002-Fix-README.md-has-unicode.patch

==== python-hpack ====

- add healthcheck.patch to disarm too_slow healthcheck random fails

==== python-py ====
Version update (1.8.0 -> 1.8.1)

- Update to 1.8.1:
- Handle ``FileNotFoundError`` when trying to import pathlib in
``path.common`` on Python 3.4 (#207).
- ``py.path.local.samefile`` now works correctly in Python 3 on
Windows when dealing with symlinks.

==== python-pybind11 ====

- Add package version to extra devel packages added via Provides

==== python-scipy ====

- Fix pybind11 devel dependency to match real name

==== python-six ====
Version update (1.12.0 -> 1.13.0)
Subpackages: python2-six python3-six

- Pull in dbm/gdbm module from python for testing
- update to 0.13.0:
- Issue #298, pull request #299: Add `six.moves.dbm_ndbm`.
- Issue #155: Add `six.moves.collections_abc`, which aliases the `collections`
module on Python 2-3.2 and the `collections.abc` on Python 3.3 and greater.
- Pull request #304: Re-add distutils fallback in `setup.py`.
- Pull request #305: On Python 3.7, `with_metaclass` supports classes using
PEP

==== rdma-core ====
Version update (26.1 -> 27.0)
Subpackages: libefa1 libibverbs libibverbs1 libmlx4-1 libmlx5-1 librdmacm1

- Update to v27.0 (bsc#1160338)
- No release notes available
- Dropped patches merged upstream:
- bnxt_re-lib-Add-remaining-pci-ids-for-gen-P5-devices.patch
- bnxt_re-lib-Recognize-additional-5750x-device-ID-s.patch
- Add patches to support older HW (nes, cxgb3) that was dropped upstream
- Revert-Update-kernel-headers.patch
- Revert-libcxgb3-Remove-libcxgb3-from-rdma-core.patch
- Revert-libnes-Remove-libnes-from-rdma-core.patch
- Fix post scripts to work with systemd 244: udevadm has been moved
from /sbin to /usr/bin and systemd is dropping the compat links
now.
- Remove file listed twice
- Disable pyverbs build for older releases that do not have python3-Cython >=
0.25

==== rubygem-cheetah ====
Version update (0.5.1 -> 0.5.2)

- updated to version 0.5.2
see installed CHANGELOG
0.5.2 (2020-01-06)
- -----------------
* If listed in allowed_exitstatus, log exit code as Info, not as Error
(bsc#1153749)
* Added support for ruby 2.7

==== systemd ====
Version update (243 -> 244)
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1
libudev1-32bit systemd-32bit systemd-container systemd-lang systemd-logger
systemd-sysvinit udev

- Temporarily restore /sbin/{udevd,udevadm) obsolete symlinks
They're restored until YaST stop using them (see boo#1160890)
- Import commit 8254b8d9646f3e0f5f8057d1ffb5d6c20f079aaa (merge v244.1)
639dc9f4bf network: set ipv6 mtu after link-up or device mtu change
cbced49daa man: fix typo in net-naming-scheme man page
7dd04c99b0 network: tc: drop unused element
bf4b7d07ba man: fix typos (#14304)
1ba2e7a730 ipv4ll: do not reset conflict counter on restart
49806bb310 macro: avoid subtraction overflow in ALIGN_POWER2()
c4c1600689 test-network: add a test case for SendOption=
6f15b45949 network: fix segfault in parsing SendOption=
2e531b830d seccomp: real syscall numbers are >= 0
f7616ed52b network: fix copy and paste mistake
e8b53300c4 network: do not drop foreign config if interface is in initialized
state
00f05813bf seccomp: mmap test results depend on kernel/libseccomp/glibc
4de1909e61 seccomp: use per arch shmat_syscall
d83010521d seccomp: ensure rules are loaded in
seccomp_memory_deny_write_execute
2c6568221a seccomp: fix multiplexed system calls
bcf0aa02bf Fix typo (duplicate "or")
96d7083c54 network: if /sys is rw, then udev should be around
e874419902 nspawn: do not fail if udev is not running
29c9144655 Create parent directories when creating systemd-private subdirs
9cbb8b5254 network: do not return error but return UINT64_MAX if speed meter
is disabled
c08429ae33 core: swap priority can be negative
f25c0be335 networkctl: fix to show BSSID
65fd2fce59 systemctl: enhance message about kexec missing kernel
bdd0af5f81 Fixup typo in NEWS
- Manually set system-uid-max and system-gid-max to 499
It used to be detected automatically by meson but it's been broken
by the migration of login.defs from /etc to /usr/etc.
- Import commit d8f6a204858bff68b8e0e7be86b418c36087ab2e
6c5e492a65 cryptsetup: umount encrypted devices before detaching it during
shutdown
- Upgrade to v244 (commit 090da85161ceb1ba0b4c208963c7156a8fdf10c6)
See https://github.com/openSUSE/systemd/blob/SUSE/v244/NEWS for
details.
Legacy and obsolete symlinks have been finally dropped.
Dropped 0001-logind-keep-backward-compatibility-with-UserTasksMax.patch.
Users were notified about the deprecation of UserTasksMax option and
how to move to the new mechanism. The dropin replacement for
UserTasksMax is therefore no more generated but its use still
produces a warning.
Added 0001-SUSE-policy-do-not-clean-tmp-by-default.patch and
0001-Fix-run-lock-group-to-follow-openSUSE-policy.patch.
These patches were extracted from the git repo because it's not
clear where the SUSE tmpfiles specificities should be located.

==== texlive ====
Subpackages: libkpathsea6 libsynctex2

- Add source-common.patch to avoid common variable (boo#1160417)
- Ensure to have the correct version of perl-Business-ISBN
and perl-Business-ISBN-Data

==== totem ====
Subpackages: totem-lang totem-plugins

- Add totem-Fix-bracket-keys-and-backspace.patch: variable-rate:
Fix bracket keys and backspace not working in search entry.

==== vlc ====
Subpackages: libvlc5 libvlccore9 vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt
vlc-vdpau

- Port away from obsolete OpenCV C API, fixes build with OpenCV 3.4.9,
add 0001-Port-OpenCV-facedetect-example-to-C-API.patch
- Move OpenCV plugins to subpackage, as libopencv has a quite large
footprint.
- Remove __DATE__/__TIME__ workaround, current GCC respects
SOURCE_DATE_EPOCH.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages