Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200114 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Thu, 16 Jan 2020 01:01:20 +0000
  • Message-id: <157913648048.13782.5639546140734487665@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200114

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
MozillaThunderbird (68.3.1 -> 68.4.1)
NetworkManager (1.22.2 -> 1.22.4)
alsa-firmware
attica-qt5 (5.65.0 -> 5.66.0)
baloo5 (5.65.0 -> 5.66.0)
bluez-qt (5.65.0 -> 5.66.0)
breeze5-icons (5.65.0 -> 5.66.0)
cups-pk-helper
frameworkintegration (5.65.0 -> 5.66.0)
kaccounts-providers
kactivities-stats (5.65.0 -> 5.66.0)
kactivities5 (5.65.0 -> 5.66.0)
karchive (5.65.0 -> 5.66.0)
kauth (5.65.0 -> 5.66.0)
kbookmarks (5.65.0 -> 5.66.0)
kcmutils (5.65.0 -> 5.66.0)
kcodecs (5.65.0 -> 5.66.0)
kcompletion (5.65.0 -> 5.66.0)
kconfig (5.65.0 -> 5.66.0)
kconfigwidgets (5.65.0 -> 5.66.0)
kcoreaddons (5.65.0 -> 5.66.0)
kcrash (5.65.0 -> 5.66.0)
kdbusaddons (5.65.0 -> 5.66.0)
kdeclarative (5.65.0 -> 5.66.0)
kded (5.65.0 -> 5.66.0)
kdelibs4support (5.65.0 -> 5.66.0)
kdesu (5.65.0 -> 5.66.0)
kdnssd-framework (5.65.0 -> 5.66.0)
kdoctools (5.65.0 -> 5.66.0)
kemoticons (5.65.0 -> 5.66.0)
kfilemetadata5 (5.65.0 -> 5.66.0)
kglobalaccel (5.65.0 -> 5.66.0)
kguiaddons (5.65.0 -> 5.66.0)
kholidays (5.65.0 -> 5.66.0)
khtml (5.65.0 -> 5.66.0)
ki18n (5.65.0 -> 5.66.0)
kiconthemes (5.65.0 -> 5.66.0)
kidletime (5.65.0 -> 5.66.0)
kimageformats (5.65.0 -> 5.66.0)
kinit (5.65.0 -> 5.66.0)
kio (5.65.0 -> 5.66.0)
kirigami2 (5.65.0 -> 5.66.0)
kitemmodels (5.65.0 -> 5.66.0)
kitemviews (5.65.0 -> 5.66.0)
kjobwidgets (5.65.0 -> 5.66.0)
kjs (5.65.0 -> 5.66.0)
knewstuff (5.65.0 -> 5.66.0)
knotifications (5.65.0 -> 5.66.0)
knotifyconfig (5.65.0 -> 5.66.0)
kpackage (5.65.0 -> 5.66.0)
kparts (5.65.0 -> 5.66.0)
kpeople5 (5.65.0 -> 5.66.0)
kplotting (5.65.0 -> 5.66.0)
kpty (5.65.0 -> 5.66.0)
kross (5.65.0 -> 5.66.0)
krunner (5.65.0 -> 5.66.0)
kservice (5.65.0 -> 5.66.0)
ktexteditor (5.65.0 -> 5.66.0)
ktextwidgets (5.65.0 -> 5.66.0)
kunitconversion (5.65.0 -> 5.66.0)
kwallet (5.65.0 -> 5.66.0)
kwayland (5.65.0 -> 5.66.0)
kwidgetsaddons (5.65.0 -> 5.66.0)
kwindowsystem (5.65.0 -> 5.66.0)
kxmlgui (5.65.0 -> 5.66.0)
lftp (4.8.4 -> 4.9.0)
libKF5ModemManagerQt (5.65.0 -> 5.66.0)
libKF5NetworkManagerQt (5.65.0 -> 5.66.0)
libhandy (0.0.11 -> 0.0.13)
messagelib
oxygen5-icon-theme (5.65.0 -> 5.66.0)
perl-Mojolicious (8.29 -> 8.30)
perl-Template-Toolkit (3.003 -> 3.004)
pim-data-exporter
plasma-framework (5.65.0 -> 5.66.0)
plasma5-desktop
prison-qt5 (5.65.0 -> 5.66.0)
purpose (5.65.0 -> 5.66.0)
python-base
qqc2-desktop-style (5.65.0 -> 5.66.0)
rubygem-sassc
solid (5.65.0 -> 5.66.0)
sonnet (5.65.0 -> 5.66.0)
syndication (5.65.0 -> 5.66.0)
syntax-highlighting (5.65.0 -> 5.66.0)
threadweaver (5.65.0 -> 5.66.0)

=== Details ===

==== MozillaThunderbird ====
Version update (68.3.1 -> 68.4.1)
Subpackages: MozillaThunderbird-translations-common

- Mozilla Thunderbird 68.4.1
* Various improvements when setting up an account for a Microsoft
Exchange server: Now offers IMAP/SMTP if available, better
detection for Office 365 accounts; re-run configuration after
password change
Fixes:
* After changing view layout, the message display pane showed
garbled content under some circumstances
* Various theme changes to achieve "pixel perfection": Unread icon,
"no results" icon, paragraph format and font selector, background
of folder summary tooltip
* Tags were lost on messages in shared IMAP folders under some
circumstances
* Calendar: Event attendee dialog was not displayed correctly
MFSA 2020-04 (bsc#1160498, bsc#1160305)
* CVE-2019-17026 (bmo#1607443)
IonMonkey type confusion with StoreElementHole and FallibleStoreElement
* CVE-2019-17015 (bmo#1599005)
Memory corruption in parent process during new content process
initialization on Windows
* CVE-2019-17016 (bmo#1599181)
Bypass of @namespace CSS sanitization during pasting
* CVE-2019-17017 (bmo#1603055)
Type Confusion in XPCVariant.cpp
* CVE-2019-17021 (bmo#1599008)
Heap address disclosure in parent process during content process
initialization on Windows
* CVE-2019-17022 (bmo#1602843)
CSS sanitization does not escape HTML tags
* CVE-2019-17024 (bmo#1507180, bmo#1595470, bmo#1598605, bmo#1601826)
Memory safety bugs fixed in Firefox 72 and Firefox ESR 68.4
- removed obsolete patch mozilla-bmo1511604.patch
- added mozilla-bmo1602730.patch to fix LE<->BE issues in the
platform (bmo#1602730)

==== NetworkManager ====
Version update (1.22.2 -> 1.22.4)
Subpackages: NetworkManager-lang libnm0 typelib-1_0-NM-1_0

- Update to version 1.22.4:
+ Fix behavior of internal DHCP client when the server sends a
NAK.
+ Support 31-bit prefixes on IPv4 point-to-point links according
to RFC 3021.
+ Fix memory leak parsing RequestScan D-Bus method arguments.
- Fix 'nfs' dispatcher script
It was checking for an enabled unit 'nfs.service' - which does not
exist (anymore?). Switched to a check for an enabled unit
'nfs-client.target'

==== alsa-firmware ====

- Comment out superfluous buildreq automake
- Run fdupes for reducing the duplications
- Remove conflicting CA0132 files against kernel-firmware
- Add supplements for the automatic installation
- Install license-related files into licensesdir
- Drop the support for old distros (<1200), drop old udev rules

==== attica-qt5 ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Attica5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* [Attica] Port QRegExp to QRegularExpression
* qrand is deprecated. Port to QRandomGenerator
* Don't use a verified nullptr as a data source
* Support multiple children elements in comment elements
* Update the obsolete projects.kde.org URL
* Set a proper agent string for Attica requests

==== baloo5 ====
Version update (5.65.0 -> 5.66.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* QAtomicInteger::loadRelaxed() and storeRelaxed() are available since Qt 5.14
* Delete icon
* Port to QRandomGenerator
* Correctly report if baloo_file is unavailable
* Port away from Qt 5.14 deprecated QList methods
* Check cursor_open return value
* Initialise QML monitor values
* Update the obsolete projects.kde.org URL
* Move URL parsing methods from kioslave to query object

==== bluez-qt ====
Version update (5.65.0 -> 5.66.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port QRegExp to QRegularExpression
* Add Battery1 interface
* Update the obsolete projects.kde.org URL

==== breeze5-icons ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Change XHTML icon to be a purple HTML icon
* Merge headphones and zigzag in the center
* Add application/x-audacity-project icon
* Add 32px preferences-system
* Port endl to "\n" flush at the end + use const'ref in loop
* Add application/vnd.apple.pkpass icon (kde#397987)
* icon for ktimetracker using the PNG in the app repo, to be replaced with
real breeze SVG
* add kipi icon, needs redone as a breeze theme svg [or just kill off kipi]
* Update the obsolete projects.kde.org URL

==== cups-pk-helper ====
Subpackages: cups-pk-helper-lang

- No longer recommend cups-pk-helper-lang: the lang package has
relevant supplements which pulls it in whenever needed.
- Move /usr/share/locale/en from the -lang package to the main
package: English is installed on all systems. This avoids
cups-pk-helper-lang being triggered for installation on
english-only systems.
- Modernize spec.

==== frameworkintegration ====
Version update (5.65.0 -> 5.66.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL
* We don't need xcb anymore
* Remove ColorSchemeFilter from KStyle

==== kaccounts-providers ====
Subpackages: kaccounts-providers-lang

- Add upstream patch to fix Google accounts:
* 0001-Google-provider-limit-requested-OAuth-scopes.patch

==== kactivities-stats ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port to QRandomGenerator
* Update the obsolete projects.kde.org URL

==== kactivities5 ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== karchive ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port to QRandomGenerator (qrand was deprecated in qt5.15)
* Update the obsolete projects.kde.org URL

==== kauth ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang libKF5AuthCore5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port QRegExp to QRegularExpression
* Port to QRandomGenerator
* Update the obsolete projects.kde.org URL

==== kbookmarks ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl in qDebug
* Update the obsolete projects.kde.org URL

==== kcmutils ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Deprecate KCModuleContainer
* Remove endl. qCritical/qDebug already adds a endl.
* Port from KDE::icon to KIconUtils for getting icon overlays
* Update the obsolete projects.kde.org URL

==== kcodecs ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* [KEmailAddress] Remove redundant bool var
* Port QRegExp to QRegularExpression
* Fix invalid cast to enum by changing the type to int rather than enum
* Fix Invalid-enum-value assignment
* Update the obsolete projects.kde.org URL

==== kcompletion ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Deprecate KPixmapProvider
* Update the obsolete projects.kde.org URL
* [KHistoryComboBox] Add method to set an icon provider

==== kconfig ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl at the end of qdebug
* Port deprecated methods
* kconfig EBN transport protocol cleanup
* update @since
* Expose getter to KConfigWatcher's config
* Fix writeFlags with KConfigCompilerSignallingItem
* Update the obsolete projects.kde.org URL
* Fix URL: use the stable redirect commits.kde.org
* Add a comment pointing to the history of Cut and Delete sharing a shortcut
* Fix Python bindings compilation

==== kconfigwidgets ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL
* Rename "Configure Shortcuts" to "Configure Keyboard Shortcuts" (kde#39488)

==== kcoreaddons ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Too many changes since 5.65.0, only listing bugfixes:
* [KProcessList] Optimize KProcessList::processInfo (kde#410945)
* Fix KAutoSaveFile when having a long path (kde#412519)

==== kcrash ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kdbusaddons ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kdeclarative ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* [KeySequenceHelper] Grab actual window when embedded
* Update the obsolete projects.kde.org URL
* Add optional subtitle to grid delegate
* document colorbutton with an example
* [QImageItem/QPixmapItem] Don't lose precision during calculation
* kdeclarative EBN spelling cleanup

==== kded ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kded-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kdelibs4support ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kdesu ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl. qCritical/qDebug already adds a endl.
* Port QRegExp to QRegularExpression
* Update the obsolete projects.kde.org URL

==== kdnssd-framework ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kdoctools ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port endl to "\n", endl in qt5.15 is namespaced.
* [KDocTools] Port QRegExp to QRegularExpression
* Minor update of Ukrainian translation
* Update the obsolete projects.kde.org URL

==== kemoticons ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port endl to "\n" as QTextStream is flushed at the end.
* Update the obsolete projects.kde.org URL

==== kfilemetadata5 ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kfilemetadata5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* In qt5.15 QHash::insertMulti is deprecated now we need to use QMultiHash
* Port QRegExp to QRegularExpression
* partial fix for accentuated characters in file name on Windows
* Port deprecated QSet::toList method
* Update the obsolete projects.kde.org URL
* Remove unrequired private declarations for taglibextractor
* partial solution to accept accentuated characters on windows
* xattr: fix crash on dangling symlinks (kde#414227)

==== kglobalaccel ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Make it compile against qt5.15
* insertMulti is already a QMultiHash.
* Update the obsolete projects.kde.org URL

==== kguiaddons ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kholidays ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* kholidays EBN transport protocol cleanup

==== khtml ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port some deprecated methods

==== ki18n ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* autotests: add test for salvageMarkup() function, using a broken tag
* autotests: add more tests in KLocalizedStringTest::correctSubs()
* [Kuit] Use const and QList::at() as need be
* [Kuit] Port QRegExp to QRegularExpression, second pass
* [KuitFormatterPrivate] Start porting QRegExp to QRegularExpression
* Update the obsolete projects.kde.org URL

==== kiconthemes ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Set breeze as default theme when reading from configuration file
* Qt 5.12 is now required so remove the ifdef
* Deprecate the top-level IconSize() function
* Update the obsolete projects.kde.org URL
* Fix centering scaled icons on high dpi pixmaps

==== kidletime ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kimageformats ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kimageformats-eps

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL
* pic: Fix Invalid-enum-value undefined behaviour

==== kinit ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kinit-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kio ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kio-core kio-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Too many changes since 5.65.0, only listing bugfixes:
* Adding support for mounting KIOFuse URLs for applications that don't use
KIO (kde#398216)
* [KUrlNavigator] Add RPM support to krarc: (kde#408082)
* KFilePlaceEditDialog: fix crash when editing the Trash place (kde#415676)

==== kirigami2 ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Too many changes since 5.65.0, only listing bugfixes:
* ActionToolBar: Only show the overflow button if there are visible items in
the menu (kde#415412)
* reintroduce the collapse button (kde#415074)

==== kitemmodels ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port deprecated QSet::toList method
* Update the obsolete projects.kde.org URL
* Add KColumnHeadersProxyModel
* Fix build of python bindings for kcolumnheadersmodel

==== kitemviews ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* QHash::unite is deprecated in qt5.15. We need to port to QMultiHash.
* Remove unused variable
* Update the obsolete projects.kde.org URL

==== kjobwidgets ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kjs ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL
* Added tests for Math.exp()
* Added tests for various assignment operators.
* Test special cases of multiplicate operators (*, / and %).

==== knewstuff ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl. qCritical/qDebug already adds a endl.
* QHash::insertMulti is deprecated
* Update the obsolete projects.kde.org URL
* Ensure the dialog title is correct with an uninitialised engine
* Don't show the info icon on the big preview delegate (kde#413436)
* Support archive installs with adoption commands (kde#407687)
* Send along the config name with requests

==== knotifications ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port endl to "\n" (QFile flushs data when deleted)
* Update the obsolete projects.kde.org URL

==== knotifyconfig ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* KNotifyConfig: port QRegExp to QRegularExpression
* Update the obsolete projects.kde.org URL

==== kpackage ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kpackage-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port endl to "\n"
* Port QRegExp to QRegularExpression
* Update the obsolete projects.kde.org URL

==== kparts ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port QRegExp to QRegularExpression
* Remove endl. qCritical/qDebug already add a endl.
* Update the obsolete projects.kde.org URL

==== kpeople5 ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kpeople5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* QMultiHash::insertMulti is deprecated
* Update the obsolete projects.kde.org URL
* Seems like qt5_wrap_cpp will work better if we pass the header file
* Expose enum to the metaobject compiler

==== kplotting ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kpty ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kross ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kross-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== krunner ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kservice ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kservice-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl in qDebug, it already adds "\n" + port to Qt::endl when using
qt5.15
* Deprecate KServiceTypeProfile
* Update the obsolete projects.kde.org URL
* autotests: remove <QtTest> which includes all of <QtCore>
* autotests: make ksycoca_xdgdirstest work without /etc/xdg/menus
* Fix kmimeassociationstest in case of symlinks in the paths
* Remove dead code in KCTimeFactory and KBuildSycoca
* Port KPluginTrader away from Q_GLOBAL_STATIC.

==== ktexteditor ====
Version update (5.65.0 -> 5.66.0)
Subpackages: ktexteditor-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Fix warning about unused variable and minor optimization
* Add "line-count" property to the ConfigInterface
* Avoid unwanted horizontal scrolling (kde#415096)
* Port deprecated QSet::toList() method
* Update the obsolete projects.kde.org URL

==== ktextwidgets ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl. qCritical/qDebug already add a endl.
* Update the obsolete projects.kde.org URL

==== kunitconversion ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== kwallet ====
Version update (5.65.0 -> 5.66.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Replace endl by "\n" + flush when it's necessary
* KWallet: Port QRegExp to QRegularExpression
* Update the obsolete projects.kde.org URL

==== kwayland ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* [plasmashell] Update docs for panelTakesFocus to make it generic
* [plasmashell] Add signal for panelTakesFocus changing
* Update the obsolete projects.kde.org URL

==== kwidgetsaddons ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Port QRegExp to QRegularExpression
* Port deprecated toList() method
* Update the obsolete projects.kde.org URL

==== kwindowsystem ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* In qt5.15 endl is namespaced. But qCCritical already adds "\n"
at the end, so we can remove it.
* qrand is deprecated in qt5.15.
* Update the obsolete projects.kde.org URL

==== kxmlgui ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl. qCritical/qDebug already add a endl.
* Port QSet::toList deprecated method
* Update the obsolete projects.kde.org URL
* KActionCollection: provide a changed() signal as a replacement for removed()
* Adjust keyboard shortcut configuration window's title

==== lftp ====
Version update (4.8.4 -> 4.9.0)

- Update to version 4.9.0
* ftp: add support for CEPR command.
* ftp: enabled TLS by default.
* ftp: fixed OPTS MLST format.
* ftps: apply rfc1738 rules.
* ftp: stop sending ALLO commands by default.
* http: fixed redirection to absolute path.
* http: improved index parsing performance.
* http: revert to original URL when temporary redirects led to an error.
* mirror --no-empty-dirs: exclude empty dirs so that chmod is not done on
them.
* net: disable inet6 if there is no public ipv6 address.
* net: lowered reconnect intervals.
* sftp, fish: fixed yes/no/[fingerprint] and passphrase recognition.
* sftp: fixed a bug with truncated files when packets are reordered.
* torrent: fixed a coredump when all dht ports are busy.
* fixed file list sorting when some file names start with tilde.
* fixed retry counting when a site has multiple addresses.
* fixed "version" command for certain openssl versions.
- Drop relax-ssh-password-prompt-recognition.patch, fixed upstream.

==== libKF5ModemManagerQt ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== libKF5NetworkManagerQt ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Manager: add support for AddAndActivateConnection2
* cmake: Consider NM headers as system includes
* Sync Utils::securityIsValid with NetworkManager (kde#415670)
* Update the obsolete projects.kde.org URL
- Drop 0001-Sync-Utils-securityIsValid-with-NetworkManager.patch
(merged upstream)

==== libhandy ====
Version update (0.0.11 -> 0.0.13)
Subpackages: libhandy-0_0-0 typelib-1_0-Handy-0_0

- Update to version 0.0.13:
+ Various build and bug fixes.

==== messagelib ====
Subpackages: messagelib-lang

- Add upstream patch to fix display of large messages (kde#387061)
* 0001-Fix-Bug-387061-Large-messages-don-t-display-in-the-v.patch
* 0002-Initialize-variable.patch

==== oxygen5-icon-theme ====
Version update (5.65.0 -> 5.66.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL

==== perl-Mojolicious ====
Version update (8.29 -> 8.30)

- updated to 8.30
see /usr/share/doc/packages/perl-Mojolicious/Changes
8.30 2020-01-07
- Switch from Future::AsyncAwait::Frozen to Future::AsyncAwait for async/await
support.

==== perl-Template-Toolkit ====
Version update (3.003 -> 3.004)

- updated to 3.004
see /usr/share/doc/packages/perl-Template-Toolkit/Changes

==== pim-data-exporter ====
Subpackages: pim-data-exporter-lang

- Drop the unneeded python2 requirement

==== plasma-framework ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Too many changes since 5.65.0, only listing bugfixes:
* Sync QWindow flag WindowDoesNotAcceptFocus to wayland plasmashell interface
(kde#415124)
* [RFC] Fix Display Configuration icon margins (kde#400087)
* [PC3 ToolButton] Have the label take into account complementary color
schemes (kde#414929)
* Added background colors to active and inactive icon view (kde#370465)
- Drop calendar-Check-out-of-bounds-array-access.patch. Merged upstream

==== plasma5-desktop ====
Subpackages: plasma5-desktop-lang

- Add patch to fix the activity list in the KCM (kde#416158):
* 0001-Revert-KCMs-Activities-Fix-jagginess-for-activities-.patch

==== prison-qt5 ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* endl is namespaced in qt5.15
* Update the obsolete projects.kde.org URL

==== purpose ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Use standard ECMQMLModules

==== python-base ====
Subpackages: libpython2_7-1_0 python-xml

- libnsl is required only on more recent SLEs and openSUSE, older
glibc supported NIS on its own.

==== qqc2-desktop-style ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* [ToolTip] Round position
* Update size hint when font changes

==== rubygem-sassc ====

- Add reproducible.patch to sort file list (boo#1041090)
- Compile with --extconf-opts=--disable-march-tune-native (boo#1100677)

==== solid ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Remove endl. qCritical/qDebug already adds a endl.
* Clean up unnecessary code
* Display first / in mounted storage access description
* Port QSet::toList deprecated method
* Remove unused header from QtWidgets
* Fix build on BSD
* Port solid from Qt5::Widgets to Qt5::Gui
* Ensure mounted nfs filesystems matches their fstab declared counterpart
(kde#406242)
* Update the obsolete projects.kde.org URL

==== sonnet ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Fix typos in API docs
* Done is deprecated + missing using new signal
* Remove unused variable + const'ify
* Update the obsolete projects.kde.org URL

==== syndication ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- No code change since 5.65.0

==== syntax-highlighting ====
Version update (5.65.0 -> 5.66.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* LaTeX: fix brackets in some commands (kde#415384)
* TypeScript: add "bigint" primitive type
* Python: improve numbers, add octals, binaries and "breakpoint" keyword
(kde#414996)
* fix linking with static qt
* SELinux: add "glblub" keyword and update permissions list
* Several enhancements to gitolite syntax definition.

==== threadweaver ====
Version update (5.65.0 -> 5.66.0)

- Update to 5.66.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.66.0.php
- Changes since 5.65.0:
* Update the obsolete projects.kde.org URL


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages