Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200112 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Tue, 14 Jan 2020 15:02:02 +0000
  • Message-id: <157901412241.3460.8770197211153542229@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200112

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.9.13 -> 7.0.9.14)
LibVNCServer
analitza (19.12.0 -> 19.12.1)
blinken (19.12.0 -> 19.12.1)
bovo (19.12.0 -> 19.12.1)
cervisia (19.12.0 -> 19.12.1)
desktop-data-openSUSE (15.1.20191124 -> 15.2.20200107)
espeak-ng
ffmpeg-4
ffmpegthumbs (19.12.0 -> 19.12.1)
frogr (1.5 -> 1.6)
gamin
glusterfs (7.0 -> 7.1)
groff
groff-full
gstreamer
gstreamer-plugins-bad
gstreamer-plugins-base
gstreamer-plugins-good
gstreamer-plugins-ugly
hplip (3.19.6 -> 3.19.12)
iproute2
juk (19.12.0 -> 19.12.1)
k3b (19.12.0 -> 19.12.1)
kalgebra (19.12.0 -> 19.12.1)
kalzium (19.12.0 -> 19.12.1)
kanagram (19.12.0 -> 19.12.1)
kapptemplate (19.12.0 -> 19.12.1)
katomic (19.12.0 -> 19.12.1)
kblackbox (19.12.0 -> 19.12.1)
kblocks (19.12.0 -> 19.12.1)
kbounce (19.12.0 -> 19.12.1)
kbreakout (19.12.0 -> 19.12.1)
kbruch (19.12.0 -> 19.12.1)
kcachegrind (19.12.0 -> 19.12.1)
kcron (19.12.0 -> 19.12.1)
kde-print-manager (19.12.0 -> 19.12.1)
kdeedu-data (19.12.0 -> 19.12.1)
kdegraphics-thumbnailers (19.12.0 -> 19.12.1)
kdenetwork-filesharing (19.12.0 -> 19.12.1)
kdf (19.12.0 -> 19.12.1)
kdiamond (19.12.0 -> 19.12.1)
kgeography (19.12.0 -> 19.12.1)
kget (19.12.0 -> 19.12.1)
kgoldrunner (19.12.0 -> 19.12.1)
khangman (19.12.0 -> 19.12.1)
kig (19.12.0 -> 19.12.1)
kimagemapeditor (19.12.0 -> 19.12.1)
kipi-plugins (19.12.0 -> 19.12.1)
kiriki (19.12.0 -> 19.12.1)
kiten (19.12.0 -> 19.12.1)
kjumpingcube (19.12.0 -> 19.12.1)
klines (19.12.0 -> 19.12.1)
kmahjongg (19.12.0 -> 19.12.1)
kmines (19.12.0 -> 19.12.1)
kmouth (19.12.0 -> 19.12.1)
kmplot (19.12.0 -> 19.12.1)
knavalbattle (19.12.0 -> 19.12.1)
knetwalk (19.12.0 -> 19.12.1)
kolf (19.12.0 -> 19.12.1)
kollision (19.12.0 -> 19.12.1)
kolourpaint (19.12.0 -> 19.12.1)
konquest (19.12.0 -> 19.12.1)
kpat (19.12.0 -> 19.12.1)
kqtquickcharts (19.12.0 -> 19.12.1)
kreversi (19.12.0 -> 19.12.1)
kshisen (19.12.0 -> 19.12.1)
ksirk (19.12.0 -> 19.12.1)
kspaceduel (19.12.0 -> 19.12.1)
ksquares (19.12.0 -> 19.12.1)
ksudoku (19.12.0 -> 19.12.1)
ksystemlog (19.12.0 -> 19.12.1)
kteatime (19.12.0 -> 19.12.1)
ktimer (19.12.0 -> 19.12.1)
ktouch (19.12.0 -> 19.12.1)
ktuberling (19.12.0 -> 19.12.1)
kturtle (19.12.0 -> 19.12.1)
kubrick (19.12.0 -> 19.12.1)
kwordquiz (19.12.0 -> 19.12.1)
libkdegames (19.12.0 -> 19.12.1)
libkeduvocdocument (19.12.0 -> 19.12.1)
libkmahjongg (19.12.0 -> 19.12.1)
libosinfo
libuv
libvpx (1.8.1 -> 1.8.2)
logrotate (3.15.0 -> 3.15.1)
lokalize (19.12.0 -> 19.12.1)
lskat (19.12.0 -> 19.12.1)
man-pages
mbox-importer (19.12.0 -> 19.12.1)
openldap2
parley (19.12.0 -> 19.12.1)
pcsc-lite (1.8.25 -> 1.8.26)
perl-Convert-ASN1
pim-data-exporter (19.12.0 -> 19.12.1)
pim-sieve-editor (19.12.0 -> 19.12.1)
re2 (20191201 -> 20200101)
step (19.12.0 -> 19.12.1)
sweeper (19.12.0 -> 19.12.1)
tftp
tigervnc
umbrello (19.12.0 -> 19.12.1)
v4l-utils (1.14.2 -> 1.18.0)
virglrenderer (0.8.0 -> 0.8.1)
xf86-video-ati
xfce4-branding-openSUSE (4.14+20200110 -> 4.14+20200112)
xfce4-session (4.14.0 -> 4.14.1)
xfce4-settings (4.14.1 -> 4.14.2)
yakuake (19.12.0 -> 19.12.1)

=== Details ===

==== ImageMagick ====
Version update (7.0.9.13 -> 7.0.9.14)
Subpackages: ImageMagick-config-7-SUSE ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI7 libMagickWand-7_Q16HDRI7 perl-PerlMagick

- version update to 7.0.9.14
* Support extended Fx assignment operators (e.g. *=, /=, ++, --, etc.)
* Support Fx for() iterator.
* Optimize Fx performance.
* Ensure circle.rb renders the same for IMv6 and IMv7

==== LibVNCServer ====

- Add patches to fix crash on shutdown:
* avoid-pthread_join-if-backgroundLoop-is-FALSE.patch
* fix-crash-on-shutdown.patch

==== analitza ====
Version update (19.12.0 -> 19.12.1)
Subpackages: analitza-lang libAnalitza5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update the obsolete projects.kde.org URL

==== blinken ====
Version update (19.12.0 -> 19.12.1)
Subpackages: blinken-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== bovo ====
Version update (19.12.0 -> 19.12.1)
Subpackages: bovo-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== cervisia ====
Version update (19.12.0 -> 19.12.1)
Subpackages: cervisia-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== desktop-data-openSUSE ====
Version update (15.1.20191124 -> 15.2.20200107)

- Update to version 15.2.20200107:
* Fix csh (boo#1158422)

==== espeak-ng ====
Subpackages: libespeak-ng1

- Added espeak-ng-1.50-fix_gcc10_no_common.patch and
espeak-ng-1.50-fix_gcc10_no_common_2.patch (fix boo#1160389)

==== ffmpeg-4 ====
Subpackages: libavcodec58 libavdevice58 libavfilter7 libavformat58
libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5

- Add 929e5159bc13da374b83f5627879c607acce180b.patch to fix
bad ID3v2 tag length.

==== ffmpegthumbs ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ffmpegthumbs-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== frogr ====
Version update (1.5 -> 1.6)
Subpackages: frogr-lang

- Update to version 1.6:
+ Remove deprecated use of GTimeVal.
+ Updated translations.
- Do not recommend -lang package: it is supplemented already based
on requested locales.

==== gamin ====

- Disable python bindings (python2-only):
+ Drop python-devel BuildRequires.
+ Drop gamin-fix_python_main.patch: no longer needed.
+ No longer build python-gamin sub-package.

==== glusterfs ====
Version update (7.0 -> 7.1)
Subpackages: libgfapi0 libgfrpc0 libgfxdr0 libglusterfs0

- Update to release 7.1
* Fix rebalance causing IO Error - File descriptor in bad state
* Fix geo-replication sessions going faulty
* Fix memory leak in glusterfsd process
* Fix GlusterFS brick process crash
- Add nocommon.patch [boo#1160392]

==== groff ====

- don't recommend groff-full as that would pull in X etc by default.
Instead use packageand on groff and ghostscript-library to only install
groff-full when other deps are already there.

==== groff-full ====
Subpackages: gxditview

- don't recommend groff-full as that would pull in X etc by default.
Instead use packageand on groff and ghostscript-library to only install
groff-full when other deps are already there.

==== gstreamer ====
Subpackages: gstreamer-lang gstreamer-utils libgstreamer-1_0-0
typelib-1_0-Gst-1_0

- Add gstreamer-revert-encforce-elements.patch: Revert enforce
elements, patches from upstream stable branch.

==== gstreamer-plugins-bad ====
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0
libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0

- Add upstream bug fix patches:
+ gst-bad-interlace-fixes.patch: Fix various issues with
interlace.
+ gst-bad-autoconvert-fix-lock-less.patch: autoconvert: Fix
lock-less exchange or free condition.

==== gstreamer-plugins-base ====
Subpackages: gstreamer-plugins-base-lang libgstallocators-1_0-0 libgstapp-1_0-0
libgstaudio-1_0-0 libgstfft-1_0-0 libgstgl-1_0-0 libgstpbutils-1_0-0
libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0
libgsttag-1_0-0 libgstvideo-1_0-0 typelib-1_0-GstAudio-1_0
typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

- Add upstream bugfix patches:
+ gst-base-playbin-handle-error.patch: playbin: Handle error
message with redirection indication.
+ gst-base-audioencoder-fix-leak.patch: audioencoder: fix segment
event leak.
+ gst-base-fft-update-kiss-version.patch: fft: Update our kiss
fft version.

==== gstreamer-plugins-good ====
Subpackages: gstreamer-plugins-good-extra gstreamer-plugins-good-gtk
gstreamer-plugins-good-jack gstreamer-plugins-good-lang
gstreamer-plugins-good-qtqml

- Add upstream bugfix patches:
+ gst-good-qtdemux-Specify-REDIRECT-info.patch: qtdemux: Specify
REDIRECT information in error message.
+ gst-good-rtpjpegdepay-outputs-framed-jpeg.patch: rtpjpegdepay:
outputs framed jpeg.

==== gstreamer-plugins-ugly ====
Subpackages: gstreamer-plugins-ugly-lang

- Add gst-ugly-x264enc-fixes.patch: x264enc: corrected em_data
value. Patch from upstream git.
- Drop no longer needed conditional libtool BuildRequires.

==== hplip ====
Version update (3.19.6 -> 3.19.12)
Subpackages: hplip-hpijs hplip-sane

- Fix crash if python3-reportlab is missing (bsc#1159240, lp#1859179)
* Added hp-sendfax-avoid-crash-if-python-reportlab-is-missin.patch
* Added recommends on python3-reportlab
- updated to 3.19.12
Rendering print jobs with cupsfilter command
Added support for the following new Printers:
* HP Color LaserJet Pro M256dn
* HP Color LaserJet Pro M255dn
* HP Color LaserJet Pro M256nw
* HP Color LaserJet Pro M255nw
* HP Color LaserJet Pro M256dw
* HP Color LaserJet Pro M255dw
* HP Color LaserJet Pro M155a
* HP Color LaserJet Pro M156a
* HP Color LaserJet Pro M155nw
* HP Color LaserJet Pro M156nw
* HP Color LaserJet Pro MFP M282nw
* HP Color LaserJet Pro MFP M284nw
* HP Color LaserJet Pro MFP M283fdn
* HP Color LaserJet Pro MFP M285fdn
* HP Color LaserJet Pro MFP M283fdw
* HP Color LaserJet Pro MFP M285fdw
* HP Color LaserJet Pro MFP M283cdw
* HP Color LaserJet Pro MFP M285cdw
* HP Color LaserJet Pro MFP M182n
* HP Color LaserJet Pro MFP M184n
* HP Color LaserJet Pro MFP M182nw
* HP Color LaserJet Pro MFP M184nw
* HP Color LaserJet Pro MFP M183fw
* HP Color LaserJet Pro MFP M185fw
- updated to 3.19.11
Added Supported for ?hp-uiscan? to scan only backside of a page
Added support for the following new Printers:
* HP Color LaserJet MFP M776dn
* HP Color LaserJet Flow MFP M776z
* HP Color LaserJet Flow MFP M776zs
* HP Color LaserJet M856dn
* HP Color LaserJet M856x
* HP Color LaserJet E85055dn
Added Job Accounting Support for the following devices:
* HP LaserJet Managed Flow MFP E77822-28-30 Printer
* HP LaserJet Managed MFP E77822-28-30 Printer
* HP LaserJet Managed Flow MFP E87640-50-60 Printer
* HP LaserJet Managed MFP E87640-50-60 Printer
* HP LaserJet Managed Flow MFP E82540-50-60 Printer
* HP LaserJet Managed MFP E82540-50-60 Printer
* HP LaserJet Managed Flow MFP E72525-30-35 Printer
* HP LaserJet Managed MFP E72525-30-35 Printer
- updated to 3.19.8
hp-uiscan will fetch the paper sizes from the device dynamically for ScanJet
devices.
hp-uiscan will prompt error message when paper jam occurs for ScanJet devices.
Added support for the following new Printers:
* HP DesignJet T1530 Postscript
* HP DesignJet T1600 Postscript Printer
* HP DesignJet T1600dr Postscript Printer
* HP DesignJet T2530 Postscript
* HP DesignJet T2600 Postscript MFP
* HP DesignJet T930 Postscript
* HP LaserJet Pro M304a
* HP LaserJet Pro M305d
* HP LaserJet Pro M305dn
* HP LaserJet Pro M305dw
* HP LaserJet Pro MFP M329dn
* HP LaserJet Pro MFP M329dw

==== iproute2 ====

- Add no-double-definitions.patch [boo#1160271]

==== juk ====
Version update (19.12.0 -> 19.12.1)
Subpackages: juk-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* PlayerManager: Unify volume slots (kde#405973)
* Save config after it is closed by the window manager (kde#359681)

==== k3b ====
Version update (19.12.0 -> 19.12.1)
Subpackages: k3b-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kalgebra ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kalgebra-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kalzium ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kalzium-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kanagram ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kanagram-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kapptemplate ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kapptemplate-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== katomic ====
Version update (19.12.0 -> 19.12.1)
Subpackages: katomic-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kblackbox ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kblackbox-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kblocks ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kblocks-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kbounce ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kbounce-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kbreakout ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kbreakout-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kbruch ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kbruch-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kcachegrind ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kcachegrind-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kcron ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kcron-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kde-print-manager ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kde-print-manager-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kdeedu-data ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kdegraphics-thumbnailers ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Prevent division by zero and force ghostscript run (kde#406463)

==== kdenetwork-filesharing ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdenetwork-filesharing-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kdf ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdf-lang kwikdisk

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kdiamond ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdiamond-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kgeography ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kgeography-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* Russia districts: Fix Kaliningrad not being shown as part of Northwestern
(kde#414857)

==== kget ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kget-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kgoldrunner ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kgoldrunner-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== khangman ====
Version update (19.12.0 -> 19.12.1)
Subpackages: khangman-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kig ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kig-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* Add Extension to Filename to Save to Kig Format
* Add a QDialogButtonBox to the Coordinate Precision Dialog (kde#414641)
* Fix crash with simple python script (kde#401512)

==== kimagemapeditor ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kimagemapeditor-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kipi-plugins ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kipi-plugins-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kiriki ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kiriki-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kiten ====
Version update (19.12.0 -> 19.12.1)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kjumpingcube ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kjumpingcube-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== klines ====
Version update (19.12.0 -> 19.12.1)
Subpackages: klines-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmahjongg ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmahjongg-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmines ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmines-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmouth ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmouth-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmplot ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmplot-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== knavalbattle ====
Version update (19.12.0 -> 19.12.1)
Subpackages: knavalbattle-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== knetwalk ====
Version update (19.12.0 -> 19.12.1)
Subpackages: knetwalk-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kolf ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kolf-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Fix stroke count being increased more than once when hitting the ball
(kde#414791)
* Remove unused function

==== kollision ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kollision-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kolourpaint ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kolourpaint-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* Fix warning about help and version already being added

==== konquest ====
Version update (19.12.0 -> 19.12.1)
Subpackages: konquest-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kpat ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kpat-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* Add oars content rating

==== kqtquickcharts ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kreversi ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kreversi-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kshisen ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kshisen-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== ksirk ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ksirk-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kspaceduel ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kspaceduel-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== ksquares ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ksquares-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== ksudoku ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ksudoku-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== ksystemlog ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ksystemlog-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kteatime ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kteatime-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== ktimer ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ktimer-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== ktouch ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ktouch-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== ktuberling ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ktuberling-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kturtle ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kturtle-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kubrick ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kubrick-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kwordquiz ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kwordquiz-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== libkdegames ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkeduvocdocument ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkmahjongg ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libosinfo ====
Subpackages: libosinfo-1_0-0 libosinfo-lang typelib-1_0-Libosinfo-1_0

- Drop ids.tar.bz2 in favor of using hwdata. (boo#1159838)

==== libuv ====

- Add fno-common-build-errs.patch which fixes gh#libuv/libuv#2603
(bsc#1160280)

==== libvpx ====
Version update (1.8.1 -> 1.8.2)

- Update to version 1.8.2:
Fixes:
- CVE-2019-2126 bsc#1160611: double free in ParseContentEncodingEntry()
- CVE-2019-9325 bsc#1160612: out-of-bounds read
- CVE-2019-9232 bsc#1160613: Fix OOB memory access on fuzzed data
- CVE-2019-9433 bsc#1160614: use-after-free in vp8_deblock()
- CVE-2019-9371 bsc#1160615: resource exhaustion after memory leak
official changelog:
* This release collects incremental improvements to many aspects of the
library.
* Upgrading:
ARCH_* defines have been removed in favor of VPX_ARCH_*.

==== logrotate ====
Version update (3.15.0 -> 3.15.1)

- Update to 3.15.1:
* use correct create mode in examples/btmp (#257)
* fix several bugs found by fuzzing (#254)
* do not abort globbing on a broken symlink (#251)
* rearrange logrotate.8 man page to improve readability (#248)
* encourage admins to use the su directive in logrotate.8 man page (#236)

==== lokalize ====
Version update (19.12.0 -> 19.12.1)
Subpackages: lokalize-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== lskat ====
Version update (19.12.0 -> 19.12.1)
Subpackages: lskat-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== man-pages ====

- do not install man7/bpf-helpers.7 as it is already part of
bpftool package
- don't use alternatives for man.7, just move it to a different directory
(boo#1160568)
- use packageand to supplement the documentation pattern instead of
unconditionally hooking on man.

==== mbox-importer ====
Version update (19.12.0 -> 19.12.1)
Subpackages: mbox-importer-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== openldap2 ====
Subpackages: libldap-2_4-2 libldap-2_4-2-32bit libldap-data openldap2-client
openldap2-devel

- added back-port patch
0013_openldap-its9124_fix_crash_with_cancel_exop.patch
to fix OpenLDAP ITS#9124

==== parley ====
Version update (19.12.0 -> 19.12.1)
Subpackages: parley-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== pcsc-lite ====
Version update (1.8.25 -> 1.8.26)
Subpackages: libpcsclite1

- Updated to version 1.8.26
* Use poll() instead of select() to allow file descriptor higher
than FD_SETSIZE
* Enable reader filtering by default
* pcsc-spy:
- Do not read output buffer after error
- Adjust code to handle autoallocated buffers
- fix year-2038 issue by using long instead of int
* Android: fix compilation
* polkit: log the error message if polkit_authority_get_sync() fails
* Exit with EXIT_SUCCESS on shutdown to please systemd
* Fix a minor memory leak

==== perl-Convert-ASN1 ====

- Update spec file

==== pim-data-exporter ====
Version update (19.12.0 -> 19.12.1)
Subpackages: pim-data-exporter-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== pim-sieve-editor ====
Version update (19.12.0 -> 19.12.1)
Subpackages: pim-sieve-editor-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== re2 ====
Version update (20191201 -> 20200101)

- Update to 2020-01-01:
* various developer visible changes

==== step ====
Version update (19.12.0 -> 19.12.1)
Subpackages: step-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== sweeper ====
Version update (19.12.0 -> 19.12.1)
Subpackages: sweeper-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== tftp ====

- Pass fcommon to cflags wrt bsc#1160297

==== tigervnc ====
Subpackages: libXvnc1 xorg-x11-Xvnc xorg-x11-Xvnc-module

- TigerVNC security fix:
0001-Make-ZlibInStream-more-robust-against-failures.patch
0002-Encapsulate-PixelBuffer-internal-details.patch
0003-Restrict-PixelBuffer-dimensions-to-safe-values.patch
0004-Add-write-protection-to-OffsetPixelBuffer.patch
0005-Handle-empty-Tight-gradient-rects.patch
0006-Add-unit-test-for-PixelFormat-sanity-checks.patch
0007-Fix-depth-sanity-test-in-PixelFormat.patch
0008-Add-sanity-checks-for-PixelFormat-shift-values.patch
0009-Remove-unused-FixedMemOutStream.patch
0010-Use-size_t-for-lengths-in-stream-objects.patch
0011-Be-defensive-about-overflows-in-stream-objects.patch
0012-Add-unit-tests-for-PixelFormat.is888-detection.patch
0013-Handle-pixel-formats-with-odd-shift-values.patch
* stack use-after-return due to incorrect usage of stack memory
in ZRLEDecoder (CVE-2019-15691, bsc#1159856)
* improper value checks in CopyRectDecode may lead to heap
buffer overflow (CVE-2019-15692, bsc#1160250)
* heap buffer overflow in TightDecoder::FilterGradient
(CVE-2019-15693, bsc#1159858)
* improper error handling in processing MemOutStream may lead
to heap buffer overflow (CVE-2019-15694, bsc#1160251
* stack buffer overflow, which could be triggered from
CMsgReader::readSetCurso (CVE-2019-15695, bsc#1159860)

==== umbrello ====
Version update (19.12.0 -> 19.12.1)
Subpackages: umbrello-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Remove obsolete code
* Fix 'No undo support for adding connected widgets' (kde#415888)
* Fix 'Different name when adding connected states compared to adding via the
toolbar' (kde#415890)
* Fix 'Adding connected widgets cannot be cancelled' (kde#415889)
* Limit building local KDev::Tests library for KF5 only when kdevplatform
library has been found
* Library KDev::Tests: remove Qt5::Tests dependencies (kde#415849)
* Embed KDev::Tests library to not depend on kdevplatform for KF5 builds
* Fix 'The initial cursor position in the properties dialog of a state should
be set to the name field' (kde#415784)
* Fix 'Adding a connected state should allow entering of a state name'
(kde#415779)

==== v4l-utils ====
Version update (1.14.2 -> 1.18.0)
Subpackages: libv4l libv4l1-0 libv4l2-0 libv4lconvert0

- Refresh patch sysmacros.patch
- Update to 1.18.0:
* Various fixes all around

==== virglrenderer ====
Version update (0.8.0 -> 0.8.1)

- Update package to 0.8.1
Requires very recent libepoxy, which is currently only available
in Factory. Accordingly also switch to meson build, which also
excludes older releases.
Other highlights include:
+ support emulating planar image sampling
+ Add all formats to VIRGL_FORMAT that are referenced in Gallium
+ deprecation of the autotools build system
+ miscellaneous bug and performance fixes
+ drop the following patches, which are included in this release:
0001-5d03711-vrend-Keep-the-max-texture-sizes-in-the-vrend_state.patch
0002-0d9a2c8-vrend-Check-resource-creation-more-thoroughly.patch
0003-24f67de-vrend-check-info-formats-in-blits.patch
0004-cbc8d8b-vrend-check-transfer-bounds-for-negative-values-too-.patch
0005-2abeb18-vrend-check-that-the-transfer-iov-holds-enough-data-.patch
0006-164d758-vrend-Add-an-assert-for-allocating-the-intermediate-.patch

==== xf86-video-ati ====

- u_fno-common.patch
* fix build with gcc's -fno-common option (boo#1160422)

==== xfce4-branding-openSUSE ====
Version update (4.14+20200110 -> 4.14+20200112)
Subpackages: exo-branding-openSUSE libgarcon-branding-openSUSE
libxfce4ui-branding-openSUSE openSUSE-xfce-icon-theme
thunar-volman-branding-openSUSE xfce4-notifyd-branding-openSUSE
xfce4-panel-branding-openSUSE xfce4-power-manager-branding-openSUSE
xfce4-session-branding-openSUSE xfce4-settings-branding-openSUSE
xfdesktop-branding-openSUSE xfwm4-branding-openSUSE

- Update to version 4.14+20200112:
* set exo applications for mimetypes (boo#1160683)

==== xfce4-session ====
Version update (4.14.0 -> 4.14.1)
Subpackages: xfce4-session-lang

- Update to version 4.14.1
* Fix session crash at logout (bxo#16105)
* settings: Don't make 'saved sessions' tab reorderable
* Translation Updates

==== xfce4-settings ====
Version update (4.14.1 -> 4.14.2)
Subpackages: xfce4-settings-lang

- Update to version 4.14.2
* display: Fix icon name for primary indicator
* display: Initialize crtc->scalex/y (bxo#15971)
* appearance: Only show themes that support Gtk3 (bxo#15849)
* color: Fix crash in add-profiles dialog (bxo#15876)
* Translation Updates

==== yakuake ====
Version update (19.12.0 -> 19.12.1)
Subpackages: yakuake-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages