Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200111 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Mon, 13 Jan 2020 15:01:29 +0000
  • Message-id: <157892768910.27329.16830226914915053253@go-agent-stagingbot-4>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200111

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
MozillaFirefox (71.0 -> 72.0.1)
akonadi-calendar (19.12.0 -> 19.12.1)
akonadi-calendar-tools (19.12.0 -> 19.12.1)
akonadi-contact (19.12.0 -> 19.12.1)
akonadi-import-wizard (19.12.0 -> 19.12.1)
akonadi-mime (19.12.0 -> 19.12.1)
akonadi-notes (19.12.0 -> 19.12.1)
akonadi-search (19.12.0 -> 19.12.1)
akonadi-server (19.12.0 -> 19.12.1)
akregator (19.12.0 -> 19.12.1)
ark (19.12.0 -> 19.12.1)
baloo5-widgets (19.12.0 -> 19.12.1)
bind (9.14.8 -> 9.14.9)
bluedevil5 (5.17.4 -> 5.17.5)
breeze (5.17.4 -> 5.17.5)
breeze-gtk (5.17.4 -> 5.17.5)
calendarsupport (19.12.0 -> 19.12.1)
curl (7.67.0 -> 7.68.0)
discover (5.17.4 -> 5.17.5)
dolphin (19.12.0 -> 19.12.1)
dragonplayer (19.12.0 -> 19.12.1)
drkonqi5 (5.17.4 -> 5.17.5)
eventviews (19.12.0 -> 19.12.1)
grantleetheme (19.12.0 -> 19.12.1)
gwenview5 (19.12.0 -> 19.12.1)
incidenceeditor (19.12.0 -> 19.12.1)
kaccounts-integration (19.12.0 -> 19.12.1)
kaccounts-providers (19.12.0 -> 19.12.1)
kactivitymanagerd (5.17.4 -> 5.17.5)
kaddressbook (19.12.0 -> 19.12.1)
kalarmcal (19.12.0 -> 19.12.1)
kamera (19.12.0 -> 19.12.1)
kate (19.12.0 -> 19.12.1)
kcalc (19.12.0 -> 19.12.1)
kcalutils (19.12.0 -> 19.12.1)
kcharselect (19.12.0 -> 19.12.1)
kcm_sddm (5.17.4 -> 5.17.5)
kcolorchooser (19.12.0 -> 19.12.1)
kdav (19.12.0 -> 19.12.1)
kde-cli-tools5 (5.17.4 -> 5.17.5)
kde-gtk-config5 (5.17.4 -> 5.17.5)
kde-user-manager (5.17.4 -> 5.17.5)
kdepim-addons (19.12.0 -> 19.12.1)
kdepim-apps-libs (19.12.0 -> 19.12.1)
kdepim-runtime (19.12.0 -> 19.12.1)
kdialog (19.12.0 -> 19.12.1)
kgamma5 (5.17.4 -> 5.17.5)
khelpcenter5 (19.12.0 -> 19.12.1)
khotkeys5 (5.17.4 -> 5.17.5)
kidentitymanagement (19.12.0 -> 19.12.1)
kimap (19.12.0 -> 19.12.1)
kinfocenter5 (5.17.4 -> 5.17.5)
kio-extras5 (19.12.0 -> 19.12.1)
kio_audiocd (19.12.0 -> 19.12.1)
kitinerary (19.12.0 -> 19.12.1)
kldap (19.12.0 -> 19.12.1)
kleopatra (19.12.0 -> 19.12.1)
kmag (19.12.0 -> 19.12.1)
kmail (19.12.0 -> 19.12.1)
kmail-account-wizard (19.12.0 -> 19.12.1)
kmailtransport (19.12.0 -> 19.12.1)
kmbox (19.12.0 -> 19.12.1)
kmenuedit5 (5.17.4 -> 5.17.5)
kmime (19.12.0 -> 19.12.1)
kmousetool (19.12.0 -> 19.12.1)
knotes (19.12.0 -> 19.12.1)
kompare (19.12.0 -> 19.12.1)
konsole (19.12.0 -> 19.12.1)
kontact (19.12.0 -> 19.12.1)
kontactinterface (19.12.0 -> 19.12.1)
kopete (19.12.0 -> 19.12.1)
korganizer (19.12.0 -> 19.12.1)
kpimtextedit (19.12.0 -> 19.12.1)
kpkpass (19.12.0 -> 19.12.1)
kruler (19.12.0 -> 19.12.1)
kscreen5 (5.17.4 -> 5.17.5)
kscreenlocker (5.17.4 -> 5.17.5)
ksmtp (19.12.0 -> 19.12.1)
ksshaskpass5 (5.17.4 -> 5.17.5)
ksysguard5 (5.17.4 -> 5.17.5)
ktnef (19.12.0 -> 19.12.1)
kwalletmanager5 (19.12.0 -> 19.12.1)
kwayland-integration (5.17.4 -> 5.17.5)
kwin5 (5.17.4 -> 5.17.5)
libgravatar (19.12.0 -> 19.12.1)
libkcddb (19.12.0 -> 19.12.1)
libkcompactdisc (19.12.0 -> 19.12.1)
libkdcraw (19.12.0 -> 19.12.1)
libkdecoration2 (5.17.4 -> 5.17.5)
libkdepim (19.12.0 -> 19.12.1)
libkexiv2 (19.12.0 -> 19.12.1)
libkgapi (19.12.0 -> 19.12.1)
libkipi (19.12.0 -> 19.12.1)
libkleo (19.12.0 -> 19.12.1)
libkomparediff2 (19.12.0 -> 19.12.1)
libksane (19.12.0 -> 19.12.1)
libkscreen2 (5.17.4 -> 5.17.5)
libksieve (19.12.0 -> 19.12.1)
libksysguard5 (5.17.4 -> 5.17.5)
libreoffice (6.3.3.2 -> 6.4.0.1)
libstorage-ng (4.2.44 -> 4.2.49)
mailcommon (19.12.0 -> 19.12.1)
mailimporter (19.12.0 -> 19.12.1)
messagelib (19.12.0 -> 19.12.1)
milou5 (5.17.4 -> 5.17.5)
mobipocket (19.12.0 -> 19.12.1)
mozilla-nspr (4.23 -> 4.24)
mozilla-nss (3.47.1 -> 3.48)
musepack
okular (19.12.0 -> 19.12.1)
openconnect
oxygen5 (5.17.4 -> 5.17.5)
pimcommon (19.12.0 -> 19.12.1)
plasma-browser-integration (5.17.4 -> 5.17.5)
plasma-nm5 (5.17.4 -> 5.17.5)
plasma5-addons (5.17.4 -> 5.17.5)
plasma5-desktop (5.17.4 -> 5.17.5)
plasma5-integration (5.17.4 -> 5.17.5)
plasma5-openSUSE
plasma5-pa (5.17.4 -> 5.17.5)
plasma5-workspace (5.17.4 -> 5.17.5)
polkit-kde-agent-5 (5.17.4 -> 5.17.5)
powerdevil5 (5.17.4 -> 5.17.5)
signon-kwallet-extension (19.12.0 -> 19.12.1)
snapper (0.8.6 -> 0.8.8)
spectacle (19.12.0 -> 19.12.1)
subversion
systemsettings5 (5.17.4 -> 5.17.5)
tcsh
xen
yast2 (4.2.49 -> 4.2.53)
yast2-iscsi-client (4.2.2 -> 4.2.3)
yast2-kdump (4.2.6 -> 4.2.7)
yast2-network (4.2.42 -> 4.2.43)
yast2-nfs-client (4.2.3 -> 4.2.4)
yast2-packager (4.2.42 -> 4.2.43)
yast2-ruby-bindings (4.2.6 -> 4.2.7)
yast2-storage-ng (4.2.67 -> 4.2.69)
yast2-trans (84.87.20191229.ed49b3ce0a -> 84.87.20200104.ad092ae8df)
yast2-update (4.2.12 -> 4.2.13)
zinnia

=== Details ===

==== MozillaFirefox ====
Version update (71.0 -> 72.0.1)
Subpackages: MozillaFirefox-translations-common

- Mozilla Firefox 72.0.1
MFSA 2020-03 (bsc#1160498)
* CVE-2019-17026 (bmo#1607443)
IonMonkey type confusion with StoreElementHole and FallibleStoreElement
- Mozilla Firefox 72.0
* block fingerprinting scripts by default
* new notification pop-ups
* Picture-in-picture video
MFSA 2020-01 (bsc#1160305)
* CVE-2019-17016 (bmo#1599181)
Bypass of @namespace CSS sanitization during pasting
* CVE-2019-17017 (bmo#1603055)
Type Confusion in XPCVariant.cpp
* CVE-2019-17020 (bmo#1597645)
Content Security Policy not applied to XSL stylesheets applied
to XML documents
* CVE-2019-17022 (bmo#1602843)
CSS sanitization does not escape HTML tags
* CVE-2019-17023 (bmo#1590001) (fixed in NSS FIXME)
NSS may negotiate TLS 1.2 or below after a TLS 1.3
HelloRetryRequest had been sent
* CVE-2019-17024 (bmo#1507180,bmo#1595470,bmo#1598605,bmo#1601826)
Memory safety bugs fixed in Firefox 72 and Firefox ESR 68.4
* CVE-2019-17025 (bmo#1328295,bmo#1328300,bmo#1590447,bmo#1590965
bmo#1595692,bmo#1597321,bmo#1597481)
Memory safety bugs fixed in Firefox 72
- update create-tar.sh to skip compare-locales
- requires NSPR 4.24 and NSS 3.48
- removed usage of browser-plugins convention for NPAPI plugins
from start wrapper and changed the RPM macro to the
/usr/$LIB/mozilla/plugins location (boo#1160302)

==== akonadi-calendar ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akonadi-calendar-tools ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-calendar-tools-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akonadi-contact ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akonadi-import-wizard ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akonadi-mime ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akonadi-notes ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akonadi-search ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akonadi-server ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== akregator ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akregator-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== ark ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ark-lang libkerfuffle19

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== baloo5-widgets ====
Version update (19.12.0 -> 19.12.1)
Subpackages: baloo5-widgets-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== bind ====
Version update (9.14.8 -> 9.14.9)
Subpackages: bind-chrootenv bind-doc bind-utils libbind9-1302 libdns1311
libirs1301 libisc1310 libisccc1302 libisccfg1302 python3-bind

- Upgrade to bind-9.14.9
bug fixes and feature improvements

==== bluedevil5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: bluedevil5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== breeze ====
Version update (5.17.4 -> 5.17.5)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers libbreezecommon5-5

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* Add item spacing to size hint

==== breeze-gtk ====
Version update (5.17.4 -> 5.17.5)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== calendarsupport ====
Version update (19.12.0 -> 19.12.1)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== curl ====
Version update (7.67.0 -> 7.68.0)
Subpackages: libcurl4

- Update to 7.68.0
* Changes:
- TLS: add BearSSL vtls implementation
- XFERINFOFUNCTION: support CURL_PROGRESSFUNC_CONTINUE
- curl: add --etag-compare and --etag-save
- curl: add --parallel-immediate
- multi: add curl_multi_wakeup()
- openssl: CURLSSLOPT_NO_PARTIALCHAIN can disable partial cert chains
* Bugfixes:
- CVE-2019-15601: file: on Windows, refuse paths that start with \\
- Azure Pipelines: add several builds
- CMake: add support for building with the NSS vtls backend
- CURL-DISABLE: initial docs for the CURL_DISABLE_* defines
- CURLOPT_HEADERFUNCTION.3: Document that size is always 1
- CURLOPT_QUOTE.3: fix typos
- CURLOPT_READFUNCTION.3: fix the example
- CURLOPT_URL.3: "curl supports SMB version 1 (only)"
- CURLOPT_VERBOSE.3: see also ERRORBUFFER
- HISTORY: added cmake, HTTP/3 and parallel downloads with curl
- HISTORY: the SMB(S) support landed in 2014
- INSTALL.md: provide Android build instructions
- KNOWN_BUGS: Connection information when using TCP Fast Open
- KNOWN_BUGS: LDAP on Windows doesn't work correctly
- KNOWN_BUGS: TLS session cache doesn't work with TFO
- OPENSOCKETFUNCTION.3: correct the purpose description
- TrackMemory tests: always remove CR before LF
- altsvc: bump to h3-24
- altsvc: make the save function ignore NULL filenames
- build: Disable Visual Studio warning "conditional expression is constant"
- build: fix for CURL_DISABLE_DOH
- checksrc.bat: Add a check for vquic and vssh directories
- checksrc: repair the copyrightyear check
- cirrus-ci: enable clang sanitizers on freebsd 13
- cirrus: Drop the FreeBSD 10.4 build
- config-win32: cpu-machine-OS for Windows on ARM
- configure: avoid unportable `==' test(1) operator
- configure: enable IPv6 support without `getaddrinfo`
- configure: fix typo in help text
- conncache: CONNECT_ONLY connections assumed always in-use
- conncache: fix multi-thread use of shared connection cache
- copyrights: fix copyright year range
- create_conn: prefer multiplexing to using new connections
- curl -w: handle a blank input file correctly
- curl.h: add two missing defines for "pre ISO C" compilers
- curl/parseconfig: fix mem-leak
- curl/parseconfig: use curl_free() to free memory allocated by libcurl
- curl: cleanup multi handle on failure
- curl: fix --upload-file . hangs if delay in STDIN
- curl: fix -T globbing
- curl: improved cleanup in upload error path
- curl: make a few char pointers point to const char instead
- curl: properly free mimepost data
- curl: show better error message when no homedir is found
- curl: show error for --http3 if libcurl lacks support
- curl_setup_once: consistently use WHILE_FALSE in macros
- define: remove HAVE_ENGINE_LOAD_BUILTIN_ENGINES, not used anymore
- docs: Change 'experiemental' to 'experimental'
- docs: TLS SRP doesn't work with TLS 1.3
- docs: fix several typos
- docs: mention CURL_MAX_INPUT_LENGTH restrictions
- doh: improved both encoding and decoding
- doh: make it behave when built without proxy support
- examples/postinmemory.c: Call curl_global_cleanup always
- examples/url2file.c: corrected erroneous comment
- examples: add multi-poll.c
- global_init: undo the "intialized" bump in case of failure
- hostip: suppress compiler warning
- http_ntlm: Remove duplicate NSS initialisation
- lib: Move lib/ssh.h -> lib/vssh/ssh.h
- lib: fix compiler warnings with `CURL_DISABLE_VERBOSE_STRINGS`
- lib: fix warnings found when porting to NuttX
- lib: remove ASSIGNWITHINCONDITION exceptions, use our code style
- lib: remove erroneous +x file permission on some c files
- libssh2: add support for ECDSA and ed25519 knownhost keys
- multi.h: remove INITIAL_MAX_CONCURRENT_STREAMS from public header
- multi: free sockhash on OOM
- multi_poll: avoid busy-loop when called without easy handles attached
- ngtcp2: Support the latest update key callback type
- ngtcp2: fix thread-safety bug in error-handling
- ngtcp2: free used resources on disconnect
- ngtcp2: handle key updates as ngtcp2 master branch tells us
- ngtcp2: increase QUIC window size when data is consumed
- ngtcp2: use overflow buffer for extra HTTP/3 data
- ntlm: USE_WIN32_CRYPTO check removed to get USE_NTLM2SESSION set
- ntlm_wb: fix double-free in OOM
- openssl: Revert to less sensitivity for SYSCALL errors
- openssl: improve error message for SYSCALL during connect
- openssl: prevent recursive function calls from ctx callbacks
- openssl: retrieve reported LibreSSL version at runtime
- openssl: set X509_V_FLAG_PARTIAL_CHAIN by default
- parsedate: offer a getdate_capped() alternative
- pause: avoid updating socket if done was already called
- projects: Fix Visual Studio projects SSH builds
- projects: Fix Visual Studio wolfSSL configurations
- quiche: reject HTTP/3 headers in the wrong order
- remove_handle: clear expire timers after multi_done()
- runtests: --repeat=[num] to repeat tests
- runtests: introduce --shallow to reduce huge torture tests
- schannel: fix --tls-max for when min is --tlsv1 or default
- setopt: Fix ALPN / NPN user option when built without HTTP2
- strerror: Add Curl_winapi_strerror for Win API specific errors
- strerror: Fix an error looking up some Windows error strings
- strerror: Fix compiler warning "empty expression"
- system.h: fix for MCST lcc compiler
- test/sws: search for "Testno:" header unconditionally if no testno
- test1175: verify symbols-in-versions and libcurl-errors.3 in sync
- test1270: a basic -w redirect_url test
- test1456: remove the use of a fixed local port number
- test1558: use double slash after file:
- test1560: require IPv6 for IPv6 aware URL parsing
- tests/lib1557: fix mem-leak in OOM
- tests/lib1559: fix mem-leak in OOM
- tests/lib1591: free memory properly on OOM, in the trailers callback
- tests/unit1607: fix mem-leak in OOM
- tests/unit1609: fix mem-leak in OOM
- tests/unit1620: fix bad free in OOM
- tests: Change NTLM tests to require SSL
- tests: Fix bounce requests with truncated writes
- tests: fix build with `CURL_DISABLE_DOH`
- tests: fix permissions of ssh keys in WSL
- tests: make it possible to set executable extensions
- tests: make sure checksrc runs on header files too
- tests: set LC_ALL=en_US.UTF-8 instead of blank in several tests
- tests: use DoH feature for DoH tests
- tests: use \r\n for log messages in WSL
- tool_operate: fix mem leak when failed config parse
- travis: Fix error detection
- travis: abandon coveralls, it is not reliable
- travis: build ngtcp2 with --enable-lib-only
- travis: export the CC/CXX variables when set
- vtls: make BearSSL possible to set with CURL_SSL_BACKEND
- winbuild: Define CARES_STATICLIB when WITH_CARES=static
- winbuild: Document CURL_STATICLIB requirement for static libcurl
- Remove curl-expire-clear.patch

==== discover ====
Version update (5.17.4 -> 5.17.5)
Subpackages: discover-backend-flatpak discover-backend-fwupd
discover-backend-packagekit discover-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== dolphin ====
Version update (19.12.0 -> 19.12.1)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* Improve scroll wheel speed by basing it on label height, not icon height
(kde#386379)

==== dragonplayer ====
Version update (19.12.0 -> 19.12.1)
Subpackages: dragonplayer-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== drkonqi5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: drkonqi5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== eventviews ====
Version update (19.12.0 -> 19.12.1)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== grantleetheme ====
Version update (19.12.0 -> 19.12.1)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== gwenview5 ====
Version update (19.12.0 -> 19.12.1)
Subpackages: gwenview5-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== incidenceeditor ====
Version update (19.12.0 -> 19.12.1)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Fix Bug 414977 - broken layout does no longer resize attendee list
(kde#414977)

==== kaccounts-integration ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kaccounts-providers ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kaccounts-providers-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kactivitymanagerd ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kactivitymanagerd-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kaddressbook ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kaddressbook-doc kaddressbook-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kalarmcal ====
Version update (19.12.0 -> 19.12.1)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kamera ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kamera-lang kio_kamera

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kate ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kate-lang kate-plugins

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Unbreak build with cmake < 3.7 (VERSION_GREATER_EQUAL only avail >= 3.7)
* Update Appstream for new release
* Fix crash when pressing ESC after external tools plugin was un/reloaded
* sort settings file by language id
* initial support for javascript + typescript LSP
* lsp: update info of OCaml server
* lspclient: aid compilation on older version by explicit json object
conversion
* relax ocaml regex
* allow highlighting mode => language id mapping to be configured in the JSON
config
* Add icons to metadata of plugins supporting KDevelop/Plugin

==== kcalc ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kcalc-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Fix warning on launch from QCommandLineParser
* Update Appstream for new release

==== kcalutils ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Fix kcalutils-testincidenceformatter color

==== kcharselect ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kcharselect-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kcm_sddm ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kcm_sddm-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* Use text color for "No preview image" text

==== kcolorchooser ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kcolorchooser-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kdav ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdav-lang libKPimKDAV5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kde-cli-tools5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kde-cli-tools5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kde-gtk-config5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kde-user-manager ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kde-user-manager-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kdepim-addons ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdepim-addons-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Fix save config
* Fix insert text
* Activate by default

==== kdepim-apps-libs ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdepim-apps-libs-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kdepim-runtime ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdepim-runtime-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kdialog ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kdialog-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kgamma5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kgamma5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== khelpcenter5 ====
Version update (19.12.0 -> 19.12.1)
Subpackages: khelpcenter5-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== khotkeys5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: khotkeys5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kidentitymanagement ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Check if 'cat' executable exists before using it

==== kimap ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kimap-lang libKF5IMAP5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kinfocenter5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kinfocenter5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kio-extras5 ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kio_audiocd ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kio_audiocd-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kitinerary ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Too many changes to list here.

==== kldap ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kldap-lang libKF5Ldap5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kleopatra ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kleopatra-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kmag ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmag-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kmail ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Fix change settings. KPIM::PIMMessageBox::fourBtnMsgBox return a
QDialogButtonBox::
* Update Appstream for new release
* Fix Bug 415160 - KMail build fails if messagelib is built without Qca-qt5
(kde#415160)

==== kmail-account-wizard ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmail-account-wizard-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmailtransport ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmbox ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmenuedit5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kmenuedit5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kmime ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmime-lang libKF5Mime5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kmousetool ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kmousetool-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== knotes ====
Version update (19.12.0 -> 19.12.1)
Subpackages: knotes-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kompare ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kompare-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== konsole ====
Version update (19.12.0 -> 19.12.1)
Subpackages: konsole-part konsole-part-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update copyright year
* ColorScheme: fix stack-use-after-scope detected by ASAN
* Update Appstream for new release
* Copy _colorRandomization when copying a new ColorScheme
* Fix token buffer indexing (kde#415249)
* Revert removal to allow Bookmark tabs as Folders to work
* Revert supportTabs() removal to fix bookmenu issue (kde#415549)
- Drop Add ColorScheme-fix-stack-use-after-scope.patch. Merged upstream.
- Drop the obsolete fix-build-with-gcc48.patch patch

==== kontact ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kontact-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kontactinterface ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kopete ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kopete-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== korganizer ====
Version update (19.12.0 -> 19.12.1)
Subpackages: korganizer-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kpimtextedit ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kpkpass ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKPimPkPass5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kruler ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kruler-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== kscreen5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kscreen5-lang kscreen5-plasmoid

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kscreenlocker ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4
- Rename kscreenlocker pam file to kde (boo#1158966)
- Use %_distconfdir for saving the PAM service file. No migration
code for .rpmsave added as the file was never supposed to be
modified.

==== ksmtp ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== ksshaskpass5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: ksshaskpass5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== ksysguard5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: ksysguard5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== ktnef ====
Version update (19.12.0 -> 19.12.1)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== kwalletmanager5 ====
Version update (19.12.0 -> 19.12.1)
Subpackages: kwalletmanager5-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* Do not use future versions for disabling deprecated API in stable branches

==== kwayland-integration ====
Version update (5.17.4 -> 5.17.5)

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== kwin5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: kwin5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* [nightcolor] Fix division by zero (kde#415359)
* Possible fix for KDecoration crash in systemsettings (kde#411166)
- Remove patches, now upstream:
* 0001-Possible-fix-for-KDecoration-crash-in-systemsettings.patch

==== libgravatar ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkcddb ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5Cddb5 libkcddb-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update the obsolete projects.kde.org URL

==== libkcompactdisc ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update the obsolete projects.kde.org URL

==== libkdcraw ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkdecoration2 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: libkdecorations2-5 libkdecorations2-5-lang libkdecorations2private6

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== libkdepim ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkexiv2 ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkgapi ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkipi ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update the obsolete projects.kde.org URL

==== libkleo ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libkomparediff2 ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libksane ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5Sane5 libksane-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update the obsolete projects.kde.org URL
* Fix color-options layout & KSaneOptCombo::setValue() (kde#414601)
* Optimize support of scanners with different image sources or duplex unit
(kde#414600)

==== libkscreen2 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== libksieve ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libksieve-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== libksysguard5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* Speed up sending request to ksysguardd

==== libreoffice ====
Version update (6.3.3.2 -> 6.4.0.1)
Subpackages: libreoffice-base libreoffice-base-drivers-firebird
libreoffice-calc libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-l10n-es
libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru
libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
libreofficekit

- Add patch to fix button ordering in Qt interface:
* 0001-tdf-129879-Fix-wrong-order-of-buttons.patch
- Set LANG during check; needed for a UTF8-related test to pass.
- Update to 6.4.0.1:
* Various minor fixes for the RC1 of 6.4 branch
- Update to 6.4.0.0.beta1:
* Various features for 6.4 libreoffice series
- Remove upstreamed patch mdds-1-5.patch

==== libstorage-ng ====
Version update (4.2.44 -> 4.2.49)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#696
- updated pot and po files
- 4.2.49
- merge gh#openSUSE/libstorage-ng#697
- merge gh#openSUSE/libstorage-ng#693
- Translated using Weblate (Estonian) (bsc#1149754)
- Translated using Weblate (Finnish) (bsc#1149754)
- Add unit tests
- Bump version
- Ensure default to 0 for optional columns
- Improve test
- Revert "Translated using Weblate (Finnish)" (bsc#1149754)
- Revert "Translated using Weblate (Estonian)" (bsc#1149754)
- Allow optional fstab columns (merge SLE-15-SP1)
- 4.2.48
- merge gh#openSUSE/libstorage-ng#695
- added probing of BitLocker (bsc#1159318)
- added unit test
- fixed message
- add minimal support for BitLocker
- 4.2.47
- merge gh#openSUSE/libstorage-ng#694
- Fix partition id when creating partition
- Bump version
- 4.2.46
- merge gh#openSUSE/libstorage-ng#691
- Add method to get partition id name
- Bump version
- Add note
- Partition Id names
- 4.2.45

==== mailcommon ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Move variable before attachmeent

==== mailimporter ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== messagelib ====
Version update (19.12.0 -> 19.12.1)
Subpackages: messagelib-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Too many changes since 19.12.0, only listing bugfixes:
* Fix Bug 415254 - [regression] HTML viewer complains about "external
references to images etc." when there are no images (kde#415254)

==== milou5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: milou5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* [Applet] Replace missing icon

==== mobipocket ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== mozilla-nspr ====
Version update (4.23 -> 4.24)

- update to version 4.24
* added macro PR_ASSERT_ARG
* removed some declarations
* added support for Nios-II, Nds32 and Microblaze architectures

==== mozilla-nss ====
Version update (3.47.1 -> 3.48)
Subpackages: libfreebl3 libfreebl3-hmac libsoftokn3 libsoftokn3-hmac
mozilla-nss-certs mozilla-nss-tools

- update to NSS 3.48

https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.48_release_notes
Notable Changes
* TLS 1.3 is the default maximum TLS version (bmo#1573118)
* TLS extended master secret is enabled by default, where possible
(bmo#1575411)
* The master password PBE now uses 10,000 iterations by default when
using the default sql (key4.db) storage (bmo#1562671)
Certificate Authority Changes
* Added Entrust Root Certification Authority - G4 Cert (bmo#1591178)
Bugfixes
- requires NSPR 4.24

==== musepack ====

- Add libmpcdec-extern.patch: add missing extern declarations
(boo#1160284).

==== okular ====
Version update (19.12.0 -> 19.12.1)
Subpackages: okular-lang okular-spectre

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release
* Fix crash when closing print preview dialog (kde#415340)
* Fix man page formatting (kde#415468)

==== openconnect ====
Subpackages: libopenconnect5 openconnect-lang

- Remove tncc-wrapper.py script as it is python2 only bsc#1157446

==== oxygen5 ====
Version update (5.17.4 -> 5.17.5)

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== pimcommon ====
Version update (19.12.0 -> 19.12.1)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== plasma-browser-integration ====
Version update (5.17.4 -> 5.17.5)
Subpackages: plasma-browser-integration-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* [Purpose Plugin] Reset pending reply serial when aborting

==== plasma-nm5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* Do not crash when changing advanced IPv4 configuration (kde#415856)
* Port KCM menu away from PlasmaComponents (kde#414762)
* Fortisslvpn: add option to ignore the password BUG: 414975 (kde#414975)

==== plasma5-addons ====
Version update (5.17.4 -> 5.17.5)
Subpackages: plasma5-addons-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* [applets/weather] Fix regression in temperature size with short panels
(kde#415187)

==== plasma5-desktop ====
Version update (5.17.4 -> 5.17.5)
Subpackages: plasma5-desktop-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* [Notifications KCM] Fixup current item syncing logic (kde#410842)
* [KRunner KCM] Mark KCM as dirty when plugin configuration changes
* [Pager] Fix switching pages on drag (kde#415423)
* [Colors KCM] Increase delegate height
* Fix regression in "Port the pager applet away from QtWidgets" (kde#414849)
* [KCMs/Activities] Fix jagginess for activities list icons on high DPI
systems (kde#414945)
* [Icons KCM] Use help-browser icon

==== plasma5-integration ====
Version update (5.17.4 -> 5.17.5)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* Resize file dialog window before size restore

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.17.5

==== plasma5-pa ====
Version update (5.17.4 -> 5.17.5)
Subpackages: plasma5-pa-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== plasma5-workspace ====
Version update (5.17.4 -> 5.17.5)
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* Fix build with gpsd 3.20 (kde#425939)
* [Notifications] Don't show DrKonqi notifications in history
* Revert "Add Meta+Space as a default shortcut to activate KRunner"
* [Notifications] Release all cookies when service unregisters
* Revert "[sddm-theme] Fix initial focus after SDDM QQC2 Port" (kde#414875)
* Keep at least one system monitor alive
* Use the right value of EnableMagicMimeActions
* [sddm-theme] Fix initial focus after SDDM QQC2 Port

==== polkit-kde-agent-5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- No code changes since 5.17.4

==== powerdevil5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: powerdevil5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* Check for DPMS extension being present (kde#414921)

==== signon-kwallet-extension ====
Version update (19.12.0 -> 19.12.1)

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- No code change since 19.12.0

==== snapper ====
Version update (0.8.6 -> 0.8.8)
Subpackages: snapper-zypp-plugin

- Add a "writeble copy" description to the 2nd snapshot
of a rollback (Hrotkó Gábor).
- Fix the previous version to build on Debian, Ubuntu, and old GCC
(bsc#1160306).
- version 0.8.8
- snapper-zypp-plugin subpackage rewritten from Python to C++
(jsc#SLE-10500)
- added integration tests in snapper-testsuite subpackage
- version 0.8.7

==== spectacle ====
Version update (19.12.0 -> 19.12.1)
Subpackages: spectacle-lang

- Update to 19.12.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.1
- Changes since 19.12.0:
* Update Appstream for new release

==== subversion ====
Subpackages: libsvn_auth_gnome_keyring-1-0 libsvn_auth_kwallet-1-0
subversion-bash-completion subversion-perl

- Disable dependency on ctypesgen which is borked with new pythons

==== systemsettings5 ====
Version update (5.17.4 -> 5.17.5)
Subpackages: systemsettings5-lang

- Update to 5.17.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.17.5.php
- Changes since 5.17.4:
* [Icon View] Fix titles of previously opened KCMs bleeding into QML KCMs

==== tcsh ====
Subpackages: tcsh-lang

- Add temporary patch tcsh-6.22.02-workaround-common.patch to avoid
common variable seen twice by compiler (boo#1160296)

==== xen ====
Subpackages: xen-libs xen-tools xen-tools-domU

- BuildRequire pkgconfig(libsystemd) instead of systemd-devel:
Allow OBS to shortcut through the -mini flavors.

==== yast2 ====
Version update (4.2.49 -> 4.2.53)
Subpackages: yast2-logs

- Fixed error during upgrade if Btrfs is used and '/var/lib/YaST2'
is missing (bsc#1159562)
- 4.2.53
- Propagate an error status when a CommandLine module gets an
unknown command (related to bsc#1144351).
- 4.2.52
- Fix an exception in the live installation caused by a missing
"require" clause (bsc#1160362).
- 4.2.51
- Persian is also an RTL language (related to bsc#1156437)
- 4.2.50

==== yast2-iscsi-client ====
Version update (4.2.2 -> 4.2.3)

- Keep the current service state after writing the configuration by
default (bsc#1160374).
- 4.2.3

==== yast2-kdump ====
Version update (4.2.6 -> 4.2.7)

- Showing default (expected) values for high/low kdump memory.
(bsc#1153940)
- 4.2.7

==== yast2-network ====
Version update (4.2.42 -> 4.2.43)

- Add a sanity test for CLI error code reporting (bsc#1144351)
- 4.2.43

==== yast2-nfs-client ====
Version update (4.2.3 -> 4.2.4)

- Avoids displaying phantom NFS entries adding an action to
refresh the UI (related to bsc#1156446).
- 4.2.4

==== yast2-packager ====
Version update (4.2.42 -> 4.2.43)

- PackageSlideShow: Do not show medium if there is only one
(bsc#1158498)
- PackageSlideShow: Show hourglass when computing remaining time
- PackageSlideShow: Never exceed 2 hours for time estimation
- 4.2.43

==== yast2-ruby-bindings ====
Version update (4.2.6 -> 4.2.7)

- Fix previous fix to really set exit code in ruby wrapper
(bsc#1144351)
- 4.2.7

==== yast2-storage-ng ====
Version update (4.2.67 -> 4.2.69)

- disallow to mount BitLocker (related to bsc#1159318)
- 4.2.69
- Use partition id names defined by libstorage-ng.
- 4.2.68

==== yast2-trans ====
Version update (84.87.20191229.ed49b3ce0a -> 84.87.20200104.ad092ae8df)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20200104.ad092ae8df:
* New POT for text domain 'packager'.
* New POT for text domain 'rear'.
* New POT for text domain 'network'.
* New POT for text domain 'country'.
* New POT for text domain 'ftp-server'.
* New POT for text domain 'bootloader'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Albanian)

==== yast2-update ====
Version update (4.2.12 -> 4.2.13)

- Aborting upgrade: Restoring old settings e.g. RPM database
(bsc#1158914).
- mount /run and efivars into target to fix hanging LVM (bsc#1148500)
by Steffen Winterfeldt <snwint@xxxxxxxx>
- 4.2.13

==== zinnia ====
Subpackages: libzinnia0

- Disable the build with python for Tumbleweed, as python 2 support
is dropped


N�����r��y隊Z)z{.���r�+�맲��r��z�^�ˬz��N�(�֜��^� ޭ隊Z)z{.���r�+��0�������Ǩ�
< Previous Next >
Follow Ups