Mailinglist Archive: opensuse-factory (300 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20200105 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Mon, 06 Jan 2020 22:00:31 +0000
  • Message-id: <157834803126.23758.15410537722100094523@go-agent-stagingbot-7>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20200105

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
autoyast2 (4.2.24 -> 4.2.26)
hplip
libstorage-ng (4.2.40 -> 4.2.44)
libyui (3.9.0 -> 3.9.1)
libyui-ncurses (2.54.1 -> 2.54.4)
libyui-qt (2.52.0 -> 2.52.1)
logrotate
python
python-base
python-passlib (1.7.1 -> 1.7.2)
smartmontools (7.0 -> 7.1)
tpm2-0-tss (2.3.0 -> 2.3.2)
usb_modeswitch (2.5.2 -> 2.6.0)
yast2 (4.2.47 -> 4.2.49)
yast2-auth-client (4.2.2 -> 4.2.3)
yast2-bootloader (4.2.13 -> 4.2.15)
yast2-country (4.2.10 -> 4.2.14)
yast2-firstboot (4.2.5 -> 4.2.6)
yast2-ftp-server (4.2.2 -> 4.2.3)
yast2-network (4.2.35 -> 4.2.42)
yast2-packager (4.2.39 -> 4.2.42)
yast2-ruby-bindings (4.2.5 -> 4.2.6)
yast2-storage-ng (4.2.62 -> 4.2.67)
yast2-sudo (4.2.1 -> 4.2.2)
yast2-trans (84.87.20191209.9412cbcf88 -> 84.87.20191229.ed49b3ce0a)
yast2-ycp-ui-bindings (4.2.6 -> 4.2.7)

=== Details ===

==== autoyast2 ====
Version update (4.2.24 -> 4.2.26)
Subpackages: autoyast2-installation

- Fix cloning patterns (regression from 4.2.22)
(bsc#1159269, bsc#1159472)
- 4.2.26
- Fixed conflicting items in rule dialogs (bsc#1123091).
- Semi-automatic with partition: Do not use the common AY partition
workflow (bsc#1134501).
- Do not reset Base-Product while registration. Do not call
registration in the second installation stage again.
(bsc#1143106).
- Fix profile validation for scripts elements (bsc#1156905).
- UI: Report XML parsing errors instead of just crashing
(bsc#1159157).
- 4.2.25

==== hplip ====
Subpackages: hplip-hpijs hplip-sane

- Pass Python includedir in CFLAGS to fix broken lookup of Python.h
in configure, fails with Python 3.8 (boo#1159242).

==== libstorage-ng ====
Version update (4.2.40 -> 4.2.44)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#692
- improved sort-key for block devices (for bsc#1140018)
- extended documentation
- 4.2.44
- merge gh#openSUSE/libstorage-ng#690
- provide sort-key for device name (for bsc#1140018)
- adapted utility programs to changes in networkx 2.4
- removed obsolete variable
- 4.2.43
- Translated using Weblate (Finnish) (bsc#1149754)
- 4.2.42
- Translated using Weblate (German) (bsc#1149754)
- 4.2.41

==== libyui ====
Version update (3.9.0 -> 3.9.1)

- added sort key to table cell (bsc#1140018)
- 3.9.1

==== libyui-ncurses ====
Version update (2.54.1 -> 2.54.4)

- handle new sort-key when sorting tables (bsc#1140018)
- 2.54.4
- update selected item in table when changing sorting only if
multiselection mode is off (bsc#1159098)
- 2.54.3
- sort new table content (unless keep-sorting flag is set) (part
of bsc#1140018 and part of #1159177)
- update selected item in table when changing sorting (bsc#1159098)
- 2.54.2

==== libyui-qt ====
Version update (2.52.0 -> 2.52.1)

- handle new sort-key when sorting tables (bsc#1140018)
- 2.52.1

==== logrotate ====

- Use systemd_ordering instead of systemd_requires

==== python ====
Subpackages: python-curses python-tk

- Add provides in gdbm subpackage to provide dbm symbols. This
allows us to use %%{python_module dbm} as a dependency and have
it properly resolved for both python2 and python3

==== python-base ====
Subpackages: libpython2_7-1_0 python-xml

- Add provides in gdbm subpackage to provide dbm symbols. This
allows us to use %%{python_module dbm} as a dependency and have
it properly resolved for both python2 and python3

==== python-passlib ====
Version update (1.7.1 -> 1.7.2)

- Removed obsolete patches:
* python-passlib-1.7.1-libxcrypt-compat.patch
* pr_9_1.patch and pr_9_2.patch
- Update to 1.7.2
* New Features
- argon2: Now supports Argon2 ?ID? and ?D? hashes
(assuming new enough backend library).
- scrypt: Now uses python 3.6 stdlib?s hashlib.scrypt() as backend,
if present (issue 86).
* Bugfixes
- Python 3.8 compatibility fixes
- passlib.apache.HtpasswdFile:
Now generates bcrypt hashes using the "$2y$" prefix, which should work
properly with Apache 2.4?s htpasswd tool.
- passlib.totp: The TOTP.to_uri() method now prepends the issuer to URI label,
(per the KeyURI spec). This should fix some compatibility issues with
older TOTP clients (issue 92)
- Fixed error in argon2.parsehash() (issue 97)
- unittests: crypt() unittests now account for linux systems running
libxcrypt (such as recent Fedora releases)

==== smartmontools ====
Version update (7.0 -> 7.1)

- Update to version 7.1:
* smartctl: Fixed bogus exception on unknown form factor value.
* smartctl '--json=cg': Suppresses extra spaces also in 'g'
format.
* smartctl '-i': ATA ACS-4 and ACS-5 enhancements.
* smartd: No longer truncates very long device names in warning
emails.
* smartd: No longer skips scheduled tests if system clock has
been adjusted to the past.
* smartd '-A': Attribute logs now use local time instead of UTC.
* ATA: Device type '-d jmb39x,N' for drives behind JMicron JMB39x
RAID port multipliers.
* SCSI: Workaround for incomplete Log subpages response from some
SAS SSDs.
* HDD, SSD and USB additions to drive database.
* Autodetection of '-d sntjmicron' type for JMicron USB to NVMe
bridges.
* Fixed segfault on CCISS transfer sizes > 512 bytes.
* Fixed smartd.service 'Type' if libsystemd-dev is not available.
* Fixed '/dev/megaraid_sas_ioctl_node' fd leak.
* Fixed GPL licensing problem of 'linux_nvme_ioctl.h'
(smartmontools#1226,
drop smartmontools-nvme_ioctl_h-license.patch).
- Update smartmontools.keyring. Developers use new key.
- smartmontools-drivedb_h-update.sh: Recognize equal files in
different commits.
- Remove smartmontools-drivedb.h. No update available in the
upstream branch RELEASE_7_0_DRIVEDB.
- BuildRequire pkgconfig(libsystemd) instead of systemd-devel:
Allow OBS to shortcut through the -mini flavors.

==== tpm2-0-tss ====
Version update (2.3.0 -> 2.3.2)
Subpackages: libtss2-esys0 libtss2-mu0 libtss2-sys0

- update to upstream version 2.3.2:
- changes since version 2.3.0:
- Fix unit tests on S390 architectures
- Fixed HMAC generation for policy sessions

==== usb_modeswitch ====
Version update (2.5.2 -> 2.6.0)
Subpackages: usb_modeswitch-data

- Update to version 2.6.0
* Removed included libjim source alltogether
* Rewrote parts of the dispatcher script to make location of
global config file into a parameter: --config-file, so it can be
customised now
* Replaced tcl helper file for jim embedding with a sh script,
dropping the install dependency on a tcl interpreter
(Attention maintainers!)
* Changed Makefile to prevent parallel build issues as reported
here:
http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?f=2&t=2829,
make targets have changed names (Attention maintainers!)
- Update usb-modeswitch-data package to version 20191128
* Slight change of the 'skipping' rules to avoid unnecessary
checks (thanks to Florian Zumbiehl)
* Added devices: [03f0:0857] HP lt4220, [05c6:1000:uMa=Qualcomm]
Venus Fast2, [0bda:1a2b] D-Link DWA-171 Wifi Dongle,
[0e8d:2870] COMFAST CF-WU782AC WiFi Dongle, [12d1:15ee]
Vodafone/Huawei K5160, [12d1:1f0a] Vodafone/Huawei R218h
(lkly compat. to E5573cs), [1410:9030] Novatel USB730L,
[1410:b00c] Novatel MiFi 6620L, [15eb:a403] Abit AK-020,
[161c:f010] KuWfi 4g LTE, [19d2:1421] ZTE MF833V / Telewell
TW-LTE v2, [1c9e:3003] 4G System XS W21s, [1c9e:f030] JioFi
JMR1040, [2001:ac01] D-Link DWM-222 A2, [2020:2030] Telewell
TW-LTE / Olicard 600 / Digisol BG-BA4305, [2357:0601] TP-Link
UE300, [2fd4:9aff] 4G Systems W1208, [413c:81a2] Dell DW5806,
[413c:81a3] Dell DW5570, [413c:81a4] Dell DW5570e, [413c:81a8]
Dell DW5808, [413c:81b1] Dell DW5809e, [413c:81b3] Dell DW5809e,
[413c:81d7] Dell DW5821e, [413c:81e0] Dell DW5821e-eSIM
* Corrected/amended configs: [057c:62ff] AVM Fritz!Wlan USB
Sticks (added target 8602), [1199:0fff] Sierra devices
(3 erroneous target IDs removed)
- Fixed usb_modeswitch-fix_fsf_address.patch

==== yast2 ====
Version update (4.2.47 -> 4.2.49)
Subpackages: yast2-logs

- Yast2::ServiceWidget: By default, propose to reload or restart
the service when it is active (bsc#1158946)
- 4.2.49
- Added helper to create UI sort-key term (bsc#1140018)
- 4.2.48

==== yast2-auth-client ====
Version update (4.2.2 -> 4.2.3)

- Add missing domain setting 'ignore_group_members'; (bsc#1153547);
- 4.2.3

==== yast2-bootloader ====
Version update (4.2.13 -> 4.2.15)

- deduplicate kernel parameters after merging them
(bsc#1130954, bsc#1043103, bsc#1132328, bsc#1134895)
- 4.2.15
- Report proper error when /etc/default/grub missing and allow
user to repropose it (bsc#1100755)
- 4.2.14

==== yast2-country ====
Version update (4.2.10 -> 4.2.14)
Subpackages: yast2-country-data

- Do not crash when unknown keymap is set on system (bsc#1159286)
- 4.2.14
- fix passing parameters to loadkeys call (bsc#1159185)
- 4.2.13
- Fix incorect dialect offers (bsc#949591)
- 4.2.12
- Setting keyboard: Ignoring empty keyboard values.
(bsc#1158994, bsc#1159210)
- 4.2.11

==== yast2-firstboot ====
Version update (4.2.5 -> 4.2.6)

- Replace outdated "SuSE" spelling (bsc#970809).
- 4.2.6

==== yast2-ftp-server ====
Version update (4.2.2 -> 4.2.3)

- fix crash with undefined method mkdir (bsc#1158421)
- 4.2.3

==== yast2-network ====
Version update (4.2.35 -> 4.2.42)

- bnc#1159970
- suppport for reading / writing MTU
- 4.2.42
- bnc#1153198, fate#319639
- fixed internal error caused by incompatibility between new and
old DNS / Hostname handling code.
- 4.2.41
- read properly old wireless auth modes and use new ones instead
(bsc#1159160)
- 4.2.40
- bnc#1153198, fate#319639
- improved previous fix - exception handling
- 4.2.39
- bsc#1156986
- Fixed the creation of network configuration for virtualization
- 4.2.38
- bnc#1153198, fate#319639
improved previous fix together with some cleanup
- 4.2.37
- Centered and added title to the add interface dialog
(jsc#SLE-7753)
- 4.2.36

==== yast2-packager ====
Version update (4.2.39 -> 4.2.42)

- Improve warning when all repositories are disabled (bsc#1158512)
- 4.2.42
- Do not unexpectly end during slide show script progress
(bsc#1159461)
- 4.2.41
- do not crash when invalid URL is used in config mode
(bsc#1073208)
- 4.2.40

==== yast2-ruby-bindings ====
Version update (4.2.5 -> 4.2.6)

- Fix returning error codes from y2start start point. Helps with
CLI exit codes and also with failed installation (helps e.g. with
bsc#1144351 and yast lan CLI)
- 4.2.6

==== yast2-storage-ng ====
Version update (4.2.62 -> 4.2.67)

- Improved sorting by device name and size in tables (bsc#1140018)
- 4.2.67
- Fixed an error when applying fallback_max_size_lvm in some corner
cases (bsc#1075990).
- 4.2.66
- AutoYaST: use the multipath device when the 'device' element
points to one of its wires (bsc#1159081).
- 4.2.65
- Wrap long details message when error happens (bsc#1085468)
- 4.2.64
- Improved support for Raspberry Pi in the Guided Proposal: now it
also works without preexisting firmware partition (jsc#SLE-7298)
- 4.2.63

==== yast2-sudo ====
Version update (4.2.1 -> 4.2.2)

- Do not truncate the sudoers file after write changes
(bsc#1156929).
- 4.2.2

==== yast2-trans ====
Version update (84.87.20191209.9412cbcf88 -> 84.87.20191229.ed49b3ce0a)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20191229.ed49b3ce0a:
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Albanian)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* New POT for text domain 'storage'.
* New POT for text domain 'auth-client'.
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
- Update to version 84.87.20191222.53df11f8fb:
* Translated using Weblate (Finnish)
* New POT for text domain 'packager'.
* New POT for text domain 'network'.
* Translated using Weblate (German)
* Translated using Weblate (German)
* New POT for text domain 'network'.
* New POT for text domain 'country'.
* New POT for text domain 'base'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 'rmt'.
* New POT for text domain 'installation'.
* New POT for text domain 'firewall'.
* New POT for text domain 'control'.
* New POT for text domain 'base'.
* New POT for text domain 'auth-client'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Automatic update of rmt.
* Automatic update of installation.
* Automatic update of firstboot.
* Automatic update of firewall.
* Automatic update of control.
* Automatic update of base.
* Automatic update of auth-client.
* Translated using Weblate (Slovak)
* Translated using Weblate (Czech)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 'rmt'.
* New POT for text domain 'installation'.
* New POT for text domain 'firewall'.
* New POT for text domain 'control'.
* New POT for text domain 'base'.
* New POT for text domain 'auth-client'.
* DOMAIN_MAP: Add hana* components.
* weblate-functions.inc: Refer to python3, as Weblate now runs on python3.
* Automatic update of storage.
* Automatic update of rmt.
* Automatic update of network.
* Automatic update of installation.
* Automatic update of hana-update.
* Automatic update of hana-ha.
* Automatic update of hanafirewall.
* Automatic update of firewall.
* Automatic update of control.
* Automatic update of base.
* Automatic update of auth-client.
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Dutch)
* Translated using Weblate (Slovak)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* Translated using Weblate (Danish)
* Translated using Weblate (Danish)
* New POT for text domain 'network'.
* Translated using Weblate (Persian)
- Update to version 84.87.20191215.58f3983ff2:
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Albanian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 'registration'.
* New POT for text domain 'ncurses-pkg'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Czech)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Japanese)
* New POT for text domain 'storage'.
* New POT for text domain 'packager'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Dutch)
* Translated using Weblate (Danish)
* Translated using Weblate (Danish)
* Translated using Weblate (Catalan)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 's390'.
* New POT for text domain 'ncurses-pkg'.
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Catalan)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* New POT for text domain 'qt-pkg'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 'rmt'.
* New POT for text domain 'installation'.
* New POT for text domain 'firewall'.
* New POT for text domain 'control'.
* New POT for text domain 'base'.
* New POT for text domain 'auth-client'.
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* weblate-functions.inc: Updates for new Weblate
* DOMAIN_MAP: add rmt and samba-provision
* Automatic update of samba-provision.
* Automatic update of rmt.
* Automatic update of installation.
* Automatic update of firewall.
* Automatic update of control.
* Automatic update of base.
* Automatic update of auth-client.
* Automatic update of add-on.
* Translated using Weblate (Slovak)

==== yast2-ycp-ui-bindings ====
Version update (4.2.6 -> 4.2.7)

- handle sort key in parser for table item (bsc#1140018)
- 4.2.7


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages