Mailinglist Archive: opensuse-factory (229 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20191221 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Tue, 24 Dec 2019 12:00:28 +0000
  • Message-id: <157718882854.9145.4947227085725511598@go-agent-stagingbot-4>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20191221

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
389-ds (1.4.2.4~git0.c881f6ec0 -> 1.4.2.5~git0.d52700340)
ImageMagick (7.0.9.6 -> 7.0.9.8)
aspell-dictionaries
attica-qt5 (5.64.0 -> 5.65.0)
baloo5 (5.64.0 -> 5.65.0)
bison (3.4.2 -> 3.5)
bluez-qt (5.64.0 -> 5.65.0)
breeze5-icons (5.64.0 -> 5.65.0)
clamav
cryptsetup
ebtables (2.0.10.4 -> 2.0.11)
f2fs-tools (1.12 -> 1.13.0)
frameworkintegration (5.64.0 -> 5.65.0)
gnome-control-center
gstreamer-plugins-bad
gtk3
kactivities-stats (5.64.0 -> 5.65.0)
kactivities5 (5.64.0 -> 5.65.0)
karchive (5.64.0 -> 5.65.0)
kauth (5.64.0 -> 5.65.0)
kbookmarks (5.64.0 -> 5.65.0)
kcalendarcore (5.64.0 -> 5.65.0)
kcmutils (5.64.0 -> 5.65.0)
kcodecs (5.64.0 -> 5.65.0)
kcompletion (5.64.0 -> 5.65.0)
kconfig (5.64.0 -> 5.65.0)
kconfigwidgets (5.64.0 -> 5.65.0)
kcontacts (5.64.0 -> 5.65.0)
kcoreaddons (5.64.0 -> 5.65.0)
kcrash (5.64.0 -> 5.65.0)
kdbusaddons (5.64.0 -> 5.65.0)
kdeclarative (5.64.0 -> 5.65.0)
kded (5.64.0 -> 5.65.0)
kdelibs4support (5.64.0 -> 5.65.0)
kdesu (5.64.0 -> 5.65.0)
kdnssd-framework (5.64.0 -> 5.65.0)
kdoctools (5.64.0 -> 5.65.0)
kemoticons (5.64.0 -> 5.65.0)
kfilemetadata5 (5.64.0 -> 5.65.0)
kglobalaccel (5.64.0 -> 5.65.0)
kguiaddons (5.64.0 -> 5.65.0)
kholidays (5.64.0 -> 5.65.0)
khtml (5.64.0 -> 5.65.0)
ki18n (5.64.0 -> 5.65.0)
kiconthemes (5.64.0 -> 5.65.0)
kidletime (5.64.0 -> 5.65.0)
kimageformats (5.64.0 -> 5.65.0)
kinit (5.64.0 -> 5.65.0)
kio (5.64.0 -> 5.65.0)
kirigami2 (5.64.1 -> 5.65.0)
kitemmodels (5.64.0 -> 5.65.0)
kitemviews (5.64.0 -> 5.65.0)
kjobwidgets (5.64.0 -> 5.65.0)
kjs (5.64.0 -> 5.65.0)
knewstuff (5.64.0 -> 5.65.0)
knotifications (5.64.0 -> 5.65.0)
knotifyconfig (5.64.0 -> 5.65.0)
konsole
kpackage (5.64.0 -> 5.65.0)
kparts (5.64.0 -> 5.65.0)
kpeople5 (5.64.0 -> 5.65.0)
kplotting (5.64.0 -> 5.65.0)
kpty (5.64.0 -> 5.65.0)
kross (5.64.0 -> 5.65.0)
krunner (5.64.0 -> 5.65.0)
kservice (5.64.0 -> 5.65.0)
ktexteditor (5.64.0 -> 5.65.0)
ktextwidgets (5.64.0 -> 5.65.0)
kunitconversion (5.64.0 -> 5.65.0)
kwallet (5.64.0 -> 5.65.0)
kwayland (5.64.0 -> 5.65.0)
kwidgetsaddons (5.64.0 -> 5.65.0)
kwindowsystem (5.64.0 -> 5.65.0)
kxmlgui (5.64.0 -> 5.65.0)
libKF5ModemManagerQt (5.64.0 -> 5.65.0)
libKF5NetworkManagerQt (5.64.0 -> 5.65.0)
libcap
libcontainers-common (20190923 -> 20191211)
libgit2 (0.28.2 -> 0.28.4)
libselinux-bindings
libvirt
man-pages-ja (20181215 -> 20191215)
moonjit
nodejs12 (12.13.1 -> 12.14.0)
openblas_pthreads
oxygen5-icon-theme (5.64.0 -> 5.65.0)
patchutils
perl-Cpanel-JSON-XS (4.17 -> 4.18)
pidgin-sipe (1.24.0 -> 1.25.0)
plasma-framework (5.64.0 -> 5.65.0)
plymouth
prison-qt5 (5.64.0 -> 5.65.0)
procps (3.3.15 -> 3.3.16)
purpose (5.64.0 -> 5.65.0)
qemu (4.1.93 -> 4.2.0)
qemu-linux-user (4.1.93 -> 4.2.0)
qqc2-desktop-style (5.64.0 -> 5.65.0)
rubygem-actioncable-6.0 (6.0.2 -> 6.0.2.1)
rubygem-actionmailbox-6.0 (6.0.2 -> 6.0.2.1)
rubygem-actionmailer-6.0 (6.0.2 -> 6.0.2.1)
rubygem-actionpack-6.0 (6.0.2 -> 6.0.2.1)
rubygem-actiontext-6.0 (6.0.2 -> 6.0.2.1)
rubygem-actionview-6.0 (6.0.2 -> 6.0.2.1)
rubygem-activejob-6.0 (6.0.2 -> 6.0.2.1)
rubygem-activemodel-6.0 (6.0.2 -> 6.0.2.1)
rubygem-activerecord-6.0 (6.0.2 -> 6.0.2.1)
rubygem-activestorage-6.0 (6.0.2 -> 6.0.2.1)
rubygem-activesupport-6.0 (6.0.2 -> 6.0.2.1)
rubygem-rack (2.0.7 -> 2.0.8)
rubygem-rails-6.0 (6.0.2 -> 6.0.2.1)
rubygem-railties-6.0 (6.0.2 -> 6.0.2.1)
rubygem-rubocop (0.77.0 -> 0.78.0)
rubygem-thor (1.0.0 -> 1.0.1)
sendmail
solid (5.64.0 -> 5.65.0)
sonnet (5.64.0 -> 5.65.0)
spamassassin (3.4.2 -> 3.4.3)
sudo
syndication (5.64.0 -> 5.65.0)
syntax-highlighting (5.64.0 -> 5.65.0)
texlive
threadweaver (5.64.0 -> 5.65.0)
tpm2-0-tss (2.2.3 -> 2.3.0)
wicked (0.6.60 -> 0.6.61)
wireguard (0.0.20191212_k5.3.12_1 -> 0.0.20191219_k5.3.12_2)

=== Details ===

==== 389-ds ====
Version update (1.4.2.4~git0.c881f6ec0 -> 1.4.2.5~git0.d52700340)
Subpackages: lib389 libsvrcore0

- Update to version 1.4.2.5~git0.d52700340:
* Bump version to 1.4.2.5
* Issue 50747 - Port readnsstate to dsctl
* Issue 50758 - Enable CLI arg completion
* Issue 50753 - Dumping the changelog to a file doesn't work
* Ticket 50745: ns-slapd hangs during CleanAllRUV tests
* Issue 50734 - lib389 creates non-SSCA cert DBs with misleading README.txt
* Issue: 48851 - investigate and port TET matching rules filter tests(cert)
* Issue: 50443 - Create a module in lib389 to Convert a byte sequence to a
properly escaped for LDAP
* Ticket 50664 - DS can fail to recover if an empty directory exists in db
* Ticket 50736 - RetroCL trimming may crash at shutdown if trimming
configuration is invalid
* Ticket 50741 - bdb_start - Detected Disorderly Shutdown last time Directory
Server was running
* Issue 50572 - After running cl-dump dbdir/cldb/*ldif.done are not deleted
* Issue 50701 - Fix type in lint report
* Ticket 50729 - add support for gssapi tests on suse
* Issue 50701 - Add additional healthchecks to dsconf
* Issue 50711 - `dsconf security` lacks option for setting
nsTLSAllowClientRenegotiation attribute
* Issue 50439 - Update docker integration for Fedora
* Issue: 48851 - Investigate and port TET matching rules filter tests(last
test cases for match)
* Issue 50499 - Fix npm audit issues
* Issue 50722 - Test IDs are not unique
* Issue 50712 - Version comparison doesn't work correctly on git builds
* Issue 50499 - Fix npm audit issues
* Issue 50706 - Missing lib389 dependency - packaging

==== ImageMagick ====
Version update (7.0.9.6 -> 7.0.9.8)
Subpackages: ImageMagick-config-7-SUSE ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI7 libMagickWand-7_Q16HDRI7 perl-PerlMagick

- version update to 7.0.9.8
* -type bilevel behavior restored, it creates a black and white image.
* Support Pocketmod image format, e.g.
convert -density 300 pages?.pdf pocketmod:organize.pdf
* Fixed numerous issues posted to GitHub (reference
https://github.com/ImageMagick/ImageMagick/issues).
* Update documentation.
- deleted patches
- ImageMagick-targa.patch (upstreamed)

==== aspell-dictionaries ====
Subpackages: aspell-cs aspell-da aspell-de aspell-el aspell-es aspell-fr
aspell-hu aspell-it aspell-pl aspell-pt_BR aspell-pt_PT aspell-ru

- removing Novell residues
- update:
. da 1.6.36
. pt_PT 20190329
- deleted patches
- aspell-dictionaries-Novellwords_extra_dict.patch (abandoned)
- deleted sources
- Nwordlist.tgz (abandoned)

==== attica-qt5 ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Attica5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== baloo5 ====
Version update (5.64.0 -> 5.65.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== bison ====
Version update (3.4.2 -> 3.5)
Subpackages: bison-lang

- Drop unnecessary autoconf BuildRequires.
- Update to version 3.5:
* Plenty of changes - see provided NEWS for detailed list

==== bluez-qt ====
Version update (5.64.0 -> 5.65.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Fix minor issue found by EBN and typos

==== breeze5-icons ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Pixel align color-picker
* Add new baloo icons
* Add new preferences search icons
* Use an eyedropper for color-picker icons (kde#403924)
* Add "all applications" category icon

==== clamav ====
Subpackages: libclamav9 libfreshclam2

- BuildRequire pkgconfig(libsystemd) instead of systemd-devel:
Aloow OBS to shortcut through the -mini flavors.

==== cryptsetup ====
Subpackages: libcryptsetup12 libcryptsetup12-32bit libcryptsetup12-hmac

- Create a weak dependency cycle between libcryptsetup and
libcryptsetup-hmac to make sure they are installed together
(bsc#1090768)

==== ebtables ====
Version update (2.0.10.4 -> 2.0.11)

- add ebtables.keyring as a Source
- Update to release 2.0.11
* Add --noflush command line support for ebtables-restore
* Do not print IPv6 mask if it is all ones
* Allow RETURN target rules in user defined chains
* ebt_ip: add support for matching ICMP type and code
* ebt_ip: add support for matching IGMP type
* extensions: Add string filter to ebtables
* Print IPv6 prefixes in CIDR notation
* extensions: Add AUDIT target
* Fix incorrect IPv6 prefix formatting
- Drop ebtables-v2.0.8-makefile.diff (no longer needed)
- Drop ebtables-v2.0.8-initscript.diff, include-linux-if.patch
(not applicable)
- Drop ebtables-v2.0.10-4-audit.patch,
0001-fix-compilation-warning.patch,
0001-Use-flock-for-concurrent-option.patch,
0002-Fix-locking-if-LOCKDIR-does-not-exist.patch (merged)

==== f2fs-tools ====
Version update (1.12 -> 1.13.0)

- Update to release 1.13
* introduce some preen mode in fsck.f2fs
* add f2fs_io tool
* add casefolding support

==== frameworkintegration ====
Version update (5.64.0 -> 5.65.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Conditionally set SH_ScrollBar_LeftClickAbsolutePosition based on
kdeglobals setting
* Set application name and version on the knshandler tool
* Port away from deprecated signal KNSCore::Engine::signalError

==== gnome-control-center ====
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Add gnome-control-center-Initialize-GError-to-NULL-before-use.patch:
backport upstream commit 54caab7b, initialize GError* to NULL
before use, fix g-c-c crash.
- Rebase gnome-control-center-more-power-button-actions.patch for 3.34:
Rename 'Shutdown' to 'Force Off' and adjust the order by severity
(bsc#1091796, bsc#1158476).
- Add gnome-control-center-can-not-find-usermod.patch:
g-c-c use command usermod to verify user is valid, usermod is in
/usr/sbin, environment PATH doesn't include this path, so g-c-c
can't find this command. Upstream commit c6be204
(bsc#1158341 glgo#GNOME/gnome-control-center!653).

==== gstreamer-plugins-bad ====
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0
libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0

- Add a BuildRequires for pkgconfig(pangocairo) since it's needed
by the ttmlsubs and closedcaption extensions. This is not currently
a problem in openSUSE because the dependency is pulled in by other
packages which are not installed in SLE.

==== gtk3 ====
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-tigrigna gtk3-immodule-vietnamese
gtk3-immodule-xim gtk3-lang gtk3-schema gtk3-tools libgtk-3-0
typelib-1_0-Gtk-3_0

- Split API doc generation from main package using _multibuild,
libgtk3 itself only takes a fraction of the time to build.

==== kactivities-stats ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kactivities5 ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* EBN KActivites transfer protocol cleanup

==== karchive ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Port to QRegularExpression

==== kauth ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang libKF5AuthCore5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Install .pri file for KAuthCore

==== kbookmarks ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Simplify null check
* Clean up includes
* Remove unneeded moc include
* Remove superflous private
* Deprecate KonqBookmarkMenu and KonqBookmarkContextMenu
* Move classes only used by KonqBookmarkMenu together with it.
* Coding style fixes

==== kcalendarcore ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* autotests: Find perl executable on all platforms
* Add some test to ensure local time handling in recurrences.
* Fallback to system time zone on calendar creation with an invalid one.
* Memory Calendar: avoid code duplication
* Use QDate as key in mIncidencesForDate in MemoryCalendar
* Handle incidences in different time zones in MemoryCalendar.

==== kcmutils ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* [KCMultiDialog] Remove most special margins handling; it's done in
KPageDialog now
* KPluginSelector: use new KAboutPluginDialog
* Add guard for missing kirigami
* Disable the restore defaults button if the KCModule says so
* Have KCModuleProxy take care of the defaulted state
* Make KCModuleQml conform to the defaulted() signal

==== kcodecs ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kcompletion ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Refactor KHistoryComboBox::insertItems
* Add missing include for Qt 5.14 build

==== kconfig ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Don't use nullptr as flag. Make it compile against qt5.15
* Make sure to execute test with english lang
* Document Notifiers setting
* Only create a session config when actually restoring a session
* kwriteconfig: add delete option
* Add KPropertySkeletonItem
* Prepare KConfigSkeletonItem to allow inheriting its private class

==== kconfigwidgets ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* [KColorScheme] Make order of decoration colors match DecorationRole enum
* [KColorScheme] Fix mistake in NShadeRoles comment
* [KColorScheme/KStatefulBrush] Switch hardcoded numbers for enum items
* [KColorScheme] Add items to ColorSet and Role enums for the total number of
items
* Remove unused include
* KConfigWidgets: port away from KF5 deprecated API
* Register KKeySequenceWidget to KConfigDialogManager
* Adjust KCModule to also channel information about defaults

==== kcontacts ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Fix compile against qt5.15. a flags can't be nullptr

==== kcoreaddons ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Remove unused variable
* Deprecate KAboutData::fromPluginMetaData, now there is KAboutPluginDialog
* Add a descriptive warning when inotify_add_watch returned ENOSPC
* Add test for bug "bug-414360" it's not a ktexttohtml bug

==== kcrash ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* actually set a dependency between kcrashtest and test_crasher
* disable kcrashtest and its helper executable test_crasher on windows
* Disable execution of test_crasher, which enters an infinite loop on
Windows (one step from a fork bomb) and holds up the CI system infinitely

==== kdbusaddons ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Include API to generically implement --replace arguments

==== kdeclarative ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* EBN kdeclarative transfer protocol cleanup
* Adapt to change in KConfigCompiler
* MAke it compile without deprecated method
* make header and footer visible when they get content
* support qqmlfileselectors
* Allow to disable autosave behavior in ConfigPropertyMap

==== kded ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kded-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Remove kdeinit dependency from kded.

==== kdelibs4support ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Don't use nullptr/0 as flag
* Fix build: remove include of no longer used & provided kgesturemap_p.h
* Document how to port away from Kdeprint::createPrintDialog
* remove unused kgesturemap from kaction
* Docs: KIO::file_copy() is a more direct path for porting upload()

==== kdesu ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Use remove method directly

==== kdnssd-framework ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kdoctools ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Catalan Works: Add missing entitie

==== kemoticons ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kfilemetadata5 ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kfilemetadata5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* xattr: fix crash on dangling symlinks (kde#414227)
* disable writercollectiontest when taglib is not installed

==== kglobalaccel ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kguiaddons ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Minor qstring optimization

==== kholidays ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== khtml ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== ki18n ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Undeprecate I18N_NOOP2

==== kiconthemes ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Deprecate top-level UserIcon method, no longer used
* Replace for with maths with range for

==== kidletime ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kimageformats ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kimageformats-eps

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kinit ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kinit-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Finish cleaning up autostart-related code
* use more modern for construct

==== kio ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kio-core kio-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Too many changes since 5.64.0, only listing bugfixes:
* [KFileWidget] Avoid calling slotOk right after the url changed (kde#412737)
* KRun: don't override user preferred app when opening local *.*html and co.
files (kde#399020)
* [KPropertiesDialog] provide a way of showing the target of a symlink
(kde#413002)
* [Remote ioslave] Add Display Name to remote:/ (kde#414345)
* Fix HTTP proxy settings (kde#414346)
* [DeleteJob] Use a separate worker thread to run actual IO operation
(kde#390748)
* [KPropertiesDialog] Make creation date string mouse-selectable too
(kde#413902)

==== kirigami2 ====
Version update (5.64.1 -> 5.65.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Too many changes since 5.64.0, only listing bugfixes:
* Fix default card background (kde#414329)
* Make QmlComponentsPool one instance per engine (kde#414003)
* Vertically center left actions in ActionTextField (kde#413769)

==== kitemmodels ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Too many changes to list here.

==== kitemviews ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Add missing include for Qt 5.14 build

==== kjobwidgets ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kjs ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== knewstuff ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Too many changes since 5.64.0, only listing bugfixes:
* Fix i18n syntax to avoid runtime errors (kde#414498)
* Correctly set i18n arguments in one pass (kde#414060)
* Add OBS to screenrecorders (kde#412320)
* Give some more pretty feedback in NewStuff::Page while the Engine is
loading (kde#413439)
* Add an overlay component for item activity feedback (kde#413441)
* Only show DownloadItemsSheet if there's more than one download item
(kde#413437)
* Use the pointing hand cursor for the single-clickable delegates (kde#413435)
* Fix the header layouts for EntryDetails and Page components (kde#413433)

==== knotifications ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Add missing include for Qt 5.14 build
* Make the docs reflect that setIconName should be preferred
over setPixmap when possible
* Document configuration file path on Android
* Disable knotification_test, which starts D-Bus if it is not
already running, which on Windows causes the test to hang infinitely

==== knotifyconfig ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== konsole ====
Subpackages: konsole-part konsole-part-lang

- Add ColorScheme-fix-stack-use-after-scope.patch to fix wrong
background color with "Black on Random Light" color scheme
(boo#1159247, kde#415242)

==== kpackage ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kpackage-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Remove -std=c++0x flag and duplicated -Wall flag
* Remove commented cmake code
* support Qt File selectors in KPackage

==== kparts ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Remove more dead code as a consequence of nepomuk removal long ago
* Mark BrowserRun::simpleSave properly as deprecated
* BrowserOpenOrSaveQuestion: move AskEmbedOrSaveFlags enum from BrowserRun

==== kpeople5 ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kpeople5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Allow triggering sort from QML
* Port deprecated method
* Make it compile with qt >= 5.14 without deprecated method

==== kplotting ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Add missing include for Qt 5.14 build

==== kpty ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kross ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kross-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* loadLibrary: Use enum values to define what type of plugin we load

==== krunner ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Use ECMGenerateExportHeader to manage deprecated API better
* Include KDE CMake settings macros as first
* KRunner: port away from deprecated KF5 API
* Remove unused variable "package"

==== kservice ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kservice-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== ktexteditor ====
Version update (5.64.0 -> 5.65.0)
Subpackages: ktexteditor-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* KateModeManager::updateFileType(): validate modes and reload menu of the
status bar
* Remove unused include
* Remove KIconThemes use
* Verify modes of the session config file
* LGPLv2+ after ok by Svyatoslav Kuzmich
* restore files pre-format
* don't touch templates/

==== ktextwidgets ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Remove unused kregexpeditorinterface include
* Fix compilation for users of kregexpeditorinterface.h
* deprecate kregexpeditorinterface
* [kfinddialog] Remove usage of kregexpeditor plugin system

==== kunitconversion ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kwallet ====
Version update (5.64.0 -> 5.65.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== kwayland ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Make test more tolerant timing-wise
* Don't use nullptr to flags
* [server] Do not own dmabuf implementation
* [server] Make double-buffered properties in xdg-shell double-buffered
* Add missing include for Qt 5.14 build

==== kwidgetsaddons ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* [KSqueezedTextLabel] Add icon for "Copy entire text" action
* Remove unused signal we can use directly "signal(const QUrl&)
* Unify KPageDialog margin handling into KPageDialog itself (kde#413181)

==== kwindowsystem ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Adjust count after _GTK_FRAME_EXTENTS addition
* Add support for _GTK_FRAME_EXTENTS
* use modern for syntax

==== kxmlgui ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Unbreak last commit: still install normal headers as before
* Drop unused broken KGesture support
* Move comment to the right place
* Port foreach
* Port away from KTextWidgets
* Add KAboutPluginDialog, to be used with KPluginMetaData
* Enable -DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x053f00
* Also allow invoking session restoration logic when apps are manually
launched
* Add missing property to KKeySequenceWidget

==== libKF5ModemManagerQt ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== libKF5NetworkManagerQt ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== libcap ====

- Remove pam_cap (bsc#1150522) since this PAM module is a bad idea, security
wise.

==== libcontainers-common ====
Version update (20190923 -> 20191211)

- Update to image 5.0.0
- Clean up various imports primarily so that imports of packages that aren't
in the standard library are all in one section.
- Update to major version v5
- return resp error message
- copy.Image(): select the CopySystemImage image using the source context
- Add manifest list support
- docker: handle http 429 status codes
- allow for .dockercfg files to reside in non-home directories
- Use the correct module path in (make test-skopeo)
- Update to libpod 1.6.3
- Handling of the libpod.conf configuration file has seen major changes. Most
significantly, rootless users will no longer automatically receive a complete
configuration file when they first use Podman, and will instead only receive
differences from the global configuration.
- Initial support for the CNI DNS plugin, which allows containers to resolve
the IPs of other containers via DNS name, has been added
- Podman now supports anonymous named volumes, created by specifying only a
destination to the -v flag to the podman create and podman run commands
- Named volumes now support uid and gid options in --opt o=... to set UID and
GID of the created volume
- Update to storage 1.15.3
- overlay: allow storing images with more than 127 layers
- Lazy initialize the layer store
- tarlogger: drop state mutex

==== libgit2 ====
Version update (0.28.2 -> 0.28.4)

- libgit2 0.28.4:
* CVE-2019-1348: the fast-import stream command "feature
export-marks=path" allows writing to arbitrary file paths. As
libgit2 does not offer any interface for fast-import, it is not
susceptible to this vulnerability. (boo#1158785)
* CVE-2019-1349: by using NTFS 8.3 short names, backslashes or
alternate filesystreams, it is possible to cause submodules to
be written into pre-existing directories during a recursive
clone using git. As libgit2 rejects cloning into non-empty
directories by default, it is not susceptible to this
vulnerability. (boo#1158787)
* CVE-2019-1350: recursive clones may lead to arbitrary remote
code executing due to improper quoting of command line
arguments. As libgit2 uses libssh2, which does not require us
to perform command line parsing, it is not susceptible to this
vulnerability. (boo#1158788)
* CVE-2019-1351: Windows provides the ability to substitute
drive letters with arbitrary letters, including multi-byte
Unicode letters. To fix any potential issues arising from
interpreting such paths as relative paths, we have extended
detection of DOS drive prefixes to accomodate for such cases.
(boo#1158790)
* CVE-2019-1352: by using NTFS-style alternative file streams for
the ".git" directory, it is possible to overwrite parts of the
repository. While this has been fixed in the past for Windows,
the same vulnerability may also exist on other systems that
write to NTFS filesystems. We now reject any paths starting
with ".git:" on all systems. (boo#1158790)
* CVE-2019-1353: by using NTFS-style 8.3 short names, it was
possible to write to the ".git" directory and thus overwrite
parts of the repository, leading to possible remote code
execution. While this problem was already fixed in the past for
Windows, other systems accessing NTFS filesystems are
vulnerable to this issue too. We now enable NTFS protecions by
default on all systems to fix this attack vector. (boo#1158791)
* CVE-2019-1354: on Windows, backslashes are not a valid part of
a filename but are instead interpreted as directory separators.
As other platforms allowed to use such paths, it was possible
to write such invalid entries into a Git repository and was
thus an attack vector to write into the ".git" dierctory. We
now reject any entries starting with ".git" on all systems.
(boo#1158792)
* CVE-2019-1387: it is possible to let a submodule's git
directory point into a sibling's submodule directory, which may
result in overwriting parts of the Git repository and thus lead
to arbitrary command execution. As libgit2 doesn't provide any
way to do submodule clones natively, it is not susceptible to
this vulnerability. Users of libgit2 that have implemented
recursive submodule clones manually are encouraged to review
their implementation for this vulnerability. (boo#1158793)
- libgit2 0.28.3:
* A carefully constructed commit object with a very large number
of parents may have lead to out-of-bounds writes or potential
denial of service (boo#1158981)

==== libselinux-bindings ====

- Added swig4_moduleimport.patch to prevent import errors due to
SWIG 4

==== libvirt ====
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- virt-create-rootfs: add SLE 15 and SLE 12 service packs support
bsc#1154093

==== man-pages-ja ====
Version update (20181215 -> 20191215)

- version update to 20191215
* added and improved manual pages

==== moonjit ====

- Ignore make check error for PowerPC until upstream solved issue
https://github.com/moonjit/moonjit/issues/40
- do the same for %arm rather than to disable all %check.
- Disable %check on %arm until the following issue is fixed:
https://github.com/moonjit/moonjit/issues/9
- Use %_lib

==== nodejs12 ====
Version update (12.13.1 -> 12.14.0)
Subpackages: nodejs12-devel npm12

- Update to LTS release 12.14.0:
* deps: update npm to 6.13.4 fixing an arbitrary path overwrite
and access via "bin" field (bsc#1159352, CVE-2019-16777,
CVE-2019-16776, CVE-2019-16775)
- refreshed: fix_ci_tests.patch versioned.patch

==== openblas_pthreads ====

- Add gcc10-Support-two-digit-version-numbers-in-gcc-version-che.patch
in order to fix boo#1158727.

==== oxygen5-icon-theme ====
Version update (5.64.0 -> 5.65.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* EBN cleanup of autotests transfer protocol
* Symlink microphone to audio-input-microphone on all sizes (kde#398160)

==== patchutils ====

- Drop xmlto dependency as it would introduce build cycle
- Modernise spec file

==== perl-Cpanel-JSON-XS ====
Version update (4.17 -> 4.18)

- updated to 4.18
see /usr/share/doc/packages/perl-Cpanel-JSON-XS/Changes
4.18 2019-12-13 (rurban)
- Add new method ->type_all_string (#156 by Pali).
When type_all_string is set then encode method produce stable deterministic
string types in result JSON.
This can be an alternative to Cpanel::JSON::XS::Type when having
deterministic output is required but string JSON types are enough for any
output.
- Move SvGETMAGIC() from encode_av() and encode_hv() to encode_sv()
(#156 by Pali)
- Add Math::BigInt and Math::BigFloat as recommended dependences
(#157 by Pali and Grinnz)

==== pidgin-sipe ====
Version update (1.24.0 -> 1.25.0)
Subpackages: libpurple-plugin-sipe libpurple-plugin-sipe-lang pidgin-plugin-sipe

- Update to version 1.25.0:
* Provide idle start time for a buddy.
* RTF support (incoming)
+ the code only extracts plain text from incoming RTF.
* Fix build with glib-2.0 >= 2.62.0.
* Inconsistent parsing of From:/To: headers.
* Raise BR telepathy-glib >= 0.24.0.
* Switch from GPLv2+ to SPDX identifier GPL-2.0-or-later.
- Drop openSUSE Leap 42.x support.

==== plasma-framework ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Too many changes to list here.

==== plymouth ====
Subpackages: libply-boot-client5 libply-splash-core5 libply-splash-graphics5
libply5 plymouth-dracut plymouth-plugin-label plymouth-plugin-label-ft
plymouth-plugin-two-step plymouth-scripts plymouth-theme-bgrt
plymouth-theme-spinner

- Avoid inconsistencies in library package names causing unresolvable
dependencies, replace all soversion occurences with a macro.

==== prison-qt5 ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- No code change since 5.64.0

==== procps ====
Version update (3.3.15 -> 3.3.16)

- Update to procps-ng-3.3.16
* library: Increment to 8:2:0
No removals or functions
Internal changes only, so revision is incremented.
Previous version should have been 8:1:0 not 8:0:1
* docs: Use correct symbols for -h option in free.1 Debian #898774
* docs: ps.1 now warns about command name length issue #101
* docs: install translated man pages issue #146
* pgrep: Match on runstate issue #109, Debian
#919381
* snice: Fix matching on pid merge #89
* top: can now exploit 256-color terminals issue #96
* top: preserves 'other filters' in configuration file issue #99
* top: can now collapse/expand forest view children issue #99
* top: parent %CPU time includes collapsed children
* top: improve xterm support for vim navigation keys issue #135
* top: avoid segmentation fault at program termination Redhat #1737552
- Port patches (mostly changed offsets of the hunks)
* procps-ng-3.3.10-fdleak.dif
* procps-ng-3.3.10-large_pcpu.patch
* procps-ng-3.3.10-slab.patch
* procps-ng-3.3.10-xen.dif
* procps-ng-3.3.8-bnc634840.patch
* procps-ng-3.3.8-petabytes.patch
* procps-ng-3.3.8-readeof.patch
* procps-ng-3.3.8-tinfo.dif
* procps-ng-3.3.8-vmstat-terabyte.dif
* procps-v3.3.3-read-sysctls-also-from-boot-sysctl.conf-kernelversion.diff
- Delete patches now upstream
* procps-ng-3.3.15-typo.patch
* procps-ng-3.3.8-top.1.diff
- Add aptch procps-ng-3.3.16-comm_len.patch
* "ps -C" does not allow anymore an argument longer than 15
characters (bsc#1158830)

==== purpose ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* include the cmake command we are about to use

==== qemu ====
Version update (4.1.93 -> 4.2.0)
Subpackages: qemu-arm qemu-block-curl qemu-block-dmg qemu-block-gluster
qemu-block-iscsi qemu-block-nfs qemu-block-rbd qemu-block-ssh qemu-extra
qemu-guest-agent qemu-ipxe qemu-ksm qemu-kvm qemu-lang qemu-microvm qemu-ppc
qemu-s390 qemu-seabios qemu-sgabios qemu-tools qemu-ui-curses qemu-ui-gtk
qemu-ui-sdl qemu-ui-spice-app qemu-vgabios qemu-vhost-user-gpu qemu-x86

- Update to v4.2.0: See http://wiki.qemu.org/ChangeLog/4.2
Take note that ongoing feature deprecation is tracked at both
http://wiki.qemu-project.org/Features/LegacyRemoval and in
Appendix B of the qemu-doc.* files installed with the qemu package
Some noteworthy changes:
* x86: Denverton, Snowridge, and Dhyana CPU models added
* x86: Latest version of all CPU models how have TSX (HLE and RTM)
disabled by default
* x86: Support for AVX512 BFloat16 extensions
* x86: VMX features exposed more accurately and controllably
* s390: TCG now implements IEP (Instruction Execution Protection)
* PowerPC: POWER8 and POWER9 non-virtualized machines separated out
* PowerPC: RTAS now comes from SLOF instead of QEMU itself
* PowerPC: Unplug of multifunction PCI devices now unplugs the
whole slot, as in x86
* ARM: Support for >256 CPUs with KVM is fixed
* ARM: Memory hotplug now supported , when using UEFI, ACPI, for
virt machine type
* ARM: SVE support possuble now for KVM guests
* ARM: ACPI generic event device can now deliver powerdown event
* The backend device can be specified for a guest audio device
* virtio v1.1 packed virtqueues supported
* Socket based character device backends now support TCP keep-alive
* Use encryption library cipher mode facilities, allowing improved
performance for eg. AES-XTS encrption
* Misc block device improvements, esp. with nbd
- See the following few release-candidate changelog entries for
additional changes related to this release
- Switched package build to be out-of-tree
- Update to v4.2.0-rc5: See http://wiki.qemu.org/ChangeLog/4.2
- Update to v4.2.0-rc4: See http://wiki.qemu.org/ChangeLog/4.2
* Update the support documents used for SUSE SLE releases to cover
this qemu release

==== qemu-linux-user ====
Version update (4.1.93 -> 4.2.0)

- Update to v4.2.0: See http://wiki.qemu.org/ChangeLog/4.2
Take note that ongoing feature deprecation is tracked at both
http://wiki.qemu-project.org/Features/LegacyRemoval and in
Appendix B of the qemu-doc.* files installed with the qemu package
Some noteworthy changes:
* x86: Denverton, Snowridge, and Dhyana CPU models added
* x86: Latest version of all CPU models how have TSX (HLE and RTM)
disabled by default
* x86: Support for AVX512 BFloat16 extensions
* x86: VMX features exposed more accurately and controllably
* s390: TCG now implements IEP (Instruction Execution Protection)
* PowerPC: POWER8 and POWER9 non-virtualized machines separated out
* PowerPC: RTAS now comes from SLOF instead of QEMU itself
* PowerPC: Unplug of multifunction PCI devices now unplugs the
whole slot, as in x86
* ARM: Support for >256 CPUs with KVM is fixed
* ARM: Memory hotplug now supported , when using UEFI, ACPI, for
virt machine type
* ARM: SVE support possuble now for KVM guests
* ARM: ACPI generic event device can now deliver powerdown event
* The backend device can be specified for a guest audio device
* virtio v1.1 packed virtqueues supported
* Socket based character device backends now support TCP keep-alive
* Use encryption library cipher mode facilities, allowing improved
performance for eg. AES-XTS encrption
* Misc block device improvements, esp. with nbd
- See the following few release-candidate changelog entries for
additional changes related to this release
- Switched package build to be out-of-tree
- Update to v4.2.0-rc5: See http://wiki.qemu.org/ChangeLog/4.2
- Update to v4.2.0-rc4: See http://wiki.qemu.org/ChangeLog/4.2
* Update the support documents used for SUSE SLE releases to cover
this qemu release

==== qqc2-desktop-style ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Fix typo in name of installed CMake Config: Deskop->Desktop
* Make it compile against qt5.14 without deprecated method
* [TabBar] Use window color instead of button color (kde#413311)
* bind enabled properties to the view enabled
* [ToolTip] Base timeout on text length
* [ComboBox] Don't dim Popup
* [ComboBox] Don't indicate focus when popup is open
* [ComboBox] Follow focusPolicy

==== rubygem-actioncable-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-actionmailbox-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-actionmailer-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-actionpack-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* Fix possible information leak / session hijacking vulnerability.
The ActionDispatch::Session::MemcacheStore is still vulnerable given it
requires the
gem dalli to be updated as well.
(CVE-2019-16782)

==== rubygem-actiontext-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-actionview-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-activejob-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-activemodel-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-activerecord-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-activestorage-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-activesupport-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-rack ====
Version update (2.0.7 -> 2.0.8)

- updated to version 2.0.8
* CVE-2019-16782: Possible information leak / session hijack vulnerability

==== rubygem-rails-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-railties-6.0 ====
Version update (6.0.2 -> 6.0.2.1)

- updated to version 6.0.2.1
* no changes

==== rubygem-rubocop ====
Version update (0.77.0 -> 0.78.0)

- New upstream release 0.78.0
[#]## New features
* [#7528](https://github.com/rubocop-hq/rubocop/pull/7528): Add new
`Lint/NonDeterministicRequireOrder` cop. ([@mangara][])
* [#7559](https://github.com/rubocop-hq/rubocop/pull/7559): Add
`EnforcedStyleForExponentOperator` parameter to
`Layout/SpaceAroundOperators` cop. ([@khiav223577][])
[#]## Bug fixes
* [#7530](https://github.com/rubocop-hq/rubocop/issues/7530): Typo in
`Style/TrivialAccessors`'s `AllowedMethods`. ([@movermeyer][])
* [#7532](https://github.com/rubocop-hq/rubocop/issues/7532): Fix an error for
`Style/TrailingCommaInArguments` when using an anonymous function with
multiple line arguments with `EnforcedStyleForMultiline:
consistent_comma`. ([@koic][])
* [#7534](https://github.com/rubocop-hq/rubocop/issues/7534): Fix an incorrect
autocorrect for `Style/BlockDelimiters` cop and
`Layout/SpaceBeforeBlockBraces` cop with `EnforcedStyle: no_space` when
using multiline braces. ([@koic][])
* [#7231](https://github.com/rubocop-hq/rubocop/issues/7231): Fix the exit
code to be `2` rather when `0` when the config file contains an unknown
cop. ([@jethroo][])
* [#7513](https://github.com/rubocop-hq/rubocop/issues/7513): Fix abrupt error
on autocorrecting with `--disable-uncorrectable`. ([@tejasbubane][])
* [#7537](https://github.com/rubocop-hq/rubocop/issues/7537): Fix a false
positive for `Layout/SpaceAroundOperators` when using a Rational literal
with `/` (e.g. `2/3r`). ([@koic][])
* [#7029](https://github.com/rubocop-hq/rubocop/issues/7029): Make
`Style/Attr` not flag offense for custom `attr` method. ([@tejasbubane][])
* [#7574](https://github.com/rubocop-hq/rubocop/issues/7574): Fix a corner
case that made `Style/GuardClause` crash. ([@buehmann][])
[#]## Changes
* [#7514](https://github.com/rubocop-hq/rubocop/pull/7514): Expose correctable
status on offense and in formatters. ([@tyler-ball][])
* [#7542](https://github.com/rubocop-hq/rubocop/pull/7542): **(Breaking)**
Move `LineLength` cop from `Metrics` department to `Layout`
department. ([@koic][])

==== rubygem-thor ====
Version update (1.0.0 -> 1.0.1)

- updated to version 1.0.1
* Fix thor when `thor/base` and `thor/group` are required without `thor.rb`.
* Handle relative source path in `create_link`.

==== sendmail ====
Subpackages: libmilter1_0

- BuildRequire pkgconfig(libsystemd) instead of systemd-devel:
Allow OBS to shortcut through the -mini flavors.

==== solid ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* [udisks2] fix media change detection for external optical drives
(kde#394348)

==== sonnet ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Rename signal for avoiding overload signal
* Disable ispell backend with mingw
* fix windows compile
* Implement ISpellChecker backend for Windows >= 8
* Basic cross-compiling support for parsetrigrams
* no trigrams for cross compiling at the moment, like before
* embed trigrams.map into shared library

==== spamassassin ====
Version update (3.4.2 -> 3.4.3)
Subpackages: perl-Mail-SpamAssassin

- remove old (compiled) rules in /var/lib/spamassassin directory
after package upgrade and remove entirely upon package removal
- add BuildRequires for perl(Archive::Zip) and perl(IO::String)
- update spamassassin to 3.4.3
* There is one new plugin (disabled by default)
OLEVBMacro - Detects both OLE macros and VB code inside Office
documents
* Two CVE security bug fixes are included in this release
CVE-2019-12420 for Multipart Denial of Service Vulnerability
CVE-2018-11805 for nefarious CF files can be configured to
run system commands without any output or errors
* Safer and faster scanning of large emails using
body_part_scan_size and rawbody_part_scan_size settings.
* New tflag "nosubject" for 'body' rules, to stop matching the
Subject header which is part of the body text.
* Security updates include deprecation of the unsafe sa-update
'--allowplugins' option, which now prints a warning that
'--reallyallowplugins' is required to use it.
- Increase maximum size for spampd to 7168

==== sudo ====

- Move pam.d/sudo* files to /usr/etc

==== syndication ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Too many changes since 5.64.0, only listing bugfixes:
* Fix Bug 383381 - Getting the feed URL from a youtube channel
no longer works (kde#383381)

==== syntax-highlighting ====
Version update (5.64.0 -> 5.65.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Updates from CMake 3.16 final release
* reStructuredText: Fix inline literals highlighting preceding characters
* rst: Add support for standalone hyperlinks
* JavaScript: move keywords from TypeScript and other improvements
* JavaScript/TypeScript React: rename syntax definitions
* LaTeX: fix backslash delimiter in some keywords (kde#413493)

==== texlive ====
Subpackages: libkpathsea6 libsynctex2

- Add source-poppler0.83.0.patch: support poppler 0.83.

==== threadweaver ====
Version update (5.64.0 -> 5.65.0)

- Update to 5.65.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.65.0.php
- Changes since 5.64.0:
* Make it compile with qt5.15 without deprecated method
* Use URL with transport encryption

==== tpm2-0-tss ====
Version update (2.2.3 -> 2.3.0)
Subpackages: libtss2-esys0 libtss2-mu0 libtss2-sys0

- update to upstream version 2.3.0:
- changes in version 2.3.0:
- tss2-tctildr: A new library that helps with tcti initialization
Recommend to use this in place of custom tcti loading code now !
- tss2-rc: A new library that provides textual representations for return
codes
- Option to disable NIST-deprecated crypto (--disable-weak-crypto)
- Support Esys_TR_FromTPMPublic on sessions (for use in Esys_FlushContext)
- map-files with correct symbol lists for tss2-sys and tss2-esys
This may lead to unresolved symbols in linked applications
- Support to call Tss2_Sys_Execute repeatedly on certain errors
- Reduced RAM consumption in Esys due to Tss2_Sys_Execute change
- Automated session attribution clearing for esys (decrypt and encrypt)
per cmd
- Removed libtss2-mu from "Requires" field of libtss2-esys.pc
Needs to be added explicitely now
- All fixes from 2.2.1, 2.2.2 and 2.2.3
- Fixed SPDX License Identifiers
- Fixed Null-pointer problems in tcti-tbs
- Fixed Default locality for tcti-mssim set to LOC_0
- Fixed coverity and valgrind leaks detected in test programs (not library
code)

==== wicked ====
Version update (0.6.60 -> 0.6.61)
Subpackages: wicked-service

- version 0.6.61
- dracut: add initial cmdline parsing as a config source
- address: don't check hwaddr length if parsing as ARPHRD_VOID
- utils: added find and insert var array utils, cleanup
- client: add show-policy command calling policy generation
- client: initial support to generate a basic policy directly
- client: cleanup convert and show-config commands

==== wireguard ====
Version update (0.0.20191212_k5.3.12_1 -> 0.0.20191219_k5.3.12_2)

- Update to version 0.0.20191219
* wg-quick: linux: try both iptables(8) and nft(8) on teardown
* wg-quick: linux: use already configured addresses instead of
in-memory
* compat: ipv6_dst_lookup_flow was backported to 5.3 and 5.4
* tools: adjust wg.8 syntax for consistency in COMMANDS section


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages