Mailinglist Archive: opensuse-factory (229 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20191214 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Mon, 16 Dec 2019 14:00:36 +0000
  • Message-id: <157650483620.20203.637161315335087258@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20191214

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
analitza (19.08.3 -> 19.12.0)
autoyast2 (4.2.21 -> 4.2.24)
blinken (19.08.3 -> 19.12.0)
bovo (19.08.3 -> 19.12.0)
cervisia (19.08.3 -> 19.12.0)
claws-mail
ffmpegthumbs (19.08.3 -> 19.12.0)
glibc
juk (19.08.3 -> 19.12.0)
k3b (19.08.3 -> 19.12.0)
kalgebra (19.08.3 -> 19.12.0)
kalzium (19.08.3 -> 19.12.0)
kanagram (19.08.3 -> 19.12.0)
kapptemplate (19.08.3 -> 19.12.0)
katomic (19.08.3 -> 19.12.0)
kblackbox (19.08.3 -> 19.12.0)
kblocks (19.08.3 -> 19.12.0)
kbounce (19.08.3 -> 19.12.0)
kbreakout (19.08.3 -> 19.12.0)
kbruch (19.08.3 -> 19.12.0)
kcachegrind (19.08.3 -> 19.12.0)
kcron (19.08.3 -> 19.12.0)
kde-print-manager (19.08.3 -> 19.12.0)
kdeedu-data (19.08.3 -> 19.12.0)
kdegraphics-thumbnailers (19.08.3 -> 19.12.0)
kdenetwork-filesharing (19.08.3 -> 19.12.0)
kdf (19.08.3 -> 19.12.0)
kdiamond (19.08.3 -> 19.12.0)
kgeography (19.08.3 -> 19.12.0)
kget (19.08.3 -> 19.12.0)
kgoldrunner (19.08.3 -> 19.12.0)
khangman (19.08.3 -> 19.12.0)
kig (19.08.3 -> 19.12.0)
kimagemapeditor (19.08.3 -> 19.12.0)
kipi-plugins (19.08.3 -> 19.12.0)
kiriki (19.08.3 -> 19.12.0)
kiten (19.08.3 -> 19.12.0)
kjumpingcube (19.08.3 -> 19.12.0)
klines (19.08.3 -> 19.12.0)
kmahjongg (19.08.3 -> 19.12.0)
kmines (19.08.3 -> 19.12.0)
kmouth (19.08.3 -> 19.12.0)
kmplot (19.08.3 -> 19.12.0)
knavalbattle (19.08.3 -> 19.12.0)
knetwalk (19.08.3 -> 19.12.0)
kolf (19.08.3 -> 19.12.0)
kollision (19.08.3 -> 19.12.0)
kolourpaint (19.08.3 -> 19.12.0)
konquest (19.08.3 -> 19.12.0)
kpat (19.08.3 -> 19.12.0)
kqtquickcharts (19.08.3 -> 19.12.0)
kreversi (19.08.3 -> 19.12.0)
kshisen (19.08.3 -> 19.12.0)
ksirk (19.08.3 -> 19.12.0)
kspaceduel (19.08.3 -> 19.12.0)
ksquares (19.08.3 -> 19.12.0)
ksudoku (19.08.3 -> 19.12.0)
ksystemlog (19.08.3 -> 19.12.0)
kteatime (19.08.3 -> 19.12.0)
ktimer (19.08.3 -> 19.12.0)
ktouch (19.08.3 -> 19.12.0)
ktuberling (19.08.3 -> 19.12.0)
kturtle (19.08.3 -> 19.12.0)
kubrick (19.08.3 -> 19.12.0)
kwordquiz (19.08.3 -> 19.12.0)
libkdegames (19.08.3 -> 19.12.0)
libkeduvocdocument (19.08.3 -> 19.12.0)
libkmahjongg (19.08.3 -> 19.12.0)
libstorage-ng (4.2.27 -> 4.2.40)
libtasn1 (4.14 -> 4.15.0)
lokalize (19.08.3 -> 19.12.0)
lskat (19.08.3 -> 19.12.0)
mbox-importer (19.08.3 -> 19.12.0)
parley (19.08.3 -> 19.12.0)
pim-data-exporter (19.08.3 -> 19.12.0)
pim-sieve-editor (19.08.3 -> 19.12.0)
rubygem-actioncable-6.0 (6.0.1 -> 6.0.2)
rubygem-actionmailbox-6.0 (6.0.1 -> 6.0.2)
rubygem-actionmailer-6.0 (6.0.1 -> 6.0.2)
rubygem-actionpack-6.0 (6.0.1 -> 6.0.2)
rubygem-actiontext-6.0 (6.0.1 -> 6.0.2)
rubygem-actionview-6.0 (6.0.1 -> 6.0.2)
rubygem-activejob-6.0 (6.0.1 -> 6.0.2)
rubygem-activemodel-6.0 (6.0.1 -> 6.0.2)
rubygem-activerecord-6.0 (6.0.1 -> 6.0.2)
rubygem-activestorage-6.0 (6.0.1 -> 6.0.2)
rubygem-activesupport-6.0 (6.0.1 -> 6.0.2)
rubygem-autoprefixer-rails (9.7.2 -> 9.7.3)
rubygem-builder (3.2.3 -> 3.2.4)
rubygem-excon (0.69.1 -> 0.71.0)
rubygem-json (2.2.0 -> 2.3.0)
rubygem-puma (4.3.0 -> 4.3.1)
rubygem-rails-6.0 (6.0.1 -> 6.0.2)
rubygem-railties-6.0 (6.0.1 -> 6.0.2)
rubygem-thor (0.20.3 -> 1.0.0)
rubygem-zeitwerk (2.2.1 -> 2.2.2)
step (19.08.3 -> 19.12.0)
sweeper (19.08.3 -> 19.12.0)
umbrello (19.08.3 -> 19.12.0)
yakuake (19.08.3 -> 19.12.0)
yast2 (4.2.34 -> 4.2.47)
yast2-add-on (4.2.8 -> 4.2.13)
yast2-bootloader (4.2.11 -> 4.2.13)
yast2-country (4.2.6 -> 4.2.10)
yast2-installation (4.2.23 -> 4.2.25)
yast2-network (4.2.28 -> 4.2.35)
yast2-packager (4.2.32 -> 4.2.39)
yast2-pkg-bindings (4.2.2 -> 4.2.4)
yast2-samba-server (4.2.1 -> 4.2.2)
yast2-security (4.2.5 -> 4.2.8)
yast2-storage-ng (4.2.57 -> 4.2.62)
yast2-theme (4.2.5 -> 4.2.8)
yast2-trans (84.87.20191117.fb9cd042cd -> 84.87.20191209.9412cbcf88)
yast2-tune (4.2.1 -> 4.2.2)
yast2-update (4.2.10 -> 4.2.12)
yast2-users (4.2.5 -> 4.2.6)
yast2-ycp-ui-bindings (4.2.4 -> 4.2.6)

=== Details ===

==== analitza ====
Version update (19.08.3 -> 19.12.0)
Subpackages: analitza-lang libAnalitza5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Make it compile without deprecated method
* Make it compiles without deprecated methods
* plotter2d: remove duplicated code with the views
* Fix warning
* fix setting populated models to plot views
* graph2dmobile: add a notify field in the property
* Missing identifier on Graph3D

==== autoyast2 ====
Version update (4.2.21 -> 4.2.24)
Subpackages: autoyast2-installation

- Allow to run autoupgrade on registered system with almost empty
profile (jsc#SLE-7101)
- 4.2.24
- Improve message when registration missing for autoupgrade with
online medium (jsc#SLE-7101)
- 4.2.23
- Using Y2Packager::Resolvable.any? and Y2Packager::Resolvable.find
in order to decrease the required memory (bsc#1132650, bsc#1140037).
- 4.2.22

==== blinken ====
Version update (19.08.3 -> 19.12.0)
Subpackages: blinken-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Add Icon to Executable
* Make it compile without kf5 deprecated methods
* it compile fine without deprecated method

==== bovo ====
Version update (19.08.3 -> 19.12.0)
Subpackages: bovo-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make It compile without kf5 deprecated methods
* Make it compiles against qt5.14
* Update KDE_APPLICATIONS_VERSION_MINOR
* Follow KDE_APPLICATIONS_VERSION

==== cervisia ====
Version update (19.08.3 -> 19.12.0)
Subpackages: cervisia-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* it compiles fine without kf5 deprecated methods
* Port setMargin to setContentsMargins
* Follow KDE_APPLICATIONS_VERSION
* Add override
* Get rid of deprecated methods

==== claws-mail ====
Subpackages: claws-mail-lang

- Add a test on build-time libetpan version to require the proper
version at run-time (boo#1157594)
- Move "Mark all read/unread" menu entries where they belong.
remove-MarkAll-from-message-menu.patch (claws#4278)
add-MarkAll-to-folder-menu.patch (claws#4278)

==== ffmpegthumbs ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ffmpegthumbs-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix minor issue found by EBN
* screenshot
* use a category which exists
* rename for spec compliance
* add an appstream file for use in kde.org/applications

==== glibc ====
Subpackages: glibc-32bit glibc-devel glibc-extra glibc-info glibc-locale
glibc-locale-base nscd

- prefer-map-32bit-exec.patch: rtld: Check __libc_enable_secure before
honoring LD_PREFER_MAP_32BIT_EXEC (CVE-2019-19126, bsc#1157292, BZ
[#25204])
- nsswitch.conf: add usrfiles for services, protocols, rpc, ethers
and aliases for /usr/etc move
- euc-kr-overrun.patch: Fix buffer overrun in EUC-KR conversion module
(BZ #24973)
- ldconfig-dynstr.patch: ldconfig: handle .dynstr located in separate
segment (bsc#1153149, BZ #25087)

==== juk ====
Version update (19.08.3 -> 19.12.0)
Subpackages: juk-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* taglib: Remove deprecated code.
* Port to QElapsedTimer
* Port some deprecated method
* Port setMargins -> setContentsMargins
* install notifier file in correct directory
* Consistency in About window: Use same URL as appdata file and unify some
wording
* Limit to one instance
* HiDPI support for slider

==== k3b ====
Version update (19.08.3 -> 19.12.0)
Subpackages: k3b-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Link to Qt5::Xml explicitly, the code uses QDomDocument.
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* kns: install knsrc file in the new recommended location (kde#409502)
* Replace deprecated methods
* Minor spelling and grammar fixes.
* Port some deprecated methods
* expose version to cmake
* Helper: Link to AuthCore instead of Auth

==== kalgebra ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kalgebra-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Make it compile against qt5.14
* Fix compilation with Qt 5.14
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Make it compiles against qt5.14
* Make it compiles without deprecated methods

==== kalzium ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kalzium-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Make it compile with qt5.14
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Remove outdated KUIT tags
* Make it compile without kf5 deprecated methods
* adding multiple decays and updated isotope information H-Na
* Make it compile without deprecated method
* Fix minor typo
* Port away from QRegExp to QRegularExpression
* Port away from KHTML

==== kanagram ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kanagram-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Get rid of deprecated qSort()

==== kapptemplate ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kapptemplate-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== katomic ====
Version update (19.08.3 -> 19.12.0)
Subpackages: katomic-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile against 5.15. This enum was unused
* Make it compile without kf5 deprecated method
* Make it compile without deprecated method
* Follow KDE_APPLICATIONS_VERSION

==== kblackbox ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kblackbox-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* Replace deprecated KFilterDev::device with KCompressionDevice in KBlackBox
* Follow KDE_APPLICATIONS_VERSION

==== kblocks ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kblocks-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile against qt5.15, This enum is unused
* Fix minor issues found by EBN
* Make it compile without kf5 deprecated method
* Remove Dependence on unistd.h and sys/time.h
* Follow KDE_APPLICATIONS_VERSION

==== kbounce ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kbounce-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* It compiles fine without deprecated method
* Fix links
* Get rid of deprecated QPainter::drawRoundRect()
* Follow KDE_APPLICATIONS_VERSION

==== kbreakout ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kbreakout-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix links
* Follow KDE_APPLICATIONS_VERSION

==== kbruch ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kbruch-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* it compiles fine without deprecated method
* Use directly kde_enable_exceptions
* Use QLatin1String and QLatin1Char when it's possible
* Use more conservative boundingRect() as horizontalAdvance was introduced in
Qt 5.11 only
* Get rid of obsolete width()

==== kcachegrind ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kcachegrind-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Port to QElapsedTimer (QTime::start/elapsed is deprecated)
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without deprecated method
* It done by default by ecm

==== kcron ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kcron-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Make it compiles without deprecated method
* use an icon which exists
* add extends
* Fix metainfo file (wrongly named)
* install appstream file for use on kde.org/applications

==== kde-print-manager ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kde-print-manager-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Fix crash when cups returns jobs with duplicate id (kde#326289)
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kdeedu-data ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== kdegraphics-thumbnailers ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles without deprecated method
* Fix compile warning
* add screenshot
* add appstream file for use on kde.org/applications and app stores

==== kdenetwork-filesharing ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdenetwork-filesharing-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* It compiles fine without deprecated methods
* add a appstream file for use on kde.org/applications

==== kdf ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdf-lang kwikdisk

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* QString::replace operates on the same object, no need to reassign
* It compiles fine without foreach

==== kdiamond ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdiamond-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* Make it compiles against qt5.14
* Add DesktopEntry
* Follow KDE_APPLICATIONS_VERSION

==== kgeography ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kgeography-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Russia districts: Fix Kaliningrad not being shown as part of Northwestern
(kde#414857)
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Port setMargins

==== kget ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kget-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== kgoldrunner ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kgoldrunner-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Make it compile without deprecated method
* Make it compile against freebsd
* Port deprecated signal
* Make it compiles against qt5.14
* It compiles fine without deprecated method
* Get rid of deprecated QSignalMapper() in KGoldRunner
* Get rid of deprecated shortDayName()
* Follow KDE_APPLICATIONS_VERSION

==== khangman ====
Version update (19.08.3 -> 19.12.0)
Subpackages: khangman-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use nullptr here
* It compiles fine without deprecated method
* Reorder to avoid warnings

==== kig ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kig-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Port away from deprecated QWheelEvent API.
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix warnings "implicitly-declared Rect& Rect::operator=(const Rect&) is
deprecated" from GCC 9
* Try to fix Python 3 build
* Port deprecated enum
* Goniometry use default provided copy constructor and assignment operator
* Remove unused HierarchyImp::setData
* Follow KDE_APPLICATIONS_VERSION
* Port to angleDelta().y()
* It compiles fine without deprecated method
* Remove unused cmake variable
* Get rid of obsolete qSort()

==== kimagemapeditor ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kimagemapeditor-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Follow KDE_APPLICATIONS_VERSION
* QFileInfo::exists is documented to be faster
* Remove unused variables
* Port away from deprecated methods
* Add override
* Fix build with cmake < 3.12
* Move preview from khtml to qwebengine
* Move xmlgui files into qrc files to be able to run without installing
* remove unused code

==== kipi-plugins ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kipi-plugins-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Enable QT_NO_URL_CAST_FROM_STRING and fix compilation
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix typo found by Iñigo Salvador Azurmendi

==== kiriki ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kiriki-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Port deprecated method (make it compile without deprecated method qt5.14)

==== kiten ====
Version update (19.08.3 -> 19.12.0)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Get rid of several compiler warnings
* Make it compiles against qt5.14
* Initialize some variable in class header directly
* Use nullptr + override
* It compiles fine without deprecated method
* Modernize cmake

==== kjumpingcube ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kjumpingcube-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Remove deprecated method
* Update the home page address

==== klines ====
Version update (19.08.3 -> 19.12.0)
Subpackages: klines-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile against qt5.15, This enum is unused
* Make it compile without kf5 deprecated methods
* Update the home page address

==== kmahjongg ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmahjongg-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* make it compile without deprecated methods
* Fix minor typos
* Add some docs about the Board Editor
* Get rid of deprecated availableGeometry()

==== kmines ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmines-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile against qt5.15, This enum is unused
* Make it compiles without kf5 deprecated methods
* Fix minor issues and typos found by EBN
* It compiles fine without deprecated methods
* Make it compile without deprecated method

==== kmouth ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmouth-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles without deprecated method
* Get rid of deprecated qSort and QModelIndex::child

==== kmplot ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmplot-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Center-align plot and header table
* Port some deprecated methods
* Add HiDPI support
* Remove foreach in KmPlot in favor of range-based loops
* Fix minor typos
* Implement third derivative and loosen the mesh a bit to calculate the
fourth. This should allow to calculate extrema for second derivative right.
(kde#304574)
* Make man DocBook XSL compatible

==== knavalbattle ====
Version update (19.08.3 -> 19.12.0)
Subpackages: knavalbattle-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* make it compile without deprecated methods
* Make it compile without deprecated methods

==== knetwalk ====
Version update (19.08.3 -> 19.12.0)
Subpackages: knetwalk-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles without kf5 deprecated methods

==== kolf ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kolf-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Remove unused function
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Don't install the kolfprivate lib (kde#413383)
* Fix kolflib_export
* It compiles fine without deprecated method
* Use https

==== kollision ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kollision-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* appdata: move the homepage away from projects.kde.org
* Make it compile against qt5.15, This enum is unused
* Make it compiles without kf5 deprecated methods
* Make it compiles against qt5.14

==== kolourpaint ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kolourpaint-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix minor issues found by EBN
* Properly set the cmake version
* Modernize
* Look at for removing kdelibs4support

==== konquest ====
Version update (19.08.3 -> 19.12.0)
Subpackages: konquest-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles without kf5 deprecated methods
* Make it compiles without deprecated method

==== kpat ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kpat-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* FcSolveSolver: cleanup ressources (kde#395624)
- Dropped patches, now upstream:
* FcSolveSolver-cleanup-ressources.patch

==== kqtquickcharts ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without deprecated method

==== kreversi ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kreversi-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles without kf5 deprecated methods
* Make it compile without deprecated method

==== kshisen ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kshisen-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* It compiles fine without deprecated method

==== ksirk ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ksirk-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Fix more nonsense if() statements
* Port away from deprecated API in Qt 5.14
* Fix long-standing nonsense in if() statements, discovered by a gcc warning
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Silence compiler warnings about spacer name duplication
* Compile with Qt versions < 5.13
* make it compile without deprecated methods
* Port some deprecated method
* Port some deprecated methods

==== kspaceduel ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kspaceduel-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Port away from deprecated QString::sprintf
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* Make it compiles without deprecated method

==== ksquares ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ksquares-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* It compiles fine without deprecated method

==== ksudoku ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ksudoku-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles against qt5.14
* It compiles fine without deprecated method
* Get rid of deprecated QSignalMapper

==== ksystemlog ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ksystemlog-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* Journald mode: handle the case when the journal can't be opened
* Fix some clang-tidy and clazy warnings.
* Fix filtering by priority for new log items.
* Improve settings window category icons
* Make it compiles against qt5.14
* Make it compile without deprecated method
- Remove obsolete version requirements

==== kteatime ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kteatime-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Remove deprecated method
* Remove unused includes
* Port from KPassivePopup to KNotification

==== ktimer ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ktimer-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== ktouch ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ktouch-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== ktuberling ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ktuberling-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Move to modern connect syntax
* Mark TopLevel::changeGameboard as final
* port to python3/pyqt5
* Make it compile without kf5 deprecated method
* Change to qt5.10.0 as it depends against kf5 5.55.0
* It compiles fine without deprecated method

==== kturtle ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kturtle-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without deprecated method
* Don't assign qstring as replace works on same element
* Fix some clazy warning
* Use more conservative boundingRect() as horizontalAdvance was introduced in
Qt 5.11 only
* Get rid of obsolete width()

==== kubrick ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kubrick-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* Make it compiles without deprecated method
* Make all action names translatable
* Get rid of deprecated QSignalMapper and width()

==== kwordquiz ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kwordquiz-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use URLs with transport encryption
* It compiles fine without deprecated method
* Close KWordQuiz documents before closing the app

==== libkdegames ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix minor typos
* Make it compile without kf5 deprecated method
* Add version too
* Make it compile without deprecated method
* Use STL equivalent of deprecated qCopy
* audio: Support loading of files from Qt embedded resources

==== libkeduvocdocument ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3
- Remove obsolete version requirements

==== libkmahjongg ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method

==== libstorage-ng ====
Version update (4.2.27 -> 4.2.40)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#689
- use ranks in graphviz output to ease readability (bsc#1149154)
- reduce test devicegraph to required information
- 4.2.40
- merge gh#openSUSE/libstorage-ng#688
- Add new callbacks for LUKS activation
- Bump version
- Add specialized Luks callbacks
- 4.2.39
- merge gh#openSUSE/libstorage-ng#687
- use correct size for btrfs resize command during shrink (bsc#1157762)
- 4.2.38
- merge gh#openSUSE/libstorage-ng#686
- extended some testcases to also check executed commands
- merged testsuite/actions into testsuite/dependencies
- added tests for shrinking btrfs
- extended tests
- extended and added testcases
- 4.2.37
- merge gh#openSUSE/libstorage-ng#685
- added testcases for growing btrfs
- check that all command and file mockups are used
- added testcases for growing and shrinking ext4
- added testcases for resizing filesystems
- 4.2.36
- merge gh#openSUSE/libstorage-ng#684
- list all devices in subvolume actions (bsc#1152523)
- consistent list of block devices in compound actions
- removed unneeded use of c_str
- updated explanations for translators
- show all block devices for action texts of btrfs subvolumes
- 4.2.35
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.34
- merge gh#openSUSE/libstorage-ng#683
- extended unit test (bsc#1135341)
- updated documentation (bsc#1149148)
- added internal check
- fixed typo
- 4.2.33
- merge gh#openSUSE/libstorage-ng#682
- merge gh#openSUSE/libstorage-ng#681
- Translated using Weblate (Danish) (bsc#1149754)
- Translated using Weblate (Estonian) (bsc#1149754)
- fixed handling of btrfs subvolumes with special (regex control)
characters in the path (bsc#1135341)
- 4.2.32
- merge gh#openSUSE/libstorage-ng#680
- fixed escaping of graphviz escString (bsc#1157916)
- 4.2.31
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.30
- merge gh#openSUSE/libstorage-ng#679
- use estimation from resize2fs for min size of ext4 (bsc#1149148)
- use 64bit feature forr max size of ext4
- separated parser for ntfsresize output
- added example programs
- added unit tests
- extended exception logging
- cleanup
- consistent naming of example programs
- changed path of resize2fs to /usr/sbin
- improved calculation of resize information
- 4.2.29
- merge gh#openSUSE/libstorage-ng#678
- Only join entries when path matches
- Select the most reasonable mount point
- Add unit tests
- Update version
- Bind mount workaround
- 4.2.28

==== libtasn1 ====
Version update (4.14 -> 4.15.0)
Subpackages: libtasn1-6 libtasn1-6-32bit

- libtasn1 4.15.0:
* The generated tree no longer contains ASN.1 built-in types
even if they are explicitly defined in the description.
Previously a warning was printed when these types were seen,
now they are ignored.
* Several fixes in ASN.1 definition parser, preventing several
crashes and leaks in the tools due to improper ASN.1.
* Switched to semantic versioning

==== lokalize ====
Version update (19.08.3 -> 19.12.0)
Subpackages: lokalize-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Fix alternative translation path building (kde#316924)
* Internationalize the default project name (kde#305677)
* Don?t disable the context menu for the source pane (kde#315462)
* Delete translation memory ?meta? scan jobs when switching projects
(kde#293790)

==== lskat ====
Version update (19.08.3 -> 19.12.0)
Subpackages: lskat-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile against qt5.15, This enum is unused
* Make it compile without kf5 deprecated method
* Make it compiles against qt5.14

==== mbox-importer ====
Version update (19.08.3 -> 19.12.0)
Subpackages: mbox-importer-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Add missing Q_REQUIRED_RESULT
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix hidpi support
* Add release version too

==== parley ====
Version update (19.08.3 -> 19.12.0)
Subpackages: parley-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* README: fix the homepage and a typo
* Make it compiles against qt5.14
* It compiles fine without deprecated method
* Modernize CMakeLists.txt
* Cleanup removed dependencies
* Remove unused KPassivePopup includes
* Remove as deprecated marked classes and functions
- Remove obsolete version requirements

==== pim-data-exporter ====
Version update (19.08.3 -> 19.12.0)
Subpackages: pim-data-exporter-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Add missing Q_REQUIRED_RESULT
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Import/export dkimsettingsrc
* Fix i18n()
* Fix hidpi support
* QString::remove operates on the same object, no need to reassign
* Add info about kde release version too.
* Allow to open file
* Add missing question sign
* Start to implement open file directly
* Add messagebox when we don't want to override file
- Remove obsolete version requirements

==== pim-sieve-editor ====
Version update (19.08.3 -> 19.12.0)
Subpackages: pim-sieve-editor-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Add missing Q_REQUIRED_RESULT
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix hidpi support
* Compare directly with QMargins
* Add info about kde release version too.

==== rubygem-actioncable-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* no changes

==== rubygem-actionmailbox-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* no changes

==== rubygem-actionmailer-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* Fix ActionMailer assertions don't work for parameterized mail with legacy
delivery job.
* bogdanvlviv*

==== rubygem-actionpack-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* Allow using mountable engine route helpers in System Tests.
* Chalo Fernandez*

==== rubygem-actiontext-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* no changes

==== rubygem-actionview-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* no changes

==== rubygem-activejob-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* Allow Sidekiq access to the underlying job class.
By having access to the Active Job class, Sidekiq can get access to any
`sidekiq_options` which
have been set on that Active Job type and serialize those options into
Redis.
https://github.com/mperham/sidekiq/blob/master/Changes.md#60
* Mike Perham*

==== rubygem-activemodel-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* no changes

==== rubygem-activerecord-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* Share the same connection pool for primary and replica databases in the
transactional tests for the same database.
* Edouard Chin*
* Fix the preloader when one record is fetched using `after_initialize`
but not the entire collection.
* Bradley Price*
* Fix collection callbacks not terminating when `:abort` is thrown.
* Edouard Chin*, *Ryuta Kamizono*
* Correctly deprecate `where.not` working as NOR for relations.
12a9664 deprecated where.not working as NOR, however
doing a relation query like `where.not(relation: { ... })`
wouldn't be properly deprecated and `where.not` would work as
NAND instead.
* Edouard Chin*
* Fix `db:migrate` task with multiple databases to restore the connection
to the previous database.
The migrate task iterates and establish a connection over each db
resulting in the last one to be used by subsequent rake tasks.
We should reestablish a connection to the connection that was
established before the migrate tasks was run
* Edouard Chin*
* Fix multi-threaded issue for `AcceptanceValidator`.
* Ryuta Kamizono*

==== rubygem-activestorage-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* no changes

==== rubygem-activesupport-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* Eager load translations during initialization.
* Diego Plentz*
* Use per-thread CPU time clock on `ActiveSupport::Notifications`.
* George Claghorn*

==== rubygem-autoprefixer-rails ====
Version update (9.7.2 -> 9.7.3)

- updated to version 9.7.3
* Update Can I Use data.

==== rubygem-builder ====
Version update (3.2.3 -> 3.2.4)

- updated to version 3.2.4
* no changelog found

==== rubygem-excon ====
Version update (0.69.1 -> 0.71.0)

- updated to version 0.71.0
* fix for leftover data with interrupted persistent connections

==== rubygem-json ====
Version update (2.2.0 -> 2.3.0)

- updated to version 2.3.0
see installed CHANGES.md

==== rubygem-puma ====
Version update (4.3.0 -> 4.3.1)

- updated to version 4.3.1
* Fix: a poorly-behaved client could use keepalive requests
to monopolize Puma's reactor and create a denial of service
attack (CVE-2019-16770)

==== rubygem-rails-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* Changes are in Rails's modules
https://github.com/rails/rails/releases/tag/v6.0.2

==== rubygem-railties-6.0 ====
Version update (6.0.1 -> 6.0.2)

- updated to version 6.0.2
* Fix the collision check for the scaffold generator.
* Ryan Robeson*

==== rubygem-thor ====
Version update (0.20.3 -> 1.0.0)

- updated to version 1.0.0
* Drop support to Ruby 1.8 and 1.9.
* Deprecate relying on default `exit_on_failure?`.
In preparation to make Thor commands exit when there is a failure we are
deprecating
defining a command without defining what behavior is expected when there is
a failure.
To fix the deprecation you need to define a class method called
`exit_on_failure?` returning
`false` if you want the current behavior or `true` if you want the new
behavior.
* Deprecate defining an option with the default value using a different type
as defined in the option.
* Allow options to be repeatable. See #674.

==== rubygem-zeitwerk ====
Version update (2.2.1 -> 2.2.2)

- updated to version 2.2.2
* `Zeitwerk::NameError#name` has the name of the missing constant now.

==== step ====
Version update (19.08.3 -> 19.12.0)
Subpackages: step-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Resolve problem with objinfo, examples, and tutorials installation when
there are several locales
* Port extractxml to Python 3 with minor typo fixes
* Fix Step infobrowser and examples localization
* Fix link to Coulomb's law Wikipedia page to enable clean extraction
* Add softbody to the resources
* Fix minor typos in tutorials
* Fix minor typos, add some information about springs and soft bodies
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Sort includes
* Port away from QRegExp to QRegularExpression
* i18n: fix extraction of objectinfo HTML files
* Port away from KHTML
* Add MIME type for Step files (kde#296317)

==== sweeper ====
Version update (19.08.3 -> 19.12.0)
Subpackages: sweeper-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== umbrello ====
Version update (19.08.3 -> 19.12.0)
Subpackages: umbrello-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Fix api issue in class ToolBarState in case UMLScene is constructed without
a view
* Add save/load unit test for class PreConditionWidget
* Fix 'Sequence diagram - on reload file - app crash when conditions are
added' (kde#414759)
* Apply quick fix to prevent crashing on loading extented testcase for
reproducing behaviour
* Handle "show property dialog" content menu entry for combined fragment and
precondition widgets
* Fix 'Missing property dialog entries in context menu for combined fragment
and precondition widgets' (kde#414778)
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Too many changes since 19.11.80, only listing bugfixes:
* Fix 'Crash on pasting a sequence diagram elements' (kde#414615)
* Fix 'No namespace creation when importing stack traces' (kde#414599)
* Fix 'Incorrect applying of an auto layout for spline line type' (kde#414568)
* Fix 'No control points are created for association lines in "spline"
layout default mode' (kde#414520)
* Fix 'Associations are sometime not addable in class diagram' (kde#409631)
* Fix of string includes in c++ code generator (kde#413569)
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, listing only bugfixes:
* Fix 'Classifier unit case not enabled' (kde#414044)
* Fix 'auto-generated getters and setters to atributes are private in
generated java classes' (kde#331655)
* Add customizable class variable prefix for c++ code generation (kde#57583)
* Add additional c++ code generation policies to fix unexpected code
generation (kde#413991)
* Fix 'Added points to an association do not display them by default'
(kde#413910)
* Fix 'For relationships, partially unsupported properties are displayed in
the properties dialog on the style page' (kde#413908)
* Fix 'Changes to the fill color of the head of a composition are not
displayed' (kde#413907)
* Implement 'Open file assigned to an artifact' (kde#410937)
* Add support for adding connected "required interfaces" (kde#403794)
* Add subsystem support to toolbar and context menu for component diagrams
(kde#410543)
* Fix 'Incorrect icon in toolbar for adding interfaces to component diagram'
(kde#410519)
* Add missing context menu entries for activity diagrams (kde#410479)

==== yakuake ====
Version update (19.08.3 -> 19.12.0)
Subpackages: yakuake-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Port away from deprecated overload of slideWindow
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Enable high DPI pixmaps (kde#407726)
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Minor qstring optimization + use isEmpty
* Get rid of deprecated qSort(), qFind(), and screenCount()

==== yast2 ====
Version update (4.2.34 -> 4.2.47)
Subpackages: yast2-logs

- Add backward compatible hash accessors to Resolvable which solve
several crashes (related to bsc#1132650 and bsc#1140037)
- 4.2.47
- Use 70-yast.conf instead of 30-yast.conf to write YaST settings
under /etc/sysctl.d (related to jsc#SLE-9077).
- 4.2.46
- Do not crash while reading the product info (related to
bsc#1132650 and bsc#1140037).
- 4.2.45
- Do not crash when no base product is found (related to
bsc#1132650 and bsc#1140037).
- 4.2.44
- Using Y2Packager::Resolvable.any? and Y2Packager::Resolvable.find
in order to decrease the required memory (bsc#1132650,
bsc#1140037).
- 4.2.43
- Network: drop support for obsolete network device types
(jsc#SLE-7753)
- 4.2.42
- Use /etc/login.defs.d/70-yast.defs to write login.defs
values that are overridden by YaST (related to bsc#1155735).
- 4.2.41
- add is_wsl function to detect wsl (boo#1154962)
- 4.2.40
- bsc#1155735, bsc#1157541:
- Read /usr/etc/login.defs.
- Write login.defs configuration to /etc/login.defs.d/.
- 4.2.39
- bnc#1157532
- do not modify /etc/sysctl.conf in inst-sys as it is on r/o
filesystem
- 4.2.38
- Linuxrc: Ensure the new opened SCR instace is closed when reading
the /etc/install.inf file (bsc#1122493, bsc#1157476)
- 4.2.37
- Ensure /etc/install.inf is not read from the target system but
from the local one. (bsc#1122493, bsc#1157476)
- 4.2.36
- Do not try to find licenses in the installation medium when they
have been already downloaded from SCC (bsc#1153326).
- 4.2.35

==== yast2-add-on ====
Version update (4.2.8 -> 4.2.13)

- Added needed requriments to vendor.rb (bsc#1158436).
- 4.2.13
- Do not offer add-ons on the Full medium when the system is
registered (jsc#SLE-7101)
- 4.2.12
- Fixed crash when cloning the system (bsc#1158247)
- 4.2.11
- Using Y2Packager::Resolvable.any? and Y2Packager::Resolvable.find
in order to decrease the required memory (bsc#1132650,
bsc#1140037).
- 4.2.10
- Handle correctly the user input when going back (bsc#1156528)
- 4.2.9

==== yast2-bootloader ====
Version update (4.2.11 -> 4.2.13)

- Abort the execution when the module run without enough
permissions (related to bsc#1137688).
- 4.2.13
- Improved detection of the root filesystem in non-standard
btrfs configurations (bsc#1151748, bsc#1124581).
- If there is no file system mounted in "/" or "/boot", report the
error and quit instead of crashing.
- 4.2.12

==== yast2-country ====
Version update (4.2.6 -> 4.2.10)
Subpackages: yast2-country-data

- Improve detection of Windows system (related to bsc#1135341).
- 4.2.10
- AutoYaST keyboard: Do not crash if no language and keyboard
sections have been defined (bsc#1158119).
- 4.2.9
- Bring back the agent to set the console font, deleted during the
keyboard module refactorization (bsc#1156896).
- 4.2.8
- Refactoring complete keyboard workflow.
- Main parts have been done by -Joaquín Yeray Martín de la Nuez-
in a GSoC project:
https://github.com/openSUSE/mentoring/issues/79
- Checked also CLI suppot (bsc#1142957).
- 4.2.7

==== yast2-installation ====
Version update (4.2.23 -> 4.2.25)

- Using Y2Packager::Resolvable.any? and Y2Packager::Resolvable.find
in order to decrease the required memory (bsc#1132650,
bsc#1140037).
- 4.2.25
- Do not remove /etc/install.inf from inst-sys (bsc#1122493,
bsc#1157476).
- 4.2.24

==== yast2-network ====
Version update (4.2.28 -> 4.2.35)

- bnc#1158122
- fixed internal error when incorrectly querying for hostname in
AY's second stage
- 4.2.35
- Drop support for obsolete network device types (jsc#SLE-7753)
- 4.2.34
- Fix wireless mode and auth_mode initialization (bsc#1157394)
- 4.2.33
- Added a special type for the "Unknown" interfaces omitting them
from the interfaces list (bsc#1156285)
- 4.2.32
- Ignores invalid udev rules parts (bsc#1157361)
- 4.2.31
- Firsboot dhcp: Ensure the network configuration has been read
before trying to configure it by dhcp (bsc#1157429)
- 4.2.30
- bnc#1153198, fate#319639
- implemented proper hostname setup in installation for the new
backend
- 4.2.29

==== yast2-packager ====
Version update (4.2.32 -> 4.2.39)

- Speed up product renames calculation (bsc#1157926).
- 4.2.39
- AY Export: Exporting product_dir into the configuration file.
(bsc#1158450)
- 4.2.38
- Allow to override medium type to allow to upgrade registered
system with Full medium (jsc#SLE-7101)
- 4.2.37
- Moved resolvable class to yast2 package (bsc1140037).
- 4.2.36
- Fix a typo in the "Extension and Module Selection" screen
(bsc#1157789).
- 4.2.35
- Show beta warning only once (bsc#1156629).
- 4.2.34

==== yast2-pkg-bindings ====
Version update (4.2.2 -> 4.2.4)

- Include the "deps" resolvable property even when it is empty
(bsc#1159120).
- 4.2.4
- Fixed Pkg.Resolvables() to return the license text when requested
(bsc#1158247)
- 4.2.3

==== yast2-samba-server ====
Version update (4.2.1 -> 4.2.2)

- Fix failing Samba.GetServiceStatus old testsuite forcing and
import of 'Directory' (bsc#1155923)
- 4.2.2

==== yast2-security ====
Version update (4.2.5 -> 4.2.8)

- Added to rnc file: sys_gid_max, sys_gid_min, sys_uid_max,
sys_uid_min, hibernate_system, kernel.sysrq, mandatory_services,
net.ipv4.ip_forward, net.ipv4.tcp_syncookies,
net.ipv6.conf.all.forwarding (bsc#1158301).
- 4.2.8
- bsc#1155735, bsc#1157541:
- Read /usr/etc/login.defs.
- Write login.defs configuration to /etc/login.defs.d/.
- 4.2.7
- Change default encryption method from DES to SHA512 (bsc#1157541,
CVE-2019-3700).
- 4.2.6

==== yast2-storage-ng ====
Version update (4.2.57 -> 4.2.62)

- Show device name when activating a LUKS device (related to
bsc#1125774).
- 4.2.62
- Generate encryption names according to the mount point of the
encryption device (bsc#1125774).
- 4.2.61
- Improve detection of Windows systems (related to bsc#1135341).
- 4.2.60
- Set passno to 2 for the ESP (bsc#1135523)
- 4.2.59
- Detect root mount point probed as inactive (e.g., as result of a
snapshot rollback without rebooting the system).
- Related to bsc#1124581.
- 4.2.58

==== yast2-theme ====
Version update (4.2.5 -> 4.2.8)
Subpackages: yast2-theme-breeze yast2-theme-oxygen

- Added a banner on the upper/right side of the YaST layout.
The label can be set by the environment variable YAST_BANNER
(jsc#SLE-9424).
- 4.2.8
- fixed contrast of highlighted text (bsc#1158009)
- 4.2.7
- updated the SLE installer theme (jsc#SLE-7684)
- 4.2.6

==== yast2-trans ====
Version update (84.87.20191117.fb9cd042cd -> 84.87.20191209.9412cbcf88)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20191209.9412cbcf88:
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Slovak)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 'registration'.
* New POT for text domain 'qt'.
* New POT for text domain 'autoinst'.
* New POT for text domain 'add-on'.
* Translated using Weblate (Albanian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* New POT for text domain 'registration'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (German)
* Translated using Weblate (Albanian)
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* New POT for text domain 'add-on'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* New POT for text domain 'country'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Finnish)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Chinese (China))
- Update to version 84.87.20191202.a8922b7f8d:
* Translated using Weblate (Danish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* New POT for text domain 'qt-pkg'.
* New POT for text domain 'qt'.
* New POT for text domain 'base'.
* New POT for text domain 'add-on'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Finnish)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 'users'.
* New POT for text domain 'update'.
* New POT for text domain 'tune'.
* New POT for text domain 'security'.
* New POT for text domain 'registration'.
* New POT for text domain 'packager'.
* New POT for text domain 'network'.
* New POT for text domain 'installation'.
* New POT for text domain 'control'.
* New POT for text domain 'bootloader'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* New POT for text domain 'storage'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* New POT for text domain 'packager'.
* New POT for text domain 'network'.
- Update to version 84.87.20191124.632f5dfaa3:
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Czech)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Estonian)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* New POT for text domain 'security'.
* New POT for text domain 'add-on'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* New POT for text domain 'storage'.
* New POT for text domain 'qt'.
* New POT for text domain 'bootloader'.
* Translated using Weblate (Estonian)
* Translated using Weblate (German)
* New POT for text domain 'registration'.
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* New POT for text domain 'network'.
* Translated using Weblate (Estonian)
* Translated using Weblate (Dutch)
* Translated using Weblate (Slovak)

==== yast2-tune ====
Version update (4.2.1 -> 4.2.2)

- Abort the execution when the bootloader cannot be read
(related to bsc#1137688).
- 4.2.2

==== yast2-update ====
Version update (4.2.10 -> 4.2.12)

- fix upgrade for online medium (bsc#1158056 and bsc#1157636)
- 4.2.12
- Using Y2Packager::Resolvable.any? and Y2Packager::Resolvable.find
in order to decrease the required memory (bsc#1132650,
bsc#1140037).
- 4.2.11

==== yast2-users ====
Version update (4.2.5 -> 4.2.6)

- bsc#1155735, bsc#1157541:
- Read /usr/etc/login.defs.
- Write login.defs configuration to /etc/login.defs.d/.
- 4.2.6

==== yast2-ycp-ui-bindings ====
Version update (4.2.4 -> 4.2.6)

- require correct libyui so version 11 (bsc#1132247)
- 4.2.6


< Previous Next >
Follow Ups