Mailinglist Archive: opensuse-factory (229 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20191213 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 15 Dec 2019 01:02:42 +0000
  • Message-id: <157637176230.8049.187791694263418598@go-agent-stagingbot-5>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20191213

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
akonadi-calendar (19.08.3 -> 19.12.0)
akonadi-calendar-tools (19.08.3 -> 19.12.0)
akonadi-contact (19.08.3 -> 19.12.0)
akonadi-import-wizard (19.08.3 -> 19.12.0)
akonadi-mime (19.08.3 -> 19.12.0)
akonadi-notes (19.08.3 -> 19.12.0)
akonadi-search (19.08.3 -> 19.12.0)
akonadi-server (19.08.3 -> 19.12.0)
akregator (19.08.3 -> 19.12.0)
ark (19.08.3 -> 19.12.0)
baloo5-widgets (19.08.3 -> 19.12.0)
calendarsupport (19.08.3 -> 19.12.0)
dolphin (19.08.3 -> 19.12.0)
dragonplayer (19.08.3 -> 19.12.0)
eventviews (19.08.3 -> 19.12.0)
grantleetheme (19.08.3 -> 19.12.0)
gstreamer-editing-services (1.16.1 -> 1.16.2)
gstreamer-plugins-libav (1.16.1 -> 1.16.2)
gstreamer-rtsp-server (1.16.1 -> 1.16.2)
gstreamer-validate (1.16.1 -> 1.16.2)
gwenview5 (19.08.3 -> 19.12.0)
incidenceeditor (19.08.3 -> 19.12.0)
kaccounts-integration (19.08.3 -> 19.12.0)
kaccounts-providers (19.08.3 -> 19.12.0)
kaddressbook (19.08.3 -> 19.12.0)
kalarmcal (19.08.3 -> 19.12.0)
kamera (19.08.3 -> 19.12.0)
kate (19.08.3 -> 19.12.0)
kcalc (19.08.3 -> 19.12.0)
kcalutils (19.08.3 -> 19.12.0)
kcharselect (19.08.3 -> 19.12.0)
kcolorchooser (19.08.3 -> 19.12.0)
kdav (19.08.3 -> 19.12.0)
kdepim-addons (19.08.3 -> 19.12.0)
kdepim-apps-libs (19.08.3 -> 19.12.0)
kdepim-runtime (19.08.3 -> 19.12.0)
kdialog (19.08.3 -> 19.12.0)
khelpcenter5 (19.08.3 -> 19.12.0)
kidentitymanagement (19.08.3 -> 19.12.0)
kimap (19.08.3 -> 19.12.0)
kio-extras5 (19.08.3 -> 19.12.0)
kio_audiocd (19.08.3 -> 19.12.0)
kitinerary (19.08.3 -> 19.12.0)
kldap (19.08.3 -> 19.12.0)
kleopatra (19.08.3 -> 19.12.0)
kmag (19.08.3 -> 19.12.0)
kmail (19.08.3 -> 19.12.0)
kmail-account-wizard (19.08.3 -> 19.12.0)
kmailtransport (19.08.3 -> 19.12.0)
kmbox (19.08.3 -> 19.12.0)
kmime (19.08.3 -> 19.12.0)
kmousetool (19.08.3 -> 19.12.0)
knotes (19.08.3 -> 19.12.0)
kompare (19.08.3 -> 19.12.0)
konsole (19.08.3 -> 19.12.0)
kontact (19.08.3 -> 19.12.0)
kontactinterface (19.08.3 -> 19.12.0)
kopete (19.08.3 -> 19.12.0)
korganizer (19.08.3 -> 19.12.0)
kpimtextedit (19.08.3 -> 19.12.0)
kpkpass (19.08.3 -> 19.12.0)
kruler (19.08.3 -> 19.12.0)
ksmtp (19.08.3 -> 19.12.0)
ktnef (19.08.3 -> 19.12.0)
kwalletmanager5 (19.08.3 -> 19.12.0)
libgravatar (19.08.3 -> 19.12.0)
libkcddb (19.08.3 -> 19.12.0)
libkcompactdisc (19.08.3 -> 19.12.0)
libkdcraw (19.08.3 -> 19.12.0)
libkdepim (19.08.3 -> 19.12.0)
libkexiv2 (19.08.3 -> 19.12.0)
libkgapi (19.08.3 -> 19.12.0)
libkipi (19.08.3 -> 19.12.0)
libkleo (19.08.3 -> 19.12.0)
libkomparediff2 (19.08.3 -> 19.12.0)
libksane (19.08.3 -> 19.12.0)
libksieve (19.08.3 -> 19.12.0)
mailcommon (19.08.3 -> 19.12.0)
mailimporter (19.08.3 -> 19.12.0)
messagelib (19.08.3 -> 19.12.0)
mobipocket (19.08.3 -> 19.12.0)
okular (19.08.3 -> 19.12.0)
pimcommon (19.08.3 -> 19.12.0)
python-gst (1.16.1 -> 1.16.2)
signon-kwallet-extension (19.08.3 -> 19.12.0)
spectacle (19.08.3 -> 19.12.0)
wireguard (0.0.20191205_k5.3.12_1 -> 0.0.20191212_k5.3.12_1)

=== Details ===

==== akonadi-calendar ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* fix find_dependency: fix version
* Prefer icons over pixmaps
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* QString::replace operates on the same object, no need to reassign
* Use new api
* Fix plugin name
* Fix qt version

==== akonadi-calendar-tools ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-calendar-tools-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* konsolekalendar.cpp - html export credit url
* Make it compile without kf5 deprecated methods
* Make it compile without deprecated methods

==== akonadi-contact ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== akonadi-import-wizard ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* QString::remove operates on the same object, no need to reassign
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Add release version too

==== akonadi-mime ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign

==== akonadi-notes ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== akonadi-search ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== akonadi-server ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Only build and install designer plugin if it's enabled
* akonadi: improve debug message in state() method
* Testrunner: wait until all jobs are done before aborting setup
* akonadi_control: announce new Resource once both services are registered
* Make itemmovetest more robust.
* Fix build with Qt 5.14
* Avoid KIO starting klauncher, as that can hang the CI
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== akregator ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akregator-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Make it compile with qt5.14
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Too many changes since 19.11.80, only listing bugfixes:
* Fix Bug 177511 - inline article view in new-opened-article
scrolls to "same" position as previous opened article in same feed
(kde#177511)
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Fix Bug 412182 - Missing date for new articles (kde#412182)

==== ark ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ark-lang libkerfuffle19

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Drop ark.cliexample debug category
* Update HACKING file
* Translate MIME type description
- Update to 19.11.80
* New feature release
- Too many changes to list here.
- Remove outdated minimum versions in spec

==== baloo5-widgets ====
Version update (19.08.3 -> 19.12.0)
Subpackages: baloo5-widgets-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* [UserMetaData] Shortcut attribute queries for the common case
* [baloo-widgets] Apply condensed date to file metadata properties
(kde#406832)
* Allow non-local directories to provide UDS_SIZE (kde#413091)
* Fix Windows support in FileMetaDataProvider::subDirectoriesCount
* Don't count hidden files in folder item count (kde#412396)
* Port setMargin
* Add missing include
* We depend against 5.58.0 which depends against qt5.11.0
* Unify inserting data between FileFetchJob and IndexedDataRetriever
* Do not display a buggy filesize for non local files

==== calendarsupport ====
Version update (19.08.3 -> 19.12.0)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Port away from deprecated BarIcon method
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Remove duplicate code (same code in korganizer and kdepim-addons)

==== dolphin ====
Version update (19.08.3 -> 19.12.0)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Fix build with Qt 5.14 RC (kde#414492)
* Correct invalid homepage URL (kde#414901)
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* fix(search): Fix baloo searchString parsing (kde#412952)
* Force dbus introspection on the Dolphin_1 object (kde#414402)
* Fix accessibility regression on the Dolphin Control button
* Fix dolphin homepage in the appstream metadata
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* [Status Bar] Remove file status Timer, add text update delay (kde#399267)
* When the selection is deselected, restart the keyboard search from the
beginning (kde#411538)
* Expose full set of script execution options in settings window (kde#371837)
* Fix wrong window titles (kde#389135)
* Add "Add to Places" action to file menu (kde#390757)
* [dolphin] Add an action to toggle the searchbar (kde#344617)
* Make non-empty textual columns come first in sorting (kde#410538)
* Middle-elide file/folder labels so the extension is always visible
(kde#404955)
* Correct "New Window" tooltip (kde#411215)
* Fix an issue with focus lost after closing terminal panel (kde#407979)
* Fix name grouping feature for cyrillic names (kde#406867)
* Fix an issue with a new tab focus (kde#407604)
- Refreshed patches:
* 0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch

==== dragonplayer ====
Version update (19.08.3 -> 19.12.0)
Subpackages: dragonplayer-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Properly expose the version to cmake
* Add ability to copy the URL of played media

==== eventviews ====
Version update (19.08.3 -> 19.12.0)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Don't use nullptr for flags
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Month View: background color computation for dark mode theme
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* month/monthitem.cpp - fix chronological sorting in day block (kde#232162)
* agenda/agenda.cpp - grid colors when not using system settings (kde#411608)
* src/month/monthscene.cpp - use QDate stringification
* month/monthscene.cpp - remove comma in year (in the title) (kde#412833)
* Prefer icon over pixmap, and QIcon::fromTheme over KIconLoader
* Use QLatin1String overload for QString::operator ==/!=
* Warning--
* Add metainfo.yaml to trigger API docs generation

==== grantleetheme ====
Version update (19.08.3 -> 19.12.0)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Add colorSetAlpha filter, so explicitly set the alpha value of a color
* Add support for KColorScheme
* Don't use qt 5.12 enum
* Increase version
* Add color and palette APIs for Grantlee
* Add dummy API docs, so these classes show up on api.kde.org
* Not necessary to assign paths if we don't add new path

==== gstreamer-editing-services ====
Version update (1.16.1 -> 1.16.2)
Subpackages: libges-1_0-0 typelib-1_0-GES-1_0

- Update to version 1.16.2:
+ Initialize debug categories before usage

==== gstreamer-plugins-libav ====
Version update (1.16.1 -> 1.16.2)

- Update to version 1.16.2:
+ avvidenc: Fix error propagation
+ avdemux: Fix segmentation fault if long_name is NULL
+ avviddec:
- Fix huge leak caused by circular reference
- Enforce allocate new AVFrame per input frame
+ avdec_mpeg2video (and probably more): Fix huge memory leak.
- Drop patches fixed upstream:
+ gst-libav-fix-mem-leak.patch
+ gst-libav-fix-segfault.patch

==== gstreamer-rtsp-server ====
Version update (1.16.1 -> 1.16.2)

- Update to version 1.16.2:
+ rtsp-media: Use lock in gst_rtsp_media_is_receive_only
+ rtsp-client:
- RTP Info when completed_sender
- Fix location uri-format by getting uri directly from context
instead

==== gstreamer-validate ====
Version update (1.16.1 -> 1.16.2)
Subpackages: libgstvalidate-1_0-0 typelib-1_0-GstValidate-1_0

- Update to version 1.16.2:
+ No changes, version bump only

==== gwenview5 ====
Version update (19.08.3 -> 19.12.0)
Subpackages: gwenview5-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Create additional subfolders if needed (e.g. when extra slashes in
FileNameFormater). (kde#237114)
* fix fractional scaling (kde#412738)

==== incidenceeditor ====
Version update (19.08.3 -> 19.12.0)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Don't use nullptr for flags
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make sure that mimeData is not null
* QString::remove operates on the same object, no need to reassign
* Use QLatin1String overload for QString::operator ==/!=
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Add missing override
* Insert ldap addresses
* Use new plugin
* Add dummy API docs, so these classes show up on api.kde.org
* Add clear button on lineedit + add "insert url" in incident editor

==== kaccounts-integration ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kaccounts-integration-lang libkaccounts1

- Add runtime dep on accounts-qml-module
- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kaccounts-providers ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kaccounts-providers-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* providers: move the twitter provider to disabled

==== kaddressbook ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kaddressbook-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Don't add a non-existent icon search path
* fix typo 'Pint' -> 'Print'
* Fix minor typos
* Add missing CMakeLists.txt
* Use the new offline documentation
* Adding new .docbook for KAddressBook, draft version (kde#409998)
* Fix hidpi support
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* QString::replace operates on the same object, no need to reassign
* Add info about kde release version too.

==== kalarmcal ====
Version update (19.08.3 -> 19.12.0)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kamera ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kamera-lang kio_kamera

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Minor optimization.
* Port deprecated methods + use override
* Use override keyword
* Patch from Petros Siligkounas
* Add arconfig
* Make it compile without deprecated method
* Remove unused include
* rename for spec compliance
* add appstream file for kde.org/applications and app stores

==== kate ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kate-lang kate-plugins

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Make the strings translatable, fix typo
* Fix translation of external tools (kde#181528)
* Fix: Do not translate KActionCollection identifier
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Read the user visible name of the default color scheme
* Fix tyop in find_package call
* Respect KF5_MIN_VER and QT_MIN_VER
* Search for KF5I18n and KF5DocTools
* Search for Qt5Widgets to make a version comparison work
- Dropped patches, now upstream:
* search-for-kf5i18n-kdoctools.patch
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* handle build path as relative to project path (kde#413306)
* disable ctags indexing per default (kde#412351)
* fix message extraction (kde#412358)
* External Tools: Support adding actions to toolbar (kde#261210)
* ensure view stack gets focus on startup (kde#412227)
* Added a line to set default sort order for the Symbolviewer. (kde#405895)
* allow ESC to be used as global application shortcut and still exit the
quick open (kde#409856)
* fix dbus session registration (kde#410742)
- Add upstream patch to fix build:
* search-for-kf5i18n-kdoctools.patch

==== kcalc ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kcalc-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* It compiles fine without kf5 deprecated method
* make sure the classes are known
* Add live conversions between numerical bases
* delete obsolete patch
* Use colorful icon for Colors category in settings window
* Don't assign qstring when we use replace as it works on same element

==== kcalutils ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Fix kcalutils-testincidenceformatter color
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.2:
* Make it compiles without deprecated methods
* Use new framework KF5CalendarCore
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Show class on api.kde.org

==== kcharselect ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kcharselect-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles against qt5.14
- Dropped patches, now upstream:
* 0001-Make-it-compiles-against-qt5.14.patch

==== kcolorchooser ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kcolorchooser-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* It compiles fine without foreach

==== kdav ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdav-lang libKPimKDAV5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Seems we need to disable HTTP cache cleaning too for avoiding klauncher
* Run KIO-based tests without the need for klauncher
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kdepim-addons ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdepim-addons-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Link with Qt5::Xml where QDomDocument is used
* Disable mReadAuthResultHeader for the moment
* Add missing Q_REQUIRED_RESULT
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Fix Bug 387598 - Send As ICalendar Address Selection has problems
(kde#387598)
* Use external itinerary extraction process (kde#409001)
* Fix Bug 410432 - Add Reminders to New Events (kde#410432)

==== kdepim-apps-libs ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdepim-apps-libs-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix minor issues found by EBN and typos
* Allow to debug sendlaterinfo
* Fix typo
* Remove Q_REQUIRED_RESULT here
* Remove unnecessary dependency on KF5::IconThemes
* Add dbus method for removing item
* Make all public classes show up on api.kde.org

==== kdepim-runtime ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdepim-runtime-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Don't use nullptr as flag value
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* IMAP resource: do not prompt for password with GSSAPI auth (kde#383279)
* Link to Qt5::Xml since this code uses QDomDocument.
* Sanity-check collection path before performing recursive deletion
* Set deprecation versions to Qt 5.13 and KF 5.63 for the release branch
- Dropped patches, now upstream:
* 0001-Sanity-check-collection-path-before-performing-recur.patch
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kdialog ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kdialog-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* KDialog: add --ok-label for sorry and detailedsorry
* It compiles fine without deprecated method
* Ignore some files
* Modernize CMakeLists.txt
* Use QLatin1String for QString::contains
* Honour geometry for kmessageboxes too.
* Handle --geometry in --inputbox, --imgbox, --imginputbox, --slider.
* Port to non-deprecated KWindowSystem::setMainWindow(). Requires KF 5.62.
* add a category and icon for kde.org/applications

==== khelpcenter5 ====
Version update (19.08.3 -> 19.12.0)
Subpackages: khelpcenter5-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Increase KF5 dep since it's using KDEClangFormat
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Port to non-deprecated KWindowSystem::setMainWindow(). Requires KF 5.62.
* Add KDEClangFormat cmake support
* It compiles fine without deprecated method
* Add an automatically managed "tweak" version number
* Bump the version number
* Remove unused includes

==== kidentitymanagement ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Check if 'cat' executable exists before using it
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Warn if emailsidentity we can't write in this config file
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Add dummy API docs, so these classes show up on api.kde.org
- Remove outdated version requirements

==== kimap ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kimap-lang libKF5IMAP5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile against qt5.15
* Warning--
* Port away from KTcpSocket to QSslSocket
* Use truncate directly

==== kio-extras5 ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Apply KIO's klauncher CI workaround here too
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* [Comic Thumbnailer] Add support for 7zip-compressed comic books (kde#410696)
- Dropped patches, now upstream:
* 0001-make-the-libssh-finder-ensure-the-new-ssh-target-is-.patch

==== kio_audiocd ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kio_audiocd-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compiles without deprecated method
* Port away from QRegExp to QRegularExpression
* use a valid category
* rename for spec compliance
* complete appstream file for kde.org/applications goodness

==== kitinerary ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Too many changes to list here.
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Update knowledge base databases from Wikidata
* Silence debug output
* Do not fail on DB tickets with VDV barcodes
* Make RegioJet date/time patterns more strict
* Fix nullptr dereference when PDF loading fails
* Add a RAII wrapper around Poppler's globalParams
* Make the Poppler version checking a bit more scalable
* Don't initialize MemoryCalendar with an invalid timezone
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kldap ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kldap-lang libKF5Ldap5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Remove unused includes
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated methods
* Make it compiles against qt5.14
* Make it compiles without foreach
* Use truncate directly
* Use chop directly

==== kleopatra ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kleopatra-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Fix version check for pgp cards (kde#411849)
- Remove outdated version requirements

==== kmag ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmag-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Remove a commented reference to projects.kde.org
* It compiles fine without deprecated methods
* It compiles fine without deprecated method
- Remove obsolete version requirements

==== kmail ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Don't use nullptr as flag
* Fix invalid fcc warning when we restore mail
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Show invalid fcc folder widget
* When we use "send again" make sure to assign FCC to current folder.
* honour notification inhibition by delaying reminders
* Add missing Q_REQUIRED_RESULT
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Fix improve notification message (kde#411992)
* Fix Bug 412904 - Provide option to hide menu bar in message view windows
(kde#412904)
- Remove obsolete version requirements

==== kmail-account-wizard ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmail-account-wizard-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix minor issues found by EBN and typos
* MAke it compile without kf5 deprecated methods
* Already initialized in header
* Fix Bug 411501 - Account wizard always shows busy indicator (kde#411501)
* Use QLatin1String overload for QString::operator ==/!=
* Add release version too

==== kmailtransport ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use QLatin1String overload for QString::operator ==/!=
* Add dummy API docs, so these classes show up on api.kde.org
* Add framework type for api.kde.org
* Fix API docs generation

==== kmbox ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== kmime ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmime-lang libKF5Mime5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Remove erroneous Q_REQUIRED_RESULT
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix variable name
* Remove warnings about ignoring return value of removeHeader()
* Port deprecated methods
* Use truncate directly
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign

==== kmousetool ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kmousetool-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Fix compilation error due to X11 #defines
- Dropped patches, now upstream:
* Fix-build-with-Qt-5_14.diff
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== knotes ====
Version update (19.08.3 -> 19.12.0)
Subpackages: knotes-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Make it compile against qt5.14
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Fix a warning string.
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* HACKING, README - update the url for the coding style doc
* Make it compile without deprecated methods
* Fix hidpi support
* Update email address
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Add info about kde release version too.

==== kompare ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kompare-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Enable HiDPI icon rendering

==== konsole ====
Version update (19.08.3 -> 19.12.0)
Subpackages: konsole-part konsole-part-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes to list here, only listing bugfixes:
* Fix tabs not indicating activity (kde#406828)
* Fix OSC sequence parsing (kde#231405)
* Add missing setFocusProxy() call in ViewManager (kde#411181)
* Start new splits in same directory as current session (kde#411332)
* Fix search bar placement (kde#405482)
* Add a "Do not ask again" option to close session dialog (kde#405481)
* Remove env variable KONSOLE_PROFILE_NAME (kde#406955)
* Do not allow adding duplicates in bookmarks (kde#408939)
- Dropped patches, now upstream:
* Fix-tabs-not-indicating-activity.patch

==== kontact ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kontact-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* kontact: simplify ksycoca-related startup code
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* HACKING - update location of coding style documentation
* Remove Kontact sidebar frame
* Fix hidpi support
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Add info about kde release version too.

==== kontactinterface ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Remove debug
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* kontactinterface: remove unused virtual method createDBUSInterface()
* Make it compile with last kf5
* Make it compile without kf5 deprecated methods
* Use QStyle to determine icon size

==== kopete ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kopete-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== korganizer ====
Version update (19.08.3 -> 19.12.0)
Subpackages: korganizer-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Fix usage flags
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Add missing Q_REQUIRED_RESULT
* korgac: honour notification inhibition by delaying reminders
* add missing Q_REQUIRED_RESULT
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kpimtextedit ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Only build and install designer plugin if it's enabled
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== kpkpass ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKPimPkPass5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH

==== kruler ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kruler-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.2:
* Make it compile without kf5 deprecated method
* Fix minor issue found by EBN
* Make it compiles without deprecated method
* It's time to increase qt version
* It compiles fine without foreach
* Remove unused includes
- Dropped patches, now upstream:
* 0001-Make-it-compiles-without-deprecated-method.patch

==== ksmtp ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use non-deprecated headers
* Port away from KTcpSocket to QSslSocket
* Fix SMTP login example to actually handle SSL errors
* Add dummy API docs, so these classes show up on api.kde.org
* Specify framework type for api.kde.org
- Remove obsolete version requirements

==== ktnef ====
Version update (19.08.3 -> 19.12.0)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use top level qt version
* fix find_dependency: fix version
- Remove obsolete version requirements

==== kwalletmanager5 ====
Version update (19.08.3 -> 19.12.0)
Subpackages: kwalletmanager5-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Port away from DesktopIcon()
* Initialize it before using qapp
* increase version as we depend against 5.56
* Helper: Link to AuthCore instead of Auth
- Remove obsolete version requirements

==== libgravatar ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Make it compile without kf5 deprecated method
* Compare directly from QMArgins
* Add dummy API docs, so these classes show up on api.kde.org
- Remove obsolete version requirements

==== libkcddb ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5Cddb5 libkcddb-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Compile without deprecated method
* Get rid of deprecated methods
- Remove obsolete version requirements

==== libkcompactdisc ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== libkdcraw ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== libkdepim ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Only build and install designer plugin if it's enabled
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== libkexiv2 ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== libkgapi ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Make it compile with last qt5.14
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Fix minor typo
* Fix comparison typo
* Cleanup and modernize the Calendar library codebase
* Add missing parameters to Permission related jobs and fix url typo.
* QString::remove operates on the same object, no need to reassign
* Use QLatin1String overload for QString::operator ==/!=
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Fix API docs generation

==== libkipi ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Port QString::null
- Remove obsolete version requirements

==== libkleo ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Replace an occurrence of projects.kde.org
* Fix minor issues found by EBN and typos
* Let Qt handle sub-window icons
* Make it compile without kf5 deprecated methods
* Use QLatin1String overload for QString::operator ==/!=
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Enable API docs generation
* Add tooltips for custom actions in keyapproval

==== libkomparediff2 ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3
- Remove obsolete version requirements

==== libksane ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5Sane5 libksane-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Use KF5_VERSION for ecm too
* Make it compiles without deprecated method
- Remove obsolete version requirements

==== libksieve ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libksieve-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Fix copy/paste error in previous commit
* Fix as David did in messagelib
* Make it compile against 5.14 beta3
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== mailcommon ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Move variable before attachmeent
* Fix Bug 414839 - Folder expiration not automatic (kde#414839)
* Don't use nullptr as flag value
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Link to Qt5::Xml explicitly in case KConfigGui stops doing it for us
* Only build and install designer plugin if it's enabled
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== mailimporter ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* QString::remove operates on the same object, no need to reassign
* Use QLatin1String in join/startswith/endsWith/contains + QString::replace
operates on the same object, no need to reassign
* Add dummy API docs, so these classes show up on api.kde.org
* Add framework type for api.kde.org
* Fix API docs generation
- Remove obsolete version requirements

==== messagelib ====
Version update (19.08.3 -> 19.12.0)
Subpackages: messagelib-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* fix split element
* Fix some autotest
* Fix autotest. Code for showing "we have external ref" was fixed
* Fetch DKIMResultAttribute too
* Make basicobjecttreeparsertest independent of host timezone
* Move mQcaInitializer directly in dkimmanagerkey. Not necessary to create
* Fix Bug 414825 - saving dialog does not propose a file name (kde#414825)
* Add new autotest. It will help us to port to qregularexpression
* Don't use nullptr as flag value
* Minor optimization
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Too many changes to list here.
- Update to 19.11.80
* New feature release
- Too many changes to list here.
- Remove obsolete version requirements

==== mobipocket ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Changes since 19.08.3:
* Mark functions with override
* add screenshot
* rename for spec compliance
* appstreamcli validate
* add appstream file for use on kde.org/applications and app stores

==== okular ====
Version update (19.08.3 -> 19.12.0)
Subpackages: okular-lang okular-spectre

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Increase version here too
* Increase version
* Update Appstream for new release
* Fix spurious dialogs in PickPointEngine (kde#409638)
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Remove 'yellow' word (kde#412890)
* Add "find in this document" to selection context menu (kde#408355)
* General improvements to stamp annotation (kde#370381)
- Remove obsolete version requirements

==== pimcommon ====
Version update (19.08.3 -> 19.12.0)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- Changes since 19.11.80:
* Only build and install designer plugin if it's enabled
- Update to 19.11.80
* New feature release
- Too many changes to list here.

==== python-gst ====
Version update (1.16.1 -> 1.16.2)

- Update to version 1.16.2:
+ No changes, version bump only.

==== signon-kwallet-extension ====
Version update (19.08.3 -> 19.12.0)

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- No code change since 19.11.90
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- No code change since 19.08.3

==== spectacle ====
Version update (19.08.3 -> 19.12.0)
Subpackages: spectacle-lang

- Update to 19.12.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/releases/19.12.0
- Changes since 19.11.90:
* Update Appstream for new release
* Fix issue preventing spectacle from opening
- Update to 19.11.90
* New feature release
* For more details please see:
* https://kde.org/announcements/releases/19.12-rc
- No code change since 19.11.80
- Update to 19.11.80
* New feature release
- Too many changes since 19.08.3, only listing bugfixes:
* Add new touch-friendly drag handlers (kde#371843)

==== wireguard ====
Version update (0.0.20191205_k5.3.12_1 -> 0.0.20191212_k5.3.12_1)

- Update to version 0.0.20191212
* socket: convert to ipv6_dst_lookup_flow for 5.5
* wg-quick: linux: add support for nft and prefer it
* wg-quick: linux: support older nft(8)
* global: fix up spelling
* main: remove unused include <linux/version.h>
- Update to 0.0.20191206
* chacha20poly1305: double check the sgmiter logic with test
* wg-quick: linux: ignore save warnings for iptables-nft
* wg-quick: linux: suppress more warnings on weird kernels
* wg-quick: linux: some iptables don't like empty lines
* crypto: use new assembler macros for 5.5
* chacha20poly1305: port to sgmitter for 5.5
* netlink: prepare for removal of genl_family_attrbuf in 5.5
- fix changelog for 0.0.20191205


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups