Mailinglist Archive: opensuse-factory (378 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20191121 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sat, 23 Nov 2019 00:01:41 +0000
  • Message-id: <157446730181.21408.9920234797217625121@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20191121

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
MozillaThunderbird (68.2.1 -> 68.2.2)
autoyast2 (4.2.13 -> 4.2.21)
build (20190923 -> 20191114)
dnsmasq
dpdk (18.11.2_k5.3.11_1 -> 18.11.3_k5.3.11_1)
elfutils
libstorage-ng (4.2.19 -> 4.2.27)
libwacom (0.32 -> 1.1)
libxmlb (0.1.11 -> 0.1.13)
libyui (3.8.2 -> 3.8.5)
libyui-ncurses (2.53.1 -> 2.53.2)
libyui-qt (2.51.1 -> 2.51.4)
nagios
ncurses
openssl (1.1.1c -> 1.1.1d)
openssl-1_1 (1.1.1c -> 1.1.1d)
perl-Apache-AuthCookie (3.27 -> 3.28)
perl-DateTime-TimeZone (2.37 -> 2.38)
perl-HTTP-Cookies (6.06 -> 6.07)
perl-Test-Simple (1.302168 -> 1.302169)
polkit-default-privs (13.2+20191015.280c25b -> 13.2+20191119.a36b458)
publicsuffix (20191025 -> 20191115)
qpdf (9.0.2 -> 9.1.0)
signon (8.59 -> 8.60)
supermin (5.1.18 -> 5.1.20)
ucode-intel (20191112 -> 20191115)
yast2 (4.2.30 -> 4.2.34)
yast2-installation (4.2.19 -> 4.2.23)
yast2-kdump (4.2.5 -> 4.2.6)
yast2-network (4.2.23 -> 4.2.28)
yast2-nfs-client (4.2.2 -> 4.2.3)
yast2-nfs-server (4.2.1 -> 4.2.2)
yast2-ntp-client (4.2.5 -> 4.2.6)
yast2-packager (4.2.30 -> 4.2.32)
yast2-pkg-bindings (4.2.0 -> 4.2.2)
yast2-ruby-bindings (4.2.3 -> 4.2.4)
yast2-samba-server (4.2.0 -> 4.2.1)
yast2-schema (4.2.5 -> 4.2.6)
yast2-storage-ng (4.2.51 -> 4.2.57)
yast2-trans (84.87.20191020.c721485b2e -> 84.87.20191117.fb9cd042cd)
yast2-update (4.2.7 -> 4.2.10)
yast2-ycp-ui-bindings (4.2.3 -> 4.2.4)

=== Details ===

==== MozillaThunderbird ====
Version update (68.2.1 -> 68.2.2)
Subpackages: MozillaThunderbird-translations-common

- Mozilla Thunderbird 68.2.2:
* fix age calculation in address book (bmo#1592536)
* fix column menu behavior in address book (bmo#1592393)

==== autoyast2 ====
Version update (4.2.13 -> 4.2.21)
Subpackages: autoyast2-installation

- Do not override all storage proposal settings when importing
values from the profile (boo#1156539).
- 4.2.21
- Handle renamed add-ons during auto upgrade (part of jsc#SLE-7101)
- 4.2.20
- report wrong type of param-list instead of crash (bsc#1143260)
- 4.2.19
- Fix autoinstallation on online medium (bsc#1156058)
- 4.2.18
- Update schema to support setting the encryption method through
the 'crypt_method' (related to jsc#SLE-7376).
- 4.2.17
- AutoYaST support for the Full installation medium
(jsc#SLE-7101)
- 4.2.16
- fix auto-adding required packages for autoyast sections (bsc#1153746)
- don't run kdump autoyast config in 2nd stage
- 4.2.15

==== build ====
Version update (20190923 -> 20191114)
Subpackages: build-mkbaselibs build-mkdrpms

- Add Fedora module parser
- Rpmmd parser: set up a dummy ExternEnt handler
- Add support for modules and publish flags
- add zstd to recommends
- Support rpm's new expression expansion syntax

==== dnsmasq ====

- bsc#1154849, CVE-2019-14834, dnsmasq-CVE-2019-14834.patch:
memory leak in the create_helper() function in /src/helper.c
- bsc#1143454: Require user(tftp) instead of creating it ourselves.
- Package contrib/lease-tools/dhcp_release6.
- bsc#1152539: include config files from /etc/dnsmasq.d/*.conf .

==== dpdk ====
Version update (18.11.2_k5.3.11_1 -> 18.11.3_k5.3.11_1)

- Add version to the PMD driver directory to avoid loading previous
version drivers (bsc#1157179).
- Update to 18.11.3 (bsc#1156146). For a list of fixes check:
* https://doc.dpdk.org/guides-18.11/rel_notes/release_18_11.html#fixes
- Add patches to fix vulnerability where malicious container can trigger
a denial of service (CVE-2019-14818, bsc#1156146)
* 0001-vhost-fix-possible-denial-of-service-on-SET_VRING_NU.patch
* 0002-vhost-fix-possible-denial-of-service-by-leaking-FDs.patch
- Removed patrches already included upstream:
* dpdk-fix-implicit-fallthrough-warning.patch

==== elfutils ====
Subpackages: elfutils-lang libasm1 libdw1 libebl-plugins libelf-devel libelf1

- disable-tests-with-ptrace.patch: Remove, set XFAIL_TESTS instead
- dwelf_elf_e_machine_string.patch: Avoid spurious failure

==== libstorage-ng ====
Version update (4.2.19 -> 4.2.27)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#677
- Make default mount_options public (needed for jsc#SLE-7687)
- Bump version
- Rename Mountable::Impl#get_default_mount_options
- Split MountPoint#set_default_mount_options into pieces (needed
for jsc#SLE-7687)
- 4.2.27
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.26
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.25
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.24
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.23
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.22
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.21
- Translated using Weblate (Estonian) (bsc#1149754)
- 4.2.20

==== libwacom ====
Version update (0.32 -> 1.1)
Subpackages: libwacom-data libwacom2

- Add libwacom-meson-0.51-lto.patch: Completely strip the
test_deprecated linkingn from meson.build> 174.patch would only
properly work with meson 0.52+.
- Add 174.patch

(https://patch-diff.githubusercontent.com/raw/linuxwacom/libwacom/pull/174.patch):
+ Disable deprecated symbol test when using LTO.
- Update to 1.1:
New devices: Wacom HID 5115
Other change:
* Button codes defined for the 3rd gen Intuos S
Changes from version 1.0:
- udev rules are now installed by default
Changes from version 0.99.901:
New devices
* Lenovo YOGA 720, YOGA 520, IdeaPad FLEX 5, MIIX 520
* Dell XPS 15 9570, Latitude 5175
* HP Spectre x360, Envy x360 Convertible
* Wacom Intuos Pro 2 S, Cintiq 22, DTK-1660E
* Huion 610 Pro v2
* Samsung 930QAA
Other changes:
* New API: libwacom_get_model_name()
* meson build system support
* fixed symbol versioning
* EKR button ordering fixed
* Stylus grouping added
Changes from version 0.33:
- New devices:
* Wacom Bamboo Fun 4x5, Bamboo Fun 6x8, Bamboo1 5x8, Cintiq 16
* HP EliteBook x360, x2, HP Envy x360
* Acer Switch SA5
* Huion H420
* Lenovo Thinkpad L380 Yoga, L390 Yoga, Ideapad Flex, Yoga 730
* Dell Latitude 7390
- Switch to meson for 15.2/tumbleweed
- Remove URI from keyring: file is no longer there.
- Add libxml2 to BuildRequires.
- Don't manually install udev rules: now done by install.
- Switch URL to github.

==== libxmlb ====
Version update (0.1.11 -> 0.1.13)

- Update to version 0.1.13:
+ New Features:
- Export xb_silo_query_full()
+ Bugfixes:
- Show the XPath that was used in the query in the error
message
- Changes from version 0.1.12:
+ New Features:
- Add helper functions to get the first and last child
XbBuilerNode
- Add xb_node_transmogrify to allow changing XML format
- Support 'tail' XML data in the stored silo
+ Bugfixes:
- Do not escape a single quote with &apos;
- Don't invalidate the silo for a GIO temp file
- Fix up two memory leaks if using libxmlb from an introspected
binding

==== libyui ====
Version update (3.8.2 -> 3.8.5)

- Don't use tab in string literal
(bsc#1084674)
- 3.8.5
- Support item status getting and setting for ItemSelector
(bsc#1084674)
- 3.8.4
- Support custom status values (int, not just bool) in ItemSelector
(bsc#1084674)
- 3.8.3

==== libyui-ncurses ====
Version update (2.53.1 -> 2.53.2)

- Implemented CustomStatusItemSelector widget (bsc#1084674)
- 2.53.2

==== libyui-qt ====
Version update (2.51.1 -> 2.51.4)

- Mirror layout direction in Farsi (bsc#1156437)
- 2.51.4
- Left-align ItemSelector toggle and icon if using custom status values,
but items without description (bsc#1084674)
- 2.51.3
- Support custom status values (int, not just boolean) in ItemSelector
(bsc#1084674)
- 2.51.2

==== nagios ====
Subpackages: nagios-www

- compile with -ffat-lto-objects to prevent build failure

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base terminfo-screen

- Do not add has size to linker flags of any pkg-config
- Add ncurses patch 20191109
+ add warning-check in tic for terminals with parm_dch vs parm_ich.
+ drop ich1 from rxvt-basic, Eterm and mlterm to improve compatibility
with old non-curses programs -TD
+ reviewed st 0.8.2, updated some details -TD
+ use ansi+rep several places -TD
+ corrected tic's check for ich1 (report by Sebastian J. Bronner,
cf: 20020901).
- Add ncurses patch 20191102
+ check parameter of set_escdelay, return ERR if negative.
+ check parameter of set_tabsize, return ERR if not greater than zero
(report/patch by Anthony Sottile).
+ revise CF_ADD_LIBS macro to prepend rather than append libraries.
+ add "xterm-mono" to help packagers (report by Sven Joachim) -TD

==== openssl ====
Version update (1.1.1c -> 1.1.1d)
Subpackages: libopenssl-devel

- Update to 1.1.1d release

==== openssl-1_1 ====
Version update (1.1.1c -> 1.1.1d)
Subpackages: libopenssl-1_1-devel libopenssl1_1 libopenssl1_1-32bit

- Merged upstream changes to allow NULL salt values in EVP_PBE_scrypt().
* Revealed by nodejs12 during bsc#1149572.
* Modified openssl-jsc-SLE-8789-backport_KDF.patch
- openssl-jsc-SLE-8789-backport_KDF.patch: retain old behaviour
of EVP_PBE_scrypt. When key output buffer is not provided,
only check if the input parameters are in valid range and
ignore passphrase/salt fields as they are only used in
the actual calculation.
- Update to 1.1.1d (bsc#1133925, jsc#SLE-6430)
* Fixed a fork protection issue. OpenSSL 1.1.1 introduced a rewritten random
number generator (RNG). This was intended to include protection in the
event of a fork() system call in order to ensure that the parent and child
processes did not share the same RNG state. However this protection was not
being used in the default case.
(bsc#1150247, CVE-2019-1549)
* Compute ECC cofactors if not provided during EC_GROUP construction. Before
this change, EC_GROUP_set_generator would accept order and/or cofactor as
NULL. After this change, only the cofactor parameter can be NULL.
(bsc#1150003, CVE-2019-1547)
* Fixed a padding oracle in PKCS7_dataDecode and CMS_decrypt_set1_pkey.
(bsc#1150250, CVE-2019-1563)
* For built-in EC curves, ensure an EC_GROUP built from the curve name is
used even when parsing explicit parameters, when loading a serialized key
or calling
EC_GROUP_new_from_ecpkparameters()/EC_GROUP_new_from_ecparameters().
* Early start up entropy quality from the DEVRANDOM seed source has been
improved for older Linux systems.
* Changed DH_check to accept parameters with order q and 2q subgroups.
With order 2q subgroups the bit 0 of the private key is not secret
but DH_generate_key works around that by clearing bit 0 of the
private key for those. This avoids leaking bit 0 of the private key.
* Significantly reduce secure memory usage by the randomness pools.
* Revert the DEVRANDOM_WAIT feature for Linux systems
- drop 0001-build_SYS_str_reasons-Fix-a-crash-caused-by-overlong.patch
(upstream)
- refresh patches
* openssl-1.1.0-no-html.patch
* openssl-jsc-SLE-8789-backport_KDF.patch
- To avoid seperate certification of openssh server / client
move the SSH KDF (Key Derivation Function) into openssl.
* jsc#SLE-8789
* Sourced from commit

8d76481b189b7195ef932e0fb8f0e23ab0120771#diff-a9562bc75317360a2e6b8b0748956e34
in openssl master (introduce the SSH KDF)
and commit 5a285addbf39f91d567f95f04b2b41764127950d
in openssl master (backport EVP/KDF API framework)
* added openssl-jsc-SLE-8789-backport_KDF.patch

==== perl-Apache-AuthCookie ====
Version update (3.27 -> 3.28)

- updated to 3.28
see /usr/share/doc/packages/perl-Apache-AuthCookie/Changes
3.28 2019-11-19
- Add support for SameSite cookie property (can be strict/lax).
- Minor POD updates.

==== perl-DateTime-TimeZone ====
Version update (2.37 -> 2.38)

- updated to 2.38
see /usr/share/doc/packages/perl-DateTime-TimeZone/Changes
2.38 2019-11-15
- Added support for Etc/GMT and Etc/UTC style zones like "Etc/GMT-2" or
"Etc/UTC+12". Implemented by kclaggett. GH #38.

==== perl-HTTP-Cookies ====
Version update (6.06 -> 6.07)

- updated to 6.07
see /usr/share/doc/packages/perl-HTTP-Cookies/Changes
6.07 2019-11-15 18:11:42Z
- Fix t/issue32.t on old perl versions (GH#59) (Bernhard M. Wiedemann)

==== perl-Test-Simple ====
Version update (1.302168 -> 1.302169)

- updated to 1.302169
see /usr/share/doc/packages/perl-Test-Simple/Changes
1.302169 2019-11-18 15:49:38-08:00 America/Los_Angeles
- Update inline Object::HashBase
- Avoid 'used only once' warnings in BEGIN and END blocks (James E Keenan
<jkeenan@xxxxxxxx>)

==== polkit-default-privs ====
Version update (13.2+20191015.280c25b -> 13.2+20191119.a36b458)

- Update to version 13.2+20191119.a36b458:
* kcm_sddm: incremental addition of new rules (bsc#1145182)

==== publicsuffix ====
Version update (20191025 -> 20191115)

- Update to version 20191115:
* Add gov.scot for Scottish Government
* update gTLD list to 2019-11-15 state
* remove go-vip.co, go-vip.net, wpcomstaging.com

==== qpdf ====
Version update (9.0.2 -> 9.1.0)

- Update to version 9.1.0
* Incorporate contribution from Masamichi Hosoda to properly handle
signature dictionaries by not including them in object streams,
formatting the Contents key has a hexadecimal string,
and excluding the /Contents key from encryption and decryption.
* Incorporate contribution from Masamichi Hosoda to provide new API
calls for getting file-level information about input and output files,
enabling certain operations on the files at the file level rather
than the object level. New methods include QPDF::getXRefTable(),
QPDFObjectHandle::getParsedOffset(),
QPDFWriter::getRenumberedObjGen(QPDFObjGen),
and QPDFWriter::getWrittenXRefTable().
* Support build-time and runtime selectable crypto providers.
This includes the addition of new classes QPDFCryptoProvider
and QPDFCryptoImpl and the recognition of the QPDF_CRYPTO_PROVIDER
environment variable. Crypto providers are described in depth
in Section 2.3, ?Crypto Providers?.
* Addition of the --show-crypto option in support of selectable
crypto providers, as described in Section 2.3, ?Crypto Providers?.
* Allow :even or :odd to be appended to numeric ranges for
specification of the even or odd pages from among the pages
specified in the range.
* Add BR on pkgconfig(gnutls) to add support for GnuTLS for encryption
operations.

==== signon ====
Version update (8.59 -> 8.60)
Subpackages: libsignon-qt5-1 signon-plugins signond signond-libs

- Update to 8.60. No changelog available (boo#1157142)

==== supermin ====
Version update (5.1.18 -> 5.1.20)

- Update to version 5.1.20, via _service file
No changelog provided by upstream

==== ucode-intel ====
Version update (20191112 -> 20191115)

- Updated to 20191115 release (bsc#1157004)
- Processor Identifier Version Products
- Model Stepping F-MO-S/PI Old->New
- ---- updated platforms ------------------------------------
- SKL-U/Y D0 6-4e-3/c0 000000d4->000000d6 Core Gen6 Mobile
- SKL-U23e K1 6-4e-3/c0 000000d4->000000d6 Core Gen6 Mobile
- SKL-H/S/E3 N0/R0/S0 6-5e-3/36 000000d4->000000d6 Core Gen6
- AML-Y22 H0 6-8e-9/10 000000c6->000000ca Core Gen8 Mobile
- KBL-U/Y H0 6-8e-9/c0 000000c6->000000ca Core Gen7 Mobile
- KBL-U23e J1 6-8e-9/c0 000000c6->000000ca Core Gen7 Mobile
- CFL-U43e D0 6-8e-a/c0 000000c6->000000ca Core Gen8 Mobile
- KBL-R U Y0 6-8e-a/c0 000000c6->000000ca Core Gen8 Mobile
- WHL-U W0 6-8e-b/d0 000000c6->000000ca Core Gen8 Mobile
- AML-Y42 V0 6-8e-c/94 000000c6->000000ca Core Gen10 Mobile
- WHL-U V0 6-8e-c/94 000000c6->000000ca Core Gen8 Mobile
- CML-U42 V0 6-8e-c/94 000000c6->000000ca Core Gen10 Mobile
- KBL-G/H/S/X/E3 B0 6-9e-9/2a 000000c6->000000ca Core Gen7 Desktop,
Mobile, Xeon E3 v6
- CFL-H/S/E3 U0 6-9e-a/22 000000c6->000000ca Core Gen8 Desktop,
Mobile, Xeon E
- CFL-S B0 6-9e-b/02 000000c6->000000ca Core Gen8
- CFL-S P0 6-9e-c/22 000000c6->000000ca Core Gen9 Desktop
- CFL-H/S/E3 R0 6-9e-d/22 000000c6->000000ca Core Gen9 Desktop,
Mobile, Xeon E
- CML-U62 A0 6-a6-0/80 000000c6->000000ca Core Gen10 Mobile
- Updated to 20191113 release
- Processor Identifier Version Products
- Model Stepping F-MO-S/PI Old->New
- ---- updated platforms ------------------------------------
- CFL-S P0 6-9e-c/22 000000a2->000000c6 Core Gen9 Desktop

==== yast2 ====
Version update (4.2.30 -> 4.2.34)
Subpackages: yast2-logs

- Fix crash in upgrade caused by wrong parameter to snapper
(bsc#1156819)
- 4.2.34
- Use new snapper machine-readable output to retrieve snapshots
information (related to bsc#1149322).
- 4.2.33
- Add linuxrc option "reboot_timeout" to configure the timeout
before reboot (bsc#1122493)
- 4.2.32
- Network: During an installation, check which backend is in use
when Systemd is running. (bsc#1151291)
- 4.2.31

==== yast2-installation ====
Version update (4.2.19 -> 4.2.23)

- Use linuxrc option "reboot_timeout" to configure the timeout
before reboot (bsc#1122493)
- 4.2.23
- Save and restore the proposal vertical scroll (related to a
problem reseting the scroll position reported in bsc#1143558)
- 4.2.22
- Improve the role selection dialog using a new scrollable widget
to select a role (related to bsc#1084674, bsc#bsc#1086187).
- 4.2.21
- Implement upgrade for the Full medium (jsc#SLE-7101)
- 4.2.20

==== yast2-kdump ====
Version update (4.2.5 -> 4.2.6)

- fix crash for empty kdump section (related to change for
bsc#1149208)
- 4.2.6

==== yast2-network ====
Version update (4.2.23 -> 4.2.28)

- Do not crash when wrapping text (bsc#1157161)
- 4.2.28
- fix importing dhclient_set_hostname key from autoyast profile
(bsc#1152021)
- 4.2.27
- Wireless: Fix wpa auth modes selection removing the prefix from
the combobox value which is not used when writing the config.
(bsc#1155639)
- 4.2.26
- Live installation:
- Do not try to configure dhcp when NetworkManager is in use.
- Show the general tab in the lan client allowing to switch
between backends when systemd is running.
- Do not do a netconfig update during an installation for not
breaking the current resolv configuration.
- 4.2.25
- fix typo in remote desktop file (thanks for contribution
to Markus S aka kamikazow) (bsc#1155584)
- 4.2.24

==== yast2-nfs-client ====
Version update (4.2.2 -> 4.2.3)

- Removed nfsidmap hardcoded dependency once libnfsidmap was merged
into nfs-utils and a separate package should not be needed
anymore (bsc#1150807, bsc#1153568)
- 4.2.3

==== yast2-nfs-server ====
Version update (4.2.1 -> 4.2.2)
Subpackages: yast2-nfs-common

- Do not use Builtins.regexpmatch when checking the options as the
match is failing with default options depending on the locale
used (bsc#1151637)
- 4.2.2

==== yast2-ntp-client ====
Version update (4.2.5 -> 4.2.6)

- Break autoyast<->yast2-ntp-client cycle (related to changes done
for jsc#SLE-7101)
- 4.2.6

==== yast2-packager ====
Version update (4.2.30 -> 4.2.32)

- Preselect the installed add-ons when upgrading from the Full
installation medium (related to jsc#SLE-7101)
- 4.2.32
- Do not crash when the product licenses cannot be read
(bsc#1155454)
- 4.2.31

==== yast2-pkg-bindings ====
Version update (4.2.0 -> 4.2.2)

- Fixed Pkg.Resolvables() to properly filter by status
(related to bsc#1132650)
- 4.2.2
- Returning raw packages dependencies while calling
<Y2Packager::Resolvable>.deps (bsc#1132650).
- 4.2.1

==== yast2-ruby-bindings ====
Version update (4.2.3 -> 4.2.4)

- Added symbol for new UI CustomStatusItemSelector widget
(bsc#1084674)
- Added symbol for UI icon term
- 4.2.4

==== yast2-samba-server ====
Version update (4.2.0 -> 4.2.1)

- Fix failing old testsuite (bsc#1155923)
- 4.2.1

==== yast2-schema ====
Version update (4.2.5 -> 4.2.6)

- Update schema to support setting the encryption method through
the 'crypt_method' (related to jsc#SLE-7376).
- 4.2.6

==== yast2-storage-ng ====
Version update (4.2.51 -> 4.2.57)

- Fixed a wrong check that was preventing the installation of some
needed packages (bsc#1151148).
- 4.2.57
- Propagate the noauto, nofail and _netdev options from fstab
to crypttab (needed for jsc#SLE-7687).
- Add the _netdev option to fstab for mount points on top of a
network-based device like iSCSI or FCoE (jsc#SLE-7687).
- 4.2.56
- AutoYaST: allow to inject settings for the guided proposal
(related to boo#1156539).
- 4.2.55
- AutoYaST: do not repeat filesystem related information when
cloning multidevice Btrfs filesystems (bsc#1148578).
- AutoYaST: do not export the enable_snapshots element for drives
which do not contain the root filesystem.
- 4.2.54
- AutoYaST: add support to set the encryption method (related to
jsc#SLE-7376).
- 4.2.53
- fix creation of secure key for new partitions (bsc#1154267)
- 4.2.52

==== yast2-trans ====
Version update (84.87.20191020.c721485b2e -> 84.87.20191117.fb9cd042cd)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20191117.fb9cd042cd:
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* New POT for text domain 'qt'.
* New POT for text domain 'installation'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* New POT for text domain 'control'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (German)
* Translated using Weblate (German)
* New POT for text domain 'packager'.
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Estonian)
* Translated using Weblate (German)
* New POT for text domain 'network'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
- Update to version 84.87.20191110.22b1ea9ba5:
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* New POT for text domain 'update'.
* New POT for text domain 'registration'.
* New POT for text domain 'installation'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* New POT for text domain 'qt-pkg'.
* New POT for text domain 'installation'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* New POT for text domain 'update'.
* New POT for text domain 'base'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Finnish)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
- Update to version 84.87.20191103.0ebbcd783b:
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Albanian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Albanian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Danish)
* New POT for text domain 'installation'.
* New POT for text domain 'drbd'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Slovak)
* Translated using Weblate (French)
* Translated using Weblate (French)
* Translated using Weblate (French)
* Translated using Weblate (French)
* Translated using Weblate (French)
* New POT for text domain 'nfs_server'.
* New POT for text domain 'installation'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Dutch)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Estonian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Estonian)
* Translated using Weblate (Czech)
* New POT for text domain 'storage'.
* New POT for text domain 'registration'.
* New POT for text domain 'kdump'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* New POT for text domain 'autoinst'.
* Translated using Weblate (Estonian)
* Translated using Weblate (German)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (Czech)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Danish)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Slovak)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* New POT for text domain 'registration'.
* New POT for text domain 'installation'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* New POT for text domain 'registration'.
* New POT for text domain 'installation'.
* New POT for text domain 'country'.
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Finnish)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Estonian)
* New POT for text domain 'storage'.
* Translated using Weblate (Slovak)
* Translated using Weblate (Estonian)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Estonian)

==== yast2-update ====
Version update (4.2.7 -> 4.2.10)

- Fixed too eager Rubocop cleanup resulting in "No fstab found"
error after selecting a partition to upgrade (related to
jsc#SLE-7101)
- 4.2.10
- Implement upgrade for Full medium (jsc#SLE-7101)
- 4.2.9
- Add support for online auto_upgrade (jsc#SLE-7214)
- 4.2.8

==== yast2-ycp-ui-bindings ====
Version update (4.2.3 -> 4.2.4)

- require correct libyui version (bsc#1153103)
- 4.2.5
- Support for CustomStatusItemSelector (bsc#1084674)
- 4.2.4


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages