Mailinglist Archive: opensuse-factory (269 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190921 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Sun, 22 Sep 2019 21:02:05 +0000
  • Message-id: <156918612580.27428.11654946497599361046@go-agent-stagingbot-5>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190921

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
cabextract (1.9 -> 1.9.1)
gstreamer-plugins-bad
libqt5-qtbase
libqt5-qtwebengine
libreoffice (6.3.1.1 -> 6.3.2.2)
osinfo-db (20190726 -> 20190905)
pulseaudio (12.2 -> 13.0)

=== Details ===

==== cabextract ====
Version update (1.9 -> 1.9.1)

- Modernise spec file
- Update to version 1.9.1
* Rerelease of 1.9 with some packaging issues fixed

==== gstreamer-plugins-bad ====
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0
libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0

- Use openssl for HLS crypto. openssl is required by DTLS, and hls
can use any of openssl, gcrypt or gnutls/nettle (since 1.5.1).
Drop explicit pkgconfig(nettle) BuildRequires and pass
hls-crypto=openssl to configure/meson.

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5
libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libQt5Sql5 libQt5Sql5-mysql
libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk3

- Add patch to fix focus in some cases (QTBUG-77364):
* 0001-QWidget-setFocusProxy-adjust-focus-widget-properly.patch

==== libqt5-qtwebengine ====

- Add gn_args+=link_pulseaudio=true to work around incompatibility
with PA 13 headers (QTBUG-77037)
- Enable kerberos support

==== libreoffice ====
Version update (6.3.1.1 -> 6.3.2.2)
Subpackages: libreoffice-base libreoffice-base-drivers-firebird
libreoffice-calc libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-l10n-es
libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru
libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
libreofficekit

- Update to 6.3.2.2:
* Fixes for full 6.3.2 release included
- Add patch to fix building on SLE12:
* 0001-Check-for-EMOJI-content-only-on-ICU-57-and-newer.patch
- Update to 6.3.2.1:
* Contain fixes for the bellow CVE issues and also few
stability tweaks
- Drop merged patches:
* old-boost.patch
* old-boost2.patch
- Add Silesian language
- Update to 6.2.7.1:
bsc#1149944 VUL-0: CVE-2019-9854 Unsafe URL assembly flaw
bsc#1149943 VUL-0: CVE-2019-9855 path equivalence handling flaw
- Drop merged patch:
* 0001-Fix-buidling-with-older-boost.patch

==== osinfo-db ====
Version update (20190726 -> 20190905)

- Update database to version 20190905
osinfo-db-20190905.tar.xz
- Update database to version 20190805
osinfo-db-20190805.tar.xz
- Add support for SLE15-SP2
add-sle15sp2-support.patch

==== pulseaudio ====
Version update (12.2 -> 13.0)
Subpackages: libpulse-mainloop-glib0 libpulse0 pulseaudio-bash-completion
pulseaudio-gdm-hooks pulseaudio-lang pulseaudio-module-bluetooth
pulseaudio-module-gsettings pulseaudio-module-x11 pulseaudio-module-zeroconf
pulseaudio-utils

- Update to version 13.0:
* Added support for Dolby TrueHD and DTS-HD Master Audio
* Improved initial card profile selection for ALSA cards
* Bluetooth card profile choices aren't persistent any more by
default.
* Added support for SteelSeries Arctis 5 USB headset.
* New "max_latency_msec" module argument for module-loopback.
* New "stream_name" module argument for module-rtp-send.
* Fixed S/PDIF for CMEDIA USB2.0 High-Speed True HD Audio.
* Use source sample spec and channel map by default in
module-loopback.
* New "avoid_resampling" module argument for module-udev-detect
and module-alsa-card.
* "avoid_resampling" also tries to avoid format conversion if the
ALSA device supports it.
* New function to enable realtime scheduling for client threads.
* Removed BlueZ 4 support.
* Dropped intltool.
* Introduction of the Meson build system.
* Const-ification of parameters across headers.
* Minor bug-fixes, bindings updates.
* Updated translations.
- Update drvver to 13.0.
- Use make_build macros.
- Workaround for old systemd on Leap 15.x, as the recent hardening
relies on the new systemd:
pulseaudio-old-systemd-workaround.patch
- Update to 13 RC2 (12.99.2)
* Added support for Dolby TrueHD and DTS-HD Master Audio
* Improved initial card profile selection for ALSA cards
* Bluetooth card profile choices aren't persistent any more by default
* Added support for SteelSeries Arctis 5 USB headset
* New "max_latency_msec" module argument for module-loopback
* New "stream_name" module argument for module-rtp-send
* Fixed S/PDIF for CMEDIA USB2.0 High-Speed True HD Audio
* Use source sample spec and channel map by default in module-loopback
* New "avoid_resampling" module argument for module-udev-detect and
module-alsa-card
* New function to enable realtime scheduling for client threads
* Removed BlueZ 4 support
* Dropped intltool
* Some initial work on a Meson build system
* https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/13.0/
- Removed patches already included in the source:
pulseaudio-alsa.patch
pa-set-exit-idle-time-to-0-when-we-detect-a-session.patch


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages