Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190828 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Fri, 30 Aug 2019 03:09:35 +0000
  • Message-id: <156713457538.31675.7044984028257090761@go-agent-stagingbot-5>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190828

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
389-ds
Mesa (19.1.3 -> 19.1.5)
Mesa-drivers (19.1.3 -> 19.1.5)
MozillaFirefox (68.0.1 -> 68.0.2)
SDL2_image (2.0.4 -> 2.0.5)
SDL_image (1.2.12 -> 1.2.12+hg695)
WindowMaker-applets
amarok (2.9.0 -> 2.9.70git.20190820T023444~600806141d)
babl (0.1.66 -> 0.1.72)
calamaris
ccache (3.7.1 -> 3.7.3)
cifs-utils
dwz (0.12 -> 0.13)
e2fsprogs (1.45.2 -> 1.45.3)
elfutils (0.176 -> 0.177)
fcitx
ffmpeg-4
flex
gawk (4.2.1 -> 5.0.1)
gcc9 (9.1.1+r274111 -> 9.2.1+r274709)
git (2.22.1 -> 2.23.0)
gsl (2.5 -> 2.6)
gstreamer-plugins-bad
gstreamer-plugins-base
gstreamer-plugins-good
ipset (7.2 -> 7.3)
iputils
kcalcore
kernel-source (5.2.9 -> 5.2.10)
krusader (2.7.1 -> 2.7.2)
libabw (0.1.2 -> 0.1.3)
libgdata (0.17.9 -> 0.17.11)
libgpg-error
libinput (1.14.0 -> 1.14.1)
libmfx
libnftnl (1.1.3 -> 1.1.4)
libntlm (1.4 -> 1.5)
liborcus (0.15.0 -> 0.15.1)
libstorage-ng (4.1.145 -> 4.2.2)
libteam (1.27 -> 1.29)
libva (2.4.1 -> 2.5.0)
libva-gl (2.4.1 -> 2.5.0)
libvisio (0.1.6 -> 0.1.7)
mokutil (0.3.0 -> 0.4.0)
mpg123 (1.25.11 -> 1.25.12)
mugshot (0.4.1 -> 0.4.2)
musepack
nano (4.3 -> 4.4)
neon
nftables (0.9.0 -> 0.9.2)
nghttp2 (1.39.1 -> 1.39.2)
openexr
openpgm
openssh
opensuse-welcome (0.1.5 -> 0.1.6)
pam-config (1.1 -> 1.2)
perl-Error (0.17027 -> 0.17028)
perl-HTML-Clean (0.8 -> 0.9)
potrace
protobuf-c (1.3.1 -> 1.3.2)
python
python-gtk
python-packaging (19.0 -> 19.1)
python-pyOpenSSL
python-pyzmq (18.0.2 -> 18.1.0)
python-setuptools (41.0.1 -> 41.2.0)
read-only-root-fs (1.0+git20190206.586e9f1 -> 1.0+git20190607.11f8587)
remmina (1.3.5 -> 1.3.6)
rpm-config-SUSE (0.g27 -> 0.g32)
schily
sudo
suse-module-tools (15.2.4 -> 15.2.5)
susepaste
util-linux (2.33.2 -> 2.34)
util-linux-systemd (2.33.2 -> 2.34)
util-macros
xdm
xfce4-screenshooter (1.9.5 -> 1.9.6)
xfce4-whiskermenu-plugin
xtrans
yast2-alternatives (4.2.1 -> 4.2.2)
yast2-auth-client (4.2.1 -> 4.2.2)
yast2-auth-server (4.2.2 -> 4.2.3)
yast2-configuration-management (4.2.1 -> 4.2.2)
yast2-dns-server (4.2.1 -> 4.2.2)
yast2-http-server (4.2.0 -> 4.2.1)
yast2-installation (4.2.10 -> 4.2.11)
yast2-iscsi-client (4.2.1 -> 4.2.2)
yast2-journal (4.2.1 -> 4.2.2)
yast2-kdump (4.2.1 -> 4.2.2)
yast2-online-update (4.2.1 -> 4.2.2)
yast2-pam (4.2.3 -> 4.2.4)
yast2-proxy (4.2.1 -> 4.2.2)
yast2-ruby-bindings (4.2.1 -> 4.2.2)
yast2-security (4.2.0 -> 4.2.1)
yast2-services-manager (4.2.0 -> 4.2.3)
yast2-storage-ng (4.2.32 -> 4.2.35)
yast2-theme (4.2.4 -> 4.2.5)
yast2-trans (84.87.20190811.da547f2b17 -> 84.87.20190825.25c7d8a3aa)
yast2-update (4.2.4 -> 4.2.5)
yast2-vpn (4.2.1 -> 4.2.2)
zimg (2.9.1 -> 2.9.2)

=== Details ===

==== 389-ds ====
Subpackages: lib389 libsvrcore0

- Temporarily back out of rust enablement due to incorrectly linked
library causing server startup failure.
- During review an issue with libevent depedencies was noted. Change
to buildrequires libevent-devel.
- During testing of versioning of features it was noticed that legacy
perl builds were broken.

==== Mesa ====
Version update (19.1.3 -> 19.1.5)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- Update to version 19.1.5
* bugfix release
- Build radeonsi and libvdpau_radeonsi on ppc64le
- Update to version 19.1.4:
* Mostly, as usual, in fixes for different drivers (anv, radv,
radeon, nv50, nvc0) as well as in backend parts (egl, spirv,
nir, ...).
* Of those fixes, we could highlight several ones:
- Vulkan 24/48 bit formats are now not supported on Ivybridge.
- R8G8B8_UNORM_SRGB is not supported on Haswell.
- A fix for hair artifacts in Max Payne 3 on AMD/RADV.
- Vulkan transform feedback extension is disabled on Intel
gen7.

==== Mesa-drivers ====
Version update (19.1.3 -> 19.1.5)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- Update to version 19.1.5
* bugfix release
- Build radeonsi and libvdpau_radeonsi on ppc64le
- Update to version 19.1.4:
* Mostly, as usual, in fixes for different drivers (anv, radv,
radeon, nv50, nvc0) as well as in backend parts (egl, spirv,
nir, ...).
* Of those fixes, we could highlight several ones:
- Vulkan 24/48 bit formats are now not supported on Ivybridge.
- R8G8B8_UNORM_SRGB is not supported on Haswell.
- A fix for hair artifacts in Max Payne 3 on AMD/RADV.
- Vulkan transform feedback extension is disabled on Intel
gen7.

==== MozillaFirefox ====
Version update (68.0.1 -> 68.0.2)
Subpackages: MozillaFirefox-translations-common

- Mozilla Firefox 68.0.2:
* Fixed a bug causing some special characters to be cut off from
the end of the search terms when searching from the URL bar
(bmo#1560228)
* Allow fonts to be loaded via file:// URLs when opening a page
locally (bmo#1565942)
* Printing emails from the Outlook web app no longer prints only
the header and footer (bmo#1567105)
* Fixed a bug causing some images not to be displayed on reload,
including on Google Maps (bmo# 1565542)
* Fixed an error when starting external applications configured
as URI handlers (bmo#1567614)
MFSA 2019-24 (boo#1145665)
* CVE-2019-11733: Stored passwords in 'Saved Logins' can be
copied without master password entry (bmo#1565780)
- drop fix-build-after-y2038-changes-in-glibc.patch, upstream
- Fix crash when typing in the URL bar on ppc64le (bmo#1512162).
The upstream patch doesn't resolve the issue on TW, but compiling
with -O1 does. Do this until we have a proper fix.

==== SDL2_image ====
Version update (2.0.4 -> 2.0.5)

- Add CVE-2019-13616.patch: fix heap buffer overflow when reading
a crafted bmp file (boo#1141844 CVE-2019-13616).
- Update to new upstream release 2.0.5
* Fixed TALOS-2019-0820 CVE-2019-5051
* Fixed TALOS-2019-0821 CVE-2019-5052
* Fixed TALOS-2019-0841 CVE-2019-5057 boo#1143763
* Fixed TALOS-2019-0842 CVE-2019-5058 boo#1143764
* Fixed TALOS-2019-0843 CVE-2019-5059 boo#1143766
* Fixed TALOS-2019-0844 CVE-2019-5060 boo#1143768
- Not mentioned by upstream, but issues seemingly further fixed:
* Fixed CVE-2019-12218 boo#1135789
* Fixed CVE-2019-12217 boo#1135787
* Fixed CVE-2019-12220 boo#1135806
* Fixed CVE-2019-12221 boo#1135796
* Fixed CVE-2019-12222 boo#1136101

==== SDL_image ====
Version update (1.2.12 -> 1.2.12+hg695)

- Update to new snapshot 1.2.12+hg695
* Fixed TALOS-2019-0821 CVE-2019-5052
* Fixed TALOS-2019-0841 CVE-2019-5057 boo#1143763
* Fixed TALOS-2019-0842 CVE-2019-5058 boo#1143764
* Fixed TALOS-2019-0843 CVE-2019-5059 boo#1143766
* Fixed TALOS-2019-0844 CVE-2019-5060 boo#1143768
* Fixed CVE-2019-7635
* Fixed CVE-2019-13616 boo#1141844
- Drop CVE-2019-13616.patch (merged)
- Add CVE-2019-13616.patch: fix heap buffer overflow when reading
a crafted bmp file (boo#1141844 CVE-2019-13616).

==== WindowMaker-applets ====

- Avoid bash-specific += operator in build recipe.
- Replace $RPM_* shell vars (where possible) by macros.
- Remove %defattr, BuildRoot and the redundant %clean section.

==== amarok ====
Version update (2.9.0 -> 2.9.70git.20190820T023444~600806141d)

- Add 0001-Fix-a-crash-when-running-amarok-l-path-to-file.patch (kde#410870)
- Update to version 2.9.70git.20190820T023444~600806141d:
* Fix the CI build
* Use identical internet-services icon
- Remove the taglib runtime Requires, these are just examples and
are not used, the automatic library dependencies are sufficient.
- Update to version 2.9.70git.20190614T140058~cea336303a:
* Fix passing local file paths on the command line
- Add back gstreamer-plugins-ugly Recommends (if
phonon4qt5-backend-gstreamer is installed) to make mp3 playback
work out of the box
- Require libqt5-qtquickcontrols instead of libqt5-qtquickcontrols2
as the former is used/needed too and the latter is required by
kirigami2 anyway
- Update to version 2.9.70git.20190510T121601~fc370bbebf:
* Set urgency to Low for track changes
* Add DesktopEntry to notifyrc
- Add 0001-Work-around-QTBUG-75797-for-openQA.patch
- Enable 'changesgenerate' in the _service file.
- Use a git snapshot for amarok.
- Drop patches:
- Fix-build-with-gcc6.patch
- initial-preference.diff
- Refresh disable-web-plugins-by-default.patch
- Refresh flac_mimetype_bnc671581.diff
- Add amarok_mariadb.patch
- Replace some hardcoded package names with pkgconfig() ones.
- Tweak summary a bit: Amarok is not only for KDE.
- Remove GCC workaround for ancient and unsupported openSUSE versions.

==== babl ====
Version update (0.1.66 -> 0.1.72)

- Trim package descriptions on packages installed more rarely.
- Update to version 0.1.72:
+ Added handling for grayscale ICC profiles and gobject
introspection support.
+ Optimizations for many format conversions for u8, u16 and half
formats.
+ Fixed a crash for NANs in float to u8 conversions.
- Drop babl-add-sse2_cflags-to-CIE.patch: Fixed upstream.
- Add pkgconfig(gobject-introspection-1.0) BuildRequires: New
dependency.
- Following the above, package new sub-package
typelib-1_0-Babl-0_1.
- Update to version 0.1.70:
+ Build fixes making the meson build work with more
architectures.
- Changes from version 0.1.68:
+ Added Yu'v' (CIE 1976 UCS) color model.
+ Fixed a severe non-initialised memory issue - that kept us from
using fast paths for many babl spaces loaded from profile.
+ More fully symmetric conversions between associated and
separate alpha.
+ Added more converters, both SSE2 and non-SSE2 for
matrix-conversion between different RGB spaces.
+ Improvements to website/documentation; babl is now using the
terms associated alpha and separate alpha, all of:
nonpremultiplied-, premultiplied- and nonassociated- alpha are
now considered deprecated API.
+ HCY luminance is now relative to the RGB space used - no change
for sRGB related pixel formats. AVX2 acceleration for some
linear to float conversions.
- Add meson BuildRequires and macros, upstream switched to meson
only.
- Add pkgconfig(lcms2) BuildRequires: New dependency.
- Add babl-add-sse2_cflags-to-CIE.patch: Fix build for i586
(glgo#GNOME/babl!42, glgo#GNOME/babl#23).

==== calamaris ====

- Fix generation of reports with Perl >= 5.12 (boo#1145328)
+ 0001_perl.patch

==== ccache ====
Version update (3.7.1 -> 3.7.3)

- Update to version 3.7.3:
* The cache size (which is counted in ?used disk blocks?) is now correct on
filesystems that use more or less disk blocks than conventional filesystems,
e.g. ecryptfs or btrfs/zfs with transparent compression. This also fixes a
related problem with ccache?s own test suite when run on such file systems.
Fixed a regression in 3.7.2 when using the compiler option ?-Werror? and then
?-Wno-error? later on the command line.
- Changes n version 3.7.2:
* The compiler option -gdwarf* no longer forces ?run_second_cpp = true?.
* Added verification that the value passed to the -o/--set-config option is
valid.
* Fixed detection of precompiled headers in the depend mode.
* Bail out on too hard Clang option -ftime-trace.
* ccache now updates the correct stats file when adding/updating manifest
files. This bug previously made the file and size statistics counters incorrect
over time.
* Fixed warnings from Clang about unused arguments during preprocessing.
* Unknown manifest versions are now handled gracefully in --dump-manifest.
* Fixed make check with ?funny? locales.

==== cifs-utils ====

- Update to cifs-utils 6.9; (bsc#1132087); (bsc#1136031).
* adds fixes for Azure
* new smbinfo utility
* remove cifs-utils-6.8.tar.bz2
* remove cifs-utils-6.8.tar.bz2.asc
* add cifs-utils-6.9.tar.bz2
* add cifs-utils-6.9.tar.bz2.asc
* add 0001-smbinfo-Improve-help-usage-and-add-h-option.patch
* add 0002-smbinfo-Add-bash-completion-support-for-smbinfo.patch
* add 0003-getcifsacl-Add-support-to-accept-more-paths.patch
* add 0004-getcifsacl-Fix-usage-message-to-include-multiple-fil.patch
* add 0005-smbinfo-add-GETCOMPRESSION-support.patch
* add 0006-getcifsacl-Add-support-for-R-recursive-option.patch
* add 0007-smbinfo-add-bash-completion-support-for-getcompressi.patch
* add 0008-mount.cifs.c-fix-memory-leaks-in-main-func.patch
* add 0009-Zero-fill-the-allocated-memory-for-new-struct-cifs_n.patch
* add 0010-Zero-fill-the-allocated-memory-for-a-new-ACE.patch
- Remove backports that are already in 6.9; (fate#325270); (bsc#1130528);
* remove 0001-docs-cleanup-rst-formating.patch
* remove 0002-mount.cifs.rst-document-new-no-handlecache-mount-opt.patch
* remove 0003-manpage-update-mount.cifs-manpage-with-info-about-rd.patch
* remove 0004-checkopts-add-python-script-to-cross-check-mount-opt.patch
* remove 0005-mount.cifs.rst-document-missing-options-correct-wron.patch
* remove 0006-cifs-utils-support-rst2man-3.patch
* remove 0007-checkopts-report-duplicated-options-in-man-page.patch
* remove 0008-mount.cifs.rst-more-cleanups.patch
* remove 0009-mount.cifs.rst-document-vers-3-mount-option.patch
* remove 0010-mount.cifs.rst-document-vers-3.02-mount-option.patch
* remove allow-dns-resolver-key-to-expire.patch
* remove suse-document-new-vers-default-SMB2.1.patch
- Remove dependency workaround regarding python2/python3
- Fix dependency failure on SLE15 regarding python2/python3.
- Allow cached DNS entry to expire; (fate#325270).
* add allow-dns-resolver-key-to-expire.patch
- Document new SMB2.1+ defaults; (bsc#1130528).
* be more verbose on mount errors, especially with EHOSTDOWN which
is often returned on SMB version issues.
* add suse-document-new-vers-default-SMB2.1.patch
- Fix python dependency stalemate by requiring python3 version of
samba-libs.
- Update to cifs-utils 6.8.
+ document more mount options
+ man pages now generated from RST files
+ add python-docutils build dependency
+ update keyring to check tarball signature
+ remove 0001-manpage-correct-typos-and-spelling-mistakes.patch
+ remove 0002-mount.cifs-document-SMBv3.1.1-and-new-seal-option.patch
- Add typo corrections, better doc and configure fixes from upstream
+ add 0001-docs-cleanup-rst-formating.patch
+ add 0002-mount.cifs.rst-document-new-no-handlecache-mount-opt.patch
+ add 0003-manpage-update-mount.cifs-manpage-with-info-about-rd.patch
+ add 0004-checkopts-add-python-script-to-cross-check-mount-opt.patch
+ add 0005-mount.cifs.rst-document-missing-options-correct-wron.patch
+ add 0006-cifs-utils-support-rst2man-3.patch
+ add 0007-checkopts-report-duplicated-options-in-man-page.patch
+ add 0008-mount.cifs.rst-more-cleanups.patch
+ add 0009-mount.cifs.rst-document-vers-3-mount-option.patch
+ add 0010-mount.cifs.rst-document-vers-3.02-mount-option.patch
- Cleanup spec file
* assume SUSE vendor and SLE >= 11
- Update BuildIgnore to break build cycle samba-client <-> cifs-utils
- update to 6.7:
* mount.cifs cleanups
- includes 6.6:
* cleanup/overhaul of cifs.upcall krb5 credcache handling
- partial cleanup with spec-cleaner
- Document SMB3+ and new seal option; (fate#322075).
+ add patch 0001-manpage-correct-typos-and-spelling-mistakes.patch
+ add patch 0002-mount.cifs-document-SMBv3.1.1-and-new-seal-option.patch
- Get rid of init script on everything based off SLE12+ (bsc#1025471).
- Use https urls.
- Don't ignore libldb, libtalloc, libtevent, and samba-client-libs at build
time; (bsc#966174).
- Update to cifs-utils 6.5.
+ mount.cifs: ignore x- mount options
+ minor build fixes; obsoletes include_paths.h_for__PATH_MOUNTED.patch
+ minor manpage fix
- Ignore samba-client-libs at build-time on post-22 Fedora systems.
- Add include_paths.h_for__PATH_MOUNTED.patch
- Use rccifs -> service symlink for proper status (bnc#908023).
- Remove dependency on gpg-offline as signature checking is implemented in the
source validator.
- Add README.cifstab.migration to document the cifstab removal; (bnc#902947).
- Fix broken rccifs symbolic link.
- Remove dead code associated with cifstab file which is no longer used.

==== dwz ====
Version update (0.12 -> 0.13)

- Fix copyright years in --version message:
* dwz-update-version-copyright-message.patch
- Split off dwz-testsuite package using multibuild, to remove build
cycle
- Don't require binutils-gold for riscv64
- DWZ 0.13 update:
* Dropped patches:
- dwz-0.12-ignore-nobits.patch
- dwz-0.12-DW_OP_GNU_variable_value.patch
- dwz-low-mem-Fix-DW_OP_GNU_parameter_ref-handling-in-read_exprloc.patch
* Added BuildRequires for dejagnu, elfutils, gdb and binutils-gold.
* Add %check
- Add URL tag

==== e2fsprogs ====
Version update (1.45.2 -> 1.45.3)
Subpackages: e2fsprogs-devel e2fsprogs-scrub libcom_err-devel libcom_err2
libcom_err2-32bit libext2fs-devel libext2fs2

- Update to 1.45.3:
* Whether or not automatic online scrubbing will be called is now controlled
in /etc/e2scrub.conf.
* Fix e2fsck handling of filesystems with large_dir and inline directories
* Fix e2scrub_all for encrypted LUKS partitions
* Fix e2scrub_all volume cleanup
* Regression tests cleanups and improvements
* Fixed compiler warnings
* Translation fixes and updates

==== elfutils ====
Version update (0.176 -> 0.177)
Subpackages: elfutils-lang libasm1 libdw1 libebl-plugins libelf-devel libelf1

- Update to version 0.177:
elfclassify: New tool to analyze ELF objects.
readelf: Print DW_AT_data_member_location as decimal offset.
Decode DW_AT_discr_list block attributes.
libdw: Add DW_AT_GNU_numerator, DW_AT_GNU_denominator and DW_AT_GNU_bias.
libdwelf: Add dwelf_elf_e_machine_string.
dwelf_elf_begin now only returns NULL when there is an error
reading or decompressing a file. If the file is not an ELF file
an ELF handle of type ELF_K_NONE is returned.
backends: Add support for C-SKY.
- remove fix-bsc-1110929.diff and
gcc9-tests-Don-t-printf-a-known-NULL-symname.patch
- Use %make_build

==== fcitx ====
Subpackages: fcitx-branding-openSUSE fcitx-gtk2 fcitx-gtk3 fcitx-pinyin
fcitx-table fcitx-table-cn-wubi fcitx-table-cn-wubi-pinyin libfcitx-4_2_9

- Stop packaging fcitx-qt4 for leap 15.2 and Tumbleweed.
- Run spec-cleaner

==== ffmpeg-4 ====
Subpackages: libavcodec58 libavdevice58 libavfilter7 libavformat58
libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5

- Rename ffmpeg-4.2-dlopen-faac-mp3lame-opencore-x264-x265-xvid.patch
to ffmpeg-4.2-dlopen-fdk_aac.patch since we need dlopen only
for fdk_aac and looks like some other parts of the patch is
buggy.
- Sync ffmpeg-4.2-dlopen-faac-mp3lame-opencore-x264-x265-xvid.patch
from upstream.
- Disable LTO for arm, fixes build.

==== flex ====
Subpackages: libfl-devel libfl2

- Enable profile guided optimization during build

==== gawk ====
Version update (4.2.1 -> 5.0.1)

- GNU awk 5.0.1:
* Sandbox mode now disallows assigning new filename values in
ARGV that were not there when gawk was invoked
* The new argument "no-ext" to --lint disables "XXX is a gawk
extension" lint warnings
- possibly incompatible changes in 5.0.0:
* Add support for the POSIX standard %a and %A printf formats
* Replace regex routines with those from GNULIB
* PROCINFO["platform"] yields a string indicating the platform for
which gawk was compiled.
* Writing to elements of SYMTAB that are not variable names now
causes a fatal error
* New comment handling in the pretty-printer
* Namespaces have been implemented. Files included with -i, read
with -f, and command line program segments must all be self-
contained syntactic units.
* now uses the locale settings for ignoring case in single byte
locales, instead of hardwiring in Latin-1

==== gcc9 ====
Version update (9.1.1+r274111 -> 9.2.1+r274709)
Subpackages: cpp9 gcc9-c++ gcc9-fortran gcc9-info gcc9-locale gcc9-objc
libasan5 libatomic1 libgcc_s1 libgcc_s1-32bit libgfortran5 libgomp1 libitm1
liblsan0 libobjc4 libquadmath0 libstdc++6 libstdc++6-32bit
libstdc++6-devel-gcc9 libstdc++6-locale libstdc++6-pp-gcc9
libstdc++6-pp-gcc9-32bit libtsan0 libubsan1

- Update gcc9-add-flto=auto.patch by adding backport
of upstream revision r274849.
- Update to gcc-9-branch head (r274709).
- Add gcc9-pr91307.patch to make symbols for aggregated global
constructor names stable when using LTO.
- Update to gcc-9-branch head (r274311).
* Includes GCC 9.2 release. [jsc#SLE-6536, jsc#SLE-6533]
- Update nvptx-newlib.tar.xz to official newlib-3.1.0.tar.xz
since nvptx support is now upstream.
- Add gcc9-add-flto=auto.patch in order to support -flto=auto.

==== git ====
Version update (2.22.1 -> 2.23.0)
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- git 2.23.0:
* The "--base" option of "format-patch" computed the patch-ids for
prerequisite patches in an unstable way, which has been updated
to compute in a way that is compatible with "git patch-id
- -stable".
* The "git log" command by default behaves as if the --mailmap
option was given.
* fixes and improvements to UI, workflow and features

==== gsl ====
Version update (2.5 -> 2.6)

- update to gsl 2.6:
* add BLAS calls for multiple functions
* Algorithm and implementation updates
* deprecation of multiple functions
* removal of multiple previously deprecated functions
* add binary search tree module (gsl_bst); based on GNU libavl
* remove -u flag to gsl-histogram
* updated spmatrix module
* add routines for banded Cholesky decomposition
- drop upstreamed patches:
* gsl-1.6-initvars.diff
* gsl-wrap.diff
* gsl-fsf_address.patch

==== gstreamer-plugins-bad ====
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0
libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0

- bsc#1144244: Remove dependency on jasper
Jasper support was removed in 2013. OpenJPEG is used for JPEG2000.
- Drop pkgconfig(gtk+-3.0) and pkgconfig(gtk+-x11-3.0)
BuildRequires and stop passing --with-gtk=3.0 to configure, only
used for building examples, and we are already passing
- -disable-examples to configure.
- Drop gst-bad-revert-automake-autoconf-versions.patch: No longer
needed for any supported version of openSUSE. Note, leaving
libtool BuildRequires in place as fix-Werror=return-type.patch
needs it still.

==== gstreamer-plugins-base ====
Subpackages: gstreamer-plugins-base-lang libgstallocators-1_0-0 libgstapp-1_0-0
libgstaudio-1_0-0 libgstfft-1_0-0 libgstgl-1_0-0 libgstpbutils-1_0-0
libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0
libgsttag-1_0-0 libgstvideo-1_0-0 typelib-1_0-GstAudio-1_0
typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

- Drop pkgconfig(gdk-pixbuf-2.0), pkgconfig(gtk+-3.0) and
pkgconfig(gtk+-x11-3.0) BuildRequires and pass --disable-examples
to configure (we already do in meson conditional): Only needed to
build the examples.
- Add explicit pkgconfig(wayland-protocols) BuildRequires:
Previously pulled in by gtk3 dependency.
- Add explicit conditional pkgconfig(cairo) BuildRequires for
openSUSE versions older than current Tumbleweed, workaround bug
in pangocairo dependencies in those releases. Also previously
pulled in by gtk3 dependency.

==== gstreamer-plugins-good ====
Subpackages: gstreamer-plugins-good-extra gstreamer-plugins-good-gtk
gstreamer-plugins-good-jack gstreamer-plugins-good-lang
gstreamer-plugins-good-qtqml

- Add gstreamer-plugins-good-fix-glibc-incompat.patch: v4l2: Fix
type compatibility issue with glibc 2.30.
- Use make_build macro.

==== ipset ====
Version update (7.2 -> 7.3)
Subpackages: libipset13

- Update to new upstream release 7.3
* Fix rename concurrency with listing, which can result broken
list/save results.
* ipset: Copy the right MAC address in bitmap:ip,mac and
hash:ip,mac sets.
* ipset: Actually allow destination MAC address for hash:ip,mac
sets too.

==== iputils ====
Subpackages: rarpd

- Fix arping -D problem (bsc#1146440)
* added arping-revert-partially-fix-sent-vs-received-package.patch
(upstream commit 18f14be)

==== kcalcore ====

- Add 0001-Restore-backward-compatibility-for-the-version-heade.patch

==== kernel-source ====
Version update (5.2.9 -> 5.2.10)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms kernel-vanilla

- Linux 5.2.10 (bnc#1012628).
- KEYS: trusted: allow module init if TPM is inactive or
deactivated (bnc#1012628).
- sh: kernel: hw_breakpoint: Fix missing break in switch statement
(bnc#1012628).
- seq_file: fix problem when seeking mid-record (bnc#1012628).
- mm/hmm: fix bad subpage pointer in try_to_unmap_one
(bnc#1012628).
- mm: mempolicy: make the behavior consistent when MPOL_MF_MOVE*
and MPOL_MF_STRICT were specified (bnc#1012628).
- mm: mempolicy: handle vma with unmovable pages mapped correctly
in mbind (bnc#1012628).
- mm/z3fold.c: fix z3fold_destroy_pool() ordering (bnc#1012628).
- mm/z3fold.c: fix z3fold_destroy_pool() race condition
(bnc#1012628).
- mm/memcontrol.c: fix use after free in mem_cgroup_iter()
(bnc#1012628).
- mm/usercopy: use memory range to be accessed for wraparound
check (bnc#1012628).
- mm, vmscan: do not special-case slab reclaim when watermarks
are boosted (bnc#1012628).
- cpufreq: schedutil: Don't skip freq update when limits change
(bnc#1012628).
- drm/amdgpu: fix gfx9 soft recovery (bnc#1012628).
- drm/nouveau: Only recalculate PBN/VCPI on mode/connector changes
(bnc#1012628).
- xtensa: add missing isync to the cpu_reset TLB code
(bnc#1012628).
- arm64: ftrace: Ensure module ftrace trampoline is coherent
with I-side (bnc#1012628).
- ALSA: hda/realtek - Add quirk for HP Envy x360 (bnc#1012628).
- ALSA: usb-audio: Fix a stack buffer overflow bug in
check_input_term (bnc#1012628).
- ALSA: usb-audio: Fix an OOB bug in parse_audio_mixer_unit
(bnc#1012628).
- ALSA: hda - Apply workaround for another AMD chip 1022:1487
(bnc#1012628).
- ALSA: hda - Fix a memory leak bug (bnc#1012628).
- ALSA: hda - Add a generic reboot_notify (bnc#1012628).
- ALSA: hda - Let all conexant codec enter D3 when rebooting
(bnc#1012628).
- HID: holtek: test for sanity of intfdata (bnc#1012628).
- HID: hiddev: avoid opening a disconnected device (bnc#1012628).
- HID: hiddev: do cleanup in failure of opening a device
(bnc#1012628).
- Input: kbtab - sanity check for endpoint type (bnc#1012628).
- Input: iforce - add sanity checks (bnc#1012628).
- net: usb: pegasus: fix improper read if get_registers() fail
(bnc#1012628).
- bpf: fix access to skb_shared_info->gso_segs (bnc#1012628).
- netfilter: ebtables: also count base chain policies
(bnc#1012628).
- riscv: Correct the initialized flow of FP register
(bnc#1012628).
- riscv: Make __fstate_clean() work correctly (bnc#1012628).
- Revert "i2c: imx: improve the error handling in
i2c_imx_dma_request()" (bnc#1012628).
- blk-mq: move cancel of requeue_work to the front of
blk_exit_queue (bnc#1012628).
- io_uring: fix manual setup of iov_iter for fixed buffers
(bnc#1012628).
- RDMA/hns: Fix sg offset non-zero issue (bnc#1012628).
- IB/mlx5: Replace kfree with kvfree (bnc#1012628).
- clk: at91: generated: Truncate divisor to GENERATED_MAX_DIV +
1 (bnc#1012628).
- clk: sprd: Select REGMAP_MMIO to avoid compile errors
(bnc#1012628).
- clk: renesas: cpg-mssr: Fix reset control race condition
(bnc#1012628).
- dma-mapping: check pfn validity in dma_common_{mmap,get_sgtable}
(bnc#1012628).
- platform/x86: pcengines-apuv2: Fix softdep statement
(bnc#1012628).
- platform/x86: intel_pmc_core: Add ICL-NNPI support to PMC Core
(bnc#1012628).
- mm/hmm: always return EBUSY for invalid ranges in
hmm_range_{fault,snapshot} (bnc#1012628).
- xen/pciback: remove set but not used variable 'old_state'
(bnc#1012628).
- irqchip/gic-v3-its: Free unused vpt_page when alloc vpe table
fail (bnc#1012628).
- irqchip/irq-imx-gpcv2: Forward irq type to parent (bnc#1012628).
- f2fs: fix to read source block before invalidating it
(bnc#1012628).
- tools perf beauty: Fix usbdevfs_ioctl table generator to handle
_IOC() (bnc#1012628).
- perf header: Fix divide by zero error if f_header.attr_size==0
(bnc#1012628).
- perf header: Fix use of unitialized value warning (bnc#1012628).
- RDMA/qedr: Fix the hca_type and hca_rev returned in device
attributes (bnc#1012628).
- ALSA: pcm: fix lost wakeup event scenarios in snd_pcm_drain
(bnc#1012628).
- libata: zpodd: Fix small read overflow in zpodd_get_mech_type()
(bnc#1012628).
- powerpc/nvdimm: Pick nearby online node if the device node is
not online (bnc#1012628).
- drm/bridge: lvds-encoder: Fix build error while
CONFIG_DRM_KMS_HELPER=m (bnc#1012628).
- drm/bridge: tc358764: Fix build error (bnc#1012628).
- Btrfs: fix deadlock between fiemap and transaction commits
(bnc#1012628).
- scsi: hpsa: correct scsi command status issue after reset
(bnc#1012628).
- scsi: qla2xxx: Fix possible fcport null-pointer dereferences
(bnc#1012628).
- tracing: Fix header include guards in trace event headers
(bnc#1012628).
- drm/amdkfd: Fix byte align on VegaM (bnc#1012628).
- drm/amd/powerplay: fix null pointer dereference around dpm
state relates (bnc#1012628).
- drm/amdgpu: fix error handling in amdgpu_cs_process_fence_dep
(bnc#1012628).
- drm/amdgpu: fix a potential information leaking bug
(bnc#1012628).
- ata: libahci: do not complain in case of deferred probe
(bnc#1012628).
- kbuild: modpost: handle KBUILD_EXTRA_SYMBOLS only for external
modules (bnc#1012628).
- kbuild: Check for unknown options with cc-option usage in
Kconfig and clang (bnc#1012628).
- arm64/efi: fix variable 'si' set but not used (bnc#1012628).
- riscv: Fix perf record without libelf support (bnc#1012628).
- arm64: Lower priority mask for GIC_PRIO_IRQON (bnc#1012628).
- arm64: unwind: Prohibit probing on return_address()
(bnc#1012628).
- arm64/mm: fix variable 'pud' set but not used (bnc#1012628).
- arm64/mm: fix variable 'tag' set but not used (bnc#1012628).
- IB/core: Add mitigation for Spectre V1 (bnc#1012628).
- IB/mlx5: Fix MR registration flow to use UMR properly
(bnc#1012628).
- RDMA/restrack: Track driver QP types in resource tracker
(bnc#1012628).
- IB/mad: Fix use-after-free in ib mad completion handling
(bnc#1012628).
- RDMA/mlx5: Release locks during notifier unregister
(bnc#1012628).
- drm: msm: Fix add_gpu_components (bnc#1012628).
- RDMA/hns: Fix error return code in hns_roce_v1_rsv_lp_qp()
(bnc#1012628).
- drm/exynos: fix missing decrement of retry counter
(bnc#1012628).
- arm64: kprobes: Recover pstate.D in single-step exception
handler (bnc#1012628).
- arm64: Make debug exception handlers visible from RCU
(bnc#1012628).
- Revert "kmemleak: allow to coexist with fault injection"
(bnc#1012628).
- ocfs2: remove set but not used variable 'last_hash'
(bnc#1012628).
- page flags: prioritize kasan bits over last-cpuid (bnc#1012628).
- asm-generic: fix -Wtype-limits compiler warnings (bnc#1012628).
- arm64: KVM: regmap: Fix unexpected switch fall-through
(bnc#1012628).
- staging: comedi: dt3000: Fix signed integer overflow 'divider *
base' (bnc#1012628).
- staging: comedi: dt3000: Fix rounding up of timer divisor
(bnc#1012628).
- iio: adc: max9611: Fix temperature reading in probe
(bnc#1012628).
- USB: core: Fix races in character device registration and
deregistraion (bnc#1012628).
- usb: gadget: udc: renesas_usb3: Fix sysfs interface of "role"
(bnc#1012628).
- usb: cdc-acm: make sure a refcount is taken early enough
(bnc#1012628).
- USB: CDC: fix sanity checks in CDC union parser (bnc#1012628).
- USB: serial: option: add D-Link DWM-222 device ID (bnc#1012628).
- USB: serial: option: Add support for ZTE MF871A (bnc#1012628).
- USB: serial: option: add the BroadMobi BM818 card (bnc#1012628).
- USB: serial: option: Add Motorola modem UARTs (bnc#1012628).
- usb: setup authorized_default attributes using usb_bus_notify
(bnc#1012628).
- netfilter: conntrack: Use consistent ct id hash calculation
(bnc#1012628).
- Input: psmouse - fix build error of multiple definition
(bnc#1012628).
- bnx2x: Fix VF's VLAN reconfiguration in reload (bnc#1012628).
- bonding: Add vlan tx offload to hw_enc_features (bnc#1012628).
- net: dsa: Check existence of .port_mdb_add callback before
calling it (bnc#1012628).
- net/mlx4_en: fix a memory leak bug (bnc#1012628).
- net/packet: fix race in tpacket_snd() (bnc#1012628).
- net: sched: sch_taprio: fix memleak in error path for sched
list parse (bnc#1012628).
- sctp: fix memleak in sctp_send_reset_streams (bnc#1012628).
- sctp: fix the transport error_count check (bnc#1012628).
- team: Add vlan tx offload to hw_enc_features (bnc#1012628).
- tipc: initialise addr_trail_end when setting node addresses
(bnc#1012628).
- xen/netback: Reset nr_frags before freeing skb (bnc#1012628).
- net/mlx5e: Only support tx/rx pause setting for port owner
(bnc#1012628).
- bnxt_en: Fix VNIC clearing logic for 57500 chips (bnc#1012628).
- bnxt_en: Improve RX doorbell sequence (bnc#1012628).
- bnxt_en: Fix handling FRAG_ERR when NVM_INSTALL_UPDATE cmd fails
(bnc#1012628).
- bnxt_en: Suppress HWRM errors for HWRM_NVM_GET_VARIABLE command
(bnc#1012628).
- bnxt_en: Use correct src_fid to determine direction of the flow
(bnc#1012628).
- bnxt_en: Fix to include flow direction in L2 key (bnc#1012628).
- net sched: update skbedit action for batched events operations
(bnc#1012628).
- tc-testing: updated skbedit action tests with batch
create/delete (bnc#1012628).
- netdevsim: Restore per-network namespace accounting for fib
entries (bnc#1012628).
- net/mlx5e: ethtool, Avoid setting speed to 56GBASE when autoneg
off (bnc#1012628).
- net/mlx5e: Fix false negative indication on tx reporter CQE
recovery (bnc#1012628).
- net/mlx5e: Remove redundant check in CQE recovery flow of tx
reporter (bnc#1012628).
- net/mlx5e: Use flow keys dissector to parse packets for ARFS
(bnc#1012628).
- net/tls: prevent skb_orphan() from leaking TLS plain text with
offload (bnc#1012628).
- net: phy: consider AN_RESTART status when reading link status
(bnc#1012628).
- netlink: Fix nlmsg_parse as a wrapper for strict message parsing
(bnc#1012628).
- Refresh patches.suse/supported-flag.
- commit 5878ee6
- iwlwifi: Add support for SAR South Korea limitation
(bsc#1142128).
- commit 0100738

==== krusader ====
Version update (2.7.1 -> 2.7.2)
Subpackages: kio_iso

- Update to 2.7.2
* FIXED: Memory leak in the Locate dialog
* FIXED: UDSEntry::insert deprecation warnings
* FIXED: synchronize directory window: column widths
are incorrect (kde#167410)
* FIXED: Context menu item "copy selected to clipboard" copies
all result items (kde#328918)
* FIXED: "Information - Krusader" dialog does not fit to screen
width; text non-copyable (kde#330788)
* FIXED: After trying to rename the file that's being updated,
rename function stops working on any file on this tab
(kde#392750)
* FIXED: New Text File is created with 600 (-rw-------)
permissions (kde#395609)
* FIXED: Misleading ?Created? date in file properties
(kde#397398)
* FIXED: Compilation error because of QOverload usage
(kde#405212)
* FIXED: The list of search results doesn't get the focus
(kde#410118)
* FIXED: Krusader does not search correctly if the "Follow links"
checkbox is disabled (kde#410120)
* FIXED: Okteta support for versions >= 0.26 (due to oktetapart
file layout change)
- Drop Prefer-to-find-oktetapart-by-desktop-file.patch, merged
upstream
- Don't add -fpermissive to compiler options, no longer necessary
- Run spec-cleaner

==== libabw ====
Version update (0.1.2 -> 0.1.3)

- Update to 0.1.3:
- Fix a memory access error found by oss-fuzz.
- Configure with --disable-werror by default.
- Disable expanding entities by XML parser as a vulnerability
prevention measure. Abiword-saved documents do not contain entities,
so there is no difference in behavior.

==== libgdata ====
Version update (0.17.9 -> 0.17.11)
Subpackages: libgdata-lang libgdata22 typelib-1_0-GData-0_0

- Update to version 0.17.11:
+ Various fixes to the Meson port, including a soversion fix.
+ Add support for user-specified properties of documents in
Drive.
+ Bugs fixed: glgo#GNOME/libgdata#30, glgo#GNOME/libgdata#31,
glgo#GNOME/libgdata#32, glgo#GNOME/libgdata#33,
glgo#GNOME/libgdata#35, glgo#GNOME/libgdata!7,
glgo#GNOME/libgdata!9, glgo#GNOME/libgdata!10,
glgo#GNOME/libgdata!13 glgo#GNOME/libgdata!16.
+ Updated translations.
- Update to version 0.17.10:
+ Port to Meson and drop autotools support.
+ Migrate from intltool to gettext.
+ Bugs fixed: glgo#GNOME/libgdata#26, glgo#GNOME/libgdata#27,
glgo#GNOME/libgdata!1, glgo#GNOME/libgdata!3,
glgo#GNOME/libgdata!4, bgo787252.
+ Updated translations.
- Add meson BuildRequires and macros following upstreams port.
- Drop intltool BuildRequires, no longer needed after port.
- Add gtk-doc BuildRequires: Build documentation.
- Add pkgconfig(vapigen) BuildRequires: Build vapi bindings.

==== libgpg-error ====
Subpackages: libgpg-error0 libgpg-error0-32bit

- Add patch to fix buidling with gawk 5.0 and newer:
* gawk5.patch

==== libinput ====
Version update (1.14.0 -> 1.14.1)
Subpackages: libinput-udev libinput10

- Update to new upstream release 1.14.1
* Fix a two-finger interaction (click + drag) was interpreted
as scroll event instead of the intended action
* The RollerMouse v3 now has debouncing disabled so the
double-click button works.

==== libmfx ====
Subpackages: libmfx1

- More consistent macro usage throughout.
- Grammar fixes to description.

==== libnftnl ====
Version update (1.1.3 -> 1.1.4)

- Update to new upstream release 1.1.4
* Add ct id support, add ct expectation support,
add synproxy support.

==== libntlm ====
Version update (1.4 -> 1.5)

- Update to new upstream release 1.5
* Build system fixes, patches for LTO/gcc8 support.

==== liborcus ====
Version update (0.15.0 -> 0.15.1)

- Update to 0.15.1:
* minor bugfixes after the 0.15.0 was released
- Remove merged patches
* fix-linking.patch
* 32bit.patch

==== libstorage-ng ====
Version update (4.1.145 -> 4.2.2)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- Translated using Weblate (Chinese (China))
- 4.2.2
- merge gh#openSUSE/libstorage-ng#663
- update packaging documentation
- 4.2.1
- merge gh#openSUSE/libstorage-ng#662
- merge gh#openSUSE/libstorage-ng#661
- Adapt Dockerfile for SLE-15-SP1
- Translated using Weblate (Slovak)
- Translated using Weblate (Catalan)
- Translated using Weblate (Czech)
- Translated using Weblate (Japanese)
- Translated using Weblate (Arabic)
- Translated using Weblate (Chinese (China))
- Translated using Weblate (Chinese (Taiwan))
- Translated using Weblate (Dutch)
- Translated using Weblate (French)
- Translated using Weblate (German)
- Translated using Weblate (Hungarian)
- Translated using Weblate (Italian)
- Translated using Weblate (Korean)
- Translated using Weblate (Polish)
- Translated using Weblate (Russian)
- Translated using Weblate (Spanish)
- Translated using Weblate (Swedish)
- Translated using Weblate (Portuguese (Brazil))
- Translated using Weblate (Finnish)
- Fix dectection of surrounding region (bsc#1146686)
- Bump lib version
- Fix surrounding detection
- Revert "Translated using Weblate (Catalan)"
- Revert "Translated using Weblate (Finnish)"
- Revert "Translated using Weblate (Dutch)"
- Revert "Translated using Weblate (Portuguese (Brazil))"
- Revert "Translated using Weblate (Swedish)"
- Revert "Translated using Weblate (Spanish)"
- Revert "Translated using Weblate (Russian)"
- Revert "Translated using Weblate (Polish)"
- Revert "Translated using Weblate (Korean)"
- Revert "Translated using Weblate (Italian)"
- Revert "Translated using Weblate (Hungarian)"
- Revert "Translated using Weblate (German)"
- Revert "Translated using Weblate (French)"
- Revert "Translated using Weblate (Chinese (Taiwan))"
- Revert "Translated using Weblate (Chinese (China))"
- Revert "Translated using Weblate (Arabic)"
- Revert "Translated using Weblate (Japanese)"
- Revert "Translated using Weblate (Czech)"
- Revert "Translated using Weblate (Slovak)"
- Revert "Adapt Dockerfile for SLE-15-SP1"
- Merge SLE-15-SP1
- 4.2.0

==== libteam ====
Version update (1.27 -> 1.29)

- Update to upstream release 1.29
* teamd: remove port if adding fails
* teamd: add a default value 1000 for link_watch.interval
* teamd: fix a json object memleak in get_port_obj()
- Update to upstream release 1.28
* teamd: do not process lacpdu before the port ifinfo is set
* teamd: add port_hwaddr_changed for ab runner
* teamd: add port_hwaddr_changed for lb runner
* teamd: add port_hwaddr_changed for lacp runner
name
* libteam: don't crash when trying to print unregistered device
teamd_event_watch_ops
* teamd: add port_master_ifindex_changed for
syslog
* teamd: add an option to force log output to stdout, stderr or
DEFAULT to CURRENT
* teamd: lacp: send LACPDU when port state transitions from

==== libva ====
Version update (2.4.1 -> 2.5.0)
Subpackages: libva-drm2 libva-x11-2 libva2

- Update to version 2.5.0:
* Correct the comment of color_range.
* Add VA_FOURCC_A2B10G10R10 for format a2b10g10r10.
* Adjust VAEncMiscParameterQuantization structure to be align with
VAEncMiscParameterBuffer(possible to impact BC)
* Add attribute for max frame size
* Add va_footer.html into distribution build
* va_trace: hevc profiles added
* Add new definition for input/output surface flag
* va/va_trace: add trace support for VAEncMiscParameterTypeSkipFrame
structure.
* va/va_trace: add MPEG2 trace support for MiscParam and SequenceParam
* va_openDriver: check strdup return value
* Mark some duplicated field as deprecated
* Add return value into logs
* va/va_trace: add trace support for VAEncMiscParameterEncQuality structure.
* Add newformat foucc defination
* va_backend: remove unneeded linux/videodev2.h include
* va_trace: add missing <sys/time.h> include
* configure: don't build glx if VA/X11 isn't built
* va/va_trace: unbreak with C89 after b369467
* [common] Add A2RGB10 fourcc definition
* build: meson: enables va messaging and visibility
* va/va_trace: add trace support for RIR(rolling intra refresh).
* va/va_trace: add trace support for ROI(region of interest)

==== libva-gl ====
Version update (2.4.1 -> 2.5.0)
Subpackages: libva-glx2 libva-wayland2

- Update to version 2.5.0:
* Correct the comment of color_range.
* Add VA_FOURCC_A2B10G10R10 for format a2b10g10r10.
* Adjust VAEncMiscParameterQuantization structure to be align with
VAEncMiscParameterBuffer(possible to impact BC)
* Add attribute for max frame size
* Add va_footer.html into distribution build
* va_trace: hevc profiles added
* Add new definition for input/output surface flag
* va/va_trace: add trace support for VAEncMiscParameterTypeSkipFrame
structure.
* va/va_trace: add MPEG2 trace support for MiscParam and SequenceParam
* va_openDriver: check strdup return value
* Mark some duplicated field as deprecated
* Add return value into logs
* va/va_trace: add trace support for VAEncMiscParameterEncQuality structure.
* Add newformat foucc defination
* va_backend: remove unneeded linux/videodev2.h include
* va_trace: add missing <sys/time.h> include
* configure: don't build glx if VA/X11 isn't built
* va/va_trace: unbreak with C89 after b369467
* [common] Add A2RGB10 fourcc definition
* build: meson: enables va messaging and visibility
* va/va_trace: add trace support for RIR(rolling intra refresh).
* va/va_trace: add trace support for ROI(region of interest)

==== libvisio ====
Version update (0.1.6 -> 0.1.7)

- Update to 0.1.7:
- Fix a few memory leaks found by oss-fuzz.
- Fix date and time conversion to string. (tdf#98291)
- Fix number conversion to string. (tdf#76829)
- Fix unit conversion. (tdf#126292)
- Handle more arrow styles. (tdf#126402)
- Fix some issues found by Coverity.
- Disable expanding entities by XML parser as a vulnerability
prevention measure. Applications writing VSDX/VDX documents do not use
entities, so there is no difference in behavior.

==== mokutil ====
Version update (0.3.0 -> 0.4.0)

- Update to 0.4.0
+ Rename export_moks as export_db_keys
+ Add support for exporting other keys
+ add new --mok argument
+ set list-enrolled command as default for some arguments
+ Add more info to --sb-state: show when we're in SetupMode or
with shim validation disabled
+ Correct help: --set-timeout is really --timeout
+ generate_hash() / generate_pw_hash(): don't use strlen() for
strncpy bounds
+ Add the type casting to silence the warning
+ Add a way for mokutil to configure a timeout for MokManager's
prompt
+ list_keys_in_var(): check errno correctly, not ret twice
+ Fix typo in error message when the system lacks Secure Boot
support
+ Add bash completion file
+ mokutil: be explicit about file modes in all cases
+ Make all efi_guid_t const
+ Don't allow sha1 on the mokutil command line
+ Build with -fshort-wchar so toggle passwords work right
+ Fix the 32bit signedness comparison
+ Fix the potential buffer overflow
- Add mokutil-remove-shebang-from-bash-completion-file.patch to
remove shebang from bash-completion/mokutil
- Drop upstreamed patches
+ mokutil-constify-efi-guid.patch
+ mokutil-fix-overflow.patch
+ mokutil-fshort-wchar.patch
+ mokutil-set-efi-variable-file-mode.patch
- Refresh mokutil-support-revoke-builtin-cert.patch
- Install bash-completion/mokutil
- Add modhash to calculate the hash of kernel module (SLE-5661)
+ Also add openssl to Requires since the script needs it

==== mpg123 ====
Version update (1.25.11 -> 1.25.12)
Subpackages: libmpg123-0 mpg123-openal mpg123-pulse

- Update to version 1.25.12
* Fix dynamic build with gcc -fsanitize=address (check for all
dl functions before deciding that separate -ldl is not
needed).
libmpg123:
* Fix an out-of-bounds read of maximal two bytes for truncated
RVA2 frames (oss-fuzz-bug 15975). The earlier fix around the
same location needed one thought more. Actually, another
though was needed, oss-fuzz-bug 16009 documents the
incomplete fix.
* Fix an invalid write of one zero byte for empty ID3v2 frames
that demand de-unsyncing (oss-fuzz-bug 16050).
* Correct preprocessor syntax in mangle.h, no #error in a
[#]define line. (bug 273, thanks to nmlgc).

==== mugshot ====
Version update (0.4.1 -> 0.4.2)

- Use correct source archive
- Update to version 0.4.2
* Mugshot has moved to Github
* Translation updates
- Generalize description and trim bias.

==== musepack ====

- Remove degree adverbs from description.

==== nano ====
Version update (4.3 -> 4.4)
Subpackages: nano-lang

- Update to version 4.4:
* At startup, the cursor can be put on the first or last
occurrence of a string by preceding the filename with +/string
or +?string.
* When automatic hard-wrapping occurs (--breaklonglines), any
leading quoting characters will be automatically copied to the
new line.
* M-6 works again also when the cursor is at end of buffer.

==== neon ====

- fix testsuite fail due to expired nulcerts (neon-0.30.2-nulcert.patch)
- BuildRequires libopenssl-1_1-devel >= 1.1.1 becase build fails with
1.1.0
- Remove pointless --with-pic (because of --disable-static)
- Disabled some tests due to behavior change in underlying OpenSSL.
- Replaced error message string to match new message from OpenSSL.
- Add neon-0.30.2_ssl-fix_timeout_retvals.patch implementing these
two changes.

==== nftables ====
Version update (0.9.0 -> 0.9.2)

- Update to new upstream release 0.9.2
* Transport header port matching, e.g. "th dport 53"
* Support for matching on IPv4 options
* Support for synproxy

==== nghttp2 ====
Version update (1.39.1 -> 1.39.2)

- Require correct library from devel package - boo#1125689
- Update to version 1.39.2 (bsc#1146184, bsc#1146182):
* This release fixes CVE-2019-9511 ?Data Dribble? and CVE-2019-9513
?Resource Loop? vulnerability in nghttpx and nghttpd. Specially crafted HTTP/2
frames cause Denial of Service by consuming CPU time. Check out

https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-002.md
for details. For nghttpx, additionally limiting inbound traffic by
- -read-rate and --read-burst options is quite effective against
this kind of attack.
* Add nghttp2_option_set_max_outbound_ack API function
* nghttpx: Fix request stall

==== openexr ====

- Enable tests on architectures with enough memory - boo#1146648
* disable imffuzztest as it takes to much resources

==== openpgm ====

- Add libpgm-5.2.122-configure-rdtsc-checking-chg.patch
same as https://github.com/steve-o/openpgm/pull/63

==== openssh ====
Subpackages: openssh-helpers

- don't install SuSEfirewall2 service on Factory, since SuSEfirewall2
has been replaced by firewalld, see [1].
[1]: https://lists.opensuse.org/opensuse-factory/2019-01/msg00490.html

==== opensuse-welcome ====
Version update (0.1.5 -> 0.1.6)
Subpackages: opensuse-welcome-lang

- Update to 0.1.6
- More translations, woo-hoo
- Fix bug where launching a help program causes the program to freeze

==== pam-config ====
Version update (1.1 -> 1.2)

- Update to version 1.2:
- use /usr/etc as second fallback directory

==== perl-Error ====
Version update (0.17027 -> 0.17028)

- updated to 0.17028
see /usr/share/doc/packages/perl-Error/Changes
0.17028 2019-08-23
- Moved the VCS repo to https://github.com/shlomif/perl-error.pm
- No other significant changes.

==== perl-HTML-Clean ====
Version update (0.8 -> 0.9)

- Drop perl-HTML-Clean-0.8-IO.diff as upstream moved to IO::File
- updated to 0.9
see /usr/share/doc/packages/perl-HTML-Clean/Changes
0.9 Tue Aug 20 09:24 PDT 2019
- Fix warnings - use IO::File instead deprecated module IO.

==== potrace ====

- Add potrace_configure_chg_for_lto.patch
to avoid PowerPC and ARM build failure when LTO enabled.

==== protobuf-c ====
Version update (1.3.1 -> 1.3.2)

- Update to new upstream release 1.3.2
* Fix proto3 repeated scalar field default packing behavior
* Fix out-of-bounds read in scan_length_prefixed_data()
- Remove protobuf-c-namespace.patch (merged)

==== python ====
Subpackages: python-curses python-tk

- Remove xrpm from subpackage tk description

==== python-gtk ====

- Drop python-numpy-devel BuildRequires and python-numpy Requires:
No longer build the optional numpy support.

==== python-packaging ====
Version update (19.0 -> 19.1)
Subpackages: python2-packaging python3-packaging

- Remove dependency on attrs
Add: 0005-Drop-dependency-on-attrs.patch
this fixes bsc#1144506
- Fix a bit the multibuild conversion
- Remove the attrs from the deps as they are no longer needed
- Enable tests via _multibuild
Add patches from https://github.com/pypa/packaging/pull/176:
* 0001-Fix-test-failures-test_linux_platforms_manylinux-for.patch
* 0002-Fix-check-for-64-bit-OS.patch
* 0003-Add-additional-test-to-get-100-branch-coverage.patch
* 0004-Fix-test_macos_version_detection-failure-on-32-bit-L.patch
(these fix the tests on non-x86 platforms and can be dropped on the next
release)
- Add Requires:python-attrs as this is a new dependency
this fixes bsc#1144506
- update to 19.1:
* Add the ``packaging.tags`` module.
* Correctly handle two-digit versions in ``python_version``

==== python-pyOpenSSL ====
Subpackages: python2-pyOpenSSL python3-pyOpenSSL

- Add fix-compilation-2020.patch to fix tests after 2020

==== python-pyzmq ====
Version update (18.0.2 -> 18.1.0)

- update to version 18.1.0:
* Compatibility with Python 3.8 release candidate by regenerating
Cython courses with Cython 0.29.13
* bump bundled libzmq to 4.3.2
* handle cancelled futures in asyncio
* make :meth:`zmq.Context.instance` fork-safe
* fix errors in :meth:`zmq.Context.destroy` when opening and closing
many sockets

==== python-setuptools ====
Version update (41.0.1 -> 41.2.0)
Subpackages: python2-setuptools python3-setuptools

- Switch to multibuild to enable testsuite
- Update to 41.2.0:
* #479: Remove some usage of the deprecated imp module.
* #1565: Changed html_sidebars from string to list of string as per
https://www.sphinx-doc.org/en/master/changes.html#id58
* #1697: Moved most of the constants from setup.py to setup.cfg
* #1756: Forse metadata-version >= 1.2. when project urls are present.

==== read-only-root-fs ====
Version update (1.0+git20190206.586e9f1 -> 1.0+git20190607.11f8587)

- Update to version 1.0+git20190607.11f8587:
* Determine /@ programmatically
- Update to version 1.0+git20190606.e1f756c:
* Mount writable /boot subvolume in GRUB environment
- Create /boot/writable subvolume to provide a place to store the
GRUB environment block or Ignition's firstboot flag on a ro root
device

==== remmina ====
Version update (1.3.5 -> 1.3.6)
Subpackages: remmina-lang remmina-plugin-rdp remmina-plugin-secret
remmina-plugin-vnc remmina-plugin-xdmcp

- Update to new upstream release 1.3.6
* Fix fullscreen switching
* Fullscreen fixes
* rdpr channel initialization for special devices sharing. Closes #1955
* Fixing remminamain destroy issues
* Makes Rmnews modal to avoid that it steals input to the RCW
* Make some cmake targets optional to avoid packaging isssues
* SNAP fixing dependencies for the plugin WWW
* Updating Remmna icon to the yaru/suru icon set.
* Adding harfbuzz headers, closes #1941
* New stats
* *.md: typo corrections
* Remove G+ from documents

==== rpm-config-SUSE ====
Version update (0.g27 -> 0.g32)

- Update to version 0.g32:
* find-provides.ksyms, find-requires.ksyms: cleanup kernel version handling
(bsc#1145601).
* find-requires.ksyms: fix matching of uninstalled files (bsc#1145601).
- Update to version 0.g29:
* find-requires.ksyms: Move modinfo and modprobe before the ksym dependency
code.

==== schily ====
Subpackages: cdda2wav cdrecord libcdrdeflt1_0 libdeflt1_0 libedc_ecc1_0
libedc_ecc_dec1_0 libfile1_0 libfind3_0 libparanoia1_0 librmt1_0 librscg1_0
libscg1_0 libscgcmd1_0 libschily2_0 mkisofs readcd spax star

- Update to new upstream release 2019.08.13
* mkisofs: The struct attrinfo in apple.h has been enhanced by the
struct members objid_low, objid_high, rsrc_length.

==== sudo ====

- Correct typo in sudoers patch

==== suse-module-tools ====
Version update (15.2.4 -> 15.2.5)

- Update to version 15.2.5:
* remove 'modhash' - moved to mokutil package (jsc#SLE-6094)

==== susepaste ====
Subpackages: susepaste-screenshot

- Trim duplicated wording from descriptions.

==== util-linux ====
Version update (2.33.2 -> 2.34)
Subpackages: libblkid-devel libblkid1 libblkid1-32bit libfdisk1 libmount1
libmount1-32bit libsmartcols1 libuuid-devel libuuid1 libuuid1-32bit
util-linux-lang

- Issue a warning for outdated pam files
(bsc#1082293, boo#1081947#c68).
- Fix comments and unify look of PAM files (login.pamd,
remote.pamd, runuser-l.pamd, runuser.pamd, su-l.pamd, su.pamd).
- Update to version 2.34:
* new command hardlink
* rewrite of lsblk, now supports --dedup
* support for FUSE in umount
* support for "--all -o remount" in mount
* su: prefer /etc/default/su over /etc/login.defs and ENV_SUPATH
over ENV_ROOTPATH (bsc#1121197), improved --pty
* unshare: add -S/--setuid, -G/--setgid, -R/--root and -w/--wd
* fstrim: do not suppress warnings unless --quiet is used
* lscpu: print 'Frequency boost' and 'Vulnerability' fields, add
- -caches
* logger: merge multiple MESSAGE= lines
* libblkid: do not depend on libuuid, supports DRBD9 detection
* libsmartcols: support N:M relationships in tree-like output
* fstrim and uuidd systemd services: hardening settings to
improve security and service isolation
* fstrim: trim root filesystem on --fstab, check for read-only
filesystems on --all and --fstab (boo#1106214).
* fstrim -A: properly de-duplicate sub-volumes (boo#1127701).
* Obsoletes util-linux-login_defs-priority1.patch,
util-linux-login_defs-priority2.patch and
util-linux-login_defs-SYS_UID.patch.
* Many Other fixes, see
https://www.kernel.org/pub/linux/utils/util-linux/v2.34/v2.34-ReleaseNotes
- Provide and obsolete hardlink package.
- util-linux-login_defs-check.sh: Update checksum, login now
supports LASTLOG_UID_MAX.
- Fix /etc/default/su comments and create /etc/default/runuser
(bsc#1121197#31).
- Remove /etc/default/su migration from coreutils.

==== util-linux-systemd ====
Version update (2.33.2 -> 2.34)

- Issue a warning for outdated pam files
(bsc#1082293, boo#1081947#c68).
- Fix comments and unify look of PAM files (login.pamd,
remote.pamd, runuser-l.pamd, runuser.pamd, su-l.pamd, su.pamd).
- Update to version 2.34:
* new command hardlink
* rewrite of lsblk, now supports --dedup
* support for FUSE in umount
* support for "--all -o remount" in mount
* su: prefer /etc/default/su over /etc/login.defs and ENV_SUPATH
over ENV_ROOTPATH (bsc#1121197), improved --pty
* unshare: add -S/--setuid, -G/--setgid, -R/--root and -w/--wd
* fstrim: do not suppress warnings unless --quiet is used
* lscpu: print 'Frequency boost' and 'Vulnerability' fields, add
- -caches
* logger: merge multiple MESSAGE= lines
* libblkid: do not depend on libuuid, supports DRBD9 detection
* libsmartcols: support N:M relationships in tree-like output
* fstrim and uuidd systemd services: hardening settings to
improve security and service isolation
* fstrim: trim root filesystem on --fstab, check for read-only
filesystems on --all and --fstab (boo#1106214).
* fstrim -A: properly de-duplicate sub-volumes (boo#1127701).
* Obsoletes util-linux-login_defs-priority1.patch,
util-linux-login_defs-priority2.patch and
util-linux-login_defs-SYS_UID.patch.
* Many Other fixes, see
https://www.kernel.org/pub/linux/utils/util-linux/v2.34/v2.34-ReleaseNotes
- Provide and obsolete hardlink package.
- util-linux-login_defs-check.sh: Update checksum, login now
supports LASTLOG_UID_MAX.
- Fix /etc/default/su comments and create /etc/default/runuser
(bsc#1121197#31).
- Remove /etc/default/su migration from coreutils.

==== util-macros ====

- Own %{_datadir}/aclocal: when we might switch to pkgconf instead
of pkg-config, nothing in the build root is 'accidentally' owning
this directory for us.

==== xdm ====
Subpackages: xdm-xsession

- pam.d/xdm{,-np}: added pam_keyinit.so (boo#1144063)

==== xfce4-screenshooter ====
Version update (1.9.5 -> 1.9.6)
Subpackages: xfce4-screenshooter-lang xfce4-screenshooter-plugin

- Update to version 1.9.6
* Do not show translation info on --help output (bxo#15883)
* Avoid destroying size window twice (bxo#15792)
* Replace GtkStock buttons
* Add missing NULL as last parameter of
xfce_titled_dialog_new_with_buttons() (bxo#14973)
* Do not use root coordinates for region capture (bxo#15406)
* Install AppData into metainfo
* Update AppData file
* Try to grab seat more than once (bxo#15320)
* Use new xfce_gdk_screen_get_geometry if available
* Make screenshooter-imgur-dialog.ui translatable (bxo#15254)
* Translation Updates

==== xfce4-whiskermenu-plugin ====
Subpackages: xfce4-whiskermenu-plugin-lang

- Compact description. Ensure neutrality of description.

==== xtrans ====

- Own %{_datadir}/aclocal: when we might switch to pkgconf instead
of pkg-config, nothing in the build root is 'accidentally' owning
this directory for us.

==== yast2-alternatives ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-auth-client ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-auth-server ====
Version update (4.2.2 -> 4.2.3)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.3

==== yast2-configuration-management ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-dns-server ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-http-server ====
Version update (4.2.0 -> 4.2.1)

- bnc#114553
- loaded missing namespace to avoid internal error
- 4.2.1

==== yast2-installation ====
Version update (4.2.10 -> 4.2.11)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.11

==== yast2-iscsi-client ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-journal ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-kdump ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-online-update ====
Version update (4.2.1 -> 4.2.2)
Subpackages: yast2-online-update-frontend

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-pam ====
Version update (4.2.3 -> 4.2.4)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.4

==== yast2-proxy ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-ruby-bindings ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-security ====
Version update (4.2.0 -> 4.2.1)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.1

==== yast2-services-manager ====
Version update (4.2.0 -> 4.2.3)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.3

==== yast2-storage-ng ====
Version update (4.2.32 -> 4.2.35)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.35
- log all ng proposal settings
- 4.2.34
- Initial Guided Proposal: added support to make the proposal
using all candidates devices, without trying all possible set
of settings for each individual device first (related to
jsc#SLE-7238).
- 4.2.33

==== yast2-theme ====
Version update (4.2.4 -> 4.2.5)
Subpackages: yast2-theme-breeze yast2-theme-oxygen

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.5

==== yast2-trans ====
Version update (84.87.20190811.da547f2b17 -> 84.87.20190825.25c7d8a3aa)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv
yast2-trans-ta yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi
yast2-trans-wa yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20190825.25c7d8a3aa:
* Translated using Weblate (Chinese (China))
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Czech)
* New POT for text domain 'http-server'.
- Update to version 84.87.20190818.25be0081c6:
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Portuguese)
* Translated using Weblate (Hindi)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* New POT for text domain 'country'.
* New POT for text domain 'control'.
* New POT for text domain 'caasp'.
* New POT for text domain 'cluster'.
* Translated using Weblate (German)
* Translated using Weblate (Portuguese)
* Translated using Weblate (Portuguese)
* New POT for text domain 'installation'.
* Translated using Weblate (French)
* Translated using Weblate (French)

==== yast2-update ====
Version update (4.2.4 -> 4.2.5)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.5

==== yast2-vpn ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== zimg ====
Version update (2.9.1 -> 2.9.2)

- Switch to git checkout (GitHub tarbals lack required submodules)
- Build unit tests separately as they impact the build result and
produce a broken install rule
- Update to version 2.9.2:
* colorspace: fix crash on invalid conversion from unspec to
real primaries
* x86: additional optimizations for AMD Piledriver
* x86: optimizations for AMD Zen2 processors


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups