Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190820 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Fri, 23 Aug 2019 00:04:42 +0000
  • Message-id: <156651868273.12119.17140920487977097344@go-agent-stagingbot-4>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190820

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
389-ds (1.4.1.2~git0.9a126614a -> 1.4.1.6~git0.5ac5a8aad)
akonadi-calendar (19.04.3 -> 19.08.0)
akonadi-calendar-tools (19.04.3 -> 19.08.0)
akonadi-contact (19.04.3 -> 19.08.0)
akonadi-import-wizard (19.04.3 -> 19.08.0)
akonadi-mime (19.04.3 -> 19.08.0)
akonadi-notes (19.04.3 -> 19.08.0)
akonadi-search (19.04.3 -> 19.08.0)
akonadi-server (19.04.3 -> 19.08.0)
akregator (19.04.3 -> 19.08.0)
analitza (19.04.3 -> 19.08.0)
appstream-glib (0.7.14+0 -> 0.7.15)
apr (1.6.5 -> 1.7.0)
ark (19.04.3 -> 19.08.0)
attica-qt5 (5.60.0 -> 5.61.0)
baloo5 (5.60.0 -> 5.61.0)
baloo5-widgets (19.04.3 -> 19.08.0)
blinken (19.04.3 -> 19.08.0)
bluez-qt (5.60.0 -> 5.61.0)
bovo (19.04.3 -> 19.08.0)
breeze5-icons (5.60.0 -> 5.61.0)
calendarsupport (19.04.3 -> 19.08.0)
catfish (1.4.8 -> 1.4.9)
cervisia (19.04.3 -> 19.08.0)
dolphin (19.04.3 -> 19.08.0)
dragonplayer (19.04.3 -> 19.08.0)
eventviews (19.04.3 -> 19.08.0)
exo (0.12.7 -> 0.12.8)
ffmpeg-4
ffmpegthumbs (19.04.3 -> 19.08.0)
frameworkintegration (5.60.0 -> 5.61.0)
git (2.22.0 -> 2.22.1)
gnome-documents
gnome-video-effects (0.4.3 -> 0.5.0)
gnu-unifont-bitmap-fonts (12.0.01 -> 12.1.03)
gobject-introspection
grantleetheme (19.04.3 -> 19.08.0)
gstreamer-plugins-bad
gwenview5 (19.04.3 -> 19.08.0)
hwdata (0.325 -> 0.326)
incidenceeditor (19.04.3 -> 19.08.0)
iw (5.0.1 -> 5.3)
juk (19.04.3 -> 19.08.0)
k3b (19.04.3 -> 19.08.0)
kaccounts-integration (19.04.3 -> 19.08.0)
kaccounts-providers (19.04.3 -> 19.08.0)
kactivities-stats (5.60.0 -> 5.61.0)
kactivities5 (5.60.0 -> 5.61.0)
kaddressbook (19.04.3 -> 19.08.0)
kalarmcal (19.04.3 -> 19.08.0)
kalgebra (19.04.3 -> 19.08.0)
kalzium (19.04.3 -> 19.08.0)
kamera (19.04.3 -> 19.08.0)
kanagram (19.04.3 -> 19.08.0)
kapptemplate (19.04.3 -> 19.08.0)
karchive (5.60.0 -> 5.61.0)
kate (19.04.3 -> 19.08.0)
katomic (19.04.3 -> 19.08.0)
kauth (5.60.0 -> 5.61.0)
kblackbox (19.04.3 -> 19.08.0)
kblocks (19.04.3 -> 19.08.0)
kbookmarks (5.60.0 -> 5.61.0)
kbounce (19.04.3 -> 19.08.0)
kbreakout (19.04.3 -> 19.08.0)
kbruch (19.04.3 -> 19.08.0)
kcachegrind (19.04.3 -> 19.08.0)
kcalc (19.04.3 -> 19.08.0)
kcalcore (19.04.3 -> 19.08.0)
kcalutils (19.04.3 -> 19.08.0)
kcharselect (19.04.3 -> 19.08.0)
kcmutils (5.60.0 -> 5.61.0)
kcodecs (5.60.0 -> 5.61.0)
kcolorchooser (19.04.3 -> 19.08.0)
kcompletion (5.60.0 -> 5.61.0)
kconfigwidgets (5.60.0 -> 5.61.0)
kcontacts (19.04.3 -> 19.08.0)
kcoreaddons (5.60.0 -> 5.61.0)
kcrash (5.60.0 -> 5.61.0)
kcron (19.04.3 -> 19.08.0)
kdav (19.04.3 -> 19.08.0)
kdbusaddons (5.60.0 -> 5.61.0)
kde-print-manager (19.04.3 -> 19.08.0)
kdeclarative (5.60.0 -> 5.61.0)
kded (5.60.0 -> 5.61.0)
kdeedu-data (19.04.3 -> 19.08.0)
kdegraphics-thumbnailers (19.04.3 -> 19.08.0)
kdelibs4support (5.60.0 -> 5.61.0)
kdenetwork-filesharing (19.04.3 -> 19.08.0)
kdepim-addons (19.04.3 -> 19.08.0)
kdepim-apps-libs (19.04.3 -> 19.08.0)
kdepim-runtime (19.04.3 -> 19.08.0)
kdesu (5.60.0 -> 5.61.0)
kdf (19.04.3 -> 19.08.0)
kdialog (19.04.3 -> 19.08.0)
kdiamond (19.04.3 -> 19.08.0)
kdnssd-framework (5.60.0 -> 5.61.0)
kdoctools (5.60.0 -> 5.61.0)
kemoticons (5.60.0 -> 5.61.0)
kfilemetadata5 (5.60.0 -> 5.61.0)
kgeography (19.04.3 -> 19.08.0)
kget (19.04.3 -> 19.08.0)
kglobalaccel (5.60.0 -> 5.61.0)
kgoldrunner (19.04.3 -> 19.08.0)
kguiaddons (5.60.0 -> 5.61.0)
khangman (19.04.3 -> 19.08.0)
khelpcenter5 (19.04.3 -> 19.08.0)
kholidays (5.60.0 -> 5.61.0)
khtml (5.60.0 -> 5.61.0)
ki18n (5.60.0 -> 5.61.0)
kiconthemes (5.60.0 -> 5.61.0)
kidentitymanagement (19.04.3 -> 19.08.0)
kidletime (5.60.0 -> 5.61.0)
kig (19.04.3 -> 19.08.0)
kimageformats (5.60.0 -> 5.61.0)
kimagemapeditor (19.04.3 -> 19.08.0)
kimap (19.04.3 -> 19.08.0)
kinit (5.60.0 -> 5.61.0)
kio (5.60.0 -> 5.61.0)
kio-extras5 (19.04.3 -> 19.08.0)
kio_audiocd (19.04.3 -> 19.08.0)
kipi-plugins (5.9.1 -> 19.08.0)
kirigami2 (5.60.0 -> 5.61.0)
kiriki (19.04.3 -> 19.08.0)
kitemmodels (5.60.0 -> 5.61.0)
kitemviews (5.60.0 -> 5.61.0)
kiten (19.04.3 -> 19.08.0)
kitinerary (19.04.3 -> 19.08.0)
kjobwidgets (5.60.0 -> 5.61.0)
kjs (5.60.0 -> 5.61.0)
kjsembed (5.60.0 -> 5.61.0)
kjumpingcube (19.04.3 -> 19.08.0)
kldap (19.04.3 -> 19.08.0)
kleopatra (19.04.3 -> 19.08.0)
klines (19.04.3 -> 19.08.0)
kmag (19.04.3 -> 19.08.0)
kmahjongg (19.04.3 -> 19.08.0)
kmail (19.04.3 -> 19.08.0)
kmail-account-wizard (19.04.3 -> 19.08.0)
kmailtransport (19.04.3 -> 19.08.0)
kmbox (19.04.3 -> 19.08.0)
kmime (19.04.3 -> 19.08.0)
kmines (19.04.3 -> 19.08.0)
kmousetool (19.04.3 -> 19.08.0)
kmouth (19.04.3 -> 19.08.0)
kmplot (19.04.3 -> 19.08.0)
knavalbattle (19.04.3 -> 19.08.0)
knetwalk (19.04.3 -> 19.08.0)
knewstuff (5.60.0 -> 5.61.0)
knotes (19.04.3 -> 19.08.0)
knotifications (5.60.0 -> 5.61.0)
knotifyconfig (5.60.0 -> 5.61.0)
kolf (19.04.3 -> 19.08.0)
kollision (19.04.3 -> 19.08.0)
kolourpaint (19.04.3 -> 19.08.0)
kompare (19.04.3 -> 19.08.0)
konquest (19.04.3 -> 19.08.0)
konsole (19.04.3 -> 19.08.0)
kontact (19.04.3 -> 19.08.0)
kontactinterface (19.04.3 -> 19.08.0)
konversation
kopete (19.04.3 -> 19.08.0)
korganizer (19.04.3 -> 19.08.0)
kpackage (5.60.0 -> 5.61.0)
kparts (5.60.0 -> 5.61.0)
kpat (19.04.3 -> 19.08.0)
kpeople5 (5.60.0 -> 5.61.0)
kpimtextedit (19.04.3 -> 19.08.0)
kpkpass (19.04.3 -> 19.08.0)
kplotting (5.60.0 -> 5.61.0)
kpty (5.60.0 -> 5.61.0)
kqtquickcharts (19.04.3 -> 19.08.0)
krdc (19.04.3 -> 19.08.0)
kreversi (19.04.3 -> 19.08.0)
krfb (19.04.3 -> 19.08.0)
kross (5.60.0 -> 5.61.0)
kruler (19.04.3 -> 19.08.0)
krunner (5.60.0 -> 5.61.0)
kservice (5.60.0 -> 5.61.0)
kshisen (19.04.3 -> 19.08.0)
ksirk (19.04.3 -> 19.08.0)
ksmtp (19.04.3 -> 19.08.0)
kspaceduel (19.04.3 -> 19.08.0)
ksquares (19.04.3 -> 19.08.0)
ksudoku (19.04.3 -> 19.08.0)
ksystemlog (19.04.3 -> 19.08.0)
kteatime (19.04.3 -> 19.08.0)
ktexteditor (5.60.0 -> 5.61.0)
ktextwidgets (5.60.0 -> 5.61.0)
ktimer (19.04.3 -> 19.08.0)
ktnef (19.04.3 -> 19.08.0)
ktouch (19.04.3 -> 19.08.0)
ktuberling (19.04.3 -> 19.08.0)
kturtle (19.04.3 -> 19.08.0)
kubrick (19.04.3 -> 19.08.0)
kunitconversion (5.60.0 -> 5.61.0)
kwallet (5.60.0 -> 5.61.0)
kwalletmanager5 (19.04.3 -> 19.08.0)
kwayland (5.60.0 -> 5.61.0)
kwidgetsaddons (5.60.0 -> 5.61.0)
kwindowsystem (5.60.0 -> 5.61.0)
kwordquiz (19.04.3 -> 19.08.0)
kxmlgui (5.60.0 -> 5.61.0)
kxmlrpcclient5 (5.60.0 -> 5.61.0)
ldns (1.7.0 -> 1.7.1)
libKF5ModemManagerQt (5.60.0 -> 5.61.0)
libKF5NetworkManagerQt (5.60.0 -> 5.61.0)
libavc1394
libcap-ng
libdbusmenu
libdvdnav
libdvdread
libgravatar (19.04.3 -> 19.08.0)
libgsm
libkcddb (19.04.3 -> 19.08.0)
libkcompactdisc (19.04.3 -> 19.08.0)
libkdcraw (19.04.3 -> 19.08.0)
libkdegames (19.04.3 -> 19.08.0)
libkdepim (19.04.3 -> 19.08.0)
libkeduvocdocument (19.04.3 -> 19.08.0)
libkexiv2 (19.04.3 -> 19.08.0)
libkgapi (19.04.3 -> 19.08.0)
libkipi (19.04.3 -> 19.08.0)
libkleo (19.04.3 -> 19.08.0)
libkmahjongg (19.04.3 -> 19.08.0)
libkomparediff2 (19.04.3 -> 19.08.0)
libksane (19.04.3 -> 19.08.0)
libksieve (19.04.3 -> 19.08.0)
libmpcdec
libofa
libqt5-qtbase
libqt5-qtwayland
libsigc++2 (2.10.1 -> 2.10.2)
libstorage-ng (4.1.144 -> 4.1.145)
libvirt (5.5.0 -> 5.6.0)
libxfce4ui (4.12.1 -> 4.14.1)
libxfce4util (4.12.1 -> 4.14.0)
lokalize (19.04.3 -> 19.08.0)
lskat (19.04.3 -> 19.08.0)
mailcommon (19.04.3 -> 19.08.0)
mailimporter (19.04.3 -> 19.08.0)
makedumpfile
mbox-importer (19.04.3 -> 19.08.0)
messagelib (19.04.3 -> 19.08.0)
mobipocket (19.04.3 -> 19.08.0)
mousepad (0.4.1 -> 0.4.2)
nghttp2 (1.38.0 -> 1.39.1)
okular (19.04.3 -> 19.08.0)
openblas_pthreads (0.3.6 -> 0.3.7)
opus
oxygen5-icon-theme (5.60.0 -> 5.61.0)
parley (19.04.3 -> 19.08.0)
patterns-media
patterns-xfce (20190412 -> 20190809)
perl-DBD-SQLite (1.62 -> 1.64)
perl-Test-Simple (1.302164 -> 1.302166)
pim-data-exporter (19.04.3 -> 19.08.0)
pim-sieve-editor (19.04.3 -> 19.08.0)
pimcommon (19.04.3 -> 19.08.0)
pkcs11-helper
pkgconf (1.6.1 -> 1.6.3)
plasma-framework (5.60.0 -> 5.61.0)
prison-qt5 (5.60.0 -> 5.61.0)
publicsuffix (20190529 -> 20190808)
purpose (5.60.0 -> 5.61.0)
python-gssapi (1.6.0 -> 1.6.1)
python-libvirt-python (5.5.0 -> 5.6.0)
python-numpy (1.16.4 -> 1.17.0)
python-pip (19.2.1 -> 19.2.2)
python-scipy (1.3.0 -> 1.3.1)
python2-numpy
qqc2-desktop-style (5.60.0 -> 5.61.0)
quota
radvd (2.17 -> 2.18)
re2c (1.1.1 -> 1.2.1)
ristretto (0.8.5 -> 0.10.0)
rubygem-exception_notification (4.3.0 -> 4.4.0)
rubygem-excon (0.64.0 -> 0.66.0)
rubygem-msgpack (1.3.0 -> 1.3.1)
rubygem-nokogiri (1.10.3 -> 1.10.4)
rubygem-puma (4.0.1 -> 4.1.0)
rubygem-pundit (2.0.1 -> 2.1.0)
rubygem-rails-html-sanitizer (1.0.4 -> 1.2.0)
rubygem-sass-rails (5.0.7 -> 6.0.0)
rubygem-web-console (3.7.0 -> 4.0.1)
schily
signon-kwallet-extension (19.04.3 -> 19.08.0)
solid (5.60.0 -> 5.61.0)
sonnet (5.60.0 -> 5.61.0)
soundtouch
spectacle (19.04.3 -> 19.08.0)
step (19.04.3 -> 19.08.0)
sweeper (19.04.3 -> 19.08.0)
syndication (5.60.0 -> 5.61.0)
syntax-highlighting (5.60.0 -> 5.61.0)
taglib (1.11.2~git20190531.ba7adc2b -> 1.11.2~git20190725.79bc9ccf)
telepathy-logger
thin-provisioning-tools (0.8.3 -> 0.8.5)
threadweaver (5.60.0 -> 5.61.0)
thunar (1.8.8 -> 1.8.9)
thunar-volman (0.9.4 -> 0.9.5)
tumbler (0.2.5 -> 0.2.7)
umbrello (19.04.3 -> 19.08.0)
vte
wavpack (5.1.0 -> 5.1.0~git20190420.22977b2)
wicked (0.6.54 -> 0.6.55)
xdg-desktop-portal-gtk
xen (4.12.0_16 -> 4.12.1_02)
xfce4-appfinder (4.12.0 -> 4.14.0)
xfce4-branding-openSUSE (4.12.0 -> 4.14+20190815)
xfce4-dev-tools (4.12.0 -> 4.14.0)
xfce4-panel (4.12.2 -> 4.14.0)
xfce4-power-manager (1.6.1 -> 1.6.5)
xfce4-screenshooter
xfce4-session (4.12.1 -> 4.14.0)
xfce4-settings (4.12.4 -> 4.14.0)
xfconf (4.12.1 -> 4.14.1)
xfdesktop (4.12.5 -> 4.14.1)
xfwm4 (4.12.5 -> 4.14.0)
yakuake (3.0.5 -> 19.08.0)
yast2-country (4.2.3 -> 4.2.4)

=== Details ===

==== 389-ds ====
Version update (1.4.1.2~git0.9a126614a -> 1.4.1.6~git0.5ac5a8aad)
Subpackages: lib389 libsvrcore0

- Fix spec file discrepencies from SLE
- Update to correct license issue in spec file
- Update to simplify rust option selection
- Update to version 1.4.1.6~git0.5ac5a8aad:
* Bump version to 1.4.1.6
* Issue 50355 - SSL version min and max not correctly applied
* Issue 50497 - Port cl-dump.pl tool to Python using lib389
* Issue: 48851 - investigate and port TET matching rules filter tests(Final)
* correction to fix for #50417
* Issue 50425 - Add jemalloc LD_PRELOAD to systemd drop-in file
* Issue 50425 - Add jemalloc LD_PRELOAD to systemd drop-in file
* Issue 50325 - Add Security tab to UI
* Ticket 49789 - By default, do not manage unhashed password
* Ticket 49421 - Implement password hash upgrade on bind.
* Ticket 49421 - on bind password upgrade proof of concept
* Ticket 50493 - connection_is_free to trylock
* Ticket 50459 - Correct issue with allocation state
* Issue 50499 - Fix audit issues and remove jquery from the whitelist
* Ticket 50459 - c_mutex to use pthread_mutex to allow ns sharing
* Ticket 50484 - Add a release build dockerfile and dscontainer improvements
* Issue 50486 - Update jemalloc to 5.2.0
- Update to version 1.4.1.5~git0.748334143:
* Bump version to 1.4.1.5
* Issue 50431 - Fix regression from coverity fix
* Issue 49239 - Add a new CI test case
* Issue 49997 - Add a new CI test case
* Issue 50177 - Add a new CI test case, also added fixes in lib389
* Issue 49761 - Fix CI test suite issues
* Issue 50474 - Unify result codes for add and modify of repl5 config
* Ticket 50472 - memory leak with encryption
* Issue 50462 - Fix Root DN access control plugin CI tests
* Issue 50462 - Fix CI tests
* Ticket 50217 - Implement dsconf security section
* Issue: 48851 - Add more test cases to the match test suite.
* Issue 50378 - ACI's with IPv4 and IPv6 bind rules do not work for IPv6
clients
* Ticket 50439 - fix waitpid issue when pid does not exist
* Issue 50454 - Fix Cockpit UI branding
* Issue: 48851 - investigate and port TET matching rules filter tests(index)
* Issue 49232 - Truncate the message when buffer capacity is exceeded
* Bump version to 1.4.1.4
* Ticket 49361 - Use IPv6 friendly network functions
* Issue: 48851 - Investigate and port TET matching rules filter
tests(bug772777)
* Issue: 50446 - NameError: name 'ds_is_older' is not defined
* Issue 49602 - Revise replication status messages
* Ticket 50439 - Update docker integration to work out of source directory
* Ticket 50037 - revert path changes as it breaks prefix/rpm builds
* Issue 50431 - Fix regression from coverity fix
* Issue 50370 - CleanAllRUV task crashing during server shutdown
* Issue: 48851 - investigate and port TET matching rules filter tests(match)
* Issue 50417 - Fix missing quote in some legacy tools
* Ticket 50431 - Fix covscan warnings
* Revert "Issue 49960 - Core schema contains strings instead of numer oids"
* Issue 50426 - nsSSL3Ciphers is limited to 1024 characters
* Issue 50052 - Fix rpm.mk according to audit-ci change
* Issue 50365 - PIDFile= references path below legacy directory /var/run/
* Ticket 50428 - Log the actual base DN when the search fails with "invalid
attribute request"
* Ticket 50329 - (2nd) Possible Security Issue: DOS due to ioblocktimeout not
applying to TLS
* Ticket 50417 - Revise legacy tool scripts to work with new systemd changes
* Issue: 48851 - Add more search filters to vfilter_simple test suite
* Issue 49761 - Fix CI test suite issues
* Issue 49875 - Move SystemD service config to a drop-in file
* Ticket 50413 - ds-replcheck - Always display the Result Summary
* Issue 50052 - Add package-lock.json and use "npm ci"
* Issue: 48851 - investigate and port TET matching rules filter tests(vfilter
simple)
* Ticket 50355 - NSS can change the requested SSL min and max versions
* Issue: 48851 - investigate and port TET matching rules filter
tests(vfilter_ld)
* Issue 50390 - Add Managed Entries Plug-in Config Entry schema
* Ticket 49730 - Remove unused Mozilla ldapsdk variables
- Update to version 1.4.1.3~git0.1f1119d4b:
* Bump version to 1.4.1.3
* Issue 49761 - Fix CI test suite issues
* Issue 50041 - Add the rest UI Plugin tabs - Part 2
* Ticket 50340 - 2nd try - structs for diabled plugins will not be freed
* Issue 50403 - Instance creation fails on 1.3.9 using perl utils and latest
lib389
* Ticket 50389 - ns-slapd craches while two threads are polling the same
connection
* Issue: 48851 - investigate and port TET matching rules filter
tests(scanlimit)
* Issue 50037 - lib389 fails to install in venv under non-root user
* Issue: 50112 - Port ACI test suit from TET to python3(userattr)
* Ticket 50393 - maxlogsperdir accepting negative values
* Issue: 50112 - Port ACI test suit from TET to python3(roledn)
* Issue 49960 - Core schema contains strings instead of numer oids
* Ticket 50396 - Crash in PAM plugin when user does not exist
* Issue 50387 - enable_tls() should label ports with ldap_port_t
* Issue 50390 - Add Managed Entries Plug-in Config Entry schema
* Ticket 50306 - Fix regression with maxbersize
* Issue 50384 - Missing dependency: cracklib-dicts
* Issue 49029 - [RFE] improve internal operations logging
* Issue 49761 - Fix CI test suite issues
* Issue - 50374 dsdim posixgroup create fails with ERROR
* Ticket 50251 - clear text passwords visable in CLI verbose mode logging
* Ticket 50378 - ACI's with IPv4 and IPv6 bind rules do not work for IPv6
clients
* Issue:48851 - investigate and port TET matching rules filter tests
* Issue 50220 - attr_encryption test suite failing
* Ticket 50370 - CleanAllRUV task crashing during server shutdown
* Ticket 50340 cont - structs for disabled plugins will not be freed
* Fix missing import
* Issue 50164 - Add test for dscreate to basic test suite
* Ticket 50363 - ds-replcheck incorrectly reports error out of order
multi-valued attributes
* Issue 49730 - MozLDAP bindings have been unsupported for a while
* Issue #50353 - Categorize tests by tiers
* Issue 50303 - Add creation date to task data
* Issue: 50358 - Create a Bitwise Plugin class in plugins.py
* Remove the nss3 path prefix from the cert.h C preprocessor source file
inclusion
* Ticket 50329 - revert fix
* Issue: 50112 - Port ACI test suit from TET to python3(keyaci)
* Ticket 50344 - tidy rpm vs build systemd flag handling
* Issue #50067 - Fix krb5 dependency in a specfile
* Ticket 50340 - structs for diabled plugins will not be freed
* Ticket 50327 - Add replication conflict support to UI
* Ticket 50327 - Add replication conflict entry support to lib389/CLI
* Ticket 50329 - improve connection default parameters
* Issue: 50313 - Add a NestedRole type to lib389
* Issue:50112 - Port ACI test suit from TET to python3(Delete and Add)
* Ticket 49390, 50019 - support cn=config compare operations
* Issue 50041 - Add the rest UI Plugin tabs - Part 1
* Ticket 50329 - Possible Security Issue: DOS due to ioblocktimeout not
applying to TLS
* Ticket 49990 - Increase the default FD limits
* Ticket 50306 - (cont typo) Move connection config inside struct
* Ticket 50291 - Add monitor tab functionality to Cockpit UI
* Fix cockpit console AppStream data
* Ticket 50317 - fix ds-backtrace issue on latest gdb
* Ticket 50305 - Revise CleanAllRUV task restart process
* Fix typo from: Issue 49915 - Add regression test
* Issue 50026 - Audit log does not capture the operation where
nsslapd-lookthroughlimit is modified
* Ticket 49899 - fix pin.txt and pwdfile permissions
* Issue 49915 - Add regression test
* Ticket 50303 - Add task creation date to task data
* Ticket 50306 - Move connection config inside struct
* Ticket 50240 - Improve task logging
* Issue 50032 - Fix deprecation warnings in tests
* Ticket 50310 - fix sasl header include
* Ticket 49390 - improve compare and cn=config compare tests

==== akonadi-calendar ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
* Adapt to KCalCore namespace change
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attachment changes
* Adapt to KCalCore::Attendee changes
* Prepare for Attendee becoming a value type
* When we use framework 5.59.0 we can use new logging file directory
* Remove unused legacy include
* Adapt to KCalCore::Person changes
* Add executable attribute
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry
* Fix clazy warning
* Remove unused shared-pointer-to-self hack
* Make it compile without FOREACH

==== akonadi-calendar-tools ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-calendar-tools-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Adapt to KCalendarCore namespace change
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attachment changes
* When we use framework 5.59.0 we can use new logging file directory

==== akonadi-contact ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== akonadi-import-wizard ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Add missing QVector include
* When we use framework 5.59.0 we can use new logging file directory
* Use QVector here
* Adapt to new api
* It was fixed in 5.13.0beta2
* It compiles fine without foreach

==== akonadi-mime ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* Port to new connect api
* Allow to not regenerate xdg mime file (only for dev). It takes some time to
generate it
* It compiles fine without foreach
* autotests: cleanup, compilation fixes... but leave them disabled in the end

==== akonadi-notes ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* It compiles fine without foreach
* It's already defined in FrameworkCompilerSettings

==== akonadi-search ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attendee changes
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* Adapt to KCalCore::Person changes
* Make it compile without foreach
* Add option for disabling akonadi autotest (enable by default)

==== akonadi-server ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Fix compatibility with QMYSQL driver after 74aed95
- Dropped patches, superseded by upstream changes:
* 0001-Revert-Adapt-DBInitializer-to-behavior-change-of-QPS.patch
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== akregator ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akregator-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== analitza ====
Version update (19.04.3 -> 19.08.0)
Subpackages: analitza-lang libAnalitza5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* find qt5xml as dependency
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration
* Port deprecated method
* It's time to use cmake 3.5
* Create a small demo app that turns plots into soundwaves
* Remove redundant code that can be inferred
* Still find header after installing
* Const'ify + use new connect api
* Deprecating rotation function
* Tell cmake eigen includes are SYSTEM ones
* Use Qt CamelCase includes

==== appstream-glib ====
Version update (0.7.14+0 -> 0.7.15)
Subpackages: appstream-glib-lang libappstream-glib8

- Update to version 0.7.15:
+ Notes: The libappstream-builder shared library is no longer
installed.
+ New Features:
- Add as_content_rating_get_rating_ids().
- Add as_release_set_install_duration().
- Add as_utils_vercmp_full() for gnome-software.
- Add support for CONTACT URLs.
- Add support for per-release URLs.
- Add support for SOURCE URLs.
- Make as_content_rating_attribute_to_csm_age() public.
+ Bugfixes:
- Add missing OARS ? CSM mappings.
- Add some thread safety to AsApp and AsStore.
- Do not overwrite the project group using heuristics if
already set.
- Recognise uncompressed Arch packages.
- Remove unnecessary gtk dependency for builder.
- Return G_IO_ERROR_NOT_FOUND when loading fails.
- Tokenize the ID when adding search tokens.
- Drop pkgconfig(gtk+-3.0) BuildRequires: No longer needed.
- Switch to obs_scm service, use explict tag ref in _service,
ensure we only use released tags and drop tag offset in version.
- Drop no longer built subpackages libappstream-builder8 and
typelib-1_0-AppStreamBuilder-1_0.

==== apr ====
Version update (1.6.5 -> 1.7.0)
Subpackages: apr-devel libapr1

- Version 1.7.0
* apr_dir_read: [Unix] Dropped the preference of the dirread_r() flavor
for dirread(), because the former is both deprecated and unneeded.
[Yann Ylavic, William Rowe]
* apr_file_info: [Win32 only] Treat only "name surrogate" reparse points
as symlinks, and not other reparse tag types. PR47630
[Oleg Liatte <olegliatte gmail.com>]
* Test %ld vs. %lld to avoid compiler emits using APR_OFF_T_FMT, in the
case of apparently equivilant long and long long types. [William Rowe]
* Recognize APPLE predefined macros as equivilant to DARWIN. [Jim Jagielski]
* Signals: Allow handling of SIGUSR2 in apr_signal_thread. [Yann Ylavic]
* Atomics: Support for 64bit ints. [Jim Jagielski]
* Add the apr_encode_* API that implements RFC4648 and RFC7515
compliant BASE64, BASE64URL, BASE32, BASE32HEX and BASE16
encode/decode functions. [Graham Leggett]
* rand: Use arc4random_buf() on BSD platforms and getrandom() on Linux,
when available. [Christian Weisgerber <naddy openbsd.org, Yann Ylavic]
* Add apr_sockaddr_zone_set, apr_sockaddr_zone_set to set and retrieve
the zone for link-local IPv6 addresses. [Joe Orton]
* apr_sockaddr_equal: Compare link-local IPv6 addresses with different
zones as not equal. [Joe Orton]
* apr_sockaddr_ip_getbuf, apr_sockaddr_ip_get: Append "%zone" for
IPv6 link-local addresses. [Joe Orton]
* Locks: add a --disable-timedlocks config option in case users
encounter more platforms where it fails [Nick Kew].
* apr_allocator, apr_pools: Add apr_allocator_page_size() and
apr_allocator_min_order_set() to respectively get the (system's) page size
in use and set the minimum allocation size for an allocator (expressed in
2^order pages). [Yann Ylavic]
* locks: provide portable implementations of timedlock()s for
posix-sems, sysv-sems and pthreads for those platforms that
lack native versions (eg: OSX/macOS). [Jim Jagielski]
* locks: Introduce apr_{thread,proc,global}_mutex_timedlock().
[Yann Ylavic]
- Remove patch
* apr-use-getrandom.patch no longer needed, apr 1.7.0 use getrandom() on
Linux,
when available.
- Refresh apr-visibility.patch

==== ark ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ark-lang libkerfuffle19

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix build with cmake < 3.7
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Add missing include
* Remove unused includes
* Fix ECM version comparison
* Install in new logging directory when we use kf5 5.59.0
* Fix forward declaration
* ReadWriteLibarchivePlugin: always return false if jobs are killed
* Part: reset UI after aborting creation of new archives
* ReadWriteLibarchivePlugin: call archive_write_fail on fail
* Simplify kill logic
* Part: call updateWithDefaults() instead of setting an invalid index
* ReadWriteLibarchivePlugin: stop calling QSaveFile::commit() on fail
* ReadWriteLibarchivePlugin: bring back an old TODO
* Promote m_operationMode as protected member of ReadWriteArchiveInterface
* CMake: use proper construct to compare versions
* Make it compile without foreach
* clirar: Use switch-case instead of if-else
* ReadWriteLibarchivePlugin: simplify error check
* ReadWriteLibarchivePlugin: move declaration near to usage
* ReadWriteLibarchivePlugin: rename variable
* ReadWriteLibarchivePlugin: remove stale comment
* BatchExtract: improve error reporting when a job fails

==== attica-qt5 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Attica5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Add 0001-Fix-the-attica-pkgconfig-file.patch
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== baloo5 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove extra ";"
* [tags] Fix coding style
* Add KDevelop files to gitignore
* Link against KIOCore instead of KIOWidgets in kioslaves
* [IndexCleaner] ignore non-existent entries inside config
- Drop fix-cmakelists-comments.diff as well, it cannot be built
with cmake 2.x anymore since a long time
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop patch to support Qt 5.9:
* 0001-Do-not-use-qfileinfo-metadatachangetime-if-Qt-lt-5.10.patch

==== baloo5-widgets ====
Version update (19.04.3 -> 19.08.0)
Subpackages: baloo5-widgets-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== blinken ====
Version update (19.04.3 -> 19.08.0)
Subpackages: blinken-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Stop using deprecated QPainter::worldMatrix
* Use the non depracated QPainter::drawRoundedRect
* Follow KDE_APPLICATIONS_VERSION
* It's time to use cmake 3.5
* Ignore files
* Use Qt CamelCase includes

==== bluez-qt ====
Version update (5.60.0 -> 5.61.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Fix crash due to the q pointer never being initialized.
* Don't include bluezqt_dbustypes.h from installed headers
* Fix compiler warnings
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== bovo ====
Version update (19.04.3 -> 19.08.0)
Subpackages: bovo-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* fix some warnings
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Use KF5_MIN_VERSION for ecm version too
* Port to new connect api + use QStringLiteral
* Use Qt camelcase include

==== breeze5-icons ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Add "user-others" icon (kde#407782)
* Make "edit-none" a symlink to "dialog-cancel"
* Delete redundant and monochrome versions of applications-internet
* Add view-pages-* icons, as needed in Okular for page layout selection
(kde#409082)
* Fix typo in stylesheets
* Change Highlight to ButtonFocus in stylesheets
* Use clockwise arrows for *refresh* and update-* icons (kde#409914)
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== calendarsupport ====
Version update (19.04.3 -> 19.08.0)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attachment changes
* Remove one last call to the attachment writing code I missed previously
* Remove unused incidence attachment saving code
* Adapt to KCalCore::Attendee changes
* Use new logging category directory when ECM>=5.59.0
* Adapt to KCalCore::Person changes
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry
* Use QStringLiteral here
* calendarsupport does not depend on KIMAP, so don't search for it

==== catfish ====
Version update (1.4.8 -> 1.4.9)
Subpackages: catfish-lang

- Fixed sources in spec file
- Update to version 1.4.9
* Fix path exclusions (deb#926850)
* Translation updates

==== cervisia ====
Version update (19.04.3 -> 19.08.0)
Subpackages: cervisia-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== dolphin ====
Version update (19.04.3 -> 19.08.0)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix build with cmake < 3.7
* Do not match daemonized dolphin instances: part 2
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Fix dir change when show hidden terminal panel with running program in it
* servicemenuinstaller: Fix placeholders in i18n string
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here
- Refreshed patches:
* 0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch

==== dragonplayer ====
Version update (19.04.3 -> 19.08.0)
Subpackages: dragonplayer-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Port QFontMetrics::width -> QFontMetrics::horizontalAdvance
* Port QColor::dark -> QColor::darker
* give it a homepage

==== eventviews ====
Version update (19.04.3 -> 19.08.0)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace changes
* Port KCalCore-related connect to PMF syntax
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attachment changes
* Adapt to KCalCore::Attendee changes
* When we use framework 5.59.0 we can use new logging file directory
* Fix infinite loop guard in case of duplicate UIDs
* Adapt to KCalCore::Person changes
* Use ellipsis in search placeholder
* It was fixed in 5.13.0beta2
* Use new connect api
* Remove local copy of KCalCore::DateList typedef
* Port local usage of SortableList to std::vector
* Make it compile without foreach

==== exo ====
Version update (0.12.7 -> 0.12.8)
Subpackages: exo-data exo-helpers exo-lang exo-tools libexo-1-0 libexo-2-0

- Fixed sources in spec file
- Update to version 0.12.8
* preferred-apps: Add button icons to Help/Close
* Replace GtkStock buttons
* Translation Updates
- Dropped obsolete patch exo-revert-gnome-3.22-req.diff

==== ffmpeg-4 ====
Subpackages: libavcodec58 libavdevice58 libavfilter7 libavformat58
libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5

- avoid ppc64le build error upstream issue
https://trac.ffmpeg.org/ticket/7861
Add ffmpeg4_swscale_replace_illegal_vector_keyword.patch
Add ffmpeg4_swscale_fix_altivec_vsx_recent_gcc.patch
- Add ffmpeg-prefer-dav1d-for-playback.patch: Prefer using dav1d
for av1 playback over libaom.

==== ffmpegthumbs ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ffmpegthumbs-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== frameworkintegration ====
Version update (5.60.0 -> 5.61.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== git ====
Version update (2.22.0 -> 2.22.1)
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- git 2.22.1
* A relative pathname given to "git init --template=<path> <repo>"
ought to be relative to the directory "git init" gets invoked in,
but it instead was made relative to the repository, which has been
corrected.
* "git worktree add" used to fail when another worktree connected to
the same repository was corrupt, which has been corrected.
* "git am -i --resolved" segfaulted after trying to see a commit as
if it were a tree, which has been corrected.
* "git merge --squash" is designed to update the working tree and the
index without creating the commit, and this cannot be countermanded
by adding the "--commit" option; the command now refuses to work
when both options are given.
* Update to Unicode 12.1 width table.
* "git request-pull" learned to warn when the ref we ask them to pull
from in the local repository and in the published repository are
different.
* "git fetch" into a lazy clone forgot to fetch base objects that are
necessary to complete delta in a thin packfile, which has been
corrected.
* The URL decoding code has been updated to avoid going past the end
of the string while parsing %-<hex>-<hex> sequence.
* "git clean" silently skipped a path when it cannot lstat() it; now
it gives a warning.
* "git rm" to resolve a conflicted path leaked an internal message
"needs merge" before actually removing the path, which was
confusing. This has been corrected.
* Many more bugfixes and code cleanups.

==== gnome-documents ====
Subpackages: gnome-documents-lang gnome-shell-search-provider-documents

- Drop inkscape and poppler-tools BuildRequires: No longer needed
since we do not build getting_started pdf anymore.

==== gnome-video-effects ====
Version update (0.4.3 -> 0.5.0)

- Update to version 0.5.0:
+ Port to meson build system.
+ Updated translations.
- Add meson BuildRequires and macros.

==== gnu-unifont-bitmap-fonts ====
Version update (12.0.01 -> 12.1.03)

- unifont 12.1.03:
* add Reiwa Japanese era glyph
* various other glyph updates

==== gobject-introspection ====
Subpackages: girepository-1_0 libgirepository-1_0-1

- Update gi-find-deps.sh: upate javascript_requires function to parse
the new JS import style (bsc#1140614).

==== grantleetheme ====
Version update (19.04.3 -> 19.08.0)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* Use QVector here
* It was fixed in 5.13.0beta2
* Move PimCommon::GenericGrantleeFormatter here
* metainfo.yaml: Fix cmakename, is own top-level entry
* It compiles fine without foreach
* Grantleetheme should always prefer files that are located in DataLocation.

==== gstreamer-plugins-bad ====
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0
libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0

- Move openh264 plugin to build_orig and build it there
unconditionally.

==== gwenview5 ====
Version update (19.04.3 -> 19.08.0)
Subpackages: gwenview5-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== hwdata ====
Version update (0.325 -> 0.326)

- Update to version 0.326:
* Updated pci, usb and vendor ids.

==== incidenceeditor ====
Version update (19.04.3 -> 19.08.0)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
* Simplify OpenComposerJob using DBus activation.
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attachment changes
* Avoid an attachment pointer hash
* Remove attachment temporary file clearing, we don't create such files here
* Adapt to KCalCore::Attendee changes
* When we use framework 5.59.0 we can use new logging file directory
* Remove the last remaining maps using Attendee pointers as keys
* Use a vector rather than a map for the attendee status
* Simplify AttendeeTableModel construction
* Use a vector rather than a hash for storing attendee/combobox pairs
* Adapt to KCalCore::Person changes
* It was fixed in 5.13.0beta2
* Second attempt on getting API docs generated on api.kde.org
* Add to kdepim group so this shows up on api.kde.org
* Re-enable moving events between collections in korganizer
* Fix: don't install not exported class

==== iw ====
Version update (5.0.1 -> 5.3)

- Update to version 5.3
* info: update extended feature list
* info: macro-ify ext_feat_print()
* util: update command list
* iw: print HE capabilities
* iw: really fix build
* iw: add HE support to station dump call
* cac: fix error handling in channel parsing
* nan: fix memory leak
* mesh: initialize err in set_interface_meshparam()
* iw: fix fp handling inside handle_vendor
* iw: fix memory leaks inside handle_scan
* iw: fix memory leak inside parse_sched_scan
* iw: fix fd leak inside handle_netns
* iw: fix memory leak inside handle_cac
* iw: fix endless loop inside handle_mgmt_dump
* iw: fix memory leak inside register_mgmt_frame
* iw: add version.o to objects
* iw: include all C files into the binary
* iw: change __cmd section scheme to fit gcc/clang
* iw: Add support for controlling tx power for per station
* iw: add command to inject a frame via direct mesh link to mesh peer
* iw: print 4ADDR attribute when dumping interface
* iw: small cleanup for the sizer code
* iw: fix cmd_size determination with LTO
* iw: Print airtime fairness feature
* iw: Add command to set airtime weight
* iw: Add printing of station tx duration and airtim

==== juk ====
Version update (19.04.3 -> 19.08.0)
Subpackages: juk-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Adjust lyrics to use new URLs. (kde#406791)
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Fix folder dialog always opens even if it is set and not empty
* Fix compilation with -DQT_NO_CAST_TO_ASCII
* Fix taglib includes to match the way taglib was meant to be used: #include
<tag.h>
* Rename tag.* to juktag.* to avoid a clash with taglib's tag.h
* Mark taglib includes as SYSTEM
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* appdata: fix the URLs (mostly https-related)
* renamer: Stretch the content, not the label of confirm dialog.
* Found a few more compiler warnings to fix [-Wsuggest-override].
* Bump copyright year
* Finish removing deprecated code.
* Remove deprecated code, fix NowPlaying bar height.
* Remove broken/unused MusicBrainz feature and code.
* A few more FileRenamer cleanups since I was there.
* Remove deprecated use of QSignalMapper.
* Remove more compiler warnings for deprecated functions/uses.

==== k3b ====
Version update (19.04.3 -> 19.08.0)
Subpackages: k3b-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use lambda instead of QSignalMapper
* stick to one category
* Fix no Elapsed time information issue after finished job.. (kde#405994)
* Enable the k3b helper by default
* Connect to result and not statusChanged
* KAuth needs the return type to be ActionReply
* Permission helpers: Start the jobs, otherwise this is a noop
* Remove useless if
* Remove ENABLE_PERMISSION_HELPER use guarding slots
- Add downstream patch to disable the KAuth helper:
* 0001-Revert-Enable-the-k3b-helper-by-default.patch

==== kaccounts-integration ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== kaccounts-providers ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kaccounts-providers-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== kactivities-stats ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Add Date term to KActivities Stats to filter on resource event date
* Fix some compiler warnings
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported openSUSE versions

==== kactivities5 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Simplify previous-/nextActivity code in kactivities-cli
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported distribution versions

==== kaddressbook ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kaddressbook-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kalarmcal ====
Version update (19.04.3 -> 19.08.0)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Adapt to KCalendarCore namespace change
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Fix GCC compile warning
* Replace deprecated Qt calls
* Fix erroneous KMail indication in calendar file
* Evaluate Todo start date correctly
* Convert KMail serial number to use Akonadi Item ID instead
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Put calendar type identifiers at start of UID
* When we use framework 5.59.0 we can use new logging file directory
* Adapt to KCalCore::Person changes
* Remove unused variable
* Improve comments
* Fix version
* Fix compile warnings
* Add more tests
* Fix clazy warning
* Second attempt on getting API docs generated on api.kde.org
* Add to kdepim group so this shows up on api.kde.org
* Fix warning "warning: "TRANSLATION_DOMAIN" redefined"
* Make it compile without foreach
* Remove unnecessary list copy

==== kalgebra ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kalgebra-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Follow KDE_APPLICATIONS_VERSION
* update screenshot
* It's time to use cmake 3.5
* Ignore files
* Use QStringLiteral + use new connect api
* Use Qt CamelCase includes

==== kalzium ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kalzium-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Document the new 'Swap axes' button
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Add button to swap X and Y in Plot Setup dialog
* Get rid of obsolete methods
* QPalette::background -> QPalette::window
* Use the int variant of currentIndexChanged
* QColor::dark -> QColor:darker
* Tell cmake openbabel includes are system includes
* Follow KDE_APPLICATIONS_VERSION
* Fix deprecated method
* Fix forward declaration
* It's time to use cmake 3.5
* Ignore more files
* Remove extra include
* Use ellipsis in search field

==== kamera ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kamera-lang kio_kamera

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Give the Solid action a more descriptive name (kde#406294)

==== kanagram ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kanagram-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Follow KDE_APPLICATIONS_VERSION
* Fix forward declaration
* It's time to use cmake 3.5
* Ignore more files
* Make it compile without foreach

==== kapptemplate ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kapptemplate-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Add wrap text attribute in choice.ui
* it does not generate templates for KDE alas
* update screenshot
* get with the times

==== karchive ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* KTar::openArchive: Don't assert if file has two root dirs
* KZip::openArchive: Don't assert when opening broken files
* KZip::openArchive: turn assert into if+return false
* KTar::openArchive: Remove "bad" assert
* KZip::openArchive: Remove "bad" assert
* KZip::openArchive: Return false instead of asserting in broken files
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kate ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kate-lang kate-plugins

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix dbus session registration (kde#410742)
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== katomic ====
Version update (19.04.3 -> 19.08.0)
Subpackages: katomic-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Fix forward declaration
* it compiles fine without foreach
* Make it compile without foreach
* Add missing override
* flags are already defined

==== kauth ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang libKF5AuthCore5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kblackbox ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kblackbox-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Port to new connect api + use QStringLiteral
* Use Qt camelcase include

==== kblocks ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kblocks-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Install in new logging directory when we use kf5 5.59.0
* Call sounds enabled on startup
* Delete sounds before creating them again
* No need to make KGameTheme a member variable
* Use the theme file defined sounds if they are declared.
* Fix forward declaration
* Make it compile without deprecated method
* Use more nullptr
* Make it compile without foreach
* Add missing override
* breeze icon
* USe const'ref + use new connect api

==== kbookmarks ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove deprecated method
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kbounce ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kbounce-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes

==== kbreakout ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kbreakout-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use new logging category directory when ECM>=5.59
* It compiles without foreach
* Use const'ref
* It's already defined

==== kbruch ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kbruch-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use more conservative boundingRect() as horizontalAdvance was introduced in
Qt 5.11 only
* Get rid of obsolete width()
* Follow KDE_APPLICATIONS_VERSION
* Fix forward declaration
* It's time to use cmake 3.5
* Exclude more files
* Make it compiles without foreach

==== kcachegrind ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kcachegrind-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== kcalc ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kcalc-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Enable Antialiasing in bitset editor (kde#408045)
* Allow changing the foreground/text color of buttons (kde#77140)
* Add missing Comment in .desktop file
* Accept hex letters with the Shift key pressed (kde#283521)
* Use Q_FALLTHROUGH instead of a comment
* Remove unused includes
* kcalc_core: Fix initialization order
* Use MPFR in knumber_float in order to improve floating-point precision
(kde#132158, kde#148357, kde#407318)
* Make it compile without deprecated methods
* bitset: Add bit number to tooltip
* Time to increase cmake version + this compile flags is already defined
* Add gitignore

==== kcalcore ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* "kcalcore_debug.h" -> "kcalendarcore_debug.h"
* Rename to kcalendarcore
* Rename kcalcore_version.h to kcalendarcore_version.h
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Clarify that utils.h is not public API
* Port tests to new namespace
* Rename the header install locations to KCalendarCore
* Rename the KCalCore namespace to KCalendarCore
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kcalutils ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix Bug 410458 - Invitations: When should include day-of-the-week
(kde#410458)
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attachment changes
* Adapt to KCalCore::Attendee changes
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* Remove unused scheduler class
* Adapt to KCalCore::Person changes
* Adjust unit test results to changes in 2c4ef81fa75a
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry

==== kcharselect ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kcharselect-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Follow KDE_APPLICATIONS_VERSION
* CMake: simplify version check
* Clean up cmakelist.txt.

==== kcmutils ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* adapt to UI changes in KPageView
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kcodecs ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kcolorchooser ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kcolorchooser-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Follow KDE_APPLICATIONS_VERSION
* Fix minor typo

==== kcompletion ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kconfigwidgets ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kcontacts ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kcoreaddons ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove extra ';'
* autotest: fix kformattest to ignore translations + QStringLiteral fix on
Windows
* Add function to suggest a unique filename
* Fix build after 0b2fe3cf21
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop patch to support Qt 5.9:
* 0001-Do-not-use-functor-if-Qt-lt-5.10.patch

==== kcrash ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kcron ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kcron-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Install in new logging directory when we use kf5 5.59.0
* Fix clazy warning

==== kdav ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdav-lang libKPimKDAV5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry
* Make it compile without foreach

==== kdbusaddons ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kde-print-manager ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kde-print-manager-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix warning "0 instead of 1 arguments to message {Printing with %1}
* CMake: drop duplicate cmake_minimum_required() call
* use KDE Applications version numbering
* CMake: drop needless policy setting
* Fix forward declaration
* Use friendlier Name for notification file

==== kdeclarative ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Scrollview - Don't fill the parent with the view (kde#407643)
* introduce FallbackTapHandler
* Fix typo - GridView -> ScrollView
* KRun QML proxy: port away from deprecated KRun API
* Docs: fix bad example code
* KRun QML proxy: fix path/URL confusion
* Calendar events: allow plugins to show event details
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kded ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kded-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* kded5 desktop file: use valid type (Service) to suppress warning from
kservice
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kdeedu-data ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* It's time to use cmake 3.5

==== kdegraphics-thumbnailers ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Add blender thumbnailer

==== kdelibs4support ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Designer plugin: use consistently "KF5" in group names & texts
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Use non-deprecated suggestName
* Don't advertise using KPassivePopup
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kdenetwork-filesharing ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdenetwork-filesharing-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Add a button to open the Samba status monitor KCM (kde#365830)
* Port to new connect syntax
* Remove unintentional change
* Add my copyright
* Support installing multiple Samba packages
* Display accurate status message during installation
* Tweak UI strings to be a bit clearer
* Add .arcconfig file

==== kdepim-addons ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdepim-addons-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Allow to wrap attachment text (as diff)
* Fix autotests
* Fix a crash
* Add missing includes
* Adapt to KCalendarCore namespace change
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Install the .rc files back into KDE_INSTALL_CONFDIR (kde#410279)
* Port SemanticUrlHandler::showCalendar to activateApplication
* Calendar formatter: port to PimUniqueApplication::activateApplication
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kdepim-apps-libs ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdepim-apps-libs-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kdepim-runtime ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdepim-runtime-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Adapt to KCalendarCore namespace change
* Fix a build time race condition
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Fix the license file.
- Dropped patches, now upstream:
* fix-the-license-file.patch
- Add patch to fix a copy of the LGPLv3:
* fix-the-license-file.patch
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kdesu ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported distribution versions

==== kdf ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdf-lang kwikdisk

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* CMake: fix version check and whitespace damage
* Install in new logging directory when we use kf5 5.59.0
* Fix forward declaration
* update screenshot
* Remove deprecated method
* Fix clazy warning
* Add gitignore

==== kdialog ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdialog-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Follow KDE_APPLICATIONS_VERSION
* add appstream file
* add appstream

==== kdiamond ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdiamond-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Fix forward declaration
* qt crash was fixed in 5.13
* larger image cos kde.org/applications does not like small ones
* update to breeze icon
* It compiles fine without deprecated methods

==== kdnssd-framework ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kdoctools ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kemoticons ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kfilemetadata5 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kfilemetadata5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* add missing semicolon
* Get mobipocket extractor up-to-date, but keep disabled
* taglibextractortest.cpp - fix build with include <QSet>
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kgeography ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kgeography-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* qSort is deprecated, use std::sort
* Follow KDE_APPLICATIONS_VERSION
* Ignore files
* Use more https
* Fix spelling of Nur-Sultan

==== kget ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kget-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* [mirrorsearch] Remove no longer available services from default list
(kde#410406)
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use the new logging category directory with ECM >= 5.59.0
* Fix minor typos
* Add DesktopEntry to notifyrc
* Port qSort.
* Port away from KLocale::global()->languageCodeToName().
* Move country code generation into CountryModel::setupModelData.
* Use locale aware sorting for countries and languages.
* Fix missing include.
* Port KLocale::global()->allCountriesList() to QLocale.
* Reduce dependency on KDELibs4Support.

==== kglobalaccel ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kgoldrunner ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kgoldrunner-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Use new logging category directory when ECM>=5.59
* Fix forward declaration
* Use new syntax
* it compiles fine without foreach
* Port setMargins

==== kguiaddons ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== khangman ====
Version update (19.04.3 -> 19.08.0)
Subpackages: khangman-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Follow KDE_APPLICATIONS_VERSION
* It's time to use cmake 3.5
* use nullptr here
* Ignore files

==== khelpcenter5 ====
Version update (19.04.3 -> 19.08.0)
Subpackages: khelpcenter5-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Install in new logging directory when we use kf5 5.59.0

==== kholidays ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Add public holidays' substitute days in Russia, for 2019-2020
* Update holidays in Russia
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== khtml ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== ki18n ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Fix string scaping
* Replace QString::null with QString
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kiconthemes ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Restore "Check if group < LastGroup, as KIconEffect doesn't handle
UserGroup anyway"
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kidentitymanagement ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* Fix the build
* USe QVector
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry
* Second attempt on getting API docs generated on api.kde.org
* Add to kdepim group so this shows up on api.kde.org
* Fix compile: replace foreach with std::remove_if + erase

==== kidletime ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kig ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kig-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* It's time to use cmake 3.5
* Use override keyword
* Use QStringLiteral

==== kimageformats ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kimageformats-eps

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove unused pnm.desktop file
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kimagemapeditor ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kimagemapeditor-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix build with cmake < 3.7
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Support the new logging category directory in case of KF 5.59+
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== kimap ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kimap-lang libKF5IMAP5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Provide an option whether to use the system proxy settings
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* Use https for documentation links, and fix a few broken links
* metainfo.yaml: Fix cmakename, is own top-level entry

==== kinit ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kinit-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* KLauncher code cleanups and cppcheck fixes.
* Harmless code cleanups
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kio ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kio-core kio-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Use identical internet-services icon.
* Stabilize test KFileWidgetTest::testDropFile
* Add missing KIOWIDGETS_NO_DEPRECTAED check
* Deprecate suggestName
* Replace implementation of suggestName with KFileUtils::suggestName
* Port internal usage of KIO::suggestName
* Fix can't enter directory error on some FTP servers with Turkish locale
(kde#409740)
* Port from KRun::runService to KRun::runApplication
* Fix compiler warnings about initialization order.
* Look for protocols in the bin dir too, to fix the autotests
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported openSUSE versions

==== kio-extras5 ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* [Text thumbnailer] Don't show text preview for .directory and .flatpakref
files (kde#410561)
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* kio_sftp: QFile::rename takes QString, so remove erroneous QFile::encodeName
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kio_audiocd ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kio_audiocd-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Get rid of obsolete QString::null
* Fix typo, remove extra QByteArray() (thanks to Albert Astals Cid)
* Use new logging category directory when ECM>=5.59
* Use new syntax
* Make audiocd:/ conformant with other KIO from KF5 by adding JSON file

==== kipi-plugins ====
Version update (5.9.1 -> 19.08.0)
Subpackages: kipi-plugins-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 5.9.1:
* Code comments: update link to existing page with related info
* Remove deprecated method
* Already defined in default flags
* Remove obsolete/unused method
* cmake: Remove unused MacroUtils.cmake module
* Use FeatureSummary instead of local MacroUtils.cmake
* cmake: Remove MacroLocalLibs.cmake module
* Drop use of DETECT_LIBKVKONTAKTE
* Drop use of DETECT_LIBMEDIAWIKI
* Drop use of DETECT_LIBKIPI macro and move relevant part to CMakeLists.txt
* Simplify optional Qt5/KF5 deps, drop ENABLE_KIO
* Raise KF5_MIN_VERSION to 5.18.0 and use for ECM
* run-clang-tidy.py -header-filter='.*' -checks='-*,modernize-use-nullptr'
-fix
- Remove conditionals for no longer supported distribution versions

==== kirigami2 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* reintroduce 00415d3345a with proper names
* Partially revert 00415d3345a to fix regression
* Sync to diff in D22868 (pushed wrong branch)
* Revamp Kirigami.AboutPage
* Consistently use Units.toolTipDelay instead of hardcoded values
* properly size the card contents when the card size is constrained
* hide ripple when we don't want items clickable
* make handle follow arbitrary height of the drawer
* Fix typo
* [SwipeListItem] Take into account scrollbar visibility and form factor for
handle and inline actions
* Remove scaling of iconsize unit for isMobile
* always show back button on layers>1
* Fix 2 typos
* hide actions with submenus from more menu
* default ActionToolBar position ot Header
* big z to not appear under dialogs
* use opacity to hide buttons that don't fit
* add the spacer only when it fills the width
* fully retrocompatible with showNavigationButtons as bool
* more granularity to globalToolBar.showNavigationButtons
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kiriki ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kiriki-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* QColor::dark/light -> darker/lighter
* Remove unused includes
* Follow KDE_APPLICATIONS_VERSION
* It compiles fine without foreach

==== kitemmodels ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Write myself down as the maintainer for KItemModels
* KConcatenateRowsProxyModel: add note that Qt 5.13 provides
QConcatenateTablesProxyModel
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kitemviews ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kiten ====
Version update (19.04.3 -> 19.08.0)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Follow KDE_APPLICATIONS_VERSION
* It's time to use cmake 3.5
* Use nullptr
* Ignore files

==== kitinerary ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
* Update Wikidata data tables for 19.08 release
* Hotfix for ZXing master breaking pure QR code decoding for some reason
* Fix another method name typo
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kjobwidgets ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kjs ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kjsembed ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kjumpingcube ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kjumpingcube-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Use new logging category directory when ECM>=5.59
* Use new connect api + use QStringLiteral

==== kldap ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kldap-lang libKF5Ldap5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix enable/disable server button
* Port to openPasswordDialogV2 + fix store password
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* We can't compile for the moment without deprecated method
* Use QLatin1String
* Use QStringLiteral

==== kleopatra ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kleopatra-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== klines ====
Version update (19.04.3 -> 19.08.0)
Subpackages: klines-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* It was fixed
* Time to increase Qt version as we use override but qt5.7 doesn't support it
and we use 5.7 from long time
* Fix some clazy warning
* It builds without deprecated methods
* Use strict compile flags here

==== kmag ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmag-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Follow KDE_APPLICATIONS_VERSION
* Use in-class member initialization for m_printer member
* Remove object name, since it was never set anyways

==== kmahjongg ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmahjongg-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kmail ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Adapt to KCalendarCore namespace change
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Cleanup now unused DBUS/Mailer code
* Check if KMail is running before calling it, to avoid autostarting it at
kontact startup
* Provide DBus activation file for kmail
* Remove wrong use of DBUS/Mailer servicetype
* summaryview_part.h - fix build by including QMap
* Fix apps name
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kmail-account-wizard ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmail-account-wizard-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove prefix
* When we use framework 5.59.0 we can use new logging file directory
* Try to make it compile on FreeBSD
* Use QVector here
* Clean up code
* Use KPasswordLineEdit here
* Add clear button
* Move knsrc files to the new location
* It was fixed in 5.13.0beta2
* Fix test command
* Rename as assistants
* Return all types of accounts
* Fix remove correct identity
* Allow to disable refreshing mime file (only for dev)
* replace deprecated KFilterProxySearchLine

==== kmailtransport ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* Remove full stop from checkbox
* metainfo.yaml: Fix cmakename, is own top-level entry
* Use new signal/slot
* Use qOverload directly
* Add option for disabling akonadi autotest (enable by default)

==== kmbox ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* Better check
* Fix check from QUrl
* Fix unlock mbox file
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry

==== kmime ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmime-lang libKF5Mime5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove copy of Akonadi's supertrait.h
* Use https links where available
* metainfo.yaml: Fix cmakename, is own top-level entry

==== kmines ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmines-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes

==== kmousetool ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmousetool-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes

==== kmouth ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmouth-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Fix forward declaration
* use the id as defined in this file
* Fix clazy warning

==== kmplot ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kmplot-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Get rid of some obsolete members
* update screenshot
* It's time to use cmake 3.5
* Use QStringLiteral
* Remove deprecated methods
* http -> https + update some links

==== knavalbattle ====
Version update (19.04.3 -> 19.08.0)
Subpackages: knavalbattle-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration

==== knetwalk ====
Version update (19.04.3 -> 19.08.0)
Subpackages: knetwalk-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration
* fix add_test command

==== knewstuff ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Use identical internet-services icon.
* Port from KRun::runService to runApplication, so runService can be
deprecated
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== knotes ====
Version update (19.04.3 -> 19.08.0)
Subpackages: knotes-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Port away from KDELibs4Support
* Now we depend against 5.11
* Remove unused includes
* Use KDE_INSTALL_KNSRCDIR for knsrc
* Fix bad commit here
* When we use framework 5.59.0 we can use new logging file directory
* update screenshot
* use https here
* Make it compile without deprecated method
* Port to GrantleeTheme::GenericFormatter
* It compiles fine without foreach
* Add urgency support
* It's already defined in FrameworkCompilerSettings

==== knotifications ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* remove dbus for windows build and change audio dep logic
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== knotifyconfig ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kolf ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kolf-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Fix forward declaration

==== kollision ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kollision-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* update screenshot
* Time to increase Qt version as we use override but qt5.7 doesn't support it
and we use 5.7 from long time
* Fix some clazy warning

==== kolourpaint ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kolourpaint-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration
* Don't use deprecated kpartgui keyword
* Fix hsv effect when applied to image
* Speed up invert colors effect
* Remove warning static member accessed through instance
* Remove warning: do not use 'else' after 'return'
* Simplify function return by removing the redundant empty object
* Fix some clazy warning
* remove the OpenMPI dependency
* Simplifying class constructor with constructor delegate
* Correct math to blend color in the blur effect
* Revert "Remove conditional debug output"

==== kompare ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kompare-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Fix browse for files/folders doesn't enable "Compare" button. (kde#390024)
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Port QFontMetrics::width -> QFontMetrics::horizontalAdvance
* Port QColor::light -> QColor::lighter
* Port QColor::dark -> QColor::darker

==== konquest ====
Version update (19.04.3 -> 19.08.0)
Subpackages: konquest-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Fix forward declaration
* Use KF5_MIN_VERSION directly
* Time to increase Qt version as we use override but qt5.7 doesn't support it
and we use 5.7 from long time
* Fix some clazy warning

==== konsole ====
Version update (19.04.3 -> 19.08.0)
Subpackages: konsole-part konsole-part-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix focus getting stuck in menu when XDG_CURRENT_DESKTOP ? kde (kde#410641)
* Do not allow 'Close Current Tab" to crash
* Fix dbus newSession() three methods to work
* Remove accelerators from tabs when pressing ALT (kde#410488)
- Drop Fix-dbus-newSession-three-methods-to-work.patch. Merged upstream.
- Add Fix-dbus-newSession-three-methods-to-work.patch to fix the
newSession() D-BUS method (boo#1143335, kde#410469)
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Mark constructor explicit
* Add/fix KUIT context marker
* Add KUIT context marker
* Fix initial terminal size
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kontact ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kontact-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Remove now unused KDBusServiceStarter code
* Provide DBus activation file for kontact
* Move data files (desktop files etc.) under data/ like in kmail and
korganizer
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* Allow parts (like kmail) to set a custom caption in guiActivateEvent
* It was fixed in 5.13.0beta2
* Show "hide_show_sidebar" action in menu.
* Use qOverload directly
* It compiles fine without foreach

==== kontactinterface ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Add PimUniqueApplication::activateApplication
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry
* Second attempt on getting API docs generated on api.kde.org
* Add to kdepim group so this shows up on api.kde.org

==== konversation ====
Subpackages: konversation-lang

- Add 0001-Fix-build-with-Qt-5.13.patch

==== kopete ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kopete-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use the new logging category directory with ECM >= 5.59.0
* doc: Write docbook date in standard format
* Fix launchable element in appdata data
* either use the .desktop or dont, not both
* update image
* the the -> the
* AddresseeList is a typedef now, don't forward declare it as a class

==== korganizer ====
Version update (19.04.3 -> 19.08.0)
Subpackages: korganizer-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
* korganizer CalendarView: port KCalCore connects to PMF or lambda syntax
* Cleanup now unused DBUS/* servicetype code
* Install servicetype desktop file
* Provide DBus activation file for korganizer
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attendee changes
* Clean includes
* When we use framework 5.59.0 we can use new logging file directory
* Adapt to KCalCore::Person changes
* Port some foreach
* Port some foreach code
* Move knsrc files to the new location
* It was fixed in 5.13.0beta2
* Don't use QStringLiteral("")
* Use ellipis in search placeholder
* Use new connect api
* Remove Kolab <-> LDAP person identity merging code
* Use KCalCore's typedefs rather than the about to go away SortableList

==== kpackage ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kpackage-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Offer metadata.json when requesting the package metadata
* PackageLoader: Use the right scope for the KCompressionDevice
* Use metadata.json when creating the metadata from KPackage::metadata()
* Fix build due to missing QVector include
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kparts ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kpat ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kpat-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Add QMap include to fix build (with Qt 5.13)
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Use new logging category directory when ECM>=5.59
* Fix forward declaration
* update url
* Port qVariantFromValue
* Small optimizations.
* Fix the path to kpat in the tests.
* accept games by name as a parameter to --solve.
* Convert from virtual+Q_DECL_OVERRIDE to override.
* Time to increase Qt version as we use override but qt5.7 doesn't support it
and we use 5.7 from long time
* Eliminate some GCC warnings during compilation.
* Add an assert as a regression test.
* Fix for bug 406587 - Freecell Autodrop.
* Shorten the freecell solutions.
* Fix some clazy warning
* Add a comment to explain.
* Optimize loading freecell games.
* Compatibility with bh-solver 0.20.0.
* add .arcconfig file

==== kpeople5 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kpeople5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* declarative: refresh actions list when person changes
* declarative: don't crash when the API is misused
* Remove unused includes
* personsmodel: Add phoneNumber
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kpimtextedit ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here
- Dropped patches, now upstream:
* Fix-Bug-409695.patch
* Add-more-protocols.patch

==== kpkpass ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKPimPkPass5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* Allow to not regenerate xdg mime file (only for dev). It takes some time to
generate it

==== kplotting ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kpty ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kqtquickcharts ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* It's time to use cmake 3.5
* Use nullptr + port to new connect api + use QStringLiteral

==== krdc ====
Version update (19.04.3 -> 19.08.0)
Subpackages: krdc-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* vnc: Optimize and simplify repainting

==== kreversi ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kreversi-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Add some nullptr

==== krfb ====
Version update (19.04.3 -> 19.08.0)
Subpackages: krfb-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Add a missing QHash include
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== kross ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kross-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kruler ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kruler-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Follow KDE_APPLICATIONS_VERSION
* Fix forward declaration
* screenshot
* Add ignore files

==== krunner ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kservice ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kservice-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Clean up all core related to opening a dummy sycoca, unused.
* Fix asserts when the sycoca DB is unreadable by user (e.g. root owned)
* Expose X-KDE-Wayland-Interfaces
* Fix KService build on Android
* KService: remove broken concept of global sycoca database
* Fix infinite recursion when using a dummy DB because ksycoca is inaccessible
* CMakeLists: add "CONFIG" for better error messages if anything isn't found
* Deprecate KDBusServiceStarter. All usage in kdepim is now gone, DBus
activation is a better solution.
* Remove very dangerous deletion code with kbuildsycoca5 --global.
* Allow KAutostart to be constructed using an absolute path
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kshisen ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kshisen-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Use KMessageBox instead of QMessageBox
* Use new logging category directory when ECM>=5.59
* Make it compile without foreach
* update screenshot
* fix add_test
* update some best practices definitions

==== ksirk ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ksirk-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Follow KDE_APPLICATIONS_VERSION
* Use new logging category directory when ECM>=5.59
* Fix forward declaration

==== ksmtp ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* Comment fix, setUseProxy() should be setUseNetworkProxy()
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry
* Make this show up on api.kde.org

==== kspaceduel ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kspaceduel-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* update screenshot
* Port setMargins
* Modernize cmake file
* Fix some clazy warning

==== ksquares ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ksquares-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration
* it compiles fine without foreach
* Make it compile with strict compile flags
* use cmake 3.5

==== ksudoku ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ksudoku-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration
* update screenshot
* Time to increase Qt version as we use override but qt5.7 doesn't support it
and we use 5.7 from long time
* Fix some clazy warning
* Don't use KIO copy and QTemporaryFile to load xml definition files.
(kde#405422)

==== ksystemlog ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ksystemlog-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* capitalise
* add appstream file
* Fix clazy warning

==== kteatime ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kteatime-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* CMake: fix version comparison
* use KDE Applications version numbering
* define version number in CMakeLists.txt for easier maintenance
* correct spelling of original author name
* Time to increase minimum cmake version
* Add missing override
* It's already defined in KDEFrameworkCompilerSettings
* It compiles fine without foreach
* Add gitignore

==== ktexteditor ====
Version update (5.60.0 -> 5.61.0)
Subpackages: ktexteditor-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Save and load page margins
* Don't persist authentication
* Re-map default "Switch input mode" shortcut to not confict with konsolepart
(kde#409978)
* Make keyword completion model return HideListIfAutomaticInvocation by
default
* Minimap: Do not grab the left-mmouse-button-click on up/down buttons
* Fix minor typos
* allow up to 1024 hl ranges instead of not higlighting the line at all if
that limit is reached
* fix folding of lines with end position at column 0 of a line (kde#405197)
* move enum to dialog, only used there
* Add option to treat some chars also as "auto bracket" only when we have a
selection
* Add an action to insert a non-indented newline (kde#314395)
* Add setting to enable/disable text drag-and-drop (on by default)
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported distribution versions

==== ktextwidgets ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== ktimer ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ktimer-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* It's already defined in default flags
* Time to increase minimum cmake version

==== ktnef ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Adapt to KCalendarCore namespace change
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Adapt to KCalCore::Attendee changes
* When we use framework 5.59.0 we can use new logging file directory
* Use QString::clear directly
* It was fixed in 5.13.0beta2
* Use https: rather than http: for documentation links
* metainfo.yaml: Fix cmakename, is own top-level entry
* It compiles without foreach

==== ktouch ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ktouch-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix Fuzzy Icons on HiDPI Displays
* Fix build with older cmake
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== ktuberling ====
Version update (19.04.3 -> 19.08.0)
Subpackages: ktuberling-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration
* Follow KDE_APPLICATIONS_VERSION

==== kturtle ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kturtle-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use more conservative boundingRect() as horizontalAdvance was introduced in
Qt 5.11 only
* Get rid of obsolete width()
* Follow KDE_APPLICATIONS_VERSION
* update screenshot

==== kubrick ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kubrick-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* Use new logging category directory when ECM>=5.59
* const'ify. + add QLatin1Char + remove unused code
* Remove compile warning
* It compiles fine without foreach
* Fix compile on arm

==== kunitconversion ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Fix minor typos
* Add Binary Data units (bits, kilobytes, kibibytes ... yottabytes)
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kwallet ====
Version update (5.60.0 -> 5.61.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Move kwalletd initialization earlier (kde#410020)
* Do not try to install no longer existing file
* Remove kde4 migration agent completely
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported distribution versions

==== kwalletmanager5 ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kwalletmanager5-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* CMake: fix version check and whitespace damage
* Install in new logging directory when we use kf5 5.59.0
* It's already defined in default flags
* Add gitignore
* Use camelcase includes

==== kwayland ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Use wayland-protocols
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported distribution versions

==== kwidgetsaddons ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* introduce concept of header and footer for kpageview
* QPalette::background -> QPalette::window
* [Busy Indicator] Match duration of QQC2-desktop-style version
* Add a warning dialog with a collapsible details section.
* Remove unused includes
* new class KBusyIndicatorWidget similar to QtQuick's BusyIndicator
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop patch to support Qt 5.9:
* 0001-Do-not-use-AnimationDuration-if-Qt-lt-5.10.patch

==== kwindowsystem ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* [platforms/xcb] Use XRES extension to get real window PID (kde#384837)
* Fix failing autotest
* Port KXMessages away from QWidget
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== kwordquiz ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kwordquiz-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Close KWordQuiz documents before closing the app
* Get rid of some obsolete members
* Follow KDE_APPLICATIONS_VERSION
* Fix forward declaration
* Use <gui> instead of deprecated <kpartgui>
* Fix minimum cmake version
* Excludes files
* Check if the filename is empty when user wants to save the file
* http -> https + update some links

==== kxmlgui ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Add expanding spacers as a customization option for toolbars
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Use monochrome action icons for KAboutData buttons.
* Remove visibilityChanged connection in favor of existing eventFilter
* Remove unused includes
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop conditionals for no longer supported openSUSE versions

==== kxmlrpcclient5 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== ldns ====
Version update (1.7.0 -> 1.7.1)

- new version 1.7.1
https://open.nlnetlabs.nl/pipermail/ldns-users/2019-July/000946.html
* Support for DNSSEC algorithms ED25519 and ED448
when compiled with OpenSSL 1.1.1
* An -I option to ldns-notify to specify a source IP address
to send to notify from.
* Complete OpenSSL engine support with ldns-signzone
contributed by Vadim Penzin
* security fixes CVE-2017-1000231 (boo#1068711), CVE-2017-1000232
(boo#1068709)
* includes ldns-swig4.0.patch
- add keyring and signature

==== libKF5ModemManagerQt ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Allow updating default DBus timeout on every interface
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== libKF5NetworkManagerQt ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* device: include reapplyConnection() in the interface
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop patches for Leap 42.3 which is no longer supported:
* 0001-Revert-Require-NetworkManager-1.4.0-and-newer.patch
* 0001-Revert-Add-missing-ipv4-setting-options.patch
* 0001-Revert-Add-IpTunnel-setting.patch
* 0001-Revert-Add-vxlan-setting.patch
* 0001-Revert-Add-missing-IPv6-options.patch

==== libavc1394 ====

- Freshen a bit

==== libcap-ng ====

- Own %{_datadir}/aclocal: when we might switch to pkgconf instead
of pkg-config, nothing in the build root is 'accidentally' owning
this directory for us.

==== libdbusmenu ====
Subpackages: libdbusmenu-glib4 libdbusmenu-gtk3-4

- Drop superfluous hard pkgconfig(gtk+-2.0) Requires from
libdebusmenu-glib-devel sub-package.

==== libdvdnav ====

- Format with spec-cleaner
- Remove not really needed patch:
* libdvdnav-strict-aliasing.patch
- Point URL to videolan.org

==== libdvdread ====

- Minor cleanup with spec-cleaner
- Point URL to videolan.org

==== libgravatar ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* Second attempt on getting API docs generated on api.kde.org
* Add to kdepim group so this shows up on api.kde.org
* It's already defined in FrameworkCompilerSettings

==== libgsm ====

- Small cleanups with spec-cleaner

==== libkcddb ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* No code changes since 19.04.3

==== libkcompactdisc ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Define _BSD_SOURCE for strdup and timerclear
* Include <strings.h> for strcasecmp

==== libkdcraw ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* No code changes since 19.04.3

==== libkdegames ====
Version update (19.04.3 -> 19.08.0)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Install in new logging directory when we use kf5 5.59.0
* Fix cmake warning: Migrate ECMPackageConfigHelpers ->
CMakePackageConfigHelpers
* Fix forward declaration
* increase version a bit since there's a new function
* Add a prefix public function to access the internal prefix.
* Fix some compile error with deprecated method + port some foreach
* Replace Q_DECL_OVERRIDE by override
* Add .arcconfig
* Modernize cmake file
* Fix add_test command
* Fix some clazy warning

==== libkdepim ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* fix forward declaration
* It was fixed in 5.13.0beta2
* Use https: rather than http: for links
* Make it functional
* metainfo.yaml: Fix cmakename, is own top-level entry
* Fix clazy warning
* Use qOverload directly
* It compiles fine without foreach
* Increase version here
* increase version
* Remove KPIM::Person and related jobs

==== libkeduvocdocument ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove method declaration with missing implementation
* It's time to use cmake 3.5
* Use Qt CamelCase includes

==== libkexiv2 ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* No code changes since 19.04.3

==== libkgapi ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
* Use mimeType from metadata instead of blindly re-determining it during
uploads
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== libkipi ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== libkleo ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* Fix key mapping based on summary column
* Fix double sig key select in newkeyapproval
* Filter out unusable keys in keyapproval dlg
* Fix / Improve handling of overrides in Keyapproval
* Add protocol specific defaultkeys to keyselectcb
* Print actual override format in debug output
* Extend keylistmodel with additional columns
* Bump required GPGME version to 1.11.1
* Mark Gpgmepp as required and print version
* Fix clazy warning
* Improve Display of UserID::Signatures
* It's already defined in FrameworkCompilerSettings

==== libkmahjongg ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use the new logging categories directory with ECM >= 5.59.0
* It compiles fine without foreach + deprecated method
* Add vscode files to gitignore
* Time to increase Qt version as we use override but qt5.7 doesn't support it
and we use 5.7 from long time
* Fix some clazy warning

==== libkomparediff2 ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* No code changes since 19.04.3

==== libksane ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5Sane5 libksane-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Update README.md to Qt5/KF5 version
* Add HiDPI support
* Extract HideRectItem class

==== libksieve ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libksieve-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* Use QVector here too
* Move knsrc files to the new location
* It was fixed in 5.13.0beta2
* Purpose is required now
* metainfo.yaml: Fix cmakename, is own top-level entry
* Fix enum changed in last qt5.13
* Make sure that PDFViewerEnabled is false
* Fix clazy warning
* It compiles fine without foreach
* Replace MinimumComboBox with regular QComboBox
* Move comment/uncomment in edit menu as in sieveeditor
* Add new menu "view" as in sieveeditor

==== libmpcdec ====

- Minor spec-cleaner run

==== libofa ====

- Use %license macro
- Remove two BRs that are not directly used

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5
libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libQt5Sql5 libQt5Sql5-mysql
libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk3

- Fix qmake pkconfig generation, broken .pc files become apparent
when switching from pkg-config to pkgconf. (QTBUG-75901)
* 0001-Fix-meta-file-replacements-if-matches-are-empty.patch
* 0002-Do-not-write-Libs-into-.pc-files-if-TEMPLATE-is-not-.patch
* 0003-Make-sure-.pc-.prl-and-.la-files-are-created-for-hea.patch

==== libqt5-qtwayland ====
Subpackages: libQt5WaylandClient5 libQt5WaylandCompositor5

- Add patch to fix deps in Qt5WaylandClient.pc and .cmake:
* 0001-Fix-use-of-private-dependency.patch

==== libsigc++2 ====
Version update (2.10.1 -> 2.10.2)

- Update to version 2.10.2:
+ This release is identical to 2.10.1, except for: Reference docs
generated by Doxygen 1.8.11. Hopefully it will show up at
https://developer.gnome.org/libsigc++/stable/

==== libstorage-ng ====
Version update (4.1.144 -> 4.1.145)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- Translated using Weblate (Chinese (China))
- 4.1.145

==== libvirt ====
Version update (5.5.0 -> 5.6.0)
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- network: fix ability to use openvswitch with vlans (bsc#1145651)
- Added patch:
93c1d5fe-network-fix-ability-to-use-openvswitch-with-vlans.patch
- Update to libvirt 5.6.0
- Enable proper use of systemd socket activation with libvirtd
- bsc#1133719
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
xen-pv-cdrom.patch, xen-sxpr-disk-type.patch
- qemu: fix default value of security_default_confined
Updated suse-qemu-conf.patch
bsc#1143871

==== libxfce4ui ====
Version update (4.12.1 -> 4.14.1)
Subpackages: libxfce4ui-1-0 libxfce4ui-2-0 libxfce4ui-lang libxfce4ui-tools

- Fixed sources in spec file
- Update to version 4.14.1
* No changes, re release because 4.14.0 tarball was broken
- Changes from 4.14.0
* Do not try to a set button' image if an empty string was used
* Translation Updates
- Cleaned up spec file
- Update to version 4.13.7
* Translations Updates
- Update to version 4.13.6
* Update active contributors
* Translation Updates
- Update to version 4.14.5
* Add PrintScreen as shortcut for xfce4-screenshooter (bxo#14524)
* Add Ctrl + Alt + t as default shortcut for terminal (bxo#14510)
* Add xfce_gdk_screen_get_geometry (a replacement for
gdk_screen_width/gdk_screen_height)
* Remove useless glade_*dir variables from libxfce4ui-{1,2}.pc
(bxo#13945)
* Fix release tarball by adding libxfce4ui-dialog-ui.ui
* Fixes for gladeui2 detection
* Install icons when gladeui2 is set (bxo#15207)
* Fix build error with --disable-gtk2 and having gladeui-1.0 installed
* Remove styling of emails in about dialog (bxo#14638)
* Fix compiler error -Wcast-function-type (GCC 8)
* Use https://docs.xfce.org for help url
* Fix compilation warnings ""defined" may not be portable"
& Update xfce4-about (core contributors, contributors, translators)
* Translation Updates
- Added conditional for source section for when building with
git master sources.
- Update to version 4.13.4
* Fix missing gresource file in release tarball (bxo#13705)
* Add Vala support (Vidar Haarr)
* Fix gladeui2 path detection (bxo#13944)
* Fix make distcheck (bxo#14039)
* Fix incorrect use of AC_ARG_ENABLE(tests..) (bxo#13703)
* Use BOOLEAN instead of deprecated BOOL
* Allows to properly show some characters, such as ampersand (bxo#12715)
* Translation Updates
- Changes from 4.13.3
* Fix make distcheck with gladeui2 install path
* Add an --enable-tests option
* Remove the filterout from introspection sources
* Move gresource building out of maintainer mode
* Fix condition in confirm dialog
* Add POTFILES.skip to appease gmake distcheck gods on OpenBSD
* Ship libxfce4ui.gresource.xml in the tarball too
* Add libxfce4ui-marshal.list to EXTRA_DIST to fix
- -enable-maintainer-mode on released tarballs
* Fix build error with --disable-gtk2
* Translation updates
- Changes from 4.13.2
* Fix build error with --disable-gtk3 bxo#12648
* Improve layout of labels in xfce dialogs
* Set a reasonable default window width to make sure labels wrap
* Improve vertical alignment of primary and secondary label
* Bump the default dialog width to 500px
* Update libxfce4ui documentation
* Fix make docs compilation warning
* Fix xfce_dialog_show_help(_with_version) doc
* Remove Makefile.am space to fix autogen.sh warning
* Better documentation processing
* Change xfce_dialog_show_help(_with_version)
* Default debxoto yes instead of full
* Remove exo dependancy bxo#13326
* fix: add libxfce4ui_get_resource to abi check symbols bxo#13326
* Let autotools find and invoke glib-compile-resources bxo#13326
* Add support for GOBJECT-INTROSPECTION bxo#13461
* Add GtkDoc checks
* Add missing introspection.m4 file
* fix: make distcheck
* fix: remove deprecation warnings
* feat: Switch to Gtk3 default, Gtk2 Optional
* Rename introspection GIR to 4ui-2.0 to match util
* Translation updates
- Changes from 4.13.1
* Better Gtk3.20 compatibility (fix XfceHeading style, drop deprecated call)
* Translation updates
- Changes from 4.13.0
* Add xfce_widget_reparent to replace the deprecated gtk_widget_reparent
* Add xfce_titled_dialog_new_with_mixed_buttons to allow for setting
icon names, button label text and response id.
* Add xfce_gtk_menu_popup_until_mapped as a convenience function to fix
widespread problems with popping up menus (e.g. on keyboard shortcuts)
* Add dialog UI tests for Gtk2 and Gtk3
* Fix Glade Gtk3 support
* Fix a memory leak
- Translation updates
- Clean up spec file and dropped obsolete macros
- Added conditional %bcond_with git for easier maintanance when using
git master branch
- Add missing buildrequires on direct build dependencies
x11,pango,cairo,atk and ice.
- correct licenses of libxfce4ui-1-0 and libxfce4ui-2-0 to GPL2.0+,
because files libxfce4kbd-private/xfce-shortcuts-xfwm4.{c,h} are
GPL 2, not LGPL.
- disable gtk-doc build, fails with newer gtk-doc > 1.25
- do not package ChangeLog, NEWS is enough
- Add conditional for pkgconfig(gladeui-1.0) BuildRequires and
corresponding subpackage glade3-catalog-libxfce4ui. No longer
build glade integration for Tumbleweed.
- update to version 4.12.1
- fix glade directory information in .pc file (bxo#11353)
- add shortcuts for xfwm4 to tile windows to corners (bxo#11652)
- remove unused 'has_member' variable in xfce4-about (bxo#11654)
- update .gitignore
- increase xfce4-about default size
- improve formatting of translators list
- update translation contributors in xfce4-about
- update contributors lists
- translation updates
- update BuildRequires
- update BuildRequires
- update to version 4.12.0
- bump version
- translation updates
- update to version 4.11.2
- bump dependencies versions (autotools, Xfce libraries)
- remove SVN $Id$ tags
- properly quote AC_LANG_SOURCE
- fix autoconf m4 directory warning
- fix IT_PROG_INTLTOOL warning
- fix build with --enable-debug=full and GTK3 (bxo#11176)
- add .gitignore
- fix grabbing shortcuts with <Super> modifier (bxo#10373)
- avoid double forking when spawning external apps (bxo#9373)
- don't drop startup notify hint when resetting to defaults
(bxo#10630)
- add <Ctrl><Alt>l shortcut for screen locking (xflock4)
(bxo#10728)
- fix xfce_dialog_show_help()

==== libxfce4util ====
Version update (4.12.1 -> 4.14.0)
Subpackages: libxfce4util-lang libxfce4util7

- Split out typelib-1_0-libxfce4util-1_0 from -devel package: the
.typelib files are not development files, but are actively used
at runtime.
- Fixed sources in spec file
- Update to version 4.14.0
* Bump to Xfce version 4.14
- Cleaned up spec file
- Enable vala (bxo#15756)
- Update to 4.13.5
* Translation updates
- Update to version 4.13.4
* Bump the Xfce version to 4.14pre2
* Translation Updates
- Update to 4.13.3
* Add support for rc files as symlinks (bxo#14698)
* Fix GObject Introspection language bindings (bxo#14766)
* Fix compiler error -Wcast-function-type (GCC 8)
* Bump minimum glib version
* Fix compilation warnings ""defined" may not be portable"
* Translation Updates: Arabic, Belarusian, Czech, Danish, French,
Galician, Hebrew, Icelandic, Italian, Kazakh, Lithuanian, Malay,
Norwegian Bokmål, Occitan (post 1500),
Romanian, Slovak, Serbian, Uighur, Ukrainian
- Updated Url and Source Url
- Switched from -lang to %lang_package
- Update to 4.13.2
* Add VAPIGEN for vala binding generation.
* Fix make distcheck build
* Better documentation processing (migrate away from sgml templates)
* Allow language-specific keys before language-neutral ones
(bxo#13979)
* Translation updates
- Changes from 4.13.1
* Fix a minor typo: ment ? meant
* Fix some autotools warnings, default debug to yes
* Fix duplicate DISTCHECK_CONFIGURE_FLAGS
* Improve gobject-introspection annotations
- Changes from 4.13.0
* Fix abicheck to handle ppc64 architecture
* Add support for GOBJECT-INTROSPECTION bxo#12159
* Translation updates
- Clean up spec file and dropped obsolete macros
- Added conditional %bcond_with git for easier maintanance when using
git master branch
- Dropped obsolete libxfce4util-xfce-rc-i18n.patch

==== lokalize ====
Version update (19.04.3 -> 19.08.0)
Subpackages: lokalize-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== lskat ====
Version update (19.04.3 -> 19.08.0)
Subpackages: lskat-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Use new logging category directory when ECM>=5.59
* It compiles without foreach + make it compile without deprecated method
* Time to increase Qt version as we use override but qt5.7 doesn't support it
and we use 5.7 from long time
* Fix some clazy warning

==== mailcommon ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* Clean forward declaration
* Use QVector here too
* Add more QVector
* Fix compile on CI
* Use QVector here
* Use QVector here
* Use QVector here
* It was fixed in 5.13.0beta2
* Now purpose is enabled by default
* metainfo.yaml: Fix cmakename, is own top-level entry
* snippets: Add icon for 'insert snippet' action
* Second attempt on getting API docs generated on api.kde.org
* Add to kdepim group so this shows up on api.kde.org
* Add option for disabling akonadi autotest (enable by default)
* Fix FilterActionWithUrlTest
* Remove MinimumComboBox

==== mailimporter ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* When we use framework 5.59.0 we can use new logging file directory
* It was fixed in 5.13.0beta2
* metainfo.yaml: Fix cmakename, is own top-level entry
* It compiles fine without foreach

==== makedumpfile ====

- Also support extended address space with SLE 12 SP5 (bsc#1138451)
* refresh makedumpfile-ppc64-VA-range-SUSE.patch

==== mbox-importer ====
Version update (19.04.3 -> 19.08.0)
Subpackages: mbox-importer-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* It was fixed in 5.13.0beta2

==== messagelib ====
Version update (19.04.3 -> 19.08.0)
Subpackages: messagelib-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix crash when viewer is null
* Allow to wrap attachment text (as diff)
* Add/Remove includes
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Adapt to KCalendarCore namespace change
* Fix runtime warning "QFSFileEngine::open: No file name specified"
* Use system codepage when reading from piped command
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== mobipocket ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== mousepad ====
Version update (0.4.1 -> 0.4.2)
Subpackages: mousepad-lang

- Update to version 0.4.2
* Port to GDBus (bxo#14337)
* Show full path in window title by default (bxo#2896)
* Reset modification time when new filename is set (bxo#10498)
* Do not overwrite view settings when opening encoding dialog
(bxo#12298)
* Make dialog windows modal only for parent window (bxo#10488)
* Add string to translation (bxo#11049)
* Selecting a font via menu now disables system font (bxo#12773)
* Check for exo-csource in maintainer mode (bxo#12719)
* New line can't be printed in status bar (bxo#11050)
* Do not move text cursor when searching backwards (bxo#14942)
* Fix gravity of selection end mark (bxo#10986)
* Missing line in dbus.h, found typo in window.h (bxo#10583)
* Append a newline char at EOF when saving (bxo#4824)
* Do not core dump on silly errors, just exit (bxo#12413)
* Fix gtksourceview warnings/errors (bxo11663)
* Only set template filetype when detected (bxo#15314)
* Replace deprecated style properties in MousepadCloseButton
(bxo#13114)
* Fix Tab mode and Home/End Keys in preferences dialog (bxo#15075)
* Fix language guess function (bxo#15141)
* Read system font from xfconf property (bxo#12485)
* Add pkexec policy (bxo#11088)
* Fix g_type_class_add_private is deprecated
* Set intltool minimum version
* Bump minimal required glib
* Translation updates

==== nghttp2 ====
Version update (1.38.0 -> 1.39.1)

- Update to version 1.39.1:
* This release fixes the bug that log-level is not set with
cmd-line or configuration file. It also fixes FPE with default
backend.
- Changes for version 1.39.0:
* libnghttp2 now ignores content-length in 200 response to
CONNECT request as per RFC 7230.
* mruby has been upgraded to 2.0.1.
* libnghttp2-asio now supports boost-1.70.
* http-parser has been replaced with llhttp.
* nghttpx now ignores Content-Length and Transfer-Encoding in 1xx
or 200 to CONNECT.
- Drop no longer needed boost170.patch

==== okular ====
Version update (19.04.3 -> 19.08.0)
Subpackages: okular-lang okular-spectre

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Fix an incorrect text bounding rectangle calculation inside the sidebar
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== openblas_pthreads ====
Version update (0.3.6 -> 0.3.7)

- Update to version 0.3.7
common:
* having the gmake special variables TARGET_ARCH or TARGET_MACH
defined no longer causes build failures in ctest or utest
* defining NO_AFFINITY or USE_TLS to zero in gmake builds
no longer has the same effect as setting them to one
* a new test program was added to allow checking the library for thread safety
* a new option USE_LOCKING was added to ensure thread safety
when OpenBLAS itself is built without multithreading but
* will be called from multiple threads.
* a build failure on Linux with glibc versions earlier than 2.5 was fixed
* a runtime error with CPU enumeration (and NO_AFFINITY not set)
on glibc 2.6 was fixed
* NO_AFFINITY was added to the CMAKE options
(and defaults to being active on Linux, as in the gmake builds)
x86_64
* the build-time logic for detection of AVX512 availability
in the processor and compiler was fixed
* gmake builds on OSX now set the internal name
of the library to libopenblas.0.dylib (consistent with CMAKE)
* the Haswell DGEMM kernel received a significant speedup
through improved prefetch and load instructions
* performance of DGEMM, DTRMM, DTRSM and ZDOT on Zen/Zen2
was markedly increased by avoiding vpermpd instructions
* the SKYLAKEX (AVX512) DGEMM helper functions have now been
disabled to fix remaining errors in DGEMM, DSYMM and DTRMM
POWER:
* added support for building on FreeBSD/powerpc64 and FreeBSD/ppc970
* added optimized kernels for POWER9 single and double precision complex BLAS3
* added optimized kernels for POWER9 SGEMM and STRMM
ARMV7:
* fixed the softfp implementations of xAMAX and IxAMAX
* removed the predefined -march= flags on both ARMV5
and ARMV6 as they were appropriate for only a subset of platforms
- Remove not needed fix-arm64-cpuid-return.patch.

==== opus ====

- Add 2 upstream bug fixes for Silk:
* opus-Silk-CNG-adapts-faster.patch: Silk CNG adapts faster to
received packets with lower gains.
* opus-Silk-fix-arm-optimization.patch: Avoid processing LPC
coeffs beyond the given order in NEON optimizations.
- Own %{_datadir}/aclocal: when we might switch to pkgconf instead
of pkg-config, nothing in the build root is 'accidentally' owning
this directory for us.

==== oxygen5-icon-theme ====
Version update (5.60.0 -> 5.61.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== parley ====
Version update (19.04.3 -> 19.08.0)
Subpackages: parley-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Fix forward declaration
* use a url which exists
* Fix for memory leak in SessionManagerFixed
* Fix faulty number of new words counting
* Port deprecated qVariantFromValue method
* It's time to use cmake 3.5

==== patterns-media ====
Subpackages: patterns-media-rest_cd_core patterns-media-rest_dvd

- Drop imaging_opt from rest_dvd: we are at a size limit;
imaging_opt mainly consists of 'calibre'.

==== patterns-xfce ====
Version update (20190412 -> 20190809)
Subpackages: patterns-xfce-xfce patterns-xfce-xfce_basis
patterns-xfce-xfce_laptop patterns-xfce-xfce_office

- Added mugshot
- Added xfce4-panel-profiles
- Added lightdm-gtk-greeter-settings
- Update panel plugin names (renamed)
- Added openSUSE-welcome
- Added gnome-disk-utility (useful disk utility to mount iso file)
- Added mate-calc (replaces gnome-calculator)
- Added xfce4-screensaver (replaces xscreensaver)
- Removed orage (upstream likely to abanon it)
- Removed xfce4-notes-plugin from Recommends
(development upstream stalled)

==== perl-DBD-SQLite ====
Version update (1.62 -> 1.64)

- updated to 1.64
see /usr/share/doc/packages/perl-DBD-SQLite/Changes
1.64 2019-08-12
- Switched to a production version
1.63_05 2019-07-12
- Upgraded SQLite to 3.29.0
- Added sqlite_get_autocommit private method (GH#52)
- Addded new db_config constants, notably to prohibit
double-quoted string literals
1.63_04 2019-05-25
- Upgraded SQLite to 3.28.0
- Modified doc for sqlite_db_filename which actually returns undef
or an empty string (GH#50)
- Fixed ->quote($blob, SQL_BLOB) to quote correctly (GH#51, pali++)
1.63_03 2019-02-15
- Applied a patch to fix segmentation fault on 32-bit big-endian
platforms by Niko Tyni (GH#45)
1.63_02 2019-02-14
- Upgraded SQLite to 3.27.1
- Let a URI filename test skip if SQLite is compiled with URI filename
support (GH#47)
1.63_01 2019-01-26
- Made sure an internal hv is initialized (GH#45)
- Fixed a number of tests to skip
- Bumped up Test::More requirement
- Replaced bundled Test::NoWarnings with Test::FailWarnings
- Handle 'unknown' op in DBD::SQLite::VirtualTable::PerlData (Corion++)

==== perl-Test-Simple ====
Version update (1.302164 -> 1.302166)

- updated to 1.302166
see /usr/share/doc/packages/perl-Test-Simple/Changes
1.302166 2019-08-15 10:37:01-07:00 America/Los_Angeles
- Fix context test on older perls
1.302165 2019-08-15 10:21:09-07:00 America/Los_Angeles
- Better diagnostics when a context is destroyed unexpectedly
- Add an event to notify when END phase starts

==== pim-data-exporter ====
Version update (19.04.3 -> 19.08.0)
Subpackages: pim-data-exporter-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Adapt to KCalendarCore namespace change
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Fix includes, only use the namespace path, not the install prefix
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== pim-sieve-editor ====
Version update (19.04.3 -> 19.08.0)
Subpackages: pim-sieve-editor-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== pimcommon ====
Version update (19.04.3 -> 19.08.0)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* When we use framework 5.59.0 we can use new logging file directory
* Use QVector here
* It was fixed in 5.13.0beta2
* Remove the now unused GenericGrantleeFormatter
* metainfo.yaml: Fix cmakename, is own top-level entry
* It's enabled by default
* Clean up. It was enabled by default from 1 release
* Simplify GenericGrantleeFormatter
* Don't use const'ref
* Use new connect api
* Remove MinimumComboBox
* Make purpose required now

==== pkcs11-helper ====
Subpackages: libpkcs11-helper1

- Own %{_datadir}/aclocal: when we might switch to pkgconf instead
of pkg-config, nothing in the build root is 'accidentally' owning
this directory for us.

==== pkgconf ====
Version update (1.6.1 -> 1.6.3)
Subpackages: libpkgconf3 pkgconf-m4 pkgconf-pkg-config

- Update to 1.6.3
+ Fixed a memory leak when deduplicating paths.
+ Fixed strndup-related build regression on Windows.
+ Added --modversion description to pkgconf(1) man page.
+ Properly tokenize versions. Versions cannot logically contain
whitespace, as dependency-lists would not properly tokenize if
they could. A diagnostic is generated for malformed version
strings containing whitespace when --validate is used.
- Co-own aclocal directory to avoid requiring autoconf-archive

==== plasma-framework ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* [ToolButtonStyle] Use same color group for hovered state
* Handle colors file in fake plasma theme installer
* Install plasma theme into local XDG_DATA_DIR for icon test
* Apply busy indicator duration change of D22646 to the QQC2 style
* Compile package structure plugins into expected subdirectory
* Change Highlight to ButtonFocus
* Make sure we compare paths properly
* Fix running the dialognativetest without installing
* Search for the plugin of the other plasmoid
* [Busy Indicator] Match duration of QQC2-desktop-style version
* remove dangling remote widgets code
* Remove deprecated tests
* Remove hardcoded colors (view.svg, system.svg)
* Add missing components in org.kde.plasma.components 3.0
* Update refresh and restart icons to reflect new breeze-icons versions
* itemMouse isn't defined in plasma.components 3.0
* use clearItems when an applet gets deleted
* Fix crash if swtichSize is adjusted during initial setup
* react when switchWidth/Height changes
* Remove unused bits in ContainmentAction
* Improve plugin caching
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop patch to support Qt 5.9:
* 0001-Revert-Remove-Qt-version-check.patch

==== prison-qt5 ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== publicsuffix ====
Version update (20190529 -> 20190808)

- Update to version 20190808:
* tools: update newgtlds.go to filter removed gTLDs (#860)
* gTLD autopull: 2019-08-08 (#862)
* Remove non-public nuernberg.museum nuremberg.museum domains (#859)
* gTLD autopull: 2019-08-02 (#858)
* Update public_suffix_list.dat (#825)
* Update reference as per #855
* add nic.za
* Update contact for SymfonyCloud (#854)
* Add lelux.site (#849)
* Add *.webhare.dev (#847)
* Update Hostbip Section (#846)
* Add Yandex Cloud domains (#850)
* Add ASEINet domains (#844)
* Update nymnom section (#771)
* Add Handshake zones (#796)
* Add iserv.dev for IServ GmbH (#826)
* Add trycloudflare.com to Cloudflare's domains (#835)
* Add shopitsite.com (#838)
* Add pubtls.org (#839)
* Add qualifio.com domains (#840)
* Update newgtlds tooling & associated gTLD data. (#834)
* Add web.app for Google (#830)
* Add iobb.net (#828)
* Add cloudera.site (#829)

==== purpose ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Phabricator: open a new diff automatically in the browser
* Use non-deprecated suggestName
* Fix extraction. Patch by Victor Ryzhykh.
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== python-gssapi ====
Version update (1.6.0 -> 1.6.1)

- update to 1.6.1
* GSSAPI extension rfc4178 (set_neg_mechs) support
* Expose mechanisms in the high-level API

==== python-libvirt-python ====
Version update (5.5.0 -> 5.6.0)

- Update to 5.6.0
- Add all new APIs and constants in libvirt 5.6.0

==== python-numpy ====
Version update (1.16.4 -> 1.17.0)

- Update to version 1.17.0
Highlights
* A new extensible random module along with four selectable random number
generators and improved seeding designed for use in parallel processes has
been added. The currently available bit generators are MT19937, PCG64,
Philox, and SFC64.
* NumPy's FFT implementation was changed from fftpack to pocketfft, resulting
in faster, more accurate transforms and better handling of datasets of
prime length.
* New radix sort and timsort sorting methods. It is currently not possible to
choose which will be used, but they are hardwired to the datatype and used
when either ``stable`` or ``mergesort`` is passed as the method.
* Overriding numpy functions is now possible by default.
- Python 2 support has been dropped
- Rebase numpy-buildfix.patch

==== python-pip ====
Version update (19.2.1 -> 19.2.2)

- Update to version 19.2.2:
* Merge pull request #6827 from cjerdonek/issue-6804-find-links-expansion
* Fix handling of tokens (single part credentials) in URLs (#6818)
* Simplify the handling of "typing.cast"

==== python-scipy ====
Version update (1.3.0 -> 1.3.1)

- Update to 1.3.1
* BUG: Empty data handling of (c)KDTrees
* lsoda fails to detect stiff problem when called from solve_ivp
* sparse matrices indexing with scipy 1.3
* Exception in loadarff with quoted nominal attributes in scipy...
* DOC/REL: Some sections of the release notes are not nested correctly.
* BUG: optimize: `linprog` failing
TestLinprogSimplexBland::test_unbounded_below_no_presolve_corrected
* TST: Travis CI fails (with pytest 5.0 ?)
* CircleCI doc build failing on new warnings
* Scipy 1.3.0 build broken in AIX
* BUG: scipy.spatial.HalfspaceIntersection works incorrectly
* BUG: cKDTree GIL handling is incorrect
* TST: master branch CI failures
* BUG: ckdtree query_ball_point errors on discontiguous input
* BUG: No warning on PchipInterpolator changing from bernstein base to local
power base

==== python2-numpy ====

- Make sure to provide oldpython names
- Add python2-only version since the latest release doesn't
support python2.
- Remove python3-only patch fix-py34-tests.patch

==== qqc2-desktop-style ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Fix broken guard that prevents styling sliders with negative values
* Slow down the busy indicator's rotation speed
* Fix "Type error" when creating a TextField with focus: true
* [ComboBox] Set close policy to close on click outside instead of only
outside parent (kde#408950)
* [SpinBox] Set renderType (kde#409888)
- Don't lower minimum Qt version anymore, it requires 5.11 now
- Drop patch to support Qt 5.9:
* 0001-Fix-MobileTextActionsToolBar.qml-with-Qt-5.9.patch
- Drop patch for Leap 42.3 which is EOL:
* fix-build-with-gcc48.patch

==== quota ====
Subpackages: quota-nfs

- Add patch from git to stop config processing on errors bsc#1144265:
* 0001-warnquota-Do-not-ignore-errors-in-config-file.patch

==== radvd ====
Version update (2.17 -> 2.18)

- new version 2.18:
* Fix double-free scenario in case if duplicate interface was specified
* Separate systemd and SysV packaging
* Update fedora packaging files
* No router advertisements on tunnel interfaces
* Add nodaemon option to the manpage
* Write to stderr in non-daemonized mode
* Fixes memory leak in add_ra_options_dnssl
* Allow quoted strings in config.
* nd_opt_6co endianness fix
- new keyid 0x6FE19F21451C9A2B used for signing. Upstream confirmed
that he changed computers and changed his key.
- do not strictly require systemd
- use upstream service file
- use system user framework to create user. Leads to using a dedicated radvd
group after all (boo#1060032)
- rename patch radvd-tmpfile-grpname.patch -> radvd-systemd.patch

==== re2c ====
Version update (1.1.1 -> 1.2.1)

- Update to version 1.2.1:
* Lots of changes, see provided CHANGELOG
- Drop no longer needed re2c-nogenerationdatedefault.patch
- Enable profile guided optimization during build

==== ristretto ====
Version update (0.8.5 -> 0.10.0)
Subpackages: ristretto-lang

- Update to version 0.10.0
* Port to GTK3
* Fix file permissions for ristretto.png
* Resolve or suppress deprecation warnings
* Add icons to "Close", "Cancel", "Apply", "OK" buttons
* Resolve "GtkDialog mapped without a transient parent" for
set wallpaper dialog
* Fix the ristretto icon loading size (128, not 256)
* Fix sensitivity of flip menu
* Add more separators to the menus
* Make Preferences dialog prettier
* Make the privacy dialog prettier
* Support for setting background image for both gtk2 and gtk3 versions
of xfdesktop (bxo#14571)
* configure: print build configuration
* Translation updates

==== rubygem-exception_notification ====
Version update (4.3.0 -> 4.4.0)

- updated to version 4.4.0
* enhancements
* Rails 6 compatibility (by @shanecav)
* Add Datadog notifier (by @ajain0184)
* Use backtrace cleaner for Slack notifications (by @pomier)
* Add slack channel name override option (by @chaadow)
* Addition of sample application for testing purposes (by @ampeigonet)
* bug fixes
* Fix error in Resque failure backend (by @EmilioCristalli)
* Remove sqlite dependency (by @EmilioCristalli)
* Configure ignore_crawlers from Rails initializer (by @EmilioCristalli)

==== rubygem-excon ====
Version update (0.64.0 -> 0.66.0)

- updated to version 0.66.0
* Add remote_ip to datum, enabling usage in middleware
* redirect follower now raises after following too many redirects (default 10)
* fixed stub clearing in tests to avoid race conditions

==== rubygem-msgpack ====
Version update (1.3.0 -> 1.3.1)

- updated to version 1.3.1
* Fix timestamp ext type bug about timestamps with seconds larger than 32bit
int (after 2106-02-07 06:28:16 UTC)

==== rubygem-nokogiri ====
Version update (1.10.3 -> 1.10.4)

- updated to version 1.10.4 (CVE-2019-5477)
A command injection vulnerability in Nokogiri v1.10.3 and earlier allows
commands to be executed in a subprocess by Ruby's `Kernel.open` method.
Processes are vulnerable only if the undocumented method
`Nokogiri::CSS::Tokenizer#load_file` is being passed untrusted user
input.
This vulnerability appears in code generated by the Rexical gem
versions v1.0.6 and earlier. Rexical is used by Nokogiri to
generate lexical scanner code for parsing CSS queries. The
underlying vulnerability was addressed in Rexical v1.0.7 and
Nokogiri upgraded to this version of Rexical in Nokogiri v1.10.4.
This CVE's public notice is
https://github.com/sparklemotion/nokogiri/issues/1915

==== rubygem-puma ====
Version update (4.0.1 -> 4.1.0)

- updated to version 4.1.0
* 4 features
* Add REQUEST_PATH on parse error message (#1831)
* You can now easily add custom log formatters with the `log_formatter`
config option (#1816)
* Puma.stats now provides process start times (#1844)
* Add support for disabling TLSv1.1 (#1836)
* 7 bugfixes
* Fix issue where Puma was creating zombie process entries (#1887)
* Fix bugs with line-endings and chunked encoding (#1812)
* RACK_URL_SCHEME is now set correctly in all conditions (#1491)
* We no longer mutate global STDOUT/STDERR, particularly the sync setting
(#1837)
* SSL read_nonblock no longer blocks (#1857)
* Swallow connection errors when sending early hints (#1822)
* Backtrace no longer dumped when invalid pumactl commands are run (#1863)
* 5 other
* Avoid casting worker_timeout twice (#1838)
* Removed a call to private that wasn't doing anything (#1882)
* README, Rakefile, docs and test cleanups (#1848, #1847, #1846, #1853,
#1859, #1850, #1866, #1870, #1872, #1833, #1888)
* Puma.io has proper documentation now (https://puma.io/puma/)
* Added the Contributor Covenant CoC
* 1 known issue
* Some users are still experiencing issues surrounding socket activation and
Unix sockets (#1842)

==== rubygem-pundit ====
Version update (2.0.1 -> 2.1.0)

- updated to version 2.1.0
[#]## Fixed
- Avoid name clashes with the Error class. (#590)
[#]## Changed
- Return a safer default NotAuthorizedError message. (#583)

==== rubygem-rails-html-sanitizer ====
Version update (1.0.4 -> 1.2.0)

- updated to version 1.2.0
* Remove needless `white_list_sanitizer` deprecation.
By deprecating this, we were forcing Rails 5.2 to be updated or spew
deprecations that users could do nothing about.
That's pointless and I'm sorry for adding that!
Now there's no deprecation warning and Rails 5.2 works out of the box, while
Rails 6 can use the updated naming.
* Kasper Timm Hansen*

==== rubygem-sass-rails ====
Version update (5.0.7 -> 6.0.0)

- updated to version 6.0.0
* no changelog found

==== rubygem-web-console ====
Version update (3.7.0 -> 4.0.1)

- updated to version 4.0.1
* [#279](https://github.com/rails/web-console/pull/279) Fix initial
config.web_console.permissions value ([@patorash])
- updated to version 4.0.0
see installed CHANGELOG.markdown
[#]# 4.0.0
*
[|61c](https://github.com/rails/web-console/commit/61ce65b599f56809de1bd8da6590a80acbd92017)
Move to config.web_console.permissions ([@gsamokovarov])
*
[|961](https://github.com/rails/web-console/commit/96127aac143e1e653fffdc4bb65e1ce0b5ff342d)
Introduce Binding#console as an alternative interface ([@gsamokovarov])
*
[|d45](https://github.com/rails/web-console/commit/d4591ca5396ed15a08818f3da11134852a485b27)
Introduce Rails 6 support ([@gsamokovarov])
*
[|f97](https://github.com/rails/web-console/commit/f97d8a889a38366485e5c5e8985995c19bf61d13)
Introduce Ruby 2.6 support ([@gsamokovarov])
*
[|d6d](https://github.com/rails/web-console/commit/d6deacd9d5fcaabf3e3051d6985b53f924f86956)
Drop Rails 5 support ([@gsamokovarov])
*
[|90f](https://github.com/rails/web-console/commit/90fda8789d402f05647c18f8cdf8e5c3d01692dd)
Drop Ruby 2.4 support ([@gsamokovarov])
* [#265](https://github.com/rails/web-console/pull/265) Add support for
nested exceptions ([@yuki24])

==== schily ====
Subpackages: cdda2wav cdrecord libcdrdeflt1_0 libdeflt1_0 libedc_ecc1_0
libedc_ecc_dec1_0 libfile1_0 libfind3_0 libparanoia1_0 librmt1_0 librscg1_0
libscg1_0 libscgcmd1_0 libschily2_0 mkisofs readcd spax star

- Update to new upstream release 2019.07.22
* The smake man page now mentions -N,-T,-u,-w,-j,-m-R
* smake: fixed a potential crash when printing current directory
* smake: implemented the -C option for gmake compatibility

==== signon-kwallet-extension ====
Version update (19.04.3 -> 19.08.0)

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- No code changes since 19.04.3

==== solid ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Make sure solid backends are reentrant
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== sonnet ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== soundtouch ====

- Use dos2unix insted of tr and friends

==== spectacle ====
Version update (19.04.3 -> 19.08.0)
Subpackages: spectacle-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Use correct KPageDialog face style for settings window
* Use QTEST_GUILESS_MAIN
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here
- Refreshed patches:
* 0001-Use-qdbus-qt5-instead-of-qdbus.patch

==== step ====
Version update (19.04.3 -> 19.08.0)
Subpackages: step-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Use cosmetic pen to draw anchors and pins to make them look pretty.
(kde#396587)
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Get rid of obsolete QSignalMapper
* Fix file loading (temporary file cannot be copied in time)
* Get rid of obsolete members
* Silence compiler warnings about comparison of std::isinf() with -1
* Do not ask if overwrite twice
* Follow KDE_APPLICATIONS_VERSION
* Fix forward declaration
* It's time to use cmake 3.5
* Fix add_test command

==== sweeper ====
Version update (19.04.3 -> 19.08.0)
Subpackages: sweeper-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Remove unused includes
* CMake: fix version comparison
* use copyright sign glyph
* use KDE Applications version numbering

==== syndication ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== syntax-highlighting ====
Version update (5.60.0 -> 5.61.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- Changes since 5.60.0:
* Rust: add missing keywords and minor improvements
* TypeScript: fix keywords in conditional expressions
* Fix generator and test paths of CMake
* Add support for additional QML keywords not part of JavaScript
* Update cmake highlighting
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== taglib ====
Version update (1.11.2~git20190531.ba7adc2b -> 1.11.2~git20190725.79bc9ccf)
Subpackages: libtag1 libtag_c0

- Update to version 1.11.2~git20190725.79bc9ccf:
* Call fflush() before ftruncate() to drop all buffered data (#914)

==== telepathy-logger ====
Subpackages: libtelepathy-logger3 typelib-1_0-TelepathyLogger-0_2

- Add libtpl-extensions-dependencies.patch: Fix dependencies of
tpl-extensions.pc: LIBTPL_MODULES have been dropped a while back.

==== thin-provisioning-tools ====
Version update (0.8.3 -> 0.8.5)

- Update to version 0.8.5
* Mostly internal changes

==== threadweaver ====
Version update (5.60.0 -> 5.61.0)

- Update to 5.61.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.61.0.php
- No code change since 5.60.0
- Don't lower minimum Qt version anymore, it requires 5.11 now

==== thunar ====
Version update (1.8.8 -> 1.8.9)
Subpackages: libthunarx-3-0 thunar-lang

- Fixed sources in spec file
- Update to version 1.8.9
* Remove 'auto-expand folders' from tree-view since it causes bad
usability with keyboard (bxo#15743)
* preferences: Add button icons to Help/Close
* Use designated initializer to avoid compile warnings (bxo#15734)
* Prevent premature disposal of clipboard manager (bxo#15635)
* Keep "Open with" menu items updated (bxo#15530)
* Translation Updates

==== thunar-volman ====
Version update (0.9.4 -> 0.9.5)
Subpackages: thunar-volman-lang

- Update to version 0.9.5
* Translation updates

==== tumbler ====
Version update (0.2.5 -> 0.2.7)
Subpackages: libtumbler-1-0 tumbler-lang

- Fixed sources in spec file
- Update to version 0.2.7
* Translation updates
- Cleaned up spec file
- Update to version 0.2.6
* Translation updates

==== umbrello ====
Version update (19.04.3 -> 19.08.0)
Subpackages: umbrello-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- Changes since 19.07.90:
* Activate newly added association rules for UML2 "required interface"
(kde#115269)
* Add UML2 support for "required interface" associations
* Fix 'Properties dialog box for components does not display links'
(kde#410513)
* Component symbol made more unique by enlarging the inner rectangle
* Fix icon for UML2 components
* cmake: make umbrello version number generating more robust
* Indention fix
* Fixup of icons for adding states
* New icon for activities added to toolbar and context menu (kde#410508)
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- Changes since 19.07.80:
* Too many changes to list here
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 19.04.3:
* Too many changes to list here

==== vte ====
Subpackages: libvte-2_91-0 typelib-1_0-Vte-2.91 vte-lang

- Drop the glade catalog subpackage. The catalogue is unmaintained
and has been dropped upstream with version 0.57.1.
This has the nice side effect of removing an indirect build
dependency on webkit2gtk3 via glade.

==== wavpack ====
Version update (5.1.0 -> 5.1.0~git20190420.22977b2)

- Update to version 5.1.0~git20190420.22977b2:
* Switch to github service to collect all the CVE fixes as releases
are not really happening often
* bsc#1133384 CVE-2019-11498
* bsc#1141337 CVE-2019-1010315
* bsc#1141338 CVE-2019-1010318
* bsc#1141339 CVE-2019-1010317
* bsc#1141334 CVE-2019-1010319
- Remove merged patches:
* CVE-2018-19840.patch
* CVE-2018-19841.patch
* CVE-2018-7253.patch
* CVE-2018-7254.patch
* wavpack-CVE-2018-6767.patch

==== wicked ====
Version update (0.6.54 -> 0.6.55)
Subpackages: libwicked-0-6 wicked-service

- version 0.6.55
- dhcp6: do not default to a /64 address prefix-length (bsc#1132280)
Add an address-length aka DHCLIENT6_ADDRESS_LENGTH ifcfg option, which
permits to specify explicit prefix-length to use for the DHCPv6 address
and override detection using RA prefix info and a default to /128.
- time: use boot time for timer instead of real time (bsc#1129986)
- dhcp: Consistently log dhcp xid and enabled to log dhcp6 timings line.
- dhcp6: lower unexpected xid messages to debug level
- systemd: change to depend on udev settle service (bsc#1136034,bsc#1132774)
Calling udevadm settle directly caused systemd to kill wicked services.
- bridge: honour ifcfg LLADDR and set link address (bsc#1042123,boo#1142670)
- rfkill: fix switch statement to check enum variable not a constant
(bsc#1140117)
- man: ifcfg-ovs-bridge(5): recommend STARTMODE=nfsroot
- dhcp4: nullify defer timer pointer when timeout (openSUSE/wicked#798)
- dhcp4: fix to request routing options when custom options are used
(bsc#1132326)
- testing: add ifbind.sh helper script allowing to test hotplugging

==== xdg-desktop-portal-gtk ====
Subpackages: xdg-desktop-portal-gtk-lang

- Supplement gtk3 in combination with flatpak or snapd instead of
just supplementing against gnome-shell. Allows to the package to
be auto-triggered for installation also on other desktops
(boo#1136753).

==== xen ====
Version update (4.12.0_16 -> 4.12.1_02)
Subpackages: xen-libs xen-tools xen-tools-domU

- Update to Xen 4.12.1 bug fix release (bsc#1027519)
xen-4.12.1-testing-src.tar.bz2
- Drop patches contained in new tarball
5c87b644-IOMMU-leave-enabled-for-kexec-crash.patch
5c87b6a2-x86-HVM-dont-crash-guest-in-find_mmio_cache.patch
5c87b6c8-drop-arch_evtchn_inject.patch
5c87b6e8-avoid-atomic-rmw-accesses-in-map_vcpu_info.patch
5c87e6d1-x86-TSX-controls-for-RTM-force-abort-mode.patch
5c8f752c-x86-e820-build-with-gcc9.patch
5c8fb92d-x86-HVM-split-linear-reads-and-writes.patch
5c8fb951-x86-HVM-finish-IOREQs-correctly-on-completion.patch
5c8fc6c0-x86-MSR-shorten-ARCH_CAPABILITIES.patch
5c8fc6c0-x86-SC-retpoline-safety-calculations-for-eIBRS.patch
5c9e63c5-credit2-SMT-idle-handling.patch
5ca46b68-x86emul-no-GPR-update-upon-AVX-gather-failures.patch
5ca773d1-x86emul-dont-read-mask-reg-without-AVX512F.patch
5cab1f66-timers-fix-memory-leak-with-cpu-plug.patch
5cac6cba-vmx-Fixup-removals-of-MSR-load-save-list-entries.patch
5cd921fb-trace-fix-build-with-gcc9.patch
5cd9224b-AMD-IOMMU-disable-upon-init-fail.patch
5cd922c5-x86-MTRR-recalc-p2mt-when-iocaps.patch
5cd9230f-VMX-correctly-get-GS_SHADOW-for-current.patch
5cd926d0-bitmap_fill-zero-sized.patch
5cd92724-drivers-video-drop-constraints.patch
5cd93a69-x86-MSR_INTEL_CORE_THREAD_COUNT.patch
5cd93a69-x86-boot-detect-Intel-SMT-correctly.patch
5cd93a69-x86-spec-ctrl-reposition-XPTI-parsing.patch
5cd981ff-x86-IRQ-tracing-avoid-UB-or-worse.patch
5cdad090-x86-spec-ctrl-CPUID-MSR-definitions-for-MDS.patch
5cdad090-x86-spec-ctrl-infrastructure-for-VERW-flush.patch
5cdad090-x86-spec-ctrl-misc-non-functional-cleanup.patch
5cdad090-x86-spec-ctrl-opts-to-control-VERW-flush.patch
5cdeb9fd-sched-fix-csched2_deinit_pdata.patch
5ce7a92f-x86-IO-APIC-fix-build-with-gcc9.patch
5cf0f6a4-x86-vhpet-resume-avoid-small-diff.patch
5cf16e51-x86-spec-ctrl-Knights-retpoline-safe.patch
5d03a0c4-1-Arm-add-an-isb-before-reading-CNTPCT_EL0.patch
5d03a0c4-2-gnttab-rework-prototype-of-set_status.patch
5d03a0c4-3-Arm64-rewrite-bitops-in-C.patch
5d03a0c4-4-Arm32-rewrite-bitops-in-C.patch
5d03a0c4-5-Arm-bitops-consolidate-prototypes.patch
5d03a0c4-6-Arm64-cmpxchg-simplify.patch
5d03a0c4-7-Arm32-cmpxchg-simplify.patch
5d03a0c4-8-Arm-bitops-helpers-with-timeout.patch
5d03a0c4-9-Arm-cmpxchg-helper-with-timeout.patch
5d03a0c4-A-Arm-turn-on-SILO-mode-by-default.patch
5d03a0c4-B-bitops-guest-helpers.patch
5d03a0c4-C-cmpxchg-guest-helpers.patch
5d03a0c4-D-use-guest-atomics-helpers.patch
5d03a0c4-E-Arm-add-perf-counters-in-guest-atomic-helpers.patch
5d03a0c4-F-Arm-protect-gnttab_clear_flag.patch
- Refreshed patches
libxl.pvscsi.patch
xen-tools.etc_pollution.patch

==== xfce4-appfinder ====
Version update (4.12.0 -> 4.14.0)
Subpackages: xfce4-appfinder-lang

- Fixed sources in spec file
- Update to 4.14.0
* Replace GtkStock buttons
* Translation Updates:
- Claned up spec file
- Update to version 4.13.5
* Translation updates
- Update to version 4.13.4
* Improve xfce4-run comment (bxo#15473)
* Translation updates
- Validate appstream metadata
- Update to version 4.13.3
* Update minimal required glib to 2.42
* Allow case-insensitive search
* Do not wrap when Text beside icons is enabled (bxo#8490)
* Icon view: reduce padding/spacing with small icons
* Translation updates
- Updated dependencies
- Fixed up %build section
- update to version 4.13.2
- Convert AppData file to AppStream (bxo#14624)
- Improved spacing and resizing (bxo#14651)
- Ignore menu items without name (bxo#14655)
- Add hide category preference (bxo#14893)
- Save command in history even if it matches Exec (bxo#9023)
- Change default action conflicting pattern (bxo#12103)
- Translation updates
- Changes from 4.13.1
- Improved keyboard navigation in List View
- When expanded, launch apps with single enter press (bxo#14469)
- Improved app sorting
- Add single window option
- Fix segfault when toggling bookmarks (bxo#14134)
- Fix preferences button height
- Translation updates
- Changes from 4.13.0
- Port to GTK+3.
- Update app icons to new standard names.
- Fuzzy search matching (bxo#10393).
- Translation updates
- Clean up spec file:
- Added conditional %bcond_with git for easier maintanance when using
git master branch
- Updated URL
- Cleaned up spec file
- BR: Replaced libraries with devel packages

==== xfce4-branding-openSUSE ====
Version update (4.12.0 -> 4.14+20190815)
Subpackages: exo-branding-openSUSE libgarcon-branding-openSUSE
libxfce4ui-branding-openSUSE openSUSE-xfce-icon-theme
thunar-volman-branding-openSUSE xfce4-notifyd-branding-openSUSE
xfce4-panel-branding-openSUSE xfce4-power-manager-branding-openSUSE
xfce4-session-branding-openSUSE xfce4-settings-branding-openSUSE
xfdesktop-branding-openSUSE xfwm4-branding-openSUSE

- Update to version 4.14+20190815:
* Add back legacy YaST desktop filenames for Leap 15
- Update to version 4.14+20190814:
* Use new YaST desktop file names for application menu
- Update to version 4.14+20190811:
* symlink button to prevent missing icon after update
- Update to version 4.14+20190808:
* Panel defaut size at 24px
- Update to version 4.14+20190805:
* Fixed icon resolutions
- Update to version 4.14+20190805:
* Cleaned up pixmaps folder
* Changed Whisker menu button icon
* Restructured and improved button icons
* set systray icon size to 22px
- Update to version 4.14+20190729:
* xfce4-panel use upstream clock format
- Update to version 4.14+20190725:
* Make systray icon size 16px
* Rebase keyboard shortcuts from upstream and add improvements
* Update Whisker Menu title and icon
* Added new button icons in svg format
* Make panel tasklist group windows
* use Greybird-Geeko-Light xfwm4 theme by default
* Set greybird-Geeko-Light gtk theme as default
- Update to version 4.13+20190703:
* Remove splashscreen configs from xfce4-session.xml
* Add Priorities to fix race conditions on startup
- Follow correct name guidelines for file name ("+" instead of "~")
- Use xz for source compression
- Update to version 4.13~20190513:
* Delete terminalrc as not needed for now
* Make systray use square icons
* make statusnotifier plugin use symbolic icons
- Updated URL in spec file
- fixed path of terminalrc
- make Firefox default instead of Midori (fix)
- Use xfce4-branding-openSUSE-4.13 source
* adds xfce4-terminal color scheme
* panel tasklist: show flat window buttons

==== xfce4-dev-tools ====
Version update (4.12.0 -> 4.14.0)

- Fixed sources in spec file
- Update to version 4.14.0
* Bump to 4.14.0
- Added bcond to build with git master source
- Cleaned spec file
- Update to Version 4.13.0
* Merge exo-csource modifications in xdt-csource
* xdt-csource will replace exo-csource (projects using
exo-csource need to be updated)
* The work started in issue bxo#6449 but the full migration has
never been done.
* Remove svn support in xdt-autogen
* Simplify a bit the XDT_AUTOGEN_REQUIRED_VERSION detection
* Remove the check of the unused doc submodule
* Remove useless macros: m4macros/xdt-python.m4
and m4macros/xdt-xfce.m4 are not used
* Remove xdt-commit, used to generate Changelog, now done via
make distcheck
* No -Wshadow flag for enable_debug=full (bxo#11637).
Use it only for enable_debug=yes.

==== xfce4-panel ====
Version update (4.12.2 -> 4.14.0)
Subpackages: libxfce4panel-1_0-4 libxfce4panel-2_0-4 xfce4-panel-lang
xfce4-panel-restore-defaults

- Fixed sources in spec file
- Update to version 4.14.0
* tasklist: Keep panel visible on drag and drop (bxo#15703)
* pager: Keep panel visible on drag and drop (bxo#15703)
* launcher: Make dialog's context menu popup at pointer
* Make strings translatable
* Translation Updates
- Cleaned up spec file
- Update to version 4.13.7
* Make vala and gobject-introspection optional
* clock: Add short weekday to default clock string
* clock: Add date to default clock layout (bxo#15456)
* prefs: Improve position of panel profiles button (bxo#15657)
* tasklist: Fix position of group indicator in vertical mode
* tasklist: Fix overlapping vertical window titles (bxo#14901)
* tasklist: Add fallback for missing window icons (bxo#15511)
* directory-menu: Use natural order for sorting (bxo#15413)
* arrow-button: Remove timeout on dispose (bxo#15696)
* pager: Ensure bg color is set correctly (bxo#15690)
* show-desktop: Toggle also when DND-ing (bxo#15654)
* tic-tac-toe: Add mnemonic to Close button
* tic-tac-toe: Avoid use-after-free/double-free (bxo#15649)
* Translation updates
- Update to version 4.13.6
* Update default panel layout
* Retain original GDK_CORE_DEVICE_EVENTS setting for plugins
(bxo#15044)
* directorymenu: Fix plugin menu autohide behaviour
* prefs: Add missing mnemonic accelerators (bxo#15652)
* prefs: Improve window title (bxo#15653)
* prefs: Correct capitalization of labels (bxo#15651)
* arrow-button: Allow connect_after signals on draw
* tasklist: Draw grouped windows count indicator (bxo#10844)
* tasklist: Only base bg color of group indicator on Gtk theme
* tasklist: Avoid draw signal loop
* tasklist: Don't show actionsmenu in grouped windows
(bxo#15622)
* Add more accelerators to dialog buttons (bxo#15490)
* AC_CONFIG_MACRO_DIR -> AC_CONFIG_MACRO_DIRS
* Fix typo in debug output
* Translation updates
- Update to version 4.13.5
* Bugfixes:
- Revert "Applications menu icon sizing fixes" (bxo#14976)
- Make sure panel plugin icons aren't clipped (lp#1756608)
- actions: use a different icon for hybrid sleep when possible
(bxo#15204)
- Fix compiler error -Wcast-function-type (GCC 8)
- Fix alpha-transparent background images (bxo#14850)
- Fix this use of "defined" may not be portable
- Bump glib version to 2.42.0
- tasklist: Activate parent windows (bxo#15307)
- launcher: Fix tooltip icon size (bxo#15319)
- Hide systray frame in default panel config
- separator: Use symbolic icon for more clarity (bxo#15359)
* Translation updates
- Update to version 4.13.4
* Add per-panel setting "icon-size"
* Set minimum Gtk+3 version to 3.22
* Bugfixes:
- Gtk+ deprecation fixes (all plugins)
- tasklist: Fix group-button states
- libxfce4panel: arrow button size fixes
- launcher: plugin sizing fixes
- appmenu: Add support for other menu editors (bxo#11684)
- tasklist: Fix urgency blinking for group buttons (bxo#6904)
- tasklist: Add 'group-button' styleclass
- Fix anchors for gtk_menu_popup_at_widget (bxo#14803)
- Fix struts on the bottom and right of the screen (bxo#14886)
- tasklist: Don't listen for monitor changes in the plugin (bxo#10725)
- tasklist: Use Gdk to to determine which monitor contains a window
- tasklist: Ensure pressed buttons with open menus
- tasklist: Replace exo-lucency with gtkcss
- tasklist: Make all-minimized group buttons translucent (bxo#10862)
- tasklist: Switch from wnck* icons to standard names
- tasklist: Keep groupbutton active after closing menu
- tasklist: Make sure icons in the group menu are 16px
- tasklist: Make grouped buttons active (bxo#9129)
- launcher: Rely on icon-size provided by panel
- Prevent crash on removing certain plugins (bxo#14418)
- Add "configure" button to composited infobar
- Make compositor info in settings dialog a GtkInfoBar
- directorymenu: Fix crash and drop deprecated call
- Fix unreadable panel items without compositing (bxo#14842)
- launcher: Fix arrows not being shown (bxo#14373)
- launcher: Fix tooltip icon size (bxo#14774)
- Re-introduce button images to plugin settings dialogs
- Make the settings dialog more HIG compliant
- launcher: Add 'New Link' button to properties (bxo#14855)
- Drop the panel's welcome dialog (bxo#14388)
- clock: Resolve deprecations and fix binary clock
- Workaround for xinput2's subpixel handling (lp#1795135)
- Ensure the orientation style classes are always applied
- Add orientation-related style classes for improved theming
- actions: Add support for dm-tool
- panel-window: set struts with monitor scaling
* Translation updates
- Changes from 4.13.3
* Bugfixes:
- Get the actual widget state flags to avoid constant redraws (bxo#14307)
- launcher: Fix empty button in remove launcher dialog (bxo#13962)
- launcher: Make sure icons are not oversize
- launcher: Make sure the appropriate icon size is used
- launcher: Fix resizing of pixbuf based icons (bxo#14138)
- Move "Separator" to the top of the "Add New Items..." menu (bxo#14086)
- Make a couple of strings translatable (bxo#14338)
- Make former GtkStock dialog buttons translateable (bxo#14338)
- Make double-click add plugin in the "Add item" dialog (bxo#9784)
- clock: Improve discoverability of tooltip help-texts (bxo#11708)
- Correctly initialize return value (bxo#10873)
- Gtk+3 fixes:
- Fix various warnings with Gtk3 (bxo#14135)
- Fix Gtk+3 version in ifdef
- Use 'gdk_screen_is_composited' with Gtk3 (bxo#14128)
- Try to fix menu positioning with Gtk3.22
- Various icon fixes:
- Switch to GtkIconTheme (bxo#14125)
- Fix missing icons with Adwaita icon theme (bxo#14133)
- Fix remaining deprecated icon names
* Translation updates
- Changes from 4.13.2
* Add support for gobject-introspection (Vidar Haarr)
* Bugfixes:
- actions: Fix GPtrArray usage (bxo#13981)
- actions: Show Hybrid Sleep option (bxo#12771)
- clock: Fix invalid datetime formats appearing in list (bxo#11527)
- clock: Use freedesktop.org compliant icon (bxo#13779)
- clock: Add a validator for digital custom formats (bxo#11527)
- clock: Fix format validation (bxo#11527)
- launcher: Fix custom images
- tasklist: Fix scrolling to cycle through open windows (bxo#13789)
- tasklist: Define cosmetic default padding for images (bxo#13865)
- tasklist: Fix alignment of labels when orientation is changed (bxo#13864)
- tasklist: Allow to hide label decorations (bxo#10546)
- systray: Fix crash when systray is empty (bxo#13927)
- systray: Don't lookup hash table for null keys (bxo#11929)
- systray: Add option to display icons with square sizing (bxo#12093)
- Pass socket id to D-Bus service to embed settings window (bxo#13854)
- Make "Automatic" the default selection in the panel config dialog
- Fix make distcheck (But #14040)
- Improve gtkdoc
* Translation updates
- Changes from 4.13.1
* Port to GDBus (Ali)
This means the panel now depends on xfconf 4.13 - recommended is 4.13.3.
* Features:
- systray: Allow ordering of items (bxo#11929)
- tasklist: Add styleclass to make life easier for themers
* Bugfixes:
- Fix DND between external plugins (bxo#13687)
- Fix drag and drop for internal plugins (bxo#13642)
- Correct enter and leave opacity label positions (bxo#13594)
- Fix Gtk3 XfceArrowButtons not blinking (bxo#13599)
- Fix datarootdir declaration in .pc files (bxo#13589)
- Use fd.org terminal icon name (bxo#13592)
- Don't let the wrapper crash on unknown properties (bxo#13614)
- Set default panel-2 size of default settings
- windowmenu: Fix icon size in menu
- systray: Fix alignment of single non-square items (bxo#9095)
- clock: Make the default date and time format translatable (bxo#9637)
* Translation updates
Changes from 4.13.0
* Port to Gtk3:
The port is the result of the hard work Nick, Peter, Andrzejr, Simon and
many others that helped with testing, patches and translations.
* Features:
- Support for the "primary" monitor option in RandR
- Gtk2 plugins are still supported and work almost completely fine
(see regressions below)
* Deprecations:
- xfce_panel_image is deprecated, instead plugins shall use GtkImage and
xfce_panel_plugin_get_icon_size which introduces defined icon size-steps
to avoid fuzzy icons
* Known regressions:
- The panel is not visually focused by default (fixed in Xfwm4>=4.12.4)
- Moving panel plugins via drag and drop on the panel directly via the plugins
context menu action "Move" is currently broken (works fine in preferences
dialog)
- Small regression with intelligent hiding (when opening a menu, the panel
hides and comes back immediately while it should just remain visible)
- Enter/leave opacity does not work for Gtk2 plugins
- Not all panel settings may be kept as the configuration is not 100% backward
compatible (e.g. we're using GdkRGBA instead of GdkColor for the backgorund)
* Known todos:
- Fix all bugs/regressions
- Remove more/all Gtk+ deprecations
(lots of warnings when compiling currently)
* Lots of translations updates
- Clean up spec file and dropped obsolete macros
- Added conditional %bcond_with git for easier maintanance when using
git master branch

==== xfce4-power-manager ====
Version update (1.6.1 -> 1.6.5)
Subpackages: xfce4-power-manager-lang

- Fixed sources in spec file
- Update to version 1.6.5
* Improve size of critical power level spin
* Correctly hide brightness label (bxo#14649)
* Replace GtkStock buttons
* Add icons to close and help buttons in prefs
* Translation Updates
- Cleaned up spec file
- Update to version 1.6.4
* Make inhibition affect dimming and inactivity action (bxo#14687)
* Add support of xfce4-screensaver
* Disable trayicon when panel plugin is present (bxo#15682)
* Translation updates
- Panel plugin sub-package renamed to follow upstream name:
xfce4-foo-plugin
- Update to version 1.6.3
* Revert "Read from actual_brightness instead of brightness"
* Translation updates
- Validate appstream metadata
- Update to version 1.6.2
* Fix compiler warning (bxo#14104)
* Fix various warnings
* Don't autostart the power manager in the LXQt DE (bxo#14450)
* Don't overwrite the user's XScreensaver settings (bxo#14968)
* Fix slider labels (bxo#14395)
* Replace xfconf_channel_new by xfconf_channel_get
* Read from actual_brightness instead of brightness
* Fix g_type_class_add_private is deprecated
* Handle glib deprecations
* Use the newer up_client_get_devices2
* Install Appdata in metainfo (bxo#15380)
* plugin: Show discharge level even in unknown state (bxo#15280)
* settings: change "going from sleep" to "going to sleep"(bxo#15144)
* settings: Improve devices tab visually by adding frame
* Translation updates
- Dropped obsolete patches:
- xfce4-power-manager-1.6.1-fix-no-return-in-nonvoid.diff
- xfce4-power-manager-1.6.1-no-show-in-lxqt.diff
- Added bcond to build with sources from git master branch
- Switched to %autosetup for simpler maintenance
- Switch urls to https://
- Cleaned up spec file

==== xfce4-screenshooter ====
Subpackages: xfce4-screenshooter-lang

- Fixed sources in spec file
- Renamed Panel Plugin subpackage to follow upstream naming
xfce4-foo-plugin
- Added bcond for git master builds

==== xfce4-session ====
Version update (4.12.1 -> 4.14.0)
Subpackages: xfce4-session-lang

- Fixed sources in spec file
- Update to version 4.14.0
* settings: Fix icon name
* settings: Replace GtkStock buttons
* Set XAUTHLOCALHOSTNAME in systemd user session (bxo#15440)
* Translation Updates
- Changes from version 4.13.4
* Process Gtk events prior to starting D-Bus (bxo#15712)
* Splash engines are not present anymore in xfce4-session
(obsoletes the lib and -devel Subpackages)
* Translation updates
- Changes from version 4.13.3
* Reset font-size of logout dialog to default (bxo#15505)
* Report optional dependency on polkit (bxo#12761)
* Read data from correct group when editing autostart entry
(bxo#10423)
* Improve layout of autostart add/edit dialogs
* Improve column layout of autostart tab (bxo#15448)
* settings: Fix crash when terminating programs (bxo#15489)
* Translation updates
- Update to version 4.13.2
- Drop splash screens
- Introduce priority-group startup for FailSafe Session
- Optionally run commands on logout, suspend etc. (bxo#10172)
- xflock4:
- Do not override PATH with hardcoded value.
- Add support for xfce4-screensaver to xflock4
- chooser:
- Improve look and feel of the session chooser
- Improve UI and add delete button (bxo#12799)
- Add fallback theming to chooser dialogs
- Enable keypress response to session creation
- Update session name in xfconf after chooser
- Fix case in session chooser buttons
- settings:
- Show saved sessions in settings dialog
- Move "lock screen before sleep" option to general tab
- Fix alignment of session lock property
- Fix PID showing in "Current Session" tab
- Improve icon matching in "Current Session" tab
- Add a label for the currently active session
- Add a "delete session" button to the session list
- Make the Autostart buttons an inline toolbar
- Initialize the session list treeview if necessary
- More settings dialog UI improvements
- Add column headers to autostart list
- In autostart some apps (e.g. xfce-polkit) have bigger icons
- Make entries expand in add/edit app startup dialog (bxo#15321)
- logout-dialog:
- Fix sensitivity of switch user button
- Remove blue border from logout dialog (bxo#15284)
- Improve default style of the logout dialog
- Add styleclass to make logout dialog themeable
- Set logout dialog icons from icon_name
- Support scaling in logout dialog (bxo#14951)
- Use a different icon for hybrid sleep when possible
- Fix mnemonic conflict on logout dialog
- Use systemd-logind methods instead of polkit permissions (bxo#14707)
- scripts/xinitrc.in.in: use "command" shell builtin instead of
which(1)
- Use sysconf(_SC_NGROUPS_MAX) instead of #defining an arbitrary
MAX_USER_GROUPS (bxo#14722)
- Don't auto start consolekit daemon if it is not running
- Added better shutdown fallback support for the BSDs (bxo#14722)
- Don't install generic icon names (bxo#11912)
- Use exec to launch xfce4-session from xinitrc
- xinitrc: Remove fallback path when xfce4-session is not installed
- Remove old unused autostart_migrate function
- Fix GVariant format string in dbus server
- Extend debug messages
- Silence compiler warnings
- Remove unused checks on configure step
- Drop unused function
- Remove useless ioprio.h check
- rollback fix of a warning (fix requires glib 2.58)
- Fixed warning "cast between incompatible function types" introduced
in GCC 8
- replaced GList of windows with single window (not required any more)
- merged identic cases
- removed duplicated loop counter
- replaced deprecated "gtk_display_get_screen" - For each display
there is only one screen (See gtk3 doc of gdk_display_get_screen).
- bump gtk version to 3.22 and gmodule/gio to 2.42
- Remove now useless XFCE_GLADE_*_PATH variables (bxo#13945)
- Tell intltool how to extract .ui files (bxo#14582)
- fix build failure when dbus is not in the system include path
(bxo#14386)
- Translation updates
- Changes from 4.13.1
* Add/Edit Application Autostart Entries (bxo#13271)
* Remove non-existent grid properties (bxo#13271)
* fix coverity 178990 Resource leak
* fix coverity cid 178989 Dereference after null check
* 178988 'Constant' variable guards dead code
* fix coverity cid 178987 Logically dead code
* fix coverity cid 87608 Dereference after null check
* 178988 'Constant' variable guards dead code
* fix coverity cid 178987 Logically dead code
* fix coverity cid 87608 Dereference after null check
* fix coverity cid 87607 Unchecked return value from library
* Hybrid Sleep support - "hibernate" and suspend the system
* xfce4-session-logout: deconflict -h option (bxo#12806)
* Export the SSH_AUTH_SOCK when spawning client bxo#13486
* fix: Compilation error with --disable-polkit bxo#12760
* Require libxfce4ui-2 instead of libxfce4ui-1 in pc.in file
* xfsm-manager: pass manager variable to g_timeout_add bxo#13802
* Bump GTK version to 3.20
* Check accessibility depending on xfsm configuration
* Fix keyboard grab for logout window
* Fix fadeout window using Xlib API
* Fix gdk max version to 3.20
* Translation updates
- Changes from 4.13.0
* xfsm has been ported to Gtk3.
* xfsm now does session management for clients using the Gtk application
dbus interface.
* xfsm has been ported to GDBus.
* Add a switch user button to the logout dialog (bxo#10345)
* UPower dependency has been removed as the suspend/hibernate dbus calls
were dropped from it.
* Handle screensaver with it's own object (bxo#12603)
* Fix a crash when warning about the screenlocker (bxo#12603)
* When locking fallback to xflock4 first (bxo#12603)
* Add switch-user to the xfsm-logout program
- Added %bcond to improve portability of spec file between git master
and released sources
- Drop obsolete patch xfce4-session-simple-splash-remove-shadows.patch
- Drop obsolete patch xfce4-session-Make-verbose-logging-conditional.patch
- Dropped additional-lockers-support.patch
- Added add-light-locker-support.patch
- Added xfce4-session-adapt-session-scripts-git.patch for git master builds
- Added add-light-locker-support-git.patch for git master builds
- Dropped obsolete xfce4-session-systemd-user-addons.patch (fixed upstream)
- Fixed up spec file
- Don't install xscreensaver.desktop. We use xfce4-screensaver instead

==== xfce4-settings ====
Version update (4.12.4 -> 4.14.0)
Subpackages: xfce4-settings-lang

- Fixed sources in spec file
- Enable colord support
- Update to version 4.14.0
* a11y: Replace GtkStock buttons
* appearance: Replace GtkStock buttons
* color: Replace GtkStock buttons
* display: Don't warn on deleting last profile
* display: Fix settings retention (bxo#15437)
* display: Remove debug statement breaking profiles (bxo#15769)
* display: Use proper icon name
* keyboard: Replace GtkStock buttons
* Make strings translatable
* mouse: Replace GtkStock buttons
* settings-editor: Fix buttons declaration
* settings-editor: Replace GtkStock buttons
* Translation Updates
- Update to version 4.13.7
* display: Sync display when applying config
* display: Use current display
* xsettings: Grab and sync XServer on startup (bxo#15725)
* xfsettingsd: Start settings prior to complete startup (bxo#15725)
* Update copyright years
* Translation updates
- Update to version 4.13.7
* color:
- Fix crash when launching gcm in plugged dialog (bxo#15426)
- Set correct icon in color dialogs
* display:
- Replace deprecated icon (bxo#15416)
- Add mnemonics to minimal dialog buttons (bxo#15449)
- Disable auto-enabling profiles by default
* settings-manager: Fix missing icons on resize/add/remove
(bxo#15428, bxo#15613)
* xfsettingsd: Fix numlock state restoration (bxo#15642)
* Translation updates
- Added OBS service file to enable only for GIT Master aka RAT
- Update to version 4.13.6
* New Feature: Add color-settings (colord frontend)
* New Feature: Add display profile support to the daemon
* Bugfixes and other smaller changes:
- display:
- Track and highlight active profile
- Ask user to update profile when closing with unsaved
changes
- Add interactive information about primary display setting
- Improve profile-create popover
- Improve profile-delete dialog
- UI alignment improvements
- Reduce complexity of the code and speedup
display_settings_get_profiles
- Replace deprecated GtkStock
- Re-introduce display numbering
- Ensure the settomgs dialog gets properly destroyed
- Verify unique profile names
- Drop connector name from profile matching
- Correctly fall back to previous profile on cancel
- Fix alignment of buttons in minimal dialog
- Only show profiles which match *all* connected displays
- Update profile list on screen changes
- Fix crash when no RRMode is available (bxo#12607)
- Correctly hide primary setting with 1 display
- Fix calculation of offset
- Always show the 'primary display' option
- Make primary indicator a star icon
- Throw warning when monitors exceed max screen size
- color: Always select first device on startup (bxo#15266)
- xfsettingsd: Increase startup priority
- Fix scrolling in embedded settings dialogs (bxo#14285,
lp#1653448)
- Fix search change clearing and hiding sections (bxo#14792)
- Resolved g_type_class_add_private deprecations (GObject 2.58)
- Fix incremental sending from the clipboard manager (bxo#13537)
- Fix WindowScalingFactory property type
- Fix code spacing
- Fix memory leaks
- Fix CID 337242: Null pointer dereferences (REVERSE_INULL)
- Fix compiler warnings
- Fix icon names
- Update configure.ac.in
- Update .gitignore
- Set yes as the default debxolevel
* Translation Updates
- Update to version 4.13.5
- New: Add display profiles feature
- Allows for saving/restoring display configurations
- Profiles can be auto-applied when new displays are connected
- Drop the Gtk Theme previews
- Various UI improvements to the settings dialogs
- New icons for the minimal display dialog
- Fix: Fix broken hover effect in the settings manager (bxo#14539)
- Fix: Add default mnemonics back to dialog buttons
- Fix: Add DBUS_GLIB_CFLAGS for Settings Editor (bxo#14385)
- Fix: Force using a period as a decimal separator in xfsettingsd (bxo#11906)
- Translation updates
- Changes from 4.13.4
- Fix: Redefinition of DISTCLEANFILES
- Fix: Typo, "PRECISON" to "PRECISION"
- Replaced "AC_CONFIG_MACRO_DIR" usage with "AC_CONFIG_MACRO_DIRS"
- Translation updates
- Changes from 4.13.3
- Fix: Uninitialized scalar variables (CID #292062, #292063)
- Fix: -Wcast-function-type (GCC 8)
- Ported from dbus-glib to gdbus (bxo#14426)
- Added support for xrandr display scaling (via Xfconf)
- Improved display manufucturer name recognition:
- Refreshed PNP IDs from hwdata
- Added support for VBX (VirtualBox)
- Standardized and shortened manufacturer names
- Updated laptop detection to include eDP in XfceRandr
- Updated --help copyright information to 2018
- Translation updates
- Changes from 4.13.2
- New: Show location of the mouse pointer on keypress
- Fix: syncdaemon not starting with certain locales
- Fix: division by 0 crash from gdk_screen_height_mm()
- Fix: Remove existing socket from socket viewport (bxo#13847)
- Fix: Use transient notifications for improved logging
- Fix: Do not expand event sounds section so font scaling is correctly
positioned
- Improvements for multimonitor support:
- Visualize all three display configuration states
- Visually note if two displays overlap (mirrored) but are not cloned
- Always draw active display last so it's on top
- Fix: Correctly position monitors in extended mode
- Fix: Race condition with monitor connect and disconnect
- Fix: Segfault on monitor reconnect
- Fix: Leave monitors where they were if possible (bxo#14096)
- Deprecations:
- Resolved GTK+ 3.22 deprecations (bxo#14273)
- Translation updates
- Changes from 4.13.1
- This release now requires xfconf 4.13+
- New: Default monospace font option in the Appearance dialog
- New: Improved support for embedded DisplayPort connectors
- Fix: Display dialog drawing of displays
- Fix: Display dialog DND usability issue introduced in 4.13.0
- Fix: Make minimal dialog single instance (bxo#11169)
- Fix: Linking to dbus-glib with xfconf 4.13+ (bxo#13633)
- Deprecations:
- Resolved gtk_menu_popup deprecation
- Resolved gdk_error_trap_pop deprecation
- Ignoring GdkScreen and GdkCairo deprecations in the display settings
until GNOME or others find a resolution in their display management
- Code Quality:
- Several indentation fixes
- Drop duplicate drawing code
- Translation updates
- Changes from 4.13.0
- Initial port to GTK+ 3
- Known issues:
- The display dialog does not always build correctly. The offending
code exists in the port to GdkSeat. When alternating between the
old and new versions of this code, both versions do work, so there
seems to be some strangeness at build time.
- See dialogs/display-settings/scrollarea.c#n513
- Translation updates
- Clean up spec file:
- Added conditional %bcond_with git for easier maintanance when using
git master branch
- Updated URL
- Clean up spec file:
- Added conditional %bcond_with git for easier maintanance when using
git master branch
- Updated URL

==== xfconf ====
Version update (4.12.1 -> 4.14.1)
Subpackages: xfconf-lang

- Fixed sources in spec file
- Update to version 4.14.1
* Release rebuild for libxfconf-0.deps
- Update to version 4.14.0
* Translation updates
- Fixed up spec file
- Update to Version 4.13.8
* Add support for GObject introspection and vala
* Tests: Explicitly handle error reply from Ping method call
* Disable perl bindings by default
* Translation Updates
- Update to version 4.13.7
- Bump glib version
- bxo#15122: xfconf: disable gsettings backend by default
- Fix compiler error -Wcast-function-type (GCC 8)
- Fix this use of "defined" may not be portable
- Update .gitignore
- Fix warnings reported by GCC 8 (bxo#15112)
- Added gdbus binding to gitignore, add post release git tag
- Translation updates
- Fixed up dependencies
- Update to version 4.13.6
* Added .NOTPARALLEL to property change test (bxo#13840)
* Implement an optional GSettings backend
- Changes from 4.13.5
* Fix make distcheck, (bxo#14082)
* Handle empty arrays by initializing the GValue to G_TYPE_PTR_ARRAY
(bxo#13780)
- Changes from 4.13.4
* Fix segfault in xfconf_cache_set_property_reply_handler when
multiple calls are made (bug #13825)
* Allow to store empty arrays (bug #13791)
* Fix a path in xfconf_cache_set where the mutex isn't locked (bxo#13790)
- Changes from 4.13.3
* Flush gdbus connection on xfconf_shutdown
* Correctly use xfconf_shutdown in xfconf-query
* Check for invalid GPtrArrays in the conversion
from GValue to GVariant.
* Fix some build issues in AM subdir-objects
* Fix some autogen.sh warnings
Better documentation processing.
- Changes from 4.13.2
* Fix cache corruption due to a wrong g_value_unset call.
* Update API gtk documentation
- Changes from 4.13.1
* Revert the bump of libxfconf version from 0 to 1,
to avoid massive changes in all xfce's components.
- Changes from 4.13.0
* Port xfconf to gdbus
* Bump libxfconf version from 0 to 1.
- Clean up spec file and dropped obsolete macros
- Added conditional %bcond_with git for easier maintanance when using
git master branch

==== xfdesktop ====
Version update (4.12.5 -> 4.14.1)
Subpackages: xfdesktop-lang

- Fixed sources in spec file
- Update to version 4.14.1
* Ensure the new default wallpaper gets installed
- Update to version 4.14.0
* Add 4.14 wallpaper
* Do not query file information again (bxo#15460)
* Replace GtkStock buttons
* Translation updates
- Fixed up spec file
- Rebased xfdesktop-default-background-image.patch
- Rebased xfdesktop-backgrounds-path.patch
- Update to version 4.13.6
* Update copyright year
* Use https where possible
* Add padding to Window Actions menu entry (bxo#14628)
* Display correct icon size of minimized apps (bxo#8951)
* Reorder checkboxes in Settings UI
* Translation updates
- Update to version 4.13.5
* Highlight drag target when hovering it (bxo#12695)
* Fix drag data being received multiple times (bxo#14471)
* Allow to load non-theme icons (bxo#15294)
* Add Next Background option (bxo#12261)
* Do not cycle backdrop twice
* Ensure that CSD is not applied to desktop window (bxo#15241)
* Use async dbus proxy initialization (bxo#15418)
* Open all selected icons on key press (bxo#15420)
* Improve fallback CSS
* Fix warning about ignoring return value (bxo#15410)
* Update README.xfconf (bxo#15457)
* Translation Updates
- Removed unneeded BuildRoot
- Changes from version 4.13.4
* Re-introduce ability to move icons to other displays
(bxo#15198)
* Make 'Move to Trash' icon the same as Thunar (bxo#15234)
* Match Thunar Drag and Drop behavior (bxo#14919)
* Stop ongoing drag/selection if middle/right mouse button is
pressed (bxo#14180)
* Fix Desktop icons order resets, by adding link to last used
configuration as fallback (bxo#11266)
* Fix xfdesktop crashes after multiples --reload (bxo#15060)
* Fix scaling of images with orientation metadata (bxo#14644)
* Fix stretching/zooming of images with orientation metadata
(bxo#15292)
* Fix has_mime_type implementation (bxo#15295)
* Use clipboard target "text/uri-list" when copying/cutting
(bxo#13379)
* Set desktop environment for garcon app menu (bxo#14599)
* Remove faulty line in glade file (bxo#15293)
* Fix g_type_class_add_private is deprecated
* Avoid invalid memory access (bxo#15299)
* Avoid timer leak when docking-undocking monitors (bxo#13887)
* Use clipboard target "text/uri-list" when copying/cutting
(bxo#13379)
* Set desktop environment for garcon app menu (bxo#14599)
* Properly center workspace header in windowlist (bxo#15405)
* Fix memory leak when monitors change (bxo#14844)
* Replace/remove deprecated functions
* Translation Updates
- Changes from version 4.13.3
* Minimal GTK version = 3.22
* Avoid crash: do not clean up data to be used (bxo#14609)
* Add orientation option to arrange icons (bxo#14979)
* Fix icon size in Open with submenu (bxo#14774)
* Add support for RandR's primary monitor (bxo#10688)
* Sync user's wallpaper selection to AccountsService
* Restore icons of custom actions
* Port Settings UI to Glade 3
* Add padding to some context menu icons (bxo#14628)
* Translation Updates
- Changes from 4.13.2
* Use the new Thunarx-3 API (Thunar >= 1.7)
* Use custom CSS for the iconview as a fallback (bxo#13609)
* Get/set _NET_DESKTOP_MANAGER_S<screen> atom (bxo#13653)
* Make "another desktop manager is running" messages critical (bxo#13653)
* Change "Create Launcher..." icon (bxo#14161)
* Do not popup a single "Applications" menu when right clicking on desktop
(bxo#13866)
* Single-click mode executes desktop items twice (bxo#14021)
* Fix menu popup issue with desktop icons disabled (bxo#14415)
* Fix memory leak : Don't try to allocate all the memory (bxo#12805)
* Fix some autotools warnings and bump dependencies
* Make a couple of strings translatable (bxo#14374)
* Translation Updates
- Changes from 4.13.1
* Fix a memory leak reported in bxo#13555
* Fix garcon-2 dependancy check (continue to use garcon-1)
* Translation Updates
- Changes from 4.13.0
* Port to GTK version = 3.22
* Fix icon size in Open with submenu (bxo#147743)
* The iconview has a CSS name of "XfdesktopIconView" and
adds the GTK_STYLE_CLASS_VIEW to it's base. It then adds
GTK_STYLE_CLASS_LABEL when rendering the icon text with
the states: selected, active, or normal. Additionally it
uses the GTK_STYLE_CLASS_RUBBERBAND when for the rubberband
theming.
* Port to GDBus.
* Don't redraw the icons on focus change events (bxo#12071)
* Don't try to divide by 0 (bxo#12115)
* Settings: Fix loading of wallpaper previews (bxo#11892)
* Settings: Allow directories to be selected (bxo#12832)
* Fix Open dialog's title (bxo#12560)
* Prevent a crash in the backdrop loader (bxo#12339)
* Use gdk's get static image for animation files
* Add translation string for Trash desktop icon
* Retain icon relative position when moving a group
- Clean up spec file and dropped obsolete macros
- Added conditional %bcond_with git for easier maintanance when using
git master branch
- Dropped obsolete 0001-Use-the-new-Thunarx-3-API.patch
- Fixed patch xfdesktop-default-background-image.patch
- Dropped obsolete wallpaper-scaling.patch (fixed upstream)

==== xfwm4 ====
Version update (4.12.5 -> 4.14.0)
Subpackages: xfwm4-lang

- Fixed sources in spec file
- Update to version 4.14.0
* settings-dialog: Replace GtkStock buttons
* Translation Updates
- Fixed up spec file
- Update to version 4.13.4
* Fix GL texture filter (bxo#15676)
* Fix zooming without GL
* Place windows on current monitor (bxo#14959)
* Fix raising of parent transients (bxo#15580)
* Enable root pixmap with compositor (bxo#15709)
- Enable Xpresent support
- Update to version 4.13.3
* Update CSS for tabwinb only on theme change
* HiDPI: Use GTK3 scaling attributes for window titles
* HiDPI: Adjust default theme with scale
* Fix initial pointer location when zooming
* Fix double-click distance setting
* Allow the top of the frame to be cropped when maximised
(bxo#14470)
* Update default theme to use maximized cropping
* Fix build without compositor (bxo#15432)
* Improved GLX support with NVIDIA proprietary/closed source driver
(bxo#15453)
* Compositor updates with GLX
* Small optimization with zoom on GLX
* Increase X11 client priority of xfwm4
* Change default compositor background to plain black
* Fallback to resource class name for icons
(bxo#15510)
* Clear shortcut in settings-dialog when removed (bxo#12802)
* Remove icons from window menu
* Fix regression with maximized window (bxo#15638)
* I18n: Update translations
- Update to version 4.13.2
- Fix flickering with GLX backend (bxo#14564, bxo#13519)
- Fix monitor geometry with scaled UI (bxo#14566)
- Fix issue with Android Virtual Device emulator (bxo#12206)
- Fix XI2 mask (bxo#14695)
- Fix preview with shaded windows (bxo#14899)
- Fix tabwin placement with scaled UI (bxo#14931)
- Add xfconf setting for selecting permanent vblank method
- Fix maximization with GTK clients using size increments (bxo#13954)
- Add style class to tabwin modes
- Fix crash/stack smash in startup-notification on some architectures
(bxo#15028)
- Avoid crash with button layout setting (bxo#14606)
- Raise on activate only with raise-on-focus (bxo#14656)
- Fix use after release of client picture with hidden (bxo#14990)
- Fix monitor output size update (bxo#15085)
- Allow transients to be minimized (bxo#14953)
- Raise all transients together (bxo#15303)
- Fix menu alignment with scaled UI
- Fix a regression where the client would remain visible if
closed while cycling (bxo#15318)
- Withdraw the frame before the client window (bxo#15061)
- Revert to GLX as default vblank method (bxo#15325)
- Reduce repaint timeout (bxo#14335)
- Fix support for 1bpp icons
- Use cairo for pixmaps and masks
- Allow hiding windows using NET_WM_STATE_HIDDEN (bxo#15356)
- Fix size increment with scaled UI
- Various compositor improvements and optimizations with GLX
- Check for appropriate XSync version and increase xfwm4 priority
- Adjust zoom update based on monitor refresh rate (bxo#1539)
- Fix window type for broken clients (bxo#15399)
- Fix pointer enter/leave with decoration buttons (bxo#14741)
- New default theme
- Translation updates
- Switch source to released tarball instead of git master
- Fixed bcond for building with git sources and released tarballs
- Stop trying to install Gilouche, Sonar and Kelabu themes.
These themes are no longer provided by this package.
- Cleaned up spec file
- Update to version 4.13.1~git229.add14bfa:
* I18n: Update translation gl (100%).
* I18n: Update translation da (100%).
* compositor: Remove unused variables
* compositor: Rework XPresent error handler
* compositor: Set present pending only on success
* compositor: Disable XPresent on any error
* compositor: Fix xpresent
* client: Check for enter/leave window on button events
* I18n: Update translation da (100%).
* hints: Remove unused variables
- Update to version 4.13.1~git134.558fb547:
* I18n: Update translation pt_BR (100%).
* compositor: Ignore errors when destroying windows
* display: Do not sync before trap pop
* display: Log serial and minor code
* I18n: Update translation gl (100%).
* poswin: Small cleanup
* moveresize: Size increment depends on scale
* poswin: Use our own GdkWindow for scale
* poswin: Fix position with scale
* compositor: reduce timeout to 1ms
- Update to version 4.13.1~git118.10b15b1a:
* compositor: Reduce repaint timeout to 2ms
* compositor: reinstate ?--vblank? option
* compositor: Revert to GLX as default vblank method (again)
* client: Withdraw the frame before the client window
* menu: Avoid XError with gtk
* client: Do not ping client when killing it
* cycling: Remove client if destroyed while cycling
* I18n: Update translation ko (100%).
* client: Fix regression with MWM hints
* Add gitignore
- Changes from 4.13.0
* Add support for VSYNC using either Present or OpenGL
* Support for scaled cursor when zooming
* Daemon mode is now deprecated (--daemon has no effect)
* Bug fixes and I18n improvements
- Clean up spec file
- Added conditional %bcond_with git for easier maintanance when
using Xfce git master branch

==== yakuake ====
Version update (3.0.5 -> 19.08.0)
Subpackages: yakuake-lang

- Update to 19.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08.0.php
- No code change since 19.07.90
- Update to 19.07.90
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-rc.php
- No code changes since 19.07.80
- Update to 19.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.08-beta.php
- Changes since 3.0.5:
* yakuake web site due to be killed off in favour of kde.org/applications
* [Yakuake] add blur effect support
* [Yakuake] Use the svg icons instead of the png icons for the default theme
(kde#397590)
* Remove forcing the initial dir to QDir::homePath() (kde#396036)
* Add DesktopEntry to notifyrc
* [Yakuake] Improve customization
* Remove double scrollbar in appearance settings
* Fix Skin validation when installed from KNS (kde#395012)
* Add option to restore fullscreen state of the window
* Use correct variable type
* Add shortcuts as default shortcuts (kde#401244)
* Use KWindowSystem to determine which display system is in use
* Fix KIcon -> QIcon porting bug
* Use KMainWindow instead of QMainWindow (kde#398425)
* Fix minor EBN issues and typos
- Update URL
- Remove %post/%postun sections, the package doesn't install
shared libraries
- Make lang package optional
- Run spec-cleaner

==== yast2-country ====
Version update (4.2.3 -> 4.2.4)
Subpackages: yast2-country-data

- Restore some needed keyboard maps (follow-up of bsc#1124921).
- 4.2.4


< Previous Next >
This Thread
  • No further messages