Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190815 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Mon, 19 Aug 2019 13:08:28 +0000
  • Message-id: <156622010854.4889.11120741066863053500@go-agent-stagingbot-7>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190815

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
MozillaThunderbird
busybox
ca-certificates-mozilla (2.30 -> 2.34)
corosync (2.4.4 -> 2.4.5)
evolution
gcc9 (9.1.1+r273734 -> 9.1.1+r274111)
gdm (3.32.0 -> 3.32.0+2)
gegl
gnome-control-center (3.32.2 -> 3.32.2+9)
gnome-session (3.32.0 -> 3.32.0+5)
gnome-settings-daemon
gnome-shell-extensions
inkscape
krb5
libbluray (1.1.1 -> 1.1.2)
libgee (0.20.1 -> 0.20.2)
libgnomesu
libosinfo (1.5.0 -> 1.6.0)
libqt5-qtdeclarative
mariadb-connector-c (3.1.2 -> 3.1.3)
obs-service-set_version (0.5.11 -> 0.5.12)
open-iscsi
openvpn
osinfo-db (20190611 -> 20190726)
patterns-base
perl-Role-Tiny (2.000007 -> 2.000008)
php7 (7.3.7 -> 7.3.8)
python-pytz (2019.1 -> 2019.2)
shotwell (0.30.4 -> 0.30.5)
squashfs
sysconfig (0.85.2 -> 0.85.3)
system-users
vala (0.44.6 -> 0.44.7)
yast2 (4.2.17 -> 4.2.18)
yast2-installation (4.2.9 -> 4.2.10)
yast2-trans (84.87.20190728.7ac20322a3 -> 84.87.20190811.da547f2b17)

=== Details ===

==== MozillaThunderbird ====
Subpackages: MozillaThunderbird-translations-common

- Update package summary, description, and AppData using more informative
and up-to-date text from the official Thunderbird FAQ, replacing obsolete
references to the Mozilla Application Suite and Thunderbird's relation to
the Mozilla organization

==== busybox ====

- Provide "useradd_or_adduser_dep" for sysuser-shadow

==== ca-certificates-mozilla ====
Version update (2.30 -> 2.34)

- update to 2.34 state of the Mozilla NSS Certificate store (bsc#1144169)
- Removed CAs:
- Certinomis - Root CA
- includes added root CAs from the 2.32 version:
- emSign ECC Root CA - C3 (email and server auth)
- emSign ECC Root CA - G3 (email and server auth)
- emSign Root CA - C1 (email and server auth)
- emSign Root CA - G1 (email and server auth)
- Hongkong Post Root CA 3 (server auth)

==== corosync ====
Version update (2.4.4 -> 2.4.5)
Subpackages: libcfg6 libcmap4 libcorosync_common4 libcpg4 libquorum5

- corosync-2.4.5 upgrade(bsc#1144200)
block_unlisted_ips block package from ips not in nodelist
Qnetd now supports updated NSS database format
Partly fixed problem with ifdown (only for UDPU)
Add: 0001-disable-build-html-docs.patch
Add: bsc#1083561-upgrade-from-1-x-y.patch
Add: 0002-Fix-compile-warnings-with-GCC-7.2.1.patch
Remove: disable-build-html-docs.patch
Remove: 0001-coroapi-Use-size_t-for-private_data_size.patch
Remove: 0002-fix-ifdown-udp.patch
Remove: 0003-fix-tmpfiles-create.patch
Remove: 0004-mark-corosync-as-a-static-service.patch
Remove: 0005-do-not-convert-empty-uid-gid-to-0.patch
Remove: 0006-Fix-compile-warnings-with-GCC-7.2.1.patch
Remove: 0007-add-config-for-corosync-qnetd.patch
Remove: 0008-bsc#1083561-upgrade-from-1-x-y.patch
Remove: 0009-bsc#1088619-add-version.patch
Remove: 0010-qdevice-net-instance.c-optarg-should-be-str.patch
Remove: 0011-NSS_NoDB_Init-the-parameter-is-reserved-must-be-NULL.patch
Remove: 0012-cpg-Inform-clients-about-left-nodes-during-pause.patch
Remove: bnc#872651-stop-cluster.patch
Remove: bnc#882449-corosync-conf-example.patch
Remove: bsc#1001164-corosync.conf-example.patch
Remove: bsc#1141536-corosync-qdevice-Nss-new-database-files.patch
Remove: corosync-2.3.4-fix-bashisms.patch
Remove: corosync-init-lockfile-path-error.patch
Remove: corosync-start-stop-level.patch

==== evolution ====
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin

- Split text highlight plugin into a subpackage.
- Add missing runtime dependency on the 'highlight' package.
- Replace packageand() by boolean dependencies.

==== gcc9 ====
Version update (9.1.1+r273734 -> 9.1.1+r274111)
Subpackages: cpp9 gcc9-c++ gcc9-fortran gcc9-info gcc9-locale gcc9-objc
libasan5 libatomic1 libgcc_s1 libgcc_s1-32bit libgfortran5 libgomp1 libitm1
liblsan0 libobjc4 libquadmath0 libstdc++6 libstdc++6-32bit
libstdc++6-devel-gcc9 libstdc++6-locale libstdc++6-pp-gcc9
libstdc++6-pp-gcc9-32bit libtsan0 libubsan1

- Enable cross compilers on riscv64
- Update to gcc-9-branch head (r274111).
* GCC 9.2 RC1.
- Remove bogus fixed include bits/statx.h from glibc 2.30. [gcc#91085]
- Update to gcc-9-branch head (r273795):
* Includes fix for LTO linker plugin heap overflow.
(bsc#1142649, CVE-2019-14250)
- Add systemtap-headers BuildRequires. [bsc#1142654]

==== gdm ====
Version update (3.32.0 -> 3.32.0+2)
Subpackages: gdm-lang gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Update to version 3.32.0+2:
+ Remove erroneous NULL from session search directories.
- Switch to git checkout via source service, upstream is lacking in
stable releases. In the future we will use a stable tag when
possible, but when upstream slacks off, we will use a checkout of
the stable branch.
- Refresh patches with quilt.

==== gegl ====
Subpackages: gegl-0_4 gegl-0_4-lang libgegl-0_4-0

- Port sdl-display operation to SDL2: glgo#GNOME/gegl!184.
+ 0001-Extend-configure-checks-with-checks-for-SDL2.patch
+ 0002-Port-sdl-display-to-SDL2.patch
+ 0003-Port-sdl-draw-example-to-SDL2.patch
- Add autoconf BuildRequires and pass autogen.sh call.
- Replace SDL-devel with libSDL2-devel BuildRequires: Build SDL2
support.
- Remove unused build dependencies:
- graphviz-gd is checked for, but unused: glgo#GNOME/gegl!182.
- gtk-doc generation is disabled, i.e. unused.
- enscript just regenerates bundled files, add
fix_doc_installation.patch to avoid the need for this.

==== gnome-control-center ====
Version update (3.32.2 -> 3.32.2+9)
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Update to version 3.32.2+9:
+ display:
- Add guards for NULL display configuration.
- Add failure returns into CcDisplayConfig.
+ universal-access:
- Don't use widget names for GSettings keys.
- Fix leaks checking settings.
- Fix duplicate settings call.
+ Updated translations.
- Switch to git checkout via source service, upstream is lacking in
stable releases. In the future we will use a stable tag when
possible, but when upstream slacks off, we will use a checkout of
the stable branch.

==== gnome-session ====
Version update (3.32.0 -> 3.32.0+5)
Subpackages: gnome-session-core gnome-session-default-session
gnome-session-lang gnome-session-wayland

- Update to version 3.32.0+5:
+ Updated translations.
- Switch to git checkout via source service, upstream is lacking in
stable releases. In the future we will use a stable tag when
possible, but when upstream slacks off, we will use a checkout of
the stable branch.

==== gnome-settings-daemon ====
Subpackages: gnome-settings-daemon-lang

- Refresh patches with quilt.

==== gnome-shell-extensions ====
Subpackages: gnome-shell-classic gnome-shell-classic-session
gnome-shell-extensions-common gnome-shell-extensions-common-lang

- Add gse-apps-menu-Add_missing_chain-up.patch: PanelMenu.Button is
a bit weird in that it also "contains" its parent actor. That
container is supposed to be destroyed with the button, but as we
currently don't chain up to the parent class' _onDestroy(), we
leave behind an empty container every time the extension is
disabled. Fix this by adding the missing chain-up.

==== inkscape ====
Subpackages: inkscape-extensions-extra inkscape-extensions-gimp
inkscape-extensions-skencil inkscape-lang

- Change Python dependencies to Python 3 as Python 2 will be EOL in 2020.
- Use Python 3 to extract translations, add
0001-Run-python-script-for-translations-with-Python-3.patch
- Make extensions compatible with Python 3
(https://bugs.launchpad.net/inkscape/+bug/1735363)
* Add mr_568_extensions_python3_compatibility.patch
* Add f5e0ea893f34_extensions_python3_compatibility.patch
* Add mr_582_extensions_python3_compatibility.patch
- Some spec cleanups (buildroot, defattr)
- Require extensions-extra for gimp extension

==== krb5 ====
Subpackages: krb5-32bit krb5-client

- Integrate pam_keyinit pam module, ksu-pam.d; (bsc#1081947);
(bsc#1144047);

==== libbluray ====
Version update (1.1.1 -> 1.1.2)

- Update to version 1.1.2:
+ Add libxml version to pkg-config Requires.private.
+ Improve support for NetBSD operating system.
+ Improve BD-J compability.
+ Improve Java 8+ compability.
+ Fix main playlist caching in Windows.
+ Fix mark triggering when multiple marks are passed during
single read().
+ Fix seek bar pop-up at chapter boundary with some discs.
+ Fix reading resources indirectly from mounted .jar file.
- Fixed libbluray-java9.patch.
- Enable build against java-devel >= 10.

==== libgee ====
Version update (0.20.1 -> 0.20.2)

- Update to version 0.20.2:
+ Minor build fixes.

==== libgnomesu ====
Subpackages: libgnomesu-lang libgnomesu0

- Update gnomesu-pam.pamd: Include the pam_keyinit.so module in
/etc/pam.d/gnomesu-pam to support kernel keyrings (boo#1144048).

==== libosinfo ====
Version update (1.5.0 -> 1.6.0)
Subpackages: libosinfo-1_0-0 libosinfo-lang typelib-1_0-Libosinfo-1_0

- Update to version 1.6.0
Changes in this release include:
* Add API to get the kernel URL argument for an OsinfoOs
* Improve detection of PPC ISOs
* Add API to create an OsinfoMedia from location using OsinfoMediaDetectFlags
* Add API to get whether a media is bootable or not
* Add OsinfoTree treeinfo properties
* Add API to identify an OsinfoTree
* Deprecate API to guess an OsinfoOs from OsinfoTree
* Add --config-file to osinfo-install-script tool
* Deprecate --config usage for user & admin passwords on
osinfo-install-script tool
* Add API to generate an install-script and its command-line for OsinfoTree
* Use libsoup for "http://"; & "https://"; requests for creating both
OsinfoMedia & OsinfoTree
* Drop GVFS dependency
* Add OsinfoOs property to OsinfoTree
- Drop
CVE-2019-13313-add-new-option-so-users-can-set-config-from-file.patch
CVE-2019-13313-pass-username-password-via-config-file.patch

==== libqt5-qtdeclarative ====

- QtQuick.LocalStorage needs libQt5Sql5-sqlite

==== mariadb-connector-c ====
Version update (3.1.2 -> 3.1.3)

- New upstream version 3.1.3
* CONC-380: Fix CMake warnings
* CONC-345: heap-use-after-free in client_mpvio_read_packet
* CONC-423: Fix GnuTLS error with TLSv1.3
* CONC-424: Ignore SERVER_STATUS_CURSOR_EXISTS if client didn't
open a cursor before
* CONC-421: Fixed crash in GnuTLS when key and certificate are
in the same file
* CONC-429: Don't allow invalid characters in plugin names
* MDEV-19807: Fixed Location of PLUGINDIR if Connector/C is a
subproject
- refresh absolute_path_fix.patch and private_library.patch

==== obs-service-set_version ====
Version update (0.5.11 -> 0.5.12)

- Update to version 0.5.12:
* debian: set script shebang to python3
* debian: add python3 as a runtime dependency
* conditionally define PYTHON in Makefile
* debian: use python3 for building
* try to fix set_version:157:13: E117 over-indented (comment)

==== open-iscsi ====
Subpackages: iscsiuio libopeniscsiusr0_2_0

- Disable LTO (Link Time Optimization) on aarch64 since it seems
to fail -- iscsiadm core dumps almost immediately (bsc#1143192),
updating the SPEC file.

==== openvpn ====

- Clarify in the service file that the reload action doesn't work
when dropping root privileges (boo#1142830).

==== osinfo-db ====
Version update (20190611 -> 20190726)

- Update database to version 20190726
osinfo-db-20190726.tar.xz
- Drop add-sle15sp1-support.patch

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-basesystem patterns-base-basic_desktop
patterns-base-console patterns-base-documentation patterns-base-enhanced_base
patterns-base-enhanced_base_opt patterns-base-minimal_base
patterns-base-sw_management patterns-base-transactional_base patterns-base-x11
patterns-base-x11_enhanced patterns-base-x11_opt

- use journal by default (boo#1143144)
- Add openSUSE Welcome to be included in the x11_enhanced pattern.
- Drop google-roboto-fonts recommends: nothing really depends on
it and roboto is not used as default font in any openSUSE setup
(boo#1144135).

==== perl-Role-Tiny ====
Version update (2.000007 -> 2.000008)

- updated to 2.000008
see /usr/share/doc/packages/perl-Role-Tiny/Changes
2.000008 - 2019-08-05
- reverting all changes from 2.000007 due to failures on some perl versions
and a number of downstream users. The changes will be reintroduced in a
fixed form in a future version.

==== php7 ====
Version update (7.3.7 -> 7.3.8)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pgsql php7-shmop php7-snmp
php7-sockets php7-sqlite php7-sysvsem php7-sysvshm php7-tidy php7-tokenizer
php7-wddx php7-xmlreader php7-xmlwriter php7-xsl php7-zlib

- updated to 7.3.8: This is a security release which also contains
several bug fixes. See https://www.php.net/ChangeLog-7.php#7.3.8

==== python-pytz ====
Version update (2019.1 -> 2019.2)
Subpackages: python2-pytz python3-pytz

- update to 2019.2
* IANA 2019b
* Defer generating case-insensitive lookups

==== shotwell ====
Version update (0.30.4 -> 0.30.5)
Subpackages: shotwell-lang

- Update to version 0.30.5:
+ Update appdata release information.
+ Fix crash in Piwigo if system certificate store is empty.
+ Fix crash in Google Photos if album has no title.
+ Fix crash in Google Photos and Flickr if the OAuth flow fails
in WebKit.
+ Updated translations.

==== squashfs ====

- Add -offset function to skip n bytes at the beginning of the squashfs?

https://github.com/plougher/squashfs-tools/commit/5a498ad24dcfeac9f3d747e894f22901f3ac10
(0003-Add-offset-function-to-skip-n-bytes.patch)

==== sysconfig ====
Version update (0.85.2 -> 0.85.3)
Subpackages: sysconfig-netconfig

- version 0.85.3
- boo#1123699: Use systemd's tmpfile mechanism to create the
symlink infrastructure for resolv.conf and yp.conf early during
boot.

==== system-users ====
Subpackages: system-group-hardware system-group-wheel system-user-bin
system-user-daemon system-user-ftp system-user-games system-user-lp
system-user-mail system-user-man system-user-news system-user-nobody
system-user-upsd system-user-uucp system-user-wwwrun

- Remove s390 groups again. The s390-tools maintainer wants to add groups in
s390-tools manually.
- Add system-user-tftp subpackage with tftp user and group and
/srv/tftpboot as home directory [bsc#1143454].

==== vala ====
Version update (0.44.6 -> 0.44.7)
Subpackages: libvala-0_44-0

- Update to version 0.44.7:
+ Various improvements and bug fixes:
- vala:
. Fix mixup of target_glib_major/minor in
set_target_glib_version().
. Implicit GValue cast requires GOBJECT profile.
. NoAccessorMethod checks require GOBJECT profile.
. 'construct' is not supported in POSIX profile.
- codegen:
. Use G_TYPE_CHECK_INSTANCE_CAST for comparisons with
interfaces.
. Append line-break after G_DEFINE_AUTOPTR_CLEANUP_FUNC.
. Include required type-definition when casting from generic
pointer.
- girparser: Handle "function-macro" by skipping them.
+ Bindings:
- glib-2.0: Add MappedFile.from_fd constructor.
- posix: Fix return-value of mknod() and c-include for
tcgetsid().
- webkit2gtk-4.0: Fix
WebContext.initialize_notification_permissions().
- x11: Fix return type of XInternAtoms and XGetAtomNames
bindings.

==== yast2 ====
Version update (4.2.17 -> 4.2.18)
Subpackages: yast2-logs

- Remove the obsolete XVersion API (bsc#1144627).
- Detect missing textdomain during testing (bsc#1130822)
- 4.2.18

==== yast2-installation ====
Version update (4.2.9 -> 4.2.10)

- Undo the change introduced in 4.2.7 because forcing the focus
is not a solution: now the it's always caught by the installation
summary after every action (related to bsc#1142353).
- 4.2.10

==== yast2-trans ====
Version update (84.87.20190728.7ac20322a3 -> 84.87.20190811.da547f2b17)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv
yast2-trans-ta yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi
yast2-trans-wa yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20190811.da547f2b17:
* Translated using Weblate (Albanian)
* Translated using Weblate (Danish)
* Translated using Weblate (Albanian)
* New POT for text domain 'installation'.
* New POT for text domain 'country'.
* Translated using Weblate (French)
* Translated using Weblate (French)
* New POT for text domain 'autoinst'.
* Translated using Weblate (Portuguese)
* Translated using Weblate (Portuguese)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* New POT for text domain 'installation'.
- Update to version 84.87.20190804.53aa0ced1c:
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Czech)
* Translated using Weblate (Catalan)
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* New POT for text domain 'control'.
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages