Mailinglist Archive: opensuse-factory (443 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190723 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Thu, 25 Jul 2019 02:04:58 +0000
  • Message-id: <156402029840.11708.1807558891472012272@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190723

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
Mesa
Mesa-drivers
MozillaFirefox (67.0.4 -> 68.0.1)
blueberry (1.2.5 -> 1.2.8)
diffutils
dleyna-core
dleyna-server
dnsmasq
gnome-software (3.32.3 -> 3.32.4)
grub2
guile (2.2.5 -> 2.2.6)
hwinfo (21.66 -> 21.67)
hylafax+ (5.6.1 -> 7.0.0)
kernel-source (5.1.16 -> 5.2.1)
krita (4.2.2 -> 4.2.3)
libcontainers-common
libgphoto2 (2.5.22 -> 2.5.23)
libkdepim
libkgapi
libkleo
libqt5-qtwebengine
libuv (1.27.0 -> 1.30.1)
libva (2.4.0 -> 2.4.1)
libva-gl (2.4.0 -> 2.4.1)
linux-atm
mozilla-nss (3.43 -> 3.44.1)
netpbm
open-iscsi
parted
perl-AnyEvent (7.15 -> 7.16)
perl-BerkeleyDB (0.61 -> 0.63)
perl-ExtUtils-F77 (1.23 -> 1.24)
pesign
rubygem-airbrussh (1.3.1 -> 1.3.2)
rubygem-bundler (2.0.1 -> 2.0.2)
rubygem-cfa (1.0.0 -> 1.0.1)
rubygem-childprocess (1.0.1 -> 2.0.0)
rubygem-cri (2.15.5 -> 2.15.9)
rubygem-delayed_job (4.1.5 -> 4.1.7)
rubygem-docile (1.3.1 -> 1.3.2)
rubygem-domain_name (0.5.20180417 -> 0.5.20190701)
rubygem-fluentd (1.4.2 -> 1.6.2)
rubygem-get_process_mem (0.2.3 -> 0.2.4)
rubygem-rspec-core (3.8.0 -> 3.8.2)
rubygem-rspec-expectations (3.8.3 -> 3.8.4)
rubygem-rspec-mocks (3.8.0 -> 3.8.1)
rubygem-rspec-support (3.8.0 -> 3.8.2)
thunar (1.8.7 -> 1.8.8)
transactional-update (2.14.2 -> 2.15)
webkit2gtk3
zbar (0.22 -> 0.23)

=== Details ===

==== Mesa ====
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- n_drirc-disable-rgb10-for-chromium-on-amd.patch
* added totem as another affected application (boo#1142270)
- Add v3d support (VC5/V6 driver) for %arm and aarch64
- Add kmsro for %arm and aarch64

==== Mesa-drivers ====
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- n_drirc-disable-rgb10-for-chromium-on-amd.patch
* added totem as another affected application (boo#1142270)
- Add v3d support (VC5/V6 driver) for %arm and aarch64
- Add kmsro for %arm and aarch64

==== MozillaFirefox ====
Version update (67.0.4 -> 68.0.1)
Subpackages: MozillaFirefox-translations-common

- Mozilla Firefox 68.0.1
* Fixed missing Full Screen button when watching videos in full
screen mode on HBO GO (bmo#1562837)
* Fixed a bug causing incorrect messages to appear for some
locales when sites try to request the use of the Storage
Access API (bmo#1558503)
* Users in Russian regions may have their default search engine
changed (bmo#1565315)
* Built-in search engines in some locales do not function
correctly (bmo#1565779)
* SupportMenu policy doesn't always work (bmo#1553290)
* Allow the privacy.file_unique_origin pref to be controlled by
policy (bmo#1563759)
- add fix-build-after-y2038-changes-in-glibc.patch
- Generate langpacks sequentially to avoid file corruption
from racy file writes (boo#1137970)
- Mozilla Firefox 68.0
* Dark mode in reader view
* Improved extension security and discovery
* Cryptomining and fingerprinting protections are added to strict
content blocking settings in Privacy & Security preferences
* Camera and microphone access now require an HTTPS connection
MFSA 2019-21 (bsc#1140868)
* CVE-2019-9811 (bmo#1538007, bmo#1539598, bmo#1563327)
Sandbox escape via installation of malicious languagepack
* CVE-2019-11711 (bmo#1552541)
Script injection within domain through inner window reuse
* CVE-2019-11712 (bmo#1543804)
Cross-origin POST requests can be made with NPAPI plugins by
following 308 redirects
* CVE-2019-11713 (bmo#1528481)
Use-after-free with HTTP/2 cached stream
* CVE-2019-11714 (bmo#1542593)
NeckoChild can trigger crash when accessed off of main thread
* CVE-2019-11729 (bmo#1515342)
Empty or malformed p256-ECDH public keys may trigger a segmentation fault
* CVE-2019-11715 (bmo#1555523)
HTML parsing error can contribute to content XSS
* CVE-2019-11716 (bmo#1552632)
globalThis not enumerable until accessed
* CVE-2019-11717 (bmo#1548306)
Caret character improperly escaped in origins
* CVE-2019-11718 (bmo#1408349)
Activity Stream writes unsanitized content to innerHTML
* CVE-2019-11719 (bmo#1540541)
Out-of-bounds read when importing curve25519 private key
* CVE-2019-11720 (bmo#1556230)
Character encoding XSS vulnerability
* CVE-2019-11721 (bmo#1256009)
Domain spoofing through unicode latin 'kra' character
* CVE-2019-11730 (bmo#1558299)
Same-origin policy treats all files in a directory as having the
same-origin
* CVE-2019-11723 (bmo#1528335)
Cookie leakage during add-on fetching across private browsing boundaries
* CVE-2019-11724 (bmo#1512511)
Retired site input.mozilla.org has remote troubleshooting permissions
* CVE-2019-11725 (bmo#1483510)
Websocket resources bypass safebrowsing protections
* CVE-2019-11727 (bmo#1552208)
PKCS#1 v1.5 signatures can be used for TLS 1.3
* CVE-2019-11728 (bmo#1552993)
Port scanning through Alt-Svc header
* CVE-2019-11710 (bmo#1549768, bmo#1548611, bmo#1533842, bmo#1537692,
bmo#1540590, bmo#1551907, bmo#1510345, bmo#1535482, bmo#1535848,
bmo#1547472, bmo#1547760, bmo#1507696, bmo#1544180)
Memory safety bugs fixed in Firefox 68
* CVE-2019-11709 (bmo#1547266, bmo#1540759, bmo#1548822, bmo#1550498
bmo#1515052, bmo#1539219, bmo#1547757, bmo#1550498, bmo#1533522)
Memory safety bugs fixed in Firefox 68 and Firefox ESR 60.8
- requires
* NSS 3.44.1
* rust/cargo 1.34
* rust-cbindgen 0.8.7
- rebased patches
* mozilla-aarch64-startup-crash.patch
* mozilla-kde.patch
* mozilla-nongnome-proxies.patch
* firefox-kde.patch
- use new create-tar.sh and add tar_stamps for package definitions
- added patches imported from SLE flavour
* mozilla-gcc-internal-compiler-error.patch
* mozilla-bmo1005535.patch
* mozilla-ppc-altivec_static_inline.patch
* mozilla-reduce-rust-debuginfo.patch
* mozilla-s390-bigendian.patch
* mozilla-s390-context.patch
- Enable PGO for x86_64.
* added firefox-add-kde.js-in-order-to-survive-PGO-build.patch

==== blueberry ====
Version update (1.2.5 -> 1.2.8)
Subpackages: blueberry-lang

- Update to version 1.2.8
* Don't spin spinner in devices tab (#85)
- Update to version 1.2.7
* Update translations
- 1.2.6 changes
* Fix generate_desktop_files
* Convert everything to use Python 3 (#66)
* Add paired submenu for quick connect/disconnect (#69)
* Tray: Use a tick image to represent connected device
* l10n: Update POT
* Tray: Fix paired menu when no devices are paired
* Use shell launchers and use setproctitle to name the python processes
* rfkill: Show error message on permission denied (#83)
* rfkill: Show the error message in the UI
* l10n: Update POT
- Updated and cleaned up spec file
- Rebased blueberry-fix-rfkill-path.patch

==== diffutils ====
Subpackages: diffutils-lang

- ignore make check error for diff --color as tracked by
https://debbugs.gnu.org/cgi/bugreport.cgi?bug=36488

==== dleyna-core ====

- Fixup RPM category groups. Avoid em dashes in summaries.

==== dleyna-server ====

- Fixup RPM category groups.
- Use noun phrase in summaries. Avoid em dashes in summaries.

==== dnsmasq ====

- add 0001-fix-build-after-y2038-changes-in-glibc.patch

==== gnome-software ====
Version update (3.32.3 -> 3.32.4)
Subpackages: gnome-software-lang

- Update to version 3.32.4:
+ Fix an issue that led to some packages with multiple appdata
files not correctly showing up on the updates page.
+ Fix various problems with flatpak branch handling that were
causing issues with freedesktop.org runtime updates.
+ Fix flatpak update versions to correctly show up.
+ Various other minor bug fixes.
- Drop pkgconfig(valgrind) BuildRequires, and pass valgrind=false
to meson. Fixes build for arm, and we do not really need valgrind
integration.

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Revert grub2-ieee1275-FCP-methods-for-WWPN-and-LUNs.patch until merged by
upstream (bsc#1134287, bsc#1139345, LTC#177836, LTC#174229).

==== guile ====
Version update (2.2.5 -> 2.2.6)
Subpackages: guile-modules-2_2 libguile-2_2-1

- Update to version 2.2.6
Changes compared to 2.2.5:
* Fix regression introduced in 2.2.5 that would break HTTP servers
* 'strftime' and 'strptime' honor the current locale encoding
* Re-export 'current-load-port'
* Minor documentation mistakes were fixed
- remove patches:
* revert-http-reader-change.patch: fix included in release

==== hwinfo ====
Version update (21.66 -> 21.67)

- merge gh#openSUSE/hwinfo#81
- fix DASD detection (bsc#1136475)
- don't include bcache devices
- 21.67

==== hylafax+ ====
Version update (5.6.1 -> 7.0.0)
Subpackages: hylafax+-client

- Version 7.0.0
* add LDAP features for compatibility with ActiveDirectory (25 Mar-1 Apr 2019)
* fix recovery after SSL Fax "accept failure" (18 Mar 2019)
* add TextFormat overstrike option and disable by default (6 Feb 2019)
* fix the page size of cover sheets returned via notify (8 Jan 2019)
* fix or silence numerous compiler warnings (19, 22, 28 Dec 2018)
* fix pagehandling updating after a proxy has been used (7-8 Dec 2018)
* add faxmail stderr output of RFC2047 decoding results (5 Dec 2018)
* fix faxmail handling of headers encoded with UTF-8 (4 Dec 2018)
* fix faxmail handling of base64-encoded text parts (4 Dec 2018)
* add SSL Fax support (9-26, 29 Nov; 11, 18, 25 Dec 2018; 2, 7, 23 Jan 2019)

==== kernel-source ====
Version update (5.1.16 -> 5.2.1)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms kernel-vanilla

- Linux 5.2.1 (bnc#1012628).
- staging: rtl8712: reduce stack usage, again (bnc#1012628).
- staging: bcm2835-camera: Handle empty EOS buffers whilst
streaming (bnc#1012628).
- staging: bcm2835-camera: Remove check of the number of buffers
supplied (bnc#1012628).
- staging: bcm2835-camera: Ensure all buffers are returned on
disable (bnc#1012628).
- staging: bcm2835-camera: Replace spinlock protecting context_map
with mutex (bnc#1012628).
- staging: fsl-dpaa2/ethsw: fix memory leak of switchdev_work
(bnc#1012628).
- staging: vchiq: revert "switch to wait_for_completion_killable"
(bnc#1012628).
- staging: vchiq: make wait events interruptible (bnc#1012628).
- staging: vchiq_2835_arm: revert "quit using custom
down_interruptible()" (bnc#1012628).
- VMCI: Fix integer overflow in VMCI handle arrays (bnc#1012628).
- Revert "x86/build: Move _etext to actual end of .text"
(bnc#1012628).
- carl9170: fix misuse of device driver API (bnc#1012628).
- coresight: tmc-etf: Do not call smp_processor_id from
preemptible (bnc#1012628).
- coresight: tmc-etr: alloc_perf_buf: Do not call smp_processor_id
from preemptible (bnc#1012628).
- coresight: tmc-etr: Do not call smp_processor_id() from
preemptible (bnc#1012628).
- coresight: etb10: Do not call smp_processor_id from preemptible
(bnc#1012628).
- coresight: Potential uninitialized variable in probe()
(bnc#1012628).
- iio: adc: stm32-adc: add missing vdda-supply (bnc#1012628).
- binder: return errors from buffer copy functions (bnc#1012628).
- binder: fix memory leak in error path (bnc#1012628).
- lkdtm: support llvm-objcopy (bnc#1012628).
- HID: Add another Primax PIXART OEM mouse quirk (bnc#1012628).
- staging: mt7621-pci: fix PCIE_FTS_NUM_LO macro (bnc#1012628).
- staging: comedi: amplc_pci230: fix null pointer deref on
interrupt (bnc#1012628).
- staging: bcm2835-camera: Restore return behavior of
ctrl_set_bitrate() (bnc#1012628).
- staging: wilc1000: fix error path cleanup in
wilc_wlan_initialize() (bnc#1012628).
- staging: comedi: dt282x: fix a null pointer deref on interrupt
(bnc#1012628).
- p54: fix crash during initialization (bnc#1012628).
- drivers/usb/typec/tps6598x.c: fix 4CC cmd write (bnc#1012628).
- drivers/usb/typec/tps6598x.c: fix portinfo width (bnc#1012628).
- usb: renesas_usbhs: add a workaround for a race condition of
workqueue (bnc#1012628).
- usb: dwc2: use a longer AHB idle timeout in dwc2_core_reset()
(bnc#1012628).
- usb: gadget: ether: Fix race between gether_disconnect and
rx_submit (bnc#1012628).
- usb: gadget: f_fs: data_len used before properly set
(bnc#1012628).
- p54usb: Fix race between disconnect and firmware loading
(bnc#1012628).
- Revert "serial: 8250: Don't service RX FIFO if interrupts are
disabled" (bnc#1012628).
- USB: serial: option: add support for GosunCn ME3630 RNDIS mode
(bnc#1012628).
- USB: serial: ftdi_sio: add ID for isodebug v1 (bnc#1012628).
- mwifiex: Don't abort on small, spec-compliant vendor IEs
(bnc#1012628).
- Documentation/admin: Remove the vsyscall=native documentation
(bnc#1012628).
- Documentation: Add section about CPU vulnerabilities for Spectre
(bnc#1012628).
- x86/tls: Fix possible spectre-v1 in do_get_thread_area()
(bnc#1012628).
- x86/ptrace: Fix possible spectre-v1 in ptrace_get_debugreg()
(bnc#1012628).
- perf header: Assign proper ff->ph in
perf_event__synthesize_features() (bnc#1012628).
- perf thread-stack: Fix thread stack return from kernel for
kernel-only case (bnc#1012628).
- perf pmu: Fix uncore PMU alias list for ARM64 (bnc#1012628).
- perf intel-pt: Fix itrace defaults for perf script intel-pt
documentation (bnc#1012628).
- perf auxtrace: Fix itrace defaults for perf script
(bnc#1012628).
- perf intel-pt: Fix itrace defaults for perf script
(bnc#1012628).
- block, bfq: NULL out the bic when it's no longer valid
(bnc#1012628).
- block: fix .bi_size overflow (bnc#1012628).
- tpm: Fix TPM 1.2 Shutdown sequence to prevent future TPM
operations (bnc#1012628).
- tpm: Actually fail on TPM errors during "get random"
(bnc#1012628).
- ALSA: hda/realtek - Headphone Mic can't record after S3
(bnc#1012628).
- ALSA: usb-audio: Fix parse of UAC2 Extension Units
(bnc#1012628).
- media: stv0297: fix frequency range limit (bnc#1012628).
- udf: Fix incorrect final NOT_ALLOCATED (hole) extent length
(bnc#1012628).
- fscrypt: don't set policy for a dead directory (bnc#1012628).
- crypto: talitos - rename alternative AEAD algos (bnc#1012628).
- crypto: lrw - use correct alignmask (bnc#1012628).
- commit 51ca500
- net: bpfilter: print umh messages to /dev/kmsg (bsc#1140221).
- commit 139acc9
- series.conf: sync with master
- commit 80522d2
- rpm/kernel-binary.spec.in: handle modules.builtin.modinfo
It was added in 5.2.
- commit eb88df3
- Disable CONFIG_OVERLAY_FS_REDIRECT_ALWAYS_FOLLOW in config (bsc#1140494)
- commit 8d950e4
- Delete patches.suse/Revert-ovl-detect-overlapping-layers.patch.
- Delete
patches.suse/Revert-ovl-don-t-fail-with-disconnected-lower-NFS.patch.
- Delete
patches.suse/Revert-ovl-fix-bogus-Wmaybe-unitialized-warning.patch.
transactional-update was fixed, see sr#714110.
- commit 927afc9
- Update to 5.2 final
- Eliminated 1 patch
- commit b36439f
- Refresh tpm: tpm_ibm_vtpm: Fix unallocated banks (boo#1139244).
- commit 99f9469
- config: align CONFIG_PHYSICAL_START and CONFIG_PHYSICAL_ALIGN to default
values
As suggested in bsc#1067593, our kconfig keeps the old default values
while the upstream took different (actually swapped) values for x86
CONFIG_PHYSICAL_START and CONFIG_PHYSICAL_ALIGN. Let's follow the
upstream default now.
- commit baa2434
- Rename
patches.suse/[PATCH]_tpm:_fixes_uninitialized_allocated_banks_for_IBM_vtpm_driver
to
patches.suse/tpm-fixes-uninitialized-allocated-banks-for-IBM-vtpm-driver.patch
Let's not risk some tool somewhere does not handle special characters
correctly.
- commit 8a3fff9
- tpm: fixes uninitialized allocated banks for IBM vtpm driver
(boo#1139244).
- Delete
patches.suse/Revert-tpm-pass-an-array-of-tpm_extend_digest-struct.patch.
- commit 43ec0a5

==== krita ====
Version update (4.2.2 -> 4.2.3)
Subpackages: krita-lang

- Update to 4.2.3:
* See https://krita.org/en/item/krita-4-2-3-released/
* Fix the caption of the Background Color color selection dialog
(kde#407658)
* Fix the tag selector combobox so it is possible to select
resources that have a tag that's longer than fits in the
combobox (kde#408053)
* Make it possible for the Krita startup window to become as
narrow as before adding the news widget (kde#408504)
* Fix copy/pasting of animation frames (kde#408421, kde#404595)
* Make the polygon and outline selection tool handle the control
modifier correctly (kde#376007)
* Add a reload script button to the Python scripter plugin
* Fix a crash in the Overview docker when there is no image open
* Fix drag and drop of fill layers between opened files
(kde#408019)
* Fix loading EXR files that have more than one layer with the
same name (kde#409552)
* Hide vanishing points preview lines when assistants are hidden
(kde#396158)
* Fix the Mirror All Layers Horizontally function
* Fix switching profile to default when changing channel depth in
the New Image dialog (kde#406700)
* Disable AVG optimizations for some 32 bit blending modes
(kde#404133)
* Fix a crash when pressing cancel when trying to create an 8
bit/channel linear gamma RGB image
* Make sure Stroke Selection paint correctly with the selection
border in the middle of the selection (kde#409254)
* Fix saving Krita when perspective assistants are present
(kde#409249)
* Fix issues with transformations being pixelated (kde#409280)
* Make it possible to hide all layers except the selected one
with shift-click (kde#376086)
* Fix cloning keyframe channels that are not opacity channels
* Fix a hang when trying to paint while playing an animation of
an empty image (kde#408749)
* Fix Isolated Mode when multiple windows are open (kde#408150)
* Make the gradient editor show the right editor for stop and
segmented gradients (but creating new gradients in Krita is
still broken)
* Fix a freeze when pressing delete when making a polygonal
selection (kde#408843)
* Fix the ?export commandline option to return 0 when the export
is successful (kde#409133)
* Fix support for the KDE Plasma global menu (kde#408015)
* Fix a crash when using the shrink option of the deform brush
(kde#408887)

==== libcontainers-common ====

- Update to libpod v1.4.4
- Fixed a bug where rootless Podman would attempt to use the
entire root configuration if no rootless configuration was
present for the user, breaking rootless Podman for new
installations
- Fixed a bug where rootless Podman's pause process would block
SIGTERM, preventing graceful system shutdown and hanging until
the system's init send SIGKILL
- Fixed a bug where running Podman as root with sudo -E would not
work after running rootless Podman at least once
- Fixed a bug where options for tmpfs volumes added with the
- -tmpfs flag were being ignored
- Fixed a bug where images with no layers could not properly be
displayed and removed by Podman
- Fixed a bug where locks were not properly freed on failure to
create a container or pod
- Podman now has greatly improved support for containers using
multiple OCI runtimes. Containers now remember if they were
created with a different runtime using --runtime and will
always use that runtime
- The cached and delegated options for volume mounts are now
allowed for Docker compatability (#3340)
- The podman diff command now supports the --latest flag
- Fixed a bug where podman cp on a single file would create a
directory at the target and place the file in it (#3384)
- Fixed a bug where podman inspect --format '{{.Mounts}}' would
print a hexadecimal address instead of a container's mounts
- Fixed a bug where rootless Podman would not add an entry to
container's /etc/hosts files for their own hostname (#3405)
- Fixed a bug where podman ps --sync would segfault (#3411)
- Fixed a bug where podman generate kube would produce an invalid
ports configuration (#3408)
- Podman now performs much better on systems with heavy I/O load
- The --cgroup-manager flag to podman now shows the correct
default setting in help if the default was overridden by
libpod.conf
- For backwards compatability, setting --log-driver=json-file in
podman run is now supported as an alias for
- -log-driver=k8s-file. This is considered deprecated, and
json-file will be moved to a new implementation in the future
([#3363](https://github.com/containers/libpod/issues/3363))
- Podman's default libpod.conf file now allows the crun OCI
runtime to be used if it is installed
- Fixed a bug where Podman could not run containers using an
older version of Systemd as init (#3295)
- Updated vendored Buildah to v1.9.0 to resolve a critical bug
with Dockerfile RUN instructions
- The error message for running podman kill on containers that
are not running has been improved
- The Podman remote client can now log to a file if syslog is not
available
- The MacOS dmg file is experimental, use at your own risk.
- The podman exec command now sets its error code differently
based on whether the container does not exist, and the command
in the container does not exist
- The podman inspect command on containers now outputs Mounts
JSON that matches that of docker inspect, only including
user-specified volumes and differentiating bind mounts and
named volumes
- The podman inspect command now reports the path to a
container's OCI spec with the OCIConfigPath key (only included
when the container is initialized or running)
- The podman run --mount command now supports the
bind-nonrecursive option for bind mounts (#3314)
- Fixed a bug where podman play kube would fail to create
containers due to an unspecified log driver
- Fixed a bug where Podman would fail to build with musl libc
(#3284)
- Fixed a bug where rootless Podman using slirp4netns networking
in an environment with no nameservers on the host other than
localhost would result in nonfunctional networking (#3277)
- Fixed a bug where podman import would not properly set
environment variables, discarding their values and retaining
only keys
- Fixed a bug where Podman would fail to run when built with
Apparmor support but run on systems without the Apparmor kernel
module loaded (#3331)
- Remote Podman will now default the username it uses to log in
to remote systems to the username of the current user
- Podman now uses JSON logging with OCI runtimes that support it,
allowing for better error reporting
- Updated vendored Buildah to v1.8.4
- Updated vendored containers/image to v2.0
- Update to image v2.0.0
- Add registry mirror support
- Include missing man pages (bsc#1139526)
- Update to storage v1.12.10
- Add support for UID as well as UserName in /etc/subuid files.
- utils: fix check for missing conf file
- compression: add support for the zstd algorithm
- overlay: cache the results of
supported/using-metacopy/use-naive-diff feature tests

==== libgphoto2 ====
Version update (2.5.22 -> 2.5.23)
Subpackages: libgphoto2-6 libgphoto2-6-lang

- updated to 2.5.23 release
- ptp2:
* Sony capture stability and speed improvements
* Canon EOS capture stability improvements, reduce partial read blobs from
5MB to 1MB
* Canon EOS M image format unpacking adjustments
* Olympus OMD: bulb capture added, trigger capture capable
* Panasonic GH5: added manualfocusdrive, capturetarget
* Canon PowerShot X work ... trying to support / improve stability of capture
* PTP string packing adjusted to standard (empty and null strings)
* New ids added:
* Sony Alpha A68, RX100M6, DSC-WX350
* Nikon Coolpix L100
* Canon PowerShot G7X, G9X Mark II
* Canon Rebel T6, EOS 2000D
* Fuji X-A2, GFX 50R, XT-30
* Ricoh WG-M2
* libmtp ids synced.
- pentax:
* synced smaller parts with pktriggercord
- translations:
* updated danish
- fuzzing:
* vusb and sample-afl now able to fuzz all USB cameras (even if slow)
- all:
* Various crashes fixed that were found during AFL fuzzing the USB drivers

==== libkdepim ====
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Use kf5_debugdir macro for specifying the logging categories location

==== libkgapi ====
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Use kf5_debugdir macro for specifying the logging categories location

==== libkleo ====
Subpackages: libKF5Libkleo5 libkleo-lang

- Use kf5_debugdir macro for specifying the logging categories location

==== libqt5-qtwebengine ====

- Increase assumed per-job memory use to 2.5GB
- add 0001-fix-build-after-y2038-changes-in-glibc.patch

==== libuv ====
Version update (1.27.0 -> 1.30.1)

- Upgrade to 1.30.1:
* doc: fix incorrect versionchanged (cjihrig)
* test: allow UV_ECONNRESET in tcp_try_write_error (cjihrig)
* unix: add uv_get_constrained_memory() cygwin stub (cjihrig)
* build: fix android cmake build (Ben Noordhuis)
* unix: squelch -Wcast-function-type warning (Ben Noordhuis)
* build: fix compile error with uClibc (zlargon)* darwin: fall
back to F_BARRIERFSYNC (Ben Noordhuis)
* darwin: add 32 bit close$NOCANCEL implementation
(ken-cunningham-webuse)
* build, core, unix: add support for Haiku (Leorize)
* darwin,linux: more conservative minimum stack size (Ben Noordhuis)
* threadpool: increase UV_THREADPOOL_SIZE limit (Vlad A)
* unix: return actual error from `uv_try_write()` (Anna Henningsen)
* darwin: fix build error with macos 10.10 (Ben Noordhuis)
* unix: make uv_cwd() report UV_ENOBUFS (Ben Noordhuis)
* unix: make uv_fs_read() fill all buffers (Ben Noordhuis)
* test: give hrtime test a custom 10s timeout (Ben Noordhuis)
* fs: fix uv_fs_copyfile if same src and dst (Santiago Gimeno)
* build: add cmake option to skip building tests (Niels Lohmann)
* doc: add link to nodejs.org (Jenil Christo)
* unix: fix a comment typo in signal.c (Evgeny Ermakov)
* unix: remove redundant cast in process.c (gengjiawen)
* doc: fix wrong mutex function prototypes (Leo Chung)
* unix: simplify uv/posix.h include logic (cjihrig)
* test: increase test timeout (cjihrig)
* linux: fix sscanf() overflows reading from /proc (Ben Noordhuis)
* ibmi: read memory and CPU usage info (Xu Meng)
* doc: update the cmake testing instruction (zlargon)
* unix: fix race condition in uv_async_send() (Ben Noordhuis)
* linux: use O_CLOEXEC instead of EPOLL_CLOEXEC (Ben Noordhuis)
* doc: mark uv_async_send() as async-signal-safe (Ben Noordhuis)
* linux: init st_flags and st_gen when using statx (Oscar Waddell)
* linux: read free/total memory from /proc/meminfo (Ben Noordhuis)
* test: test zero-sized uv_fs_sendfile() writes (Ben Noordhuis)
* unix: don't assert on UV_PROCESS_WINDOWS_* flags (Ben Noordhuis)
* linux: set correct mac address for IP-aliases (Santiago Gimeno)
* win,util: fix null pointer dereferencing (Tobias Nie├čen)
* unix,win: fix `uv_fs_poll_stop()` when active (Anna Henningsen)
* doc: add missing uv_fs_type entries (Michele Caini)
* doc: fix build with sphinx 2.x (FX Coudert)
* unix: don't make statx system call on Android (George Zhao)
* unix: fix clang scan-build warning (Kyle Edwards)
* unix: fall back to kqueue on older macOS systems (ken-cunningham-webuse)
* unix,win: add uv_get_constrained_memory() (Kelvin Jin)
* darwin: fix thread cancellation fd leak (Ben Noordhuis)
* linux: fix thread cancellation fd leak (Ben Noordhuis)
* unix,win: add uv_gettimeofday() (cjihrig)
* unix,win: add uv_fs_{open,read,close}dir() (cjihrig)
* unix: fix uv_interface_addresses() (Andreas Rohner)
* fs: remove macOS-specific copyfile(3) (Rich Trott)
* fs: add test for copyfile() respecting permissions (Rich Trott)
* build: partially revert 5234b1c (Ben Noordhuis)
* zos: fix setsockopt error when using AF_UNIX (Milad Farazmand)
* unix: suppress EINTR/EINPROGRESS in uv_fs_close() (Ben Noordhuis)
* build: use cmake APPLE variable to detect platform (zlargon)
* distcheck: remove duplicate test/ entry (Jameson Nash)
* unix: remove unused cmpxchgl() function (Ben Noordhuis)
* unix: support sockaddr_un in uv_udp_send() (Yury Selivanov)
* unix: guard use of PTHREAD_STACK_MIN (Kamil Rytarowski)
* unix,win: introduce uv_timeval64_t (cjihrig)
* doc: document uv_timeval_t and uv_timeval64_t (cjihrig)

==== libva ====
Version update (2.4.0 -> 2.4.1)
Subpackages: libva-drm2 libva-x11-2 libva2

- Update to version 2.4.1:
* [common] Add A2RGB10 fourcc definition.
* build: meson: enables va messaging and visibility.
* va/va_trace:
- Add trace support for RIR(rolling intra refresh).
- Add trace support for ROI(region of interest).

==== libva-gl ====
Version update (2.4.0 -> 2.4.1)
Subpackages: libva-glx2 libva-wayland2

- Update to version 2.4.1:
* [common] Add A2RGB10 fourcc definition.
* build: meson: enables va messaging and visibility.
* va/va_trace:
- Add trace support for RIR(rolling intra refresh).
- Add trace support for ROI(region of interest).

==== linux-atm ====

- add fix-build-after-y2038-changes-in-glibc.patch

==== mozilla-nss ====
Version update (3.43 -> 3.44.1)
Subpackages: libfreebl3 libsoftokn3 mozilla-nss-certs mozilla-nss-tools

- update to NSS 3.44.1
* required by Firefox 68.0
Bugs fixed
* bmo#1554336 - Optimize away unneeded loop in mpi.c
* bmo#1515342 - More thorough input checking
* bmo#1540541 - Don't unnecessarily strip leading 0's from key material
during PKCS11 import
* bmo#1515236 - Add a SSLKEYLOGFILE enable/disable flag at build.sh
* bmo#1546229 - Add IPSEC IKE support to softoken
* bmo#1473806 - Fix SECKEY_ConvertToPublicKey handling of non-RSA keys
* bmo#1546477 - Updates to testing for FIPS validation
* bmo#1552208 - Prohibit use of RSASSA-PKCS1-v1_5 algorithms in TLS 1.3
* bmo#1551041 - Unbreak build on GCC < 4.3 big-endian
- update to NSS 3.44
* required by Firefox 68.0
New functions
* CERT_GetCertificateDer - Access the DER-encoded form of a CERTCertificate
Notable changes
* It is now possible to build NSS as a static library (bmo#1543545)
* Initial support for building for iOS
Bugs fixed
* full list

https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_3.44_release_notes
- merge some baselibs fixes from SLE

==== netpbm ====
Subpackages: libnetpbm11

- signed-char.patch: fix bad use of plain char
- big-endian.patch: fix dependency on byte order

==== open-iscsi ====
Subpackages: iscsiuio libopeniscsiusr0_2_0

- Ensure /etc/iscsi/initiatorname.iscsi has reproducible size
works around https://github.com/rpm-software-management/rpm/pull/229,
updating the SPEC file

==== parted ====
Subpackages: libparted0 parted-lang

- port fixes for various bugs from upstream (bsc#1136245)
- add: libparted-dasd-correct-the-offset-where-the-first-pa.patch
4126d02, correct the offset where the first partition begins.
This patch implements libparted-dasd-do-not-use-first-tracks.patch
- remove: libparted-dasd-do-not-use-first-tracks.patch
- add: parted-fix-crash-due-to-improper-partition-number-in.patch
149f009, fix crash due to improper partition number input,
changed call to strtol, use base 0 to fit our parted-type.patch
- modify: parted-type.patch (removed ui.c part)
- add: parted-check-the-name-of-partition-first-when-to-nam.patch
d7a2ff1, check the name of partition first when to name a partition
- add: libparted-dasd-add-test-cases-for-the-new-fdasd-func.patch
c11f5c0, 571e078, add test cases for the new fdasd functions
- add: libparted-dasd-add-an-exception-for-changing-DASD-LD.patch
ee2c0c2, add an exception for changing DASD-LDL partition table
- add: libpartd-dasd-improve-flag-processing-for-DASD-LDL.patch
1545d6d, improve flag processing for DASD-LDL
- add: clean-the-disk-information-when-commands-fail-in-int.patch
5a61f15, clean the disk information when commands fail in
interactive mode
- add: parted-ui-remove-unneccesary-information-of-command.patch
0b7946a, remove unneccesary information of command line
- add: parted-fix-wrong-error-label-jump-in-mkpart.patch
af150f6, fix wrong error label jump in mkpart
- refresh: libparted-dasd-unify-vtoc-handling-for-cdl-ldl.patch
4f25d54, unify vtoc handling for cdl/ldl
- refresh: libparted-dasd-update-and-improve-fdasd-functions.patch
db37c8c, update and improve fdasd functions
- refresh: libparted-dasd-add-new-fdasd-functions.patch
b9e1281, add new fdasd functions

==== perl-AnyEvent ====
Version update (7.15 -> 7.16)

- updated to 7.16
see /usr/share/doc/packages/perl-AnyEvent/Changes

==== perl-BerkeleyDB ====
Version update (0.61 -> 0.63)

- updated to 0.63
see /usr/share/doc/packages/perl-BerkeleyDB/Changes
0.63 21 July 2019
* added 000preret.t
Dump version info in "make test"
9e17580d74662b6a3186990dd3b1469df2829503
- updated to 0.62
see /usr/share/doc/packages/perl-BerkeleyDB/Changes
0.62 20 July 2019
* default to /usr/local/BerkeleyDB
fcc0ad8adf310f7c8cc65788806439f2f8c39f90
* __heap_exist prototype needed for db 5.2 or better
7fe4ad8d74190d7f41a816c79e5ccf044c02c7c9
* t/joint.: Silence Valgrinf
https://rt.cpan.org/Ticket/Display.html?id=125605
40d03924570f8516efe4a05982f402e8ce569637
* db_remove missing txn code
https://rt.cpan.org/Ticket/Display.html?id=124979
b91875a9f3f55bb779ad7a448c9fff0645d8a527
* Fix test failure when TRACE is enabled
bb80b7d0fb83643ccddd8243d4c6b6ab637428df
* Added BERKELEYDB_DEFINE_TRACE variable to allow TRACE to be enabled
from .travis file.
bd9ebf5aa149172afab55d6ba6f27d77cf08d91a
* Add test with BERKELEYDB_DEFINE_TRACE set to .travis
000b1d8dffe542d6476fe78f218cc95534f1c1c3
* my_db_strerror: Add missing dTHX declaration
Merge pull request https://github.com/pmqs/BerkeleyDB/pull/2
4273345d8eff5f521788b3c5e71fb291bf46a646
80ca9b77968ab84aaf8b546f2933d135202e16e0
* create .appveyor.yml
4e7b034ddbe76a7c2dcd189e1e0c935c1559aa2c
* sync dbinfo from DB_File
27b499fa9dbfca78adcc7a12ada43f0b05b6ece6

==== perl-ExtUtils-F77 ====
Version update (1.23 -> 1.24)

- updated to 1.24
see /usr/share/doc/packages/perl-ExtUtils-F77/CHANGES
v1.24 released Jul 21st 2019
- --------------------------
* Fix of library order of -lgfortran and -lquadmath which effected MS Windows

==== pesign ====

- Add pesign-efikeygen-Fix-the-build-with-nss-3.44.patch to fix
the compilation error when building with NSS 3.44

==== rubygem-airbrussh ====
Version update (1.3.1 -> 1.3.2)

- updated to version 1.3.2
see installed CHANGELOG.md
[#]# [1.3.2][] (2019-06-15)
* [#121](https://github.com/mattbrictson/airbrussh/pull/121): Gracefully
handle SSH output that has invalid UTF-8 encoding instead of raising an
exception - [@mattbrictson](https://github.com/mattbrictson)

==== rubygem-bundler ====
Version update (2.0.1 -> 2.0.2)

- updated to version 2.0.2
see installed CHANGELOG.md
[#]# 2.0.2 (2019-05-13)
Changes:
- Fixes for Bundler integration with ruby-src
([#6941](https://github.com/bundler/bundler/pull/6941),
[#6973](https://github.com/bundler/bundler/pull/6973),
[#6977](https://github.com/bundler/bundler/pull/6977),
[#6315](https://github.com/bundler/bundler/pull/6315),
[#7061](https://github.com/bundler/bundler/pull/7061))
- Use `__dir__` instead of `__FILE__` when generating a gem with `bundle gem`
([#6503](https://github.com/bundler/bundler/pull/6503))
- Use `https` on externals links in the Bundler gemspec
([#6721](https://github.com/bundler/bundler/pull/6721))
- Removed duplicate gem names from the suggested `did you mean` list for gem
typos ([#6739](https://github.com/bundler/bundler/pull/6739))
- Removed Ruby 1.x compatibility code
([#6764](https://github.com/bundler/bundler/pull/6764),
[#6806](https://github.com/bundler/bundler/pull/6806))
- Fixed an issue where `bundle remove` would crash with certain Gemfiles
([#6768](https://github.com/bundler/bundler/pull/6769))
- Fixed indentation in the Bundler executable template
([#6773](https://github.com/bundler/bundler/pull/6773))
- Fixed an issue where plugins could register for the same Bundler hook
multiple times ([#6775](https://github.com/bundler/bundler/pull/6775))
- Changed the "multiple sources" message in `bundle install` to be a warning
instead of an error ([#6790](https://github.com/bundler/bundler/pull/6790))
- Fixed a bug where path gems would break when using
`only_update_to_newer_versions`
([#6774](https://github.com/bundler/bundler/pull/6774))
- Fixed a bug where installing plugins with the `--delpoyment` setting would
fail ([#6805](https://github.com/bundler/bundler/pull/6805))
- Fixed an issue where `bundle update` couldn't update & install a gem when
`no_install` was set (a `bundle package` config)
([#7078](https://github.com/bundler/bundler/pull/7078))
- Fixed an issue where users could not run `bundle exec` on default gems
([#6963](https://github.com/bundler/bundler/pull/6963))
- Updated vendor libraries to their latest version
([#7076](https://github.com/bundler/bundler/pull/7067),
[#7068](https://github.com/bundler/bundler/pull/7068))
- Fixed an issue where the `github` source was not using `https` by default
that we mentioned in the 2.0 release
([#7182](https://github.com/bundler/bundler/pull/7182))
- Fixed an issue where `rake release` was not outputting the message to users
asking for a 2fa token ([#7199](https://github.com/bundler/bundler/pull/7199))
Documentation:
- Fix incorrect documented `BUNDLE_PATH_RELATIVE_TO_CWD` env var
([#6751](https://github.com/bundler/bundler/pull/6751))
- Update URLs in Bundler's documentation to use `https`
([#6935](https://github.com/bundler/bundler/pull/6935))

==== rubygem-cfa ====
Version update (1.0.0 -> 1.0.1)

- fix writting subtree when element change to collection and vice
versa (bsc#1132362)
- 1.0.1

==== rubygem-childprocess ====
Version update (1.0.1 -> 2.0.0)

- updated to version 2.0.0
see installed CHANGELOG.md
[#]## Version 2.0.0 / 2019-07-11
* [#148](https://github.com/enkessler/childprocess/pull/148): Drop support
for Ruby 2.0, 2.1, and 2.2
* [#149](https://github.com/enkessler/childprocess/pull/149): Fix Unix fork
reopen to be compatible with Ruby 2.6
*
[#152](https://github.com/enkessler/childprocess/pull/152)/[#154](https://github.com/enkessler/childprocess/pull/154):
Fix hangs and permission errors introduced in Ruby 2.6 for leader processes of
process groups

==== rubygem-cri ====
Version update (2.15.5 -> 2.15.9)

- updated to version 2.15.9
see installed NEWS.md
[#]# 2.15.9
Fixes:
* Fixed bug which could cause options from one command appear in other
commands (#101, #102)
[#]# 2.15.8
Fixes:
* Don?t explicitly set default values for options (#99)
This release reverts a backwards-incompatible change introduced in 2.15.7.
To illustrate this, compare the behavior of the following command in recent
versions of Cri:
```ruby
option :f, :force, 'use force', argument: :forbidden
run do |opts, args, cmd|
puts "Options = #{opts.inspect}"
puts "Force? #{opts[:force]}"
puts "Option given? #{opts.key?(:force)}"
end
```
In Cri 2.15.6, the default is not set in the options hash, so the value is
`nil` and `#key?` returns false:
```sh
% ./run
Options = {}
Force? nil
Option given? false
```
This behavior was inconsistent with what was documented: flag options were
(and still are) documented to default to `false` rather than `nil`.
In Cri 2.15.7, the default value is `false`, and explicitly set in the
options hash (`#key?` returns `true`):
```sh
% ./run
Options = {:force=>false}
Force? false
Option given? true
```
This change made it impossible to detect options that were not explicitly
specified, because the behavior of `#key?` also changed.
In Cri 2.15.8, the default value is also `false` (as in 2.15.7), but not
explicitly set in the options hash (`#key?` returns `false`, as in 2.15.6):
```sh
% ./run
Options = {}
Force? false
Option given? false
```
This backwards-incompatible change was not intentional. To fix issue #94, a
change in behavior was needed, but this change also affected other,
previously-undefined behavior. The new behavior in 2.15.8 should fix the bug
fixed in 2.15.7 (#94, #96), without causing the problems introduced in that
version.
[#]# 2.15.7
Fixes:
* Options with a forbidden argument now default to false, rather than nil
(#94, #96)
[#]# 2.15.6
Fixes:
* Fixed problem with help header not being shown if the summary is missing
(#93)

==== rubygem-delayed_job ====
Version update (4.1.5 -> 4.1.7)

- updated to version 4.1.7
see installed CHANGELOG.md
4.1.7 - 2019-06-20
=================
* Fix loading Delayed::PerformableMailer when ActionMailer isn't loaded yet
4.1.6 - 2019-06-19
=================
* Properly initialize ActionMailer outside railties (#1077)
* Fix Psych load_tags support (#1093)
* Replace REMOVED with FAILED in log message (#1048)
* Misc doc updates (#1052, #1074, #1064, #1063)

==== rubygem-docile ====
Version update (1.3.1 -> 1.3.2)

- updated to version 1.3.2
see installed HISTORY.md
- updated to version 1.3.1
see installed HISTORY.md

==== rubygem-domain_name ====
Version update (0.5.20180417 -> 0.5.20190701)

- updated to version 0.5.20190701
see installed CHANGELOG.md
[#]#
[v0.5.20190701](https://github.com/knu/ruby-domain_name/tree/v0.5.20190701)
(2019-07-05)
[Full
Changelog](https://github.com/knu/ruby-domain_name/compare/v0.5.20180417...v0.5.20190701)
- Update the eTLD database to 2019-07-01 18:45:50 UTC
[#]#
[v0.5.20180417](https://github.com/knu/ruby-domain_name/tree/v0.5.20180417)
(2018-04-17)
[Full
Changelog](https://github.com/knu/ruby-domain_name/compare/v0.5.20170404...v0.5.20180417)
- Update the eTLD database to 2018-04-17T23:50:25Z

==== rubygem-fluentd ====
Version update (1.4.2 -> 1.6.2)

- updated to version 1.6.2
see installed CHANGELOG.md
[#] v1.6
[#]# Release v1.6.2 - 2019/07/11
[#]## Bug fixes
* http_server helper: Add title argument to support multiple servers
https://github.com/fluent/fluentd/pull/2493
[#]# Release v1.6.1 - 2019/07/10
[#]## Enhancement
* socket/cert: Support all private keys OpenSSL supports, not only RSA.
https://github.com/fluent/fluentd/pull/2487
* output/buffer: Improve statistics method performance
https://github.com/fluent/fluentd/pull/2491
[#]## Bug fixes
* plugin_config_formatter: update new doc URL
https://github.com/fluent/fluentd/pull/2481
* out_forward: Avoid zero division error when there are no available nodes
https://github.com/fluent/fluentd/pull/2482
[#]# Release v1.6.0 - 2019/07/01
[#]## New feature
* plugin: Add http_server helper and in_monitor_agent use it
https://github.com/fluent/fluentd/pull/2447
[#]## Enhancement
* in_monitor_agent: Add more metrics for buffer/output
https://github.com/fluent/fluentd/pull/2450
* time/plugin: Add `EventTime#to_time` method for fast conversion
https://github.com/fluent/fluentd/pull/2469
* socket helper/out_forward: Add connect_timeout parameter
https://github.com/fluent/fluentd/pull/2467
* command: Add `--conf-encoding` option
https://github.com/fluent/fluentd/pull/2453
* parser_none: Small performance optimization
https://github.com/fluent/fluentd/pull/2455
[#]## Bug fixes
* cert: Fix cert match pattern
https://github.com/fluent/fluentd/pull/2466
* output: Fix forget to increment rollback count
https://github.com/fluent/fluentd/pull/2462
[#] v1.5
[#]# Release v1.5.2 - 2019/06/13
[#]## Bug fixes
* out_forward: Fix duplicated handshake bug in keepalive
https://github.com/fluent/fluentd/pull/2456
[#]# Release v1.5.1 - 2019/06/05
[#]## Enhancement
* in_tail: Increase read block size to reduce IO call
https://github.com/fluent/fluentd/pull/2418
* in_monitor_agent: Refactor code
https://github.com/fluent/fluentd/pull/2422
[#]## Bug fixes
* out_forward: Fix socket handling of keepalive
https://github.com/fluent/fluentd/pull/2434
* parser: Fix the use of name based timezone
https://github.com/fluent/fluentd/pull/2421
* in_monitor_agent: Fix debug parameter handling
https://github.com/fluent/fluentd/pull/2423
* command: Fix error handling of log rotation age option
https://github.com/fluent/fluentd/pull/2427
* command: Fix ERB warning for ruby 2.6 or later
https://github.com/fluent/fluentd/pull/2430
[#]# Release v1.5.0 - 2019/05/18
[#]## New feature
* out_forward: Support keepalive feature
https://github.com/fluent/fluentd/pull/2393
* in_http: Support TLS via server helper
https://github.com/fluent/fluentd/pull/2395
* in_syslog: Support TLS via server helper
https://github.com/fluent/fluentd/pull/2399
[#]## Enhancement
* in_syslog: Add delimiter parameter
https://github.com/fluent/fluentd/pull/2378
* in_forward: Add tag/add_tag_prefix parameters
https://github.com/fluent/fluentd/pull/2396
* parser_json: Add stream_buffer_size parameter for yajl
https://github.com/fluent/fluentd/pull/2381
* command: Add deprecated message to show-plugin-config option
https://github.com/fluent/fluentd/pull/2401
* storage_local: Ignore empty file. Call sync after write for XFS.
https://github.com/fluent/fluentd/pull/2409
[#]## Bug fixes
* out_forward: Don't use SO_LINGER on SSL/TLS WinSock
https://github.com/fluent/fluentd/pull/2398
* server helper: Fix recursive lock issue in TLSServer
https://github.com/fluent/fluentd/pull/2341
* Fix typo
https://github.com/fluent/fluentd/pull/2369

==== rubygem-get_process_mem ====
Version update (0.2.3 -> 0.2.4)

- updated to version 0.2.4
see installed CHANGELOG.md
[#]# 0.2.4
- Use FFI to speed up memory lookup on Mac (darwin) by roughly 12x (#32)

==== rubygem-rspec-core ====
Version update (3.8.0 -> 3.8.2)

- updated to version 3.8.2
[Full Changelog](http://github.com/rspec/rspec-core/compare/v3.8.1...v3.8.2)
Bug Fixes:
* Fix `config.define_derived_metadata` so that cascades are not triggered
until metadata has been assigned to the example or example group
(Myron Marston, #2635).
[#]## 3.8.1 / 2019-06-13
[Full Changelog](http://github.com/rspec/rspec-core/compare/v3.8.0...v3.8.1)
Bug Fixes:
* Handle RSpec description(s) with japanese chars in CP932 encoded files.
(Benoit Tigeot, #2575)
* When defining `let` methods that overwrite an existing method, prevent
a warning being issued by removing the old definition. (Jon Rowe, #2593)
* Prevent warning on Ruby 2.6.0-rc1 (Keiji Yoshimi, #2582)
* Fix `config.define_derived_metadata` so that it supports cascades.
(Myron Marston, #2630).

==== rubygem-rspec-expectations ====
Version update (3.8.3 -> 3.8.4)

- updated to version 3.8.4
[Full
Changelog](http://github.com/rspec/rspec-expectations/compare/v3.8.3...v3.8.4)
Bug Fixes:
* Prevent false negatives when checking objects for the methods required to
run the
the `be_an_instance_of` and `be_kind_of` matchers. (Nazar Matus, #1112)

==== rubygem-rspec-mocks ====
Version update (3.8.0 -> 3.8.1)

- updated to version 3.8.1
* no changelog entry found

==== rubygem-rspec-support ====
Version update (3.8.0 -> 3.8.2)

- updated to version 3.8.2
[Full
Changelog](http://github.com/rspec/rspec-support/compare/v3.8.1...v3.8.2)
Bug Fixes:
* Ensure that optional hash arguments are recognised correctly vs keyword
arguments. (Evgeni Dzhelyov, #366)
* Ensure that an empty hash is recognised as empty keyword arguments when
applicable. (Thomas Walpole, #375)
* Ensure that diffing truthy values produce diffs consistently.
(Lucas Nestor, #377)
[#]## 3.8.1 / 2019-03-03
[Full
Changelog](http://github.com/rspec/rspec-support/compare/v3.8.0...v3.8.1)
Bug Fixes:
* Ensure that inspecting a `SimpleDelegator` based object works regardless of
visibilty of the `__getobj__` method. (Jon Rowe, #369)

==== thunar ====
Version update (1.8.7 -> 1.8.8)
Subpackages: libthunarx-3-0 thunar-lang

- Update to version 1.8.8
* Do not register "send to" as last used app (bxo#14118)
* Use https where possible
* Dont restart the folder monitor on each refresh (bxo#13364)
* Fix XML declaratation in uca.xml (bxo#13623)
* Always show the executable checkbox (bxo#15605)
* Replace Trash action with Delete as needed (bxo#15352)
* Translation updates

==== transactional-update ====
Version update (2.14.2 -> 2.15)
Subpackages: transactional-update-zypp-config

- Update to version 2.15
- Move description of interactiveness [boo#1132438]
- Enable network during update [boo#1137890]
- Add compatibilty with new overlayfs versions [boo#1140057]
- Allow updates of the bootloader on EFI systems [boo#1139015]
- Add support for /boot/writable [boo#1138725]

==== webkit2gtk3 ====
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Drop webkit2gtk3-boo1088932-a11y-state-set.patch: fixed upstream.

==== zbar ====
Version update (0.22 -> 0.23)

- Update to version 0.23:
* Support for Gtk3 (backward support with Gtk2 will be maintained.
* Support for Python 3 (backward support with Python2 will be maintained);
* Support for ZBar Gtk GObject Introspection (GIR). That allows using ZBar
Gtk3 widgets on any language that it is compatible with GIR, including
python 2 and python 3.
- Switch from ImageMagick to GraphicsMagick, the latter has significantly
less build dependencies. As it is only used by the zbarimg tool to
load images, this does not affect users of the zbar library.
- Update URL tag to point to the current upstream location


< Previous Next >
Follow Ups