Mailinglist Archive: opensuse-factory (443 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190716 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Thu, 18 Jul 2019 05:23:13 +0000
  • Message-id: <156342739312.710.2405723742301727483@go-agent-stagingbot-5>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190716

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
MozillaThunderbird (60.7.2 -> 60.8.0)
akonadi-calendar (19.04.2 -> 19.04.3)
akonadi-calendar-tools (19.04.2 -> 19.04.3)
akonadi-contact (19.04.2 -> 19.04.3)
akonadi-import-wizard (19.04.2 -> 19.04.3)
akonadi-mime (19.04.2 -> 19.04.3)
akonadi-notes (19.04.2 -> 19.04.3)
akonadi-search (19.04.2 -> 19.04.3)
akonadi-server (19.04.2 -> 19.04.3)
akregator (19.04.2 -> 19.04.3)
ark (19.04.2 -> 19.04.3)
baloo5-widgets (19.04.2 -> 19.04.3)
calendarsupport (19.04.2 -> 19.04.3)
ceph (14.2.1.469+g454d851f0a -> 14.2.1.475+g83b977ffbd)
device-mapper
dolphin (19.04.2 -> 19.04.3)
dragonplayer (19.04.2 -> 19.04.3)
eventviews (19.04.2 -> 19.04.3)
gnome-shell-extensions
gpg2 (2.2.16 -> 2.2.17)
grantleetheme (19.04.2 -> 19.04.3)
grub2
gstreamer
gwenview5 (19.04.2 -> 19.04.3)
hwdata (0.324 -> 0.325)
incidenceeditor (19.04.2 -> 19.04.3)
iputils (s20190515 -> s20190709)
irqbalance (1.4.0 -> 1.6.0+git20190711.f7fdebb)
kaccounts-integration (19.04.2 -> 19.04.3)
kaccounts-providers (19.04.2 -> 19.04.3)
kaddressbook (19.04.2 -> 19.04.3)
kalarmcal (19.04.2 -> 19.04.3)
kamera (19.04.2 -> 19.04.3)
kate (19.04.2 -> 19.04.3)
kcalc (19.04.2 -> 19.04.3)
kcalcore (19.04.2 -> 19.04.3)
kcalutils (19.04.2 -> 19.04.3)
kcharselect (19.04.2 -> 19.04.3)
kcolorchooser (19.04.2 -> 19.04.3)
kcontacts (19.04.2 -> 19.04.3)
kdav (19.04.2 -> 19.04.3)
kdepim-addons (19.04.2 -> 19.04.3)
kdepim-apps-libs (19.04.2 -> 19.04.3)
kdepim-runtime (19.04.2 -> 19.04.3)
kdialog (19.04.2 -> 19.04.3)
khelpcenter5 (19.04.2 -> 19.04.3)
kidentitymanagement (19.04.2 -> 19.04.3)
kimap (19.04.2 -> 19.04.3)
kio-extras5 (19.04.2 -> 19.04.3)
kio_audiocd (19.04.2 -> 19.04.3)
kitinerary (19.04.2 -> 19.04.3)
kldap (19.04.2 -> 19.04.3)
kleopatra (19.04.2 -> 19.04.3)
kmag (19.04.2 -> 19.04.3)
kmail (19.04.2 -> 19.04.3)
kmail-account-wizard (19.04.2 -> 19.04.3)
kmailtransport (19.04.2 -> 19.04.3)
kmbox (19.04.2 -> 19.04.3)
kmime (19.04.2 -> 19.04.3)
kmousetool (19.04.2 -> 19.04.3)
knotes (19.04.2 -> 19.04.3)
kompare (19.04.2 -> 19.04.3)
konsole (19.04.2 -> 19.04.3)
kontact (19.04.2 -> 19.04.3)
kontactinterface (19.04.2 -> 19.04.3)
kopete (19.04.2 -> 19.04.3)
korganizer (19.04.2 -> 19.04.3)
kpimtextedit (19.04.2 -> 19.04.3)
kpkpass (19.04.2 -> 19.04.3)
kruler (19.04.2 -> 19.04.3)
ksmtp (19.04.2 -> 19.04.3)
ktnef (19.04.2 -> 19.04.3)
kwalletmanager5 (19.04.2 -> 19.04.3)
libgravatar (19.04.2 -> 19.04.3)
libkcddb (19.04.2 -> 19.04.3)
libkcompactdisc (19.04.2 -> 19.04.3)
libkdcraw (19.04.2 -> 19.04.3)
libkdepim (19.04.2 -> 19.04.3)
libkexiv2 (19.04.2 -> 19.04.3)
libkgapi (19.04.2 -> 19.04.3)
libkipi (19.04.2 -> 19.04.3)
libkleo (19.04.2 -> 19.04.3)
libkomparediff2 (19.04.2 -> 19.04.3)
libksane (19.04.2 -> 19.04.3)
libksieve (19.04.2 -> 19.04.3)
libpciaccess (0.14 -> 0.15)
libquicktime (1.2.4+git20180207.666c35c -> 1.2.4+git20180804.fff99cd)
libreoffice (6.2.4.2 -> 6.2.5.2)
lvm2
mailcommon (19.04.2 -> 19.04.3)
mailimporter (19.04.2 -> 19.04.3)
messagelib (19.04.2 -> 19.04.3)
metamail
mobipocket (19.04.2 -> 19.04.3)
mosh (1.3.2 -> 1.3.2+20190710)
okular (19.04.2 -> 19.04.3)
perl-Mail-SPF
permissions (1550_20190521 -> 1550_20190711)
pimcommon (19.04.2 -> 19.04.3)
polkit-default-privs (13.2+20190704.dfb36ad -> 13.2+20190711.953db4f)
pulseaudio
python-qt5 (5.12.2 -> 5.13.0)
python-sip (4.19.17 -> 4.19.18)
rsync
rubygem-bindex (0.7.0 -> 0.8.1)
rubygem-coffee-rails (4.2.2 -> 5.0.0)
rubygem-lightbox2 (2.11.0 -> 2.11.1.1)
rubygem-mini_mime (1.0.1 -> 1.0.2)
rzsz
signon-kwallet-extension (19.04.2 -> 19.04.3)
spectacle (19.04.2 -> 19.04.3)
sqlite3 (3.28.0 -> 3.29.0)
strace (5.1 -> 5.2)
tftp
totem (3.32.0 -> 3.32.1)
xauth (1.0.10 -> 1.1)
xorg-x11-fonts
xorgproto (2018.4 -> 2019.1)
xreader (1.8.5 -> 2.2.1)
zeromq (4.3.1 -> 4.3.2)
zlib

=== Details ===

==== MozillaThunderbird ====
Version update (60.7.2 -> 60.8.0)
Subpackages: MozillaThunderbird-translations-common

- Generate langpacks sequentially to avoid file corruption
from racy file writes (boo#1137970)
- Mozilla Thunderbird 60.8.0
* Calendar: Problems when editing event times, some related to
AM/PM setting in non-English locales
MFSA 2019-23 (boo#1140868)
* CVE-2019-9811 (bmo#1538007, bmo#1539598, bmo#1563327)
Sandbox escape via installation of malicious languagepack
* CVE-2019-11711 (bmo#1552541)
Script injection within domain through inner window reuse
* CVE-2019-11712 (bmo#1543804)
Cross-origin POST requests can be made with NPAPI plugins by
following 308 redirects
* CVE-2019-11713 (bmo#1528481)
Use-after-free with HTTP/2 cached stream
* CVE-2019-11729 (bmo#1515342)
Empty or malformed p256-ECDH public keys may trigger a segmentation fault
* CVE-2019-11715 (bmo#1555523)
HTML parsing error can contribute to content XSS
* CVE-2019-11717 (bmo#1548306)
Caret character improperly escaped in origins
* CVE-2019-11719 (bmo#1540541)
Out-of-bounds read when importing curve25519 private key
* CVE-2019-11730 (bmo#1558299)
Same-origin policy treats all files in a directory as having the
same-origin
* CVE-2019-11709 (bmo#1547266, bmo#1540759, bmo#1548822, bmo#1550498
bmo#1515052, bmo#1539219, bmo#1547757, bmo#1550498, bmo#1533522)
Memory safety bugs fixed in Firefox 68 and Firefox ESR 60.8 and
Thunderbird 60.8

==== akonadi-calendar ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== akonadi-calendar-tools ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-calendar-tools-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== akonadi-contact ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== akonadi-import-wizard ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== akonadi-mime ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== akonadi-notes ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== akonadi-search ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== akonadi-server ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Fix race-condition on akonadi_control start (kde#392092)
* Adapt DBInitializer to behavior change of QPSQL driver in Qt 5.13
(kde#409234)
* Check Postgres status by checking return code of pg_ctl (kde#386173)
* Shorten sockets file path
* Show error string from QLocalServer on failure

==== akregator ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akregator-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* i18n: use rc.cpp for extra sources
* [articleviewerwebengine] Reinstate crash "workaround" for Qt 5.13
(kde#371511)
* Bug 398516 - UI - Akregator comments section font seems to be hard coded.
Font is tiny on a 4k monitor (kde#398516)
- Dropped patches, now upstream:
* Reinstate-crash-workaround-for-Qt-5.13.patch

==== ark ====
Version update (19.04.2 -> 19.04.3)
Subpackages: ark-lang libkerfuffle19

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Do not use Q_DECLARE_METATYPE(KPluginMetaData) with KF 5.60+
* Fix version number
* CreateJob: connect to progress() signal instead of KJob::percent()
(kde#402824)

==== baloo5-widgets ====
Version update (19.04.2 -> 19.04.3)
Subpackages: baloo5-widgets-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== calendarsupport ====
Version update (19.04.2 -> 19.04.3)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== ceph ====
Version update (14.2.1.469+g454d851f0a -> 14.2.1.475+g83b977ffbd)
Subpackages: librados2 librbd1

- Update to 14.2.1-475-g83b977ffbd:
+ packaging: remove SuSEfirewall2 support

==== device-mapper ====
Subpackages: libdevmapper-event1_03 libdevmapper1_03 libdevmapper1_03-32bit

- Fix unknown feature in status message (bsc#1135984)
+ bug-1135984_cache-support-no_discard_passdown.patch

==== dolphin ====
Version update (19.04.2 -> 19.04.3)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* [Places Panel] Pass iconName to KFilePlaceEditDialog

==== dragonplayer ====
Version update (19.04.2 -> 19.04.3)
Subpackages: dragonplayer-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== eventviews ====
Version update (19.04.2 -> 19.04.3)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== gnome-shell-extensions ====
Subpackages: gnome-shell-classic gnome-shell-classic-session
gnome-shell-extensions-common gnome-shell-extensions-common-lang

- Update gse-sle-classic-ext.patch: Drop Convenience library since it
is now a gnome-shell built-in module (boo#1139990).

==== gpg2 ====
Version update (2.2.16 -> 2.2.17)
Subpackages: gpg2-lang

- Update to 2.2.17 [bsc#1141093]
* gpg: Do not try the import fallback if the options are already used.
* gpg: Fix regression in option "self-sigs-only".
* gpg: With --auto-key-retrieve prefer WKD over keyservers.
* gpg: Add "self-sigs-only" and "import-clean" to the keyserver options.
* gpg: Avoid printing false AKL error message.
* gpg: New command --locate-external-key.
* gpg: Make the get_pubkey_byname interface easier to understand.
* gpg: Fallback to import with self-sigs-only on too large keyblocks.
* gpg: New import and keyserver option "self-sigs-only"
* gpg: Make read_block in import.c more flexible.
* dirmngr: fix handling of HTTPS redirections during HKP.
* dirmngr: Avoid endless loop in case of HTTP error 503.
* dirmngr: Do not rewrite the redirection for the "openpgpkey" subdomain.
* dirmngr: Support the new WKD draft with the openpgpkey subdomain.
* wkd: Change client/server limit back to 64 KiB.
* tools: gpgconf: Killing order is children-first.
* Return better error code for some getinfo IPC commands.
* po: Update Russian translation.

==== grantleetheme ====
Version update (19.04.2 -> 19.04.3)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Fix iteration of FCP LUNs (bsc#1134287, bsc#1139345, LTC#177836, LTC#174229).
* Refresh grub2-ieee1275-FCP-methods-for-WWPN-and-LUNs.patch

==== gstreamer ====
Subpackages: gstreamer-lang gstreamer-utils libgstreamer-1_0-0
typelib-1_0-Gst-1_0

- Fix meson script using sed: since we rename gst-plugin-helper for
multi arch purpose, we also need to fix meson.build to make the
code look for the correct name (boo#1140998).

==== gwenview5 ====
Version update (19.04.2 -> 19.04.3)
Subpackages: gwenview5-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== hwdata ====
Version update (0.324 -> 0.325)

- Update to version 0.325:
* Updated pci, usb and vendor ids.

==== incidenceeditor ====
Version update (19.04.2 -> 19.04.3)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== iputils ====
Version update (s20190515 -> s20190709)
Subpackages: rarpd

- Update to version s20190709
- Removed patches included in this upstream release:
ping-Fix-unwanted-bell-on-unreachable-address.patch
0001-build-sys-doc-Fix-the-dependency-on-xsltproc.patch
meson-remove-setcap-setuid.sh.patch
- Add libcap-progs as a build dependency (setcap is needed)

==== irqbalance ====
Version update (1.4.0 -> 1.6.0+git20190711.f7fdebb)

- Add git hash tag and date in version as source is derived from
master/HEAD branch. Thanks to namtrac.
This is done via _service file.
Also add an example how to get back to a stable release version
- Update to latest git master version:
git commit f7fdebbaa4dbc27fcdeb7
- Use noun phrase in summaries.
- Update to version 1.6.0 (b47eea84cbb93f533b0cba2f1aa):
* fix balancing when numa information isn't available
* Refine document about IRQBALANCE_BANNED_CPUS
* Fix string truncation issues detected by GCC 8
* fix socket path creation
* Update document for option --banmod and --deepestcache
* Fix ambiguous parsing of *node* entries in /sys.
* procinterrupts: check xen-dyn-event more flexible
* misc: Add an example for policy script
* policyscript: ignore non-executable files when specifying a directory
remove because already mainline:
D fix_buffer_overflow_compiler.patch

==== kaccounts-integration ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kaccounts-providers ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kaccounts-providers-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kaddressbook ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kaddressbook-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kalarmcal ====
Version update (19.04.2 -> 19.04.3)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kamera ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kamera-lang kio_kamera

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kate ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kate-lang kate-plugins

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kcalc ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kcalc-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kcalcore ====
Version update (19.04.2 -> 19.04.3)

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kcalutils ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* i18n: use rc.cpp for extra sources

==== kcharselect ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kcharselect-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kcolorchooser ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kcolorchooser-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kcontacts ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kdav ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kdav-lang libKPimKDAV5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kdepim-addons ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kdepim-addons-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* i18n: use rc.cpp for extra sources
* Don't export UID it's not a necessary contact info

==== kdepim-apps-libs ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kdepim-apps-libs-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kdepim-runtime ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kdepim-runtime-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Improve debug
* Bug 407882: For a new resource, attempt to read existing calendar file
* Bug 407882: configure new KAlarm file resource correctly
* Try to fix a race condition.
* Fix configure lockfile settings

==== kdialog ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kdialog-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== khelpcenter5 ====
Version update (19.04.2 -> 19.04.3)
Subpackages: khelpcenter5-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== kidentitymanagement ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kimap ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kimap-lang libKF5IMAP5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Fix int overflow when parsing ImapSet (kde#409419)

==== kio-extras5 ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kio_audiocd ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kio_audiocd-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Use Unicode by default for CD-info data (kde#406262)

==== kitinerary ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kldap ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kldap-lang libKF5Ldap5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kleopatra ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kleopatra-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kmag ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kmag-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kmail ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* i18n: use rc.cpp for extra sources
* Don't save htmlLoadExternalOverride when it's default value
* Fix kontact crash on logout. (kde#404881)
* Fix warning about Qt::AA_EnableHighDpiScaling
- Dropped patches, now upstream:
* fix-kontact-crash-on-logout.patch

==== kmail-account-wizard ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kmail-account-wizard-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Fix Bug 388815 - accountwizard not reacting to alt-f4 (kde#388815)

==== kmailtransport ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kmbox ====
Version update (19.04.2 -> 19.04.3)

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kmime ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kmime-lang libKF5Mime5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kmousetool ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kmousetool-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== knotes ====
Version update (19.04.2 -> 19.04.3)
Subpackages: knotes-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kompare ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kompare-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== konsole ====
Version update (19.04.2 -> 19.04.3)
Subpackages: konsole-part konsole-part-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Variables for column/row are switched for Profile-Initial Terminal Size

==== kontact ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kontact-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* i18n: use rc.cpp for extra sources

==== kontactinterface ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kopete ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kopete-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== korganizer ====
Version update (19.04.2 -> 19.04.3)
Subpackages: korganizer-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kpimtextedit ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2
- Add upstream patches to fix pasting URI in composer not adding
href in richtext mode: (boo#1141308, kde#409695)
* Fix-Bug-409695.patch
* Add-more-protocols.patch

==== kpkpass ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKPimPkPass5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kruler ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kruler-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== ksmtp ====
Version update (19.04.2 -> 19.04.3)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== ktnef ====
Version update (19.04.2 -> 19.04.3)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== kwalletmanager5 ====
Version update (19.04.2 -> 19.04.3)
Subpackages: kwalletmanager5-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== libgravatar ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== libkcddb ====
Version update (19.04.2 -> 19.04.3)

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== libkcompactdisc ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== libkdcraw ====
Version update (19.04.2 -> 19.04.3)

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== libkdepim ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== libkexiv2 ====
Version update (19.04.2 -> 19.04.3)

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== libkgapi ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== libkipi ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== libkleo ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== libkomparediff2 ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== libksane ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5Sane5 libksane-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== libksieve ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libksieve-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== libpciaccess ====
Version update (0.14 -> 0.15)
Subpackages: libpciaccess-devel libpciaccess0

- Update to version 0.15
* Updates for FreeBSD and Hurd support
* Fixed multifunction bridge enumeration
* Fixed a crash when no PCI bus exists

==== libquicktime ====
Version update (1.2.4+git20180207.666c35c -> 1.2.4+git20180804.fff99cd)

- Remove merged patches:
* 0001-Fix-sizeof-call-in-faad2.patch
* 0002-Allow-any-avcodec-to-be-detected-by-configure.patch
* 0003-Fix-AVCODEC_HEADER-macro-replacement.patch
* 0005-ffmpeg4-conversion-fixing-the-erroring-ones-only.patch
- Update to version 1.2.4+git20180804.fff99cd:
* Should be LIBAVCODEC_LIBS rather than AVCODEC_LIBS in both configure.ac and
plugis/ffmpeg/Makfile/am
* ffmpeg4 conversion fixing the erroring ones only
* Ignore prepared patches in git checkout
* Fix AVCODEC_HEADER macro replacement
* Allow any avcodec to be detected by configure
* Fix sizeof call in faad2

==== libreoffice ====
Version update (6.2.4.2 -> 6.2.5.2)
Subpackages: libreoffice-base libreoffice-base-drivers-firebird
libreoffice-calc libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-l10n-es
libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru
libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
libreofficekit

- Update to 6.2.5.2:
* Various bugfixes on the 6.2 branch
- Remove merged patches:
* bsc1124869.patch
* bsc1127760.patch
* bsc1121874.patch
* bsc1135228.patch

==== lvm2 ====
Subpackages: liblvm2app2_2 liblvm2cmd2_02

- Fix unknown feature in status message (bsc#1135984)
+ bug-1135984_cache-support-no_discard_passdown.patch

==== mailcommon ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Don't save default value
* Don't save when it's default value
* Don't save PutRepliesInSameFolder when it's default value

==== mailimporter ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== messagelib ====
Version update (19.04.2 -> 19.04.3)
Subpackages: messagelib-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Use QTWEBENGINEWIDGETS_VERSION
* Add missing include files
* Use QTWEBENGINE_VERSION not QT_VERSION for WebEngine feature detection
* i18n: use rc.cpp for extra sources
* Use default value == date + 1
* Don't save not necessary info
* Restore popup menu position
* Fix check url when zoom != 100
* Fix Bug 390900 - Import vcf from email does not work (kde#390900)
* Fix infinite loop when mThreadingCache is 'corrupted'
* Use CTRL+ALT+Q for lock/unlock search

==== metamail ====

- Replace old mgrep script with new m(mime)grep written in hackweek

==== mobipocket ====
Version update (19.04.2 -> 19.04.3)

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* No code changes since 19.04.2

==== mosh ====
Version update (1.3.2 -> 1.3.2+20190710)

- Switch to git snapshots as there was no release over years.
- Update to version 1.3.2+20190710
* Apply latest consecutive resize, not earliest.
* mosh-server: improve error logging
* Add syslog logging of connections
* Fix issue with incorrect true-color background erase colors.
* Add true color support.
* Allow non-inserting prediction.
* Don't do prediction on large pastes into mosh-client.
* and more.

==== okular ====
Version update (19.04.2 -> 19.04.3)
Subpackages: okular-lang okular-spectre

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Fix saving "don't show again" when not using frameworksintegration
* Partial fix for high res displays (kde#401339)
* Fix compile with older poppler
* PDF: Finish support for Optional Content state change links
* Fix crash for rects that don't have an action

==== perl-Mail-SPF ====

- Fix permissions in spfd command [bsc#1141089]
- Added test dependency Test::Pod >= 1.00
- Move LICENSE file from doc to license
- Updated spec file with spec-cleaner

==== permissions ====
Version update (1550_20190521 -> 1550_20190711)
Subpackages: chkstat permissions-config permissions-doc

- Update to version 20190711:
* iputils: Add capability permissions for clockdiff (bsc#1140994)
- Update to version 20190710:
* iputils/ping: Drop effective capability
* iputils/ping6: Remove definitions

==== pimcommon ====
Version update (19.04.2 -> 19.04.3)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- Changes since 19.04.2:
* Google plus is dead.

==== polkit-default-privs ====
Version update (13.2+20190704.dfb36ad -> 13.2+20190711.953db4f)

- Update to version 13.2+20190711.953db4f:
* libvirt: add a couple of additional polkit actions (bsc#1140151)

==== pulseaudio ====
Subpackages: libpulse-mainloop-glib0 libpulse0 pulseaudio-bash-completion
pulseaudio-gdm-hooks pulseaudio-lang pulseaudio-module-bluetooth
pulseaudio-module-gsettings pulseaudio-module-x11 pulseaudio-module-zeroconf
pulseaudio-utils

- Remove SuSEfirewall2 service since SuSEfirewall2 has been
replaced by firewalld (which already provides a service for
pulseaudio).
- Remove some obsolete macros and conditionals.

==== python-qt5 ====
Version update (5.12.2 -> 5.13.0)
Subpackages: python-qt5-utils python3-qt5

- Update to 5.13.0
* Code updated to support Qt 5.13
* Fixed the conversion of the result of
QNetworkCacheMetaData.attributes()
- Drop reproducible.patch, merged upstream.

==== python-sip ====
Version update (4.19.17 -> 4.19.18)
Subpackages: python-sip-common python3-sip

- Update to 4.19.18
* Define SIP_NULLPTR as NULL (rather than 0)
* Updated the docs regarding sip5.
* Fixed warnings triggered by Python v3.8.
* Don't try and acquire the GIL if the interpreter is no longer there.

==== rsync ====

- Remove SuSEfirewall2 service since SuSEfirewall2 has been
replaced by firewalld (which already provides a rsyncd service).

==== rubygem-bindex ====
Version update (0.7.0 -> 0.8.1)

- updated to version 0.8.1
no changelog found

==== rubygem-coffee-rails ====
Version update (4.2.2 -> 5.0.0)

- updated to version 5.0.0
* Remove support to Rails < 5.2.
* Support Rails 6.

==== rubygem-lightbox2 ====
Version update (2.11.0 -> 2.11.1.1)

- updated to version 2.11.1.1
* Fixed LIGHTBOX2_VERSION and VERSION constants (The values were not updated
for the last release)
- updated to version 2.11.1
see upstream changelog:
https://github.com/lokesh/lightbox2/releases/tag/v2.11.1
* #557 Bugfix - MaxHeight wouldn't work. Fix by @RuiBandarra
* #660 fix: use max[Width|Height] when fitImagesInViewport is false. Fix by
@k-iwanishi
* #664 feature: Prevent Esc keypress from bubbling. Requested by @rkyoku in
#663

==== rubygem-mini_mime ====
Version update (1.0.1 -> 1.0.2)

- updated to version 1.0.2
* Update mime types from upstream

==== rzsz ====

- add lrzsz-0.12.21rc-drop-po-intl.patch:
fix build with gettext >= 0.20
- generate and install translation file manually

==== signon-kwallet-extension ====
Version update (19.04.2 -> 19.04.3)

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== spectacle ====
Version update (19.04.2 -> 19.04.3)
Subpackages: spectacle-lang

- Update to 19.04.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.3.php
- No code changes since 19.04.2

==== sqlite3 ====
Version update (3.28.0 -> 3.29.0)
Subpackages: libsqlite3-0 libsqlite3-0-32bit

- Update to version 3.29.0
* Added the SQLITE_DBCONFIG_DQS_DML and SQLITE_DBCONFIG_DQS_DDL
actions to sqlite3_db_config() for activating and deactivating
the double-quoted string literal misfeature. Both default to
"on" for legacy compatibility, but developers are encouraged
to turn them "off", perhaps using the -DSQLITE_DQS=0
compile-time option.
* -DSQLITE_DQS=0 is now a recommended compile-time option.
* Improvements to the query planner:
+ Improved optimization of AND and OR operators when one or
the other operand is a constant.
+ Enhancements to the LIKE optimization for cases when the
left-hand side column has numeric affinity.
* Added the "sqlite_dbdata" virtual table for extracting raw
low-level content from an SQLite database, even a database
that is corrupt.
* Enhancements to the CLI:
+ Add the ".recover" command which tries to recover as much
content as possible from a corrupt database file.
+ Add the ".filectrl" command useful for testing.
+ Add the long-standing ".testctrl" command to the ".help" menu.
+ Added the ".dbconfig" command

==== strace ====
Version update (5.1 -> 5.2)

- Update to strace 5.2
* Improvements
* Implemented syscall return status filtering with -e status=set option
and its aliases: -z (limit syscall printing to successful syscalls only)
and -Z (limit syscall printing to failed syscalls only).
* Implemented decoding of open_tree, move_mount, fsopen, fsconfig, fsmount,
and fspick syscalls.
* Enhanced decoding of bpf, clone, inotify_init, mbind, and set_mempolicy
syscalls.
* Updated lists of AT_*, AUDIT_*, BPF_*, CLONE_*, ETH_*, KEY_*, KVM_*, MPOL_*,
TIPC_*, and V4L2_* constants.
* Updated lists of ioctl commands from Linux 5.2.
* Bug fixes
* Fixed syscall tampering on powerpc, powerpc64, sparc, and sparc64 when
PTRACE_GET_SYSCALL_INFO is in use.
* Fixed build with cutting-edge toolchain.

==== tftp ====

- Remove SuSEfirewall2 service, since SuSEfirewall2 has been
replaced by firewalld (which already provides a tftp service).

==== totem ====
Version update (3.32.0 -> 3.32.1)
Subpackages: totem-lang totem-plugin-brasero totem-plugins

- Update to version 3.32.1:
+ Show the application window when opening a new file.
+ Work-around "Can't play a text file without video or
visualizations" error.
+ Build fixes.
+ Updated translations.
- Drop totem-buildfixes.patch and totem-fix-appdata.patch: fixed
upstream.

==== xauth ====
Version update (1.0.10 -> 1.1)

- Update to version 1.1
* This release fixes a race condition where an existing
authority file would be unlinked (possibly causing other
clients to fail to connect), and fixes sorting and merging
of authority file entries.

==== xorg-x11-fonts ====
Subpackages: xorg-x11-fonts-core

- encodings 1.0.5
* jisx0201.1976-0.enc: Add undefined mapping for 0x7f - 0xa0 range
* cns11643-x encodings don't need to alias to themselves

==== xorgproto ====
Version update (2018.4 -> 2019.1)

- use --enable-legacy configure option on existing products in order
not to break package builds, which still requires any of these
extensions:
* trapproto
* xf86miscproto
* xproxymngproto
deleterequests for the affected packaages have been done for factory/TW
- xorgproto 2019.1
* This release boasts a bunch of cleanup work and a few new
keysyms. No functional changes to any of the protocols.

==== xreader ====
Version update (1.8.5 -> 2.2.1)
Subpackages: libxreaderdocument3 libxreaderview3 xreader-backends xreader-lang

- Update to version 2.2.1:
* Remove patch xreader-fix-func-type.patch is no longer needed
* meson: Fix libexec (#319)
* build: Fix gir package
* Fix some warnings when building xreader 2.0.2 (#265)
* CI: Remove Mint 18
* port to meson (#269)
* Build: Fix Debian Stretch build
* Take device scale factor into account for zoom (#277)
* Update readme for meson changes (#284)
* meson: change 'debug' option to 'enable_debug' to avoid collisions (#285)
* Remove leftover code
* view: Fix whitespace issues
* ev-window: Fix incompatible pointer type issues
* ATRIL BACKPORTS: a11y: Do not use AtkFactory to create the EvViewAccessible
* ATRIL BACKPORTS: libview: Rename EvView coordinate transformation functions
* ATRIL BACKPORTS: ev-view-accessible: Use
_ev_view_transform_view_point_to_doc_point()
* ATRIL BACKPORTS: ev-view-accessible: Use
_ev_view_transform_doc_rect_to_view_rect()
* ATRIL BACKPORTS: ev-view: Inlcude ev-jobs in ev-view.h
* ATRIL BACKPORTS: libdocument: Add length and nth methods to EvMappingList
* ATRIL BACKPORTS: libview: Implement AtkHypertext interface
* ATRIL BACKPORTS: libview: Make EvLinkAccessible implement AtkAction
* ATRIL BACKPORTS: ev-view-accessible: Add helper function to get text
before, at or after offset
* ATRIL BACKPORTS: ev-view-accessible: Fix some coding style issues
* Meson fixups (#293)
* libdocument: Fix handling of mime-type aliases (#292)
* ATRIL BACKPORTS: Add missing comma.
* sidebar-thumbnails: clean up cancel_running_jobs
* ATRIL BACKPORTS: sidebar-thumbnails: preload one extra visible range while
scrolling
* ATRIL BACKPORTS: EvPixbufCache: Handle backends that don't render a
selection
* Fix some compile time warnings
* EVINCE BACKPORTS: libview: Reset `pressed_button` when starting Drag and
Drop (#301)
* build: Fix compiling with disabled epub (#308)
* Fix text selection in HiDPI (#302)
* Add optional zoom level selector. (#305)
* epub backend: make mathjax directory a configure-time option (#297)
* Make help files optional (#311)
* shell: Add a ctrl+q shortcut to close all open windows (#312)
* shell: Add a 'No recent documents' screen (#313)
* EVINCE BACKPORTS: shell: forward accels to the focused widget (#315)
* l10n: Update POT
* Build: Fix l10n
* libdocument: Return default DPI on failure (#316)
* xreaderd logging (#318)
- Fixed Obsoletes xreader-backends
- Split backends into subpackages to prevent hard-dependency
build failures
- Dropped xreader-backends package

==== zeromq ====
Version update (4.3.1 -> 4.3.2)
Subpackages: libzmq5 zeromq-tools

- New upstream version 4.3.2:
* CVE-2019-13132: a remote, unauthenticated client connecting to a
libzmq application, running with a socket listening with CURVE
encryption/authentication enabled, may cause a stack overflow and
overwrite the stack with arbitrary data, due to a buffer overflow in
the library. Users running public servers with the above configuration
are highly encouraged to upgrade as soon as possible, as there are no
known mitigations. (bsc#1140255)
* New DRAFT (see NEWS for 4.2.0) zmq_socket_monitor_versioned API that
supports
a versioned monitoring events protocol as a parameter. Passing 1 results in
the same behaviour as zmq_socket_monitor.
* New DRAFT (see NEWS for 4.2.0) zmq_socket_monitor_pipes_stats that triggers
a new ZMQ_EVENT_PIPES_STATS to be delivered via zmq_socket_monitor_versioned
v2 API, which contains the current status of all the queues owned by the
monitored socket. See doc/zmq_socket_monitor_versioned.txt for details.
* New DRAFT (see NEWS for 4.2.0) zmq_poller_fd that returns the FD of a thread
safe socket.
* New DRAFT (see NEWS for 4.2.0) socket options:
ZMQ_XPUB_MANUAL_LAST_VALUE is similar to ZMQ_XPUB_MANUAL but allows to avoid
duplicates when using last value caching.
ZMQ_SOCKS_USERNAME and ZMQ_SOCKS_PASSWORD that implement SOCKS5 proxy
authentication.
- For complete set of changes, see
https://github.com/zeromq/libzmq/releases/tag/v4.3.2

==== zlib ====
Subpackages: libminizip1 libz1 libz1-32bit zlib-devel

- Tweak zlib-power8-fate325307.patch to have type of crc32_vpmsum
conform to usage
bsc#1141059


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages