Mailinglist Archive: opensuse-factory (463 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190627 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Fri, 28 Jun 2019 21:01:25 +0000
  • Message-id: <156175568529.10836.6368286906188233492@go-agent-stagingbot-2>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190627

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
Mesa (19.0.5 -> 19.1.0)
Mesa-drivers (19.0.5 -> 19.1.0)
PackageKit
autofs
bluedevil5 (5.16.1 -> 5.16.2)
breeze (5.16.1 -> 5.16.2)
breeze-gtk (5.16.1 -> 5.16.2)
breeze4-style (5.16.1 -> 5.16.2)
brltty
discover (5.16.1 -> 5.16.2)
drkonqi5 (5.16.1 -> 5.16.2)
fwupd (1.2.8 -> 1.2.9)
gnome-settings-daemon (3.32.0 -> 3.32.1)
gpg2
gtk3 (3.24.8 -> 3.24.9)
kactivitymanagerd (5.16.1 -> 5.16.2)
kcm_sddm (5.16.1 -> 5.16.2)
kde-cli-tools5 (5.16.1 -> 5.16.2)
kde-gtk-config5 (5.16.1 -> 5.16.2)
kde-user-manager (5.16.1 -> 5.16.2)
kdump
kgamma5 (5.16.1 -> 5.16.2)
khotkeys5 (5.16.1 -> 5.16.2)
kinfocenter5 (5.16.1 -> 5.16.2)
kmenuedit5 (5.16.1 -> 5.16.2)
kscreen5 (5.16.1 -> 5.16.2)
kscreenlocker (5.16.1 -> 5.16.2)
ksshaskpass5 (5.16.1 -> 5.16.2)
ksysguard5 (5.16.1 -> 5.16.2)
kwayland-integration (5.16.1 -> 5.16.2)
kwin5 (5.16.1 -> 5.16.2)
libdmtx (0.7.4 -> 0.7.5)
libkdecoration2 (5.16.1 -> 5.16.2)
libkscreen2 (5.16.1 -> 5.16.2)
libksysguard5 (5.16.1 -> 5.16.2)
llvm8
mercurial (5.0 -> 5.0.1)
milou5 (5.16.1 -> 5.16.2)
mobile-broadband-provider-info (20190116 -> 20190618)
multipath-tools (0.8.1+8+suse.8c11498 -> 0.8.1+28+suse.fea562a)
oxygen5 (5.16.1 -> 5.16.2)
plasma-nm5 (5.16.1 -> 5.16.2)
plasma5-addons (5.16.1 -> 5.16.2)
plasma5-desktop (5.16.1 -> 5.16.2)
plasma5-integration (5.16.1 -> 5.16.2)
plasma5-openSUSE
plasma5-pa (5.16.1 -> 5.16.2)
plasma5-workspace (5.16.1 -> 5.16.2)
polkit-kde-agent-5 (5.16.1 -> 5.16.2)
powerdevil5 (5.16.1 -> 5.16.2)
presage
python-py
samba (4.10.2+git.94.31fb5e37171 -> 4.10.5+git.105.2bd98587873)
sssd (2.1.0 -> 2.2.0)
systemsettings5 (5.16.1 -> 5.16.2)
unbound (1.9.1 -> 1.9.2)

=== Details ===

==== Mesa ====
Version update (19.0.5 -> 19.1.0)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- reverted latest change in specfile; it's not needed; llvm8 is
already been chosen on factory/TW by default ...
- use llvm8 on factory/TW
- n_glesv1_cm-glesv2.patch
* reenables build of GLESv1_CM and GLESv2 ...
- readded pkgconfig files for GLESv1_CM and GLESv2 to filelists
- removed again virtual provides for
* pkgconfig(glesv1_cm)
* pkgconfig(glesv2)
- reenable LTO with Mesa 19.1 (boo#1133265, comment#5)
- enabled new gallium drivers
* iris (newer Intel GPUs)
* lima, panfrost on ARM64
- virtually provide
* pkgconfig(glesv1_cm)
* pkgconfig(glesv2)
in libGLESv1_CM-devel/libGLESv2-devel packages, since these files
have been removed from Mesa via git commit #1587586
- Update to 19.1.0:
* Mesa 19.1.0 implements the OpenGL 4.5 API, but the version
reported by glGetString(GL_VERSION) or
glGetIntegerv(GL_MAJOR_VERSION) /
glGetIntegerv(GL_MINOR_VERSION) depends on the particular
driver being used. Some drivers don't support all the features
required in OpenGL 4.5. OpenGL 4.5 is only available if
requested at context creation. Compatibility contexts may
report a lower version depending on each driver.
* The top highlights include:
- GL_ARB_parallel_shader_compile for all drivers.
- GL_EXT_gpu_shader4 on all GL 3.1 drivers.
- GL_EXT_shader_image_load_formatted on radeonsi.
- GL_EXT_texture_buffer_object on all GL 3.1 drivers.
- GL_EXT_texture_compression_s3tc_srgb on Gallium and i965
drivers (ES extension).
- GL_NV_compute_shader_derivatives on Iris and i965 drivers.
- GL_KHR_parallel_shader_compile on all drivers.
- GL_INTEL_conservative_rasterization on Iris.
- Refresh patches with quilt.
- Clean-up spec files for .pc and other files no longer built.

==== Mesa-drivers ====
Version update (19.0.5 -> 19.1.0)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- reverted latest change in specfile; it's not needed; llvm8 is
already been chosen on factory/TW by default ...
- use llvm8 on factory/TW
- n_glesv1_cm-glesv2.patch
* reenables build of GLESv1_CM and GLESv2 ...
- readded pkgconfig files for GLESv1_CM and GLESv2 to filelists
- removed again virtual provides for
* pkgconfig(glesv1_cm)
* pkgconfig(glesv2)
- reenable LTO with Mesa 19.1 (boo#1133265, comment#5)
- enabled new gallium drivers
* iris (newer Intel GPUs)
* lima, panfrost on ARM64
- virtually provide
* pkgconfig(glesv1_cm)
* pkgconfig(glesv2)
in libGLESv1_CM-devel/libGLESv2-devel packages, since these files
have been removed from Mesa via git commit #1587586
- Update to 19.1.0:
* Mesa 19.1.0 implements the OpenGL 4.5 API, but the version
reported by glGetString(GL_VERSION) or
glGetIntegerv(GL_MAJOR_VERSION) /
glGetIntegerv(GL_MINOR_VERSION) depends on the particular
driver being used. Some drivers don't support all the features
required in OpenGL 4.5. OpenGL 4.5 is only available if
requested at context creation. Compatibility contexts may
report a lower version depending on each driver.
* The top highlights include:
- GL_ARB_parallel_shader_compile for all drivers.
- GL_EXT_gpu_shader4 on all GL 3.1 drivers.
- GL_EXT_shader_image_load_formatted on radeonsi.
- GL_EXT_texture_buffer_object on all GL 3.1 drivers.
- GL_EXT_texture_compression_s3tc_srgb on Gallium and i965
drivers (ES extension).
- GL_NV_compute_shader_derivatives on Iris and i965 drivers.
- GL_KHR_parallel_shader_compile on all drivers.
- GL_INTEL_conservative_rasterization on Iris.
- Refresh patches with quilt.
- Clean-up spec files for .pc and other files no longer built.

==== PackageKit ====
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module PackageKit-lang libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- Add PackageKit-zypp-fix-newest-filter.patch: zypp: Emit installed
package for newest filter (bsc#1125434, gh#hughsie/PackageKit#329).

==== autofs ====

- BuildRequire pkgconfig(libsystemd) instead of systemd-devel:
allow OBS to shortcut by using systemd-devel-mini.

==== bluedevil5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: bluedevil5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== breeze ====
Version update (5.16.1 -> 5.16.2)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers libbreezecommon5-5

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== breeze-gtk ====
Version update (5.16.1 -> 5.16.2)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== breeze4-style ====
Version update (5.16.1 -> 5.16.2)
Subpackages: libbreezecommon4-5

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== brltty ====
Subpackages: brltty-driver-at-spi2 brltty-driver-brlapi
brltty-driver-speech-dispatcher brltty-driver-xwindow brltty-lang libbrlapi0_7
python3-brlapi xbrlapi

- BuildRequire pkgconfig(libsystemd) instead of systemd-devel:
allow OBS to shortcut by using systemd-devel-mini.

==== discover ====
Version update (5.16.1 -> 5.16.2)
Subpackages: discover-backend-flatpak discover-backend-packagekit discover-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- Changes since 5.16.1:
* make appstream files validate
* odrs: delay QNAM initialization

==== drkonqi5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: drkonqi5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== fwupd ====
Version update (1.2.8 -> 1.2.9)
Subpackages: fwupd-lang libfwupd2

- Update to version 1.2.9:
* Release fwupd 1.2.9
* trivial: Add two new translatable strings for new category types
* Check if the system is offline during install, rather than at startup
* Prompt the user to shutdown if requried when installing by ID
* Use the correct file extension for the offline updates cache
* trivial: Allow using --force to use the wrong daemon version
* trivial: Display the correct expected command
* standalone-installer: Be smarter about existing installed fwupd
* Add a plugin to update Synaptics Prometheus fingerprint readers
* trivial: standalone-installer: rename uninstall argument to cleanup
* fu-util: Check the daemon version is at least the client version
* fu-util: Check that daemon is started by expected unit
* fu-util-common: when stopping a daemon, check for snap too
* Allow using --force to trigger a duplicate offline update
* trivial: Allow using FuUsbDevice without a GUsbDevice
* trivial: Copy the icons if unset for the device child
* trivial: Copy the physical ID if unset for the device child
* trivial: Ensure the parent ID is up to date if the device ID changes
* trivial: Fix typo when setting the parent ID
* trivial: Disable the flatpak CI build
* Allow handling FORCE for devices that subclass FuDevice
* uefi: Fix a libasan failure when reading a UEFI variable
* trivial: Fix a memory leak found using libasan
* trivial: Fix an libasan failure in the dell plugin
* trivial: Fix some dead code spotted by coverity
* trivial: Fix a typo spotted by coverity
* trivial: Fix a missing config.h include in a new source file
* Dynamically read path to use for /system-update
* Display the remote warning on the console in an easy-to-read way
* ata: Set version format to plain for devices obtained from udev
* trivial: Only apply SmbiosManufacturer to release version for internal
* trivial: Fix two bugs in the hardware self tests script
* Never guess the version format from the version string
* Only force a semver when the device opts-in
* Export the version-format to clients
* Add missing gtk-doc documentation
* dfu: Add some trivial, but useful, debugging for AVR DFU devices
* dfu: Correctly identify DFU firmware that starts at offset zero
* dfu: Don't keep showing trivial debug output
* dfu: Reset the forced version during attach and detach
* ata/nvme: For devices running Dell firmware, set `VersionFormat` (Fixes:
#1169)
* fu-engine: Check if VersionFormat is ambiguous when adding devices
* trivial: Fix fwupdate --apply
* Only use class-based instance IDs for quirk matching
* trivial: dell-dock: set minimum board to 6
* trivial: post release version bump

==== gnome-settings-daemon ====
Version update (3.32.0 -> 3.32.1)
Subpackages: gnome-settings-daemon-lang

- Update to version 3.32.1:
+ Signal connector rather than output ID for OSDs.
+ Media-keys: Fix MPRIS issues with disconnecting clients.
+ Color: Allow night light to be always on.
+ Power: Only disable Suspend/Hibernate actions inside VM.
+ Smartcard: Fix cancellation issues.
+ Updated translations.

==== gpg2 ====
Subpackages: gpg2-lang

- Fix secure memory being disabled before fips checks in libgcrypt [boo#1137307]
* Added gnupg-2.2.16-secmem.patch

==== gtk3 ====
Version update (3.24.8 -> 3.24.9)
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-tigrigna gtk3-immodule-vietnamese
gtk3-immodule-xim gtk3-lang gtk3-tools libgtk-3-0 typelib-1_0-Gtk-3_0

- Update to version 3.24.9:
+ GTK can now be built with the meson build system.
+ Wayland:
- Support the xdg-output protocol for correct monitor sizes
with scaled displays.
- Fix handling of cursor hotspots that was reading
uninitialized memory.
- Update tablet cursors when scale changes.
+ CSS: Use multiple font-family values.
+ Emoji: Populate the Emoji chooser incrementally.
+ Printing: Require CUPS 1.7.
+ Scrolling: Add a gtk-overlay-scrolling setting that can be used
to force traditional (non-overlay) scrollbars.
+ GtkTreeView:
- Update rubberband rectangles more often.
- Remove the pixel cache, to avoid the redraw issues that it
causes.
+ Tooling: Support sysprof profiling.
+ Themes:
- Adwaita: Small tweaks to the theme refresh.
- Adwaita: Update treeview progress bars.
- HighContrast: Improve notebook tabs.
+ Updated translations.

==== kactivitymanagerd ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kactivitymanagerd-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kcm_sddm ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kcm_sddm-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kde-cli-tools5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kde-cli-tools5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kde-gtk-config5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kde-user-manager ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kde-user-manager-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kdump ====

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini

==== kgamma5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kgamma5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== khotkeys5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: khotkeys5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kinfocenter5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kinfocenter5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kmenuedit5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kmenuedit5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kscreen5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kscreen5-lang kscreen5-plasmoid

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kscreenlocker ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== ksshaskpass5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: ksshaskpass5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== ksysguard5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: ksysguard5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kwayland-integration ====
Version update (5.16.1 -> 5.16.2)

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== kwin5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: kwin5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- Changes since 5.16.1:
* [placement] Avoid smart placement strategy with invalid client sizes
(kde#408754)
* Make sure we don't resize clients before they've been set up
* Avoid crash without XWayland
* [wayland] Obey m_requestGeometryBlockCounter inside updateDecoration
* [platforms/X11] Disable VSync for QtQuick Windows (kde#406180)

==== libdmtx ====
Version update (0.7.4 -> 0.7.5)

- Update to 0.7.5
* Add support for GS-1 encoding via the FCN1 character
* Fix dmtxDecodeMatrixRegion returning a freed pointer
* makefile: migrating ANSI C -> C99
* Fixed Data Mosaic encoding bug
- Change the upstream URL.
- Drop patches, now upstream:
* libdmtx-mosaic.patch
* libdmtx-explicit-cast.patch
- Rebase libdmtx-DmtxPropRowPadBytes.patch.
- Update the License tag, only BSD-2-Clause files are used.

==== libkdecoration2 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: libkdecorations2-5 libkdecorations2-5-lang libkdecorations2private6

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== libkscreen2 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== libksysguard5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== llvm8 ====
Subpackages: clang8 clang8-checker libLLVM8 libLTO8 libc++-devel libc++1
libc++abi-devel libc++abi1 libclang8

- Exclude riscv64 for now since it fails to build.

==== mercurial ====
Version update (5.0 -> 5.0.1)
Subpackages: mercurial-lang

- Mercurial 5.0.1
A regularly scheduled bugfix release.
+ commands
* bookmark: also make bookmark cache depends of the changelog
* commit: allow --interactive to work again when naming a directory
(issue6131)
+ unsorted
* manifest: avoid corruption by dropping removed files with pure (issue5801)
* sslutil: fsencode path returned by certifi (issue6132)

==== milou5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: milou5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- Changes since 5.16.1:
* Don't give up if no results arrive after 500ms (kde#389611)
- Remove patches, now upstream:
* 0001-Don-t-give-up-if-no-results-arrive-after-500ms.patch

==== mobile-broadband-provider-info ====
Version update (20190116 -> 20190618)

- Update to version 20190618:
+ release: bump version to 20190618
+ build:
- Remove unused automake flags
- Switch dist to xz
- Update bug report URL
- Fix make distcheck
+ Added configuration for WinSIM (German provider)
+ apn-conf: generate Android-compatible APN list
+ all: remove SVN vestiges
+ es: new SUOP operator
+ Move mcc="232" mnc="05" from Orange to Drei
+ jp:
- Add b-mobile visitor sim entry
- Add primary markers for NTT DoCoMo and bmobile
+ fi: Add Moi Mobiili
+ cz: add T-Mobile balance check and top-up
- Add xsltproc BuildRequires: New dependency.

==== multipath-tools ====
Version update (0.8.1+8+suse.8c11498 -> 0.8.1+28+suse.fea562a)
Subpackages: kpartx libmpath0

- Update to version 0.8.1+28+suse.fea562a:
* mpathpersist: optimize for setups with many LUNs (bsc#1134648)
* mpathpersist: add option -f/--batch-file (bsc#1134648)
* libmultipath: get_prio(): really don't reset prio for
inaccessible paths (bsc#1118495)
- Upstream bug fixes from dm-devel (bsc#1139369):
* multipath: call store_pathinfo with DI_BLACKLIST
* multipathd: fix REALLOC_REPLY with max length reply
* libmultipath: make vector_foreach_slot_backwards work as expected
* multipathd: fix client response for socket activation
* various minor fixes (coverity)

==== oxygen5 ====
Version update (5.16.1 -> 5.16.2)

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== plasma-nm5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== plasma5-addons ====
Version update (5.16.1 -> 5.16.2)
Subpackages: plasma5-addons-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- Changes since 5.16.1:
* [Calculator] Fix popup size and minimum size for expanded version

==== plasma5-desktop ====
Version update (5.16.1 -> 5.16.2)
Subpackages: plasma5-desktop-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- Changes since 5.16.1:
* make appstream validate
* [Look and Feel and KSplash KCM] Set sourceSize for thumbnail
* [Task Manager] Prefer PID match even when desktop entry doesn't match
* Fix merge screwup
* [Kickoff/Dash] Show Calculator and Unit Converter runners
* Increment iterator before any potential continue
* Reject duplicate events with identical coordinates
* Fix ocasional crash on the touchpad kded
* [Colors KCM] Assign properties in a binding
* touchpad: fix some easy warnings
* [Touchpad KCM] Do not crash in case there is no touchpad (kde#408325)

==== plasma5-integration ====
Version update (5.16.1 -> 5.16.2)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.16.2

==== plasma5-pa ====
Version update (5.16.1 -> 5.16.2)
Subpackages: plasma5-pa-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== plasma5-workspace ====
Version update (5.16.1 -> 5.16.2)
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- Changes since 5.16.1:
* [Notifications] Swap configure and clear buttons in full representation
header (kde#409140)
* do not use long deprecated QString::toAscii
* print a warning when invoking the scripting API's sleep()
* [Notifications] Don't keep non-configurable notifications in history
* [Notifications] Make popup placement more resilient
* [Notifications] Don't show remaining time when job is paused
* [Notifications] Let plasmashell be the only true owner of notification and
job tracker services (kde#408250)
* [Klipper] Always restore the last clipbboard item
* Handle Gimp 2.10
* Set translation domain
* [interactiveconsole] Fix initial load selection (kde#408787)
* [Notifications] Read BAMF_DESKTOP_FILE_HINT from environment
* Make the icon applet use the same shadow settings as desktop icons

==== polkit-kde-agent-5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== powerdevil5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: powerdevil5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- Changes since 5.16.1:
* [powerdevil] Return battery source monitoring

==== presage ====
Subpackages: libpresage1 presage-data

- Split out API doc generation using multibuild. graphviz-gd has
become quite heavy as a build dependency.
- Cleanup specfile
* remove defattr, use license macro
* remove conditionals for EOLed distribution versions
- Remove gpresagemate, it depends on the long deprecated XEVIE extension
- Set she-bang for /usr/bin/presage_dbus_* to /usr/bin/python2

==== python-py ====

- Switch to multibuild to avoid cycle bsc#1138666

==== samba ====
Version update (4.10.2+git.94.31fb5e37171 -> 4.10.5+git.105.2bd98587873)
Subpackages: libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0
libdcerpc0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0
libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit
libnetapi0 libnetapi0-32bit libsamba-credentials0 libsamba-credentials0-32bit
libsamba-errors0 libsamba-errors0-32bit libsamba-hostconfig0
libsamba-hostconfig0-32bit libsamba-passdb0 libsamba-passdb0-32bit
libsamba-policy0-python3 libsamba-util0 libsamba-util0-32bit libsamdb0
libsamdb0-32bit libsmbclient0 libsmbconf0 libsmbconf0-32bit libsmbldap2
libsmbldap2-32bit libtevent-util0 libtevent-util0-32bit libwbclient0
libwbclient0-32bit samba-client samba-client-32bit samba-doc samba-libs
samba-libs-32bit samba-libs-python3 samba-python3 samba-winbind
samba-winbind-32bit

- Update to samba-4.10.5 (including updates for 4.10.4, 4.10.3)
+ CVE-2019-12435 rpc/dns: Avoid NULL deference if zone not found
in DnssrvOperation2; (bso#13922); (bsc#1137815).
+ CVE-2019-12436 dsdb/paged_results: Ignore successful results
without messages; (bso#13951); (bsc#1137816).
- Update to samba-4.10.4
+ s3: SMB1: Don't allow recvfile on stream fsp's; (bso#13938).
+ py/provision: Fix for Python 2.6; (bso#13882).
+ netcmd: Fix 'passwordsettings --max-pwd-age' command;
(bso#13873).
+ s3-libnet_join: 'net ads join' to child domain fails when
using "-U admin@forestroot"; (bso#13861).
+ vfs_ceph: Explicitly enable libcephfs POSIX ACL support;
(bso#13896); (bsc#1130245).
+ vfs_ceph: Fix cephwrap_flistxattr() debug message;
(bso#13940); (bsc#1134697).
+ ctdb-common: Avoid race between fd and signal events;
(bso#13895).
+ ctdb-common: Fix memory leak in run_proc; (bso#13943).
+ lib: Initialize getline() arguments; (bso#13892).
+ winbind: Fix overlapping id ranges; (bco#13903).
+ lib util debug: Increase format buffer to 4KiB; (bso#13902).
+ nsswitch pam_winbind: Fix Asan use after free; (bso#13927).
+ s4 lib socket: Ensure address string owned by parent struct;
(bso#13929).
+ s3 rpc_client: Fix Asan stack use after scope; (bso#13936).
+ s3:smbd: Handle IO_REPARSE_TAG_DFS in
SMB_FIND_FILE_FULL_DIRECTORY_INFO; (bso#10097).
+ smb2_tcon: Avoid STATUS_PENDING completely on tdis; (bso#10344).
+ smb2_sesssetup: avoid STATUS_PENDING responses for session setup;
(bso#12845).
+ smb2_tcon: Avoid STATUS_PENDING completely on tdis; (bso#13698).
+ smb2_sesssetup: avoid STATUS_PENDING responses for session
setup; (bso#13796).
+ dbcheck: Fix the err_empty_attribute() check; (bso#13843).
+ vfs_snapper: Drop unneeded fstat handler; (bso#13858).
+ vfs_default: Fix vfswrap_offload_write_send()
NT_STATUS_INVALID_VIEW_SIZE check; (bso#13862).
+ smb2_server: Grant all 8192 credits to clients; (bso#13863).
+ smbd: Implement SMB_FILE_NORMALIZED_NAME_INFORMATION handling;
(bso#13919).
+ s3/vfs_glusterfs: Dynamically determine NAME_MAX; (bso#13872).
+ s3: modules: ceph: Use current working directory instead of
share path; (bso#13918); (bsc#1134452).
+ winbind: Use domain name from lsa query for sid_to_name cache
entry; (bso#13831).
+ memcache: Increase size of default memcache to 512k;
(bso#13865).
+ docs: Update smbclient manpage for "--max-protocol";
(bso#13857).
+ s3:utils: If share is NULL in smbcacls, don't print it;
(bso#13937).
+ s3:smbspool: Fix regression printing with Kerberos credentials;
(bso#13939).
+ ctdb-scripts: CTDB restarts failed NFS RPC services by hand,
which is incompatible with systemd; (bso#13860).
+ ctdb-daemon: Revert "We can not assume that just because we
could complete a TCP handshake"; (bso#13888).
+ ctdb-daemon: Never use 0 as a client ID; (bso#13930).
+ ctdb-common: Fix memory leak; (bso#13943).
+ s3:debug: Enable logging for early startup failures;
(bso#13904)
- Update to samba-4.10.3
+ CVE-2018-16860: Heimdal KDC: Reject PA-S4U2Self with unkeyed
checksum; (bso#13685); (bsc#1134024).

==== sssd ====
Version update (2.1.0 -> 2.2.0)
Subpackages: libnfsidmap-sss libsss_certmap0 libsss_idmap0 libsss_nss_idmap0
sssd-32bit sssd-krb5-common sssd-ldap

- Update to new upstream release 2.2.0
* The Kerberos provider can now include more KDC addresses or
host names when writing data for the Kerberos locator plugin.
* The 2FA prompting can now be configured.
* The LDAP authentication provider now allows to use a
different method of changing LDAP passwords using a modify
operation in addition to the default extended operation.
* The "auto_private_groups" configuration option now takes a
new value hybrid.
* A new option "ad_gpo_ignore_unreadable" was added.
* The "cached_auth_timeout" parameter is now inherited by
trusted domains.
* The "ldap_sasl_mech" option now accepts another mechanism
"GSS-SPNEGO" in addition to "GSSAPI".
* The sssctl tool has two new commands, "cert-show" and
"cert-map".
- Create directory to download and cache GPOs (bsc#1132879)

==== systemsettings5 ====
Version update (5.16.1 -> 5.16.2)
Subpackages: systemsettings5-lang

- Update to 5.16.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.16.2.php
- No code changes since 5.16.1

==== unbound ====
Version update (1.9.1 -> 1.9.2)
Subpackages: libunbound2 unbound-anchor

- update to 1.9.2
Features
- add type CAA to libpyunbound (accessing libunbound from python).
- Fix #17: Add python module example from Jan Janak, that is a
plugin for the Unbound DNS resolver to resolve DNS records in
multicast DNS [RFC 6762] via Avahi. The plugin communicates
with Avahi via DBus. The comment section at the beginning of
the file contains detailed documentation.
- travis build file.
- PR #16: XoT support, AXFR over TLS, turn it on with
master: <ip>#<authname> in unbound.conf. This uses TLS to
download the AXFR (or IXFR).
Bug Fixes
- Fix for #4233: guard use of NDEBUG, so that it can be passed in
CFLAGS into configure.
- Add log message, at verbosity 4, that says the query is encrypted
with TLS, if that is enabled for the query.
- Fix #4239: set NOTIMPL when deny-any is enabled, for RFC8482.
- Fix #4240: Fix whitespace cleanup in example.conf.
- Fix that tls-session-ticket-keys: "" on its own in unbound.conf
disables the tls session ticker key calls into the OpenSSL API.
- Fix crash if tls-servic-pem not filled in when necessary.
- Fix auth-zone NSEC3 response for empty nonterminals with exact
match nsec3 records.
- Fix for out of bounds integers, thanks to OSTIF audit. It is in
allocation debug code.
- Fix for auth zone nsec3 ent fix for wildcard nodata.
- Move goto label in answer_from_cache to the end of the function
where it is more visible.
- Fix auth-zone NSEC3 response for wildcard nodata answers,
include the closest encloser in the answer.
- Fix spelling error in log output for event method.
- Fix to reinit event structure for accepted TCP (and TLS) sockets.
- Fix to use event_assign with libevent for thread-safety.
- verbose information about auth zone lookup process, also lookup
start, timeout and fail.
- Fix to wipe ssl ticket keys from memory with explicit_bzero,
if available.
- Fix that auth zone uses correct network type for sockets for
SOA serial probes. This fixes that probes fail because earlier
probe addresses are unreachable.
- Fix that auth zone fails over to next master for timeout in tcp.
- Squelch SSL read and write connection reset by peer and broken pipe
messages. Verbosity 2 and higher enables them.
- Update python documentation for init_standard().
- Typos.
- Fix tls write event for read state change to re-call SSL_write and
not resume the TLS handshake.
- Better braces in if statement in TCP fastopen code.
- iana portlist updated.
- Scrub RRs from answer section when reusing NXDOMAIN message for
subdomain answers.
- For harden-below-nxdomain: do not consider a name to be non-exitent
when message contains a CNAME record.
- Fix wrong query name in local zone redirect answers with a CNAME,
the copy of the local alias is in unpacked form.
- contrib/fastrpz.patch updated for code changes, and with git diff.
- Fix #29: Solaris 11.3 and missing symbols be64toh, htobe64.
- Fix #30: AddressSanitizer finding in lookup3.c. This sets the
hash function to use a slower but better auditable code that does
not read beyond array boundaries. This makes code better security
checkable, and is better for security. It is fixed to be slower,
but not read outside of the array.
- Fix edns-subnet locks, in error cases the lock was not unlocked.
- Fix doxygen output error on readme markdown vignettes.
- Squelch log messages from tcp send about connection reset by peer.
They can be enabled with verbosity at higher values for diagnosing
network connectivity issues.
- Attempt to fix malformed tcp response.
- Fix #31: swig 4.0 and python module.
- Note that so-reuseport at extreme load is better turned off,
otherwise queries are not distributed evenly, on Linux 4.4.x.
- Fix that spoolbuf is not used to store tcp pipelined response
between mesh send and callback end.
- Fix double file close in tcp pipelined response code.
- Fix to define _OPENBSD_SOURCE to get reallocarray on NetBSD.
- Fix to guard _OPENBSD_SOURCE from redefinition.
- Fix that fixes the Fix that spoolbuf is not used to store tcp
pipelined response between mesh send and callback end, this fixes
error cases that did not use the correct spoolbuf.
- Fix that fixes the Fix that spoolbuf is not used to store tcp
pipelined response between mesh send and callback end, this fixes
error cases that did not use the correct spoolbuf.
- Fix another spoolbuf storage code point, in prefetch.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages