Mailinglist Archive: opensuse-factory (466 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190617 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Wed, 19 Jun 2019 11:02:02 +0000
  • Message-id: <156094212270.6642.13774331009255495286@go-agent-stagingbot-1>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190617

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
MozillaThunderbird (60.7.0 -> 60.7.1)
adobe-sourceserifpro-fonts (2.010 -> 3.000)
gpgme (1.13.0 -> 1.13.1)
libarchive (3.3.3 -> 3.4.0)
libfm
media-player-info
osinfo-db
perl-Crypt-Rijndael (1.13 -> 1.14)
postfix
rpcbind
scout (0.2.1+20181004.20a0aae -> 0.2.2+20190613.e6c2668)
speech-dispatcher
usb_modeswitch
virtualbox
wireless-regdb (2019.03.01 -> 2019.06.03)
wireshark

=== Details ===

==== MozillaThunderbird ====
Version update (60.7.0 -> 60.7.1)
Subpackages: MozillaThunderbird-translations-common

- Mozilla Thunderbird 60.7.1
* fixed: No prompt for smartcard PIN when S/MIME signing is used
MFSA 2019-17 (boo#1137595)
* CVE-2019-11703 (bmo#1553820)
Heap buffer overflow in icalparser.c
* CVE-2019-11704 (bmo#1553814)
Heap buffer overflow in icalvalue.c
* CVE-2019-11705 (bmo#1553808)
Stack buffer overflow in icalrecur.c
* CVE-2019-11706 (bmo#1555646)
Type confusion in icalproperty.c
- Increase disk space requirements in _constraints.

==== adobe-sourceserifpro-fonts ====
Version update (2.010 -> 3.000)

- Update to 3.000 (Roman and Italic have now the same version):
Changes to Italic styles:
* extend Latin character set from AL-3 to AL-4
* add Cyrillic (covering AC-2)
* add Greek (covering AG-1)
Changes to Roman styles:
* minor updates to spacing of modifer glyphs
* updates to some Cyrillic characters as suggested by external
advisors
* minor updates to Cyrillic kerning
* updates to some Greek characters as suggested by external
advisors
Global changes:
* overhaul ccmp feature to decompose accented glyphs when
followed by combining
* mark, thus allowing double-stacking of accents (addresses
[#41], #42)
* add ccmp solution for Ukrainian ?? clash, also for Latin ïï
(addresses #48)
* add Bulgarian Cyrillic alternates both via locl and ss01 feature
(addresses #20)
* add Serbian/Macedonian Cyrillic alternates both via locl and
ss02 feature
Roman and Italic styles now support the same global character set,
in both static and variable versions.

==== gpgme ====
Version update (1.13.0 -> 1.13.1)
Subpackages: libgpgme11 libgpgmepp6 libqgpgme7

- gpgme 1.13.1:
* core: At debug levels up to 9 print only an ascii dump.
* core: Add commented debug helper to posix-io.c.
* core: Fix error return value of _gpgme_run_io_cb.
* core: Prettify _gpgme_io_select debug output again and fix TRACE_SYSRES.
* core: Improve the debug messages even more.
* core: Avoid explicit locks in the debug code.
* json: Print "nan", "-inf", "inf" if needed.
* json: Improve handling of large exponents in the JSON parsor.
* core: Implement recpstring option parsing for gpgsm.
* core: Make gpgme_op_encrypt_ext work for CMS.
* python: Fix typo in DecryptionError exception.
* python: Make EXTRA_DIST files explicit.
* Python, doc: Minor style improvement.
* Always use maintainer mode -Wno cflags.
* cpp: Fix initialization warning.
* python: stop raising BadSignatures from decrypt(verify=True)
* cpp: Add wrapper for gpgme_set_global_flag.
* core: Fix duplication of close_notify_handler for gpgsm.

==== libarchive ====
Version update (3.3.3 -> 3.4.0)
Subpackages: bsdtar libarchive13

- Update to version 3.4.0
* Support for file and directory symlinks on Windows
* Read support for RAR 5.0 archives
* Read support for ZIPX archives with xz, lzma, ppmd8 and
bzip2 compression
* Support for non-recursive list and extract
* New tar option: --exclude-vcs
* Improved file attribute support on Linux and file flags support
on FreeBSD
* Fix reading Android APK archives (#1055 )
* Fix problems related to unreadable directories (#1167)
* A two-digit number of OSS-Fuzz issues was resolved in this release
- Add libarchive.keyring and validate the tarball signature
- Drop all security patches, fixed upstream:
* CVE-2018-1000877.patch
* CVE-2018-1000878.patch
* CVE-2018-1000879.patch
* CVE-2018-1000880.patch
* CVE-2019-1000019.patch
* CVE-2019-1000020.patch

==== libfm ====
Subpackages: libfm-gtk4 libfm-lang libfm4

- Removed calls to update-mime-database/update-desktop-database
from scriptlets: They are automatically performed via RPM file
triggers.
- Ran spec-cleaner.

==== media-player-info ====

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini

==== osinfo-db ====

- Add official release date for sle15sp1
add-sle15sp1-support.patch

==== perl-Crypt-Rijndael ====
Version update (1.13 -> 1.14)

- updated to 1.14
see /usr/share/doc/packages/perl-Crypt-Rijndael/Changes

==== postfix ====
Subpackages: postfix-doc

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini

==== rpcbind ====

- change rpcbind locking path from /var/run/rpcbind.lock to
/run/rpcbind.lock (bsc#1134659)
add 0001-change-lockingdir-to-run.patch
- change the order of socket/service in the %postun scriptlet to
avoid an error from rpcbind.socket when rpcbind is running
during package update

==== scout ====
Version update (0.2.1+20181004.20a0aae -> 0.2.2+20190613.e6c2668)
Subpackages: command-not-found

- Update to version 0.2.2+20190613.e6c2668:
* Bump version to 0.2.2
* Fix bug where sbin packages would print as bytes strings
* Newly generated po files (new line numbers).
* The make_trans script did not work, because strings were not marked because
of eval
* Fix bash i18n support. The translations are expanded during definition of
the function, when LANG is not yet set. Use eval to postpone it.
* Fix i18n support.
* Updated translations

==== speech-dispatcher ====
Subpackages: libspeechd2 python3-speechd speech-dispatcher-configure
speech-dispatcher-module-espeak

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini

==== usb_modeswitch ====
Subpackages: usb_modeswitch-data

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini

==== virtualbox ====
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- Fix build for SLE15 SP1 - add file "fixes_for_SLE15.patch"

==== wireless-regdb ====
Version update (2019.03.01 -> 2019.06.03)

- Update to version 2019.06.03 (boo#1138177):
* Expand 60 GHz band for Japan to 57-66 GHz
* update source of information for CU
* Update regulatory rules for South Korea
* Update regulatory rules for Japan (JP) on 5GHz
* update source of information for ES

==== wireshark ====
Subpackages: libwireshark12 libwiretap9 libwscodecs2 libwsutil10 wireshark-ui-qt

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini


N�����r��y隊Z)z{.���r�+�맲��r��z�^�ˬz��N�(�֜��^� ޭ隊Z)z{.���r�+��0�������Ǩ�
< Previous Next >