Mailinglist Archive: opensuse-factory (466 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190614 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Mon, 17 Jun 2019 15:01:07 +0000
  • Message-id: <156078366741.30055.14134848665399015612@go-agent-stagingbot-6>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190614

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
NetworkManager-applet (1.8.20 -> 1.8.22)
akonadi-calendar (19.04.1 -> 19.04.2)
akonadi-calendar-tools (19.04.1 -> 19.04.2)
akonadi-contact (19.04.1 -> 19.04.2)
akonadi-import-wizard (19.04.1 -> 19.04.2)
akonadi-mime (19.04.1 -> 19.04.2)
akonadi-notes (19.04.1 -> 19.04.2)
akonadi-search (19.04.1 -> 19.04.2)
akonadi-server (19.04.1 -> 19.04.2)
akregator (19.04.1 -> 19.04.2)
analitza (19.04.1 -> 19.04.2)
ark (19.04.1 -> 19.04.2)
baloo5-widgets (19.04.1 -> 19.04.2)
blinken (19.04.1 -> 19.04.2)
bovo (19.04.1 -> 19.04.2)
calendarsupport (19.04.1 -> 19.04.2)
cervisia (19.04.1 -> 19.04.2)
cups-filters (1.22.5 -> 1.25.0)
curl (7.65.0 -> 7.65.1)
dolphin (19.04.1 -> 19.04.2)
dragonplayer (19.04.1 -> 19.04.2)
epiphany (3.32.2 -> 3.32.3)
eventviews (19.04.1 -> 19.04.2)
ffmpegthumbs (19.04.1 -> 19.04.2)
gdm (3.28.2 -> 3.32.0)
grantleetheme (19.04.1 -> 19.04.2)
gstreamer (1.14.4 -> 1.14.5)
gstreamer-editing-services (1.14.4 -> 1.14.5)
gstreamer-plugins-bad (1.14.4 -> 1.14.5)
gstreamer-plugins-base (1.14.4 -> 1.14.5)
gstreamer-plugins-good (1.14.4 -> 1.14.5)
gstreamer-plugins-libav (1.14.4 -> 1.14.5)
gstreamer-plugins-ugly (1.14.4 -> 1.14.5)
gstreamer-rtsp-server (1.14.4 -> 1.14.5)
gstreamer-validate (1.14.4 -> 1.14.5)
gwenview5 (19.04.1 -> 19.04.2)
hddtemp
incidenceeditor (19.04.1 -> 19.04.2)
jasper
juk (19.04.1 -> 19.04.2)
kaccounts-integration (19.04.1 -> 19.04.2)
kaccounts-providers (19.04.1 -> 19.04.2)
kaddressbook (19.04.1 -> 19.04.2)
kalarmcal (19.04.1 -> 19.04.2)
kalgebra (19.04.1 -> 19.04.2)
kalzium (19.04.1 -> 19.04.2)
kamera (19.04.1 -> 19.04.2)
kanagram (19.04.1 -> 19.04.2)
kapptemplate (19.04.1 -> 19.04.2)
kate (19.04.1 -> 19.04.2)
katomic (19.04.1 -> 19.04.2)
kblackbox (19.04.1 -> 19.04.2)
kblocks (19.04.1 -> 19.04.2)
kbounce (19.04.1 -> 19.04.2)
kbreakout (19.04.1 -> 19.04.2)
kbruch (19.04.1 -> 19.04.2)
kcachegrind (19.04.1 -> 19.04.2)
kcalc (19.04.1 -> 19.04.2)
kcalcore (19.04.1 -> 19.04.2)
kcalutils (19.04.1 -> 19.04.2)
kcharselect (19.04.1 -> 19.04.2)
kcolorchooser (19.04.1 -> 19.04.2)
kcontacts (19.04.1 -> 19.04.2)
kcron (19.04.1 -> 19.04.2)
kdav (19.04.1 -> 19.04.2)
kde-print-manager (19.04.1 -> 19.04.2)
kdeedu-data (19.04.1 -> 19.04.2)
kdegraphics-thumbnailers (19.04.1 -> 19.04.2)
kdenetwork4-filesharing (19.04.1 -> 19.04.2)
kdepim-addons (19.04.1 -> 19.04.2)
kdepim-apps-libs (19.04.1 -> 19.04.2)
kdepim-runtime (19.04.1 -> 19.04.2)
kdf (19.04.1 -> 19.04.2)
kdialog (19.04.1 -> 19.04.2)
kdiamond (19.04.1 -> 19.04.2)
kgeography (19.04.1 -> 19.04.2)
kget (19.04.1 -> 19.04.2)
kgoldrunner (19.04.1 -> 19.04.2)
khangman (19.04.1 -> 19.04.2)
khelpcenter5 (19.04.1 -> 19.04.2)
kidentitymanagement (19.04.1 -> 19.04.2)
kig (19.04.1 -> 19.04.2)
kimagemapeditor (19.04.1 -> 19.04.2)
kimap (19.04.1 -> 19.04.2)
kio-extras5 (19.04.1 -> 19.04.2)
kio_audiocd (19.04.1 -> 19.04.2)
kiriki (19.04.1 -> 19.04.2)
kiten (19.04.1 -> 19.04.2)
kitinerary (19.04.1 -> 19.04.2)
kjumpingcube (19.04.1 -> 19.04.2)
kldap (19.04.1 -> 19.04.2)
kleopatra (19.04.1 -> 19.04.2)
klettres (19.04.1 -> 19.04.2)
klines (19.04.1 -> 19.04.2)
kmag (19.04.1 -> 19.04.2)
kmahjongg (19.04.1 -> 19.04.2)
kmail (19.04.1 -> 19.04.2)
kmail-account-wizard (19.04.1 -> 19.04.2)
kmailtransport (19.04.1 -> 19.04.2)
kmbox (19.04.1 -> 19.04.2)
kmime (19.04.1 -> 19.04.2)
kmines (19.04.1 -> 19.04.2)
kmousetool (19.04.1 -> 19.04.2)
kmouth (19.04.1 -> 19.04.2)
kmplot (19.04.1 -> 19.04.2)
knavalbattle (19.04.1 -> 19.04.2)
knetwalk (19.04.1 -> 19.04.2)
knotes (19.04.1 -> 19.04.2)
kolf (19.04.1 -> 19.04.2)
kollision (19.04.1 -> 19.04.2)
kolourpaint (19.04.1 -> 19.04.2)
kompare (19.04.1 -> 19.04.2)
konquest (19.04.1 -> 19.04.2)
konsole (19.04.1 -> 19.04.2)
kontact (19.04.1 -> 19.04.2)
kontactinterface (19.04.1 -> 19.04.2)
kopete (19.04.1 -> 19.04.2)
korganizer (19.04.1 -> 19.04.2)
kpat (19.04.1 -> 19.04.2)
kpimtextedit (19.04.1 -> 19.04.2)
kpkpass (19.04.1 -> 19.04.2)
kqtquickcharts (19.04.1 -> 19.04.2)
krdc (19.04.1 -> 19.04.2)
kreversi (19.04.1 -> 19.04.2)
krfb (19.04.1 -> 19.04.2)
kruler (19.04.1 -> 19.04.2)
kshisen (19.04.1 -> 19.04.2)
ksirk (19.04.1 -> 19.04.2)
ksmtp (19.04.1 -> 19.04.2)
kspaceduel (19.04.1 -> 19.04.2)
ksquares (19.04.1 -> 19.04.2)
ksudoku (19.04.1 -> 19.04.2)
ksystemlog (19.04.1 -> 19.04.2)
kteatime (19.04.1 -> 19.04.2)
ktimer (19.04.1 -> 19.04.2)
ktnef (19.04.1 -> 19.04.2)
ktouch (19.04.1 -> 19.04.2)
ktuberling (19.04.1 -> 19.04.2)
kturtle (19.04.1 -> 19.04.2)
kubrick (19.04.1 -> 19.04.2)
kwalletmanager5 (19.04.1 -> 19.04.2)
kwordquiz (19.04.1 -> 19.04.2)
ldns
libgravatar (19.04.1 -> 19.04.2)
libkcddb (19.04.1 -> 19.04.2)
libkcompactdisc (19.04.1 -> 19.04.2)
libkdcraw (19.04.1 -> 19.04.2)
libkdegames (19.04.1 -> 19.04.2)
libkdepim (19.04.1 -> 19.04.2)
libkeduvocdocument (19.04.1 -> 19.04.2)
libkexiv2 (19.04.1 -> 19.04.2)
libkgapi (19.04.1 -> 19.04.2)
libkipi (19.04.1 -> 19.04.2)
libkleo (19.04.1 -> 19.04.2)
libkmahjongg (19.04.1 -> 19.04.2)
libkomparediff2 (19.04.1 -> 19.04.2)
libksane (19.04.1 -> 19.04.2)
libksieve (19.04.1 -> 19.04.2)
llvm8 (7.0.1 -> 8.0.0)
lokalize (19.04.1 -> 19.04.2)
lskat (19.04.1 -> 19.04.2)
mailcommon (19.04.1 -> 19.04.2)
mailimporter (19.04.1 -> 19.04.2)
mbox-importer (19.04.1 -> 19.04.2)
messagelib (19.04.1 -> 19.04.2)
mobipocket (19.04.1 -> 19.04.2)
okular (19.04.1 -> 19.04.2)
open-iscsi
openslp
openssl-1_1
parley (19.04.1 -> 19.04.2)
perl-Image-ExifTool (11.30 -> 11.50)
pim-data-exporter (19.04.1 -> 19.04.2)
pim-sieve-editor (19.04.1 -> 19.04.2)
pimcommon (19.04.1 -> 19.04.2)
postfix
protobuf-c
python-PyYAML (5.1 -> 5.1.1)
python-gst (1.14.4 -> 1.14.5)
signon-kwallet-extension (19.04.1 -> 19.04.2)
spectacle (19.04.1 -> 19.04.2)
step (19.04.1 -> 19.04.2)
sweeper (19.04.1 -> 19.04.2)
taglib (1.11.1+git20181028 -> 1.11.2~git20190601)
tbb (2019_20190410 -> 2019_20190605)
umbrello (19.04.1 -> 19.04.2)
vala (0.44.3 -> 0.44.4)
zimg (2.8 -> 2.9)

=== Details ===

==== NetworkManager-applet ====
Version update (1.8.20 -> 1.8.22)
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor
libnma0 nma-data typelib-1_0-NMA-1_0

- Revert back to pkgconfig(appindicator3-0.1) BuildRequires: We do
not want to pull mate desktop into staging. Sub with
pkgconfig(ayatana-appindicator3-0.1) BuildRequires was rejected.
- Update to version 1.8.22:
+ The applet's secret agent can now utilize external UI mode for
VPN plugins that support it.
+ The Wi-Fi-related items in the applet menu are now sorted more
reasonably.
+ Various improvements to the Mobile Wizard and Certificate
Chooser usability.
+ Render a QR code in the applet's connection info dialog.
+ Improved the applet's info dialog appearance.
+ Updated translations.
- Disable feature-app-indicator-desktop-file.patch: Needs rebase.
- Rebase
NetworkManager-gnome-bsc1003069-default-agent-owned-secrets.patch
with quilt.
- Rename lang subpackage following openSUSE
translation-update-upstream changes.
- Build against Ayatana Indicators instead as it's considered
the new upstream

==== akonadi-calendar ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix the akonadi-calendar dependencies

==== akonadi-calendar-tools ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-calendar-tools-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== akonadi-contact ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix the akonadi-contacts dependencies

==== akonadi-import-wizard ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== akonadi-mime ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix the akonadi-mime dependencies

==== akonadi-notes ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix the akonadi-notes dependencies

==== akonadi-search ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== akonadi-server ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Add some missing dependencies in KF5AkonadiConfig.cmake
* Fix QTimer being leaked in MonitorPrivate
* Port ExternalPartStorage::self to C++11 singleton syntax.
* autotests: fix leak of FakeServerData and FakeSession
* Fix FakeAkonadiServerCommands being leaked
* Fix leaking of requests in ItemRetriever::exec()
* Fix another null-sender warning in itemretrievertest
* monitornotificationtest: create FakeItemCache on stack
* Properly cleanup in notificationmanagertest
* Fix QObject::connect warning in itemretrievertest
* Remove dead code in NotificationManager
* itemsynctest: comment out the checks that make no sense.
* Fix memory leaks in attributefactorytest
* Fix memory leak of ItemRetrievalJobFactory in ItemRetrievalManager
* Fix previous commit, we can't use ecm_add_test because we do add_test
ourselves
* Ensure that qsqlite3.so is found in the builddir while running tests.
* akonadi: port to ecm_add_test
* Fix memory leak due to getTestMonitor()
* Akonadi: fix compilation with clang
* Fix memory leaks (found by ASAN)

==== akregator ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akregator-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix crashes with Qt 5.12 (kde#371511)
* Add DesktopEntry to notifyrc
- Dropped patches, now upsteam:
* Fix-crashes-with-Qt-5.12.patch

==== analitza ====
Version update (19.04.1 -> 19.04.2)
Subpackages: analitza-lang libAnalitza5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Improve debugging information
* Fix evaluation of matrixes

==== ark ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ark-lang libkerfuffle19

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Get columns to show from first file entry (kde#406135)
* Stop crashing when invoking batch mode without urls

==== baloo5-widgets ====
Version update (19.04.1 -> 19.04.2)
Subpackages: baloo5-widgets-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== blinken ====
Version update (19.04.1 -> 19.04.2)
Subpackages: blinken-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== bovo ====
Version update (19.04.1 -> 19.04.2)
Subpackages: bovo-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== calendarsupport ====
Version update (19.04.1 -> 19.04.2)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== cervisia ====
Version update (19.04.1 -> 19.04.2)
Subpackages: cervisia-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== cups-filters ====
Version update (1.22.5 -> 1.25.0)

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini
- Update to version 1.25.0:
* pdftoijs, pdftoopvp: Removed these deprecated filters
completely as there is no demand for them any more. They also
used unstable, undocumented APIs of Poppler.
* pdftoraster: Changed from using unstable, undocumented APIs of
Poppler to stable, documented ones, to improve maintainability
of this filter, and with it of the cups-filters package.
* libcupsfilters: Added support for color spaces CMY and RGBW
when using filters without PPD file (mainly for development and
debugging, option "print-color-mode" with values "cmy-XX" and
"rgbw-XX" with XX being the number of bits per color).
- Changes from version 1.24.0:
* cups-browsed: Integration of Deepak Patankar's Google Summer of
Code 2018 project with the main goal of clustering different
printers and automatically selecting the destination printers
by job content and option/attribute settings.
* cups-browsed, implicitclass: Support for mixed clusters of
remote CUPS queues and IPP network printers. For this PPD files
of remote CUPS queues are generated by cups-browsed based on
IPP queries, as for native IPP printers, the number of jobs for
load balancing is polled in a way that it works also with
native IPP printers, the implicitclass backend sends jobs
directly to the printer instead of re-queueing them via CUPS.
* cups-browsed: Merge IPP attributes of several printers to
combined attributes for the cluster to generate the cluster's
PPD file, including PPD constraints for option combinations not
fulfillable by any of the member printers, and finding
reasonable, non-conflicting default settings.
* cups-browsed: Selection algorithm for the destination printer
for a job sent to the cluster. Based on the job settings
requested such as page size, media type, print quality, the
best most suitable printer in the cluster for the job will be
selected.
* cups-browsed, implicitclass: Filter jobs to clusters already
locally. Due to the fact that a cluster's member printers are
not exclusively non-raw CUPS queues with the complete filtering
framework on the remote server, but also native IPP printers,
we need to support generic driverless printers as destination.
So we cannot pass on the input data unfiltered but need to
filter locally. We let the cluster's PPD file emulate a PDF
printer, letting the local CUPS queue of the cluster run
pdftopdf and any pre-filters to turn the input into PDF and we
let the implicitclass backend turn PDF into a format understood
by the destination printer, supporting the 4 formats of
driverless IPP printing: PDF, PWG Raster, Apple Raster, PCLm.
- Drop libpoppler-cpp0, libpoppler-devel and libpoppler-glib-devel
BuildRequires.
- Add pkgconfig(poppler-cpp) BuildRequires following upstream
changes.
- Update to version 1.23.0:
* This release adds support for the "print-scaling" IPP attribute
and has the code for the support of MuPDF as PDF renderer
vastly simplified.
* pdftops, mupdftoraster: Let pdftops call mutool directly and so
that it directly outputs PostScript, eliminating the need to
call the mupdftoraster and rastertops filters.
* mupdftoraster: Reduced the use of temporary files from 3 to
just one.
* imagetopdf, imagetoraster, pdftopdf: Add support for
print-scaling option.
- Changes from version 1.22.6:
* Bug fix release, to address a further issue of cups-browsed
removing user-created print queues, to make
grayscale/monochrome PostScript jobs of colored input file
actually output grayscale/monochrome files, to fix several bugs
when using MuPDF as PDF renderer, and to silence compiler
warnings.

==== curl ====
Version update (7.65.0 -> 7.65.1)
Subpackages: libcurl4

- Update to 7.65.1
* Bugfixes:
- CURLOPT_LOW_SPEED_* repaired
- NTLM: reset proxy "multipass" state when CONNECT request is done
- PolarSSL: deprecate support step 1. Removed from configure
- cmake: check for if_nametoindex()
- cmake: support CMAKE_OSX_ARCHITECTURES when detecting SIZEOF variables
- conncache: Remove the DEBUGASSERT on length check
- conncache: make "bundles" per host name when doing proxy tunnels
- curl_share_setopt.3: improve wording
- dump-header.d: spell out that no headers == empty file
- example/http2-download: fix format specifier
- examples: cleanups and compiler warning fixes
- http2: Stop drain from being permanently set
- http: don't parse body-related headers in bodyless responses
- md4: build correctly with openssl without MD4
- md4: include the mbedtls config.h to get the MD4 info
- multi: track users of a socket better
- nss: allow to specify TLS 1.3 ciphers if supported by NSS
- parse_proxy: make sure portptr is initialized
- parse_proxy: use the IPv6 zone id if given
- sectransp: handle errSSLPeerAuthCompleted from SSLRead()
- singlesocket: use separate variable for inner loop
- ssl: Update outdated "openssl-only" comments for supported backends
- tests: add HAProxy keywords
- tests: make test 1420 and 1406 work with rtsp-disabled libcurl
- tls13-docs: mention it is only for OpenSSL >= 1.1.1
- tool_setopt: for builds with disabled-proxy, skip all proxy setopts()
- url: fix bad feature-disable #ifdef
- url: use correct port in ConnectionExists()

==== dolphin ====
Version update (19.04.1 -> 19.04.2)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Elide tab titles left so key information at the end of the string doesn't
get cut off (kde#406569)

==== dragonplayer ====
Version update (19.04.1 -> 19.04.2)
Subpackages: dragonplayer-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== epiphany ====
Version update (3.32.2 -> 3.32.3)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Update to version 3.32.3:
+ Fix preferences language button sensitivity.
+ Fix crash opening preferences dialog in weird locales.
+ Fix manage additional URLs web apps preference.
+ Fix blob and data URIs in web apps.
+ Fix migration permanently corrupting web apps if migrated
before main profile.
+ Fix crashes when safe browsing database is recreated.
+ Fix crash in downloads code.
+ Fix critical when starting web apps.

==== eventviews ====
Version update (19.04.1 -> 19.04.2)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ffmpegthumbs ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ffmpegthumbs-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== gdm ====
Version update (3.28.2 -> 3.32.0)
Subpackages: gdm-lang gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Fixup gdm.tmpfiles (boo#1135272).
- Make systemd service file optional instead of outright deleting it.
- Update gdm-switch-to-tty1.patch (bsc#1120307)
- New solution for auto login problem(bsc#1116011)
+ Drop gdm-revert-commit-39fb4ff.patch
+ Add reserveVT.conf file.
- Add gdm-remove-duplicate-sessions.patch: Backport from upstream
commit 187c8515 and 1795bb31 to remove duplicate sessions once,
after all sessions have been processed (boo#1131625,
glgo#GNOME/gdm#473).
- Add gdm-s390-not-require-g-s-d_wacom.patch: Remove the gnome
session runtime requirement of g-s-d Wacom plugin because it is
not build on s390 (bsc#1129412).
- Rebase patches (boo#1128589):
+ gdm-sysconfig-settings.patch
+ gdm-default-wm.patch
+ gdm-xauthlocalhostname.patch
+ gdm-kill-user-session.patch
+ gdm-fails-to-restart-gnome-shell.patch
+ gdm-add-runtime-option-to-disable-starting-X-server-as-u.patch
- Re-enable gdm-switch-to-tty1.patch
- Add gdm-revert-commit-39fb4ff.patch: Make auto login successful
(bsc#1116011).
- Update to version 3.32.0:
+ Stable release version bump.
- Update to version 3.31.91:
+ Screen lock bypass fix (when timed login is enabled)
(CVE-2019-3825).
+ PAM file updates.
+ Improved debug logging.
+ Keyboard layout fixes.
+ Display foreach handling.
+ Updated translations.
- Changes from version 3.31.4:
+ DOAP file fixes.
+ Misc code clean ups.
+ Filter out duplicates from session list.
+ Updated translations.
- Disable patches needing rebase:
+ gdm-sysconfig-settings.patch
+ gdm-kill-user-session.patch
+ gdm-default-wm.patch
+ gdm-xauthlocalhostname.patch
+ gdm-switch-to-tty1.patch
+ gdm-fails-to-restart-gnome-shell.patch
+ gdm-add-runtime-option-to-disable-starting-X-server-as-u.patch
- Rebase patches with quilt, but sadly not enough, hence the
massive disabling of patches.
- Drop gdm-ignore-duplicate-desktop-file.patch: Fixed upstream.
- Drop old hack only needed for upgrades from pre SLED 12 and
openSUSE 10.3.
- Test if we still need to nuke data/61-gdm.rules, aka disable rm.
- Update to version 3.30.3:
+ Screen lock bypass fix (when timed login is enabled)
(CVE-2019-3825).
+ Updated translations.
- Drop gdm-CVE-2019-3825.patch: Fixed upstream.
- Add gdm-kill-user-session.patch: Kill all sessions when stopping
gdm service
(bsc#1112294 bsc#1120307 bsc#1113245 glgo#GNOME/gdm#400).
- Add gdm-switch-to-tty1.patch: Switch to tty1 when stopping gdm
service (bsc#1113700).
- Drop gdm-plymouth-vt1.patch: Replaced by gdm-switch-to-tty1.patch
- Add gdm-CVE-2019-3825.patch: Fix lock screen bypass when timed
login is enabled (boo#1124628, glgo#GNOME/gdm#460, CVE-2019-3825)
- Add gdm-ignore-duplicate-desktop-file.patch to ignore duplicate
desktop file with same "Name" value, including symlinks of
desktop files (bsc#1112834, glgo#GNOME/gdm#437).
- Drop gdm-ignore-duplicate-session.patch, the patch hardcodes
"default.desktop" while LightDM and SDDM treat symlinks as
aliases.
- Update to version 3.30.2:
+ Fix autologin crash.
+ Unlock keyring again on autologin with newerish systemds.
+ Fix initial-setup.
+ Updated translations.
- Drop patches fixed upstream:
+ gdm-fix-autologin.patch.
+ gdm-fix-initial-setup.patch.
- Add upstream patches:
+ gdm-fix-autologin.patch: as autologin got reworked and broken,
accessing the proper display variable should fix it.
+ gdm-fix-initial-setup.patch: as the initial-setup related post
work is done when stopping the greeter and this stop is delayed
until after the user session is started now, the post work
needs to be done before the user session is started.
- Re-add still needed 61-gdm.rules removal until glgo#GNOME/gdm#424
gets fixed.
- Update to version 3.30.1:
+ Make udev rule configurable.
+ Follow up fixes dealing with login screen reaping from two
releases ago.
+ Disable wayland on proprietary nvidia machines for now.
+ Updated translations.
- Drop gdm-make-udev-dir-configurable.patch: Fixed upstream.
- Update to version 3.30.0:
+ No visible changes for the user.
- Drop gdm-ignore-spurios-SeatNew-signal.patch: fixed upstream.
- Add gdm-make-udev-dir-configurable.patch: Make udev directory
configurable. Patch provided by upstream (glgo#GNOME/gdm!44).
- Rebase gdm-ignore-duplicate-session.patch.
- Update to version 3.29.92:
+ Search for sessions in XDG_DATA_DIRS.
+ Blacklist some more wayland unfriendly hardware.
+ Initial setup fix.
+ Flicker fix.
+ Misc bug fixes.
- Update to version 3.29.91:
+ CVE-2018-14424: double free fix.
+ Follow up fixes dealing with login screen reaping form last
release.
+ Add more debug logging.
+ Updated translations.
- Drop gdm-CVE-2018-14424.patch: Fixed upstream.
- Add gdm-ignore-spurios-SeatNew-signal.patch: Fix crashes.
- Update to version 3.28.4:
+ Add missing gdm-disable-wayland binary (fixes VM boots).
+ Disable wayland for certain server cards that mutter can't yet
handle sufficiently.
- Drop gdm-disable-wayland-on-unsupported-chipsets.patch: Fixed
upstream.
- Update to version 3.28.3:
+ CVE-2018-14424 - double free fix.
+ Lifecycle fixes to libgdm/GdmClient.
+ Follow up fixes dealing with login screen reaping from last
release.
+ Allow pam modules to use SIGUSR1.
+ Set PWD for user session.
+ Tell cirrus not to use wayland.
+ Updated translations.
- Drop gdm-CVE-2018-14424.patch: fixed upstream.
- Rebase gdm-disable-wayland-on-unsupported-chipsets.patch applying
it against data/61-gdm.rules.in instead of data/61-gdm.rules to
avoid hard coding directories.
- Add gdm-CVE-2018-14424.patch: Pass the display object rather than
the id in the removed signal, fix use-after-free of disposed
transient displays (CVE-2018-14424, glgo#GNOME#gdm#401,
boo#1103737).
- Update to version 3.29.90:
+ Display wayland on certain server machines.
+ Lifecycle fixes to libgdm/GdmClient.
+ Drop intltool.
+ Build goo clean ups
+ Kill login screen when not in use.
+ Cclean up stale utmp entries.
+ Misc fixes.
+ Updated translations.
- Rebase gdm-disable-wayland-on-unsupported-chipsets.patch.
- Disable
dm-add-runtime-option-to-disable-starting-X-server-as-u.patch:
Needs rebase.
- Refresh the following patches with quilt:
+ gdm-default-wm.patch.
+ gdm-fails-to-restart-gnome-shell.patch.
+ gdm-ignore-duplicate-session.patch.
+ gdm-plymouth-vt1.patch.
+ gdm-sysconfig-settings.patch
+ gdm-xauthlocalhostname.patch

==== grantleetheme ====
Version update (19.04.1 -> 19.04.2)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== gstreamer ====
Version update (1.14.4 -> 1.14.5)
Subpackages: gstreamer-lang gstreamer-utils libgstreamer-1_0-0
typelib-1_0-Gst-1_0

- Update to version 1.14.5:
+ aggregator:
- Take the pad lock around queue gap event removal.
- Don?t leak gap buffer when out of segment.
+ buffer: fix possible memory corruption in
gst_buffer_foreach_meta() when removing metas.
+ bus:
- Make removing of signal/bus watches thread-safe.
- Don?t allow removing signal watches with
gst_bus_remove_watch().
+ controlbinding: Check if the weak pointer was cleared before
explicitly removing it.
+ ptp clock: Wait for ANNOUNCE before selecting a master;
increase tolerance for late follow-up and delay-resp.
+ segment: Allow stop == -1 in gst_segment_to_running_time() and
negative rate.
+ g-i: annotations fixes.

==== gstreamer-editing-services ====
Version update (1.14.4 -> 1.14.5)
Subpackages: libges-1_0-0 typelib-1_0-GES-1_0

- Update to version 1.14.5:
+ Fix compilation with latest GLib.
+ layer: Resort clips before syncing priorities.
+ timeline: Better handle loading inconsistent timelines.

==== gstreamer-plugins-bad ====
Version update (1.14.4 -> 1.14.5)
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbadvideo-1_0-0 libgstbasecamerabinsrc-1_0-0
libgstcodecparsers-1_0-0 libgstisoff-1_0-0 libgstmpegts-1_0-0
libgstphotography-1_0-0 libgsturidownloader-1_0-0 libgstwayland-1_0-0
libgstwebrtc-1_0-0

- Update to version 1.14.5:
+ assrender: fix disappearing subtitles when seeking back in
time.
+ decklinkvideosink: fix segfault when audiosink is closed before
videosink.
+ decklinkvideosrc: respect pixel format property even if mode is
set to auto.
+ d3dvideosink: Fix calculating buffer size of packed format;
don?t leak thread object.
+ dtls: Don?t abort on non-fatal issues, make work with newer
OpenSSL versions.
+ msdk: more robust error handling; fix intel sdk libdir path.
+ nvenc: Ensure drain all frames on finish; fix element reuse and
clean up properly.
+ openh264dec: Fix handling of errors when doing EOS.
+ shmsrc: fixes a crash when is-live is true due a race
condition.
+ shmsink: fix possible (racy) deadlock on shutdown.
+ siren: Fix invalid floating point operation.
+ tsdemux: Skew correction improvements: use upstream DTS if set.
+ wasapi:
- Number of segments was always 2 (the absolute minimum) by
accident.
- Fix infinite loop when the device disappears.
- Drop gst-bad-fdkaac2-fix.patch: Fixed upstream.

==== gstreamer-plugins-base ====
Version update (1.14.4 -> 1.14.5)
Subpackages: gstreamer-plugins-base-lang libgstallocators-1_0-0 libgstapp-1_0-0
libgstaudio-1_0-0 libgstfft-1_0-0 libgstgl-1_0-0 libgstpbutils-1_0-0
libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0
libgsttag-1_0-0 libgstvideo-1_0-0 typelib-1_0-GstAudio-1_0
typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

- Update to version 1.14.5:
+ audioconvert: fix endianness conversion for unpacked formats
(e.g. S24_32BE).
+ audioringbuffer: Fix wrong memcpy address when reordering
channels.
+ decodebin2: Make sure to remove pad probes when freeing
GstDecodeGroup.
+ glviewconvert: fix output when a transformation matrix is used.
+ glupload:
- Prevent segfault when updating caps.
- dmabuf: be explicit about gl formats used.
+ gl/egl: Determine correct format on dmabuf import.
+ id3tag: validate the year from v1 tags before passing to
GstDateTime.
+ rtpbasepayload: Fix sequence numbers when using buffer lists.
+ rtspconnection:
- Fix security issue, potential heap overflow (CVE-2019-9928).
- Fix GError set over the top of a previous GError.
- Do not duplicate authentication headers.
+ subparse: don?t assert when failing to parse subrip timestamp.
+ video: various convert sample frame fixes.
+ video-converter: fix conversion from I420_10LE/BE, I420_12LE/BE,
A420_10LE/BE to BGRA/RGBA which created corrupted output.
+ video-format: Fix GBRA_10/12 alpha channel pixel strides.
- Drop upstream fixed patches:
+ CVE-2019-9928.patch
+ 0001-id3tag-Correctly-validate-the-year-from-v1-tags-befo.patch

==== gstreamer-plugins-good ====
Version update (1.14.4 -> 1.14.5)
Subpackages: gstreamer-plugins-good-extra gstreamer-plugins-good-gtk
gstreamer-plugins-good-jack gstreamer-plugins-good-lang
gstreamer-plugins-good-qtqml

- Update to version 1.14.5:
+ flv: Use 8kHz sample rate for alaw/mulaw audio.
+ flvdemux: Do not error out if the first added and chained pad
is not linked.
+ flvmux: try harder to make sure timestamps are always
increasing.
+ gdkpixbufdec: output a TIME segment which is what?s expected
for raw video.
+ matroskademux: fix handling of MS ACM audio.
+ matroska: fix handling of FlagInterlaced.
+ pulsesink: Deal with not being able to convert a format to
caps.
+ rtph265depay, rtph264depay; aggregation packet marker handling
fixes.
+ rtpmp4gdepay: detect broken senders who send AAC with ADTS
frames.
+ rtprawdepay: keep buffer pool around when flushing/seeking.
+ rtpssrcdemux: Forward serialized events to all pads.
+ qmlglsink: Handle OPENGL header guard changes.
+ qtdemux: fix track language code parsing; ignore corrupted CTTS
box.
+ qtmux: Correctly set tkhd width/height to the display size.
+ splitmuxsink:
- Various timecode meta handling fixes.
- Make work with audio-only encoders as muxers, e.g. wavenc
+ v4l2sink: fix pool-less allocation query handling.
+ v4l2dec/enc: fix use after free when handling events.
+ vpx: Fix build against libvpx 1.8.
+ webmmux: allow resolutions above 4096.
- Drop gstreamer-plugins-good-fix-vpx-build.patch: Fixed upstream.
- Drop automake and libtool BuildRequires and autogen.sh call: No
longer needed.

==== gstreamer-plugins-libav ====
Version update (1.14.4 -> 1.14.5)

- Update to version 1.14.5:
+ libav: Update internal snapshot to ffmpeg n3.4.6.
+ avdemux: fix negative pts if start_time is bigger than the ts.

==== gstreamer-plugins-ugly ====
Version update (1.14.4 -> 1.14.5)
Subpackages: gstreamer-plugins-ugly-lang

- Update to version 1.14.5:
+ sid: Fix cross-compilation by using AC_TRY_LINK instead of
AC_TRY_RUN.
+ x264: Only enable dynamic loading code for x264 before v253.

==== gstreamer-rtsp-server ====
Version update (1.14.4 -> 1.14.5)

- Update to version 1.14.5:
+ rtsp-client: Fix crash in close handler and remove timeout
GSource on cleanup.
+ rtsp-media:
- Handle set state when preparing.
- Fix race condition in finish_unprepare.
+ rtsp-stream:
- Use cached address when allocating sockets.
- Use seqnum-offset for rtpinfo.
- Add source elements to the pipeline before activation for
stream-status create message.

==== gstreamer-validate ====
Version update (1.14.4 -> 1.14.5)
Subpackages: libgstvalidate-1_0-0 typelib-1_0-GstValidate-1_0

- Update to version 1.14.5:
+ No changes provided upstream.

==== gwenview5 ====
Version update (19.04.1 -> 19.04.2)
Subpackages: gwenview5-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix build with exiv2-0.27.1

==== hddtemp ====

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini

==== incidenceeditor ====
Version update (19.04.1 -> 19.04.2)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== jasper ====

- bsc#1117508 CVE-2018-19540: Fix heap based overflow in jas_icctxtdesc_input
Add jasper-CVE-2018-19540.patch: Make sure asclen is at least 1
- bsc#1117507 CVE-2018-19541: Fix heap based overread in jas_image_depalettize
Add jasper-CVE-2018-19541.patch: Check number of lutents

==== juk ====
Version update (19.04.1 -> 19.04.2)
Subpackages: juk-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Add 'override' decl to fix compiler warnings, fix drag-and-drop.

==== kaccounts-integration ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kaccounts-providers ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kaccounts-providers-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kaddressbook ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kaddressbook-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kalarmcal ====
Version update (19.04.1 -> 19.04.2)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kalgebra ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kalgebra-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kalzium ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kalzium-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kamera ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kamera-lang kio_kamera

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kanagram ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kanagram-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kapptemplate ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kapptemplate-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kate ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kate-lang kate-plugins

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== katomic ====
Version update (19.04.1 -> 19.04.2)
Subpackages: katomic-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kblackbox ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kblackbox-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kblocks ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kblocks-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kbounce ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kbounce-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kbreakout ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kbreakout-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kbruch ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kbruch-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kcachegrind ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kcachegrind-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kcalc ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kcalc-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kcalcore ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Remove bogus TODO, this is a private header already so it's fine

==== kcalutils ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kcharselect ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kcharselect-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kcolorchooser ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kcolorchooser-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kcontacts ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kcron ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kcron-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kdav ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdav-lang libKPimKDAV5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kde-print-manager ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kde-print-manager-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kdeedu-data ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kdegraphics-thumbnailers ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kdenetwork4-filesharing ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdenetwork4-filesharing-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Properly enable and disable the table view in response to the guest checkbox
* Expand the permissions comboboxes to fill available space (kde#382085)
* Don't ever disable the OK button when the user is trying to remove a share
(kde#407698)
* Enable and disable the label too
* Enable and disable UI controls properly based on sharing status (kde#407500)

==== kdepim-addons ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdepim-addons-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Look for KF5ContactEditor before trying to use it
* Remove default shortcut. it will close main windows...

==== kdepim-apps-libs ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdepim-apps-libs-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Use the akonadi-contact version for KF5ContactEditor
* Add the missing KF5ContactEditor dependency

==== kdepim-runtime ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdepim-runtime-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Make sure that we reload settings
* Remove unused class member
* Improve debug messages
* Bug 407544: Fix crash when creating new KAlarm resource

==== kdf ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdf-lang kwikdisk

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kdialog ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdialog-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kdiamond ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdiamond-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kgeography ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kgeography-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kget ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kget-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kgoldrunner ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kgoldrunner-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== khangman ====
Version update (19.04.1 -> 19.04.2)
Subpackages: khangman-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== khelpcenter5 ====
Version update (19.04.1 -> 19.04.2)
Subpackages: khelpcenter5-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kidentitymanagement ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kig ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kig-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kimagemapeditor ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kimagemapeditor-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kimap ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kimap-lang libKF5IMAP5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kio-extras5 ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kio_audiocd ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kio_audiocd-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kiriki ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kiriki-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kiten ====
Version update (19.04.1 -> 19.04.2)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kitinerary ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Check IATA BCBP input a bit more strictly (kde#407895)
* Add German language support for the A&O hostel extractor
* Handle line continuations in Deutsche Bahn tickets
* More robust line continuation detection for the DB extractor
* Keep the ticket token in the RCT2 extractor
* Fix PNR extraction for some sort of DB/ÖBB cross-over ticket
* PNR is optional in SNCF booking confirmations (kde#404451)

==== kjumpingcube ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kjumpingcube-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kldap ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kldap-lang libKF5Ldap5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kleopatra ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kleopatra-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix copy&paste error that breaks gpg process calls (kde#407594)

==== klettres ====
Version update (19.04.1 -> 19.04.2)
Subpackages: klettres-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== klines ====
Version update (19.04.1 -> 19.04.2)
Subpackages: klines-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kmag ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmag-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kmahjongg ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmahjongg-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kmail ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* const'ify method here
* Fix crash when we want to open it in akonadi console
* Archive now can't work as config dialog is a separate process now.
* Bug 407967 - new mail: cursor jumps into blindcarboncopy (kde#407967)
* We can save several email as mbox
- Add upstream patch to fix a kontact crash on logout (kde#404881):
* fix-kontact-crash-on-logout.patch
- Dropped patches, now upstream:
* Fix-Bug-407967.patch

==== kmail-account-wizard ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmail-account-wizard-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kmailtransport ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kmbox ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kmime ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmime-lang libKF5Mime5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kmines ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmines-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Drop unused kmines.notifyrc
* Add .arcconfig

==== kmousetool ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmousetool-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kmouth ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmouth-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kmplot ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kmplot-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Use layouts for QDialogs to make KmPlot adopt the sizes (kde#407980)

==== knavalbattle ====
Version update (19.04.1 -> 19.04.2)
Subpackages: knavalbattle-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== knetwalk ====
Version update (19.04.1 -> 19.04.2)
Subpackages: knetwalk-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== knotes ====
Version update (19.04.1 -> 19.04.2)
Subpackages: knotes-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kolf ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kolf-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kollision ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kollision-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kolourpaint ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kolourpaint-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kompare ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kompare-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== konquest ====
Version update (19.04.1 -> 19.04.2)
Subpackages: konquest-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== konsole ====
Version update (19.04.1 -> 19.04.2)
Subpackages: konsole-part konsole-part-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kontact ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kontact-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kontactinterface ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kopete ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kopete-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== korganizer ====
Version update (19.04.1 -> 19.04.2)
Subpackages: korganizer-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kpat ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kpat-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kpimtextedit ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Remove Broken emoji
* Not necessary to duplicate info in tooltip
* Use NotoColorEmoji font
* Use NotoColorEmoji font here

==== kpkpass ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKPimPkPass5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kqtquickcharts ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== krdc ====
Version update (19.04.1 -> 19.04.2)
Subpackages: krdc-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kreversi ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kreversi-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== krfb ====
Version update (19.04.1 -> 19.04.2)
Subpackages: krfb-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kruler ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kruler-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kshisen ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kshisen-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ksirk ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ksirk-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ksmtp ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kspaceduel ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kspaceduel-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ksquares ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ksquares-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ksudoku ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ksudoku-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix opening saved games (kde#407768)

==== ksystemlog ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ksystemlog-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kteatime ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kteatime-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== ktimer ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ktimer-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ktnef ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ktouch ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ktouch-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== ktuberling ====
Version update (19.04.1 -> 19.04.2)
Subpackages: ktuberling-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kturtle ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kturtle-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== kubrick ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kubrick-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kwalletmanager5 ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kwalletmanager5-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== kwordquiz ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kwordquiz-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== ldns ====
Subpackages: libldns2

- Add ldns-swig4.0.patch: Fix build wih SWIG 4.0 (boo#1135750).

==== libgravatar ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== libkcddb ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkcompactdisc ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkdcraw ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkdegames ====
Version update (19.04.1 -> 19.04.2)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkdepim ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Statusbar progress widget: update up/down icon when dialog goes away
* Statusbar progress widget code cleanup: pass Mode to setMode
* Statusbar progress widget: show button immediately

==== libkeduvocdocument ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkexiv2 ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkgapi ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== libkipi ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkleo ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== libkmahjongg ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libkomparediff2 ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libksane ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5Sane5 libksane-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== libksieve ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libksieve-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== llvm8 ====
Version update (7.0.1 -> 8.0.0)
Subpackages: libc++-devel libc++1 libc++abi-devel libc++abi1

- Avoid relocation overflow on ppc by not building GPU backends.
- Update baselibs.conf.

==== lokalize ====
Version update (19.04.1 -> 19.04.2)
Subpackages: lokalize-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== lskat ====
Version update (19.04.1 -> 19.04.2)
Subpackages: lskat-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== mailcommon ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix a potential build issue when building KMail (kde#407163)

==== mailimporter ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== mbox-importer ====
Version update (19.04.1 -> 19.04.2)
Subpackages: mbox-importer-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== messagelib ====
Version update (19.04.1 -> 19.04.2)
Subpackages: messagelib-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* It's not necessary to create a view.
* enable TemplateParserJobTest::test_replyPlain again.
* Refresh TemplateParserJobTest::test_convertedHtml logic
* Decryption Oracle based on forwarding PGP or S/MIME mails (CVE-2019-10732)
(kde#404698)
* Make unexpected data leak harder via reply. (kde#404698)
* Rename convertedHtmlContent-> convertedHtmlContent for reply_Plain
* TemplateParser: test htmlReply.
* Add test cases for a Decryption Oracle based on PGP inline.
* templateparserjobtest: HTML mime parts are handled differently
* Add test for a normal encrypted message, to make sure decryption works.
* Test mails for Decryption Oracle based on replying to PGP or S/MIME.
(kde#404698)
* MimeTreeParser returns wrong content for inline messages with multiple
encrypted blocks.
* Distinguish between mMsg and mOrigMsg.

==== mobipocket ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== okular ====
Version update (19.04.1 -> 19.04.2)
Subpackages: okular-lang okular-spectre

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* [EPubGenerator] Avoid pointless scans of the whole document
* [EPubGenerator] Avoid crashes due to bogus wrapping of content in table
(kde#406738, kde#407140)
* Revert "Fix build with poppler < 0.51"
* Fix build with poppler < 0.51
* Fix line annotation leader line angle

==== open-iscsi ====
Subpackages: iscsiuio libopeniscsiusr0_2_0

- BuildRequire pkgconfig(systemd) instead of systemd: allow OBS to
shortcut the build queues by allowing usage of systemd-mini
- Added latest upstream changes, including:
- iscsiuio: Stop using /var directory for PIDfile and locks
- iscsiuio: improve daemon synchronization (bsc#1135070)
- fix pipe notification code
- add systemd support for iscsiuio
- make iscsid systemd usage optional
- fix possible discovery hang timeout
- fix iscsiuio systemd disablement
Updating:
* open-iscsi-SUSE-latest.diff.bz2

==== openslp ====
Subpackages: openslp-server

- Explicitely require library on develpackage and do not pull
in the base package with slptool binary
- Fixup summaries: SDK already includes "development",
and shared library is unspecific. Remove marketing wording
from descriptions.
- Use tcp connects to talk with other DAs [bnc#1117969]
new patch: openslp.tcpknownda.diff
- Fix segfault in predicate match if a registered service has
a malformed attribute list [bnc#1136136]
new patch: openslp.nullattr.diff
- Remove < SLE12 as it is no longer supported
- Remove obsolete conditions/etc.
* dropped file: slpd.init
- Cleanup with spec-cleaner
- Split out shared library properly
- Drop the omc config fate#301838:
* it is obsolete since SLE11

==== openssl-1_1 ====
Subpackages: libopenssl-1_1-devel libopenssl1_1 libopenssl1_1-32bit

- add 0001-Fix-for-BIO_get_mem_ptr-and-related-regressions.patch
(bnc#1136522)
- Fix a crash caused by long locale messages (bsc#1135550)
* add openssl-fix_underflow_in_errstr_handling.patch

==== parley ====
Version update (19.04.1 -> 19.04.2)
Subpackages: parley-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== perl-Image-ExifTool ====
Version update (11.30 -> 11.50)
Subpackages: exiftool perl-File-RandomAccess

- update to 11.50, see Image-ExifTool-11.50.tar.gz for details

==== pim-data-exporter ====
Version update (19.04.1 -> 19.04.2)
Subpackages: pim-data-exporter-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== pim-sieve-editor ====
Version update (19.04.1 -> 19.04.2)
Subpackages: pim-sieve-editor-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Fix enable/disable next button
* It's already initialized in header file

==== pimcommon ====
Version update (19.04.1 -> 19.04.2)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== postfix ====
Subpackages: postfix-doc

- Drop the omc config fate#301838:
* it is obsolete since SLE11

==== protobuf-c ====

- Add protobuf-c-namespace.patch to fix building with protobuf
3.8.0

==== python-PyYAML ====
Version update (5.1 -> 5.1.1)

- update to 5.1.1
* Re-release of 5.1 with regenerated Cython sources to build properly for
Python 3.8

==== python-gst ====
Version update (1.14.4 -> 1.14.5)

- Update to version 1.14.5:
+ No changes provided by upstream.

==== signon-kwallet-extension ====
Version update (19.04.1 -> 19.04.2)

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== spectacle ====
Version update (19.04.1 -> 19.04.2)
Subpackages: spectacle-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* Don't exit when running in gui mode and notification times out

==== step ====
Version update (19.04.1 -> 19.04.2)
Subpackages: step-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== sweeper ====
Version update (19.04.1 -> 19.04.2)
Subpackages: sweeper-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- Changes since 19.04.1:
* No code changes since 19.04.1

==== taglib ====
Version update (1.11.1+git20181028 -> 1.11.2~git20190601)
Subpackages: libtag1 libtag_c0

- Update to 1.11.2~git20190601, which fixes a regression when reading/
writing MP4 "rate" tags.
- Use proper package version, matching the header file version macros
- Upstream changes:
* Respect atom type when converting rate tag (#896)
* Support ID3v2 GRP1 frame introduced with iTunes 12.5.4.42, #903. (#904)
* Update mp4properties.cpp (#893)
* Minor fix for mp4 media header v0 minimum size check (#895)

==== tbb ====
Version update (2019_20190410 -> 2019_20190605)

- Add cmake-remove-include-path.patch to remove setting include
path since we already install under /usr/include and this fixes
idiot OpenCV trying to do -isystem $TBB_INCLUDE_DIR
- Update to version 2019_U8
* Fixed a bug in TBB 2019 Update 7 that could lead to incorrect memory
reallocation on Linux (https://github.com/intel/tbb/issues/148).
* Fixed enqueuing tbb::task into tbb::task_arena not to fail on threads
with no task scheduler initialized
(https://github.com/intel/tbb/issues/116).
- Update to version 2019_U7
* Added TBBMALLOC_SET_HUGE_SIZE_THRESHOLD parameter to set the
lower bound for allocations that are not released back to OS
unless a cleanup is explicitly requested.
* Added zip_iterator::base() method to get the tuple of underlying
iterators.
* Improved async_node to never block a thread that sends a message
through its gateway.
* Extended decrement port of the tbb::flow::limiter_node to accept
messages of integral types.
* Removed the number_of_decrement_predecessors parameter from the
constructor of flow::limiter_node. To allow its usage, set
TBB_DEPRECATED_LIMITER_NODE_CONSTRUCTOR macro to 1.
* Added ordered associative containers:
concurrent_{map,multimap,set,multiset} (requires C++11).

==== umbrello ====
Version update (19.04.1 -> 19.04.2)
Subpackages: umbrello-lang

- Update to 19.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.2.php
- No code changes since 19.04.1

==== vala ====
Version update (0.44.3 -> 0.44.4)
Subpackages: libvala-0_44-0

- Update to version 0.44.4:
+ Various improvements and bug fixes:
- vala: No-accessor struct properties in GLib.Object class must
be owned.
- codegen:
. Always use G_TYPE_CHECK_INSTANCE_TYPE for external symbols.
. Move GObject property validity checks to SemanticAnalyzer.
- parser: Multiple corrections for source-location of
code-nodes.
- build: Pass some useful G_LOG_DOMAIN definitions.
- girwriter:
. Mention that this file is generated and not meant to be
modified.
. Properly resolve GLib.TypeInterface instead of hardcoding
it.
. Multiple improvements and fixes for e.g. GType classes.
- girparser: Add support for string "ctype" metadata.
- When freeing local variables don't stop at "switch" on
"continue".
- compiler: Add OptionFlags.NO_ARG to deprecated "--thread"
option.
+ Bindings:
- glib-2.0: Don't annotate dedicated GLib.assert_*() functions
with [Assert].
- clutter-1.0: Bind Margin, PaintVolume, Point, Rect and Size
as struct.
- cogl-1.0: Fix out-params in
Cogl.get_modelview_matrix/projection_matrix/bitmasks.
- gstreamer: Cherry-pick some fixes from 0.46.
- gtk4: Update to 3.96.0+69016825.

==== zimg ====
Version update (2.8 -> 2.9)

- Update to version 2.9:
* colorspace: improve accuracy of SSE2 LUT-based transfer
functions
* depth: AVX2 and AVX-512 code paths for limited range upsampling
* graph: optimize tile width calculation
* graph: reduce execution overhead
* graph: skip processing pixels outside of active window
* resize: change default bicubic from Mitchell-Netravali to
Catmull-Rom
* resize: make output bit-exact regardless of active window
dimensions
* x86: optimizations for AMD Piledriver and Zen1 processors


N�����r��y隊Z)z{.���r�+�맲��r��z�^�ˬz��N�(�֜��^� ޭ隊Z)z{.���r�+��0�������Ǩ�
< Previous Next >
This Thread
  • No further messages